Référence de la ligne de commande

Vous pouvez utiliser la référence de la ligne de commande pour vous familiariser avec les nouveaux outils et les outils optimisés de ligne de commande, pour configurer votre invite de commandes, pour en savoir plus sur l'interpréteur de commande et pour automatiser les tâches de ligne de commande en utilisant des fichiers de commandes ou des outils de script tels que CScript et WMIC.

  • Pour plus d'informations sur les fonctionnalités qui ont été modifiées ou qui ne sont plus disponibles dans Windows XP, consultez la section Nouvelles méthodes pour effectuer des tâches courantes.
  • Pour obtenir la liste des nouveaux outils de ligne de commande, consultez la section Nouveaux outils de ligne de commande.
  • Pour obtenir la liste complète des outils de ligne de commande, consultez la section Références de A à Z de la ligne de commande.
  • Pour obtenir de l'aide sur des tâches, consultez la section Comment.
  • Pour obtenir des informations générales, consultez la section Concepts.


Nouvelles façons d'effectuer des tâches courantes

Windows XP conserve et améliore la plupart des fonctionnalités de MS-DOS. Les tableaux suivants expliquent :

  • Les modifications apportées à la fonctionnalité des commandes MS-DOS.
  • Les commandes MS-DOS qui ne sont plus disponibles dans Windows XP.
  • Les commandes MS-DOS qui ne sont plus disponibles dans Windows XP 64-Bit Edition.

Modifications apportées aux commandes MS-DOS

Le tableau suivant répertorie les modifications apportées aux commandes MS-DOS.

Commande | Fonctionnalités modifiées
chcp | Change les codes de page de toutes les fenêtres d'invite de commande.
diskcomp | Les options de ligne de commande /1 et /8 ne sont pas prises en charge.
diskperf | Cette commande n'est plus nécessaire pour agir sur un ordinateur serveur. Vous pouvez continuer à utiliser diskperf pour des tâches d'administration à distance.
diskcopy | L'option de ligne de commande /1 n'est pas prise en charge.
doskey | Disponible pour tous les programmes de caractères qui acceptent des entrées mises en mémoire tampon. Doskey bénéficie de plusieurs améliorations.
format | Prend en charge le lecteur de disquettes 1.44 Mo uniquement. Le lecteur magnétique-optique de 20.8 Mo n'est plus pris en charge. Les options de ligne de commande /b, /s, /u, /1, /4 et /8 ne sont plus prises en charge.
label | Les symboles ^ et & peuvent être utilisés dans les noms de volume.
mode | Les syntaxes mode lpt n[:][cols=c][lines=n] et mode lpt n[:][c][,[n]] ne sont pas prises en charge.
print | Les options de ligne de commande /b, /c, /m, /p, /q, /s, /t et /u ne sont pas prises en charge.
prompt | De nouvelles combinaisons de caractères vous permettent d'ajouter des signes ($a), des parenthèses ($c et $f) et des espaces ($s) à l'invite de commandes.
recover | Ne restaure que des fichiers.
rmdir | La nouvelle option de ligne de commande /s permet de supprimer des répertoires contenant des fichiers et des sous-répertoires.
tri | Ne requiert pas la variable d'environnement TEMP. Il n'y a pas de limite à la taille des fichiers.
xcopy | La nouvelle option de ligne de commande /g crée des fichiers de destination non cryptés.

Commandes MS-DOS non disponibles

Les commandes MS-DOS suivantes ne sont pas disponibles à l'invite de commandes.

Commande | Nouvelle procédure ou raison de l'abandon
assign | Non pris en charge actuellement.
backup | Non pris en charge actuellement.
choice | Non pris en charge actuellement.
ctty | Non pris en charge actuellement.
dblspace | Non pris en charge actuellement.
deltree | La commande rmdir /s supprime les répertoires qui contiennent des fichiers et des sous-répertoires. Pour plus d'informations sur la commande rmdir, consultez Rmdir.
dosshell | La fonction est désormais intégrée.
drvspace | Non pris en charge actuellement.
emm386 | La fonction est désormais intégrée.
fasthelp | Non pris en charge actuellement. Utilisez la commande help dans l'invite de commande. Pour plus d'informations sur la commande help, consultez Aide. Pour la liste complète des outils de ligne de commande, consultez Référence A-Z des instructions de ligne de commande.
fdisk | Non pris en charge actuellement. Utilisez la commande diskpart qui vous permet de gérer les disques, les partitions et les volumes. Pour plus d'informations sur la commande diskpart, consultez Diskpart.
include | XOX
interlnk | Non pris en charge actuellement.
intersrv | Non pris en charge actuellement.
join | L'augmentation de la taille des partitions et un système de fichiers amélioré rendent superflue la jointure de lecteurs.
memmaker | L'usage de la mémoire du sous-système MS-DOS est automatiquement optimisé.
menucolor | XOX
menudefault | XOX
menuitem | XOX
mirror | Non pris en charge actuellement.
msav | Non pris en charge actuellement.
msbackup | Utilisez la commande ntbackup pour les ordinateurs dotés de lecteurs de bande, ou la commande xcopy pour les ordinateurs sans lecteur de bande. Pour plus d'informations sur la commande ntbackup, consultez Ntbackup. Pour plus d'informations sur la commande xcopy, consultez Xcopy.
mscdex | Il n'est pas nécessaire de configurer le sous-système MS-DOS pour utiliser les lecteurs de CD-ROM. Windows XP permet au sous-système MS-DOS d'accéder aux lecteurs de CD-ROM.
msd | Utilisez le composant logiciel enfichable Informations système. Pour le démarrer, cliquez sur Démarrer, sur Exécuter, puis tapez msinfo32.
numlock | Non pris en charge actuellement.
power | Non pris en charge actuellement.
restore | Non pris en charge actuellement.
scandisk | Non pris en charge actuellement. Utilisez la commande chkdsk, qui vous permet de créer et d'afficher un rapport d'état pour un disque basé sur le système de fichiers. Chkdsk indique également toutes les erreurs détectées sur le disque et les corrige. Pour plus d'informations sur la commande chkdsk, consultez Chkdsk.
smartdrv | La mise en cache est automatique pour le sous-système MS-DOS.
submenu | XOX
sys | Une disquette 1,2 Mo ou 1,44 Mo standard ne peut pas contenir Windows XP.
undelete | Non pris en charge actuellement.
unformat | Non pris en charge actuellement.
vsafe | Non pris en charge actuellement.

Les commandes MS-DOS qui ne sont plus disponibles dans Windows XP 64-Bit Edition

Les commandes du sous-système MS-DOS 16 bits suivantes ne sont pas disponibles dans Windows XP 64-Bit Edition.

Commande | Fonction
append | Permet aux programmes d'ouvrir des fichiers de données se trouvant dans les dossiers spécifiés comme s'ils figuraient dans le dossier en cours.
debug | Démarre Debug.exe, un programme permettant de tester et de déboguer les fichiers exécutables MS-DOS.
edit | Lance l'Éditeur MS-DOS, qui crée et modifie les fichiers texte ASCII.
edlin | Démarre Edlin.exe, un éditeur de texte orienté ligne qui permet de créer et de modifier des fichiers ASCII.
exe2bin | Convertit les fichiers .exe (exécutables) au format binaire.
expand | Décompresse un ou plusieurs fichiers compressés.
fastopen | XOX
forcedos | Démarre le programme spécifié dans le sous-système MS-DOS. Cette commande est nécessaire uniquement pour les programmes MS-DOS qui ne sont pas reconnus en tant que programmes MS-DOS par Windows XP.
graphics | Charge en mémoire un programme permettant d'imprimer sur une imprimante le contenu affiché de l'écran lorsque vous utilisez une carte couleur ou graphique.
loadfix | S'assure que le programme est chargé au-dessus des premiers 64 Ko de mémoire conventionnelle et exécute le programme.
loadhigh (lh) | Charge un programme dans la zone de mémoire haute. Le chargement d'un programme dans la zone de mémoire haute permet de libérer de l'espace dans la mémoire conventionnelle pour d'autres programmes.
mem | Affiche des informations concernant les zones de mémoire allouées, les zones de mémoire libre et les programmes actuellement chargés en mémoire dans le sous-système MS-DOS.
nlsfunc | Charge les informations spécifiques à un pays ou une région. XOX
setver | Définit le numéro de version de MS-DOS que le sous-système MS-DOS renvoie à un programme.
share | XOX


Nouveaux outils de ligne de commande

Le tableau suivant répertorie les nouveaux outils de ligne de commande de Windows XP Professionnel.

Commande | Fonctionnalités
bootcfg | Configure, interroge ou modifie les paramètres du fichier boot.ini.
defrag | Localise et regroupe des dossiers, des fichiers de données et des fichiers d'amorçage fragmentés sur des volumes locaux.
diskpart | Gère des disques, des partitions ou des volumes.
driverquery | Recherche une liste de pilotes et de propriétés de pilotes.
eventcreate | Permet à un administrateur de créer un événement personnalisé dans un journal d'événements spécifié.
eventquery | Répertorie les événements et les propriétés d'événements dans un ou plusieurs journaux.
eventtriggers | Affiche et configure des déclencheurs d'événements sur des machines locales ou distantes.
fsutil | Gère les points d'analyse, les fichiers fragmentés, le démontage d'un volume ou l'extension d'un volume.
getmac | Obtient l'adresse de contrôle d'accès aux média (MAC) et la liste des protocoles réseau.
helpctr | Démarre le centre d'Aide et de support.
ipseccmd | Configure des stratégies IPSec (Internet Protocol Security) dans le service d'annuaire ou dans un registre local ou distant. Ipseccmd est une version de ligne de commande du composant logiciel enfichable Stratégie de sécurité IP de la console MMC.
logman | Gère et planifie les collections des journaux de suivi d'événements et de compteur de performances sur les systèmes locaux et distants.
openfiles | Interroge, affiche ou déconnecte les fichiers ouverts.
pagefileconfig | Affiche et configure les paramètres de mémoire virtuelle d'un fichier d'échange.
perfmon | Vous permet d'ouvrir une console de performances configurée avec des fichiers de paramètres de la version Windows NT 4.0 de l'analyseur de performances.
prncnfg | Configure ou affiche les informations de configuration d'une imprimante.
prndrvr | Ajoute, supprime et énumère les pilotes d'imprimante des serveurs d'impression locaux et distants.
prnjobs | Interrompt, reprend, annule et énumère les travaux d'impression.
prnmngr | Ajoute, supprime et énumère les connexions d'imprimantes, outre la définition et l'affichage de l'imprimante par défaut.
prnport | Crée, supprime et énumère les ports d'imprimante TCP/IP, outre l'affichage et la modification de la configuration des ports.
prnqctl | Imprime une page de test, interrompt ou reprend une imprimante, et annule une file d'attente d'impression.
relog | Extrait des compteurs de performances des journaux de compteurs de performances dans d'autres formats, tels que TSV (pour le texte délimité par des tabulations), CSV (pour le texte délimité par des virgules), BIN (pour le texte binaire) ou SQL.
sc | Extrait et définit des informations sur des services. Effectue un test et un débogage des programmes de services.
schtasks | Planifie l'exécution périodique des commandes et des programmes ou leur exécution à une heure donnée. Ajoute et supprime des tâches de la planification, démarre et arrête des tâches à la demande, et affiche et modifie des tâches planifiées.
shutdown | Arrête ou redémarre un ordinateur local ou distant.
systeminfo | Interroge le système à l'aide de requêtes sur les informations de configuration système de base.
taskkill | Termine un ou plusieurs processus ou tâches.
tasklist | Affiche la liste des applications des services et des ID de processus (PID) en cours d'exécution sur un ordinateur local ou distant.
tracerpt | Traite les journaux de suivi d'événements ou les données en temps réel des fournisseurs de suivi d'événements instrumentés et vous permet de générer des rapports d'analyse de suivi ainsi que des fichiers CSV (délimités par des virgules) pour les événements générés.
typeperf | Affiche les données du compteur de performances dans la fenêtre de commande ou dans un format de fichier journal pris en charge.
WMIC | Facilite l'utilisation de WMI (Windows Management Instrumentation) et des systèmes gérés par le biais de WMI.


Références de A à Z de la ligne de commande

Pour trouver des informations sur une commande, dans le menu comportant les boutons de A à Z au sommet de cette page, cliquez sur la lettre par laquelle commence la commande, puis cliquez sur le nom de la commande.

Outre les outils installés avec Windows XP, plus de 40 outils de support sont inclus sur le CD Windows XP. Vous pouvez utiliser ces outils pour diagnostiquer et résoudre les problèmes de votre ordinateur. Pour plus d'informations sur ces outils de support, consultez la section Outils de support Windows. Pour plus d'informations sur l'installation des outils de support, consultez la section Installer les outils de suport Windows.

Pour plus d'informations sur la modification des fonctionnalités des commandes MS-DOS, les nouveaux outils de ligne de commande, la fonctionnalité interpréteur de commande, la configuration de l'invite de commandes et l'automatisation des tâches de ligne de commande, consultez la section Références de la ligne de commande.

Des outils de ligne de commande nécessitent que l'utilisateur aie des privilèges d'administrateur sur les ordinateurs source et/ou cible.

Les outils de ligne de commande doivent être exécutés à l'invite de l'interpréteur de commande Cmd.exe. Pour ouvrir l'invite de commandes, cliquez sur Démarrer, sur Exécuter, tapez cmd, puis cliquez sur OK. Pour afficher l'aide à l'invite de commandes, tapez :

NomCommande /?

A

Arp

Assoc

At

Atmadm

Attrib

B

Fichiers de commandes

Bootcfg

Break

C

Cacls

Call

Change

Chcp

Chdir

Chkdsk

Chkntfs

Cipher

Cls

Cmd

Cmstp

Color

Vue d'ensemble de l'invite de commandes

Comp

Compact

Convert

Copy

Cprofile

Vue d'ensemble de CScript

D

Date

Defrag

Del

Dir

Diskcomp

Diskcopy

DiskPart

Doskey

Driverquery

E

Echo

Endlocal

Eventcreate

Eventquery

Eventtriggers

Evntcmd

Exit

Expand

F

Fc

Commandes filtre

Find

Findstr

Finger

Flattemp

For

Formater

Fsutil

Ftp

Sous-commandes Ftp

Ftype

G

Getmac

Goto

Gpresult

Gpupdate

Graftabl

H

Help

Helpctr

Hostname

I

If

Ipconfig

Ipseccmd

Ipxroute

Irftp

L

Label

Lodctr

Logman

Lpq

Lpr

M

Macfile

Mkdir (md)

Mmc

Mode

More

Mountvol

Move

Commandes de configuration système MS-DOS

Msiexec

Msinfo32

N

Nbtstat

Vue d'ensemble des services Net

Commandes des services Net

Vue d'ensemble des commandes Netsh

Commandes Netsh pour AAAA

Commandes Netsh pour DHCP

Commandes de diagnostic (diag) Netsh

Commandes Netsh pour l'interface IP

Commandes Netsh pour RAS

Commandes Netsh pour le routage

Commandes Netsh pour WINS

Netstat

Nslookup

Sous-commandes nslookup

Ntbackup

Ntcmdprompt

Ntsd

O

Openfiles

P

Pagefileconfig

Path

Pathping

Pause

Pbadmin

Pentnt

Perfmon

Ping

Popd

Print

Prncnfg

Prndrvr

Prnjobs

Prnmngr

Prnport

Prnqctl

Prompt

Pushd

Q

Query

R

Rasdial

Rcp

Recover

Opérateurs de redirection

Reg

Regsvr32

Relog

Rem

Rename

Replace

Reset session

Rexec

Rmdir

Route

Rsh

Rsm

Runas

S

Sc

Schtasks

Secedit

Set

Setlocal

Shift

Shutdown

Sort

Start

Subst

Systeminfo

Vérificateur des fichiers système (sfc)

T

Taskkill

Tasklist

Tcmsetup

Utilitaires et services TCP/IP

Commandes Telnet

Commandes des services Terminal Server

Tftp

Time

Title

Tracerpt

Tracert

Tree

Type

Typeperf

U

Unlodctr

V

Ver

Verify

Vol

Vssadmin

W

W32tm

Winnt

Winnt32

Vue d'ensemble de WMIC

X

Xcopy


Comment

Image Microsoft Windows

Comment...

  • Configurer l'invite de commandes


Configurer l'invite de commandes

Image Microsoft Windows

Pour configurer l'invite de commandes

  1. Ouvrez Invite de commandes.
  2. Cliquez sur l'angle supérieur gauche de la fenêtre Invite de commandes, puis cliquez sur Propriétés.
  3. Cliquez sur l'onglet Options.
  4. Dans Historique des commandes, tapez ou sélectionnez 999 dans Taille de la mémoire tampon, puis tapez ou sélectionnez 5 dans Nombre de zones de mémoire tampon.
  5. Dans Options d'édition, activez les cases à cocher Mode d'édition rapide et Mode insertion.
  6. Cliquez sur l'onglet Configuration.
  7. Dans Taille mémoire tampon écran, tapez ou sélectionnez 2500 dans Hauteur.
  8. Effectuez l'une des actions facultatives suivantes :
    • Dans Taille mémoire tampon écran, augmentez la valeur de Largeur.
    • Dans Taille de la fenêtre, augmentez la valeur de Hauteur.
    • Dans Taille de la fenêtre, augmentez la valeur de Largeur.
    • Désactivez la case à cocher Positionnée par le système puis, dans Position de la fenêtre, modifiez les valeurs Gauche et Haut.
  9. Dans la boîte de dialogue Appliquer les propriétés, cliquez sur Enregistrer les propriétés pour les fenêtres futures ayant le même titre.

Remarques

  • XOX
  • Pour ouvrir Propriétés de la console Windows à partir du clavier, appuyez sur ALT+ESPACE+P.
  • L'activation de la case à cocher Mode d'édition rapide permet d'effectuer des opérations copier-coller à partir de la fenêtre Invite de commandes. Pour copier du texte, sélectionnez-le dans la fenêtre Invite de commandes à l'aide du bouton gauche de la souris puis cliquez dessus avec le bouton droit. Pour le coller au niveau de l'invite de commandes ou dans un fichier texte, cliquez avec le bouton droit puis choisissez l'option Coller.
  • Le fait d'attribuer la valeur 999 à la taille de la mémoire tampon de l'écran permet de faire défiler la fenêtre Invite de commandes.
  • Le fait d'attribuer la valeur 5 au nombre de zones de mémoire tampon permet d'affecter 5000 lignes à la fenêtre Invite de commandes.
  • Pour activer ou désactiver la terminaison des noms de fichiers et de répertoires pour une ouverture de session d'ordinateur ou d'utilisateur, exécutez Regedit.exe puis attribuez à REG_DWORD la valeur suivante :

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    Pour définir la valeur REG_DWORD, utilisez la valeur hexadécimale d'un caractère de contrôle correspondant à une fonction particulière (par exemple, 0×9 correspond à TABULATION et 0×08 à RETOUR ARRIERE). Les paramètres spécifiques à l'utilisateur prévalent sur les paramètres de l'ordinateur et les options de ligne de commande prévalent sur les paramètres du Registre. Pour plus d'informations sur la terminaison des noms de fichiers et de répertoires, consultez Rubriques connexes.

    Attention

    • Une modification incorrecte du Registre peut endommager gravement votre système. Avant d'apporter des modifications au Registre, sauvegardez toutes les données importantes de votre ordinateur.

Rubriques connexes


Concepts

Cette section décrit les fonctionnalités de l'invite de commande :

  • Vue d'ensemble de l'invite de commande
  • Automatisation des tâches de ligne de commande


Vue d'ensemble de l'interpréteur de commandes

L'interpréteur de commandes est un programme logiciel qui fournit une communication directe entre l'utilisateur et le système d'exploitation. L'interface utilisateur non graphique de l'interpréteur de commandes propose un environnement dans lequel vous exécutez des applications et utilitaires basés sur les caractères. L'interpréteur de commandes exécute des programmes et affiche leur sortie à l'écran en utilisant des caractères individuels, comme l'interpréteur de commandes MS-DOS Command.com. L'interpréteur de commandes de Windows XP utilise l'interpréteur de commandes Cmd.exe, qui charge les applications et dirige le flux d'informations entre les applications, afin de convertir l'entrée de l'utilisateur sous une forme que le système d'exploitation peut interpréter.

Vous pouvez utiliser l'interpréteur de commandes pour créer et éditer des fichiers de commandes (également appelés scripts) afin d'automatiser les tâches routinières. Par exemple, vous pouvez utiliser les scripts pour automatiser la gestion des comptes utilisateur ou des sauvegardes quotidiennes. En outre, l'environnement d'exécution de scripts Windows CScript.exe vous permet d'exécuter des scripts plus complexes dans l'interpréteur de commandes. Les fichiers de commandes vous permettent d'effectuer des opérations plus efficacement que l'interface utilisateur. Les fichiers de commandes acceptent toutes les commandes qui sont disponibles au niveau de la ligne de commande. Pour plus d'informations sur les fichiers de commandes et les scripts, consultez la section Utilisation des fichiers de commandes.

Vous pouvez personnaliser la fenêtre de l'invite de commandes pour un obtenir un meilleur affichage et pour mieux contrôler l'exécution des programmes. Pour plus d'informations sur la personnalisation de la fenêtre de l'invite de commandes, consultez la section Pour configurer l'invite de commandes.

Utilisation de la syntaxe de la commande

La syntaxe apparaît dans l'ordre dans lequel vous devez taper une commande et tous les paramètres qui suivent. L'exemple suivant de la commande xcopy présente plusieurs formats de texte de la syntaxe :

xcopy Source [Destination] [/w] [/p] [/c] [/v] [/q] [/f] [/l] [/g] [/d[:mm-jj-aaaa]] [/u] [/i] [/s [/e]] [/t] [/k] [/r] [/h] [{/a|/m}] [/n] [/o] [/x] [/exclude:fichier1[+[fichier2]][+[fichier3]] [{/y|/-y}] [/z]

Le tableau suivant explique comment interpréter les différents formats de texte.

XOX

Utilisation de plusieurs commandes et symboles de traitement conditionnel

Vous pouvez exécuter plusieurs commandes à partir d'une seule ligne de commande ou d'un script utilisant des symboles de traitement conditionnel. Lorsque vous exécutez plusieurs commandes avec des symboles de traitement conditionnel, les commandes à droite du symbole de traitement conditionnel agissent en fonction des résultats de la commande à gauche du symbole de traitement conditionnel. Vous pouvez par exemple exécuter une commande uniquement si la commande précédente a échoué. Vous pouvez aussi exécuter une commande uniquement si la commande précédente a réussi.

Vous pouvez utiliser les caractères spéciaux figurant dans le tableau suivant pour transmettre plusieurs commandes.

Caractère | Syntaxe | Définition
& [...] | commande1 & commande2 | Permet de séparer plusieurs commandes sur la ligne de commande. Cmd.exe exécute la première commande, puis la seconde.
&& [...] | commande1 && commande2 | Permet d'exécuter la commande suivant && uniquement si la commande précédant le symbole est exécutée correctement. Cmd.exe exécute la première commande, puis la deuxième commande uniquement si la première a été exécutée correctement.
|| [...] | commande1 || commande2 | Permet d'exécuter la commande suivant || uniquement si la commande précédant || échoue. Cmd.exe exécute la première commande, puis la deuxième commande uniquement si la première a n'a pas été exécutée correctement (reçoit un code d'erreur supérieur à zéro).
( ) [...] | (commande1 & commande2) | Permet de grouper ou d'imbriquer plusieurs commandes.
; ou , | commande1 paramètre1;paramètre2 | Permet de séparer des paramètres de commande.

Remarques

  • Le signe &, la barre verticale (|) et les parenthèses ( ) sont des caractères spéciaux qui doivent être précédés du caractère d'échappement (^) ou de guillemets lorsque vous les transmettez en tant qu'arguments.
  • Si une commande exécute une opération avec succès, elle renvoie un code de sortie de zéro (0) ou aucun code de sortie. Pour plus d'informations sur les codes de sortie, consultez les Kits de ressources Microsoft Windows.

Imbrication d'interpréteurs de commandes

Vous pouvez imbriquer des interpréteurs de commandes au sein de Cmd.exe en ouvrant une nouvelle instance de Cmd.exe à l'invite de commandes. Par défaut, chaque instance de Cmd.exe hérite de l'environnement de son application Cmd.exe parente. En imbriquant des instances de Cmd.exe, vous pouvez apporter des modifications à l'environnement local sans affecter l'application parente de Cmd.exe. Cette opération vous permet de préserver l'environnement d'origine de Cmd.exe et d'y retourner lorsque vous quittez l'interpréteur de commandes imbriqué. Les modifications que vous apportez dans l'interpréteur de commandes imbriqué ne sont pas enregistrées.

Pour imbriquer un interpréteur de commandes, à l'invite de commandes, tapez :

cmd

Un message similaire au suivant apparaît :

Microsoft (R) Windows XP (TM)
(C) Copyright 1985-2001 Microsoft Corp.

Pour fermer l'interpréteur de commandes imbriqué, tapez exit.

Vous pouvez encore mieux localiser les changements dans une instance de Cmd.exe (ou dans un script) en utilisant les commandes setlocal et endlocal. La commande Setlocal crée une étendue locale et endlocal termine l'étendue locale. Toutes les modifications apportées dans l'étendue de setlocal et endlocal sont rejetées, ce qui permet de garder l'environnement initial inchangé. Vous pouvez imbriquer ces deux commandes dans 32 niveaux au maximum. Pour plus d'informations sur les commandes setlocal et endlocal, consultez Setlocal et Endlocal.

Utilisation des variables d'environnement avec Cmd.exe

L'environnement de l'interpréteur de commandes Cmd.exe est défini par des variables qui déterminent le comportement de l'interpréteur de commandes et le système d'exploitation. Vous pouvez définir le comportement de l'environnement de l'interpréteur de commandes ou l'environnement complet du système d'exploitation en utilisant deux types de variables d'environnement, système et locales. Les variables d'environnement système définissent le comportement de l'environnement global du système d'exploitation. Les variables d'environnement locales définissent le comportement de l'environnement de l'instance Cmd.exe en cours.

Les variables d'environnement système sont prédéfinies dans le système d'exploitation et sont disponibles pour tous les processus Windows XP. Seuls les utilisateurs qui disposent de privilèges d'administrateur peuvent modifier les variables système. Ces variables sont le plus souvent utilisées dans les scripts d'ouverture de session.

Les variables d'environnement locales sont disponibles uniquement lorsque l'utilisateur pour lequel elles ont été créées a ouvert une session sur l'ordinateur. Les variables locales définies dans la ruche HKEY_CURRENT_USER sont valides uniquement pour l'utilisateur en cours, mais elles définissent le comportement de l'environnement global du système d'exploitation.

La liste suivante décrit les différents types de variables, dans l'ordre de priorité décroissant :

  1. Variables système intégrées
  2. Variables système trouvées dans la ruche HKEY_LOCAL_MACHINE
  3. Variables locales trouvées dans la ruche HKEY_CURRENT_USER
  4. Tous les chemins et variables d'environnement définis dans le fichier Autoexec.bat
  5. Tous les chemins et les variables d'environnement définis dans un script d'ouverture de session (s'il existe)
  6. Variables utilisées interactivement dans un script ou un fichier de commandes

Dans l'interpréteur de commandes, chaque instance de Cmd.exe hérite de l'environnement de son application Cmd.exe parente. Par conséquent, vous pouvez modifier les variables dans le nouvel environnement Cmd.exe sans que cela n'affecte l'environnement de l'application parente.

Le tableau suivant répertorie les variables d'environnement locales et système de Windows XP.

Variable | Tapez | Description
%ALLUSERSPROFILE% | Locale | Renvoie l'emplacement du profil All Users (Tous les utilisateurs).
%APPDATA% | Locale | Renvoie l'emplacement auquel les application stockent les données par défaut.
%CD% | Locale | Renvoie la chaîne du répertoire en cours.
%CMDCMDLINE% | Locale | Renvoie la ligne de commande exacte qui est utilisée pour démarrer le programme Cmd.exe actuel.
%CMDEXTVERSION% | Système | Renvoie le numéro de version des extensions de l'interpréteur de commandes en cours.
%COMPUTERNAME% | Système | Renvoie le nom de l'ordinateur.
%COMSPEC% | Système | Renvoie le chemin exact de l'exécutable de l'interpréteur de commandes.
%DATE% | Système | Renvoie la date. Utilise le même format que la commande date /t. Générée par Cmd.exe. Pour plus d'informations sur la commande date, consultez Date.
%ERRORLEVEL% | Système | Renvoie le code d'erreur de la commande la plus récente utilisée. Une valeur qui n'est pas égale à zéro indique une erreur.
%HOMEDRIVE% | Système | Renvoie la lettre du lecteur de la station de travail locale qui est connectée au répertoire de base de l'utilisateur. Définie en fonction de la valeur du répertoire de base. Le répertoire de base de l'utilisateur est spécifié dans le composant Utilisateurs et groupes locaux.
%HOMEPATH% | Système | Renvoie le chemin d'accès complet du répertoire de base de l'utilisateur. Définie en fonction de la valeur du répertoire de base. Le répertoire de base de l'utilisateur est spécifié dans le composant Utilisateurs et groupes locaux.
%HOMESHARE% | Système | Renvoie le chemin réseau du répertoire de base partagé de l'utilisateur. Définie en fonction de la valeur du répertoire de base. Le répertoire de base de l'utilisateur est spécifié dans le composant Utilisateurs et groupes locaux.
%LOGONSEVER% | Locale | Renvoie le nom du contrôleur de domaine qui a validé la session d'ouverture de session en cours.
%NUMBER_OF_PROCESSORS% | Système | Spécifie le nombre de processeurs installés sur l'ordinateur.
%OS% | Système | Renvoie le nom du système d'exploitation. Windows 2000 affiche le système d'exploitation Windows_NT.
%PATH% | Système | Spécifie le chemin pour la recherche des fichiers exécutables.
%PATHEXT% | Système | Renvoie la liste des extensions de fichier que le système d'exploitation considère comme étant exécutables.
%PROCESSOR_ARCHITECTURE% | Système | Renvoie l'architecture du processeur. Les valeurs sont : x86, IA64.
%PROCESSOR_IDENTFIER% | Système | Renvoie la description du processeur.
%PROCESSOR_LEVEL% | Système | Renvoie le numéro du modèle de processeur installé sur l'ordinateur.
%PROCESSOR_REVISION% | Système | Renvoie le numéro de révision du processeur.
%PROMPT% | Locale | Renvoie les paramètres de l'invite de commandes de l'interpréteur en cours. Générée par Cmd.exe.
%RANDOM% | Système | Renvoie un nombre décimal compris entre 0 et 32767. Générée par Cmd.exe.
%SYSTEMDRIVE% | Système | Renvoie le lecteur contenant le répertoire racine de Windows XP (c'est-à-dire la racine système).
%SYSTEMROOT% | Système | Renvoie l'emplacement du répertoire racine de Windows XP.
%TEMP% et %TMP% | Système et utilisateur | Renvoie les répertoires par défaut temporaires utilisés par les applications disponibles pour les utilisateurs qui ont ouvert une session. Certaines applications requièrent TEMP et d'autres TMP.
%TIME% | Système | Renvoie l'heure. Utilise le même format que la commande time /t. Générée par Cmd.exe. Pour plus d'informations sur la commande time, consultez Time.
%USERDOMAIN% | Locale | Renvoie le nom du domaine qui contient le compte de l'utilisateur.
%USERNAME% | Locale | Renvoie le nom de l'utilisateur qui a ouvert une session.
%USERPROFILE% | Locale | Renvoie l'emplacement du profil de l'utilisateur en cours.
%WINDIR% | Système | Renvoie l'emplacement du répertoire du système d'exploitation.

Définition des variables d'environnement

Utilisez les commandes set pour créer, modifier, supprimer ou afficher des variables d'environnement. La commande set modifie les variables uniquement dans l'environnement de l'interpréteur de commandes en cours.

Pour visualiser une variable, à l'invite de commandes, tapez :

set NomVariable

Pour ajouter une variable, à l'invite de commandes, tapez :

set variablename=valeur

Pour supprimer une variable, à l'invite de commandes, tapez :

set NomVariable=

Vous pouvez utiliser la plupart des caractères en tant que valeurs de variables, y compris les espaces. Si vous utilisez les caractères spéciaux <, >, |, &, ou ^, vous devez les faire précéder d'un caractère d'échappement (^) ou de guillemets. Si vous utilisez les guillemets, ils sont intégrés dans la valeur car tous les éléments qui suivent le signe égal sont considérés comme la valeur. Considérons les exemples suivants :

  • Pour créer la valeur de la variable new&name, tapez :

    set varname=new^&name

  • Pour créer la valeur de la variable "new&name", tapez :

    set varname="new&name"

  • Si vous tapez set varname=new&name à l'invite de commandes, un message d'erreur semblable au suivant apparaît :
    "'name' n'est pas reconnu comme commande interne ou externe, programme ou fichier de commandes."

Les noms de variables ne respectent pas la casse. Cependant, la commande set affiche la variable telle que vous l'avez tapée. Vous pouvez associer des lettres en majusucles et des lettres en minuscules dans les noms de variables pour que le code soit plus lisible (par exemple NomUtilisateur).

Remarques

  • La taille maximale d'une variable d'environnement est 8 192 octets.
  • La taille maximale des variables d'environnement totales pour toutes les variables, qui inclut le nom des variables et le signe égal, est 65 536 Ko.

Remplacement des valeurs de variables d'environnement

Pour autoriser le remplacement des valeurs de variables dans la ligne de commandes ou dans des scripts, insérez le nom de la variable entre les signes de pourcentage (%nomvariable%). Lorsque vous utilisez les signes de pourcentage, vous vous assurez que Cmd.exe référence les valeurs de variables au lieu d'effectuer une comparaison littérale. Une fois que vous avez défini les valeurs de variables d'un nom de variable, insérez le nom de la variable entre les signes de pourcentage. Cmd.exe effectue une recherche sur toutes les instances du nom de la variable et le remplace par la valeur de variable définie. Par exemple, si vous créez un script qui contient différentes valeurs (par exemple, noms utilisateur) et si vous voulez définir la variable d'environnement USERNAME de chaque utilisateur avec ces valeurs, vous pouvez écrire un script en utilisant la variable USERNAME insérée entre les signes de pourcentage. Lorsque vous exécutez ce script, Cmd.exe remplace %USERNAME% par les valeurs de variables. Par conséquent, il n'est plus nécessaire d'effectuer cette tâche manuellement pour chaque utilisateur. Le remplacement de variables n'est pas récursif. Cmd.exe vérifie une seule fois les variables. Pour plus d'informations sur le remplacement de variables, consultez For et Call.


Utilisation des outils de script par commandes

Image Microsoft Windows

Automatisation des tâches de ligne de commande

Cette section fournit des informations sur les différents outils disponibles pour l'automatisation des tâches de ligne de commande.

  • Utilisation des fichiers de commandes
  • Utilisation de l'environnement d'exécution de script par commande (CScript.exe)
  • Utilisation des commandes Netsh
  • Utilisation de l'outil WMIC de Windows


Fichiers de commandes

Image Microsoft Windows

Utilisation de fichiers de commandes

Les fichiers de commandes, également appelés programmes de commandes ou scripts, permettent de simplifier les tâches de routine ou répétitives. Un fichier de commandes est un fichier texte sans mise en forme qui contient une ou plusieurs commandes et porte une extension .bat ou .cmd. Lorsque le nom du fichier est tapé à l'invite de commandes, Cmd.exe exécute les commandes du fichier séquentiellement.

Vous pouvez inclure n'importe quelle commande dans un fichier de commandes. Certaines commandes, telles que for, goto et if, vous permettent d'effectuer un traitement conditionnel des commandes contenues dans le fichier de commandes. Par exemple, la commande if permet l'exécution d'une commande selon les résultats d'une condition. D'autres commandes vous permettent de contrôler les entrées-sorties et d'appeler d'autres fichiers de commandes.

Les codes d'erreur standard renvoyés par la plupart des applications sont 0 en l'absence d'erreur et 1 (ou une valeur supérieure) en cas d'erreur. Veuillez consulter la documentation d'aide de votre application pour déterminer la signification des codes d'erreur spécifiques.

Pour plus d'informations sur les opérations des fichiers de commandes, consultez les rubriques suivantes :

  • Emploi des paramètres de commande
  • Utilisation de filtres
  • Utilisation d'opérateurs de redirection de commande

Pour plus d'informations sur les commandes utilisables dans les fichiers de commandes, cliquez sur une commande :

  • Call
  • Echo
  • Endlocal
  • Pour
  • Goto
  • Si
  • Pause
  • Rem
  • Setlocal
  • Shift


Utilisation des paramètres de commande

Vous pouvez utiliser les paramètres de commande où vous le souhaitez au sein d'un fichier de commandes pour extraire des informations sur vos paramètres d'environnement.

Cmd.exe fournit les variables d'extension des paramètres de commande %0 à %9. Lorsque vous utilisez des paramètres de commande dans un fichier de commandes, %0 est remplacé par un nom de fichier de commandes, et %1 à %9 sont remplacées par les arguments correspondants que vous tapez au niveau de la ligne de commande. Pour accéder aux arguments au-delà de %9, vous devez utiliser la commande shift. Pour plus d'informations sur la commande shift, consultez Shift. Le paramètre de commande %* est une référence générique à tous les arguments qui sont transmis au fichier de commandes (sauf %0).

Par exemple, pour copier le contenu de Dossier1 dans Dossier2, où %1 est remplacé par la valeur Dossier1 et %2 est remplacé par la valeur Dossier2, tapez la commande suivante dans un fichier de commandes appelé MonFichierCommandes.bat :

xcopy %1\*.* %2

Pour exécuter le fichier, tapez :

MonFichierCommandes.bat C:\dossier1 D:\dossier2

Cela équivaut à taper la commande suivante dans le fichier de commandes :

xcopy C:\dossier1 \*.* D:\dossier2

Vous pouvez également utiliser des modificateurs avec les paramètres de commande. Les modificateurs utilisent les informations de répertoire et de lecteur en cours pour étendre le paramètre de commande en nom de répertoire ou de fichier partiel ou complet. Pour utiliser un modificateur, tapez le caractère pourcentage (%) suivi d'un caractère tilde (~), puis tapez le modificateur approprié (c'est-à-dire modificateur %~).

Le tableau suivant répertorie les modificateurs que vous pouvez utiliser dans l'extension.

Modificateur | Description
%~1 | Étend %1 et supprime tous les guillemets ("").
%~f1 | Étend %1 en nom de chemin d'accès complet.
%~d1 | Étend %1 en lettre de lecteur.
%~p1 | Étend %1 en chemin d'accès.
%~n1 | Étend %1 en nom de fichier.
%~x1 | Étend %1 en extension de fichier.
%~s1 | Chemin étendu contenant des noms courts uniquement.
%~a1 | Étend %1 en attributs de fichier.
%~t1 | Étend %1 en date et heure de fichier.
%~z1 | Étend %1 en taille de fichier.
%~$PATH:1 | Parcourt les répertoires figurant dans la variable d'environnement PATH et étend %1 en nom de fichier complet du premier nom trouvé. Si le nom de la variable d'environnement n'est pas défini ou si le fichier ne peut pas être trouvé, ce modificateur est étendu à la chaîne vide.

Le tableau suivant répertorie les combinaisons de modificateurs et d'identificateurs que vous pouvez utiliser pour obtenir des résultats composés.

Modificateur | Description
%~dp1 | Étend %1 en lettre et chemin de lecteur.
%~nx1 | Étend %1 en nom et extension de fichier.
%~dp$PATH:1 | Parcourt les répertoires figurant dans la variable d'environnement PATH à la recherche de %1 et l'étend en chemin et lettre de lecteur du premier trouvé.
%~ftza1 | Étend %1 en ligne de sortie de type dir.

Remarque

  • Dans les exemples précédents, vous pouvez remplacer %1 et PATH par d'autres valeurs de paramètres de commande.

Le modificateur %* est un modificateur unique qui représente tous les arguments transmis dans un fichier de commandes. Vous ne pouvez pas utiliser ce modificateur avec le modificateur %~. La syntaxe de %~ doit se terminer par une valeur d'argument valide.

Vous ne pouvez pas manipuler les paramètres de commande de la même manière que les variables d'environnement. Vous ne pouvez pas rechercher et remplacer des valeurs ni examiner des sous-chaînes. Vous pouvez toutefois affecter le paramètre à une variable d'environnement puis manipuler la variable d'environnement.


Utilisation de filtres

Utilisé conjointement avec le caractère de redirection de commande (|), un filtre de commande est une commande à l'intérieur d'une commande qui lit l'entrée d'une commande, transforme l'entrée et écrit la sortie. Les commandes filtre vous permettent de trier, d'afficher et de sélectionner les données de sortie d'une commande.

Les commandes filtre assurent la division, la réorganisation ou l'extraction d'une partie des informations qui les traversent. Le tableau suivant répertorie les commandes filtre disponibles dans Windows XP.

Commande | Description
more | Affiche le contenu d'un fichier ou la sortie d'une commande dans une fenêtre d'invite de commande à la fois.
find | Recherche dans les fichiers et les sorties de commande les caractères que vous spécifiez.
sort | Trie par ordre alphabétique les fichiers et les sorties de commandes.

Pour envoyer des données d'entrée à une commande filtre à partir d'un fichier, utilisez le signe <. Si vous voulez que la commande filtre reçoive ses données d'entrée à partir d'une autre commande, utilisez le signe |.

Utilisation de la commande more

La commande more affiche le contenu d'un fichier ou la sortie d'une commande dans une fenêtre d'invite de commande à la fois. Par exemple, pour afficher le contenu d'un fichier appelé List.txt dans une fenêtre d'invite de commande à la fois, tapez :

more < list.txt

Une fenêtre d'invite de commande apparaît, suivie de l'invite -- More -- qui s'affiche au bas de la fenêtre. Pour faire apparaître la fenêtre d'invite de commande suivants, appuyez sur n'importe quelle touche du clavier, à l'exception de la touche PAUSE. Pour arrêter la commande sans examiner la suite des informations, appuyez sur CTRL+C.

Vous pouvez utiliser la commande more lorsque vous travaillez à l'aide d'une commande qui génère plusieurs fenêtres d'invite de commande de sortie. Supposons que vous vouliez examiner l'arborescence des répertoires de votre disque dur, par exemple. Si vous avez plus de répertoires que Windows ne peut en afficher dans la fenêtre d'invite de commande, vous pouvez utiliser la commande tree avec un signe | et une commande more, comme suit :

tree c:\ | more

La première fenêtre d'invite de commande de sortie de la commande tree apparaît, suivie de l'invite -- More --. La sortie s'interrompt jusqu'à ce que vous appuyiez sur une touche quelconque du clavier, à l'exception de PAUSE.

Utilisation de la commande find

La commande find recherche dans les fichiers la chaîne ou le texte que vous spécifiez. Cmd.exe affiche toutes les lignes qui correspondent à la chaîne ou au texte que vous spécifiez dans la fenêtre d'invite de commande. Vous pouvez utiliser la commande find en tant que commande filtre ou que commande Windows XP standard. Pour plus d'informations sur l'utilisation de find en tant que commande standard, consultez Gérer les utilisateurs et les ordinateurs.

Pour utiliser find en tant que commande filtre, vous devez inclure un signe < (inférieur à) et la chaîne ou le texte que vous recherchez. Par défaut, les recherches de find respectent la casse. La commande ci-dessous, par exemple, recherche toutes les occurrences de la chaîne “ Côte du Pacifique ” dans le fichier Commerce.txt :

find "Côte du Pacifique" < commerce.txt

La sortie ne comprend aucune occurrence de "côte du pacifique". Elle comprend uniquement les occurrences de l'expression "Côte du Pacifique" en majuscules uniquement.

Pour enregistrer la sortie de la commande find au lieu de l'afficher dans la fenêtre d'invite de commande, utilisez un signe supérieur à (>) et spécifiez le nom du fichier où vous voulez stocker la sortie. La commande suivante, par exemple, recherche les occurrences de la chaîne “Côte du Pacifique” dans le fichier Commerce.txt et les enregistre dans le fichier Nouvcommerce.txt :

find "Côte du Pacifique" < commerce.txt > nouvcommerce.txt

Utilisation de la commande sort

La commande sort trie par ordre alphabétique les lignes d'un fichier texte ou les données de sortie d'une commande. Par exemple, la commande suivante trie le contenu d'un fichier nommé List.txt et affiche les résultats dans la fenêtre d'invite de commande :

sort < list.txt

Dans cet exemple, la commande sort trie les lignes du fichier List.txt par ordre alphabétique et affiche le résultat de l'opération sans modifier le fichier. Pour enregistrer la sortie de la commande sort au lieu de l'afficher, tapez un signe supérieur à (>) et un nom de fichier. Par exemple, pour classer dans l'ordre alphabétique les lignes du fichier List.txt et enregistrer le résultat dans le fichier Listalph.txt, tapez la commande suivante :

sort < list.txt > listalph.txt

Pour trier la sortie d'une commande, tapez la commande, le signe |, puis tapez sort (c'est-à-dire, commande | sort). Par exemple, la commande suivante trie les lignes qui comprennent la chaîne "Jeanson" (c'est-à-dire, la sortie de la commande find) par ordre alphabétique :

find "Jeanson" listdiff.txt | sort


Utilisation d'opérateurs de redirection des commandes

Les opérateurs de redirection permettent de rediriger les données d'entrée et de sortie des commandes, à partir d'emplacements par défaut vers d'autres emplacements. L'emplacement des données d'entrée ou de sortie est appelé un descripteur.

Le tableau suivant contient la liste des opérateurs que vous pouvez utiliser pour rediriger les données d'entrée et de sortie des commandes.

Opérateur de redirection | Description
> | Permet d'enregistrer les données obtenues en résultat d'une commande dans un fichier ou de les diriger vers un périphérique, tel qu'une imprimante, au lieu de les afficher dans la fenêtre de l'invite de commandes.
< | Permet de récupérer l'entrée d'une commande à partir d'un fichier au lieu de la saisir sur le clavier.
>> | Permet d'ajouter les données qui résultent d'une commande à la fin d'un fichier sans supprimer les données qui s'y trouvent déjà.
>& | Permet de remplacer les données d'entrée d'un handle par les données de sortie d'un autre handle.
<& | Permet de lire les données d'entrée dans un handle et de les écrire en tant que données de sortie dans un autre handle.
| | Permet de lire les données obtenues en sortie d'une commande et de les écrire en tant que données d'entrée dans une autre commande. Ce symbole est appelé une barre verticale.

Par défaut, les données d'entrée d'une commande (handle STDIN) sont transmises via le clavier au programme Cmd.exe, lequel affiche le résultat de la commande (handle STDOUT) à la fenêtre d'invite de commandes.

Le tableau suivant indique les handles disponibles.

Handle | Équivalent numérique du handle | Description
STDIN | 0 | Entrée clavier
STDOUT | 1 | Sortie vers la fenêtre d'invite de commandes
STDERR | 2 | Sortie des erreurs sur la fenêtre d'invite de commandes
UNDEFINED | 3-9 | Ces handles sont définis individuellement par l'application et sont particuliers à chaque outil.

Les numéros de zéro à neuf désignent les 10 premiers handles. Vous pouvez utiliser l'exécutable Cmd.exe pour lancer un programme et rediriger l'un de ces 10 premiers handles définis pour ce programme. Pour spécifier le handle que vous voulez utiliser, tapez son numéro avant l'opérateur de redirection. Si vous ne définissez aucun handle, l'opérateur de redirection < par défaut en entrée est zéro (0) et l'opérateur de redirection > par défaut en sortie est un (1). Après avoir tapé l'opérateur < ou >, vous devez spécifier l'emplacement à partir duquel vous voulez lire ou écrire les données. Vous pouvez spécifier un nom de fichier ou un autre handle existant.

Pour demander la redirection vers des handles existants, utilisez le et commercial (&) suivi du numéro du handle vers lequel effectuer la redirection (par exemple, &handle#). Dans l'exemple suivant, la commande permet de rediriger le handle 2 (STDERR) vers le handle 1 (STDOUT) :

1<&2

Duplication des handles

L'opérateur de redirection & permet de dupliquer les sorties ou les entrées depuis un handle vers un autre. Par exemple, pour écrire le résultat de la commande dir dans le fichier Fichier.txt et écrire les erreurs dans le fichier Fichier.txt, tapez :

dir>c:\fichier.txt 2>&1

Lorsque vous dupliquez un handle, vous dupliquez toutes les caractéristiques du handle d'origine. Par exemple, si un handle est caractérisé par des accès en écriture seule, tous les handles dupliqués à partir de ce handle disposent également d'accès en écriture seule. Il est impossible de dupliquer un handle disposant d'accès en lecture seule dans un handle disposant d'accès en écriture seule.

Redirection des entrées de commandes (<)

Pour rediriger une entrée de commande à partir du clavier vers un fichier ou un périphérique, utilisez l'opérateur <. Par exemple, pour récupérer l'entrée de commande pour la commande sort à partir du fichier Fichier.txt, tapez :

sort<fichier.txt

Le contenu du fichier Fichier.txt s'affiche dans la fenêtre d'invite de commandes sous forme de liste classée par ordre alphabétique.

L'opérateur < permet d'ouvrir le fichier spécifié avec un accès en lecture seule. Par conséquent, si vous utilisez cet opérateur, vous ne pouvez pas modifier le fichier. Par exemple, si vous lancez un programme avec <&2, tous les essais de lecture du handle 0 échouent car le handle 2 a été à l'origine ouvert avec un accès en écriture seule.

Remarque

  • Le numéro zéro est le numéro du handle par défaut utilisé avec l'opérateur de redirection < en entrée.

Redirection des sorties de commandes (>)

Pratiquement toutes les commandes affichent en sortie des données sur la fenêtre d'invite de commandes. Même les commandes qui transférent ces données vers un lecteur de disque ou vers une imprimante affichent également des messages et des invites sur la fenêtre d'invite de commandes.

Pour rediriger les données obtenues en sortie d'une commande à partir de la fenêtre d'invite de commandes vers un fichier ou un périphérique, utilisez l'opérateur >. Vous pouvez utiliser cet opérateur avec la plupart des commandes. Par exemple, pour rediriger les résultats de la commande dir vers le fichier ListRép.txt, tapez :

dir>listrep.txt

Si le fichier ListRép.txt n'existe pas, le programme Cmd.exe le crée. Si ce fichier existe, le programme remplace les données que ce fichier contient déjà par les données résultant de la commande dir.

Pour lancer la commande netsh routing dump et envoyer le résultat dans le fichier Route.cfg, tapez :

netsh routing dump>c:\route.cfg

L'opérateur > permet d'ouvrir le fichier spécifié avec un accès en écriture seule. Par conséquent, si vous utilisez cet opérateur, vous ne pouvez pas lire le fichier. Par exemple, si vous lancez un programme avec les opérateurs de redirection >&0, tous les essais d'écriture dans le handle 1 échouent car le handle 0 a été à l'origine ouvert avec un accès en lecture seule.

Remarque

  • Le numéro un est le numéro du handle utilisé par défaut avec l'opérateur de redirection > des données en sortie.

Utilisation de l'opérateur <& pour rediriger les données en entrée et les dupliquer

Pour utiliser l'opérateur <& de redirection des données en entrée, le fichier que vous spécifiez doit déjà exister. Si le fichier d'entrées existe, le programme Cmd.exe l'ouvre en lecture seule et transmet les caractères qu'il contient à la commande qui les utilise en tant que données d'entrée tout comme s'ils été avaient saisis à partir du clavier. Si vous indiquez un handle, le programme Cmd.exe le duplique dans le handle existant dans le système.

Par exemple, pour ouvrir le fichier Fichier.txt en tant que source à partir de laquelle lire les entrées et les transmettre au handle 0 (STDIN), tapez :

<fichier.txt

Pour ouvrir le Fichier.txt, trier le contenu et afficher le résultat dans la fenêtre d'invite de commandes (STDOUT), tapez :

sort<fichier.txt

Pour rechercher le Fichier.txt, puis rediriger le handle 1 (STDOUT) et le handle 2 (STDERR) vers le fichier Recherche.txt, tapez :

findfile fichier.txt>recherche.txt 2<&1

Pour dupliquer le handle 3, défini par un utilisateur, en tant que source de lecture des entrées vers le handle 0 (STDIN), tapez :

<&3

Utilisation de l'opérateur >& pour rediriger les données en sortie et les dupliquer

Si vous redirigez les données en sortie vers un fichier et si vous spécifiez un fichier existant, le programme Cmd ouvre ce fichier en écriture seule et remplace le contenu existant. Si vous indiquez un handle, le programme Cmd.exe duplique le fichier dans le handle existant.

Pour dupliquer le handle 3 défini par l'utilisateur dans le handle 1, tapez :

>&3

Pour rediriger toutes les données en sortie, y compris le handle 2 (STDERR), à l'aide de la commande ipconfig vers le handle 1 (STDOUT), puis les rediriger vers le fichier Sortie.log, tapez :

ipconfig.exe>>sortie.log 2>&1

Utilisation de l'opérateur de redirection >> pour ajouter des données

Pour ajouter les données obtenues en sortie d'une commande à la fin d'un fichier sans perdre les données qui s'y trouvent déjà, utilisez un double signe supérieur à (>>). Dans l'exemple suivant, la liste de répertoires obtenue par la commande dir est ajoutée dans le fichier ListRép.txt :

dir>>listrep.txt

Pour ajouter les données obtenues par la commande netstat à la fin du fichier Tcpinfo.txt, tapez :

netstat>>tcpinfo.txt

Utilisation de la barre verticale (|)

L'opérateur (|) permet de récupérer les données obtenues en sortie (par défaut, STDOUT) d'une commande et de les rediriger en entrée (par défaut STDIN) d'une autre commande. La commande suivante permet par exemple, de trier le contenu d'un répertoire :

dir | sort

Dans cet exemple, les deux commandes sont tout d'abord exécutées simultanément, puis, la commande sort s'interrompt jusqu'à réception des données obtenues en sortie de la commande dir. La commande sort utilise en entrée les données obtenues par la commande dir et transmet ses résultats au handle 1 (STDOUT).

Combinaison de commandes et d'opérateurs de redirection

Vous pouvez créer des commandes personnalisées en combinant des commandes de filtre avec d'autres commandes et d'autres fichiers. Pour stocker les noms de fichiers qui contiennent la chaîne « LOG », utilisez par exemple, la commande suivante :

dir /b | find "LOG" > loglist.txt

Les résultats de la commande dir sont dirigés via la commande de filtre find. Les noms de fichier qui contiennent la chaîne « LOG » sont stockés sous forme de liste (par exemple, NetshConfig.log, Logdat.svd et Monlog.bat) dans le fichier ListLog.txt.

Pour utiliser plusieurs filtres dans la même commande, séparez les filtres par le signe |. La commande suivante, par exemple, permet d'effectuer une recherche dans chaque répertoire du lecteur C, de trouver les noms de fichier contenant la chaîne « LOG » et de les afficher à raison d'un écran à la fois.

dir c:\ /s /b | find "LOG" | more

En utilisant le signe |, Cmd.exe transmet les résultats de la commande dir via la commande de filtre find. La commande find permet de sélectionner uniquement les noms de fichier contenant la chaîne « LOG ». La commande more affiche ensuite, écran par écran, les noms des fichiers sélectionnés par la commande find. Pour plus d'informations sur les commandes de filtre, consultez Utilisation des filtres.


Utilisation de l'environnement d'exécution de script par commande (CScript.exe)

Cscript.exe est une version à ligne de commande de l'environnement d'exécution de scripts Windows qui fournit des options de ligne de commande pour la définition des propriétés de script.

Cscript.exe vous permet d'exécuter des scripts en tapant le nom d'un fichier de script à l'invite de commandes. Comme Microsoft Internet Explorer, l'environnement d'exécution de scripts Windows sert de contrôleur des moteurs de script compatibles avec Windows Script, mais il exige beaucoup moins de ressources mémoire. il est idéal pour rédiger, de manière interactive ou non, des scripts comme les scripts d'ouverture de session ou d'administration.

L'environnement d'exécution de scripts Windows est compatible avec les scripts VBScript ou JScript. Lorsque vous lancez un script à partir du Bureau ou de l'invite de commandes, l'environnement d'exécution lit le contenu du fichier de script spécifié et le transmet au moteur de script enregistré. Le moteur de script utilise des extensions de fichiers (.vbs pour VBScript, .js pour JScript) pour identifier les scripts. Par conséquent, vous n'avez pas besoin de connaître l'identificateur de programme exact (ProgID) du moteur de script. L'environnement d'exécution de scripts gère le mappage des extensions de scripts vers les identificateurs de programme, et utilise le modèle d'association Windows XP pour démarrer le moteur approprié à un script donné. Pour plus d'informations sur l'environnement d'exécution de scripts Windows, consultez Environnement d'exécution de scripts Windows. Pour plus d'informations sur CScript.exe, consultez Exécuter des scripts en utilisant un environnement de scripts basé sur la ligne de commande (cscript.exe).


Utilisation de Netsh

Netsh est un utilitaire d'exécution de scripts de ligne de commande qui permet, localement ou à distance, d'afficher ou de modifier la configuration réseau d'un ordinateur en fonctionnement. Netsh fournit également une fonction de script qui permet d'exécuter un ensemble de commandes en mode batch sur un ordinateur spécifique. L'utilitaire Netsh peut également enregistrer un script de configuration dans un fichier texte pour des besoins d'archivage ou pour la configuration d'autres serveurs.

Contextes de Netsh

Netsh interagit avec d'autres composants du système d'exploitation à l'aide de fichiers DLL. Chaque DLL d'application d'assistance de Netsh fournit un vaste ensemble de fonctionnalités portant le nom de contexte et regroupant des commandes spécifiques à un composant de mise en réseau. Ces contextes accroissent les fonctionnalités de netsh en permettant la prise en charge d'un ou plusieurs services, utilitaires ou protocoles en matière de configuration et de surveillance. Par exemple, Dhcpmon.dll fournit à netsh le contexte et l'ensemble des commandes nécessaires à la configuration et à la gestion des serveurs DHCP.

Pour exécuter une commande netsh, vous devez démarrer netsh à partir de l'invite de commandes Cmd.exe et aller dans le contexte qui contient la commande que vous voulez utiliser. Les contextes auxquels vous avez accès dépendent des composants de mise en réseau installés. Par exemple, si vous tapez dhcp à l'invite de commandes Netsh, vous accédez au contexte DHCP, tandis que le message suivant apparaît si DHCP n'est pas installé :

La commande suivante n'a pas été trouvée : dhcp.

Pour plus d'informations sur les contextes de Netsh, consultez les rubriques suivantes :

  • Commandes Netsh pour AAAA
  • Commandes Netsh pour DHCP
  • Commandes de diagnostic (diag) Netsh
  • Commandes Netsh pour l'interface IP
  • Commandes Netsh pour RAS
  • Commandes Netsh pour le routage
  • Commandes Netsh pour WINS

Utilisation de contextes multiples

Un contexte peut contenir un autre contexte. Par exemple, à l'intérieur du contexte Routage, vous pouvez passer du sous-contexte IP au sous-contexte IPX.

Pour afficher la liste des sous-contextes et des commandes susceptibles d'être utilisés dans un contexte, à l'invite de commandes netsh, tapez le nom du contexte, suivi de /? ou de help. Par exemple, pour afficher la liste des sous-contextes et des commandes susceptibles d'être utilisés dans le contexte Routage, à l'invite netsh (c'est-à-dire, netsh>), tapez l'une des commandes suivantes :

routing /?

routing help

Pour effectuer des tâches dans un autre contexte sans changer le contexte actuel, tapez le chemin d'accès du contexte de la commande que vous voulez utilisez à l'invite de commandes netsh. Par exemple, pour ajouter l'interface Connexion au réseau local dans le contexte IGMP sans passer au contexte IGMP, à l'invite de commandes netsh, tapez :

routing ip igmp add interface "Connexion au réseau local" startupqueryinterval=21

Exécution de commandes Netsh à partir de l'invite de commandes Cmd.exe

Lorsque vous exécutez Netsh à partir de l'invite de commandes Cmd.exe, netsh utilise la syntaxe suivante. Pour exécuter ces commandes Netsh sur un ordinateur distant fonctionnant sous Windows 2000 Server, vous devez tout d'abord utiliser Connexion au Bureau à distance pour vous connecter à un ordinateur fonctionnant sous Windows 2000 Server qui exécute Terminal Server. Des différences fonctionnelles peuvent apparaître entre les commandes du contexte Netsh sur Windows 2000 et Windows XP.

Pour afficher la syntaxe de la commande, cliquez sur la commande suivante :

netsh

Netsh est un utilitaire d'exécution de scripts de ligne de commande qui permet, localement ou à distance, d'afficher ou de modifier la configuration réseau d'un ordinateur en fonctionnement. Utilisée sans paramètres, la commande netsh ouvre l'invite de commandes Netsh.exe (à savoir netsh>).

Syntaxe

netsh [-a FichierAlias] [-c Contexte] [-r OrdinateurDistant] [{CommandeNetsh|-f FichierScript}]

Paramètres

-a
Revient à l'invite de commandes netsh après l'exécution de FichierAlias.
FichierAlias
Indique le nom du fichier texte contenant une ou plusieurs commandes netsh.
-c
Sélectionne le contexte netsh spécifié.
Contexte
Spécifie le contexte netsh. Le tableau suivant énumère les contextes netsh disponibles.
Contexte | Description
AAAA | Affiche et définit la configuration de la base de données d'authentification, d'autorisation, de gestion des comptes et d'audit (AAAA) utilisée par IAS (Internet Authentication Service) et le service de routage et d'accès à distance.
DHCP | Administre les serveurs DHCP et fournit une alternative équivalente à la gestion par console.
Diag | Administre et résout les problèmes liés aux paramètres de système d'exploitation et de service réseau.
Interface | Configure le protocole TCP/IP (notamment les adresses, les passerelles par défaut, les serveurs DNS et les serveurs WINS) et affiche des informations de configuration et des statistiques.
RAS | Administre les serveurs d'accès distant.
Routage | Administre les serveurs de routage.
WINS | Administre les serveurs WINS.
-r
Configure un ordinateur distant.
OrdinateurDistant
Spécifie l'ordinateur distant à configurer.
CommandeNetsh
Spécifie la commande netsh à exécuter.
-f
Quitte Netsh.exe après l'exécution du script.
FichierScript
Spécifie le script à exécuter.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisation de -r

    Si vous spécifiez -r suivi d'une autre commande, netsh exécute la commande sur l'ordinateur distant puis revient à l'invite de commandes Cmd.exe. Si vous spécifiez -r sans autre commande, netsh s'ouvre en mode distant. Ce processus est similaire à l'utilisation de set machine à l'invite de commandes Netsh. Lorsque vous utilisez -r, vous définissez l'ordinateur cible pour l'instance de netsh en cours uniquement. Si vous quittez et démarrez à nouveau netsh, l'ordinateur cible est réinitialisé à l'ordinateur local. Vous pouvez exécuter des commandes netsh sur un ordinateur distant en indiquant un nom d'ordinateur stocké dans WINS, un nom UNC, un nom Internet que le serveur DNS peut résoudre, ou une adresse IP numérique.

Exécution de commandes Netsh à partir de l'invite de commandes Netsh.exe

Netsh utilise les commandes standard suivantes dans tous les contextes exécutables à partir de l'invite de commandes Netsh.exe (c'est-à-dire, netsh>). Pour exécuter ces commandes Netsh sur un ordinateur distant fonctionnant sous Windows 2000 Server, vous devez tout d'abord utiliser Connexion au Bureau à distance pour vous connecter à un ordinateur fonctionnant sous Windows 2000 Server qui exécute Terminal Server. Des différences fonctionnelles peuvent apparaître entre les commandes du contexte Netsh sur Windows 2000 et Windows XP.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

..

Se déplace vers le contexte situé à un niveau au-dessus.

Syntaxe

..

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

abort

Ignore les modifications apportées en mode hors connexion. Abort n'a aucun effet en mode Connecté.

Syntaxe

abort

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

add helper

Installe la DLL de l'application d'assistance dans netsh.

Syntaxe

add helper NomDLL

Paramètres

NomDLL
Requis. Indique le nom de la DLL de l'application d'assistance que vous voulez installer.
/?
Affiche de l'aide à l'invite de commandes.

alias

Ajoute un alias sous la forme d'une chaîne de caractères définie par l'utilisateur, que netsh traite comme une autre chaîne de caractères. Utilisée sans paramètres, la commande alias affiche tous les alias disponibles.

Syntaxe

alias [NomAlias] [chaîne1 [chaîne2 ...]]

Paramètres

alias [NomAlias]
Affiche l'alias spécifié.
alias [NomAlias][chaîne1[chaîne2 ...]]
Définit NomAlias à la (aux) chaîne(s) spécifiée(s).
/?
Affiche de l'aide à l'invite de commandes.

Exemples

L'exemple de script netsh suivant définit deux alias netsh, Shaddr et Shp, puis quitte l'invite de commandes Netsh dans le contexte Interface IP :

alias shaddr show interface ip addr
alias shp show helpers
interface ip

Si vous tapez shaddr à l'invite de commandes Netsh, Netsh.exe interprète cette commande comme la commande show interface ip addr. Si vous tapez shp à l'invite de commandes Netsh, Netsh.exe interprète cette commande comme la commande show helpers.

bye

Quitte Netsh.exe.

Syntaxe

bye

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

commit

Applique toutes les modifications apportées au routeur en mode hors connexion. Commit n'a aucun effet en mode Connecté.

Syntaxe

commit

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

delete helper

Supprime la DLL de l'application d'assistance de netsh.

Syntaxe

delete helper NomDLL

Paramètres

NomDLL
Requis. Indique le nom de la DLL de l'application d'assistance que vous voulez désinstaller.
/?
Affiche de l'aide à l'invite de commandes.

dump

Crée un script contenant la configuration actuelle. Si vous enregistrez ce script dans un fichier, vous pouvez utiliser celui-ci pour rétablir les paramètres de configuration qui ont été modifiés. Utilisée sans paramètres, la commande dump affiche toutes les configurations du contexte netsh.

Syntaxe

dump [NomFichier]

Paramètres

[NomFichier]
Indique le nom du fichier vers lequel vous souhaitez rediriger la sortie.
/?
Affiche de l'aide à l'invite de commandes.

exec

Charge un fichier de script et exécute des commandes à partir de ce fichier.

Syntaxe

exec FichierScript

Paramètres

FichierScript
Requis. Indique le nom du script que vous voulez charger et exécuter.

Remarques

  • Le FichierScript peut s'exécuter sur un ou plusieurs ordinateurs.

exit

Quitte Netsh.exe.

Syntaxe

exit

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

help

Affiche de l'aide.

Syntaxe

{/?|?|help|h}

Paramètres

aucun

offline

Active le mode hors connexion.

Syntaxe

offline

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Les modifications effectuées dans ce mode sont enregistrées, mais vous devez exécuter la commande commit ou online pour implémenter ces modifications dans le routeur.
  • Lorsque vous passez du mode hors connexion au mode Connecté, les modifications effectuées en mode hors connexion sont prises en compte dans la configuration en cours d'exécution.
  • Les modifications apportées en mode Connecté sont immédiatement prises en compte dans la configuration en cours d'exécution.

online

Active le mode Connecté.

Syntaxe

online

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Les modifications apportées en mode Connecté sont immédiatement prises en compte dans la configuration en cours d'exécution.
  • Lorsque vous passez du mode hors connexion au mode Connecté, les modifications effectuées en mode hors connexion sont prises en compte dans la configuration en cours d'exécution.

popd

Restaure un contexte de la pile.

Syntaxe

popd

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisée en conjonction avec pushd, la commande popd permet de changer de contexte, d'exécuter la commande dans le nouveau contexte puis de revenir au contexte précédent.

Exemples

L'exemple de script suivant passe du contexte racine au contexte interface ip, ajoute une route IP statique puis revient au contexte racine :

netsh>pushd
netsh>interface ip
netsh interface ip>set address local static 10.0.0.9 255.0.0.0 10.0.0.1 1
netsh interface ip>popd netsh>

pushd

Enregistre le contexte actuel dans une pile FILO (first-in-last-out).

Syntaxe

pushd

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisée en conjonction avec popd, la commande pushd permet de changer de contexte, d'exécuter la commande dans le nouveau contexte puis de revenir au contexte précédent.

quit

Quitte Netsh.exe.

Syntaxe

quit

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

set file

Dirige la sortie de la fenêtre DOS vers un fichier.

Syntaxe

set file {open NomFichier|append NomFichier|close}

Paramètres

open NomFichier
Dirige la sortie de la fenêtre DOS vers le fichier spécifié.
append NomFichier
Ajoute la sortie de la fenêtre DOS au fichier existant spécifié.
close
Arrête l'envoi du contenu et ferme le fichier.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisation de NomFichier

    Si le NomFichier spécifié n'existe pas, netsh crée un nouveau fichier portant ce nom. Si le NomFichier spécifié existe déjà, netsh remplace les données existantes.

Exemples

Pour créer un nouveau fichier journal appelé Session.log et y copier toutes les entrées et sorties ultérieures de netsh, tapez :

set file open c:\session.log

set machine

Définit l'ordinateur actuel où effectuer les tâches de configuration. Utilisée sans paramètres, la commande set machine définit l'ordinateur local.

Syntaxe

set machine [[NomOrdinateur=]chaîne]

Paramètres

NomOrdinateur
Spécifie le nom de l'ordinateur où effectuer les tâches de configuration.
chaîne
Indique l'emplacement de l'ordinateur distant.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Réalisation de tâches de configuration sur plusieurs ordinateurs

    Il est possible d'exécuter des commandes sur plusieurs ordinateurs à partir d'un seul script. Vous pouvez utiliser la commande set machine dans un script pour spécifier un ordinateur de destination (par exemple, OrdinateurA), puis exécuter les commandes qui suivent set machine sur cet ordinateur (c'est-à-dire OrdinateurA). Vous pouvez ensuite utiliser set machine pour spécifier un autre ordinateur de destination (par exemple, OrdinateurB), puis exécuter des commandes sur cet ordinateur (c'est-à-dire OrdinateurB).

set mode

Sélectionne le mode Connecté ou hors connexion comme mode en cours.

Syntaxe

set mode {online|offline}

Paramètres

online
Active le mode Connecté.
offline
Active le mode hors connexion.
/?
Affiche de l'aide à l'invite de commandes.

show

Affiche des informations sur les alias, les applications d'assistance et les modes.

Syntaxe

show {alias|helper|mode}

Paramètres

alias
Affiche la liste de tous les alias définis.
helper
Affiche la liste de toutes les applications d'assistance de niveau supérieur.
mode
Affiche le mode en cours.
/?
Affiche de l'aide à l'invite de commandes.

unalias

Supprime l'alias spécifié.

Syntaxe

unalias NomAlias

Paramètres

NomAlias
Requis. Spécifie le nom de l'alias.
/?
Affiche de l'aide à l'invite de commandes.
XOX


Utilisation de l'utilitaire de ligne de commandes WMIC de Windows

L'utilitaire WMIC (Windows Management Instrumentation Command-line) est une interface de ligne de commandes et de script qui simplifie l'utilisation de l'outil WMI (Windows Management Instrumentation, Infrastructure de gestion Windows) et des systèmes gérés via WMI.

L'utilisation de l'utilitaire WMIC est basée sur des alias. Grâce à l'utilisation d'alias, les données principales fournies par WMI peuvent être utilisées sans qu'il soit nécessaire de comprendre les concepts spécifiques à WMI. Les données WMI ainsi que de nombreuses fonctionnalités WMI sont également accessibles via WMI sans passer par les alias.

La liste des alias disponibles peut être obtenue en utilisant l'aide WMIC /? . Le système d'aide de WMIC est un système progressif. Vous pouvez utiliser l'option /? à n'importe quel moment et à n'importe quel niveau pour prendre connaissance des options disponibles dans le contexte actuel. L'option /? permet d'afficher la liste des alias actuellement disponibles ainsi que des commutateurs globaux, c'est-à-dire des commutateurs qui s'appliquent à WMIC en général. Pour obtenir la liste des verbes et des commutateurs disponibles pour un alias, tapez le nom de l'alias suivi de ?. Pour obtenir la liste des paramètres disponibles pour un verbe en particulier, tapez le nom de l'alias, le verbe, puis ?.

Par exemple, il est possible de connaître les processus en cours d'exécution sur le système courant à partir de l'alias PROCESS. Pour afficher la liste de tous les processus actuellement en cours d'exécution sur un ordinateur, tapez PROCESS dans l'utilitaire WMIC. Pour lister un processus spécifique, tapez une commande telle que PROCESS WHERE (Description="explorer.exe"). Pour obtenir les propriétés spécifiques d'un processus, tapez une commande telle que PROCESS GET Name, Handle, PageFaults.

Si vous n'utilisez pas d'alias, vous pouvez utiliser les mêmes options avec la commande CLASS. Par exemple, CLASS Win32_Process GET Name, Handle, PageFaults. Toutefois, vous devez déterminer le nom de la classe à partir d'autres sources. Pour effectuer une action équivalente à celle possible avec la clause alias Where, vous devez utiliser la commande PATH Win32_Process.Description="explorer.exe".

Pour plus d'informations sur l'utilisation et l'extension de l'utilitaire WMIC, consultez Ligne de commande WMI dans l'aide de Windows XP. Cette aide contient des informations sur l'utilisation de WMIC dans des fichiers de commandes, pour la création de rapports avec des ordinateurs distants et plusieurs ordinateurs, ainsi que pour la gestion du système.

Commande | Résultat
/? | Affiche l'aide.
CLASS | Permet de quitter le mode d'alias par défaut de WMIC pour accéder directement aux classes du schéma WMI
PATH | Permet de quitter le mode d'alias par défaut de WMIC pour accéder directement aux instances du schéma WMI
CONTEXT | Permet d'afficher les valeurs en cours de tous les commutateurs globaux.
QUIT | Permet de quitter WMIC.
EXIT | Permet de quitter WMIC.


Append

Permet aux programmes d'ouvrir des fichiers de données se trouvant dans les dossiers spécifiés comme s'ils figuraient dans le dossier en cours. Utilisée sans paramètres, la commande append affiche la liste des répertoires ajoutés.

Syntaxe

append [;] [[Lecteur:]Chemin[;...]] [/x:{on|off}][/path:{on|off}] [/e]

Paramètres

;
Annule la liste des dossiers ajoutés.
[Lecteur:]Chemin
Désigne le lecteur et le dossier à ajouter au dossier en cours. Si vous n'indiquez pas de lecteur, le lecteur en cours est le lecteur par défaut. Il est possible de spécifier plusieurs entrées [Lecteur:]Chemin en les séparant par des points-virgules.
/x:{on|off}
Indique si le sous-système MS-DOS doit effectuer des recherches dans les dossiers ajoutés lorsqu'il exécute des programmes. La syntaxe /x:on parcourt les dossiers ajoutés. La syntaxe /x:off ne parcourt pas les dossiers ajoutés.
/path:{on|off}
Indique si un programme doit chercher un fichier de données dans les dossiers ajoutés lorsqu'un chemin d'accès est déjà inclus avec le nom du fichier. Le paramètre par défaut est /path:on.
/e
Assigne la liste des dossiers ajoutés à une variable d'environnement nommée APPEND. Cette option de ligne de commande ne fonctionne que lors du premier emploi de la commande append après le démarrage du système.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • XOX
  • Stockage de la liste des dossiers ajoutés

    L'option de ligne de commande /e employé avec append permet d'assigner à une variable d'environnement nommée APPEND la liste des dossiers ajoutés. Pour ce faire, utilisez d'abord la commande append avec l'option de ligne de commande /e seulement. Réexécutez ensuite la commande append et incluez les dossiers à ajouter. Il est impossible de spécifier /e et [Lecteur:]Chemin sur la même ligne de commande.

  • Ajout de plusieurs dossiers

    Pour ajouter plusieurs dossiers, séparez chacune des entrées par des points-virgules. Si vous réexécutez la commande append avec les paramètres [Lecteur:]Chemin, le ou les dossiers spécifiés se substituent à tous ceux qui étaient désignés au moyen d'une commande append précédente.

  • Utilisation de dir

    Lorsque vous tapez dir pour afficher la liste des fichiers et des sous-répertoires d'un répertoire, le résultat de la commande dir ne comprend pas les noms des fichiers appartenant aux dossiers ajoutés.

  • Résolution des conflits de noms de fichiers

    Si un fichier appartenant à un dossier ajouté porte le même nom qu'un fichier du dossier en cours, les programmes ouvrent le fichier du dossier en cours.

  • Emploi d'append avec des programmes créant des fichiers

    Lorsqu'un programme ouvre un fichier stocké dans un dossier ajouté, ce fichier peut être trouvé comme s'il appartenait au dossier en cours. Si, lorsque ce programme enregistre le fichier, il en crée un autre sous le même nom, celui-ci est placé dans le dossier en cours et non pas dans le dossier ajouté. Vous pouvez utiliser la commande append pour les fichiers de données qui ne doivent pas être modifiés ou qui doivent l'être sans que de nouvelles copies ne soient créées. Les programmes de gestion de bases de données, par exemple, modifient souvent les fichiers de données sans créer de nouvelles copies. Les éditeurs de texte et les programmes de traitement de texte enregistrent généralement les fichiers de données modifiés en créant de nouvelles copies. Pour éviter toute confusion, il est préférable de ne pas utiliser append avec ces programmes.

  • Utilisation de /x:on avec path

    Lorsque vous utilisez /x:on , vous pouvez exécuter un programme situé dans un dossier ajouté en tapant le nom du programme à l'invite de commandes. Généralement, vous utilisez la commande path pour spécifier des dossiers qui contiennent des programmes ; toutefois, vous n'avez pas besoin de l'utiliser pour indiquer un dossier ajouté contenant des programmes. Le sous-système MS-DOS trouve un programme dans un dossier ajouté en suivant l'ordre normal de recherche d'un programme : d'abord dans le dossier en cours, puis dans les dossiers ajoutés et enfin dans le chemin de recherche.

  • Abréviation de /x:on en /x

    Vous pouvez abréger la syntaxe /x:on en /x. Pour ce faire, indiquez /x:on lors du premier emploi de la commande append après le démarrage du système. Ensuite, vous pouvez permuter les commutateurs /x:on et /x:off.

  • Utilisation de /e avec set

    Vous pouvez utiliser /e avec la commande set pour afficher la liste des dossiers ajoutés. Pour plus d'informations sur les variables d'environnement et set, consultez Rubriques connexes.

Exemples

Pour autoriser des programmes à ouvrir des fichiers de données dans B:\Lettres et A:\Rapports, comme si ces fichiers se trouvaient dans le dossier en cours, tapez la syntaxe suivante :

append b:\lettres;a:\rapports

Pour ajouter les mêmes dossiers et conserver une copie de la liste des dossiers ajoutés dans l'environnement Windows XP (à condition qu'il s'agisse de la première exécution de la commande append après le démarrage du système), tapez la syntaxe suivante :

append /e

append b:\lettres;a:\rapports


Arp

Affiche et modifie les entrées du cache ARP (Address Resolution Protocol), qui contient une ou plusieurs tables permettant de stocker les adresses IP et leurs adresses physiques Ethernet ou Token Ring résolues. À chaque carte réseau Ethernet ou Token Ring installée sur l'ordinateur correspond une table distincte. Utilisée sans paramètres, la commande arp affiche de l'aide.

Syntaxe

arp [-a [AdrInet] [-N AdrIface]] [-g [AdrInet] [-N AdrIface]] [-d AdrInet [AdrIface]] [-s AdrInet AdrEther [AdrIface]]

Paramètres

-a [AdrInet] [-N AdrIface]
Affiche les tables en cours du cache ARP de toutes les interfaces. Pour afficher l'entrée du cache ARP d'une adresse IP spécifique, utilisez la syntaxe arp -a en affectant au paramètre AdrInet une adresse IP. Pour afficher la table du cache ARP d'une interface spécifique, utilisez la syntaxe -N AdrIface en affectant au paramètre AdrIface l'adresse IP attribuée à l'interface. Le paramètre -N tient compte de la casse.
-g [AdrInet] [-N AdrIface]
Identique à -a.
-d AdrInet [AdrIface]
Supprime une entrée correspondant à une adresse IP spécifique, représentée par AdrInet. Pour supprimer une entrée dans une table correspondant à une interface spécifique, utilisez le paramètre AdrIface, en lui affectant l'adresse IP attribuée à l'interface. Pour supprimer toutes les entrées, utilisez le caractère générique astérisque (*) à la place de AdrIface.
-s AdrInet AdrEther [AdrIface]
Ajoute dans le cache ARP une entrée statique qui résout l'adresse IP AdrInet en l'adresse physique AdrEther. Pour ajouter une entrée statique du cache ARP dans la table d'une interface spécifique, utilisez le paramètre AdrIface en lui affectant une adresse IP attribuée à l'interface.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Les adresses IP de AdrInet et AdrIface sont exprimées en notation décimale à points.
  • L'adresse physique de AdrEther se compose de six octets exprimés en notation hexadécimale et séparés par des traits d'union (par exemple, 00-AA-00-4F-2A-9C).
  • Les entrées ajoutées à l'aide du paramètre -s sont statiques et n'ont pas de durée de vie limitée dans le cache ARP. Elles sont supprimées si le protocole TCP/IP est arrêté et démarré. Pour créer des entrées statiques définitives dans le cache ARP, placez les commandes arp appropriées dans un fichier de commandes et utilisez Tâches planifiées pour exécuter le fichier de commandes au démarrage.
  • Cette commande est disponible uniquement si le protocole Internet Protocol (TCP/IP) est installé comme composant dans les propriétés d'un adaptateur réseau dans Connexions réseau.

Exemples

Pour afficher les tables du cache ARP de toutes les interfaces, tapez :

arp -a

Pour afficher la table du cache ARP de l'interface dont l'adresse IP est 10.0.0.99, tapez :

arp -a -N 10.0.0.99

Pour ajouter dans le cache ARP une entrée statique qui résout l'adresse IP 10.0.0.80 en l'adresse physique 00-AA-00-4F-2A-9C, tapez :

arp -s 10.0.0.80 00-AA-00-4F-2A-9C


Assoc

Affiche ou modifie les associations d'extensions de nom de fichier. Utilisée sans paramètres, la commande assoc affiche la liste de toutes les associations d'extensions de nom de fichier en cours.

Syntaxe

assoc [.ext[=[type_fichier]]]

Paramètres

.ext
Spécifie l'extension de nom de fichier.
type_fichier
Spécifie le type de fichier auquel vous souhaitez associer l'extension de nom de fichier désignée.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisez un espace après le signe égal pour supprimer l'association de type de fichier établie pour une extension de nom de fichier.
  • Utilisez la commande ftype afin d'afficher les types de fichier pour lesquels des chaînes de commande d'ouverture sont actuellement définies.
  • Utilisez l'opérateur de redirection > pour aiguiller le résultat de la commande assoc vers un fichier texte.

Exemples

Pour afficher l'association de type de fichier actuellement définie pour l'extension de nom de fichier .txt, tapez :

assoc .txt

Pour supprimer l'association de type de fichier définie pour l'extension de nom de fichier .txt, tapez :

assoc .txt=

Pour afficher les associations de type de fichier en cours écran par écran, tapez :

assoc | more

Pour aiguiller le résultat de la commande assoc vers le fichier Assoc.cfg, tapez :

assoc>assoc.cfg


At

Programme l'exécution de commandes et de programmes sur un ordinateur aux date et heure spécifiées. Vous ne pouvez utiliser la commande at que lorsque le service Planning est en cours d'exécution. Utilisée sans paramètre, la commande at donne la liste des commandes programmées.

Syntaxe

at [\\NomOrdinateur] [{[ID] [/delete]|/delete [/yes]}]

at [[\\NomOrdinateur] heures:minutes [/interactive] [{/every:date[,...]|/next:date[,...]}] commande]

Paramètres

\\NomOrdinateur
Désigne un ordinateur distant. En l'absence de ce paramètre, at planifie les commandes et les programmes sur l'ordinateur local.
ID
Représente le numéro d'identification assigné à une commande programmée.
/delete
Annule une commande programmée. En l'absence de ID, toutes les commandes programmées sur l'ordinateur sont annulées.
/yes
Approuve toutes les requêtes venant du système lorsque vous supprimez les événements programmés.
heures:minutes
Indique l'heure à laquelle vous souhaitez exécuter la commande. L'heure est exprimée en heures:minutes au format 24 heures (de 00:00 [minuit] à 23:59).
/interactive
Permet à la commande d'interagir avec le Bureau de l'utilisateur qui conduit une session au moment où la commande est en cours d'exécution.
/every:
Exécute la commande toutes les fois que le ou les jours spécifiés de la semaine ou du mois reviennent (par exemple tous les jeudis ou le troisième jour de chaque mois).
date
Indique la date à laquelle vous souhaitez exécuter la commande. Vous pouvez spécifier un ou plusieurs jours de la semaine (en tapant M,T,W,Th,F,S,Su) ou bien un ou plusieurs jours du mois (en tapant un nombre compris entre 1 et 31). Séparez chaque entrée de date par une virgule. En l'absence du paramètre date, at utilise le jour en cours du mois.
/next:
Exécute la commande la prochaine fois que le jour indiqué se présente (le jeudi suivant, par exemple).
commande
Spécifie la commande, le programme (fichier .exe ou .com) ou le programme de commandes (fichier .bat ou .cmd) Windows que vous souhaitez exécuter. Si la commande a besoin d'un chemin d'accès comme argument, utilisez le chemin absolu (c'est-à-dire le nom de chemin complet commençant par la lettre du lecteur). Si la commande se trouve sur un ordinateur distant, spécifiez la notation UNC (Universal Naming Convention) du serveur et le nom de partage plutôt que la lettre d'un lecteur distant.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Schtasks est un outil plus puissant de planification de sur-ensemble sous forme de ligne de commandes, qui comprend toutes les fonctionnalités de l'utilitaire de ligne de commande at. Utilisez schtasks à la place de at pour toutes les tâches de programmation avec une ligne de commande. Pour plus d'informations sur schtasks, consultez Rubriques connexes.

  • Utilisation de at

    Pour utiliser la commande at, vous devez être membre du groupe local Administrateurs.

  • Chargement de Cmd.exe

    La commande at ne charge pas automatiquement l'interpréteur de commande Cmd.exe avant d'exécuter les commandes. Si vous n'exécutez pas un fichier exécutable (.exe), vous devez charger Cmd.exe de manière explicite au début de la commande, comme suit :

    cmd /c dir > c:\test.out

  • Affichage des commandes programmées

    Lorsque vous utilisez at sans options de ligne de commande, les tâches programmées s'affichent dans un tableau présentant le format suivant :

    État  ID   Jour       Heure        Ligne de commande
    OK      1    Each F    4:30 PM     net send group leads status due
    OK      2    Each M    12:00 AM    chkstor > check.file
    OK      3    Each F    11:59 PM    backup2.bat
  • Indication d'un numéro d'identification (ID)

    Lorsque vous indiquez un numéro d'identification (ID) avec at à une invite de commandes, les informations d'une seule entrée s'affichent, dans le format suivant :

    ID tâche:      1

État :       OK

Jour(s) :     Chaque v

Heure :  4:30 PM

Commande :      net send rapport aux chefs de projet

    Après avoir programmé une commande avec at, surtout si elle possède des options de ligne de commande, tapez at sans option de ligne de commande pour vérifier que la syntaxe de la commande est correcte. Si les informations de la colonne Ligne de commande sont incorrectes, supprimez la commande et retapez-la. Si elles sont toujours incorrectes, retapez la commande avec moins d'options de ligne de commande.

  • Affichage des résultats

    Les commandes programmées avec at s'exécutent en arrière-plan. Les données de sortie ne sont pas affichées sur l'écran de l'ordinateur. Pour les rediriger vers un fichier, utilisez le symbole de redirection (>). Si vous redirigez les données de sortie vers un fichier, vous devez faire précéder le symbole de redirection du symbole d'échappement (^), que vous utilisiez at sur la ligne de commande ou dans un fichier de commandes. Par exemple, pour rediriger les données de sortie vers Output.txt, tapez :

    at 14:45 c:\test.bat ^>c:\output.txt

    Le répertoire en cours pour la commande à exécuter est le dossier systemroot.

  • Changement de l'heure système

    Si vous changez l'heure système d'un ordinateur après avoir programmé l'exécution d'une commande avec at, tapez at sans option de ligne de commande pour resynchroniser le programmateur at avec la nouvelle heure système.

  • Stockage des commandes

    Les commandes programmées sont stockées dans le Registre. Par conséquent, vous ne perdez pas les tâches programmées si vous redémarrez le service Planning.

  • Connexion à un lecteur réseau

    N'utilisez pas de lecteur redirigé pour les tâches programmées accédant au réseau. Le service Planning risque de ne pas pouvoir accéder à ce lecteur ou celui-ci peut ne pas être présent si un autre utilisateur conduit une session pendant l'exécution de la tâche planifiée. Utilisez des chemins d'accès UNC pour les tâches programmées. Par exemple :

    at 13:00 ma_sauvegarde \\serveur\partage

    N'utilisez pas la syntaxe suivante, dans laquelle x: représente une connexion établie par l'utilisateur :

    at 13:00 ma_sauvegarde x:

    Si vous programmez une commande at utilisant une lettre de lecteur permettant la connexion à un répertoire partagé, incluez une commande at pour déconnecter le lecteur quand vous ne l'utilisez plus. Si le lecteur n'est pas déconnecté, la lettre de lecteur assignée n'est pas disponible à l'invite de commandes.

Exemples

Pour afficher la liste des commandes programmées sur le serveur Marketing, tapez :

at \\marketing

Pour en apprendre davantage sur une commande dotée du numéro d'identification 3 sur le serveur Soc, tapez :

at \\soc 3

Pour programmer l'exécution d'une commande net share à 08:00 sur le serveur Soc et rediriger la liste de sortie vers le serveur Maintenance, dans le répertoire partagé Rapports et le fichier Soc.txt, tapez :

at \\soc 20:00 cmd /c "net share rapports=d:\marketing\rapports >> \\maintenance\rapports\soc.txt"

Pour sauvegarder le contenu du disque dur du serveur Marketing sur un lecteur de bande tous les cinq jours à minuit, créez un programme de commandes appelé Archives.cmd qui contient les commandes de sauvegarde, puis programmez l'exécution du programme de commandes en tapant :

at \\marketing 00:00 /every:5,10,15,20,25,30 archives

Pour annuler toutes les commandes programmées sur le serveur en cours, effacez les informations de programmation de la commande at à l'aide de la syntaxe suivante :

at /delete

Pour exécuter une commande qui n'est pas un fichier exécutable (.exe), insérez cmd /c avant la commande afin de charger Cmd.exe :

cmd /c dir > c:\test.out XOX


Atmadm

Surveille les connexions et adresses enregistrées par le Gestionnaire d'appels ATM sur un réseau en mode de transfert asynchrone (ATM, Asynchronous Transfer Mode). Vous pouvez utiliser la commande atmadm pour afficher des statistiques sur les appels entrants et sortants de cartes ATM. Utilisée sans paramètres, la commande atmadm affiche des statistiques de surveillance de l'état des connexions ATM actives.

Syntaxe

atmadm [/c][/a] [/s]

Paramètres

/c
Affiche des informations d'appel pour toutes les connexions en cours à la carte réseau ATM installée sur cet ordinateur.
/a
Affiche l'adresse du point d'accès au service du réseau (NSAP, Network Service Access Point) ATM pour chaque carte installée sur cet ordinateur.
/s
Affiche des statistiques de surveillance de l'état des connexions ATM actives.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Pour afficher des informations d'appel

Pour afficher des informations d'appel pour toutes les connexions en cours à la carte réseau ATM installée sur cet ordinateur, tapez :

atmadm /c

Le résultat de la commande atmadm /c s'apparente au code suivant :

Statistiques du Gestionnaire d'appels ATM Windows

Connexions ATM sur l'interface : [009] Carte Olicom ATM PCI 155

   Connexion   VPI/VCI   Adresse distante/

                          Paramètres du média (fréquences en octets/s)

   In  PMP SVC    0/193   47000580FFE1000000F21A2E180020481A2E180B

                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516

                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516

   Out P-P SVC    0/192   47000580FFE1000000F21A2E180020481A2E180B

                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516

                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516

   In  PMP SVC    0/191   47000580FFE1000000F21A2E180020481A2E180B

                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516

                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516

   Out P-P SVC    0/190   47000580FFE1000000F21A2E180020481A2E180B

                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516

                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516

   In  P-P SVC    0/475   47000580FFE1000000F21A2E180000C110081501

                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188

                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9188

   Out PMP SVC    0/194   47000580FFE1000000F21A2E180000C110081501 (0)

                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9180

                          Rx:UBR,Peak 0,Avg 0,MaxSdu 0

   Out P-P SVC    0/474   4700918100000000613E5BFE010000C110081500

                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188

                          Rx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188

   In  PMP SVC    0/195   47000580FFE1000000F21A2E180000C110081500

                          Tx:UBR,Peak 0,Avg 0,MaxSdu 0

                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9180

Le tableau ci-après décrit chaque élément du résultat de l'exemple de commande atmadm /c.

Type de données | Affichage à l'écran | Description
Informations de connexion | Ent/Sor | Direction de l'appel. L'entrée (In) s'effectue vers la carte réseau ATM depuis un autre périphérique. La sortie (Out) s'effectue de la carte réseau ATM vers un autre périphérique.
PMP | Appel point à points multiples.
P-P | Appel point à point.
SVC | La connexion est établie sur un circuit virtuel commuté.
PVC | La connexion est établie sur un circuit virtuel permanent.
Informations VPI/VCI | VPI/VCI | Chemin virtuel et canal virtuel de l'appel entrant ou sortant.
Paramètres de l'adresse distante/média | 47000580FFE1000000F21A2E180000C110081500 | Adresse NSAP du périphérique ATM appelant (In) ou appelé (Out).
Tx Le paramètre Tx inclut les trois éléments suivants :
  • Type de fréquence en bits par défaut ou spécifiée (UBR, CBR, VBR ou ABR)
  • Vitesse de ligne par défaut ou spécifiée
  • Taille de l'unité de données de service (SDU, Service Data Unit) spécifiée
Rx Le paramètre Rx inclut les trois éléments suivants :
  • Type de fréquence en bits par défaut ou spécifiée (UBR, CBR, VBR ou ABR)
  • Vitesse de ligne par défaut ou spécifiée
  • Taille de la SDU spécifiée

Pour obtenir la liste de toutes les adresses enregistrées

Pour afficher l'adresse du point d'accès au service du réseau (NSAP, Network Service Access Point) ATM pour chaque carte installée sur cet ordinateur, tapez :

atmadm /a

Le résultat de la commande atmadm /a s'apparente au code suivant :

Statistiques du Gestionnaire d'appels ATM Windows

Adresses ATM de l'interface : [009] Olicom ATM PCI 155 Adapter

47000580FFE1000000F21A2E180000C110081500

Pour afficher des statistiques

Pour afficher des statistiques de surveillance de l'état des connexions ATM actives, tapez :

atmadm /s

Le résultat de la commande atmadm /s s'apparente au code suivant :

Statistiques du Gestionnaire d'appels ATM Windows

Statistiques du Gestionnaire d'appels ATM pour l'interface : [009] Olicom ATM PCI 155 Adapter

    Appels actifs en cours                        = 4

    Nombre total d'appels entrants réussis             = 1332

    Nombre total d'appels sortants réussis             = 1297

    Appels entrants ayant échoué                 = 1

    Appels sortants ayant échoué                 = 1

    Appels fermés à distance                      = 1302

    Appels fermés localement                        = 1323

    Paquets de signalisation et paquets ILMI envoyés            = 33655

    Paquets de signalisation et paquets ILMI reçus            = 34989

Le tableau ci-après décrit chaque élément du résultat de l'exemple de commande atmadm /s.

Statistique du Gestionnaire d'appels | Description
Appels actifs en cours | Appels actuellement actifs sur la carte ATM installée sur cet ordinateur.
Nombre total d'appels entrants réussis | Appels des autres périphériques reçus avec succès sur cette carte ATM.
Nombre total d'appels sortants réussis | Appels à d'autres périphériques ATM de ce réseau passés avec succès à partir de cet ordinateur.
Appels entrants ayant échoué | Appels entrants n'ayant pas réussi à se connecter à cet ordinateur.
Appels sortants ayant échoué | Appels sortants qui n'ont pas réussi à se connecter à un autre périphérique du réseau.
Appels fermés à distance | Appels fermés par un périphérique distant du réseau.
Appels fermés localement | Appels fermés par cet ordinateur.
Paquets de signalisation et paquets ILMI envoyés | Nombre de paquets de l'interface de gestion locale intégrée (ILMI, Integrated Local Management Interface) envoyés au commutateur auquel cet ordinateur tente de se connecter.
Paquets de signalisation et paquets ILMI reçus | Nombre de paquets ILMI reçus du commutateur ATM.


Attrib

Affiche, définit ou supprime les attributs lecture seule, archive, système et masqué assignés aux fichiers ou aux répertoires. Utilisée sans paramètre, la commande attrib affiche les attributs de tous les fichiers du répertoire en cours.

Syntaxe

attrib [{+r|-r}] [{+a|-a}] [{+s|-s}] [{+h|-h}] [[Lecteur:][Chemin] NomFichier] [/s[/d]]

Paramètres

+r
Définit l'attribut de fichier Lecture seule.
-r
Supprime l'attribut de fichier Lecture seule.
+a
Définit l'attribut de fichier archive.
-a
Supprime l'attribut de fichier archive.
+s
Définit l'attribut Fichier système.
-s
Supprime l'attribut Fichier système.
+h
Définit l'attribut Fichier caché.
-h
Supprime l'attribut Fichier caché.
[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du répertoire, du fichier ou du groupe de fichiers dont vous souhaitez afficher ou modifier les attributs. Pour afficher ou changer les attributs d'un groupe de fichiers, vous pouvez utiliser les caractères génériques (? et *) avec le paramètre NomFichier.
/s
Applique attrib et toutes les options de ligne de commande aux fichiers correspondants du répertoire en cours et des sous-répertoires.
/d
Applique attrib et toutes les options de ligne de commande aux répertoires.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Manipulation de groupes de fichiers

    Pour afficher ou changer les attributs d'un groupe de fichiers, vous pouvez utiliser les caractères génériques (? et *) avec le paramètre NomFichier. Pour pouvoir changer tout autre attribut d'un fichier doté de l'attribut système ou caché, vous devez d'abord supprimer ce dernier.

  • Utilisation de l'attribut archive

    L'attribut archive (+a) marque les fichiers modifiés depuis leur dernière sauvegarde. La commande xcopy utilise les attributs archive. Pour plus d'informations sur les attributs archive et sur xcopy, consultez Rubriques connexes.

  • La commande attrib est disponible dans la console de récupération avec d'autres paramètres.

Exemples

Pour afficher les attributs d'un fichier nommé Nouv86 situé sur le lecteur en cours, tapez :

attrib nouv86

Pour assigner l'attribut lecture seule au fichier Rapport.txt, tapez :

attrib +r rapport.txt

Pour supprimer l'attribut lecture seule des fichiers du répertoire \Public\Jeanson d'une disquette placée dans le lecteur B et de tous ses sous-répertoires, tapez :

attrib -r b:\public\jeanson\*.* /s

Supposez que vous vouliez remettre à l'un de vos collaborateurs une disquette contenant tous les fichiers du répertoire par défaut d'une disquette placée dans le lecteur A, sauf ceux dotés de l'extension .bak. Comme vous pouvez utiliser xcopy pour copier les fichiers marqués de l'attribut archives uniquement, il vous faut donc affecter cet attribut aux fichiers concernés. Tout d'abord, vous devez affecter l'attribut archives à tous les fichiers du lecteur A. Ensuite, vous devez supprimer l'attribut archives des fichiers portant l'extension .bak. Par exemple, tapez :

attrib +a a:*.* attrib -a a:*.bak

Utilisez ensuite la commande xcopy pour copier les fichiers de la disquette du lecteur A sur celle du lecteur B. L'option de ligne de commande /a de la commande suivante force xcopy à ne copier que les fichiers marqués de l'attribut archive : Par exemple, tapez :

xcopy a: b: /a

Pour que xcopy supprime l'attribut archive de chaque fichier après l'avoir copié, utilisez l'option de ligne de commande /m à la place de /a. Par exemple, tapez :

xcopy a: b: /m


Bootcfg

Configure, interroge ou modifie les paramètres du fichier boot.ini.

Cliquez sur une commande pour afficher la syntaxe correspondante :

bootcfg addsw

Ajoute des options de chargement de système d'exploitation pour l'entrée spécifiée du système d'exploitation.

Syntaxe

bootcfg /addsw [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/mm RAMMaximale] [/bv] [/so] [/ng] /id NumLigneEntréeSE

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/mm RAMMaximale
Ajoute l'option /maxmem à la valeur NumLigneEntréeSE spécifiée et définit la quantité maximale de RAM (mémoire vive) utilisable par le système d'exploitation.
/bv
Ajoute l'option /basevideo à la valeur NumLigneEntréeSE spécifiée et indique au système d'exploitation d'utiliser le mode VGA standard pour le pilote vidéo installé.
/so
Ajoute l'option /sos à la valeur NumLigneEntréeSE spécifiée et indique au système d'exploitation d'afficher les noms des pilotes de périphériques pendant leur chargement.
/ng
Ajoute l'option /noguiboot à la valeur NumLigneEntréeSE spécifiée et désactive la barre de progression Windows XP Professionnel qui s'affiche avant l'invite d'ouverture CTRL+ALT+SUPPR.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini auquel sont ajoutées les options de chargement du système d'exploitation. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /addsw :

bootcfg /addsw /mm 64 /id 2
bootcfg /addsw /so /id 3
bootcfg /addsw /so /ng /s srvmain /u hiropln /id 2
bootcfg /addsw /ng /id 2
bootcfg /addsw /mm 96 /ng /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

bootcfg copy

Crée une copie de l'instance du système d'exploitation, pour laquelle des options peuvent être ajoutées.

Syntaxe

bootcfg /copy [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/d Description] [/id NumLigneEntréeSE]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/d Description
Spécifie la description de la nouvelle entrée du système d'exploitation.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini à copier. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /copy :

bootcfg /copy /d "\ABC Server\" /id 1
bootcfg /copy /s srvmain /u maindom\hiropln /p p@ssW23 /d "Windows XP" /id 2
bootcfg /copy /u hiropln /p p@ssW23 /d "AB Ver 1.001" /id 2

bootcfg dbg1394

Configure le débogage de port 1394 pour l'entrée de système d'exploitation spécifiée.

Syntaxe

bootcfg /dbg1394 {ON|OFF|EDIT} [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/ch canal] /id NumLigneEntréeSE

Paramètres

ON|OFF|EDIT
Spécifie la valeur du débogage de port 1394.
Valeur | Description
ON | Active la prise en charge du débogage à distance en ajoutant l'option /dbg1394 à la valeur NumLigneEntréeSE spécifiée.
OFF | Désactive la prise en charge du débogage à distance en supprimant l'option /dbg1394 de la valeur NumLigneEntréeSE spécifiée.
EDIT | Permet de modifier les paramètres de port et de débit en bauds par le biais des valeurs de canal associées à l'option /dbg1394 de la valeur NumLigneEntréeSE spécifiée.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/ch canal
Spécifie le canal à utiliser pour le débogage. Les valeurs admises sont les entiers compris entre 1 et 64. N'utilisez pas le paramètre /ch canal si vous désactivez le débogage de port 1394.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini auquel sont ajoutées les options de débogage de port 1394. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /dbg1394 :

bootcfg /dbg1394 /id 2
bootcfg /dbg1394 on /ch 1 /id 3
bootcfg /dbg1394 edit /ch 8 /id 2
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /dbg1394 off /id 2

bootcfg debug

Ajoute ou modifie les paramètres de débogage de l'entrée spécifiée du système d'exploitation.

Syntaxe

bootcfg /debug {ON|OFF|EDIT} [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/port {COM1|COM2|COM3|COM4}] [/baud {9600|19200|38400|57600|115200}] [/id NumLigneEntréeSE]

Paramètres

ON|OFF|EDIT
Spécifie la valeur du débogage.
Valeur | Description
ON | Active la prise en charge du débogage à distance en ajoutant l'option /debug à la valeur NumLigneEntréeSE spécifiée.
OFF | Désactive la prise en charge du débogage à distance en supprimant l'option /debug de la valeur NumLigneEntréeSE spécifiée.
EDIT | Permet de modifier les paramètres de port et de débit en bauds par le biais des valeurs associées à l'option /debug de la valeur NumLigneEntréeSE spécifiée.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/port {COM1|COM2|COM3|COM4}
Spécifie le port COM à utiliser pour le débogage. N'utilisez pas le paramètre /port si vous désactivez le débogage.
/baud {9600|19200|38400|57600|115200}
Spécifie le débit en bauds à utiliser pour le débogage. N'utilisez pas le paramètre /baud si vous désactivez le débogage.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini auquel sont ajoutées les options de débogage. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Si le débogage de port 1394 est requis, utilisez la commande bootcfg /dbg1394.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /debug :

bootcfg /debug on /port com1 /id 2
bootcfg /debug edit /port com2 /baud 19200 /id 2
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /debug off /id 2

bootcfg default

Spécifie l'entrée du système d'exploitation désignée comme entrée par défaut.

Syntaxe

bootcfg /default [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/id NumLigneEntréeSE]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini à désigner comme valeur par défaut. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /default :

bootcfg /default /id 2
bootcfg /default /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

bootcfg delete

Supprime une entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini.

Syntaxe

bootcfg /delete [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/id NumLigneEntréeSE]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini à supprimer. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /delete :

bootcfg /delete /id 1
bootcfg /delete /s srvmain /u maindom\hiropln /p p@ssW23 /id 3

bootcfg ems

Permet à l'utilisateur d'ajouter ou de modifier les paramètres de redirection de la console EMS vers un ordinateur distant. L'activation d'EMS ajoute une ligne « redirect=Port# » dans la section [boot loader] du fichier Boot.ini et une option /redirect dans la ligne d'entrée spécifiée du système d'exploitation. La fonctionnalité EMS n'est activée que sur les serveurs.

Syntaxe

bootcfg /ems {ON|OFF|EDIT} [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/port {COM1|COM2|COM3|COM4|BIOSSET}] [/baud {9600|19200|38400|57600|115200}] [/id NumLigneEntréeSE]

Paramètres

ON|OFF|EDIT
Spécifie la valeur de la redirection EMS.
Valeur | Description
ON | Active la génération de données à distance pour la valeur NumLigneEntréeSE spécifiée. Ajoute une option /redirect à la valeur NumLigneEntréeSE spécifiée et un paramètre redirect=comX dans la section [boot loader]. La valeur de comX est définie par le paramètre /port.
OFF | Désactive la génération de données vers un ordinateur distant. Supprime l'option /redirect de la valeur NumLigneEntréeSE spécifiée et le paramètre redirect=comX de la section [boot loader].
EDIT | Permet de modifier les paramètres de port par le biais du paramètre redirect=comX de la section [boot loader]. Le paramètre comX prend la valeur du paramètre /port.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/port {COM1|COM2|COM3|COM4|BIOSSET}
Spécifie le port COM à utiliser pour la redirection. BIOSSET indique à EMS de déterminer à partir des paramètres BIOS le port à utiliser pour la redirection. N'utilisez pas le paramètre /port si vous désactivez la génération de donner à distance.
/baud {9600|19200|38400|57600|115200}
Spécifie le débit en bauds à utiliser pour la redirection. N'utilisez pas le paramètre /baud si vous désactivez la génération de donner à distance.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation auquel l'option EMS est ajoutée dans la section [operating systems] du fichier Boot.ini. La première ligne après l'en-tête de section [operating systems] est 1. Ce paramètre est requis si EMS a pour valeur ON ou OFF.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Pour plus d'informations sur EMS (Emergency Management Services), consultez l'aide et le Support technique.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /ems :

bootcfg /ems on /port com1 /baud 19200 /id 2
bootcfg /ems on /port biosset /id 3
bootcfg /s srvmain /ems off /id 2
bootcfg /ems edit /port com2 /baud 115200
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /ems off /id 2

bootcfg query

Interroge et affiche les entrées des sections [boot loader] et [operating systems] du fichier Boot.ini.

Syntaxe

bootcfg /query [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Le texte suivant est un exemple de code issu de la commande bootcfg /query :
    Paramètres du chargeur de démarrage

--------------------

timeout: 30

default: multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

Entrées de démarrage

------------

Boot entry ID:   1

Nom complet :   "Microsoft Windows XP Professionnel"

Chemin :            multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

Options de chargement du système d'exploitation : /fastdetect /debug /debugport=com1:
  • La partie Boot Loader Settings du résultat de la commande bootcfg query affiche chaque entrée de la section [boot loader] du fichier Boot.ini.
  • La partie Boot Entries du résultat de la commande bootcfg query affiche les informations suivantes pour chaque entrée du système d'exploitation de la section [operating systems] du fichier Boot.ini : Boot entry ID, Friendly Name, Path et OS Load Options.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /query :

bootcfg /query
bootcfg /query /s srvmain /u maindom\hiropln /p p@ssW23
bootcfg /query /u hiropln /p p@ssW23

bootcfg raw

Ajoute sous la forme d'une chaîne les options de chargement de système d'exploitation à une entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini.

Syntaxe

bootcfg [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] /raw ChaîneOptionsChargementSE [/id NumLigneEntréeSE]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
ChaîneOptionsChargementSE
Spécifie les options de chargement de système d'exploitation à ajouter à l'entrée du système d'exploitation. Ces options de chargement remplacent toutes les options de chargement associées à l'entrée du système d'exploitation. Le paramètre ChaîneOptionsChargementSE ne fait l'objet d'aucune validation.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini à mettre à jour. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Bootcfg raw permet d'ajouter du texte à la fin d'une entrée du système d'exploitation à la place des options existantes. Ce texte doit contenir des options de chargement du système d'exploitation valides, telles que /debug, /fastdetect, /nodebug, /baudrate, /crashdebug et /sos. Par exemple, la commande suivante ajoute « /debug /fastdetect » à la fin de la première entrée du système d'exploitation à la place de toutes les options précédentes :

    bootcfg /raw "/debug /fastdetect" /id 1

  • Pour plus d'informations sur les options facultatives de chargement du système d'exploitation et sur la façon dont Windows utilise le fichier Boot.ini au cours du démarrage, consultez l'article Q170756, « Available Switch Options for Windows NT Boot.ini File » dans la Base de connaissances Microsoft. (http://www.microsoft.com/)

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /raw :

bootcfg /raw "/debug /sos" /id 2
bootcfg /raw /s srvmain /u maindom\hiropln /p p@ssW23 "/crashdebug " /id 2

bootcfg rmsw

Supprime des options de chargement de système d'exploitation pour l'entrée spécifiée du système d'exploitation.

Syntaxe

bootcfg /rmsw [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]] [/mm] [/bv] [/so] [/ng] /id NumLigneEntréeSE

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/mm
Supprime de la valeur NumLigneEntréeSE spécifiée l'option /maxmem et la valeur de mémoire maximale associée. L'option /maxmem spécifie la quantité maximale de RAM (mémoire vive) utilisable par le système d'exploitation.
/bv
Supprime l'option /basevideo de la valeur NumLigneEntréeSE spécifiée. L'option /basevideo indique au système d'exploitation d'utiliser le mode VGA standard pour le pilote vidéo installé.
/so
Supprime l'option /sos de la valeur NumLigneEntréeSE spécifiée. L'option /sos indique au système d'exploitation d'afficher les noms des pilotes de périphériques pendant leur chargement.
/ng
Supprime l'option /noguiboot de la valeur NumLigneEntréeSE spécifiée. L'option /noguiboot désactive la barre de progression Windows XP Professionnel qui s'affiche avant l'invite d'ouverture CTRL+ALT+SUPPR.
/id NumLigneEntréeSE
Spécifie le numéro de ligne d'entrée du système d'exploitation dans la section [operating systems] du fichier Boot.ini auquel dont sont supprimées les options de chargement du système d'exploitation. La première ligne après l'en-tête de section [operating systems] est 1.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /rmsw :

bootcfg /rmsw /mm 64 /id 2
bootcfg /rmsw /so /id 3
bootcfg /rmsw /so /ng /s srvmain /u hiropln /id 2
bootcfg /rmsw /ng /id 2
bootcfg /rmsw /mm 96 /ng /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

bootcfg timeout

Modifie le délai de sélection du système d'exploitation.

Syntaxe

bootcfg /timeout Délai [/s Ordinateur [/u Domaine\Utilisateur /p Mot_de_passe]]

Paramètres

Délai
Spécifie le délai indiqué dans la section [boot loader]. Cette valeur représente le nombre de secondes dont dispose l'utilisateur pour sélectionner un système d'exploitation à partir de l'écran de chargement de démarrage avant que NTLDR ne charge le système d'exploitation par défaut. Si la valeur est 0, NTLDR démarre le système d'exploitation par défaut sans afficher l'écran de démarrage.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p Mot_de_passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/?
Affiche de l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent l'utilisation de la commande bootcfg /timeout :

bootcfg /timeout 30
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /timeout 50


Image Microsoft Windows

Break

XOX


Image Microsoft Windows

Buffers

XOX


Cacls

Affiche ou modifie les fichiers DACL (Discretionary Access Control List).

Syntaxe

cacls NomFichier [/t] [/e] [/c] [/g Utilisateur:autorisation] [/r Utilisateur [...]] [/p Utilisateur:autorisation [...]] [/d Utilisateur [...]]

Paramètres

NomFichier
Requis. Affiche les listes DACL des fichiers spécifiés.
/t
Modifie les listes DACL des fichiers spécifiés dans le répertoire en cours ainsi que tous ses sous-répertoires.
/e
Modifie une liste DACL au lieu de la remplacer.
/c
Continue de modifier les listes DACL, en ignorant les erreurs.
/g Utilisateur:autorisation
Accorde des droits d'accès à l'utilisateur spécifié. Le tableau suivant répertorie les valeurs admises pour autorisation.
Valeur | Description
n | Aucune
r | Lecture
w | Écriture
c | Changer (écrire)
f | Contrôle total
/r Utilisateur
Révoque les droits d'accès de l'utilisateur spécifié.
/p Utilisateur:autorisation
Remplace les droits d'accès de l'utilisateur spécifié. Le tableau suivant répertorie les valeurs admises pour autorisation.
Valeur | Description
n | Aucune
r | Lecture
w | Écriture
c | Changer (écrire)
f | Contrôle total
/d Utilisateur
Refuse l'accès à l'utilisateur spécifié.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant vous permet d'interpréter les résultats.
    Sortie | Portée de l'application de l'entrée de contrôle d'accès
    OI | Ce dossier et les fichiers
    CI | Ce dossier et les sous-dossiers
    IO | L'entrée de contrôle d'accès ne s'applique pas au fichier/répertoire en cours.
    Aucun message en sortie | Ce dossier uniquement
    (IO)(CI) | Ce dossier, les sous-dossiers et les fichiers
    (OI)(CI)(IO) | Les sous-dossiers et les fichiers seulement
    (CI)(IO) | Les sous-dossiers seulement
    (OI)(IO) | Les fichiers seulement
  • Pour désigner plusieurs fichiers, vous pouvez utiliser des caractères génériques (? et*).
  • Vous pouvez désigner plusieurs utilisateurs.


Call

Appelle un programme de commandes à partir d'un autre sans arrêter le programme de commandes parent. La commande call accepte des étiquettes comme cible de l'appel. Utilisée hors d'un script ou d'un fichier de commandes, la commande call est sans effet à partir de la ligne de commande.

Syntaxe

call [[Lecteur:][Chemin] NomFichier [ParamètresCommande]] [:étiquette [arguments]]

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du programme de commandes que vous souhaitez appeler. Le paramètre NomFichier doit avoir une extension .bat ou .cmd.
ParamètresCommande
Désigne toutes les informations de ligne de commande requises par le programme de commandes, notamment les options de ligne de commande, les noms de fichier, les paramètres de commande (%0 à %9) ou les variables (par exemple, %baud%).
:étiquette
Spécifie l'étiquette à laquelle le programme de commandes doit passer un contrôle. Lorsque vous utilisez la commande call avec ce paramètre, vous créez un nouveau contexte de fichier de commandes et passez le contrôle à l'instruction qui suit l'étiquette spécifiée. La première fois que la fin du fichier de commandes est atteinte (soit après le passage à l'étiquette), le contrôle est renvoyé à l'instruction qui suit l'instruction call. La deuxième fois que la fin du fichier de commandes est atteinte, l'exécution du script de commande prend fin. Pour plus d'informations sur l'extension goto :eof qui vous permet de revenir à partir d'un script de commande, consultez Rubriques connexes.
arguments
Désigne toutes les informations de ligne de commande que vous transmettez à la nouvelle instance du programme de commandes commençant à :étiquette, notamment les options de ligne de commande, les noms de fichier, les paramètres de commande (%1 à %9) ou les variables (par exemple, %baud%).
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Emploi des paramètres de commande

    Les paramètres de commande peuvent contenir toutes les informations que vous pouvez transmettre à un programme de commandes, notamment les options de ligne de commande, les noms de fichier, les paramètres de commande (%0 à %9) et les variables (par exemple, %baud%). Pour plus d'informations sur les paramètres de commande, consultez Rubriques connexes.

  • Emploi du signe “ | ” et de symboles de redirection

    N'utilisez ni le signe « | » ni les symboles de redirection avec la commande call.

  • Appel récursif

    Vous pouvez créer un programme de commandes qui s'appelle lui-même, à condition toutefois de fournir une condition de sortie. Sinon, les programmes de commandes parent et enfant peuvent exécuter indéfiniment une boucle.

  • Utilisation des extensions de commande

    Lorsque les extensions de commande sont activées (situation par défaut), la commande call accepte une étiquette en guise de cible de l'appel. La syntaxe correcte est la suivante :

    call :ArgumentsÉtiquette

    Pour plus d'informations sur l'activation et la désactivation des extensions de commande, consultez cmd dans Rubriques connexes.

Exemples

Pour exécuter le programme VeriNouv.bat à partir d'un autre programme de commandes, tapez la commande suivante dans le programme parent :

call verinouv

Si le programme de commandes parent accepte deux paramètres de commande et que vous souhaitez transférer ces paramètres à VeriNouv.bat, utilisez la commande suivante dans le programme de commandes parent :

call verinouv %1 %2


Chcp

Affiche le numéro de la page de codes active de la console ou change la page de codes active de la console. Utilisée sans paramètre, la commande chcp affiche le numéro de la page de codes active de la console.

Syntaxe

chcp [nnn]

Paramètres

nnn
Désigne la page de codes. Le tableau suivant répertorie les pages de codes gérées ainsi que le pays/région ou la langue correspondante :
Page de codes | Pays/région ou langue
437 | États-Unis
850 | Multilingue (Latin I)
852 | Slave (Latin II)
855 | Cyrillique (Russe)
857 | Turc
860 | Portugais
861 | Islandais
863 | Français (Canada)
865 | Scandinave
866 | Russe
869 | Grec moderne
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Seule la page de codes OEM (Original Equipment Manufacturer) installée avec Windows XP s'affiche correctement dans une fenêtre de l'invite de commandes utilisant les polices Raster. Les autres pages de codes s'affichent correctement en mode plein écran ou dans une fenêtre d'invite de commandes utilisant des polices TrueType.
  • Vous n'avez pas besoin de préparer les pages de codes comme dans MS-DOS.
  • Les programmes que vous démarrez après avoir affecté une nouvelle page de codes utilisent celle-ci ; par contre, les programmes (à l'exception de Cmd.exe) démarrés avant l'affectation utilisent la page de codes initiale.

Exemples

Pour afficher le numéro de la page de codes active, tapez :

chcp

Un affichage similaire à ce qui suit apparaît :

Page de codes active : 437

Pour utiliser plutôt la page 850 (Multilingue) comme page de codes active, tapez :

chcp 850

Si la page de codes spécifiée est incorrecte, le message d'erreur suivant s'affiche :

Page de codes non valide


Chdir

Image Microsoft Windows

Chdir (Cd)

Affiche le nom du répertoire en cours ou modifie le dossier en cours. Utilisée seulement avec une lettre de lecteur (notamment, chdir C:), chdir affiche les noms du lecteur et du dossier en cours. Utilisée sans paramètres, la commande chdir affiche le lecteur et le répertoire en cours.

Syntaxe

chdir [[/d] [Lecteur:][Chemin] [..]] [[/d] [Lecteur:][Chemin] [..]]

cd [[/d] [Lecteur:][Chemin] [..]] [[/d] [Lecteur:][Chemin] [..]]

Paramètres

/d
Change le lecteur en cours ou le répertoire en cours d'un lecteur.
[Lecteur:][Chemin]
Désigne le lecteur (si ce n'est pas le lecteur en cours) et le répertoire auxquels vous voulez passer.
[..]
Indique que vous voulez passer au dossier parent.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisation des extensions de commande

    Lorsque les extensions de commande sont activées (situation par défaut), le chemin du répertoire en cours correspond exactement, casse comprise, aux noms de dossiers tels qu'ils sont libellés sur le disque dur. Par exemple, si le dossier du disque dur est C:\Temp, la commande CD C:\TEMP définit le répertoire en cours comme étant C:\Temp, respectant ainsi la casse du dossier du disque dur.

    Pour désactiver les extensions de commande dans le cadre d'un processus particulier, tapez :

    cmd e:off

    Lorsque vous désactivez les extensions de commande, la commande chdir ne traite pas les espaces comme des délimiteurs. Par conséquent, vous pouvez indiquer un nom de sous-répertoire contenant un espace sans placer la variable [Chemin] entre guillemets. Par exemple, le chemin suivant permet de passer au sous-répertoire \Start menu :

    cd \winnt\profils\nomutilisateur\programmes\menu démarrer

    Pour plus d'informations sur l'activation et la désactivation des extensions de commande, consultez cmd dans Rubriques connexes.

  • Passage au répertoire racine

    Le répertoire racine est placé au sommet de la hiérarchie des répertoires d'un lecteur. Pour revenir au répertoire racine, tapez :

    cd\

  • Changement du répertoire par défaut sur un lecteur à partir d'un autre lecteur

    Pour changer le répertoire par défaut sur un lecteur autre que le lecteur en cours, tapez l'une des commandes suivantes :

    chdir [Lecteur:\[répertoire]]

    cd [Lecteur:\[répertoire]]

    Pour vérifier le changement de répertoire, tapez l'une des commandes suivantes :

    chdir [Lecteur:]

    cd [Lecteur:]

  • La commande chdir est disponible dans la console de récupération avec d'autres paramètres.

Exemples

Lorsque vous l'utilisez avec un nom de lecteur, la commande chdir affiche le répertoire en cours du lecteur. Par exemple, si vous tapez cd c: à l'invite du répertoire C:\Temp, le texte suivant s'affiche :

C:\Temp

Pour adopter comme répertoire en cours un répertoire nommé Rapports, tapez l'une des commandes suivantes :

chdir \rapports

cd \rapports

Pour adopter comme répertoire en cours un sous-répertoire nommé \Spécial\Sponsors, tapez :

cd \special\sponsors

Si \Spécial est votre répertoire en cours, tapez la commande suivante pour passer au sous-répertoire \Spécial\Sponsors :

cd sponsors

Pour passer d'un sous-répertoire à son répertoire parent, tapez :

cd ..

Pour afficher le nom du répertoire en cours, vous pouvez taper chdir ou cd sans paramètre. Si, par exemple, \Public\Jeanson est le répertoire en cours sur le lecteur B, l'emploi de chdir génère le résultat suivant :

B:\Public\Jeanson

Si vous travaillez sur le lecteur D et si vous voulez copier tous les fichiers des répertoires \Public\Jeanson et \Public\Louis du lecteur C dans le répertoire racine du lecteur D, tapez :

chdir c:\public\jeanson

copy c:*.* d:\

chdir c:\public\louis

copy c:*.* d:\

Si vous souhaitez copier tous les fichiers des répertoires \Public\Jeanson et \Public\Louis dans le répertoire en cours du lecteur D, tapez :

chdir c:\public\jeanson

copy c:*.* d:

chdir c:\public\louis

copy c:*.* d:


Chkdsk

Crée et affiche un rapport sur l'état d'un disque donné en fonction du système de fichiers. Chkdsk indique également toutes les erreurs détectées sur le disque et les corrige. Utilisée sans paramètre, la commande chkdsk affiche l'état du disque placé dans le lecteur en cours.

Syntaxe

chkdsk [volume:][[Chemin] NomFichier] [/f] [/v] [/r] [/x] [/i] [/c] [/l[:taille]]

Paramètres

volume:
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
[Chemin] NomFichier
Indique l'emplacement et le nom du ou des fichiers dont chkdsk doit vérifier la fragmentation. Pour désigner plusieurs fichiers, vous pouvez utiliser des caractères génériques (? et*).
/f
Corrige les erreurs détectées sur le disque. Le disque doit être verrouillé. Si chkdsk ne peut pas verrouiller le lecteur, un message s'affiche vous demandant si vous souhaitez vérifier le lecteur au prochain démarrage de l'ordinateur.
/v
Affiche le nom de tous les fichiers de tous les répertoires au fur et à mesure que le disque est vérifié.
/r
Détecte les secteurs défectueux et récupère les informations lisibles. Le disque doit être verrouillé.
/x
Utilisez avec NTFS uniquement. Force le démontage du volume en premier lieu, si nécessaire. Tous les descripteurs ouverts du lecteur sont invalidés. En outre, /x intègre la fonctionnalité de /f.
/i
Utilisez avec NTFS uniquement. Effectue une vérification moins rigoureuse des entrées d'index, ce qui réduit la durée d'exécution de chkdsk.
/c
Utilisez avec NTFS uniquement. Ne vérifie pas les cycles au sein de la structure des dossiers, ce qui réduit la durée d'exécution de chkdsk.
/l[:taille]
Utilisez avec NTFS uniquement. Limite la taille du fichier journal à celle que vous tapez. Si vous omettez le paramètre de la taille, /l affiche la taille en cours.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Exécution de chkdsk

    Vous devez être membre du groupe Administrateurs pour pouvoir exécuter la commande chkdsk sur un disque dur.

  • Vérification d'un lecteur verrouillé au redémarrage

    Si vous souhaitez que chkdsk corrige les erreurs détectées sur le disque, aucun fichier du disque ne doit être ouvert. Si des fichiers sont ouverts, le message d'erreur suivant s'affiche :

    CHKDSK ne peut pas s'exécuter parce que le volume est utilisé par un autre processus. Voulez-vous que ce volume soit vérifié au prochain redémarrage du système ? (O/N)

    Si vous optez pour la vérification du lecteur au prochain redémarrage de l'ordinateur, chkdsk le vérifiera et corrigera automatiquement les erreurs à ce moment-là. Si la partition du lecteur est une partition d'amorçage, chkdsk redémarre automatiquement l'ordinateur après la vérification du lecteur.

  • Signalement des erreurs sur les disques

    La commande chkdsk effectue l'examen de l'espace disque et de son utilisation pour les systèmes de fichiers file allocation table (FAT) et NTFS. La commande chkdsk fournit des informations sur chaque système de fichiers dans un rapport d'état. Ce dernier indique les erreurs trouvées dans le système de fichiers. Si vous exécutez la commande chkdsk sans utiliser l'option de ligne de commande /f sur une partition active, elle risque de signaler de fausses erreurs, car elle ne peut pas verrouiller le lecteur. Il est recommandé d'exécuter de temps en temps chkdsk sur chaque disque pour vérifier les erreurs.

  • Correction des erreurs sur les disques

    La commande chkdsk ne corrige les erreurs du disque que si vous spécifiez l'option de ligne de commande /f. Pour corriger ces erreurs, il faut que chkdsk puisse verrouiller le lecteur. Comme les corrections modifient généralement la table d'allocation des fichiers d'un disque et entraînent parfois des pertes de données, chkdsk génère un message de confirmation semblable à ce qui suit :

    10 unités d'allocation perdues trouvées dans 3 chaînes.

    Convertir les chaînes perdues en fichiers ?

    Si vous appuyez sur O, Windows enregistre dans le répertoire racine chaque chaîne perdue sous la forme d'un fichier dont le nom présente la structure Filennnn.chk. À la fin de l'exécution de la commande chkdsk, vous pouvez vérifier si ces fichiers contiennent des données requises. Si vous appuyez sur N, Windows corrige les erreurs du disque sans enregistrer le contenu des unités d'allocation perdues.

    Si vous n'utilisez pas l'option de ligne de commande /f, chkdsk génère un message si un fichier doit être corrigé, mais ne corrige aucune erreur.

    Si vous utilisez chkdsk /f sur un disque très volumineux (par exemple, 70 giga-octets) ou sur un disque qui contient un nombre important de fichiers (par exemple, plusieurs millions de fichiers), son exécution risque de prendre un certain temps (par exemple, plusieurs jours). L'ordinateur n'est pas disponible pendant cette période car chkdsk ne passe pas la main avant d'avoir terminé.

  • Vérification d'un disque FAT

    Les rapports d'état de chkdsk qui sont affichés par Windows pour un disque FAT se présentent sous la forme suivante :

    Le numéro de série du volume est B1AF-AFBF

    72 214 528 octets d'espace disque total

    73 728 octets dans 3 fichiers cachés

    30 720 octets dans 12 répertoires

    11 493 376 octets dans 386 fichiers utilisateur

    61 440 octets dans des secteurs défectueux

    60 555 264 octets disponibles sur le disque

    2 048 octets dans chaque unité d'allocation

    35 261 unités d'allocation au total sur le disque

    29 568 unités d'allocation disponibles sur le disque
  • Vérification d'un disque NTFS

    Les rapports d'état de chkdsk qui sont affichés par Windows pour un disque NTFS se présentent sous la forme suivante :

    Le type de système de fichiers est NTFS.

    CHKDSK vérifie les fichiers...

    La vérification des fichiers est terminée.

    CHKDSK vérifie les index...

    La vérification des index est terminée.

    CHKDSK vérifie les descripteurs de sécurité...

    La vérification des descripteurs de sécurité est terminée.

    12 372 kilo-octets d'espace disque total.

    3 kilo-octets dans 1 fichier utilisateur.

    2 kilo-octets dans 1 index.

    4 217 kilo-octets utilisés par le système.

    8 150 kilo-octets disponibles sur le disque.

    512 octets dans chaque unité d'allocation.

    24 745 unités d'allocation au total sur le disque.

    16 301 unités d'allocation disponibles sur le disque.
  • Utilisation de chkdsk avec des fichiers ouverts

    Si vous spécifiez l'option de ligne de commande /f, chkdsk génère un message d'erreur si le disque contient des fichiers ouverts. Si vous n'employez pas l'option de ligne de commande /f et si des fichiers sont ouverts, il se peut que chkdsk signale des unités d'allocation perdues sur le disque. Cette situation se présente notamment lorsque des fichiers ouverts n'ont pas encore été enregistrés dans la table d'allocation. Si chkdsk signale la perte d'un grand nombre d'unités d'allocation, envisagez de réparer le disque.

  • Détection d'erreurs disque physiques

    Utilisez l'option de ligne de commande /r pour trouver les défauts physiques du disque dans le système de fichiers. Pour plus d'informations sur la récupération de fichiers physiquement endommagés avec la commande recover, consultez Rubriques connexes.

  • Signalement des secteurs disque défectueux

    Les secteurs défectueux signalés par chkdsk ont été marqués comme tels lors de la préparation initiale du disque. Ils ne présentent pas de danger.

  • Signification des codes de sortie

    Le tableau suivant répertorie les codes de sortie indiqués par chkdsk à la fin de son exécution.

    Code de sortie | Description
    0 | Aucune erreur n'a été trouvée.
    1 | Des erreurs ont été trouvées et corrigées.
    2 | Le nettoyage du disque, notamment la récupération de place en mémoire, a été effectué ou ne l'a pas été parce que l'option de ligne de commande /f n'a pas été préalablement spécifiée.
    3 | Impossible d'examiner le disque, les erreurs n'ont pas pu être corrigées ou les erreurs n'ont pas été corrigées parce que l'option de ligne de commande /f n'a pas été préalablement spécifiée.
  • La commande chkdsk est disponible dans la console de récupération avec d'autres paramètres.

Exemples

Pour vérifier le disque placé dans le lecteur D et demander à Windows de corriger les erreurs, tapez :

chkdsk d: /f

Au fur et à mesure qu'elle détecte des erreurs, la commande chkdsk s'interrompt et affiche des messages. Chkdsk termine en présentant un rapport indiquant l'état du disque. Vous ne pouvez ouvrir aucun fichier sur le lecteur spécifié avant la fin de l'exécution de la commande chkdsk.

Pour vérifier s'il existe des blocs non contigus dans l'ensemble des fichiers du répertoire en cours d'un disque FAT, tapez :

chkdsk *.*

Chkdsk affiche un rapport d'état, puis la liste des fichiers correspondant à la spécification donnée qui contiennent des blocs non contigus.


Chkntfs

Affiche ou indique si la vérification automatique du système est programmée pour être exécutée sur un volume FAT, FAT32 ou NTFS au démarrage de l'ordinateur.

Syntaxe

chkntfs volume: [...]

chkntfs [/d]

chkntfs [/t[:durée]]

chkntfs [/x volume: [...]]

chkntfs [/c volume: [...]]

Paramètres

volume: [...]
Requis. Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume. Affiche un message identifiant le système de fichiers du volume spécifié. Si la vérification automatique des fichiers est programmée, ce paramètre indique si le volume a été altéré, auquel cas vous devez exécuter chkdsk.
/d
Rétablit tous les paramètres par défaut de chkntfs, à l'exception du compte à rebours de la vérification automatique des fichiers. Par défaut, tous les volumes sont vérifiés au démarrage de l'ordinateur.
/t[:durée]
Attribue au compte à rebours du démarrage d'Autochk.exe la durée spécifiée en secondes. Si vous ne spécifiez pas le paramètre :durée, /t affiche le compte à rebours en cours.
/x volume: [...]
Exclut le volume spécifié de la vérification au démarrage de l'ordinateur, même si celui-ci est désigné comme nécessitant une exécution de chkdsk.
/c volume: [...]
Programme la vérification du volume spécifié au démarrage de l'ordinateur.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Pour exécuter la commande chkntfs, vous devez être membre du groupe Administrateurs.
  • Bien que vous puissiez attribuer la valeur zéro au compte à rebours du démarrage d'Autochk.exe, vous ne pouvez pas annuler de la sorte une vérification automatique de fichiers susceptible de durer longtemps.

Exemples

Pour afficher le compte à rebours du démarrage d'Autochk.exe, tapez :

chkntfs /t

Lorsque vous modifiez le compte à rebours du démarrage d'Autochk.exe, exprimez la durée en secondes. Par exemple, pour attribuer au compte à rebours la valeur 30 secondes, tapez :

chkntfs /t:30

L'option de ligne de commande /x ne peut pas être cumulée. Si vous la tapez plusieurs fois, l'entrée la plus récente remplace l'entrée précédente. Pour exclure plusieurs volumes, spécifiez-les tous dans une seule commande. Par exemple, pour exclure les volumes E: et F:, tapez :

chkntfs /x e: f:

Pour exclure uniquement le volume F:, tapez :

chkntfs /x e:

chkntfs /x f:

L'option de ligne de commande /c peut être cumulée. Si vous souhaitez ne vérifier que le volume spécifié, rétablissez les paramètres par défaut pour annuler toutes les commandes précédentes, excluez tous les volumes de la vérification, puis programmez la vérification automatique des fichiers du volume désiré.

Par exemple, pour programmer seulement la vérification automatique des fichiers du volume D:, tapez :

chkntfs /d

chkntfs /x c: d: e:

chkntfs /c d:


Cipher

Affiche ou modifie le cryptage des dossiers et des fichiers sur des volumes NTFS. Utilisée sans paramètre, cipher affiche l'état de cryptage du dossier actuel et des fichiers qu'il contient.

Syntaxe

cipher [{/e|/d}] [/s:rép] [/a] [/i] [/f] [/q] [/h] [/k] [/u[/n]] [NomChemin [...]] | [/r:NomCheminSansExtension] | [/w:NomChemin]

Paramètres

/e
Crypte les dossiers spécifiés. Les dossiers sont marqués de manière à ce que les fichiers qui s'y ajoutent ultérieurement soient cryptés également.
/d
Décrypte les dossiers spécifiés. Les dossiers sont marqués de manière à ce que les fichiers qui s'y ajoutent ultérieurement soient cryptés également.
/s: rép
Exécute l'opération sélectionnée dans le dossier et tous les sous-dossiers spécifiés.
/a
Exécute l'opération pour des fichiers et des répertoires.
/i
Poursuit l'exécution de l'opération spécifiée même en présence d'erreurs. Par défaut, cipher s'arrête quand elle rencontre une erreur.
/f
Force le cryptage ou le décryptage de tous les objets spécifiés. Par défaut, cipher ignore les fichiers qui ont déjà été cryptés ou décryptés.
/q
Signale uniquement les informations les plus importantes.
/h
Affiche les fichiers cachés ou les fichiers système. Par défaut, ces fichiers ne sont pas cryptés ou décryptés.
/k
Crée une nouvelle clé de cryptage de fichier pour l'utilisateur qui exécute cipher. Si vous utilisez cette option, cipher ignore toutes les autres options.
/u
Met à jour la clé de cryptage de fichier de l'utilisateur ou la clé de l'agent de récupération à partir des clés en cours dans tous les fichiers cryptés stockés sur les lecteurs locaux (dans le cas où les clés ont été modifiées). Cette option fonctionne uniquement avec /n.
/n
Empêche la mise à jour des clés. Utilisez cette option pour rechercher tous les fichiers cryptés stockés sur les lecteurs locaux. Cette option fonctionne uniquement avec /u.
NomChemin
Spécifie un modèle, un fichier ou un dossier.
/r:NomCheminSansExtension
Génère une nouvelle clé privée et un nouveau certificat d'agent de récupération puis les écrit dans des fichiers dont le nom est indiqué dans NomCheminSansExtension. Si vous utilisez cette option, cipher ignore toutes les autres options.
/w:NomChemin
Supprime les données de portions inutilisées d'un volume. NomChemin peut désigner un répertoire quelconque du volume concerné. Si vous utilisez cette option, cipher ignore toutes les autres options.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisation de /w

    /w supprime les données de portions de volume accessibles allouées à aucun fichier ou répertoire. Cette option ne verrouillant pas le lecteur, l'espace disponible peut être alloué à des programmes sans qu'ils risquent d'être effacés par cipher. Étant donné que cette option écrit sur une large portion du volume du disque dur, l'opération peut prendre du temps et ne doit être effectuée qu'en cas de nécessité.

  • Cryptage ou décryptage des fichiers

    Pour qu'un fichier crypté ne soit pas décrypté lorsqu'il est modifié, il est recommandé de crypter le fichier et le dossier dans lequel il réside.

  • Utilisation de dossiers et de fichiers accessibles en lecture seule

    La commande cipher ne peut pas crypter les fichiers accessibles en lecture seule.

  • Utilisation de plusieurs noms de dossier

    Vous pouvez utiliser plusieurs noms de dossier ainsi que des caractères génériques.

  • Utilisation de plusieurs paramètres

    Vous devez séparer les paramètres par un espace au moins.

Exemples

Pour utiliser la commande cipher pour crypter un sous-dossier appelé May dans un dossier appelé MonthlyReports, tapez :

cipher /e monthlyreports\may

Pour crypter le dossier MonthlyReports, les sous-dossiers January à December et les sous-dossiers Manufacturing situés à l'intérieur des sous-dossiers des mois, tapez :

cipher /e /s:monthlyreports

Pour crypter uniquement le fichier Marketing.xls situé dans le sous-dossier May, tapez :

cipher /e /a monthlyreports\may\marketing.xls

Pour crypter le fichier Marketing.xls, le fichier Maintenance.doc et le sous-dossier Manufacturing (situés également dans le dossier May), tapez :

cipher /e /a monthlyreports\may\ma*

Pour déterminer si le dossier May est crypté, tapez :

cipher monthlyreports\may

Pour déterminer les fichiers cryptés dans le dossier May, tapez :

cipher monthlyreports\may\*


Cls

Efface le contenu de la fenêtre Invite de commandes.

Syntaxe

cls

Paramètres

/?
Affiche de l'aide à l'invite de commandes.

Exemples

Pour effacer toutes les informations de la fenêtre Invite de commandes afin d'obtenir une fenêtre vide, tapez :

cls

XOX

Rubriques connexes


Cmd

Lance une nouvelle instance de l'interpréteur de commandes, Cmd.exe. Utilisée sans paramètre, la commande cmd affiche les informations de copyright et la version de Windows XP.

Syntaxe

cmd [[{/c|/k}] [/s] [/q] [/d] [{/a|/u}] [/t:pa] [/e:{on|off}] [/f:{on|off}] [/v:{on|off}] chaîne]

Paramètres

/c
Exécute la commande spécifiée par la chaîne, puis s'arrête.
/k
Exécute la commande spécifiée par la chaîne, puis continue.
/s
Modifie le traitement de la chaîne après /c ou /k.
/q
Désactive l'écho.
/d
Désactive l'exécution de commandes AutoRun.
/a
Crée une sortie ANSI (American National Standards Institute).
/u
Crée une sortie Unicode.
/t:pa
Spécifie les couleurs de premier plan p et d'arrière-plan a. Le tableau suivant répertorie les chiffres hexadécimaux permettant de définir les variables p et a.
Valeur | Couleur
0 | Noir
1 | Bleu
2 | Vert
3 | Turquoise
4 | Rouge
5 | Violet
6 | Jaune
7 | Blanc
8 | Gris
9 | Bleu clair
A | Vert clair
B | Bleu-vert clair
C | Rouge clair
D | Violet clair
E | Jaune clair
F | Blanc brillant
/e:on
Active les extensions de commande.
/e:off
Désactive les extensions de commandes.
/f:on
Active la terminaison des noms de fichiers et de répertoires.
/f:off
Désactive la terminaison des noms de fichiers et de répertoires.
/v:on
Active l'expansion retardée de variables d'environnement.
/v:off
Désactive l'expansion retardée de variables d'environnement.
chaîne
Spécifie la commande à exécuter.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisation de plusieurs commandes

    Dans la chaîne, vous pouvez utiliser plusieurs commandes séparées par le séparateur && à condition de les placer entre guillemets (par exemple, "commande&&commande&&commande").

  • Traitement des guillemets

    Si vous spécifiez /c ou /k, cmd traite le reste de la chaîne et les guillemets ne sont conservés que si toutes les conditions suivantes sont réunies :

    • Vous n'utilisez pas /s.
    • Vous utilisez exactement un jeu de guillemets.
    • Vous n'utilisez aucun caractère spécial entre les guillemets (par exemple : &<>( ) @ ^ |).
    • Vous utilisez un ou plusieurs espaces entre les guillemets.
    • La chaîne entre guillemets est le nom d'un fichier exécutable.

    Si les conditions ci-dessus ne sont pas réunies, le traitement de la chaîne consiste d'abord à vérifier si le premier caractère est un guillemet ouvrant. Si tel est le cas, il est supprimé ainsi que le guillemet fermant. Tout le texte à la suite du guillemet fermant est conservé.

  • Exécution des sous-clés de Registre

    Si vous ne spécifiez pas /d dans la chaîne, Cmd.exe recherche les sous-clés de Registre suivantes :

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun\REG_SZ

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun REG_EXPAND_SZ

    Si une ou les deux sous-clés de Registre sont présentes, elles sont exécutées avant toutes les autres variables.

    Attention

    • Une modification incorrecte du Registre peut endommager gravement votre système. Avant d'apporter des modifications au Registre, sauvegardez toutes les données importantes de votre ordinateur.
  • Activation et désactivation des extensions de commande

    Par défaut, les extensions de commande sont activées dans Windows XP. Vous pouvez les désactiver dans le cadre d'un processus particulier à l'aide de /e:off. Vous pouvez activer ou désactiver les extensions de toutes les options de ligne de commande cmd pour une session d'ordinateur ou d'utilisateur en définissant les valeurs REG_DWORD suivantes :

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\EnableExtensions\REG_DWORD

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\EnableExtensions\REG_DWORD

    Dans le Registre, à l'aide de Regedit.exe, attribuez à REG_DWORD la valeur 0×1 (activé) ou 0×0 (désactivé). Les paramètres spécifiques à l'utilisateur prévalent sur les paramètres de l'ordinateur et les options de ligne de commande prévalent sur les paramètres du Registre.

    Attention

    • Une modification incorrecte du Registre peut endommager gravement votre système. Avant d'apporter des modifications au Registre, sauvegardez toutes les données importantes de votre ordinateur.

    Lorsque vous activez les extensions de commande, les commandes suivantes sont affectées :

    • assoc
    • call
    • chdir (cd)
    • color
    • del (erase)
    • endlocal
    • for
    • ftype
    • goto
    • if
    • mkdir (md)
    • popd
    • prompt
    • pushd
    • set
    • setlocal
    • shift
    • start (concerne également les modifications apportées aux traitements de commandes externes)

    Pour plus d'informations sur ces commandes, consultez Rubriques connexes.

  • Activation de l'expansion retardée de variables d'environnement

    Si vous activez l'expansion retardée de variables d'environnement, vous pouvez utiliser le point d'exclamation à la place de la valeur d'une variable d'environnement à l'exécution.

  • Activation de la terminaison des noms de fichiers et de répertoires

    Par défaut, la terminaison des noms de fichiers et de répertoires n'est pas activée. Vous pouvez activer ou désactiver la terminaison des noms de fichiers dans le cadre d'un processus particulier de la commande cmd au moyen de la syntaxe /f:{on|off}. Vous pouvez activer ou désactiver la terminaison des noms de fichiers et de répertoires dans le cadre de tous les processus de la commande cmd pour une ouverture de session d'ordinateur ou d'utilisateur en définissant les valeurs REG_DWORD suivantes :

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\PathCompletionChar\REG_DWORD

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\PathCompletionChar\REG_DWORD

    Pour définir la valeur REG_DWORD, exécutez Regedit.exe et utilisez la valeur hexadécimale d'un caractère de contrôle correspondant à une fonction particulière (par exemple, 0×9 correspond à TABULATION et 0×08 à RETOUR ARRIERE). Les paramètres spécifiques à l'utilisateur prévalent sur les paramètres de l'ordinateur et les options de ligne de commande prévalent sur les paramètres du Registre.

    Attention

    • Une modification incorrecte du Registre peut endommager gravement votre système. Avant d'apporter des modifications au Registre, sauvegardez toutes les données importantes de votre ordinateur.

    Si vous activez la terminaison des noms de fichiers et de répertoires au moyen de la syntaxe /f:on, utilisez CTRL+D pour la terminaison des noms de répertoires et CTRL+F pour la terminaison des noms de fichiers. Pour désactiver un caractère de terminaison particulier dans le Registre, utilisez la valeur du caractère d'espacement [0×20] car il ne s'agit pas d'un caractère de contrôle valide.

    Lorsque vous appuyez sur CTRL+D ou CTRL+F, cmd traite la terminaison des noms de fichiers et de répertoires. Ces fonctions de combinaison de touches ajoutent un caractère générique à la chaîne (dans le cas où elle n'en contient pas), créent une liste de chemins correspondants puis affichent le premier d'entre eux. Si aucun des chemins ne correspond, la fonction de terminaison des noms de fichiers et de répertoires émet un signal sonore et ne modifie pas l'affichage. Pour parcourir la liste des chemins correspondants, appuyez sur CTRL+D ou CTRL+F autant de fois que nécessaire. Pour parcourir la liste en sens inverse, appuyez simultanément sur la touche la touche MAJ et sur CTRL+D ou CTRL+F. Pour annuler la liste enregistrée de chemins correspondants et générer une nouvelle liste, modifiez la chaîne et appuyez sur la touche CTRL+D ou CTRL+F. Si vous utilisez alternativement les combinaisons CTRL+D et CTRL+F, la liste enregistrée de chemins correspondants est annulée et une nouvelle liste est générée. La seule différence entre les combinaisons de touches CTRL+D et CTRL+F est que la première correspond uniquement aux noms de répertoires tandis que la seconde correspond aux noms de fichiers et de répertoires. Si vous utilisez la terminaison des noms de fichiers et de répertoires dans n'importe quelle commande de répertoire intégrée (CD, MD, ou RD), la terminaison de répertoire est utilisée.

    La terminaison des noms de fichiers et de répertoires traite correctement les noms de fichiers contenant des espaces ou des caractères spéciaux si vous placez le chemin correspondant entre guillemets.

    Les caractères spéciaux suivants requièrent l'utilisation de guillemets : & < > [ ] { } ^ = ; ! ' + , ` ~ [espace]

    Si les informations que vous fournissez contiennent des espaces, placez le texte entre guillemet (par exemple, "Nom Ordinateur").

    Si vous traitez la terminaison des noms de fichiers et de répertoires à partir de la chaîne, toute la partie du [chemin] à droite du curseur est ignorée (point de la chaîne au niveau duquel la terminaison a été traitée).


Rubriques d'aide affichant la table des matières

Image Microsoft Windows
Cliquez sur Rubriques d'aide pour afficher la table des matières.


Cmstp

Installe ou supprime un profil de service Connection Manager. Utilisée sans paramètre facultatif, la commande cmstp installe un profil de service à partir des valeurs par défaut du système d'exploitation et des autorisations de l'utilisateur.

Syntaxe

Syntaxe 1 : NomFichierProfilService.exe /q:a /c:"cmstp.exe NomFichierProfilService.inf [/nf] [/ni] [/ns] [/s] [/su] [/u]"

Syntaxe 2 : cmstp.exe [/nf] [/ni] [/ns] [/s] [/su] [/u] "[Lecteur:][Chemin]NomFichierProfilService.inf"

Paramètres

NomFichierProfilService.exe
Requis pour la syntaxe 1 mais non valide pour la syntaxe 2. Spécifie le nom du package d'installation contenant le profil à installer.
/q:a
Requis pour la syntaxe 1 mais non valide pour la syntaxe 2. Indique que le profil doit être installé sans solliciter l'utilisateur. Le message de vérification indiquant que l'installation est terminée s'affiche toujours.
[Lecteur:][Chemin]NomFichierProfilService.inf
Requis. Spécifie le nom du fichier de configuration qui détermine comment le profil doit être installé. Le paramètre [Lecteur:][Chemin] n'est pas valide pour la syntaxe 1.
/nf
Spécifie que les fichiers de prise en charge ne doivent pas être installés.
/ni
Spécifie qu'aucune icône de bureau ne doit être créée. Ce paramètre est uniquement valide pour les ordinateurs exécutant Windows 95, Windows 98, Windows NT 4.0 ou Windows Millennium Edition.
/ns
Spécifie qu'aucun raccourci de bureau ne doit être créé. Ce paramètre est uniquement valide pour les ordinateurs exécutant Windows 2000 ou Windows XP.
/s
Spécifie que le profil de service doit être installé ou désinstallé automatiquement (sans sollicitation de réponse de la part de l'utilisateur ni affichage de message de vérification).
/su
Spécifie que le profil de service doit être installé pour un seul utilisateur plutôt que pour tous les utilisateurs. Ce paramètre est uniquement valide pour les ordinateurs exécutant Windows 2000 ou Windows XP.
/u
Spécifie que le profil de service doit être désinstallé.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • /s est le seul paramètre que vous pouvez associer au paramètre /u.
  • La syntaxe 1 est la syntaxe généralement utilisée dans une application d'installation personnalisée. Pour utiliser cette syntaxe, vous devez exécuter cmstp à partir du répertoire qui contient le fichier NomFichierProfilService.exe.

Exemples

Les exemples suivants illustrent l'utilisation de cmstp dans le cadre d'un profil de service fictif, appelé Fiction, et de ses fichiers associés.

  • Pour installer le profil de service Fiction sans aucun fichier de prise en charge, tapez :

    • fiction.exe /c:"cmstp.exe fiction.inf /nf"

  • Pour installer automatiquement le profil de service Fiction pour un seul utilisateur, tapez :

    • fiction.exe /c:"cmstp.exe fiction.inf /s /su"

  • Pour désinstaller automatiquement le profil de service Fiction, tapez :

    • fiction.exe /c:"cmstp.exe fiction.inf /s /u"


Color

Modifie les couleurs de premier plan et d'arrière-plan de la fenêtre Invite de commandes pour la session en cours. Utilisée sans paramètre, la commande color restaure les couleurs par défaut de premier plan et d'arrière-plan de la fenêtre Invite de commandes.

Syntaxe

color [pa]

Paramètres

pa
Spécifie les couleurs de premier plan p et d'arrière-plan a. Le tableau suivant répertorie les chiffres hexadécimaux permettant de définir les variables p et a.
Valeur | Couleur
0 | Noir
1 | Bleu
2 | Vert
3 | Turquoise
4 | Rouge
5 | Violet
6 | Jaune
7 | Blanc
8 | Gris
9 | Bleu clair
A | Vert clair
B | Bleu-vert clair
C | Rouge clair
D | Violet clair
E | Jaune clair
F | Blanc brillant
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Pour définir les couleurs par défaut de la fenêtre Invite de commandes, cliquez sur l'angle supérieur gauche de la fenêtre, cliquez sur Par défaut, sur l'onglet Couleurs puis sur les couleurs à utiliser pour les paramètres Texte et Arrière-plan.
  • Vous pouvez utiliser la syntaxe cmd /t:pa afin de modifier les couleurs de la fenêtre Invite de commandes pour la session en cours.
  • Si les couleurs de premier plan et d'arrière-plan sont les mêmes, la commande color attribue à ERRORLEVEL la valeur un (1).

Exemples

Pour attribuer respectivement les couleurs rouge et blanc au premier plan et à l'arrière-plan de la fenêtre Invite de commandes, tapez :

color FC


Comp

Compare octet par octet le contenu de deux fichiers ou de groupes de fichiers. Comp peut comparer des fichiers situés sur le même lecteur ou sur des lecteurs différents, ainsi que dans le même répertoire ou dans des répertoires différents. Pendant la comparaison, comp affiche les emplacements et les noms des fichiers. Utilisée sans paramètre, la commande comp invite l'utilisateur à entrer les fichiers à comparer.

Syntaxe

comp [données1] [données2] [/d] [/a] [/l] [/n=nombre] [/c]

Paramètres

données1
Indique l'emplacement et le nom du premier fichier ou groupe de fichiers à comparer. Pour désigner plusieurs fichiers, vous pouvez utiliser des caractères génériques (* et ?).
données2
Indique l'emplacement et le nom du second fichier ou groupe de fichiers à comparer. Pour désigner plusieurs fichiers, vous pouvez utiliser des caractères génériques (* et ?).
/d
Affiche les différences au format décimal. (Le format par défaut est le format hexadécimal.)
/a
Affiche les différences sous forme de caractères.
/l
Affiche le numéro de la ligne où se présente une différence au lieu d'afficher le décalage en octets.
/n=nombre
Compare les premières lignes des deux fichiers jusqu'à concurrence du nombre, même si les fichiers sont de tailles différentes.
/c
Ne distingue pas les majuscules des minuscules lors de la comparaison.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Comparaison de fichiers de même nom

    Les fichiers comparés peuvent porter le même nom, à condition qu'ils se trouvent dans des répertoires ou sur des lecteurs différents. Si vous ne spécifiez aucun nom de fichier pour le paramètre données2, le nom de fichier par défaut de données2 est identique à celui de données1. Pour désigner des noms de fichiers, vous pouvez utiliser des caractères génériques (? et*).

  • Cas particuliers pour données1 et données2

    Si vous omettez les composants requis de données1 ou données2 ou si vous omettez données2, comp vous invite à spécifier les informations manquantes. Si données1 ne contient qu'une lettre de lecteur ou un nom de répertoire sans nom de fichier, comp compare tous les fichiers du répertoire spécifié au fichier désigné dans données2. Si données2 ne contient qu'une lettre de lecteur ou un nom de répertoire, données2 a pour nom par défaut le même nom de fichier que données1.

  • Identification des différences d'information par la commande comp

    Au cours du processus de comparaison, comp affiche des messages indiquant les emplacements des informations qui diffèrent dans les deux fichiers. Chaque message indique l'adresse mémoire du décalage des octets différents ainsi que le contenu des octets proprement dits (en notation hexadécimale si l'option de ligne de commande /a ou /d n'est pas utilisée). Le message se présente sous la forme suivante :

    Erreur de comparaison à OFFSET xxxxxxxx

    fichier1 = xx

    fichier2 = xx

    Après 10 différences trouvées, comp arrête la comparaison des fichiers et affiche le message suivant :

    10 différences - comparaison arrêtée

  • Comparaison de fichiers de tailles différentes

    Il n'est possible de comparer des fichiers de tailles différentes que si l'option de ligne de commande /n est utilisée. Si les tailles des fichiers sont différentes, comp affiche le message suivant :

    Les fichiers sont de taille différente.

    Voulez-vous comparer d'autres fichiers (O/N) ?

    Appuyez sur O pour comparer une autre paire de fichiers. Appuyez sur N pour arrêter la commande comp.

    Si vous appuyez sur O en réponse à l'invite, comp inclut toutes les options de ligne de commande éventuellement spécifiées sur la ligne de commande dans toutes les comparaisons suivantes jusqu'à ce que vous appuyiez sur N ou retapiez la commande.

    Lors d'une comparaison de fichiers de tailles différentes, utilisez l'option de ligne de commande /n pour ne comparer que le début de ces fichiers.

  • Comparaisons successives de fichiers

    Si vous utilisez des caractères génériques (* et ?) pour désigner plusieurs fichiers, comp trouve le premier fichier qui correspond à données1 et le compare au fichier correspondant spécifié dans données2, s'il existe. La commande comp signale ensuite les résultats de la comparaison, puis procède de la même manière pour chaque fichier correspondant à données1. Une fois le processus achevé, comp affiche le message suivant :

    Voulez-vous comparer d'autres fichiers (O/N) ?

    Pour comparer d'autres fichiers, appuyez sur O. La commande comp vous réclame alors l'emplacement et le nom des nouveaux fichiers. Pour arrêter les comparaisons, appuyez sur N. Quand vous appuyez sur O, comp vous invite à spécifier les options de ligne de commande. Si vous n'en spécifiez aucune, comp utilise ceux du cycle précédent.

  • Si comp ne trouve pas les fichiers

    Si comp ne trouve pas le ou les fichiers spécifiés, un message vous demande si vous voulez en comparer d'autres.

Exemples

Pour comparer le contenu du répertoire C:\Rapports à celui du répertoire de sauvegarde \\Ventes\Sauv\Avril, tapez :

comp c:\rapports \\ventes\sauv\avril

Pour comparer les dix premières lignes des fichiers texte du répertoire \Facture et afficher le résultat en notation décimale, tapez :

comp \facture\*.txt \facture\sauv\*.txt /n=10 /d


Compact

Affiche et modifie la compression des fichiers ou des répertoires dans les partitions NTFS. Utilisée sans paramètre, la commande compact affiche l'état de la compression du répertoire en cours.

Syntaxe

compact [{/c|/u}] [/s[:rép]] [/a] [/i] [/f] [/q] [NomFichier[...]]

Paramètres

/c
Compresse le répertoire ou le fichier indiqué.
/u
Décompresse le répertoire ou le fichier indiqué.
/s:rép
Indique que l'action demandée (compression ou décompression) doit s'appliquer à tous les sous-répertoires du répertoire indiqué ou du répertoire en cours si aucun répertoire n'est spécifié.

/a
Affiche les fichiers cachés ou les fichiers système.
/i
Ne tient pas compte des erreurs.
/f
Force la compression ou la décompression du répertoire ou du fichier indiqué. Ce paramètre est utilisé lorsque la compression d'un fichier est interrompue par une panne du système. Pour forcer la compression du fichier dans sa totalité, utilisez les paramètres /c et /f et spécifiez le fichier compressé partiellement.
/q
Signale uniquement les informations les plus importantes.
NomFichier
Indique le nom du fichier ou du répertoire. Vous pouvez utiliser plusieurs noms de fichier ainsi que des caractères génériques (* et ?).
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • La commande compact, version de la ligne de commandes propre au dispositif de compression du système de fichiers NTFS, affiche et modifie l'attribut de compression des fichiers et des répertoires placés dans des partitions NTFS. L'état de compression d'un répertoire indique si les fichiers ajoutés à ce répertoire seront automatiquement compressés. Lorsque vous définissez l'état de compression d'un répertoire, vous ne modifiez pas obligatoirement l'état de compression des fichiers qui s'y trouvent déjà.
  • Vous ne pouvez pas utiliser compact pour lire, écrire ou monter des volumes déjà compressés par DriveSpace ou DoubleSpace.

Exemples

Pour définir l'état de compression du dossier en cours, de ses sous-dossiers et des fichiers correspondants, à partir du dossier en cours, tapez la commande :

compact /c /s

Pour définir l'état de compression des fichiers du dossier en cours, de ses sous-dossiers et des fichiers contenus dans tous les sous-dossiers sans modifier l'état de compression du dossier en cours, à partir de celui-ci, tapez la commande :

compact /c /s *.*

Pour compresser un volume, à partir du dossier racine du volume, tapez la commande :

compact /c /i /s:\

Cet exemple définit l'état de compression du dossier racine et de tous les dossiers du volume et compresse chaque fichier du volume. Grâce au paramètre /i, aucun message d'erreur ne peut interrompre le processus de compression.

Pour compresser tous les fichiers .bmp présents dans le répertoire \Tmp et dans tous ses sous-répertoires, sans modifier l'attribut de compression de ces répertoires, tapez la commande :

compact /c /s:\tmp *.bmp

Pour forcer la compression du fichier Zèbre.bmp qui avait été interrompue par une panne du système, tapez la commande :

compact /c /f zebre.bmp

Pour supprimer l'attribut de compression du répertoire C:\Tmp sans modifier l'état de compression des fichiers qui s'y trouvent, tapez la commande :

compact /u c:\tmp


Convert

Convertit les volumes FAT et FAT32 au format NTFS.

Syntaxe

convert [volume] /fs:ntfs [/v] [/cvtarea:NomFichier] [/nosecurity] [/x]

Paramètres

volume
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume à convertir au format NTFS.
/fs:ntfs
Requis. Convertit le volume au format NTFS.
/v
Spécifie le mode documenté, dans lequel tous les messages sont affichés au cours de la conversion.
/cvtarea:NomFichier
Pour les utilisateurs avancés uniquement. Spécifie que la Master File Table (MFT) et les autres fichiers de métadonnées NTFS sont écrits dans un fichier d'espaces réservés contigu existant. Ce fichier doit se trouver dans le répertoire racine du système de fichiers pour pouvoir être converti. L'utilisation du paramètre /CVTAREA peut aboutir à un système de fichiers moins fragmenté au terme de la conversion. Pour que celle-ci donne les meilleurs résultats, la taille du fichier doit être de 1 Ko multiplié par le nombre de fichiers et de répertoires contenus dans le système de fichiers. Toutefois, l'utilitaire de conversion accepte toute taille de fichier.

Pour plus d'informations sur l'utilisation du paramètre /cvtarea, consultez « Systèmes de fichiers » sur le site Web des Kits de ressources Microsoft Windows XP.(http://www.microsoft.com/)

Important

  • Vous devez créer le fichier d'espaces réservés à l'aide de la commande fsutil file createnew avant d'exécuter convert. La commande convert ne crée pas ce fichier automatiquement. Elle lui substitue les métadonnées NTFS. Après la conversion, tout espace inutilisé dans ce fichier est libéré. Pour plus d'informations sur la commande fsutil file, consultez Rubriques connexes.
/nosecurity
Spécifie que toute personne peut accéder aux fichiers convertis et aux paramètres de sécurité des répertoires.
/x
Le cas échéant, démonte le volume avant sa conversion. Tous les descripteurs ouverts du volume ne seront plus valides.

Remarques

  • Vous devez spécifier que le lecteur doit être converti au redémarrage de l'ordinateur. Sinon, il n'est pas possible de convertir le lecteur en cours.
  • Si la commande convert ne peut pas verrouiller le lecteur (par exemple, le volume système ou le lecteur en cours), le système propose de convertir le lecteur au prochain démarrage de l'ordinateur.
  • L'emplacement de la table MFT est différent sur les volumes convertis à partir d'une version antérieure de NTFS, si bien que la performance des volumes peut être inférieure à celle des volumes convertis à partir de Windows NT.
  • Les volumes FAT convertis au format NTFS sont moins performants que les volumes auxquels le format NTFS est appliqué dès l'origine. Sur les volumes convertis, la table MFT peut devenir fragmentée. En outre, les autorisations NTFS ne s'appliquent plus sur un volume d'amorçage converti.

Exemples

Pour convertir le volume du lecteur E au format NTFS et afficher tous les messages, tapez :

convert e: /fs:ntfs /v


Copy

Copie un ou plusieurs fichiers à partir d'un emplacement dans un autre.

Syntaxe

copy [/d] [/v] [/n] [{/y|/-y}] [/z] [{/a|/b}] Source [{/a|/b}] [+ Source [{/a|/b}] [+ ...]] [Destination [{/a|/b}]]

Paramètres

/d
Permet, à l'emplacement de destination, d'enregistrer sous une forme décryptée les fichiers cryptés qui subissent l'opération de copie.
/v
Vérifie que les nouveaux fichiers sont correctement écrits.
/n
Utilise un nom de fichier court, éventuellement disponible, lors de la copie d'un fichier dont le nom comporte plus de huit caractères ou dont l'extension compte plus de trois caractères.
/y
Supprime la confirmation de remplacement d'un fichier de destination existant.
/-y
Invite l'utilisateur à confirmer le remplacement d'un fichier de destination existant.
/z
Copie des fichiers mis en réseau en mode redémarrage.
/a
Désigne un fichier texte ASCII.
/b
Désigne un fichier binaire.
Source
Requis. Indique l'emplacement à partir duquel le fichier ou jeu de fichiers doit être copié. Source peut se composer d'une lettre de lecteur et d'un deux-points, d'un nom de dossier, d'un nom de fichier, ou d'une combinaison de ces éléments.
Destination
Requis. Indique l'emplacement vers lequel le fichier ou jeu de fichiers doit être copié. Destination peut se composer d'une lettre de lecteur et d'un deux-points, d'un nom de dossier, d'un nom de fichier, ou d'une combinaison de ces éléments.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Vous pouvez copier un fichier texte ASCII utilisant un caractère de fin de fichier (CTRL+Z) pour indiquer la fin du fichier.
  • Utilisation de /a

    Lorsque l'option de ligne de commande /a précède une liste de fichiers sur la ligne de commande, elle s'applique à tous les fichiers répertoriés jusqu'à ce que la commande copy rencontre l'option de ligne de commande /b. Dans ce cas, /b s'applique au fichier qui précède /b.

    Lorsque l'option de ligne de commande /a suit une liste de fichiers sur la ligne de commande, elle s'applique à tous les fichiers répertoriés jusqu'à ce que la commande copy rencontre l'option de ligne de commande /b. Dans ce cas, /b s'applique au fichier qui précède /b.

    L'effet de l'option de ligne de commande /a dépend de sa position dans la chaîne de la ligne de commande. Lorsque l'option de ligne de commande /a suit Source, la commande copy traite le fichier comme un fichier ASCII et copie toutes les données précédant le premier caractère de fin de fichier.

    Lorsque l'option de ligne de commande /a suit Destination, la commande copy ajoute un caractère de fin de fichier comme dernier caractère du fichier.

  • Utilisation de /b

    L'option de ligne de commande /b indique à l'interpréteur de commandes de lire le nombre d'octets spécifié par la taille du fichier dans le répertoire. L'option de ligne de commande /b correspond à la valeur par défaut de copy, à moins que copy combine des fichiers.

    Lorsque l'option de ligne de commande /b précède une liste de fichiers sur la ligne de commande, elle s'applique à tous les fichiers répertoriés jusqu'à ce que la commande copy rencontre l'option de ligne de commande /a. Dans ce cas, /a s'applique au fichier qui précède /a.

    Lorsque l'option de ligne de commande /b suit une liste de fichiers sur la ligne de commande, elle s'applique à tous les fichiers répertoriés jusqu'à ce que la commande copy rencontre l'option de ligne de commande /a. Dans ce cas, /a s'applique au fichier qui précède /a.

    L'effet de l'option de ligne de commande /b dépend de sa position dans la chaîne de la ligne de commande. Lorsque l'option de ligne de commande /b suit Source, la commande copy copie intégralement le fichier, y compris tout caractère de fin de fichier.

    Lorsque l'option de ligne de commande /b suit Destination, la commande copy n'ajoute pas de caractère de fin de fichier.

  • Utilisation de /v

    Si le système ne peut pas vérifier une opération d'écriture, il affiche un message d'erreur. Bien que les erreurs d'enregistrement soient rares avec la commande copy, l'option de ligne de commande /v permet de vérifier que les données critiques ont été correctement enregistrées. En outre, l'option de ligne de commande /v ralentit la commande copy car chaque secteur enregistré sur le disque doit être vérifié.

  • Utilisation de /y et /-y

    Si l'option de ligne de commande /y est prédéfinie dans la variable d'environnement COPYCMD, vous pouvez annuler ce paramètre en spécifiant /-y sur la ligne de commande. Par défaut, vous êtes invité à confirmer le remplacement, sauf si la commande copy est exécutée dans un script de commande.

  • Ajout de fichiers

    Pour ajouter des fichiers, spécifiez un seul fichier de Destination, mais plusieurs fichiers Source (à l'aide de caractères génériques ou du format fichier1+fichier2+fichier3).

  • Utilisation de /z

    Si la connexion est perdue pendant la phase de copie (notamment si le serveur qui est mis hors connexion entrave la connexion), copy /z reprend dès que la connexion est rétablie. En outre, /z affiche le pourcentage de l'opération de copie qui est terminé pour chaque fichier.

  • Copie à destination et à partir de périphériques

    Vous pouvez substituer un nom de périphérique à une ou plusieurs occurrences de Source ou de Destination.

  • Emploi ou omission de l'option de ligne de commande /b lors de la copie à destination d'un périphérique

    Lorsque la Destination est un périphérique (COM1 ou LPT1, par exemple), l'option de ligne de commande /b copie les données sur le périphérique en mode binaire. Dans ce mode, copy /b copie tous les caractères (y compris les caractères spéciaux tels que CTRL+C, CTRL+S, CTRL+Z et le retour chariot) sur le périphérique en tant que données. Toutefois, si vous omettez l'option de ligne de commande /b, le système copie les données sur le périphérique en mode ASCII. Dans ce mode, les caractères spéciaux peuvent amener Windows XP à combiner des fichiers pendant le processus de copie. Pour plus d'informations, consultez « Combinaison de fichiers».

  • Emploi du fichier destination par défaut

    Si vous ne désignez pas de fichier destination, le système crée une copie du même nom et de mêmes date et heure de création que le fichier d'origine et place cette copie dans le répertoire et le lecteur en cours. Si le fichier source se trouve dans le lecteur et le répertoire en cours et si vous ne spécifiez pas de lecteur ou de répertoire différent pour le fichier destination, la commande copy s'arrête et affiche le message d'erreur suivant :

    Le fichier ne peut pas être copié sur lui-même

    0 fichier(s) copié(s)
  • Combinaison de fichiers

    Si vous désignez plus d'une Source, en séparant les entrées par un signe plus (+), copy combine tous les fichiers en un seul. Si vous utilisez des caractères génériques (* ou ?) dans la Source et si vous ne spécifiez qu'un seul nom de fichier dans la Destination, copy combine tous les fichiers qui concordent avec le nom de fichier de la Source et crée un seul fichier portant le nom spécifié dans la Destination. Dans un cas comme dans l'autre, et à moins que vous n'utilisiez l'option de ligne de commande /b, copy suppose que les fichiers combinés sont au format ASCII.

  • Copie de fichiers de longueur nulle

    Copy ne copie pas les fichiers de longueur égale à 0 octet. Pour copier ces fichiers, utilisez la commande xcopy.

  • Changement de l'heure et de la date d'un fichier

    Pour assigner l'heure et la date en cours à un fichier sans le modifier pour autant, utilisez la syntaxe suivante :

    copy /b Source+,,

    Les virgules indiquent l'absence du paramètre Destination.

  • Copie des fichiers de sous-répertoires

    Pour copier tous les fichiers et sous-répertoires d'un répertoire, utilisez la commande xcopy. Pour plus d'informations sur xcopy, consultez Rubriques connexes.

  • La commande copy est disponible dans la console de récupération avec d'autres paramètres.

Exemples

Pour copier un fichier nommé Memo.doc dans Lettre.doc dans le lecteur en cours et garantir la présence d'un caractère de fin de fichier à la fin du fichier copié, tapez :

copy memo.doc lettre.doc /a

Pour copier un fichier nommé Merle.typ du lecteur et du répertoire en cours dans un répertoire existant nommé Oiseaux du lecteur C, tapez :

copy merle.typ c:\oiseaux

Si le répertoire Oiseaux n'existe pas, le système copie le fichier Merle.typ dans un fichier nommé Oiseaux placé dans le répertoire racine du disque du lecteur C.

Pour copier plusieurs fichiers dans un seul fichier, indiquez plusieurs fichiers Source, séparez leurs noms par un signe positif (+) et spécifiez le fichier Destination qui doit contenir le fichier combiné final. Par exemple, pour combiner Mar89.rpt, Avr89.rpt et Mai89.rpt, situés dans les lecteur et répertoire en cours, et les placer dans un fichier nommé Rapport dans les lecteur et répertoire en cours, tapez :

copy mar89.rpt + avr89.rpt + mai89.rpt rapport

Lorsque vous combinez des fichiers, copy marque le fichier destination avec la date et l'heure en cours. Si vous omettez la Destination, le système combine les fichiers et enregistre le résultat sous le nom du premier fichier spécifié. Si, par exemple, un fichier nommé Rapport existe déjà, la syntaxe suivante réunit les quatre fichiers dans Rapport :

copy rapport + mar89.rpt + avr89.rpt + mai89.rpt

Vous pouvez aussi combiner plusieurs fichiers en un seul au moyen de caractères génériques (* ou ?). Par exemple, pour réunir tous les fichiers du répertoire et du lecteur en cours qui sont dotés de l'extension .txt en un seul fichier nommé Combin.doc, tapez :

copy *.txt combin.doc

Si vous souhaitez combiner plusieurs fichiers binaires en un seul au moyen de caractères génériques, incluez l'option de ligne de commande /b. Cette commande empêche Windows XP de traiter CTRL+Z comme un caractère de fin de fichier. Par exemple, tapez :

copy /b *.exe combin.exe

Attention

  • Si vous combinez des fichiers binaires, il est possible que le fichier résultant de l'opération soit inutilisable en raison des mises en forme internes.

Dans l'exemple suivant, la commande copy combine chaque fichier doté de l'extension .txt au fichier .ref correspondant. Le résultat est un fichier portant le même nom, mais suivi cette fois de l'extension .doc. La commande copy combine Fichier1.txt avec Fichier1.ref pour former Fichier1.doc, puis combine Fichier2.txt avec Fichier2.ref pour former Fichier2.doc, etc. Par exemple, tapez :

copy *.txt + *.ref *.doc

Pour combiner tous les fichiers dotés de l'extension .txt puis tous ceux portant l'extension .ref en un seul fichier nommé Combin.doc, tapez :

copy *.txt + *.ref combin.doc


Country

Permet au sous-système MS-DOS d'utiliser les formats appropriés à d'autres pays pour l'heure, la date, le symbole monétaire, la conversion des caractères et les séparateurs décimaux.

Syntaxe

country=xxx[,[yyy][,[Lecteur:][Chemin] NomFichier]]

Paramètres

xxx
Indique le code du pays/région.
yyy
Indique la page de codes du pays/région.
[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du fichier qui comprend des informations relatives au pays/région.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • La commande country configure le sous-système MS-DOS de manière à ce qu'il reconnaisse l'ensemble des caractères et autres conventions de ponctuation appropriées lors de l'utilisation de l'une des langues prises en charge par le système. Utilisez le fichier %racine_système%\System2\Config.nt ou le fichier de démarrage équivalent spécifié dans le fichier PIF (Program Information File) d'un programme pour charger le paramètre Country/Region.
  • Liste des langues prises en charge

    Chaque langue ou pays/région pris en charge par le sous-système MS-DOS est indiqué dans le tableau ci-dessous. Les pages de codes que vous pouvez utiliser avec chaque code de pays/région sont également indiquées. Si vous utilisez le code de pays/région 003, par exemple, vous devez utiliser la page de codes 437 ou 850 pour le paramètre yyy. La première des deux pages de codes énumérées pour chaque pays/région est la page de codes par défaut.

    Pays/région ou langue | Code de pays/région | Pages de codes
    États-Unis | 001 | 437, 850
    Français (Canada) | 002 | 863, 850
    Pays-Bas | 031 | 850, 437
    Belgique | 032 | 850, 437
    France | 033 | 850, 437
    Espagne | 034 | 850, 437
    Hongrie | 036 | 852, 850
    Italie | 039 | 850, 437
    Suisse | 041 | 850, 437
    République tchèque | 042 | 852, 850
    Slovaquie | 042 | 852, 850
    Royaume-Uni | 044 | 437, 850
    Danemark | 045 | 850, 865
    Suède | 046 | 850, 437
    Norvège | 047 | 850, 865
    Pologne | 048 | 852, 850
    Allemagne | 049 | 850, 437
    Brésil | 055 | 850, 437
    Anglais (International) | 061 | 437, 850
    Portugal | 351 | 850, 860
    Finlande | 358 | 850, 437
  • Formats internationaux de date et d'heure

    Le code de pays/région indique les formats de date et d'heure utilisés avec les commandes suivantes : backup, date et time.

    Les formats d'heure et de date de chaque code de pays/région sont indiqués dans le tableau suivant. Pour chaque code de pays/région, la colonne Format de date affiche le format approprié pour la date du 3 janvier 1994 et la colonne Format horaire affiche le format approprié pour indiquer 17:35 (avec 0 seconde et 0 centième de seconde).

    Pays/région ou langue | Code de pays/région | Format de date | Format horaire
    États-Unis | 001 | 01/03/1994 | 5:35:00.00p
    Français (Canada) | 002 | 1994-01-03 | 17:35:00
    Amérique latine | 003 | 03/01/1994 | 5:35:00.00p
    Pays-Bas | 031 | 03-01-94 | 17:35:00
    Belgique | 032 | 03/01/94 | 17:35:00
    France | 033 | 03.01.1994 | 17:35:00
    Espagne | 034 | 3/01/94 | 17:35:00
    Hongrie | 036 | 1994.01.03 | 17:35:00
    Italie | 039 | 03/01/94 | 17.35.00
    Suisse | 041 | 03.01.94 | 17 35.00
    République tchèque | 042 | 03.01.1994 | 17:35:00
    Slovaquie | 042 | 03.01.1994 | 17:35:00
    Royaume-Uni | 044 | 03/01/94 | 17:35:00.00
    Danemark | 045 | 03-01-94 | 17.35.00
    Suède | 046 | 1994-01-03 | 17.35.00
    Norvège | 047 | 03.01.94 | 17:35:00
    Pologne | 048 | 1994-01-03 | 17:35:00
    Allemagne | 049 | 03.01.1994 | 17:35:00
    Brésil | 055 | 03/01/94 | 17:35:00
    Anglais (International) | 061 | 03/01/1994 | 17:35:00.00
    Portugal | 351 | 03-01-1994 | 17:35:00
    Finlande | 358 | 3.1.1994 | 17.35.00

Exemples

Pour convertir le format international de la monnaie, l'heure, la date et les caractères aux conventions françaises, ajoutez la commande suivante au fichier Config.nt :

country=033

Pour indiquer une page de codes avec le code de pays de la France, tapez :

country=033,850

Si vous n'ajoutez pas la page de codes mais incluez le paramètre [Lecteur:][Chemin] NomFichier, vous devez quand même taper la virgule qui aurait précédé la page de codes, comme le montre l'exemple suivant :

country=033,,c:\winnt\system32\country.sys


Date

Affiche la date système en cours. Utilisée sans paramètre, la commande date affiche la date système en cours et vous invite à taper une nouvelle date.

Syntaxe

date [mm-jj-aa] [/t]

Paramètres

mm-jj-aa
Définit la date spécifiée, où mm représente le mois, jj le jour et aa l'année.
/t
Affiche la date en cours sans invite d'une nouvelle date.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Vous devez séparer les valeurs mm, jj et aa par des points (.), des traits d'union (-) ou des barres obliques (/).
  • Les valeurs admises pour mm sont comprises entre 1 et 12.
  • Les valeurs admises pour jj sont comprises entre 1 et 31.
  • Les valeurs admises pour aa sont comprises entre 80 et 99 ou 1980 et 2099
  • Windows XP est programmé pour changer correctement le mois et l'année, quel que soit le nombre de jours du mois (28, 29, 30 ou 31).

Exemples

Pour instaurer la date du 3 août 2000, tapez l'une des syntaxes suivantes :

08.03.00

08-03-00

08/03/00

Pour afficher la date système en cours, tapez :

date /t


Debug

Démarre Debug.exe, programme permettant de tester et de déboguer les fichiers exécutables MS-DOS. Utilisée sans paramètre, la commande debug démarre Debug.exe et affiche l'invite debug sous la forme d'un trait d'union (-).

Syntaxe

debug [[Lecteur:][Chemin] NomFichier [paramètres]]

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du fichier exécutable à tester.
paramètres
Indique toute information de ligne de commande requise par le fichier exécutable à tester.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Utilisation des commandes du sous-système MS-DOS

    Debug est une commande du sous-système MS-DOS qui s'exécute sous WOW et NTVDM.

  • Séparation des paramètres des commandes

    Vous pouvez séparer ces paramètres par des virgules ou des espaces, mais ces séparateurs ne sont requis qu'entre deux valeurs hexadécimales. Les commandes suivantes sont donc équivalentes :

    dcs:100 110

    d cs:100 110

    d,cs:100,110

  • Utilisation des sous-commandes debug

    Vous pouvez utiliser plusieurs sous-commandes debug. Pour plus d'informations sur les sous-commandes debug, consultez Rubriques connexes.


Debug : a (assemble)

Assemble les codes mnémoniques des 8086/8087/8088 directement dans la mémoire. Utilisée sans paramètre, la sous-commande a commence l'assemblage où il s'était arrêté précédemment.

Syntaxe

a [adresse]

Paramètres

adresse
Indique l'emplacement où vous tapez les codes mnémoniques du langage d'assemblage. Utilisez des valeurs hexadécimales pour l'adresse et tapez chaque valeur sans le caractère h à droite.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Spécification des préfixes mnémoniques

    Spécifiez un préfixe mnémonique à gauche du code opération (opcode) auquel il se réfère. La sous-commande a crée un code machine exécutable à partir d'instructions en langage d'assemblage. Toutes les valeurs numériques sont en notation hexadécimale et vous devez les taper sous forme de suite de 1 à 4 caractères.

  • Emploi de codes mnémoniques

    Les codes mnémoniques qui ignorent les segments sont cs:, ds:, es: et ss:. Celui du retour far est retf. Les codes mnémoniques de manipulation de chaîne doivent indiquer explicitement la taille de la chaîne. Utilisez, par exemple, movsw pour déplacer des chaînes de mots (16 bits) et movsb pour déplacer des chaînes d'octets (8 bits).

  • Assemblage de sauts et d'appels

    L'assembleur assemble automatiquement les sauts ou les appels (court, near ou far) selon le déplacement en octets vers l'adresse de destination. Pour procéder à des sauts ou à des appels différents, vous pouvez utiliser un préfixe near ou far. Par exemple :

    -a0100:0500
    0100:0500 jmp 502 ; saut court de 2 octets
    0100:0502 jmp near 505 ; saut near de 3 octets
    0100:0505 jmp far 50a ; saut far de 5 octets

    Vous pouvez abréger le préfixe near sous la forme ne.

  • Distinction des emplacements mémoire du type mot et du type octet

    Lorsqu'un opérande renvoie à un emplacement mémoire du type mot ou octet, vous devez spécifier le type des données au moyen du préfixe word ptr ou byte ptr, qu'il est possible d'abréger respectivement en wo et by. Par exemple :

    dec wo [si]
    neg byte ptr [128]

  • Spécification des opérandes

    Debug.exe utilise la convention courante qui veut qu'un opérande encadré par des crochets [ ] renvoie à un emplacement mémoire. C'est la seule façon dont Debug.exe peut distinguer un opérande immédiat d'un opérande représentant un emplacement mémoire. Par exemple :

    mov ax,21 ; charge AX avec 21h
    mov ax,[21] ; charge dans AX le contenu de
    ;
    ; l'emplacement mémoire 21h

  • Emploi de pseudo-instructions

    Deux pseudo-instructions courantes sont disponibles avec la sous-commande a : le code opération db, qui assemble les valeurs d'octets directement dans la mémoire, et le code opération dw, qui assemble les mots directement en mémoire. Par exemple :

    db 1,2,3,4,"VOICI UN EXEMPLE"
    db VOICI DES GUILLEMETS : "'
    db "VOICI UNE APOSTROPHE : '"
    dw 1000,2000,3000,"BACH"

  • Entrée de données dans des octets spécifiques

    Pour plus d'informations sur l'entrée de données dans des octets spécifiques à l'aide de la sous-commande e (enter), consultez Rubriques connexes.

  • Désassemblage des octets

    Pour plus d'informations sur le désassemblage des octets à l'aide de la sous-commande u (unassemble), consultez Rubriques connexes.

Exemples

La sous-commande a prend en charge toutes les formes de commandes indirectes sur registres. Par exemple :

add bx,34[bp+2].[si-1]
pop [bp+di]
push [si] )

La sous-commande a prend également en charge tous les synonymes des codes opération. Par exemple :

loopz 100
loope 100
ja 200
jnbe 200

Pour les codes opération du 8087, vous devez utiliser le préfixe wait ou fwait. Par exemple :

fwait fadd st,st(3) ; cette ligne assemble
; un préfixe fwait


Debug : c (compare)

Compare deux zones de mémoire.

Syntaxe

c adresse_plage

Paramètres

plage
Requis. Indique les adresses de début et de fin de la première zone de mémoire à comparer ou son adresse de début et sa longueur.
adresse
Requis. Indique l'adresse de début de la seconde zone de mémoire à comparer.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées de plage valides

    Utilisez plage avec une sous-commande debug pour spécifier une plage de mémoire. Vous pouvez choisir l'un des formats de plage suivants : une adresse de début et une adresse de fin ou une adresse de début et la longueur (représentée par l) de la plage. Les syntaxes suivantes, par exemple, spécifient toutes deux une plage de 16 octets commençant à l'adresse CS:100 :

    cs:100 10f

    cs:100 l 10
  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Si les zones mémoire spécifiées par plage et adresse sont identiques, la sous-commande c n'affiche rien et vous ramène à l'invite debug. Si elles sont différentes, c les affiche sous la forme suivante :

    adresse1 octet1 octet2 adresse2

Exemples

Pour comparer le bloc de mémoire allant de 100h à 10Fh à celui allant de 300h à 30Fh, tapez :

c100,10f 300

ou

c100l10 300

Ces deux commandes génèrent le résultat suivant (dans l'hypothèse où DS a pour valeur 197F) :

197F:0100 4D E4 197F:0300
197F:0101 67 99 197F:0301
197F:0102 A3 27 197F:0302
197F:0103 35 F3 197F:0303
197F:0104 97 BD 197F:0304
197F:0105 04 35 197F:0305
197F:0107 76 71 197F:0307
197F:0108 E6 11 197F:0308
197F:0109 19 2C 197F:0309
197F:010A 80 0A 197F:030A
197F:010B 36 7F 197F:030B
197F:010C BE 22 197F:030C
197F:010D 83 93 197F:030D
197F:010E 49 77 197F:030E
197F:010F 4F 8A 197F:030F

Les adresses 197F:0106 et 197F:0306 ne figurent pas dans la liste. Cela signifie que les valeurs de ces adresses sont identiques.


Debug : d (dump)

Affiche le contenu d'une plage d'adresses mémoire. Utilisée sans paramètre, la sous-commande d affiche le contenu de 128 octets, qui commence à partir de la fin de la plage d'adresses spécifiée dans la sous-commande d précédente.

Syntaxe

d [plage]

Paramètres

plage
Indique les adresses de début et de fin, ou l'adresse de début et la taille de la zone mémoire dont vous souhaitez afficher le contenu.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées de plage valides

    Utilisez plage avec une sous-commande debug pour spécifier une plage de mémoire. Vous pouvez choisir l'un des formats de plage suivants : une adresse de début et une adresse de fin ou une adresse de début et la longueur (représentée par l) de la plage. Les syntaxes suivantes, par exemple, spécifient toutes deux une plage de 16 octets commençant à l'adresse CS:100 :

    cs:100 10f

    cs:100 l 10
  • Lorsque vous utilisez la sous-commande d, Debug.exe affiche le contenu de la mémoire en deux parties : une partie hexadécimale (chaque valeur d'octet étant représentée au format hexadécimal) et une partie ASCII (qui représente chaque valeur d'octet sous la forme d'un caractère ASCII). Dans la section ASCII de l'affichage, chaque caractère non imprimable est représenté par un point (.). Chaque ligne d'affichage indique le contenu de 16 octets, un trait d'union apparaissant entre le huitième et le neuvième octets. Chaque ligne d'affichage commence sur la ligne de démarcation d'une tranche de 16 octets.
  • Pour plus d'informations sur l'affichage du contenu des registres à l'aide de la sous-commande r (register), consultez Rubriques connexes.

Exemples

Tapez :

dcs:100 10f

Debug.exe affiche le contenu de cette plage sous la forme suivante :

04BA:0100 54 4F 4D 00 53 41 57 59-45 52 00 00 00 00 00 00.....

Si vous tapez la sous-commande d sans paramètre, Debug.exe affiche le résultat sous la même forme que dans l'exemple précédent. Chaque ligne de la fenêtre Invite de commandes commence par une adresse supérieure de 16 octets à celle de la ligne précédente (ou 8 octets si vous utilisez un écran de 40 colonnes). Pour chaque sous-commande d suivante que vous tapez sans paramètre, Debug.exe affiche les octets immédiatement après ceux affichés précédemment.

Pour afficher le contenu de 20h octets à partir de CS:100, tapez :

dcs:100 l 20

Pour afficher le contenu de tous les octets de la plage des lignes 100h à 115h du segment CS, tapez :

dcs:100 115


Debug : e (enter)

Entre des données en mémoire à l'adresse spécifiée.

Syntaxe

e adresse [liste]

Paramètres

adresse
Requis. Indique le premier emplacement mémoire où vous voulez entrer les données.
liste
Représente les données que vous voulez entrer dans des octets de mémoire successifs.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Utilisation du paramètre adresse

    Si vous spécifiez une valeur pour l'adresse sans en indiquer une pour le paramètre facultatif liste, Debug.exe affiche l'adresse et son contenu, répète l'adresse sur la ligne suivante et attend que vous entriez des données. À ce stade, vous pouvez effectuer l'une des opérations suivantes :

    • Remplacer la valeur de l'octet. Il vous suffit pour cela de taper une nouvelle valeur à la suite de la valeur actuelle. Si la valeur tapée ne représente pas une valeur hexadécimale valide ou si elle contient plus de deux chiffres, Debug.exe ne renvoie pas en écho le caractère non valide ou superflu.
    • Avancer jusqu'à l'octet suivant. Il vous suffit pour cela d'appuyer sur la touche ESPACE. Pour changer la valeur de cet octet, tapez une nouvelle valeur à la suite de la valeur actuelle. Si vous dépassez une ligne de démarcation de 8 octets lorsque vous appuyez sur ESPACE, Debug.exe commence une nouvelle ligne d'affichage et affiche la nouvelle adresse au début de cette ligne.
    • Revenir à l'octet précédent. Pour cela, appuyez sur la touche -. Vous pouvez aussi appuyer sur cette touche à plusieurs reprises pour reculer de plus de 1 octet. Lorsque vous appuyez sur -, Debug.exe commence une nouvelle ligne et affiche l'adresse en cours ainsi que la valeur de l'octet.
    • Arrêter la sous-commande e. Pour cela, appuyez sur la touche ENTRÉE. Vous pouvez appuyer sur cette touche à partir de n'importe quel octet.
  • Utilisation du paramètre liste

    Si vous spécifiez des valeurs pour le paramètre liste, la sous-commande e remplace séquentiellement les valeurs existantes des octets par les valeurs de la liste. En cas d'erreur, aucun octet n'est remplacé.

    Les valeurs de la liste peuvent être des valeurs d'octet hexadécimales ou des chaînes. Pour séparer les valeurs, utilisez un espace, une virgule ou un caractère de tabulation. Les chaînes doivent obligatoirement être encadrées par des apostrophes ('chaîne') ou des guillemets ("chaîne").

  • Assemblage des codes mnémoniques

    Pour plus d'informations sur l'assemblage des codes mnémoniques à l'aide de la sous-commande a (assemble), consultez Rubriques connexes.

  • Affichage du contenu d'une zone de mémoire

    Pour plus d'informations sur l'affichage du contenu d'une partie de la mémoire à l'aide de la sous-commande d (dump), consultez Rubriques connexes.

Exemples

Tapez :

ecs:100

Debug.exe affiche le contenu du premier octet sous la forme suivante :

04BA:0100 EB._

Pour remplacer cette valeur par 41, tapez 41 au niveau du point d'insertion, comme suit :

04BA:0100 EB.41_

Il est possible d'utiliser une seule sous-commande e pour taper des valeurs d'octets consécutives. Au lieu d'appuyer sur la touche ENTRÉE après avoir tapé la nouvelle valeur, appuyez sur la touche ESPACE. Debug.exe affiche la valeur suivante. Dans cet exemple, si vous appuyez trois fois sur ESPACE, Debug.exe affiche les valeurs ci-dessous :

04BA:0100 EB.41 10. 00. BC._

Pour remplacer la valeur hexadécimale BC par 42, tapez 42 au niveau du point d'insertion, comme suit :

04BA:0100 EB.41 10. 00. BC.42_

Pour remplacer 10 par 6F, appuyez sur la touche - à deux reprises afin de revenir à l'adresse 0101 (valeur 10). Debug.exe affiche les éléments suivants :

04BA:0100 EB.41 10. 00. BC.42-
04BA:0102 00.-
04BA:0101 10._

Pour remplacer la valeur, tapez 6F au niveau du point d'insertion, comme suit :

04BA:0101 10.6F_

Pour mettre fin à la sous-commande e et revenir à l'invite debug, appuyez sur ENTRÉE.

L'exemple suivant illustre l'entrée d'une chaîne :

eds:100 "Voici l'exemple texte"

Cette chaîne remplit 24 octets à partir de DS:100.


Debug : f (fill)

Remplit les adresses de la zone mémoire désignée à l'aide des valeurs que vous spécifiez.

Syntaxe

f plage liste

Paramètres

plage
Requis. Indique les adresses de début et de fin de la zone mémoire à remplir ou son adresse de début et sa longueur.
liste
Requis. Spécifie les données à entrer.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées de plage valides

    Utilisez plage avec une sous-commande debug pour spécifier une plage de mémoire. Vous pouvez choisir l'un des formats de plage suivants : une adresse de début et une adresse de fin ou une adresse de début et la longueur (représentée par l) de la plage. Les syntaxes suivantes, par exemple, spécifient toutes deux une plage de 16 octets commençant à l'adresse CS:100 :

    cs:100 10f

    cs:100 l 10
  • Spécification des données

    Les données peuvent être spécifiées sous forme hexadécimale ou ASCII. Toutes les données précédemment stockées, le cas échéant, à l'adresse spécifiée sont perdues.

  • Utilisation de liste

    La liste peut être constituée de nombres hexadécimaux ou d'une chaîne encadrée par des guillemets ("chaîne").

Exemples

Pour remplir les emplacements mémoire 04BA:100 à 04BA:1FF à l'aide de cinq valeurs spécifiques (par exemple, 42, 45, 52, 54 et 41) et répéter les cinq valeurs jusqu'à ce que Debug.exe ait rempli les 100h octets, tapez :

f04ba:100l100 42 45 52 54 41


Debug : g (go)

Exécute le programme qui se trouve en mémoire. Utilisée sans paramètre, la sous-commande g s'exécute à partir de l'adresse courante dans les registres CS:IP.

Syntaxe

g [=adresse] [points_arrêt]

Paramètres

adresse
Spécifie l'adresse du programme actuellement en mémoire à partir de laquelle vous souhaitez exécuter celui-ci.
points_arrêt
Spécifie 1 à 10 points d'arrêt temporaires que vous pouvez définir comme faisant partie de la sous-commande g.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Utilisation du paramètre adresse

    Faites précéder le paramètre adresse par un signe égal (=) afin de distinguer adresse des adresses des points d'arrêt (points_d'arrêt).

  • Spécification des points d'arrêt

    Le programme s'arrête au premier point d'arrêt rencontré, quelle que soit la position de ce dernier dans la liste points_arrêt. À chacun de ces points, Debug.exe remplace l'instruction d'origine par un code d'interruption.

    Lorsque le programme atteint un point d'arrêt, Debug.exe rétablit les instructions d'origine aux adresses de tous les points d'arrêt et affiche le contenu de tous les registres, l'état de tous les indicateurs et la forme décodée de la dernière instruction exécutée. Debug.exe affiche les mêmes informations que lorsque vous utilisez la sous-commande r (register) et spécifiez l'adresse des points d'arrêt.

    Si vous n'arrêtez pas le programme à l'un des points d'arrêt, Debug.exe ne remplace pas les codes d'interruption par les instructions d'origine.

    Vous ne pouvez définir des points d'arrêt qu'aux adresses contenant le premier octet d'un code opération 8086. Au-delà de 10 points d'arrêt, Debug.exe affiche le message suivant :

    bp erreur

  • Utilisation du pointeur de pile de l'utilisateur

    Le pointeur de pile de l'utilisateur doit être valide et doit posséder 6 octets disponibles pour la sous-commande g. La sous-commande g utilise une instruction iret pour passer au programme à tester. Debug.exe définit le pointeur de pile de l'utilisateur et place les indicateurs, le registre des segments de code ainsi que le pointeur d'instruction dans la pile de l'utilisateur. (Si la pile de l'utilisateur n'est pas valide ou est trop petite, le système d'exploitation peut échouer.) Debug.exe place en outre un code d'interruption (0CCh) à l'adresse ou aux adresses du point d'arrêt spécifié.

  • Redémarrage d'un programme

    N'essayez pas de redémarrer un programme après que le système affiche le message suivant :

    Fin normale du programme.

    Pour exécuter correctement le programme, rechargez-le au moyen des sous-commandes n (Name) et l (Load).

  • Pour plus d'informations sur l'exécution d'une boucle, d'une instruction de chaîne répétée, d'une interruption au niveau du logiciel ou d'un sous-programme à l'aide de la sous-commande p (proceed), consultez Rubriques connexes.
  • Pour plus d'informations sur l'exécution d'une instruction à l'aide de la sous-commande t (trace), consultez Rubriques connexes.

Exemples

Pour exécuter le programme qui se trouve en mémoire jusqu'à l'adresse 7550 du point d'arrêt dans le segment CS, tapez :

gcs:7550

Debug.exe affiche le contenu des registres et l'état des indicateurs, puis met fin à la sous-commande g.

Pour définir deux points d'arrêt, tapez :

gcs:7550, cs:8000

Si vous retapez la sous-commande g après que Debug.exe a rencontré un point d'arrêt, l'exécution commence au niveau de l'instruction qui suit ce point, et non pas à l'adresse de début.


Debug : h (hexadecimal)

Effectue des opérations arithmétiques hexadécimales sur deux paramètres que vous spécifiez.

Syntaxe

h valeur1valeur2

Paramètres

valeur1
Requis. Représente n'importe quel nombre hexadécimal compris entre 0 et FFFFh.
valeur2
Requis. Représente un second nombre hexadécimal compris entre 0 et FFFFh.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Debug.exe ajoute les deux paramètres spécifiés, puis retranche le second du premier. Les résultats de ces calculs sont affichés sur une seule ligne : d'abord la somme, puis la différence.

Exemples

Tapez :

h19f 10a

Debug.exe effectue les calculs et affiche le résultat suivant :

02A9 0095


Debug : i (input)

Lit et affiche une seule valeur d'octet provenant du port spécifié.

Syntaxe

i port

Paramètres

port
Requis. Spécifie le port d'entrée à l'aide de l'adresse. Cette dernière peut être une valeur 16 bits.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Pour plus d'informations sur l'envoi d'un octet à un port de sortie à l'aide de la sous-commande o (output), consultez Rubriques connexes.

Exemples

Tapez :

i2f8

Si la valeur de l'octet sur le port est 42h, Debug.exe lit l'octet et affiche la valeur comme suit :

42


Debug : l (load)

Charge un fichier ou le contenu de secteurs spécifiques du disque en mémoire. Utilisée sans paramètre, la sous-commande l charge le fichier désigné sur la ligne de commande debug en mémoire à partir de l'adresse CS:100. Debug.exe assigne aussi aux registres BX et CX le nombre d'octets chargés. En l'absence d'un nom de fichier sur la ligne de commande debug, le fichier chargé est le fichier le plus récemment désigné au moyen de la sous-commande n (name).

Syntaxe

l [adresse]

l [adresse] [Lecteur] [PremierSecteur] [nombre]

Paramètres

adresse
Désigne l'adresse mémoire où vous voulez charger le fichier ou le contenu des secteurs. En l'absence de ce paramètre, Debug.exe utilise l'adresse actuelle dans le registre CS.
Lecteur
Désigne le lecteur qui contient le disque dont vous voulez lire des secteurs spécifiques. Cette valeur est numérique : 0 = A, 1 = B, 2 = C, etc.
PremierSecteur
Représente, sous forme hexadécimale, le numéro du premier secteur à partir duquel vous voulez charger le contenu.
nombre
Représente, sous forme hexadécimale, le nombre de secteurs consécutifs dont vous voulez charger le contenu. Utilisez uniquement Lecteur, PremierSecteur et nombre si vous voulez charger le contenu de secteurs spécifiques au lieu du fichier spécifié sur la ligne de commande debug ou dans la sous-commande n (name) la plus récente.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Pour charger à partir d'un fichier sur disque le contenu des octets dont le nombre est spécifié par les registres BX:CX, utilisez la syntaxe suivante :

    l [adresse]

  • Pour court-circuiter le système de fichiers et charger directement le contenu de secteurs spécifiques, utilisez la syntaxe ci-dessous :

    l [adresse] [Lecteur] [PremierSecteur] [nombre]

  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Utilisation du paramètre adresse

    Si vous utilisez la sous-commande l avec le paramètre adresse, Debug.exe commence à charger le fichier ou le contenu des secteurs spécifiés à l'emplacement mémoire désigné par cette adresse.

  • Emploi de tous les paramètres

    Si vous utilisez la sous-commande l avec tous les paramètres, Debug.exe charge le contenu de secteurs de disque spécifiques au lieu de charger un fichier.

  • Chargement du contenu de secteurs spécifiques

    Chaque secteur de la plage spécifiée est lu à partir du Lecteur. Debug.exe commence par charger le secteur PremierSecteur, puis continue à charger les secteurs suivants jusqu'à concurrence du nombre spécifié.

  • Chargement d'un fichier .exe

    Debug.exe ne tient pas compte du paramètre adresse avec des fichiers .exe. Si vous désignez un tel fichier, Debug.exe le replace à l'adresse de chargement indiquée dans l'en-tête du fichier .exe. Comme cet en-tête est lui-même supprimé du fichier .exe avant le chargement du fichier en mémoire, la taille d'un fichier .exe sur disque est différente de sa taille en mémoire. Si vous désirez examiner un fichier .exe complet, renommez-le en lui donnant une extension différente.

  • Ouverture d'un fichier .hex

    Debug.exe suppose que les fichiers dotés de l'extension .hex se présentent sous le format hexadécimal. Utilisée sans paramètre, la sous-commande l charge un fichier hexadécimal à partir de l'adresse spécifiée dans ce fichier. Si la sous-commande l que vous tapez inclut le paramètre adresse, Debug.exe ajoute l'adresse spécifiée à celle qui se trouve dans le fichier hexadécimal afin de déterminer l'adresse de début.

  • Pour plus d'informations sur la spécification d'un fichier à l'aide de la sous-commande n (name), consultez Rubriques connexes.
  • Pour plus d'informations sur l'écriture d'un fichier en cours de débogage sur un disque à l'aide de la sous-commande w (write), consultez Rubriques connexes.

Exemples

À l'invite de commandes, tapez :

debug

Tapez :

nfichier.com

Pour charger Fichier.com, tapez :

l

Debug.exe charge le fichier et affiche l'invite debug.

Pour charger le contenu de 109 (6Dh) secteurs du lecteur C à partir du secteur logique 15 (0Fh) en mémoire depuis l'adresse 04BA:0100, tapez :

l04ba:100 2 0f 6d


Debug : m (déplacer)

Copie le contenu d'un bloc de mémoire dans un autre bloc de mémoire.

Syntaxe

m plage adresse

Paramètres

plage
Requis. Indique les adresses de début et de fin de la zone de mémoire dont vous voulez copier le contenu, ou son adresse de début et sa longueur.
adresse
Requis. Indique l'adresse de début de la zone où vous voulez copier le contenu de la plage.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées de plage valides

    Utilisez plage avec une sous-commande debug pour spécifier une plage de mémoire. Vous pouvez choisir l'un des formats de plage suivants : une adresse de début et une adresse de fin ou une adresse de début et la longueur (représentée par l) de la plage. Les syntaxes suivantes, par exemple, spécifient toutes deux une plage de 16 octets commençant à l'adresse CS:100 :

    cs:100 10f

    cs:100 l 10
  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Copie de données

    Si de nouvelles données ne sont pas écrites aux adresses du bloc que vous copiez, les données d'origine restent intactes. Si, toutefois, le bloc destination contient déjà des données (ce qui est possible dans une opération de copie superposée), ces données sont remplacées. (Les opérations de copie superposée sont celles où une partie du bloc destination se superpose à une partie du bloc source.)

  • Copies superposées

    La sous-commande m effectue des opérations de copie superposée sans perdre les données des adresses destination. En effet, le contenu des adresses remplacées est copié d'abord. Si des données doivent être copiées des adresses supérieures aux adresses inférieures, la copie commence à l'adresse la plus basse du bloc source et progresse vers l'adresse la plus haute. Inversement, si des données doivent être copiées des adresses inférieures aux adresses supérieures, la copie commence à l'adresse la plus haute du bloc source et progresse jusqu'à l'adresse la plus basse.

Exemples

Pour copier le contenu de l'adresse CS:110 à l'adresse CS:510, puis le contenu de CS:10F à CS:50F, et ainsi de suite jusqu'à ce que le contenu de CS:100 à CS:500 soit copié, tapez :

mcs:100 110 cs:500

Pour examiner les résultats de l'opération, utilisez la sous-commande d (dump) en indiquant l'adresse destination utilisée avec la sous-commande m.


Debug : n (name)

Indique le nom d'un fichier exécutable pour une sous-commande debug l (load) ou w (write) ou spécifie les paramètres du fichier exécutable en cours de débogage. Utilisée sans paramètres, n supprime les spécifications courantes.

Syntaxe

n [Chemin][Exécutable]

n [ParamètresFichier]

Paramètres

[Chemin][Exécutable]
Indique l'emplacement et le nom du fichier exécutable à tester.
[ParamètresFichier]
Spécifie les paramètres et les options de ligne de commande à utiliser pour le fichier exécutable en cours de test.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Utilisation de la sous-commande n

    Il est possible d'utiliser la sous-commande n de deux manières différentes. Vous pouvez d'abord vous en servir pour désigner un fichier devant être utilisé par une sous-commande l (load) ou w (write) subséquente. Si vous démarrez Debug.exe sans désigner le fichier à déboguer, vous devez utiliser la commande n NomFichier avant de pouvoir faire appel à l pour charger le fichier. Le nom de fichier est correctement formaté pour un bloc de gestion de fichier (FCB) à l'adresse CS:5C. Vous pouvez aussi employer n pour spécifier des paramètres de ligne de commande et des options de ligne de commande pour le fichier en cours de débogage.

  • Zones de mémoire

    Le tableau ci-dessous présente les quatre zones de mémoire que la commande n peut affecter :

    Adresse mémoire | Sommaire
    CS:5C | Bloc de gestion (FCB) du fichier 1
    CS:6C | Bloc de gestion (FCB) du fichier 2
    CS:80 | Longueur de la ligne de commande n (en caractères)
    CS:81 | Début des caractères de la ligne de commande n

    Le premier nom de fichier spécifié pour la commande n est placé dans un bloc de gestion de fichier (FCB) à l'adresse CS:5C. Si vous spécifiez un second nom de fichier, ce nom est placé dans un FCB à l'adresse CS:6C. Le nombre de caractères tapé sur la ligne de commande n (à l'exclusion du premier caractère, c'est-à-dire n) est stocké à l'adresse CS:80. Les caractères de la ligne de commande n eux-mêmes (à l'exclusion, ici encore, de la lettre n) sont stockés à partir de CS:81. Remarquez que ces caractères peuvent être n'importe quelles options de ligne de commande et délimiteurs qui seraient valides dans une commande tapée à l'invite de commandes.

  • Pour plus d'informations sur le chargement en mémoire du contenu d'un fichier ou de secteurs spécifiques du disque à l'aide de la sous-commande l (load), consultez Rubriques connexes.
  • Pour plus d'informations sur l'écriture du fichier à déboguer sur un disque à l'aide de la sous-commande w (write), consultez Rubriques connexes.

Exemples

Cet exemple vous permet d'exécuter debug et de charger le programme Prog.com en vue de le déboguer. Afin de spécifier deux paramètres pour Prog.com et d'exécuter le programme, tapez :

debug prog.com
nparam1 param2
g

Dans ce cas, la sous-commande g (go) exécute le programme comme si vous tapiez la commande suivante à l'invite de commandes :

prog param1 param2

Le test et le débogage reflètent pour Prog.com un environnement d'exécution caractéristique.

Dans la séquence de commandes ci-dessous, la première sous-commande n désigne Fichier1.exe comme fichier soumis à la sous-commande l (load) suivante, laquelle charge Fichier1.exe en mémoire. La seconde sous-commande n indique les paramètres devant être utilisés par Fichier1.exe. Enfin, la sous-commande g (go) exécute Fichier1.exe comme si vous tapiez Fichier1 Fichier2.dat Fichier2.dat à l'invite de commandes.

nfichier1.exe
l
nfichier2.dat fichier3.dat
g

N'utilisez pas la sous-commande l après la deuxième instance de la sous-commande n. Si vous utilisez la sous-commande w (write) après la deuxième instance de la sous-commande n, Fichier1.exe (le fichier en cours de débogage) est enregistré sous le nom Fichier2.dat. Pour éviter ce résultat, utilisez toujours la première forme de la sous-commande n immédiatement avant une sous-commande l ou w.


Debug : o (output)

Envoie la valeur d'un octet à un port de sortie.

Syntaxe

o port valeur-octet

Paramètres

port
Requis. Spécifie le port de sortie à l'aide de l'adresse. Cette dernière peut être une valeur 16 bits.
valeur-octet
Requis. Indique la valeur de l'octet que vous voulez envoyer au port.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Pour plus d'informations sur la lecture de la valeur d'un octet à partir d'un port d'entrée à l'aide de la sous-commande i (input), consultez Rubriques connexes.

Exemples

Pour envoyer l'octet 4Fh au port de sortie configuré à l'adresse 2F8h, tapez :

o2f8 4f


Debug : p (proceed)

Exécute une boucle, une instruction de chaîne répétée, une interruption logicielle, un sous-programme ou toute autre instruction unique (exécution pas à pas). Utilisée sans paramètre, la sous-commande p présente les registres et leurs valeurs en cours.

Syntaxe

p [=adresse] [nombre]

Paramètres

adresse
Indique l'adresse de la première instruction à exécuter. En l'absence de ce paramètre, l'adresse par défaut est l'adresse actuelle spécifiée dans les registres CS:IP.
nombre
Indique le nombre d'instructions à exécuter avant de rendre le contrôle à Debug.exe. La valeur par défaut est 1.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Utilisation du paramètre adresse

    Si le paramètre adresse ne spécifie pas de segment, Debug.exe utilise le registre CS du programme en test. Si vous omettez l'adresse, le programme est exécuté à partir de l'adresse spécifiée par les registres CS:IP. Pour distinguer l'adresse du nombre, faites-le précéder d'un signe égal (=). Si l'instruction à l'adresse spécifiée n'est ni une boucle ni une instruction de chaîne répétée ni une interruption au niveau du logiciel ni un sous-programme, la sous-commande p agit de la même façon que la sous-commande t (trace).

  • Transfert de contrôle au programme en cours de test

    Lorsque la sous-commande p transfère le contrôle de Debug.exe au programme en cours de test, ce dernier s'exécute sans interruption jusqu'à ce que la boucle, l'instruction de chaîne répétée, l'interruption au niveau du logiciel ou le sous-programme existant à l'adresse spécifiée soit achevé ou jusqu'à ce que le nombre indiqué d'instructions machine soit exécuté. Le contrôle est ensuite rendu à Debug.exe.

  • Visualisation des messages

    Une fois que la sous-commande p est exécutée, Debug.exe affiche le contenu des registres du programme, l'état de ses indicateurs et la forme décodée de la prochaine instruction à exécuter.

    Avertissement

    • Il est impossible d'utiliser la sous-commande p pour exécuter pas à pas les instructions contenues dans la mémoire morte (ROM).
  • Pour plus d'informations sur l'exécution du programme actuellement en mémoire à l'aide de la sous-commande g (go), consultez Rubriques connexes.
  • Pour plus d'informations sur l'exécution d'une instruction à l'aide de la sous-commande t (trace), consultez Rubriques connexes.

Exemples

Dans cet exemple, le programme en cours de test contient une instruction de commande call à l'adresse CS:143F. Pour exécuter le sous-programme appelé au moyen de call et rendre ensuite le contrôle à Debug.exe, tapez :

p=143f

Debug.exe affiche les résultats sous la forme suivante :

AX=0000 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
DS=2246 ES=2246 SS=2246 CS=2246 IP=1443 NV UP EI PL NZ AC PO NC
2246:1442 7505 JNZ 144A


Debug : q (quit)

Met fin à la session Debug.exe, sans enregistrer le fichier en cours de test, et retourne à l'invite de commandes.

Syntaxe

q

Paramètres

?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX


Debug : r (register)

Affiche ou modifie le contenu d'un ou de plusieurs registres de l'unité du processeur central (CPU, Central Processor Unit). Utilisée sans paramètre, la commande r affiche le contenu de tous les registres et indicateurs de la zone de stockage des registres, l'état de tous les indicateurs et la forme décodée de l'instruction à l'adresse actuelle.

Syntaxe

r [Registre]

Paramètres

Registre
Indique le nom du registre contenant les informations à afficher.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Utilisation de la sous-commande r

    Si vous indiquez un registre, Debug.exe affiche la valeur 16 bits de ce registre en notation hexadécimale ainsi qu'un signe deux-points comme invite. Si vous voulez remplacer la valeur contenue dans le registre par une autre valeur, tapez cette dernière et appuyez sur ENTRÉE. Sinon, appuyez sur ENTRÉE pour revenir à l'invite debug.

  • Registres x86 valides

    Le tableau suivant répertorie les registres x86 admis pour Registre.

    Valeur
    ax
    bp
    bx
    cs
    cx
    di
    ds
    dx
    es
    f
    ip
    pc
    si
    sp
    ss

    Si vous spécifiez un registre n'apparaissant pas dans la liste ci-dessus, Debug.exe affiche le message suivant :

    br erreur

  • Utilisation de f à la place d'un registre

    Si vous tapez f à la place d'un registre, Debug.exe affiche la valeur courante de chaque indicateur sous forme de code à deux lettres, puis l'invite de debug. Pour changer la valeur d'un indicateur, tapez le code à deux lettres approprié choisi dans le tableau ci-dessous.

    Nom d'indicateur | Définir | Effacer
    Dépassement de capacité | ov | nv
    Direction | dn (décrément) | up (incrément)
    Interruptions | ei (activé) | di (désactivé)
    Signe | ng (négatif) | pl (positif)
    Zéro | zr | nz
    Report auxiliaire | ac | na
    Parité | pe (paire) | po (impaire)
    Report | cy | nc

    Vous pouvez taper des nouvelles valeurs d'indicateur dans n'importe quel ordre. Vous n'avez pas besoin de séparer ces valeurs par des espaces. Pour mettre fin à la sous-commande r, appuyez sur ENTRÉE. Tous les indicateurs pour lesquels vous ne spécifiez pas de nouvelles valeurs restent inchangés.

  • Messages affichés par la sous-commande r

    Si vous spécifiez plus d'une valeur pour un indicateur, Debug.exe affiche le message suivant :

    df erreur

    Si vous spécifiez un code d'indicateur qui n'apparaît pas dans le tableau ci-dessus, Debug.exe affiche le message suivant :

    bf erreur

    Dans les deux cas, Debug.exe ne tient compte d'aucun paramètre spécifié après l'entrée non valide.

  • Paramètres par défaut de Debug.exe

    Lorsque vous démarrez Debug.exe, les registres segments sont établis au bas de la mémoire libre, le pointeur d'instruction est établi à 0100h, tous les indicateurs sont désactivés et les registres restants sont remis à zéro, à l'exclusion de sp, qui est établi à FFEEh.

  • Pour plus d'informations sur l'affichage du contenu d'une partie de la mémoire à l'aide de la sous-commande d, consultez Rubriques connexes.
  • Pour plus d'informations sur le désassemblage des octets à l'aide de la sous-commande u, consultez Rubriques connexes.

Exemples

Si l'adresse actuelle est CS:11A, l'affichage se présente sous la forme suivante :

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21

Pour examiner l'état des indicateurs uniquement, tapez :

rf

Debug.exe affiche les informations sous la forme suivante :

NV UP DI NG NZ AC PE NC - _

Tapez une ou plusieurs valeurs valides d'indicateur, dans n'importe quel ordre, avec ou sans espace. Par exemple :

nv up di ng nz ac pe nc - pleicy

Debug.exe met fin à la sous-commande r et affiche l'invite debug. Pour visualiser les modifications, tapez r ou rf. Debug.exe affiche les éléments suivants :

NV UP EI PL NZ AC PE CY - _

Appuyez sur ENTRÉE pour revenir à l'invite de debug.


Debug : s (search)

Cherche dans une plage d'adresses un modèle formé d'un ou de plusieurs octets.

Syntaxe

s plage liste

Paramètres

plage
Requis. Indique les adresses de début et de fin de la plage où vous voulez effectuer la recherche.
liste
Requis. Représente le modèle formé d'un ou de plusieurs octets ou la chaîne sur laquelle porte la recherche.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées de plage valides

    Utilisez plage avec une sous-commande debug pour spécifier une plage de mémoire. Vous pouvez choisir l'un des formats de plage suivants : une adresse de début et une adresse de fin ou une adresse de début et la longueur (représentée par l) de la plage. Les syntaxes suivantes, par exemple, spécifient toutes deux une plage de 16 octets commençant à l'adresse CS:100 :

    cs:100 10f

    cs:100 l 10
  • Utilisation de liste

    Lorsque vous utilisez le paramètre liste, séparez les octets par des espaces ou des virgules et encadrez les chaînes par des guillemets ("chaîne"). Si la liste contient plus d'une valeur d'octet, Debug.exe n'affiche que la première adresse où la valeur apparaît. Si la liste contient une valeur d'octet, Debug.exe affiche toutes les adresses où la valeur apparaît dans la plage spécifiée.

Exemples

Pour trouver toutes les adresses contenant la valeur 41 dans la plage CS:100 à CS:110, tapez :

scs:100 110 41

Debug.exe affiche les résultats sous la forme suivante :

04BA:0104
04BA:010D
-

Pour chercher la chaîne « Ph » dans la plage CS:100 à CS:1A0, tapez :

scs:100 1a0 "Ph"


Sous-commandes de Debug

Pour plus d'informations, cliquez sur une commande :

  • Debug : a (assemble)
  • Debug : c (compare)
  • Debug : d (dump)
  • Debug : e (enter)
  • Debug : f (fill)
  • Debug : g (go)
  • Debug : h (hexadecimal)
  • Debug : i (input)
  • Debug : l (load)
  • Debug : m (move)
  • Debug : n (name)
  • Debug : o (output)
  • Debug : p (proceed)
  • Debug : q (quit)
  • Debug : r (register)
  • Debug : s (search)
  • Debug : t (trace)
  • Debug : u (unassemble)
  • Debug : w (write)
  • Debug : xa (allocate expanded memory)
  • Debug : xd (deallocate expanded memory)
  • Debug : xm (map expanded memory pages)
  • Debug : xs (display expanded memory status)


Debug : t (trace)

Exécute une seule instruction et affiche le contenu de tous les registres, l'état de tous les indicateurs et la forme décodée de l'instruction exécutée. Utilisée sans paramètre, la sous-commande t commence l'exécution pas à pas à l'adresse spécifiée par les registres CS:IP de votre programme.

Syntaxe

t [=adresse] [nombre]

Paramètres

adresse
Indique l'adresse à partir de laquelle Debug.exe doit commencer à exécuter les instructions pas à pas.
nombre
Indique le nombre d'instructions à exécuter pas à pas. Cette valeur doit être un nombre hexadécimal. La valeur par défaut est 1.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Exécution pas à pas d'instructions stockées dans la mémoire morte

    La sous-commande t utilise le mode d'exécution pas à pas du matériel du microprocesseur 8086 ou 8088. Vous pouvez donc aussi exécuter pas à pas des instructions stockées dans la mémoire morte (ROM).

  • Pour plus d'informations sur l'exécution d'une boucle, d'une instruction de chaîne répétée, d'une interruption au niveau du logiciel ou d'un sous-programme à l'aide de la sous-commande p (proceed), consultez Rubriques connexes.
  • Pour plus d'informations sur l'exécution du programme actuellement en mémoire à l'aide de la sous-commande g (go), consultez Rubriques connexes.

Exemples

Si l'adresse de l'instruction dans le programme est 04BA:011A, Debug.exe affiche les informations suivantes :

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21


Debug : u (unassemble)

Désassemble les octets et affiche les instructions sources correspondantes, y compris les adresses et les valeurs des octets. Le code désassemblé ressemble à la liste d'un fichier assemblé. Utilisée sans paramètre, la sous-commande u désassemble 20h octets (valeur par défaut) à partir de la première adresse qui suit celle affichée par la précédente sous-commande u.

Syntaxe

u [plage]

Paramètres

plage
Indique les adresses de début et de fin du code à désassembler ou son adresse de début et sa longueur.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Spécification d'entrées de plage valides

    Utilisez plage avec une sous-commande debug pour spécifier une plage de mémoire. Vous pouvez choisir l'un des formats de plage suivants : une adresse de début et une adresse de fin ou une adresse de début et la longueur (représentée par l) de la plage. Les syntaxes suivantes, par exemple, spécifient toutes deux une plage de 16 octets commençant à l'adresse CS:100 :

    cs:100 10f

    cs:100 l 10
  • Pour plus d'informations sur l'assemblage des codes mnémoniques à l'aide de la sous-commande a (assemble), consultez Rubriques connexes.
  • Pour plus d'informations sur l'affichage du contenu d'une partie de la mémoire à l'aide de la sous-commande d (dump), consultez Rubriques connexes.

Exemples

Pour désassembler 16 (10h) octets à partir de l'adresse 04BA:0100, tapez :

u04ba:100l10

Debug.exe affiche les résultats sous la forme suivante :

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH
04BA:0109 65 DB 65
04BA:010A 63 DB 63
04BA:010B 69 DB 69
04BA:010C 66 DB 66
04BA:010D 69 DB 69
04BA:010E 63 DB 63
04BA:010F 61 DB 61

Pour afficher uniquement les informations des adresses spécifiques 04BA:0100 à 04BA:0108, tapez :

u04ba:0100 0108

Debug.exe affiche les éléments suivants :

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH


Debug : w (write)

Écrit un fichier ou des secteurs spécifiques sur le disque. Utilisée sans paramètre, la sous-commande w démarre à CS:100.

Syntaxe

w [adresse]

w [adresse] [Lecteur] [premier_secteur] [nombre]

Paramètres

adresse
Spécifie le début de l'adresse mémoire du fichier ou de la partie du fichier que vous souhaitez écrire dans un fichier sur disque.
Lecteur
Désigne le lecteur qui contient le disque de destination. Cette valeur est numérique : 0 = A, 1 = B, 2 = C, etc.
premier_secteur
Spécifie le numéro hexadécimal du premier secteur de destination de l'écriture.
nombre
Indique le nombre de secteurs de destination de l'écriture.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Pour écrire le contenu du nombre d'octets spécifiés dans les registres BX:CX dans un fichier sur disque, utilisez la syntaxe suivante :

    w [adresse]

  • Pour court-circuiter le système de fichiers et écrire directement dans des secteurs spécifiques, utilisez la syntaxe ci-dessous :

    w [adresse] [Lecteur] [premier_secteur] [nombre]

  • Spécification d'entrées d'adresse valides

    Adresse est une désignation en deux parties contenant d'une part un registre de segment sous forme alphabétique ou une adresse de segment à 4 chiffres, et d'autre part une valeur de décalage. Vous pouvez omettre le registre de segment ou l'adresse de segment. CS est le segment par défaut des sous-commandes debug suivantes : a, g, l, t, u et w. Pour toutes les autres sous-commandes, le segment par défaut est DS. Toutes les valeurs numériques se présentent en notation hexadécimale. Vous devez inclure un signe deux-points entre le nom du segment et la valeur de décalage. Les deux adresses suivantes sont valides :

    CS:0100

    04BA:0100
  • Spécification du nom du fichier sur disque. Vous devez spécifier le nom du fichier sur disque lorsque vous démarrez Debug.exe ou dans la sous-commande n (name) la plus récente. Ces deux méthodes mettent correctement en forme le nom de fichier d'un bloc de gestion de fichier à l'adresse CS:5C.
  • Réinitialisation de BX:CX avant l'emploi de w sans paramètre

    Si vous utilisez la sous-commande g (go), t (trace), p (proceed) ou r (register), vous devez réinitialiser les registres BX:CX avant d'employer la sous-commande w sans paramètre.

  • Écriture d'un fichier modifié sur disque

    Si vous modifiez le fichier sans changer le nom, la longueur ou l'adresse de début, Debug.exe peut écrire correctement le fichier à l'emplacement d'origine du disque.

  • Écriture de fichiers .exe ou .hex

    Cette commande ne permet pas d'écrire un fichier .exe ou .hex.

    Avertissement

    • L'écriture de secteurs spécifiques est extrêmement délicate car elle court-circuite le gestionnaire de fichier Windows XP. La structure des fichiers du disque peut être endommagée par la frappe de valeurs erronées.
  • Pour plus d'informations sur la spécification d'un fichier à l'aide de la sous-commande n (name), consultez Rubriques connexes.
  • Pour plus d'informations sur le chargement en mémoire du contenu d'un fichier ou de secteurs de fichier à l'aide de la sous-commande l (load), consultez Rubriques connexes.

Exemples

Pour écrire le contenu de la mémoire, à partir de l'adresse CS:100, sur le disque placé dans le lecteur B et recueillir les données depuis le numéro de secteur logique du disque 37h jusqu'aux 2Bh secteurs, tapez :

wcs:100 1 37 2b

Une fois l'opération d'écriture terminée, Debug.exe affiche à nouveau l'invite debug.


Debug : xa (allocate expanded memory)

Alloue un nombre spécifique de pages de la mémoire paginée. Utilisée sans paramètres, la sous-commande xa vérifie la présence ou l'absence de la prise en charge de la mémoire paginée (EMS).

Syntaxe

xa[compte]

Paramètres

compte
Spécifie le nombre de pages de 16 kilo-octets de la mémoire paginée à allouer.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Windows XP ne prend pas en charge l'EMS. Pour utiliser la mémoire paginée, vous devez installer un pilote de périphérique de mémoire paginée compatible avec la version 4.0 de Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).
  • Si le nombre de pages spécifié est disponible, Debug.exe affiche un message spécifiant le numéro hexadécimal du descripteur créé. Sinon, il affichage un message d'erreur.

Exemples

Pour allouer huit pages de mémoire paginée, tapez :

xa8

Si la commande réussit, Debug.exe affiche un message semblable à ce qui suit :

Handle créé=0003


Debug : xd (deallocate expanded memory)

Supprime l'allocation d'un descripteur à la mémoire paginée. Utilisée sans paramètres, la sous-commande xd vérifie la présence ou l'absence de la prise en charge de la mémoire paginée (EMS).

Syntaxe

xd [descripteur]

Paramètres

descripteur
Désigne le descripteur dont vous voulez supprimer l'allocation.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Windows XP ne prend pas en charge l'EMS. Pour utiliser la mémoire paginée, vous devez installer un pilote de périphérique de mémoire paginée compatible avec la version 4.0 de Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).

Exemples

Pour supprimer l'allocation du descripteur 0003, tapez :

xd 0003

Si la commande s'exécute correctement, Debug.exe affiche le message suivant :

Handle 0003 désaffecté


Debug : xm (map expanded memory pages)

Mappe une page logique de la mémoire paginée, appartenant au descripteur spécifié, à une de ses pages physiques. Utilisée sans paramètres, la sous-commande xm vérifie la présence ou l'absence de la prise en charge de la mémoire paginée (EMS).

Syntaxe

xm [lpage] [ppage] [descripteur]

Paramètres

lpage
Spécifie le numéro de la page logique de la mémoire paginée que vous souhaitez mapper à la page physique ppage.
ppage
Spécifie le numéro de la page physique à laquelle lpage doit être mappée.
descripteur
Spécifie le descripteur.
?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Windows XP ne prend pas en charge l'EMS. Pour utiliser la mémoire paginée, vous devez installer un pilote de périphérique de mémoire paginée compatible avec la version 4.0 de Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).

Exemples

Pour faire correspondre la page logique 5 désignée par le descripteur 0003 à la page physique 2, tapez :

xm 5 2 0003

Si la commande s'exécute correctement, Debug.exe affiche le message suivant :

Page logique 05 mappée à page physique 02


Debug : xs (display expanded memory status)

Affiche des informations sur l'état de la mémoire paginée.

Syntaxe

xs

Paramètres

?
Affiche la liste des sous-commandes de debug.

Remarques

  • XOX
  • Pour utiliser la mémoire paginée, vous devez installer un pilote de périphérique de mémoire paginée compatible avec la version 4.0 de Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).
  • Debug.exe affiche les informations sous la forme suivante :

    Le handle xx a xx pages allouées
    Page physique xx = Segment de trame xx
    xx sur un total de xx pages EMS ont été allouées
    xx sur un total de xx handles EMS ont été alloués

Exemples

Pour afficher les informations relatives à la mémoire paginée, tapez :

xs

La sous-commande xs affiche des informations similaires à ce qui suit :

    Le handle 0000 a 0000 pages allouées

    Le handle 0001 a 0002 pages allouées

    Page physique 00 = Segment de trame C000

    Page physique 01 = Segment de trame C400

    Page physique 02 = Segment de trame C800

    Page physique 03 = Segment de trame CC00

       2 sur un total de 80 pages EMS ont été allouées

       2 sur un total de FF handles EMS ont été alloués


Defrag

Localise et regroupe des dossiers, des fichiers de données et des fichiers d'amorçage fragmentés sur des volumes locaux.

Syntaxe

defrag volume

defrag volume [/a]

defrag volume [/a] [/v]

defrag volume [/v]

defrag volume [/f]

Paramètres

volume
Lecteur ou point de montage du volume à défragmenter.
/a
Analyse un volume et affiche un récapitulatif du rapport d'analyse.
/v
Affiche les rapports complets de défragmentation et d'analyse.

Utilisé conjointement avec /a, affiche uniquement le rapport d'analyse. Utilisé seul, affiche les rapports de défragmentation et d'analyse.

/f
Impose la défragmentation du volume, que celle-ci soit ou non nécessaire.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Un volume doit disposer au moins de 15% d'espace libre pour que la défragmentation au moyen de la commande defrag puisse s'effectuer complètement et de façon adéquate. La commande defrag utilise cet espace comme zone de tri pour les fragments de fichiers. Si un volume dispose de moins de 15% d'espace libre, la commande defrag effectue uniquement une défragmentation partielle. Pour augmenter l'espace libre sur un volume, supprimez les fichiers inutiles ou déplacez-les vers un autre disque.
  • Vous ne pouvez pas défragmenter des volumes que le système de fichiers a identifiés comme étant douteux, c'est-à-dire susceptibles d'être corrompus. Vous devez exécuter chkdsk sur un volume douteux avant de pouvoir le défragmenter. Pour déterminer si un volume est douteux, utilisez la commande fsutil dirty query. Pour plus d'informations sur chkdsk et fsutil dirty, consultez Rubriques connexes.
  • Pendant que defrag analyse et défragmente un volume, un curseur clignotant est affiché. Lorsque defrag a terminé d'analyser et de défragmenter le volume, il affiche le rapport d'analyse, le rapport de défragmentation, ou les deux, puis retourne vers l'invite de commande.
  • Par défaut, defrag affiche un résumé des rapports d'analyse et de défragmentation si vous ne spécifiez pas les paramètres /a ou /v.
  • Vous pouvez envoyer les rapports vers un fichier de texte en tapant >nom_fichier.txt, où nom_fichier.txt est le nom de fichier que vous spécifiez. Par exemple :

    • defrag volume /v >nom_fichier.txt

  • Pour arrêter la défragmentation, sur la ligne de commande, appuyez sur CTRL+C.
  • Vous ne pouvez pas exécuter la commande defrag et le Défragmenteur de disque en même temps. Si vous utilisez le Défragmenteur de disque pour défragmenter un volume et que vous exécutez la commande defrag sur la ligne de commande, la commande defrag n'aboutit pas. Inversement, si vous exécutez la commande defrag et que vous lancez le Défragmenteur de disque, les options de défragmentation ne sont pas disponibles.


Del (erase)

Supprime les fichiers spécifiés.

Syntaxe

del [Lecteur:][Chemin] NomFichier [ ...] [/p] [/f] [/s] [/q] [/a[:attributs]]

erase [Lecteur:][Chemin] NomFichier [ ...] [/p] [/f] [/s] [/q] [/a[:attributs]]

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du fichier ou du jeu de fichiers à supprimer. NomFichier est obligatoire. Vous pouvez utiliser plusieurs noms de fichier. Séparez les noms de fichier par des espaces, des virgules ou des points-virgules.
/p
Vous invite à confirmer que vous voulez supprimer le fichier spécifié.
/f
Force la suppression des fichiers dotés de l'attribut lecture seule.
/s
Supprime les fichiers spécifiés du répertoire en cours et de tous ses sous-répertoires. Affiche le nom des fichiers au fur et à mesure qu'ils sont supprimés.
/q
Spécifie le mode silencieux. Vous n'êtes pas invité à confirmer l'ordre de suppression.
/a
Supprime les fichiers dotés des attributs spécifiés.
attributs
Spécifie n'importe quel attribut de fichier suivant :
Attribut | Description
r | Lecture seule
a | Archive
s | Système
h | Caché
- | Préfixe de négation
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisation de /p

    Si vous utilisez /p, del affiche le nom d'un fichier et le message suivant :

    nom_de_fichier, Supprimer (O/N) ?

    Appuyez sur O pour confirmer la suppression, sur N pour l'annuler et afficher le nom du fichier suivant (si vous avez désigné un groupe de fichiers), ou sur CRTL+C pour mettre fin à la commande del.

  • Désactivation des extensions de commandes

    Si vous désactivez les extensions de commande, l'option de ligne de commande /s affiche le nom de tous les fichiers qui n'ont pas été trouvés au lieu de ceux qui sont supprimés (le comportement est inversé). Pour plus d'informations sur la désactivation des extensions de commandes, consultez cmd dans Rubriques connexes.

  • Suppression de plusieurs fichiers à la fois

    Vous pouvez supprimer tous les fichiers d'un dossier en tapant del suivi de [Lecteur:]Chemin. Par exemple, la commande suivante supprime tous les fichiers du dossier \travail :

    del \travail

    Vous pouvez aussi utiliser les caractères génériques (* et ?) pour supprimer plusieurs fichiers à la fois. Soyez cependant prudent lors de l'emploi de ces caractères avec la commande del, car vous risquez de supprimer des fichiers sans le vouloir. Par exemple, si vous tapez la commande suivante :

    del *.*

    La commande del affiche l'invite suivante :

    Tous les fichiers du répertoire seront supprimés ! Êtes-vous sûr (O/N) ?

    Appuyez sur O, puis sur ENTRÉE pour supprimer tous les fichiers du dossier en cours ou sur N, puis sur ENTRÉE pour annuler la suppression.

    Avant d'utiliser les caractères génériques avec la commande del en vue de supprimer un groupe de fichiers, vous pouvez employer ces mêmes caractères avec la commande dir pour afficher la liste des noms des fichiers inclus dans le groupe.

    Avertissement

    • Une fois que vous avez supprimé un fichier du disque à l'aide de la commande del, vous ne pouvez plus le récupérer.
  • La commande del est disponible dans la console de récupération avec d'autres paramètres.

Exemples

Pour supprimer tous les fichiers d'un dossier nommé Test sur le lecteur C, tapez l'une des syntaxes suivantes :

del c:\test

del c:\test\*.*


Device

Charge en mémoire le pilote de périphérique spécifié.

Syntaxe

device=[Lecteur:][Chemin] NomFichier [paramètres-pp]

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du pilote de périphérique à charger. NomFichier est obligatoire.
[paramètres-pp]
Représente toutes les informations de ligne de commande éventuellement exigées par le pilote de périphérique.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisez le fichier racine_système\System32\Config.nt ou le fichier de démarrage équivalent spécifié dans le fichier PIF (Program Information File) d'un programme afin de charger les pilotes de périphérique pour le sous-système MS-DOS.

Exemples

Pour utiliser une séquence d'échappement ANSI pour contrôler l'écran et le clavier du sous-système MS-DOS, tapez la syntaxe suivante dans votre fichier Config.nt ou dans le fichier de démarrage équivalent :

device=c:\winnt\system32\ansi.sys


Devicehigh

Charge des pilotes de périphérique dans la zone de mémoire haute. Cela permet de libérer davantage d'octets de mémoire conventionnelle pour d'autres programmes. Utilisez le fichier racine_système\System32\Config.nt ou le fichier de démarrage équivalent spécifié dans le fichier PIF d'un programme afin de charger les pilotes de périphérique pour le sous-système MS-DOS.

Syntaxe

devicehigh=[Lecteur:][Chemin] NomFichier [paramètres-pp]

devicehigh size=taillehexa [Lecteur:][Chemin] NomFichier [paramètres-pp]

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du pilote de périphérique à charger dans la zone de mémoire haute. NomFichier est obligatoire.
paramètres-pp
Représente toutes les informations de ligne de commande éventuellement exigées par le pilote de périphérique.
taillehexa
Requis. Indique la mémoire minimum (nombre d'octets exprimés en notation hexadécimale) qui doit être disponible avant que devicehigh n'essaie de charger un pilote de périphérique dans la zone de mémoire haute. Vous devez utiliser à la fois size et taillehexa, comme l'indique la seconde ligne de syntaxe.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Utilisation de dos=umb

    Pour utiliser devicehigh, vous devez obligatoirement inclure dos=umb dans votre fichier Config.nt ou le fichier de démarrage équivalent. Si vous ne spécifiez pas dos=umb, tous les pilotes de périphérique sont chargés dans la mémoire conventionnelle, comme si vous utilisiez la commande device. Pour plus d'informations sur dos=umb, consultez Rubriques connexes.

  • Installation de Himem.sys

    Avant de pouvoir charger un pilote de périphérique dans la zone de mémoire haute, vous devez utiliser device pour installer le pilote de périphérique Himem.sys. Device doit apparaître devant n'importe quelle commande devicehigh dans votre fichier Config.nt ou votre fichier de démarrage équivalent.

  • Spécification d'une taille limite

    Si le pilote de périphérique spécifié tente d'allouer plus d'espace tampon qu'il n'en est de disponible dans un bloc de mémoire haute, il se peut que votre système s'interrompe. Utilisez taillehexa pour éviter ce problème. Dans ce paramètre, indiquez, en notation hexadécimale, la quantité de mémoire nécessaire au pilote de périphérique. Pour trouver la valeur requise par un pilote particulier, chargez ce dernier dans la mémoire conventionnelle et exécutez mem /debug.

  • Chargement dans la mémoire conventionnelle

    Si vous ne disposez pas d'une zone de mémoire haute suffisante pour le chargement du pilote de périphérique désigné dans devicehigh, le sous-système MS-DOS le charge dans la mémoire conventionnelle (comme si vous utilisiez device).

Exemples

Pour charger un pilote de périphérique nommé LectPerso.sys dans la zone de mémoire haute, tapez la commande suivante dans le fichier Config.nt ou dans le fichier de démarrage équivalent :

device=c:\winnt\system32\himem.sys
dos=umb
devicehigh=lectperso.sys


Dir

Affiche la liste des fichiers et des sous-répertoires d'un répertoire. Utilisée sans paramètre, la commande dir affiche le nom et le numéro de série du volume du disque, suivis de la liste des répertoires et des fichiers du disque, y compris leur nom ainsi que la date et l'heure de leur dernière modification. Pour les fichiers, dir affiche l'extension du nom ainsi que la taille en octets. Il affiche également le nombre total des fichiers et des répertoires de la liste, leur taille cumulée et l'espace restant (en octets) sur le disque.

Syntaxe

dir [lecteur:][chemin][NomFichier] [...] [/p] [/q] [/w] [/d] [/a[[:]attributs]][/o[[:]OrdreTri]] [/t[[:]ChampHeure]] [/s] [/b] [/l] [/n] [/x] [/c] [/4]

Paramètres

[[lecteur:][chemin]
Désigne le lecteur et le répertoire dont vous voulez afficher le contenu.
[NomFichier]
Désigne le fichier ou groupe de fichiers particulier dont vous voulez afficher le contenu.
/p
Affiche un écran de la liste à la fois. Pour faire apparaître l'écran suivant, appuyez sur n'importe quelle touche du clavier.
/q
Affiche les informations relatives à la propriété du fichier.
/w
Affiche la liste en largeur, avec jusqu'à cinq noms de fichier ou de répertoire sur chaque ligne.
/d
Produit le même résultat que /w, sauf que les fichiers sont triés par colonne.
/a [[:] attributs]
N'affiche que les noms des répertoires et fichiers dotés des attributs spécifiés. En l'absence de /a, dir affiche les noms de tous les fichiers, à l'exclusion des fichiers cachés et système. Si vous utilisez /a sans spécifier attributs, dir présente les noms de tous les fichiers, fichiers cachés et système compris. La liste ci-dessous décrit chacune des valeurs susceptibles d'être utilisées avec le paramètre attributs. Le signe deux-points (:) est facultatif. Employez n'importe quelle combinaison de ces valeurs sans les séparer par des espaces :
Valeur | Description
H | Fichiers cachés
s. | Fichiers système
d | Répertoires
a | Fichiers prêts pour l'archivage
r | Fichiers lecture seule
-h | Fichiers qui ne sont pas cachés
-s | Fichiers autres que les fichiers système
-d | Fichiers uniquement (sans répertoires)
-a | Fichiers qui n'ont pas été modifiés depuis la dernière sauvegarde
-r | Fichiers qui ne sont pas en lecture seule
/o [[:]OrdreTri]
Détermine l'ordre de tri et d'affichage des noms de répertoire et de fichier utilisés par dir. En l'absence de /o, dir affiche les noms dans l'ordre selon lequel ils se présentent dans le répertoire. Si vous utilisez /o sans préciser OrdreTri, dir affiche les noms des répertoires par ordre alphabétique, puis les noms des fichiers, également par ordre alphabétique. Le signe deux-points (:) est facultatif. La liste suivante décrit chacune des valeurs susceptibles d'être assignées au paramètre OrdreTri. Employez n'importe quelle combinaison de ces valeurs sans les séparer par des espaces :
Valeur | Description
n | Ordre alphabétique des noms
e | Ordre alphabétique des extensions
d | Ordre chronologique des dates et des heures, à commencer par la plus ancienne
s. | Ordre de taille, à commencer par la plus petite
g | Répertoires groupés avant les fichiers
-n | Ordre alphabétique inverse des noms (de Z à A)
-e | Ordre alphabétique inverse des extensions (de .ZZZ à .AAA)
-d | Ordre chronologique des dates et des heures, à commencer par la plus récente
-s | Ordre de taille, à commencer par la plus grande
-g | Répertoires groupés à la suite des fichiers
/t [[:]ChampHeure]
Spécifie le champ d'heure à afficher ou à utiliser pour le tri : La liste ci-dessous décrit chacune des valeurs susceptibles d'être utilisées avec le paramètre ChampHeure.
Valeur | Description
c | Création
a | Accès précédent
w | Enregistrement précédent
/s
Affiche toutes les apparitions du nom de fichier spécifié dans le répertoire désigné et tous ses sous-répertoires.
/b
Présente chaque nom de répertoire ou de fichier (extension comprise) sur une ligne séparée. /b n'affiche pas d'informations d'en-tête ou de résumé. /b annule /w.
/l
Affiche les noms de répertoire et de fichier en minuscules sans les trier. Le paramètre /l ne convertit cependant pas les caractères étendus en minuscules.
/n
Affiche le format de liste longue où les noms de fichier apparaissent à l'extrême droite de l'écran.
/x
Affiche les formes courtes des noms générées pour les fichiers situés sur les volumes FAT et NTFS. L'affichage est semblable à celui généré par le paramètre /n, à ceci près que les formes courtes sont affichées à la suite des formes longues.
/c
Affiche le séparateur des milliers pour les tailles de fichier.
/4
Affiche le format d'année à quatre chiffres.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de nomsfichier multiples

    Vous pouvez utiliser des nomsfichier multiples. Séparez les noms de fichier par des espaces, des virgules ou des points-virgules. Pour afficher un groupe de fichiers, vous pouvez utiliser les caractères génériques (? et *) avec le paramètre NomFichier.

  • Emploi des caractères génériques

    Vous pouvez utiliser les caractères génériques (? et *) pour afficher un sous-ensemble de fichiers et de sous-répertoires.

  • Spécification des attributs d'affichage des fichiers

    Si vous utilisez /a avec plusieurs valeurs dans attributs, dir affiche uniquement les noms des fichiers dotés de tous les attributs spécifiés. Si, par exemple, vous utilisez /a avec r et -h pour les attributs (/a:r-h ou /ar-h), dir n'affiche que les noms des fichiers dotés de l'attribut lecture seule qui ne sont pas cachés.

  • Spécification de l'ordre de tri des noms de fichier

    Si vous spécifiez plusieurs valeurs pour l'OrdreTri, dir trie les noms de fichier selon le premier critère d'abord, puis selon le deuxième, et ainsi de suite. Si, par exemple, vous spécifiez /o avec les valeurs e et -s pour l'OrdreTri (/o:e-s ou /oe-s), dir trie les noms des répertoires et des fichiers selon l'ordre alphabétique des extensions et par ordre de taille, en commençant par le plus grand, et ensuite affiche le résultat final. Le tri selon l'ordre alphabétique des extensions fait apparaître d'abord les noms de fichier sans extensions, puis les noms de répertoire, et enfin les noms de fichier suivis d'extensions.

  • Emploi de symboles de redirection et du signe “ | ”

    Lorsque vous utilisez un symbole de redirection (>) pour envoyer le résultat de la commande dir à un fichier ou une barre verticale (|) pour l'envoyer à une autre commande, servez-vous des paramètres /a:-d et /b pour afficher uniquement la liste des noms de fichier. Vous pouvez utiliser NomFichier avec les paramètres /b et /s pour préciser que dir doit chercher tous les noms de fichier correspondant à ce paramètre dans le répertoire en cours et ses sous-répertoires. Dir présente uniquement la lettre du lecteur, le nom du répertoire, le nom et l'extension de chaque fichier trouvé, en affichant chaque chemin sur une ligne. Avant d'utiliser un signe “ | ” en vue de redirection, il est conseillé de définir la variable d'environnement TEMP dans le fichier Autoexec.nt.

  • Prédéfinition des paramètres de la commande dir

    Pour prédéfinir les paramètres de dir, vous pouvez inclure set avec la variable d'environnement DIRCMD dans le fichier Autoexec.nt. Il est possible d'utiliser avec la commande set dircmd n'importe quelle combinaison valable de paramètres de dir, emplacement et nom d'un fichier compris.

    Pour utiliser, par exemple, la variable d'environnement DIRCMD afin de spécifier le format en largeur /w) comme format d'affichage par défaut, tapez la commande suivante dans le fichier Autoexec.net :

    set dircmd=/w

    Pour une utilisation unique de la commande dir, vous pouvez annuler un paramètre à l'aide de la variable d'environnement DIRCMD. Pour ce faire, tapez le paramètre que vous voulez annuler dans l'invite de commande dir, en précédent le paramètre d'un signe moins. Par exemple :

    dir /-w

    Pour changer les paramètres DIRCMD par défaut, tapez :

    set=NouveauParamètre

    Les nouvelles valeurs par défaut restent en vigueur pour toutes les commandes dir suivantes, jusqu'à ce que vous réutilisiez set dircmd ou que vous redémarriez votre ordinateur.

    Pour effacer tous les paramètres par défaut, tapez :

    set dircmd=

    Pour afficher les valeurs actuelles de la variable d'environnement DIRCMD, tapez :

    set

    Set affiche la liste des variables d'environnement accompagnées de leurs valeurs. Pour plus d'informations sur la définition des variables d'environnement, consultez Rubriques connexes.

  • La commande dir, avec d'autres paramètres, est disponible à partir de la console de récupération.

Exemples

Pour afficher tous les répertoires, l'un après l'autre, par ordre alphabétique, en format large et écran par écran, tapez la commande suivante après avoir vérifié que le répertoire racine est le répertoire actuel :

dir /s/w/o/p

Dir affiche le nom du répertoire racine, les noms de ses sous-répertoires et les noms des fichiers contenus dans le répertoire racine (extensions comprises). La commande dir affiche ensuite le nom de tous les sous-répertoires de l'arborescence et de tous les fichiers contenus dans chacun d'entre eux.

Pour modifier l'exemple précédent de manière à ce que dir affiche les noms de fichier et les extensions mais omette les noms des répertoires, tapez :

dir /s/w/o/p/a:-d

Pour imprimer la liste des répertoires, tapez :

dir > prn

Lorsque vous spécifiez prn, la liste des répertoires est envoyée à l'imprimante connectée au port LPT1. Si votre imprimante est connectée à un port différent, remplacez prn par le nom du port en question.

Vous pouvez aussi rediriger le résultat de la commande dir vers un fichier en remplaçant prn par un nom de fichier. Vous pouvez également taper un chemin d'accès. Par exemple, pour diriger les données de sortie de dir vers le fichier Dir.doc du répertoire Registre, tapez :

dir > \registre\dir.doc

Si Dir.doc n'existe pas, dir le crée, à moins que le répertoire Registre n'existe pas non plus. Si tel est le cas, le message suivant apparaît :

Erreur de création de fichier

Pour afficher la liste de tous les noms de fichier suivis de l'extension .txt stockés dans les répertoires du lecteur C, tapez :

dir c:\*.txt /w/o/s/p

La commande dir affiche, en largeur, une liste alphabétique des noms de fichier correspondants contenus dans chaque répertoire, s'arrête chaque fois que l'écran se remplit et ne continue que si vous appuyez sur une touche.


Diskcomp

Compare les contenus de deux disquettes. Sans paramètres, la commande diskcomp utilise le lecteur actuel pour les deux disques que vous voulez comparer.

Syntaxe

diskcomp [lecteur1: [lecteur2:]]

Paramètres

lecteur1
Désigne le lecteur qui contient l'une des disquettes.
lecteur2
Désigne le lecteur qui contient l'autre disquette.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation des disques

    La commande diskcomp fonctionne uniquement avec des disquettes. Il est impossible de l'utiliser sur un disque dur. Si vous spécifiez un lecteur de disque dur comme paramètre lecteur1 ou lecteur2, diskcomp affiche le message d'erreur suivant :

    Spécification de lecteur non valide
    Le lecteur spécifié n'existe pas
    ou n'est pas amovible

  • Comparaison des disques

    Si toutes les pistes des deux disquettes comparées sont identiques, diskcomp affiche le message suivant :

    Comparaison OK

    Si les pistes ne sont pas identiques, diskcomp affiche un message semblable à ce qui suit :

    Erreur de comparaison
    face 1, piste 2

    Une fois la comparaison achevée, diskcomp affiche le message suivant :

    Autres disquettes à comparer (O/N)?

    Si vous appuyez sur O, diskcomp vous demande d'insérer les disquettes faisant l'objet de la comparaison suivante. Si vous appuyez sur N, diskcomp arrête la comparaison.

    Lorsque diskcomp fait une comparaison, il ne tient pas compte du numéro de volume du disque.

  • Omission des paramètres lecteur

    Si vous omettez le paramètre lecteur2, diskcomp utilise le lecteur en cours comme lecteur2. Si vous omettez les deux paramètres lecteur, diskcomp utilise le lecteur en cours pour les deux. Si lecteur1 est le lecteur en cours, diskcomp vous demande d'insérer chaque disquette au fur et à mesure selon les besoins.

  • Utilisation d'un lecteur

    Si vous désignez le même lecteur de disquette pour lecteur1 et lecteur2, diskcomp effectue la comparaison en utilisant un seul lecteur et vous demande d'insérer chaque disquette au fur et à mesure selon les besoins. Il vous faudra peut-être échanger les disquettes plusieurs fois, selon leur capacité et la quantité de mémoire disponible.

  • Comparaison de disquettes de types différents

    Diskcomp est incapable de comparer une disquette simple face à une disquette double face, ou une disquette haute densité à une disquette double densité. Si les disquettes placées dans lecteur1 et lecteur2 ne sont pas du même type, diskcomp affiche le message suivant :

    Types de lecteurs ou de disquettes non compatibles

  • Utilisation de diskcomp avec des réseaux et des lecteurs redirigés

    La commande diskcomp n'est pas opérationnelle sur les lecteurs réseau ou créés par la commande subst . Si vous tentez d'utiliser diskcomp avec un de ces types de lecteur, diskcomp affiche le message d'erreur suivant :

    Spécification de lecteur non valide

  • Comparaison d'une disquette originale et de sa copie

    Lorsque vous utilisez la commande diskcomp avec une disquette que vous avez créée à l'aide de la commande copy, diskcomp peut afficher un message semblable au suivant :

    Erreur de comparaison
    face 0, piste 0

    Ce type d'erreur peut apparaître même si les fichiers enregistrés sur les disquettes sont identiques. En effet, copy reproduit les informations, mais ne les place pas nécessairement au même endroit sur la disquette destination. Pour plus d'informations sur la comparaison de fichiers individuels sur deux disques à l'aide de Fc, consultez Rubrique connexes.

  • Description des codes de sortie de diskcomp

    Le tableau suivant énumère chaque code de sortie accompagné d'une brève description.

    Code de sortie | Description
    0 | Les disques sont identiques
    1 | Différences détectées
    3 | Une erreur matérielle s'est produite
    4 | Une erreur d'initialisation s'est produite

    Pour traiter les codes de sortie renvoyés par diskcomp, vous pouvez utiliser niveau_d'erreur dans la ligne de commande if d'un programme de traitement par lots.

Exemples

Pour comparer deux disquettes alors que l'ordinateur ne dispose que d'un seul lecteur de disquette (le lecteur A, par exemple), tapez :

diskcomp a: a:

La commande diskcomp vous invite à insérer chaque disquette au moment approprié.

L'exemple suivant décrit comment traiter un code de sortie diskcomp dans un programme de traitement par lots qui utilise le paramètre niveau_d'erreur dans la ligne de commande if :

rem Controle.bat compare les disquettes des lecteurs A et B
echo off
diskcomp a: b:
if errorlevel 4 goto erreur_ini
if errorlevel 3 goto erreur_perm
if errorlevel 1 goto non_comparaison
if errorlevel 0 goto comparaison_ok
:ini_error
echo ERREUR: Mémoire insuffisante ou commande incorrecte
goto fin
:err_perm
echo ERREUR: Erreur irréparable
goto fin
:arrêt
echo "Vous venez d'appuyer sur CTRL+C" pour arrêter la comparaison
goto fin
:non_comparaison
echo Disquettes différentes
goto fin
:comparaison_ok
echo Comparaison satisfaisante; les disquettes sont identiques
goto fin
:fin


Diskcopy

Copie le contenu de la disquette insérée dans le lecteur source sur une disquette formatée ou non, placée dans le lecteur destination. Sans paramètres, diskcopy utilise le lecteur courant pour le disque source et le disque de destination.

Syntaxe

diskcopy [lecteur1: [lecteur2:]] [/v]

Paramètres

lecteur1
Désigne le lecteur où se trouve la disquette source.
lecteur2
Désigne le lecteur qui contient la disquette destination.
/v
Vérifie que les informations sont correctement copiées. Cette option de ligne de commande ralentit le processus de copie.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation des disques

    La commande diskcopy n'est opérationnelle que sur les disques amovibles, comme les disquettes. Il est impossible de l'utiliser sur un disque dur. Si vous spécifiez un lecteur de disque dur comme paramètre lecteur1 ou lecteur2, diskcopy affiche le message d'erreur suivant :

    Spécification de lecteur non valide
    Le lecteur spécifié n'existe pas
    ou n'est pas amovible

    La commande diskcopy vous demande d'insérer les disquettes source et destination et attend que vous appuyiez sur une touche pour continuer.

    Une fois la copie achevée, diskcopy affiche le message suivant :

    Autres disquettes à copier (O/N)?

    Si vous appuyez sur O, diskcopy vous demande d'insérer les disquettes source et destination à utiliser pour l'opération de copie suivante. Pour arrêter le processus de diskcopy, appuyez sur N.

    Si vous copiez les informations sur une disquette non formatée placée dans lecteur2, diskcopy formate la disquette d'après le nombre de faces et de secteurs par piste de la disquette insérée dans lecteur1. Pendant le formatage de la disquette et la copie des fichiers, diskcopy affiche le message suivant :

    Formatage pendant la copie

  • Numéros de série des disquettes

    Si la disquette source est dotée d'un numéro de série de volume, diskcopy crée un numéro de même nature pour la disquette destination et affiche ce numéro lorsque la copie s'achève.

  • Omission des paramètres lecteur

    Si vous omettez le paramètre lecteur2, diskcopy utilise le lecteur en cours comme lecteur destination. Si vous omettez les deux paramètres lecteur, diskcopy utilise le lecteur en cours pour les deux. Si lecteur1 est le lecteur en cours, diskcopy vous demande d'insérer chaque disquette au fur et à mesure selon les besoins.

  • Emploi d'un seul lecteur pour la copie

    Si lecteur1 et lecteur2 sont identiques, diskcopy vous invite à permuter les disquettes au moment approprié. Si vous omettez les deux paramètres lecteur et si le lecteur en cours est un lecteur de disquette, diskcopy vous signale lorsque vous devez insérer une disquette dans le lecteur. Si les disquettes contiennent plus d'informations que la mémoire disponible ne peut en contenir, diskcopy ne peut alors pas lire toutes les données à la fois. La commande diskcopy lit la disquette source, écrit sur la disquette destination, puis vous invite à réinsérer la disquette source. Ce processus se poursuit jusqu'à ce que vous ayez copié l'ensemble de la disquette.

  • Prévention de la fragmentation d'une disquette

    Comme diskcopy crée une copie exacte de la disquette source sur la disquette destination, toute fragmentation de la disquette source est transférée vers la disquette destination. La fragmentation correspond à la présence de petites zones d'espace disque inutilisé entre des fichiers existants sur une disquette.

    Une disquette source fragmentée risque de ralentir le processus de recherche, de lecture ou d'écriture des fichiers. Pour éviter de transférer la fragmentation d'une disquette à l'autre, utilisez les commandes copy ou xcopy pour copier la disquette. Comme copy et xcopy copient les fichiers l'un après l'autre, la nouvelle disquette n'est pas fragmentée.

    Avertissement

    • Il n'est pas possible d'utiliser xcopy pour copier une disquette de démarrage.
  • Description des codes de sortie de diskcopy

    Le tableau suivant énumère chaque code de sortie accompagné d'une brève description.

    Code de sortie | Description
    0 | L'opération de copie a réussi
    1 | Une erreur de lecture/écriture non fatale s'est produite
    3 | Une erreur matérielle fatale s'est produite
    4 | Une erreur d'initialisation s'est produite

    Pour traiter les codes de sortie renvoyés par diskcomp, vous pouvez utiliser niveau_d'erreur dans la ligne de commande if d'un programme de traitement par lots. Pour obtenir un exemple d'un programme de traitement par lots qui traite les codes de sortie, consultez diskcomp dans Rubriques connexes.

Exemples

Pour copier la disquette du lecteur B sur la disquette du lecteur A, tapez :

diskcopy b: a:


DiskPart

DiskPart.exe est un interpréteur de commandes en mode texte qui vous permet de gérer les objets (disques, partitions ou volumes) à l'aide de scripts ou de commandes directes à partir d'une invite de commande. Avant de pouvoir utiliser les commandes DiskPart.exe sur un disque, une partition ou un volume, vous devez d'abord répertorier et sélectionner l'objet voulu pour lui donner le focus. Lorsqu'un objet a le focus, toutes les commandes DiskPart.exe que vous tapez s'appliquent à cet objet.

Vous pouvez répertorier les objets disponibles et déterminer le numéro ou la lettre de lecteur d'un objet à l'aide des commandes list disk, list volume et list partition. Les commandes list disk et list volume affichent tous les disques et les volumes présents dans l'ordinateur. Toutefois, la commande list partition n'affiche que les partitions du disque qui a le focus. Lorsque vous utilisez les commandes list, un astérisque (*) apparaît près de l'objet qui a le focus. Vous sélectionnez un objet à l'aide de son numéro ou de sa lettre de lecteur, comme disque 0, partition 1, volume 3 ou volume C.

Lorsque vous sélectionnez un objet, le focus reste sur cet objet jusqu'à ce que vous en sélectionniez un autre. Par exemple, si le disque 0 a le focus et que vous sélectionnez le volume 8 sur le disque 2, le focus passe du disque 0 au volume 8 du disque 2. Certaines commandes changent automatiquement le focus. Par exemple, lorsque vous créez une nouvelle partition, le focus passe automatiquement à la nouvelle partition.

Vous pouvez uniquement donner le focus à une partition du disque sélectionné. Lorsqu'une partition a le focus, le volume associé a également le focus. Lorsqu'un volume a le focus, le disque et la partition associés ont également le focus si le volume mappe vers une partition spécifique unique. Si tel n'est pas le cas, le disque et la partition perdent le focus.

Commandes DiskPart

Cliquez sur une commande pour en afficher la syntaxe :

active

Sur les disques de base, marque la partition dotée du focus comme active. Cela informe le système d'entrée/sortie de base (BIOS) ou l'interface EFI (Extensible Firmware Interface) que la partition ou le volume est une partition système ou un volume système valide.

Seules les partitions peuvent être marquées comme actives.

Important

  • DiskPart vérifie uniquement que la partition est capable de contenir les fichiers de démarrage d'un système d'exploitation. DiskPart ne contrôle pas le contenu de la partition. Si vous marquez une partition comme active par erreur, et qu'elle ne contient pas les fichiers de démarrage du système d'exploitation, votre ordinateur peut ne pas démarrer.

Syntaxe

active

add disk

Met en miroir le volume simple qui a le focus, sur le disque spécifié.

Syntaxe

add disk=n [noerr]

Paramètres

n
Spécifie le disque qui contiendra le miroir. Vous pouvez mettre en miroir des volumes simples uniquement. Le disque spécifié doit disposer d'un espace non alloué au moins égal à la taille du volume simple que vous voulez mettre en miroir.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

assign

Affecte une lettre de lecteur ou un point de montage au volume qui a le focus. Si aucune lettre de lecteur ou aucun point de montage n'est spécifié, la première lettre de lecteur disponible est affectée. Si la lettre de lecteur ou le point de montage est déjà utilisé, une erreur est générée.

À l'aide de la commande assign, vous pouvez changer la lettre de lecteur associée à un lecteur amovible.

Vous ne pouvez pas affecter de lettres de lecteur aux volumes système, aux volumes d'amorçage ou aux volumes qui contiennent le fichier d'échange. De plus, vous ne pouvez pas affecter de lettre de lecteur à une partition OEM (Original Equipment Manufacturer) ou à une partition GPT (GUID Partition Table) autre qu'une partition MSDATA de base.

Syntaxe

assign [{letter=d|mount=chemin}] [noerr]

Paramètres

letter=d
Lettre de lecteur que vous voulez affecter au volume.
mount=chemin
Chemin de points de montage que vous voulez affecter au volume.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

break disk

S'applique aux disques dynamiques uniquement. Scinde le volume en miroir qui a le focus en deux volumes simples. Un des volumes simples conserve la lettre de lecteur et les points de montage du volume en miroir ; l'autre volume simple reçoit le focus pour que vous puissiez lui affecter une lettre de lecteur.

Le contenu des deux moitiés du miroir sont conservées par défaut. Chaque moitié devient un volume simple. Avec le paramètre nokeep, vous ne conservez qu'une moitié du miroir en tant que volume simple, tandis que l'autre moitié est supprimée et convertie en espace disque disponible. Aucun volume ne reçoit le focus.

Syntaxe

break disk=n [nokeep] [noerr]

Paramètres

n
Spécifie le disque qui contient le volume en miroir.
nokeep
Spécifie qu'un seul des volumes en miroir est conservé tandis que l'autre est supprimé et converti en espace disque disponible. Ni le volume ni l'espace disque ne reçoit le focus.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

clean

Supprime tout formatage de partition ou de volume sur le disque qui a le focus. Sur les disques MBR (Master Boot Record), seules les informations de partitionnement MBR et les informations de secteurs cachés sont effacées. Sur les disques GPT (GUID Partition Table), les informations de partitionnement GPT, MBR protectif compris, sont effacées. Il n'y a pas d'informations de secteurs cachés.

Syntaxe

clean [all]

Paramètre

all
Spécifie que chacun des secteurs du disque est effacé, ce qui signifie que toutes les données du disques sont définitivement et entièrement supprimées.

convert basic

Convertit un disque dynamique vide en disque de base.

Syntaxe

convert basic [noerr]

Paramètre

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

convert dynamic

Convertit un disque de base en disque dynamique.

Syntaxe

convert dynamic [noerr]

Paramètre

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

convert gpt

Sur les ordinateurs Itanium, convertit un disque de base vide avec un style de partition MBR (Master Boot Record) en disque de base avec le style de partition GPT (GUID partition table).

Important

  • Le disque doit être vide pour être converti en disque GPT. Sauvegardez vos données, puis supprimez l'ensemble des partitions ou des volumes avant de convertir le disque.

Syntaxe

convert gpt [noerr]

Paramètre

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

convert mbr

Sur les ordinateurs Itanium, convertit un disque de base vide avec un style de partition GPT (GUID partition table) en disque de base avec le style de partition MBR (Master Boot Record).

Important

  • Le disque doit être vide pour être converti en disque MBR. Sauvegardez vos données, puis supprimez l'ensemble des partitions ou des volumes avant de convertir le disque.

Syntaxe

convert mbr [noerr]

Paramètre

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create partition efi

Sur les ordinateurs Itanium, crée une partition système EFI (Extensible Firmware Interface) sur un disque GPT (GUID Partition Table). Après avoir créé la partition, le focus est donné à la nouvelle partition.

Syntaxe

create partition efi [size=n] [offset=n] [noerr]

Paramètres

size=n
Taille de la partition en méga-octets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région en cours soit épuisé.
offset=n
Le décalage d'octet par rapport auquel créer la partition. Si aucun décalage n'est fourni, la partition se situe sur la première extension de disque suffisamment volumineuse pour l'accueillir.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create partition extended

Crée une partition étendue sur le lecteur actuel. Après avoir créé la partition, le focus se déplace automatiquement sur la nouvelle partition. Une seule partition étendue peut être créée par disque. Cette commande échoue si vous essayez de créer une partition étendue au sein d'une autre partition étendue. Vous devez créer une partition étendue avant de pouvoir créer des lecteurs logiques.

Syntaxe

create partition extended [size=n] [offset=n] [noerr]

Paramètres

size=n
Taille de la partition étendue en méga-octets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région soit épuisé. La taille est ajustée aux cylindres. La taille est arrondie à la limite de cylindre la plus proche. Si, par exemple, vous spécifiez une taille de 500 Mo, la partition est arrondie à 504 Mo.
offset=n
S'applique uniquement aux disques MBR (Master Boot Record). Le décalage d'octet par rapport auquel créer la partition étendue. Si aucun décalage n'est fourni, la partition démarre au début du premier espace libre sur le disque. Le décalage est ajusté aux cylindres. Le décalage est arrondi à la limite de cylindre la plus proche. Par exemple, si vous spécifiez un décalage de 27 Mo alors que la taille du cylindre équivaut à 8 Mo, le décalage est arrondi à la limite de 24 Mo.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create partition logical

Crée un lecteur logique dans la partition étendue. Après avoir créé la partition, le focus se déplace automatiquement sur le nouveau lecteur logique.

Syntaxe

create partition logical [size=n] [offset=n] [noerr]

Paramètres

size=n
Taille du lecteur logique en méga-octets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région en cours soit épuisé.
offset=n
S'applique uniquement aux disques MBR (Master Boot Record). Le décalage d'octet par rapport auquel créer le lecteur logique. Le décalage est ajusté aux cylindres (c'est-à-dire que le décalage est arrondi de manière à remplir entièrement la taille de cylindre utilisée). Si aucun décalage n'est fourni, la partition se situe sur la première extension de disque suffisamment volumineuse pour l'accueillir. La partition est au moins aussi vaste en octets que la valeur spécifiée par size=n. Si vous spécifiez une taille pour le lecteur logique, elle doit être plus petite que la partition étendue.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create partition msr

Sur les ordinateurs Itanium, crée une partition MSR (Microsoft Reserved) sur un disque GPT (GUID Partition Table).

Attention

  • Utilisez la commande create partition msr avec précaution. Étant donné que les disques GPT nécessitent un format de partition spécifique, la création de partitions MSR (Microsoft Reserved) peut rendre le disque illisible. Sur les disques GPT qui sont utilisés pour démarrer Windows XP 64-Bit Edition, la partition Système EFI est la première partition du disque, suivie de la partition MSR (Microsoft Reserved). Les disques GPT utilisés uniquement à des fins de stockage des données ne possèdent pas de partition Système EFI, et la partition MSR est la première partition.

    Windows XP 64-Bit Edition ne monte pas les partitions MSR (Microsoft Reserved). Vous ne pouvez pas stocker de données sur les partitions MSR et vous ne pouvez pas les supprimer.

Syntaxe

create partition msr [size=n] [offset=n] [noerr]

Paramètres

size=n
Taille de la partition en méga-octets (Mo). La partition est au moins aussi vaste en octets que la valeur spécifiée par size=n. Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région en cours soit épuisé.
offset=n
Le décalage d'octet par rapport auquel créer la partition. La partition démarre au décalage d'octet spécifié par offset=n. Elle est ajustée aux secteurs, c'est-à-dire que le décalage est arrondi de manière à remplir entièrement la taille de secteur utilisée). Si aucun décalage n'est fourni, la partition se situe sur la première extension de disque suffisamment volumineuse pour l'accueillir.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create partition primary

Crée une partition principale sur le disque de base actuel. Après avoir créé la partition, le focus se déplace automatiquement sur la nouvelle partition. La partition ne reçoit pas de lettre de lecteur. Vous devez utiliser la commande assign pour affecter une lettre de lecteur à la partition.

Syntaxe

create partition primary [size=n] [offset=n] [ID={octet|GUID}] [noerr]

Paramètres

size=n
Taille de la partition en méga-octets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace non alloué de la région en cours soit épuisé. La taille est ajustée aux cylindres. La taille est arrondie à la limite de cylindre la plus proche. Par exemple, si vous spécifiez une taille de 500 Mo, la partition est arrondie à 504 Mo.
offset=n
Le décalage d'octet par rapport auquel créer la partition. Si aucun décalage n'est fourni, la partition démarre au début du premier espace libre sur le disque. Pour les disques MBR (Master Boot Record), le décalage est ajusté aux cylindres. Le décalage est arrondi à la limite de cylindre la plus proche. Par exemple, si vous spécifiez un décalage de 27 Mo alors que la taille du cylindre équivaut à 8 Mo, le décalage est arrondi à la limite de 24 Mo.
ID={octet|GUID}
Réservé aux fabricants OEM (Original Equipment Manufacturer).

Attention

  • La création de partitions avec ce paramètre peut entraîner une panne de votre ordinateur ou l'empêcher de démarrer. À moins d'être vous-même un fabricant OEM ou un informaticien professionnel expérimenté en disques GPT, ne créez pas de partitions sur des disques GPT à l'aide du paramètre ID=octet | GUID. À la place, utilisez toujours la commande create partition efi pour créer des partitions système EFI, la commande create partition msr pour créer des partitions réservées Microsoft, et la commande create partition primary (sans le paramètre ID=octet | GUID) pour créer des partitions principales sur des disques GPT.

Pour les disques MBR, vous pouvez spécifier un octet de type de partition, sous forme hexadécimale, pour la partition. Si aucun octet de type de partition n'est spécifié sur un disque MBR, la commande create partition primary crée une partition de type 0x6. N'importe quel octet de type de partition peut être spécifié avec le paramètre ID=octet | GUID. DiskPart ne vérifie pas la validité de l'octet de type de partition, pas plus qu'il n'effectue de contrôle du paramètre ID.

Pour les disques GPT, vous pouvez spécifier un GUID de type de partition pour la partition que vous voulez créer :
  • Partition système EFI : c12a7328-f81f-11d2-ba4b-00a0c93ec93b
  • Partition réservée Microsoft : e3c9e316-0b5c-4db8-817d-f92df00215ae
  • Partition MSDATA : ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
  • Partition LDM Metadata sur un disque dynamique : 5808c8aa-7e8f-42e0-85d2-e1e90434cfb3
  • Partition LDM Data sur un disque dynamique : af9b60a0-1431-4f62-bc68-3311714a69ad

Si aucun GUID de type de partition n'est spécifié, la commande create partition primary crée une partition MSDATA. N'importe quel type de partition peut être spécifié avec le paramètre ID={octet | GUID}. DiskPart ne vérifie pas la validité du GUID de partition, pas plus qu'il n'effectue de contrôle du paramètre ID.

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create volume raid

Crée un volume RAID-5 sur les disques dynamiques spécifiés. Après avoir créé le volume, le focus se déplace automatiquement sur le nouveau volume.

Syntaxe

create volume raid [size=n] [disk=n[,[n,…]] [noerr]

Paramètres

size=n
Espace disque, spécifié en méga-octets (Mo), que le volume occupera sur chaque disque. Si vous ne spécifiez aucune taille, la commande crée le volume RAID-5 le plus vaste possible. Le disque contenant la plus petite quantité d'espace disque disponible contigu détermine la taille du volume RAID-5 et la même quantité d'espace disque est allouée à partir de chaque disque. La quantité effective d'espace disque utilisable dans le volume RAID-5 est inférieure à la quantité combinée d'espace disque car une partie de cet espace est utilisée pour la parité.
disk=n
Disques dynamiques sur lesquels vous créez le volume. Une quantité d'espace égale à size=n est allouée sur chaque disque.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create volume simple

Crée un volume simple. Après avoir créé le volume, le focus se déplace automatiquement sur le nouveau volume.

Syntaxe

create volume simple [size=n] [disk=n] [noerr]

Paramètres

size=n
Taille du volume en méga-octets (Mo). Si aucune taille n'est spécifiée, le nouveau volume occupe la totalité de l'espace disque disponible sur le disque.
disk=n
Disque dynamique sur lequel vous créez le volume. Si aucun disque n'est spécifié, le disque courant est utilisé.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

create volume stripe

Crée un volume agrégé par bande sur les disques spécifiés. Après avoir créé le volume, le focus se déplace automatiquement sur le nouveau volume.

Syntaxe

create volume stripe [size=n] [disk=n[,[n,…]] [noerr]

Paramètres

size=n
Espace disque, spécifié en méga-octets (Mo), que le volume occupera sur chaque disque. Si aucune taille n'est spécifiée, le nouveau volume occupe le reste de l'espace disque disponible sur le plus petit disque et une quantité d'espace égale sur les disques suivants.
disk=n
Disques dynamiques sur lesquels vous créez le volume. Une quantité d'espace égale à size=n est allouée sur chaque disque.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

delete disk

Supprime un disque dynamique manquant dans la liste des disques.

Syntaxe

delete disk [noerr] [override]

Paramètres

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
override
Permet à DiskPart de supprimer tous les volumes simples sur le disque. Si le disque contient la moitié d'un volume en miroir, celle-ci est supprimée. La commande delete disk override échoue si le disque appartient à un volume RAID-5.

delete partition

Sur un disque de base, supprime la partition qui a le focus. Vous ne pouvez pas supprimer la partition système, la partition d'amorçage ou n'importe quelle partition qui contient le fichier d'échange ou fichier de vidage sur incident (vidage de la mémoire) actif.

Attention

  • Supprimer une partition sur un disque dynamique peut entraîner la suppression de tous les volumes dynamiques hors connexion du disque, supprimant ainsi toutes les données et convertissant le disque en disque de base. Pour supprimer un volume dynamique, utilisez toujours la commande delete volume à la place.

Les partitions peuvent être supprimées sur les disques dynamiques, mais elles ne doivent pas être créées. Par exemple, il est possible de supprimer une partition GPT (GUID Partition Table) non reconnue sur un disque GPT dynamique. La suppression d'une partition de ce type ne transforme pas l'espace disque libre qui en résulte en espace disponible. Cette commande vise notamment à permettre de récupérer l'espace occupé par un disque dynamique hors connexion et corrompu dans une situation d'urgence où la commande clean ne peut pas être utilisée.

Syntaxe

delete partition [noerr] [override]

Paramètres

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
override
Permet à DiskPart de supprimer n'importe quelle partition, quel qu'en soit le type. En règle générale, DiskPart vous permet uniquement de supprimer des partitions de données connues.

delete volume

Supprime le volume sélectionné. Vous ne pouvez pas supprimer le volume système, le volume d'amorçage ou n'importe quel volume contenant le fichier d'échange actif ou fichier de vidage sur incident (vidage de la mémoire).

Syntaxe

delete volume [noerr]

Paramètre

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

detail disk

Affiche les propriétés du disque sélectionné et les volumes présents sur ce disque.

Syntaxe

detail disk

detail volume

Affiche les disques sur lesquels le volume courant réside.

Syntaxe

detail volume

exit

Permet de quitter l'interpréteur de commande DiskPart.

Syntaxe

exit

extend

Étend le volume qui a le focus à l'espace non alloué et contigu du même disque. Pour les volumes de base, l'espace non alloué doit se trouver sur le même disque, et doit suivre la partition qui a le focus (être d'un décalage de secteur supérieur). Un volume dynamique simple ou fractionné peut être étendu à n'importe quel espace vide sur n'importe quel disque dynamique. Cette commande vous permet d'étendre un volume existant à un espace nouvellement créé.

Si la partition était précédemment formatée à l'aide du système de fichiers NTFS, le système de fichier est automatiquement étendu à la totalité de la nouvelle partition, plus vaste. Il ne se produit aucune perte de données. Si la partition était précédemment formatée avec un système de fichiers différent de NTFS, la commande échoue et aucune modification n'est apportée à la partition.

Vous ne pouvez pas étendre les partitions système ou d'amorçage actuelles.

Syntaxe

extend [size=n] [disk=n] [noerr]

Paramètres

size=n
Quantité d'espace, en méga-octets (Mo), à ajouter à la partition actuelle. Si vous ne spécifiez pas de taille, le disque est étendu à l'ensemble de l'espace non alloué contigu.
disk=n
Disque dynamique sur lequel vous étendez le volume. Une quantité d'espace égale à size=n est allouée sur le disque. Si vous ne spécifiez aucun disque, le volume est étendu sur le disque courant.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

help

Affiche la liste des commandes disponibles.

Syntaxe

help

import

Importe un groupe de disques étrangers dans le groupe de disques de l'ordinateur local. La commande import importe chaque disque qui est dans le même groupe que le disque qui a le focus.

Syntaxe

import [noerr]

Paramètre

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

list disk

Affiche la liste des disques et des informations sur ces disques, telles que leur taille, leur quantité d'espace disque disponible, leur type (de base ou dynamique) et si le disque utilise le style de partition MBR (Master Boot Record) ou GPT (GUID partition table). Le disque marqué d'un astérisque (*) a le focus.

Syntaxe

list disk

list partition

Affiche les partitions répertoriées dans la table de partition du disque courant. Sur les disques dynamiques, ces partitions peuvent ne pas correspondre aux volumes dynamiques du disque. Cette incohérence s'explique par le fait que les disques dynamiques contiennent des entrées dans la table de partition pour le volume système ou le volume d'amorçage (le cas échéant) ainsi qu'une partition qui occupe le reste du disque pour réserver l'espace à l'usage des volumes dynamiques.

Syntaxe

list partition

list volume

Affiche la liste des volumes de base et dynamiques de tous les disques.

Syntaxe

list volume

online

Met en ligne un disque ou un volume hors connexion qui a le focus.

Syntaxe

online [noerr]

Paramètre

noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

rem

Permet à l'utilisateur d'insérer un commentaire dans un script.

Syntaxe

rem

Exemples

rem Ces commandes configurent 3 lecteurs.

create partition primary size=2048

assign d:

create partition extended

create partition primary size=2048

assign e:

create partition logical

assign f:

remove

Supprime une lettre de lecteur ou un point de montage dans le volume qui a le focus. Si le paramètre all est utilisé, toutes les lettres de lecteur et tous les points de montage courants sont supprimés. Si aucune lettre de lecteur ou point de montage n'est spécifié, DiskPart supprime la première lettre de lecteur ou le premier point de montage qu'il rencontre.

La commande remove peut être utilisée pour changer la lettre de lecteur associée à un lecteur amovible. Vous ne pouvez pas supprimer les lettres de lecteur sur les volumes système, d'amorçage ou d'échange. De plus, vous ne pouvez pas supprimer la lettre de lecteur d'une partition OEM, d'une partition GPT dont le GUID n'est pas reconnu, de toute partition GPT non données spéciale telle que la partition système EFI.

Syntaxe

remove [{letter=d|mount=chemin [all]}] [noerr]

Paramètres

letter=d
La lettre de lecteur à supprimer.
mount=chemin
Le point de montage à supprimer.
all
Supprime toutes les lettres de lecteur et tous les points de montage courants.
noerr
Pour script uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

rescan

Repère les nouveaux disques qui peuvent avoir été ajoutés dans l'ordinateur.

Syntaxe

rescan

retain

Prépare un volume simple dynamique existant à être utilisé en tant que volume système ou d'amorçage.

Sur un ordinateur x86, crée une entrée de partition dans le MBR (Master Boot Record) du volume simple dynamique qui a le focus. Pour créer une partition MBR, le volume simple dynamique doit démarrer à un décalage ajusté aux cylindres et avoir une taille égale à un nombre entier de cylindres.

Sur un ordinateur Itanium, crée une entrée de partition dans le GPT (GUID Partition Table) du volume simple dynamique qui a le focus.

Remarque

  • La commande retain est destinée à être utilisée uniquement au cours d'installations sans assistance ou par les OEM (Original Equipment Manufacturers).

Syntaxe

retain

select disk

Sélectionne le disque spécifié en lui donnant le focus.

Syntaxe

select disk=[n]

Paramètres

n
Numéro du disque qui recevra le focus. Si aucun numéro de disque n'est spécifié, la commande select répertorie le disque qui possède actuellement le focus. Vous pouvez afficher les numéros de tous les disques de l'ordinateur à l'aide de la commande list disk.

select partition

Sélectionne la partition spécifiée et lui donne le focus. Si aucune partition n'est spécifiée, la commande select répertorie la partition qui possède actuellement le focus. Vous pouvez afficher les numéros de toutes les partitions du disque courant à l'aide de la commande list partition.

Syntaxe

select partition=[{n|d}]

Paramètres

n
Numéro de la partition qui recevra le focus.
d
La lettre de lecteur ou le chemin de points de montage de la partition qui recevra le focus.

select volume

Sélectionne le volume spécifié en lui donnant le focus. Si aucun volume n'est spécifié, la commande select répertorie le volume qui possède actuellement le focus. Vous pouvez spécifier le volume par numéro, par lettre de lecteur ou par chemin de points de montage. Sur un disque de base, sélectionner un volume donne également le focus à la partition correspondante. Vous pouvez afficher les numéros de tous les volumes de l'ordinateur à l'aide de la commande list volume.

Syntaxe

select volume=[{n|d}]

Paramètres

n
Numéro du volume qui recevra le focus.
d
La lettre de lecteur ou le chemin de points de montage du volume qui recevra le focus.

Scripts DiskPart

DiskPart vous permet de créer des scripts pour automatiser les tâches, comme créer des volumes ou convertir les disques en disques dynamiques. La mise en script de ces tâches est utile si vous déployez Windows à l'aide du programme d'installation sans assistance ou de Sysprep, qui ne prennent pas en charge la création de volumes autres que le volume d'amorçage.

Pour démarrer un script DiskPart, dans l'invite de commande, tapez :

DiskPart /S nomscript.txt

Où nomscript.txt est le nom du fichier de texte qui contient votre script.

Pour rediriger la sortie du script de DiskPart dans un fichier, tapez :

DiskPart /S nomscript.txt > fichierjournal.txt

Où nomjournal.txt est le nom du fichier de texte de destination de la sortie du script de DiskPart.

Lorsque DiskPart démarre, la version de DiskPart et le nom de l'ordinateur figurent dans l'invite de commande. Par défaut, si DiskPart rencontre une erreur en essayant d'effectuer une tâche du script, DiskPart arrête le traitement du script et affiche un code d'erreur (sauf si vous spécifiez le paramètre noerr). Sachez toutefois que DiskPart renvoie toujours les erreurs de syntaxe qu'il rencontre, que vous spécifiiez le paramètre noerr ou non. Le paramètre noerr vous permet d'effectuer des tâches utiles comme utiliser un seul script pour supprimer toutes les partitions de tous les disques, quel qu'en soit le nombre.

Le tableau suivant répertorie les codes d'erreur de DiskPart :

Erreur | Description
0 | Aucune erreur ne s'est produite. La totalité du script s'est exécutée sans erreur.
1 | Une exception fatale s'est produite. Il peut y avoir un problème sérieux.
2 | Les paramètres spécifiés pour une commande DiskPart étaient incorrects.
3 | DiskPart n'a pas réussi à ouvrir le script ou le fichier de sortie spécifié.
4 | Un des services utilisés par DiskPart a renvoyé une erreur.
5 | Une erreur de syntaxe de commande s'est produite. Le script a échoué car un objet a été sélectionné par erreur ou ne pouvait pas être utilisé avec cette commande.


Dos

Demande au sous-système MS-DOS de maintenir une liaison avec la zone de mémoire haute (HMA) ou de se charger partiellement dans cette zone.

Syntaxe

dos={high|low}[{,umb|,noumb}]

dos={[high,|low,}]{umb|noumb}

Paramètres

{high|low
Détermine si le sous-système MS-DOS doit essayer de se charger partiellement dans la zone de mémoire haute ou non. Utilisez high pour autoriser le sous-système MS-DOS à se charger lui-même dans la zone de mémoire haute. Utilisez low pour conserver la totalité du sous-système MS-DOS dans la mémoire conventionnelle. Le paramètre par défaut est low.
{umb|noumb}
Détermine si le sous-système MS-DOS doit maintenir une liaison entre la mémoire conventionnelle et la zone de mémoire haute. Umb fournit cette liaison. Noumb déconnecte cette liaison. Le paramètre par défaut est noumb.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Installation de Himem.sys pour dos=umb ou dos=high

    Pour pouvoir spécifier dos=umb ou dos=high, vous devez obligatoirement installer le pilote de périphérique HiMem.sys.

  • Utilisation de umb

    Pour pouvoir charger des programmes et des pilotes de périphérique dans la zone de mémoire haute, vous devez spécifier dos=umb. L'emploi de cette zone libère davantage de mémoire conventionnelle pour les programmes. Il est également nécessaire d'installer un fournisseur de blocs de mémoire haute (UMB).

  • Emploi du paramètre high

    Si vous spécifiez le paramètre high, le sous-système MS-DOS tente de charger une partie de lui-même dans la zone de mémoire haute. Le chargement d'une partie de MS-DOS dans la zone de mémoire haute libère de la mémoire conventionnelle pour les programmes.

  • Combinaison de paramètres

    Si vous spécifiez le paramètre high, le sous-système MS-DOS tente de charger une partie de lui-même dans la zone de mémoire haute. Le chargement d'une partie de MS-DOS dans la zone de mémoire haute libère de la mémoire conventionnelle pour les programmes.

    À condition de les séparer par des virgules, il est possible d'inclure plusieurs paramètres sur une même ligne de commande dos. Par exemple, la syntaxe suivante est valide :

    dos=umb,low
    dos=high,umb

    La commande dos peut être placée n'importe où dans le fichier Config.nt ou dans le fichier de démarrage équivalent.


Commandes du sous-système MS-DOS

Windows XP inclut des commandes 16 bits (non natives) pour le sous-système MS-DOS ainsi que pour d'autres sous-systèmes. On trouve parmi celles-ci des commandes anciennes, telles que edlin ou graphics, et des commandes spécifiques à MS-DOS, telles que debug ou exe2bin. Ces commandes 16 bits ne sont offertes que pour maintenir la compatibilité avec MS-DOS et MS OS/2 version 1.x.

D'autres commandes du sous-système MS-DOS, comme share, possèdent des fonctionnalités qui sont maintenant intégrées à Windows XP ou au sous-système MS-DOS. Les commandes sont conservées dans un souci de compatibilité avec les fichiers existants, mais n'ont pas d'effet dans la ligne de commande car la fonctionnalité est automatique.

Remarque

  • Les commandes du sous-système MS-DOS 16 bits suivantes ne sont pas disponibles dans Windows XP 64-Bit Edition.

Pour plus d'informations, cliquez sur une commande :

  • Append
  • Debug
  • Sous-commandes de Debug
  • Edit
  • Edlin
  • Sous-commandes de Edlin
  • Exe2bin
  • Fastopen
  • Forcedos
  • Graphics
  • Loadfix
  • Loadhigh (lh)
  • Mem
  • Nlsfunc
  • Setver
  • Share

Pour configurer le sous-système MS-DOS, utilisez des commandes de configuration telles que device ou lastdrive. Placez ces commandes dans le fichier Config.nt du répertoire racine_système\System32 ou dans le fichier Config spécifié par le fichier PIF (Program Information File) d'une application. Ces commandes affectent uniquement le sous-système MS-DOS. Le sous-système MS-DOS ignore nombre de ces commandes, telles que buffers et break, car il fonctionne sans elles. Elles ne sont acceptées qu'à des fins de compatibilité.

Pour plus d'informations sur les commandes de configuration du sous-système MS-DOS, cliquez sur une commande :

  • Buffers
  • Country
  • Device
  • Devicehigh
  • Dos
  • Dosonly
  • Driveparm
  • Echoconfig
  • Fcbs
  • Files
  • Install
  • Lastdrive
  • Ntcmdprompt
  • Shell
  • Stacks
  • Switches


Doskey

Appelle Doskey.exe, qui rappelle les commandes Windows XP, édite les lignes de commande et crée des macros.

Syntaxe

doskey {/reinstall | /listsize=taille | /macros:[{all | nom-exe}] | /history | /insert | /overstrike | /exename=nom-exe | /macrofile=NomFichier | nom-macro=[texte]}

Paramètres

/reinstall
Installe une nouvelle copie de Doskey.exe. Efface la mémoire tampon de l'historique de la commande.
/listsize=taille
Indique le nombre maximal de commandes dans la zone tampon d'historique.
/macros
Affiche la liste de toutes les macros doskey. Vous pouvez utiliser un symbole de redirection (>) avec /macros pour rediriger la liste vers un fichier. Vous pouvez abréger /macros en /m.
all
Affiche les macros doskey pour tous les exécutables.
nom-exe
Affiche les macros doskey du fichier exécutable spécifié.
/history
Affiche toutes les commandes stockées en mémoire. Vous pouvez utiliser un symbole de redirection (>) avec /history pour rediriger la liste vers un fichier. Vous pouvez abréger /history en /h.
{/insert | /overstrike}
Indique si le nouveau texte que vous tapez doit remplacer l'ancien. Si vous utilisez /insert, le nouveau texte que vous tapez sur une ligne est inséré à la place du texte existant (comme si vous appuyez sur la touche INSER). Si vous utilisez /overstrike, le nouveau texte remplace l'ancien. Le paramètre par défaut est /overstrike.
/exename=nom-exe
Spécifie le programme (c'est-à-dire, le fichier exécutable) dans lequel la macro doskey est exécutée.
/macrofile=NomFichier
Spécifie un fichier contenant les macros que vous voulez installer.
nom_macro=[texte]
Crée une macro qui exécute les commandes spécifiées par le texte. Le nom_macro représente le nom à assigner à la macro. Texte spécifie les commandes à enregistrer. Si vous ne complétez pas le paramètre texte, toutes les commandes éventuellement assignées au nom_macro sont supprimées.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de Doskey.exe

    Doskey.exe est toujours disponible pour tous les programmes de mode caractère et interactif (tels que des débogueurs de programmation ou des programmes de transfert de fichier), et maintient un tampon d'historique de commandes et des macros pour chaque programme qu'il démarre. Vous ne pouvez pas utiliser les options de ligne de commande doskey à partir d'un programme. Vous devez exécuter les options de ligne de commande doskey avant de démarrer un programme. Les assignations de touches de programme supplantent les assignations de touches doskey.

  • Rappel d'une commande

    Pour rappeler une commande, vous pouvez utiliser n'importe quelle touche parmi les suivantes après avoir démarré Doskey.exe. Si vous utilisez Doskey.exe à l'intérieur d'un programme, les affectations de touches de ce programme ont priorité.

    Touche | Description
    HAUT | Rappelle la commande utilisée avant celle qui est affichée.
    BAS | Rappelle la commande utilisée après celle qui est affichée.
    PG.PREC | Rappelle la première commande utilisée pendant la session en cours.
    PG. SUIV | Rappelle la dernière commande utilisée.
  • Modification de la ligne de commande

    Doskey.exe vous permet de modifier la ligne de commande en cours. Si vous utilisez Doskey.exe à partir d'un programme, les assignations de touches de ce programme sont prioritaires et certaines touches de modification Doskey.exe risquent de ne pas fonctionner.

    La liste ci-dessous décrit les touches d'édition de doskey et leurs fonctions :

    Touche ou combinaison de touches | Description
    GAUCHE | Recule le point d'insertion d'un caractère.
    DROITE | Avance le point d'insertion d'un caractère.
    CTRL+GAUCHE | Recule le point d'insertion d'un mot.
    CTRL+DROITE | Avance le point d'insertion d'un mot.
    ORIGINE | Ramène le point d'insertion au début de la ligne.
    FIN | Avance le point d'insertion à la fin de la ligne.
    ÉCHAP | Efface la commande de l'affichage.
    F1 | Copie un caractère de la même colonne du modèle dans la même colonne de la fenêtre d'invite de commande. (Le modèle est une zone tampon qui conserve la dernière commande tapée.)
    F2 | Cherche vers l'avant du modèle la touche tapée après F2. Doskey.exe insère le texte du modèle jusqu'au caractère spécifié sans inclure ce dernier.
    F3 | Copie le reste du modèle sur la ligne de commande. Doskey.exe commence à copier les caractères à partir de la position du modèle qui correspond à celle indiquée par le point d'insertion sur la ligne de commande.
    F4 | Supprime des caractères depuis la position en cours du point d'insertion jusqu'à celui que vous spécifiez. Pour utiliser cette touche d'édition, appuyez sur F4 et tapez un caractère. Doskey.exe supprime les caractères à partir de la position en cours du point d'insertion jusqu'à la première lettre spécifiée.
    F5 | Copie le modèle dans la ligne de commande en cours.
    F6 | Place un caractère de fin de fichier (c'est-à-dire, CTRL+Z) à la position en cours du point d'insertion.
    F7 | Affiche toutes les commandes pour ce programme stockées en mémoire dans une boîte de message. Utilisez les touches HAUT et BAS pour sélectionner la commande souhaitée, puis appuyez sur la touche ENTRÉE pour exécuter la commande. Vous pouvez aussi noter le numéro qui précède la commande et utiliser ce numéro avec la touche F9.
    ALT+F7 | Supprime toutes les commandes stockées en mémoire pour la zone tampon d'historique en cours.
    F8 | Affiche toutes les commandes dans la zone tampon d'historique, en commençant par les caractères de la commande en cours.
    F9 | Vous demande un numéro de commande tampon d'historique, puis affiche la commande associée au numéro que vous tapez. Appuyez sur ENTRÉE pour exécuter la commande. Pour afficher tous les numéros ainsi que les commandes qui leur sont associées, appuyez sur F7.
    ALT+F10 | Supprime toutes les définitions de macro.
  • Utilisation de doskey dans un programme

    Certains programmes interactifs en mode caractère, tels que des débogueurs de programmation ou des programmes de transfert de fichier (FTP), utilisent automatiquement Doskey.exe. Pour utiliser Doskey.exe, un programme doit être un processus de console et utiliser des informations stockées en mémoire tampon. Les assignations de touches de programme supplantent les assignations de touches doskey. Par exemple, si le programme utilise la touche F7 pour une fonction spécifique, vous ne pouvez pas afficher l'historique d'une commande doskey dans une boîte de message.

    Avec Doskey.exe, vous pouvez tenir à jour un historique de commande pour chaque programme que vous lancez, répéter et modifier les commandes précédentes à l'invite du programme, et lancer des macros doskey créées pour le programme. Si vous quittez, puis relancez un programme à partir de la même fenêtre d'invite de commandes, l'historique de commande de la session de programme précédente est disponible.

    Vous devez exécuter Doskey.exe avant de démarrer un programme. Vous ne pouvez pas utiliser des options de ligne de commande doskey à partir de l'invite de commandes d'un programme, même si le programme a une invite de commandes.

    Si vous voulez personnaliser la manière avec laquelle Doskey.exe fonctionne avec un programme et créer des macros doskey pour ce programme, vous pouvez créer un programme de commandes qui modifie Doskey.exe et démarre le programme.

  • Sélection du mode insertion par défaut

    Si vous appuyez sur la touche INSERTION, vous pouvez taper le texte de la ligne de commande doskey au milieu de son texte existant sans remplacer ce dernier. Lorsque vous appuyez sur ENTRÉE, Doskey.exe remet cependant le clavier en mode remplacement. Pour revenir au mode insertion, vous devez réappuyer sur INSERTION.

    Utilisez /insert pour mettre votre clavier en mode insertion chaque fois que vous appuyez sur la touche ENTRÉE. Le clavier demeure ensuite en mode insertion jusqu'à ce que vous utilisiez /overstrike. Pour revenir temporairement au mode remplacement, appuyez sur la touche INSERTION ; après avoir appuyé sur ENTRÉE, Doskey.exe remet cependant le clavier en mode insertion.

    Lorsque vous utilisez la touche INSERTION pour passer d'un mode à l'autre, le point d'insertion change de forme.

  • Création d'une macro

    Le programme Doskey.exe permet de créer des macros exécutant une ou plusieurs commandes. Le tableau suivant répertorie les caractères spéciaux que vous pouvez utiliser pour contrôler les opérations de commande lorsque vous définissez une macro.

    Caractère | Description
    $G ou $g | Redirige les données de sortie. Utilisez l'un ou l'autre de ces caractères spéciaux pour envoyer les données de sortie à un périphérique ou à un fichier au lieu de les diriger vers l'écran. Ces caractères sont équivalents au symbole de redirection des données de sortie (>).
    $G$G ou $g$g | Ajoute les données de sortie à la fin d'un fichier. Utilisez l'un ou l'autre de ces doubles caractères spéciaux pour ajouter les données de sortie à un fichier existant au lieu de les substituer aux informations du fichier. Ces doubles caractères sont équivalents au symbole de redirection d'ajout des données de sortie (>>).
    $L ou $l | Redirige les données d'entrée. Utilisez l'un ou l'autre de ces caractères spéciaux pour lire les données d'entrée à partir d'un périphérique ou d'un fichier et non pas du clavier. Ces caractères sont équivalents au symbole de redirection des données d'entrée (<).
    $B ou $b | Envoie les données de sortie d'une macro à une commande. Ces caractères spéciaux correspondent à l'utilisation d'une barre verticale (|) dans une ligne de commande.
    $T ou $t | Sépare des commandes. Utilisez l'un ou l'autre de ces caractères spéciaux pour séparer des commandes lorsque vous créez des macros ou que vous tapez des commandes sur la ligne de commande doskey. Ces caractères spéciaux correspondent à l'utilisation du symbole & dans une ligne de commande.
    $$ Indique le symbole du dollar ($).
    $1 à $9 | Représente toute information de ligne de commande à spécifier lors de l'exécution de la macro. Les caractères spéciaux $1 à $9 sont des paramètres de commande qui vous permettent d'utiliser sur la ligne de commande des données différentes chaque fois que vous exécutez la macro. Le caractère $1 d'une commande doskey est semblable au caractère %1 d'un programme de commandes.
    $* Représente toutes les informations de ligne de commande que vous voulez indiquer lorsque vous tapez le nom de la macro. Le caractère spécial $* est un paramètre remplaçable semblable aux paramètres de commande $1 à $9, à une différence importante près : tout ce que vous tapez sur la ligne de commande à la suite du nom de la macro se substitue au $* de la macro.
  • Exécution d'une macro doskey

    Pour exécuter une macro, tapez son nom à partir de la première position de la ligne de commande. Si la macro a été définie avec $* ou n'importe quels paramètres de commande $1 à $9, utilisez un espace pour séparer les paramètres. Il vous est impossible d'exécuter une macro doskey à partir d'un programme de commandes.

  • Création d'une macro portant le même nom qu'une commande Windows XP

    Si vous utilisez toujours une commande particulière avec des options de ligne de commande spécifiques, vous pouvez créer une macro portant le même nom que la commande. Pour indiquer si vous voulez exécuter la macro ou la commande, suivez les directives ci-dessous :

    • Pour exécuter la macro, commencez à taper son nom immédiatement après l'invite de commandes, sans laisser d'espace entre cette invite et le nom de la commande.
    • Pour exécuter la commande, insérez un ou plusieurs espaces entre l'invite de commandes et son nom.
  • Suppression d'une macro

    Pour supprimer une macro, tapez :

    doskey nom-macro=

Exemples

Les options de ligne de commande /macros et /history sont utiles pour créer des programmes de commandes qui enregistrent des macros et des commandes. Par exemple, pour stocker toutes les macros doskey courantes, tapez :

doskey /macros > macinit

Pour utiliser les macros stockées dans Macinit, tapez :

doskey /macrofile=macinit

Pour créer un programme de commandes nommé Tmp.bat contenant des commandes récemment utilisées, tapez :

doskey /history > tmp.bat

Pour définir une macro de commandes multiples, utilisez $t pour séparer les commandes, comme indiqué ci-dessous :

doskey tx=cd temp$tdir/w $*

Dans l'exemple précédent, la macro TX fait de Temp le répertoire en cours, puis affiche la liste d'un répertoire en format large. Vous pouvez utiliser $* à la fin de la macro pour ajouter d'autres options de ligne de commande à la commande dir lors de l'exécution de TX.

La macro suivante utilise un paramètre de commande comme nouveau nom de répertoire :

doskey mc=md $1$tcd $1

La macro crée un répertoire, puis passe du répertoire en cours à ce nouveau répertoire.

Pour utiliser la macro ci-dessus en vue de créer un répertoire nommé Livres et de passer à ce répertoire, tapez :

mc livres

Pour créer une macro doskey pour un programme appelé Ftp.exe, incluez /exename comme suit :

doskey /nom_exe:ftp.exe go=open 10.127.1.100$tmget *.txt c:\reports$bye

Pour utiliser la macro ci-dessus, lancez ftp. À l'invite ftp, tapez :

go

Ftp exécute les commandes open, mget et bye.

Pour créer une macro qui effectue un format de disque rapide et inconditionnel, tapez :

doskey qf=format $1 /q /u

Pour formater rapidement et inconditionnellement une disquette dans le lecteur A, tapez :

qf a:


Dosonly

Empêche le démarrage d'applications ne fonctionnant pas sous MS-DOS à partir de l'invite de Command.com.

Syntaxe

dosonly

Paramètres

Aucun

Remarques

  • Lorsque vous quittez une application MS-DOS, Windows XP revient à l'interpréteur de commande Cmd.exe. Lorsque vous exécutez un programme TSR (Terminate-and-stay-resident) ou que vous interrompez momentanément une application MS-DOS pour revenir à l'invite de commandes, Windows XP exécute Command.com, l'interpréteur de commande de l'environnement MS-DOS. Cela préserve l'environnement MS-DOS tout en vous permettant d'utiliser immédiatement le programme TSR.

    Étant donné que le démarrage et l'exécution d'autres types d'applications à partir de l'invite Command.com peuvent interrompre un programme TSR ou suspendre une application MS-DOS, Windows XP fournit la commande dosonly. Avec dosonly, vous pouvez uniquement démarrer des applications MS-DOS à partir de l'invite Command.com. Vous pouvez inclure dosonly dans votre fichier Config.nt ou dans le fichier de démarrage personnalisé équivalent qui se trouve dans le fichier PIF d'une application.

  • Config.nt initialise l'environnement MS-DOS, sauf si vous spécifiez un autre fichier de démarrage dans le fichier PIF d'une application.

Exemples

Incluez dosonly dans votre fichier Config.nt ou dans le fichier de démarrage Config spécifié dans le fichier PIF. L'exemple suivant présente l'apparence d'un fichier Config.nt.

dos=high,umb
device=%systemroot%\system32\himem.sys
files=40
@echo off
dosonly

Rubriques connexes


Driveparm

XOX

Rubriques connexes


Driverquery

Affiche la liste de tous les pilotes installés et de leurs propriétés.

Syntaxe

driverquery [/s Ordinateur] [/u Domaine\Utilisateur /p MotDePasse] [/fo {TABLE|LIST|CSV}] [/nh] [/v] [/si]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/fo {TABLE|LIST|CSV}
Spécifie le format d'affichage des informations du pilote. Les valeurs valides sont TABLE, LIST et CSV. Le format de sortie par défaut est TABLE.
/nh
Omet la ligne d'en-tête dans les informations affichées sur les pilotes. Valide lorsque le paramètre /fo est TABLE ou CSV.
/v
Spécifie l'affichage des informations détaillées sur les pilotes.
/si
Affiche les informations de signature numérique des pilotes de périphériques signés et non signés.
/?
Affiche l'aide dans l'invite de commandes.

Exemples

Les exemples suivants décrivent l'utilisation de la commande driverquery :

driverquery
driverquery /fo csv
driverquery /nh
driverquery /s ipaddress
driverquery /s server1 /u hirpln /v driverquery /s server1 /u maindom\hirpln /p p@ssw3d /fo list


Echo

Active ou désactive la fonctionnalité d'écho des commandes ou affiche un message. Utilisée sans paramètre, la commande echo affiche le paramètre d'écho actuel.

Syntaxe

echo [{on|off}] [message]

Paramètres

{on|off}
Indique si l'écho des commandes doit être activé ou désactivé.
message
Spécifie le texte que vous voulez afficher à l'écran.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • La commande echo message s'avère utile quand l'écho est désactivé. Pour faire apparaître un message de plusieurs lignes de long sans afficher d'autres commandes, vous pouvez inclure plusieurs commandes echo message à la suite de la commande echo off dans votre programme de commandes.
  • Si vous utilisez echo off, l'invite de commandes n'apparaît pas à l'écran. Pour afficher l'invite de commandes, tapez echo on.
  • Pour éviter l'écho d'une ligne, insérez un signe (@) devant une commande dans un programme de commandes.
  • Pour faire un écho d'une ligne blanche à l'écran, tapez :

    echo.

  • Pour afficher un signe “ | ” ou un caractère de redirection (< ou >) quand vous utilisez echo, faites-le précéder d'un caret (par exemple, ^>, ^< ou ^| ). Si vous devez utiliser le caret proprement dit (^), tapez-le deux fois (^^).

Exemples

L'exemple suivant illustre un programme de commandes qui inclut un message de trois lignes précédées et suivies d'une ligne blanche :

echo off
echo.
echo This batch program
echo formats and checks
echo new disks
echo.

Pour désactiver echo et ne pas renvoyer en écho la commande echo elle-même, faites précéder celle-ci d'un signe @, comme suit :

@echo off

Vous pouvez utiliser les commandes if et echo sur la même ligne de commande. Exemple :

if exist *.rpt echo Le rapport nous est parvenu.


Echoconfig

Affiche des messages au cours du traitement des fichiers d'informations des programmes Config.nt et Autoexec.nt du sous-système MS-DOS. En l'absence de cette commande, les messages n'apparaissent pas.

Paramètres

Aucun

Remarques

  • Vous devez ajouter cette commande dans le fichier Config.nt du sous-système MS-DOS. L'exemple suivant présente l'apparence d'un fichier Config.nt.

    dos=high,umb
    device=%systemroot%\system32\himem.sys
    files=40
    echoconfig

XOX

Rubriques connexes


Modifier

Lance l'Éditeur MS-DOS, qui crée et modifie les fichiers texte ASCII. Utilisée dans paramètres, edit démarre MS-DOS Editor.

Syntaxe

edit [[Lecteur:][Chemin] NomFichier] [/b] [/g] [/h] [/nohi]

Paramètres

[Lecteur:][Chemin] NomDeFichier
Indique l'emplacement et le nom d'un fichier texte ASCII. Si ce fichier n'existe pas, l'Éditeur MS-DOS le crée. S'il existe, l'éditeur MS-DOS l'ouvre et affiche son contenu à l'écran.
/b
Affiche l'Éditeur MS-DOS en noir et blanc. Utilisez cette option de ligne de commande si un moniteur monochrome n'affiche pas correctement MS-DOS Editor.
/g
Utilise la mise à jour de l'écran la plus rapide possible pour un moniteur CGA.
/h
Affiche le nombre maximal de lignes possible pour le moniteur courant.
/nohi
Permet d'utiliser des moniteurs à 8 couleurs avec l'Éditeur MS-DOS. En règle générale, Windows XP utilise 16 couleurs.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • XOX
  • Il se peut que certains moniteurs ne prennent pas en charge l'affichage par défaut des touches de raccourci. Si c'est le cas de votre moniteur, utilisez /b (pour les écrans CGA) et /nohi (pour les systèmes qui ne prennent pas en charge les caractères gras).


Edlin

Démarre Edlin.exe, un éditeur de texte orienté ligne qui permet de créer et de modifier des fichiers ASCII.

Syntaxe

edlin [Lecteur:][Chemin] NomDeFichier [/b]

Paramètres

[Lecteur:][Chemin] NomDeFichier
Indique l'emplacement et le nom d'un fichier ASCII sur disque. NomDeFichier est obligatoire. Si le fichier existe, Edlin.exe l'ouvre. Dans le cas contraire, l'éditeur crée un fichier en mémoire et utilise l'emplacement et le nom de fichier spécifiés pour générer le fichier sur disque lorsque vous utilisez la sous-commande e.
/b
Indique que Edlin.exe va ignorer le caractère de fin de fichier (CTRL+Z).
?
Affiche la liste des sous-commandes de edlin.

Remarques

  • XOX
  • XOX
  • Utilisation de Edlin.exe

    Edlin.exe numérote chaque ligne du fichier texte en mémoire. Vous pouvez utiliser Edlin.exe pour insérer, modifier, copier, déplacer et supprimer des lignes du fichier. Si vous souhaitez utiliser un éditeur plein écran, employez la commande edit.

  • Longueur de ligne maximale

    Edlin.exe accepte jusqu'à 253 caractères par ligne.

  • Utilisation des sous-commandes edlin

    Il existe plusieurs sous-commandes edlin que vous pouvez utiliser. Pour plus d'informations sur les sous-commandes edlin, consultez Rubriques connexes.

  • Présentation du caractère astérisque

    Lorsqu'un astérisque apparaît comme le seul caractère d'une ligne, il s'agit de l'invite * de edlin, après laquelle vous tapez les sous-commandes edlin. Lorsqu'un astérisque apparaît après un numéro de ligne, il signale que la ligne est la ligne en cours (où se trouve le curseur).

  • Affichage d'une page de texte

    Une page de texte est un écran complet d'informations. En mode écran de 25 lignes, Edlin.exe affiche 24 lignes de texte par page. Le nombre de lignes par page dépend du mode écran que vous utilisez.

  • Activation et désactivation du mode insertion

    Pour insérer des lignes dans le fichier en mémoire, utilisez la sous-commande i (insert). Quand vous avez terminé d'insérer des lignes, appuyez sur ENTRÉE, puis sur CTRL+C pour désactiver le mode insertion. Pour plus d'informations sur l'insertion de lignes à l'aide de la sous-commande i (insert), consultez Rubriques connexes.

  • Touches d'édition

    Vous disposez de plusieurs touches d'édition pour modifier le fichier en mémoire.


Edlin : a (append)

Charge une partie d'un fichier en mémoire quand la mémoire disponible est insuffisante pour charger la totalité du fichier. Utilisée sans paramètres, a charge des lignes du fichier disque jusqu'à ce que la mémoire disponible soit pleine à 75%. Si cela est déjà le cas, Edlin.exe ne charge aucune ligne.

Syntaxe

[n]a

Paramètres

n
Spécifie le nombre de lignes à lire en mémoire à partir du disque.
?
Affiche la liste des sous-commandes de edlin.

Remarques

  • XOX
  • XOX
  • Au démarrage, Edlin.exe lit autant de lignes que possible à partir du fichier disque en mémoire. Si la taille du fichier dépasse celle de la mémoire disponible, vous devez éditer le fichier par étapes. Pour cela, éditez la première partie du fichier, enregistrez-la sur disque à l'aide de la sous-commande w (write), puis chargez en mémoire d'autres lignes non éditées à partir du disque.
  • Une fois que la sous-commande a a lu la dernière ligne du fichier en mémoire, Edlin.exe affiche le message suivant :

    Fin du fichier d'entrée

Exemples

Dans cet exemple, les 100 dernières lignes de votre fichier disque n'entrent pas dans la mémoire. Vous éditez la première partie du fichier et en réécrivez une portion sur un disque. Pour charger les 100 lignes restantes en mémoire, tapez :

100a


Edlin : c (copy)

Copie un bloc de lignes successives vers un ou plusieurs emplacements au sein du fichier en mémoire. Vous pouvez copier ce bloc autant de fois que nécessaire.

Syntaxe

[ligne1],[ligne2],ligne3,[compte]c

Paramètres

ligne1
Spécifie la première ligne à copier.
ligne2
Spécifie la dernière ligne à copier.
ligne3
Important. Spécifie la ligne de destination avant laquelle vous voulez insérer le bloc de lignes spécifié.
compte
Spécifie le nombre de fois que vous voulez copier le bloc de lignes.

Remarques

  • XOX
  • XOX
  • Omission de valeurs de paramètres

    Si vous omettez ligne1 ou ligne2, Edlin.exe copie uniquement la ligne en cours. Vous devez inclure les virgules dans la ligne de commande, même si vous omettez l'un des paramètres, ou les deux, et vous devez spécifier le numéro de la ligne de destination.

    Si vous omettez le paramètre compte, Edlin.exe copie les lignes une seule fois.

  • Renumérotation des lignes

    Une fois que Edlin.exe a copié les lignes, vous pouvez utiliser la sous-commande l (list) à l'invite * pour visualiser les lignes correctement renumérotées.

  • Chevauchement de numéros de lignes

    La ligne spécifiée comme paramètre ligne3 ne peut pas faire partie du bloc à copier. Si les numéros de lignes se chevauchent de cette manière, Edlin.exe ne peut pas terminer la copie et affiche le message suivant :

    Erreur d'entrée

Exemples

Pour copier une fois les lignes 1 à 5, en commençant à la ligne 6, tapez :

1,5,6c

Les lignes 6 à 10 deviennent identiques aux lignes 1 à 5.

Pour copier la ligne courante dans la ligne 5, tapez :

,,5c

Pour voir le message d'erreur qui apparaît si les numéros de ligne se chevauchent, tapez :

3,20,15c


Edlin : d (delete)

Efface le bloc de lignes successives spécifié. Utilisé sans paramètres, d supprime la ligne courante.

Syntaxe

[ligne1][,ligne2]d

Paramètres

ligne1
Indique la première ligne à effacer.
ligne2
Indique la dernière ligne à effacer.
?
Affiche la liste des sous-commandes de edlin.

Remarques

  • XOX
  • XOX
  • Omission de valeurs de paramètres

    Si vous omettez les deux paramètres ou seulement ligne2, Edlin.exe supprime la ligne en cours. Néanmoins, si vous omettez seulement le paramètre ligne1, Edlin.exe efface le bloc de texte incluant la ligne en cours jusqu'à la ligne spécifiée par ligne2. Dans ce cas, il vous est impossible de spécifier comme paramètre ligne2 un numéro précédant le numéro de la ligne en cours. Le numéro spécifié pour ligne2 ne peut pas être inférieur à celui du paramètre ligne1. Si vous omettez seulement le paramètre ligne1, vous devez insérer une virgule de remplissage avant ligne2, comme indiqué sous Syntaxe.

  • Renumérotation des lignes

    Une fois que Edlin.exe a supprimé des lignes, vous pouvez utiliser la sous-commande l (list) à l'invite * pour visualiser les lignes correctement renumérotées qui restent.

Exemples

Pour supprimer la ligne 7, tapez :

7d

Pour supprimer le bloc de texte des lignes 22 à 32, tapez :

22,32d

Dans cet exemple, le numéro de la ligne en cours est 7. Pour supprimer le bloc de texte entre la ligne en cours incluse et la ligne 11, tapez :

,11d


Edlin : e (end)

Renomme le fichier d'entrée initial sur disque avec l'extension .bak, enregistre le fichier édité en mémoire dans le fichier d'entrée initial sur disque, puis arrête la session Edlin.exe.

Syntaxe

e

Paramètres

Aucun

Remarques

  • XOX
  • XOX
  • Si le fichier en mémoire a été créé pendant cette session et s'il ne s'agit pas d'un fichier chargé à partir d'un disque, Edlin.exe ne crée pas de fichier de sauvegarde (.bak) sur le disque.
  • Edlin.exe enregistre le fichier édité à partir de la mémoire vers le lecteur, le répertoire et le nom de fichier sur disque que vous spécifiez au démarrage de la session Edlin.exe en cours. Si vous omettez le nom d'un lecteur à ce moment, Edlin.exe effectue l'enregistrement sur le lecteur en cours. Si vous omettez le nom d'un répertoire à ce moment, Edlin.exe effectue l'enregistrement dans le répertoire en cours.
  • Avant d'utiliser la sous-commande e, vous devez vérifier que votre disque peut contenir la totalité du fichier édité en mémoire. Sinon, Edlin.exe perd une partie ou l'intégralité du fichier.
  • Si vous essayez d'enregistrer un fichier édité de la mémoire sur un disque, mais que la version .bak du fichier est en lecture seule, Edlin.exe affiche un message dans le format suivant, pour vous informer que edlin ne peut pas remplacer le fichier .bak :

    Accès refusé - [Lecteur:][Chemin] NomDeFichier.bak

    Les versions d'origine et de sauvegarde du fichier sur le disque demeureront inchangées.


Edlin : i (insert)

Insère des lignes avant le numéro spécifié dans le fichier édité qui réside en mémoire. Utilisé sans paramètres, i démarre le mode d'insertion dans la ligne en cours.

Syntaxe

i [ligne]

Paramètres

ligne
Spécifie le numéro de ligne avant laquelle Edlin.exe doit insérer des lignes. La valeur par défaut de ligne est le numéro de la ligne en cours.

Remarques

  • XOX
  • XOX
  • Utilisation de la sous-commande i

    Si vous créez un fichier, vous devez taper la commande i avant d'insérer une ligne. Edlin.exe affiche le numéro de ligne suivant chaque fois que vous appuyez sur ENTRÉE. Pour quitter le mode d'insertion, appuyez sur CTRL+C.

  • Renumérotation des lignes

    Lorsque vous quittez le mode insertion, la ligne placée après les lignes insérées devient la ligne en cours. Vous pouvez utiliser la sous-commande l (list) à l'invite * pour visualiser les lignes correctement renumérotées.

  • Insertion de caractères de contrôle

    Pour insérer un caractère de contrôle dans le texte, tapez :

    ^V symboleASCII

    symboleASCII est le symbole ASCII qui représente le caractère de contrôle. Par exemple, pour insérer un caractère d'échappement (CTRL+[), tapez :

    ^V[

    Pour insérer un caractère générant un son (CTRL+G), tapez :

    ^VG

  • Ajout de texte

    Si la valeur du paramètre ligne est supérieure au nombre de lignes contenues dans le fichier édité ou si vous spécifiez un symbole numéro (#) comme paramètre ligne, Edlin.exe ajoute la ligne insérée à la fin du fichier. Dans les deux cas, la dernière ligne insérée devient la ligne en cours. Si seule une partie du fichier est en mémoire, la ligne est ajoutée à la fin de cette partie.

Exemples

Le texte suivant apparaît à l'écran lorsque vous avez utilisé la sous-commande l (list) :

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6: convaincu par votre potentiel.
7:
8: Bien à vous,
9:
10: S.L. Martin, président

Pour insérer le texte avant la ligne 8, tapez :

8I

Edlin.exe affiche le résultat suivant :

8:*_

Tapez la ligne qui suit au point d'insertion sur la ligne 8 :

8:*Je pense que vous collaborerez avec plaisir avec

Appuyez sur ENTRÉE à la fin de chaque nouvelle ligne, puis tapez :

9: *Mme Lang au nouveau projet. N'hésitez
10: *pas à me contacter
11: *si je peux vous aider.

Edlin.exe affiche le résultat suivant :

12:*_

Insérez une ligne vierge en appuyant sur ENTRÉE et terminez en appuyant sur CTRL+C sur la ligne suivante. Tapez 1l pour voir les lignes correctement renumérotées :

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6: convaincu par votre potentiel.
7:
8: Je pense que vous collaborerez avec plaisir avec
9: Mme Lang au nouveau projet. N'hésitez
10: pas à me contacter
11: si je peux vous aider.
12:
13:*Bien à vous,
14:
15: S.L. Martin, président


Edlin : l (list)

Affiche le bloc de lignes consécutives que vous spécifiez. Utilisé sans paramètres, l (list) affiche jusqu'à une page, en commençant 11 lignes avant la ligne courante.

Syntaxe

l [ligne1][,ligne2]

Paramètres

ligne1
Spécifie la première ligne que Edlin.exe doit afficher.
ligne2
Spécifie la dernière ligne que Edlin.exe doit afficher.
?
Affiche la liste des sous-commandes de edlin.

Remarques

  • XOX
  • XOX
  • Omission de valeurs de paramètres

    Vous pouvez omettre le paramètre ligne1, le paramètre ligne2 ou les deux. Voici la liste des valeurs par défaut dans les deux cas :

    • Si vous omettez seulement le paramètre ligne1, Edlin.exe affiche jusqu'à une page à la fois (c'est-à-dire, un plein écran de texte), en commençant 11 lignes avant la ligne en cours jusqu'à la ligne dont le numéro est spécifié dans la ligne2. Si vous omettez seulement ligne1, vous devez insérer une virgule de remplissage.
    • Si vous omettez seulement le paramètre ligne2, Edlin.exe affiche jusqu'à une page, à partir de la ligne spécifiée dans ligne1.
    • Si vous utilisez la sous-commande l (list) sans paramètre, Edlin.exe affiche jusqu'à une page, en commençant 11 lignes avant la ligne en cours. Si vous installez le pilote de périphérique Ansi.sys, le nombre de lignes affichées par page dépend du type de moniteur que vous possédez. Ce numéro peut dépasser 24.
  • Utilisation de grands blocs de lignes

    Lorsque le bloc de lignes spécifié contient plusieurs pages, Edlin.exe affiche la première, puis affiche le message suivant :

    Voulez-vous continuer (O/N) ?

    Edlin.exe affiche une page supplémentaire chaque fois que vous répondez O à l'invite.

Exemples

Pour voir les lignes 5 à 10, tapez :

5,10l


Edlin : [ligne]

Affiche la ligne de texte que vous spécifiez.

Syntaxe

[ligne]

Paramètres

ligne
Spécifie le numéro de la ligne que Edlin.exe doit afficher. Pour voir le numéro et le texte de la ligne en cours, appuyez sur ENTRÉE.
?
Affiche la liste des sous-commandes de edlin.

Remarques

  • XOX
  • XOX
  • Quand vous tapez un numéro de ligne comme commande, Edlin.exe affiche deux lignes. La première ligne contient le numéro spécifié et le texte qui lui est associé. La seconde ligne contient à nouveau le numéro, suivi du point d'insertion. Le texte de la première ligne de l'affichage sert de modèle à la seconde ligne. Sur la seconde ligne de l'affichage, vous pouvez appuyer sur la touche ENTRÉE pour annuler la commande sans modifier le texte, taper du texte de remplacement ou modifier la ligne de texte. Après modification d'une ligne, appuyez sur ENTRÉE pour enregistrer les changements en mémoire.

    Avertissement

    • Si vous appuyez sur ENTRÉE quand le point d'insertion se trouve au milieu d'une ligne, Edlin.exe efface la partie de la ligne entre le point d'insertion et la fin de la ligne.

    Pour plus d'informations sur l'enregistrement sur disque du fichier modifié à partir de la mémoire à l'aide des sous-commandes e (End) ou w (Write), consultez Rubriques connexes.

Exemples

Dans cet exemple, le fichier ci-après est en mémoire et prêt à être édité. Lorsque vous utilisez la sous-commande l (liste) à l'invite *, Edlin.exe affiche le contenu du fichier.

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6: convaincu par votre potentiel.

Pour modifier la ligne 6, tapez :

6

Edlin.exe affiche les deux lignes suivantes :

6:*convaincu par votre potentiel.
6:*_

La première ligne contient le numéro de ligne spécifié et le texte qui lui est associé. La seconde ligne contient à nouveau le numéro, suivi du point d'insertion.

Pour insérer le mot "remarquable" avant le mot "potentiel" dans l'exemple précédent, spécifiez que Edlin.exe affiche à nouveau une portion de la première ligne, en commençant à la position du point d'insertion sur la deuxième ligne. Appuyez d'abord sur F2, puis tapez p. Edlin.exe affiche la partie de la ligne jusqu'au premier “p” (ligne 6), sans l'inclure, comme suit :

6:*convaincu _

Appuyez sur F2, puis tapez à nouveau p. Edlin.exe affiche la partie de la ligne jusqu'au “p” (ligne 6) suivant, sans l'inclure, comme suit :

6:*convaincu par votre _

Appuyez sur la touche INSERTION, tapez remarquable, appuyez sur ESPACE., puis appuyez sur F3. Edlin.exe affiche la ligne modifiée, comme suit :

6:*convaincu par votre remarquable potentiel._

Appuyez sur ENTRÉE pour valider la modification.

À l'invite *, tapez la sous-commande l (list) pour afficher le fichier modifié. Edlin.exe affiche le résultat suivant :

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6:*convaincu par votre remarquable potentiel.


Edlin : m (move)

Déplace le bloc de lignes successives spécifié à un autre endroit du fichier qui est en mémoire.

Syntaxe

[ligne1],[ligne2],ligne3 m

[ligne1],[+n],ligne3 m

Paramètres

ligne1
Indique la première ligne à déplacer.
ligne2
Spécifie la dernière ligne à déplacer.
ligne3
Important. Spécifie la ligne devant laquelle vous voulez déplacer le bloc de lignes.
+n
Spécifie le nombre de lignes que Edlin.exe doit déplacer, à partir de la ligne spécifiée dans ligne1 et en incluant les n prochaines lignes. Si vous omettez ligne1, le ligne courante est le point de démarrage du bloc de ligne déplacé par Edlin.exe.

Remarques

  • XOX
  • XOX
  • Renumérotation des lignes

    Lorsque vous avez déplacé les lignes, utilisez la sous-commande l (list) pour afficher les lignes correctement renumérotées.

  • Chevauchement de numéros de lignes

    La ligne que vous spécifiez pour ligne3 ne peut pas faire partie du bloc de lignes que vous voulez déplacer. Ainsi, la commande suivante génère un message d'erreur :

    5,10 0,8m

    Si vous chevauchez ainsi les numéros de ligne, Edlin.exe ne pourra pas terminer l'opération de déplacement et affichera le message suivant :

    Erreur d'entrée

Exemples

Dans cet exemple, le fichier ci-après est en mémoire et prêt à être édité. Lorsque vous utilisez la sous-commande l (liste) à l'invite *, Edlin.exe affiche le contenu du fichier.

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6: convaincu par votre remarquable potentiel.
7:
8: Je pense que vous collaborerez avec plaisir avec
9: Mme Lang au nouveau projet. N'hésitez
10: pas à me contacter
11: si je peux vous aider.
12:
13: Bien à vous,
14:
15: S.L. Martin, président
16: Contoso, Ltd
17: « Le leader mondial de la technologie »

Pour déplacer le slogan au début du mémo (c'est-à-dire, déplacer les lignes 16 et 17 avant la ligne 1), tapez :

16,17 0,1m

À l'invite *, tapez la sous-commande l (list) pour afficher le fichier modifié. Edlin.exe affiche le résultat suivant :

1: Contoso, Ltd
2: « Le leader mondial de la technologie »
3: Cher M. Muth,
4:
5: Félicitations pour votre promotion
6: au poste d'ingénieur
7: chimique. Je suis tout à fait
8: convaincu par votre remarquable potentiel.
9:
10: Je pense que vous collaborerez avec plaisir avec
11: Mme Lang au nouveau projet. N'hésitez
12: pas à me contacter
13: si je peux vous aider.
14:
15: Bien à vous,
16:
17: S.L. Martin, président

Pour déplacer le bloc de lignes, de la ligne courante aux 25 lignes suivantes incluses, immédiatement avant la ligne 100, tapez :

,+25,100m


Edlin : p (page)

Affiche l'intégralité ou une partie d'un fichier, une page (un plein écran de texte) à la fois. Utilisé sans paramètres, p affiche une page de texte commençant une ligne après la ligne en cours.

Syntaxe

[ligne1][, ligne2]p

Paramètres

ligne1
Spécifie la première ligne que Edlin.exe doit afficher.
ligne2
Spécifie la dernière ligne que Edlin.exe doit afficher.
?
Affiche la liste des sous-commandes de edlin.

Remarques

  • XOX
  • XOX
  • La dernière ligne affichée à l'écran devient la ligne courante dans le nouveau écran.
  • Omission de paramètres

    Lorsque vous omettez ligne1, Edlin.exe affiche une page de texte qui commence à la ligne en cours jusqu'à ligne2. Lorsque vous omettez ligne2, Edlin.exe affiche une page de texte qui commence à ligne1. Si vous omettez ligne1 et line2, Edlin.exe affiche une page de texte qui commence à la ligne située après la ligne courante.

Exemples

Pour visualiser les lignes 100 à 200, page par page, tapez :

100,200p


Edlin : q (quit)

Arrête la session Edlin.exe en cours sans enregistrer sur disque le fichier édité en mémoire.

Syntaxe

q

Paramètres

Aucun

Remarques

  • XOX
  • XOX
  • Pour écrire sur disque le fichier modifié dans la mémoire avant de terminer la session en cours, utilisez la sous-commande e (end).


Edlin : r (replace)

Recherche un bloc de lignes successives pour une chaîne d'un ou plusieurs caractères spécifiés et remplace chaque occurrence de cette chaîne par une autre chaîne spécifiée.

Syntaxe

[ligne1][,ligne2][?]r[chaîne1][CTRL+Z chaîne2]

Paramètres

ligne1
Spécifie la première ligne dans laquelle vous voulez remplacer la chaîne spécifiée dans chaîne1.
ligne2
Spécifie la dernière ligne dans laquelle vous voulez remplacer la chaîne spécifiée dans chaîne1.
?
Envoie un message de confirmation avant que Edlin.exe remplace une occurrence de la chaîne spécifiée dans chaîne1.
chaîne1
Spécifie la chaîne que vous voulez remplacer.
CTRL+Z
Sépare les valeurs de chaîne1 et chaîne2. La seule valeur valide pour ce paramètre est le caractère de fin de fichier (CTRL+Z), qui se présente sous la forme ^Z.
chaîne2
Spécifie la nouvelle chaîne qui doit remplacer chaque occurrence de la chaîne spécifiée dans chaîne1.

Remarques

  • XOX
  • XOX
  • La nouvelle ligne courante est la dernière ligne dans laquelle Edlin.exe remplace chaîne1.
  • Espacement ligne de commande

    N'insérez pas d'espace entre r et tout autre paramètre suivant dans la ligne de commande.

  • Omission de paramètres

    Si vous omettez ligne1, Edlin.exe commence la recherche sur la ligne qui suit la ligne en cours. Si vous omettez ligne2, Edlin.exe arrête la recherche à la fin du fichier ou à la fin du texte actuellement en mémoire.

    Si vous omettez chaîne1, Edlin.exe utilise la dernière valeur employée des deux valeurs ci-dessous : la valeur spécifiée pour le paramètre chaîne1 la dernière fois que vous avez utilisé r ou la valeur spécifiée pour la chaîne la dernière fois que vous avez employé s au cours de cette session. Si vous omettez chaîne1 et si vous n'avez pas utilisé les sous-commandes r ou s pendant la session d'édition en cours, la sous-commande s'arrête instantanément.

    Si vous omettez chaîne2, Edlin.exe prend la valeur spécifiée la dernière fois que vous avez utilisé la commande r pendant cette session. Si vous omettez chaîne2 et que vous n'avez pas encore utilisé la commande r pendant la session en cours, Edlin.exe supprime toutes les occurrences de la chaîne spécifiée dans chaîne1.

  • Utilisation de CTRL+Z

    Vous devez séparer les valeurs chaîne1 et chaîne2 à l'aide de CTRL+Z. Si vous omettez chaîne1, vous devez tout de même appuyer sur CTRL+Z pour marquer le début de chaîne2. Lorsque vous appuyez sur CTRL+Z, les caractères suivants apparaissent :

    ^Z

  • Utilisation du paramètre point d'interrogation (?)

    Si vous incluez ? dans votre commande, Edlin.exe affiche la ligne contenant la première occurrence de la chaîne spécifiée pour chaîne1 et vous demande une confirmation en affichant le message suivant :

    O.K.? _

    Si vous appuyez sur O ou sur ENTRÉE, Edlin.exe remplace cette occurrence de chaîne1 par la valeur de chaîne2, puis recherche l'occurrence suivante. Si vous appuyez sur N, Edlin.exe ne remplace pas cette occurrence de la valeur de chaîne1 et recherche l'occurrence suivante.

    Si vous n'utilisez pas le paramètre ? pour confirmer les remplacements à mesure qu'ils se font, Edlin.exe remplace automatiquement toutes les occurrences de chaîne1, puis affiche toutes les lignes qui contiennent un remplacement. Si une ligne contient deux remplacements ou davantage, Edlin.exe affiche la ligne à chaque occurrence.

Exemples

Pour remplacer chaque occurrence de "le mien" par "le nôtre" dans les 20 premières lignes du fichier modifié en mémoire et recevoir un message de confirmation, tapez la commande suivante, mais n'appuyez pas sur ENTRÉE :

1,20?rle mienCTRL+Zle nôtre

CTRL+Z s'affiche comme suit : ^Z. La commande s'affiche comme suit :

1,20?rle mien^Zle nôtre

Dans cet exemple, le fichier ci-après est en mémoire et prêt à être édité. Lorsque vous utilisez la sous-commande l (liste) à l'invite *, Edlin.exe affiche le contenu du fichier.

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6: convaincu par votre remarquable potentiel.
7:
8: Je pense que vous collaborerez avec plaisir avec
9: Mme Lang au nouveau projet. N'hésitez
10: pas à me contacter
11: si je peux vous aider.
12:
13: Bien à vous,
14:
15: S.L. Martin, président
16: Contoso, Ltd
17: « Le leader mondial de la technologie »

Pour remplacer toutes les occurrences du mot "vous" par les mots "vous cher ami" dans les lignes 5 à 10 sans recevoir de message de confirmation, tapez :

5,10rvousCTRL+Zvous cher ami

CTRL+Z s'affiche comme suit : ^Z. La commande s'affiche comme suit :

5,10rvous^Zvous cher ami

Étant donné que vous n'avez pas inclus le paramètre ?, Edlin.exe remplace les trois occurrences de "vous" sans afficher de message de confirmation. Quand Edlin.exe a terminé d'exécuter la commande, il affiche les lignes suivantes qui ont été modifiées par les trois remplacements :

8: Je pense que vous cher ami collaborerez avec plaisir avec
9: si je peux vous cher ami aider.
12:
13: Bien à vous cher ami,
14:

Dans l'exemple précédent, deux remplacements inattendus ont été effectués dans les lignes 8 et 9. Pour éviter ce type de remplacement, ajoutez le paramètre ? à la commande. La commande complète s'affiche comme suit :

5,10?rvous^Zvous cher ami

Edlin.exe vous demande de confirmer le remplacement de chaque occurrence de la chaîne spécifiée dans chaîne1, et n'effectue que les remplacements confirmés, comme le montre l'exemple suivant.

8: Je pense que vous cher ami collaborerez avec plaisir avec
O.K.? n
9: si je peux vous cher ami aider.
O.K.? n

12:
13: Bien à vous cher ami,
14: O.K.? o

Lorsque vous utilisez le paramètre ?, Edlin.exe n'affiche pas automatiquement les lignes modifiées à la suite des remplacements confirmés. Si vous tapez la sous-commande l (list) à l'invite *, Edlin.exe affiche le fichier modifié en mémoire comme suit :

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6: convaincu par votre remarquable potentiel.
7:
8: Je pense que vous collaborerez avec plaisir avec
9: Mme Lang au nouveau projet. N'hésitez
10: pas à me faire savoir si sincèrement
11: si je peux vous aider.
12:
13: Bien à vous cher ami,
14:
15: S.L. Martin, président
16: Contoso, Ltd
17: « Le leader mondial de la technologie »


Edlin : s (search)

Recherche la chaîne que vous spécifiez.

Syntaxe

[ligne1][,ligne2][?]s[chaîne]

Paramètres

ligne1
Spécifie la première ligne à rechercher.
ligne2
Spécifie la dernière ligne à rechercher.
?
Envoie un message de confirmation lorsque Edlin.exe trouve la première occurrence de la chaîne spécifiée dans chaîne1.
chaîne
Spécifie la chaîne à rechercher. N'insérez pas d'espace avant ce paramètre sur la ligne de commande, à moins que l'espace ne fasse partie du texte recherché.

Remarques

  • XOX
  • XOX
  • Edlin.exe affiche la première ligne contenant une occurrence de la chaîne. Lorsque la première occurrence a été trouvée, la recherche s'arrête et la ligne qui contient chaîne devient la ligne courante.
  • Omission de paramètres

    Si vous omettez ligne1, Edlin.exe commence la recherche sur la ligne qui suit la ligne en cours. Si vous omettez ligne2, Edlin.exe arrête la recherche à la fin du fichier.

    Si vous omettez chaîne, Edlin.exe utilise la dernière valeur employée des deux valeurs ci-dessous : la valeur spécifiée pour chaîne la dernière fois que vous avez utilisé s ou la valeur spécifiée pour chaîne1 la dernière fois que vous avez employé r au cours de cette session. Si vous omettez chaîne et si vous n'avez pas utilisé les sous-commandes s ou r pendant la session en cours, la sous-commande s s'arrête instantanément.

  • Utilisation du paramètre ?

    Si vous incluez ? dans votre commande, Edlin.exe affiche la ligne contenant la première occurrence de la chaîne de caractères spécifiée pour chaîne et vous demande une confirmation en affichant le message suivant :

    O.K.? _

    Si vous appuyez sur O ou sur ENTRÉE, la ligne affichée avant le message devient la ligne en cours et la recherche s'arrête. Si vous appuyez sur N, la recherche continue jusqu'à l'occurrence suivante ou jusqu'à ce que Edlin.exe affiche le message suivant, indiquant que la recherche a été effectuée dans toutes les lignes :

    Introuvable

Exemples

Dans cet exemple, le fichier ci-après est en mémoire et prêt à être édité. Lorsque vous utilisez la sous-commande l (liste) à l'invite *, Edlin.exe affiche le contenu du fichier.

1: M. Muth :
2:
3: Félicitations pour votre promotion
4: au poste d'ingénieur
5: chimique. Je suis tout à fait
6: convaincu par votre remarquable potentiel.
7:
8: Je pense que vous collaborerez avec plaisir avec
9: Mme Lang au nouveau projet. N'hésitez
10: pas à me contacter
11: si je peux vous aider.
12:
13: Bien à vous,
14:
15: S.L. Martin, président

Pour rechercher la première occurrence du mot "au" dans les lignes 2 à 12, tapez :

2,12sau

Edlin.exe affiche la ligne suivante :

4: au poste d'ingénieur

Pour afficher la ligne contenant la première occurrence de "au" et recevoir un message de confirmation, tapez :

1,?sau

Edlin.exe affiche les lignes suivantes :

4: au poste d'ingénieur
O.K.? _

Si vous appuyez sur une touche autre que O ou ENTRÉE, la recherche continue. Pour cet exemple, appuyez sur N, comme suit :

O.K.? n

Edlin.exe continue la recherche et affiche les lignes suivantes :

8: Je pense que vous collaborerez avec plaisir avec Mme Lang au nouveau projet.
O.K.? _

Appuyez sur O pour arrêter la recherche.


Sous-commandes de Edlin

Pour plus d'informations, cliquez sur une commande :

  • Edlin : [ligne]
  • Edlin : a (append)
  • Edlin : c (copy)
  • Edlin : d (delete)
  • Edlin : e (end)
  • Edlin : i (insert)
  • Edlin : l (list)
  • Edlin : m (move)
  • Edlin : p (page)
  • Edlin : q (quit)
  • Edlin : r (replace)
  • Edlin : s (search)
  • Edlin : t (transfer)
  • Edlin : w (write)


Edlin : t (transfer)

Fusionne le contenu d'un fichier sur disque avec celui du fichier qui est en mémoire.

Syntaxe

[ligne]t[Lecteur:][Chemin] NomFichier

Paramètres

ligne
Spécifie le numéro de ligne avant laquelle vous voulez insérer le fichier que vous transférez à partir d'un disque. La valeur par défaut est le numéro de la ligne en cours.
[Lecteur:][Chemin] NomDeFichier
Spécifie l'emplacement et le nom du fichier que vous voulez insérer avant la ligne que vous spécifiez dans ligne. NomDeFichier est obligatoire. La valeur par défaut de Lecteur est le lecteur en cours et la valeur par défaut de Chemin est le répertoire en cours.

Remarques

  • XOX
  • XOX
  • Quand Edlin.exe fusionne un fichier à partir d'un disque, vous pouvez utiliser la sous-commande l (list) à l'invite * pour visualiser les lignes correctement renumérotées.

Exemples

Pour fusionner le fichier Taxes.mem à la ligne 12 du fichier que vous éditez, tapez :

12t taxes.mem


Edlin : w (write)

Enregistre sur un disque la première partie du fichier édité de la mémoire. Utilisé sans paramètres, w écrit des lignes du fichier édité en mémoire sur un disque jusqu'à ce que la mémoire soit pleine à 25%.

Syntaxe

[n]w

Paramètres

n
Spécifie le nombre de lignes que vous voulez écrire sur disque, en commençant par la première ligne du fichier édité en mémoire.
?
Affiche la liste des sous-commandes de edlin.

Remarques

  • XOX
  • XOX
  • Au démarrage, Edlin.exe lit autant de lignes que possible à partir du fichier disque en mémoire. Si la taille du fichier dépasse celle de la mémoire disponible, vous devez éditer le fichier par étapes. Pour cela, vous modifiez une partie du fichier, vous enregistrez celle-ci sur votre disque à l'aide de la sous-commande w, puis vous chargez la partie suivante à partir du disque avec la sous-commande a (append).
  • Lorsque vous ouvrez un fichier, Edlin.exe lit les lignes du disque jusqu'à ce que la mémoire soit pleine à plus de 75 %. Edlin.exe réserve les 25 % restants aux modifications que vous apportez au texte. Si le fichier complet entre en mémoire, Edlin.exe affiche le message suivant :

    Fin du fichier d'entrée

    Si ce message apparaît, vous ne devez pas utiliser les sous-commandes w et a (append).

    Si Edlin.exe n'affiche pas ce message lorsque vous ouvrez un fichier, la taille du fichier dépasse la mémoire disponible. Vous devez éditer votre fichier par étapes, en utilisant les commandes w et a pour enregistrer et lire des parties de fichier.

    La sous-commande w n'enregistre pas sur disque les modifications apportées, à moins que l'utilisation de cette sous-commande ne s'impose. Ainsi, si vous utilisez w alors que le fichier complet entre dans la mémoire et si vous utilisez ensuite q (quit) pour quitter edlin, aucune des modifications apportées au fichier n'est enregistrée.

  • Renumérotation des lignes

    Lorsque edlin a écrit sur disque de la première partie du fichier édité, utilisez la sous-commande l (list) à l'invite * pour visualiser les lignes restantes correctement renumérotées, en commençant par la ligne 1.

Exemples

Dans cet exemple, les 100 dernières lignes de votre fichier disque n'entrent pas dans la mémoire. Pour libérer suffisamment d'espace afin de charger le reste de votre disque en mémoire et continuer à éditer, tapez :

125w


Endlocal

Met fin à la localisation des modifications d'environnement dans un fichier de commandes, en rétablissant les valeurs des variables d'environnement avant la commande concordante setlocal.

Syntaxe

endlocal

Paramètres

/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Vous devez utiliser endlocal dans un script ou un fichier de commandes. Si vous utilisez endlocal en dehors d'un script ou un fichier de commandes, il est sans effet.
  • Il existe une commande endlocal implicite à la fin d'un fichier de commandes.
  • Si les extensions de commande sont activées (ce qui est le cas par défaut), la commande endlocal rétablit l'état des extensions de commande (c'est-à-dire activé ou désactivé) en vigueur avant l'exécution de la commande setlocal correspondante. Pour plus d'informations sur l'activation et la désactivation d'extensions de commandes, consultez cmd dans Rubriques connexes.

Exemples

Vous pouvez localiser des variables d'environnement dans un fichier de commandes. Exemple :

@echo off

rem Ce programme lance le programme de commandes superapp sur le réseau,

rem dirige la sortie d'un fichier et affiche le fichier

rem dans le Bloc-notes.

setlocal

path=g:\programs\superapp;%path%

call superapp>c:\superapp.out

endlocal

start notepad c:\superapp.out


Eventcreate

Permet à un administrateur de créer un événement personnalisé dans un journal d'événements spécifié.

Syntaxe

eventcreate [/s Ordinateur [/u Domaine\Utilisateur [/p MotDePasse]] {[/l {APPLICATION|SYSTEM}]|[/so NomSrc]} /t {ERROR|WARNING|INFORMATION|SUCCESSAUDIT|FAILUREAUDIT} /id IDÉvénement /d Description

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/l {APPLICATION|SYSTEM}
Spécifie le nom du journal des événements où l'événement sera créé. Les noms de journaux valides sont APPLICATION et SYSTEM.
/so NomSrc
Spécifie la source à utiliser pour l'événement. Une source valide peut être n'importe quelle chaîne et doit représenter l'application ou le composant qui génère l'événement.
/t {ERROR|WARNING|INFORMATION|SUCCESSAUDIT|FAILUREAUDIT}
Spécifie le type d'événement à créer. Les types valides sont ERROR, WARNING, INFORMATION, SUCCESSAUDIT et FAILUREAUDIT.
/id IDÉvénement
Spécifie l'ID d'événement de l'événement. Un ID valide peut être n'importe quel nombre entre 1 et 65535.
/d Description
Spécifie la description à utiliser pour l'événement nouvellement créé.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Les événements personnalisés ne peuvent pas être écrits dans le journal de sécurité.

Exemples

Les exemples suivants décrivent l'utilisation de la commande eventcreate :

eventcreate /t error /id 100 /l application /d "Créer un événement dans le journal d'application"
eventcreate /t information /id 1000 /so winmgmt /d "Créer un événement dans la source WinMgmt"
eventcreate /t error /id 2001 /so winword /l application /d "nouveau Winword src dans le journal d'application"
eventcreate /s server /t error /id 100 /l application /d "Machine distante sans informations d'identification d'utilisateur"
eventcreate /s server /u user /p password /id 100 /t error /l application /d "Machine distante avec informations d'identification d'utilisateur"
eventcreate /s server1 /s server2 /u user /p password /id 100 /t error /so winmgmt /d "Création d'événements sur plusieurs machine distantes"
eventcreate /s server /u user /id 100 /t warning /so winmgmt /d "Machine distante avec informations d'identification d'utilisateur partielles"


Eventquery.vbs

Répertorie les événements et les propriétés d'événements dans un ou plusieurs journaux.

Syntaxe

eventquery[.vbs] [/s Ordinateur [/u Domaine\Utilisateur [/p MotDePasse]]] [/fi NomFiltre] [/fo {TABLE|LIST|CSV}] [/r PlageÉvénement [/nh] [/v] [/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS server"] [JournalDéfiniParUtilisateur] [NomJournalRépertoire] [*] ]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute le script avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/fi NomFiltre
Spécifie les types d'événements à inclure ou à exclure de la requête. Pour trouver des événements ayant une de ces valeurs, Type et ID peuvent être utilisés ensemble dans une seule déclaration en utilisant l'opérateur or. Les exemples suivants sont des noms de filtres valides, des opérateurs et des valeurs.
Nom | Opérateur | Valeur
Datetime | eq, ne, ge, le, gt, lt | mm/jj/aa(aaaa), hh:mm:ssAM(/PM)
Tapez | eq, ne | {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}
ID | eq, ne, ge, le, gt, lt | N'importe quel entier positif valide.
Utilisateur | eq, ne | Toute chaîne valide.
Ordinateur | eq, ne | Toute chaîne valide.
Source | eq, ne | Toute chaîne valide.
Catégorie | eq, ne | Toute chaîne valide
/fo {TABLE|LIST|CSV}
Spécifie le format à utiliser pour la sortie. Les valeurs valides sont table, list et csv.
/r PlageÉvénement
Spécifie la plage d'événements à répertorier.
Valeur | Description
O | Répertorie les N événements les plus récents.
-N | Répertorie les N événements les plus anciens.
N1-N2 | Répertorie les événements de N1 à N2.
/nh
Supprime les en-têtes de colonnes dans la sortie. Valide uniquement pour les formats table et csv.
/v
Spécifie l'affichage des commentaires sur les événements dans la sortie.
/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS server"] [JournalDéfiniParUtilisateur] [NomJournalRépertoire] [*] ]
Spécifie le ou les journaux à surveiller. Les valeurs valides sont Application, System, Security, "DNS server", un journal défini par l'utilisateur et un journal de répertoire. "DNS server" peut être utilisé uniquement si le service DNS est exécuté sur l'ordinateur spécifié par le paramètre /s. Pour spécifier plusieurs journaux à surveiller, utilisez à nouveau le paramètre /l. Le caractère générique (*) peut être utilisé et est la valeur par défaut.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour exécuter ce script, vous devez exécuter CScript. Si vous n'avez pas encore défini l'hôte de script par défaut comme étant CScript, tapez :

    cscript //h:cscript //s //nologo

Exemples

Les exemples suivants décrivent l'utilisation de la commande eventquery :

eventquery /l system
eventquery /l mylog
eventquery /l application /l system
eventquery /s srvmain /u maindom\hiropln /p p@ssW23 /v /l *
eventquery /r 10 /l application /nh
eventquery /r -10 /fo LIST /l security
eventquery /r 5-10 /l "DNS server"
eventquery /fi "Type eq Error" /l application
eventquery /fi "Datetime eq 06/25/00,03:15:00AM/06/25/00,03:15:00PM" /l application
eventquery /fi "Datetime gt 08/03/00,06:20:00PM" /fi "id gt 700" /fi "Type eq warning" /l system eventquery /fi "ID eq 1000 OR ID ge 4500" eventquery /fi "Type eq error OR Type eq INFORMATION" eventquery /fi "ID eq 250 OR Type eq ERROR"


Eventtriggers

Affiche et configure les déclencheurs d'événements sur les machines locales ou distantes.

Pour afficher la syntaxe d'une commande, sélectionnez-la :

eventtriggers create

Crée un nouveau déclencheur d'événement qui surveille et agit sur l'occurrence des événements de journaux de critères donnés.

Syntaxe

eventtriggers[.exe] /create [/s Ordinateur [/u Domaine\Utilisateur [/p MotDePasse]]] /tr NomDéclencheur [/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS Server"] [LOG] [NomJournalRépertoire] [*] ] {[/eid ID]|[/t {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}]|[/so Source]} [/d Description] /tk NomTâche [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot de passe]]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/tr NomDéclencheur
Spécifie un nom à associer au déclencheur d'événement.
/l [APPLICATION] [SYSTEM] [SECURITY] ["Serveur DNS"] [LOG] [NomJournalRépertoire] [*] ]
Spécifie le ou les journaux d'événements à surveiller. Les différents types valides sont les suivants : Application, Système, Sécurité, Serveur DNS, Journal et Journal de répertoire. Le caractère générique (*) peut être utilisé et est la valeur par défaut.
/eid ID
Spécifie un ID d'événement spécifique que le déclencheur d'événement doit surveiller. N'importe quel entier valide est une valeur valide. Ne peut être utilisé conjointement aux paramètres /type ou /so.
/t {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}
Spécifie un type d'événement que le déclencheur d'événement doit surveiller. Les valeurs suivantes sont valides : ERROR, INFORMATION, WARNING, SUCCESSAUDIT et FAILUREAUDIT. Ne peut être utilisé conjointement aux paramètres /id ou /so.
/so Source
Spécifie une source d'événement que le déclencheur d'événement doit surveiller. Toutes les chaînes constituent des valeurs valides. Ne peut être utilisé conjointement aux paramètres /id ou /type.
/d Description
Spécifie une description détaillée du déclencheur d'événement. Toutes les chaînes constituent des valeurs valides.
/tk NomTâche
Spécifie la tâche/commande/ligne à exécuter lorsque les conditions du déclencheur d'événement sont remplies.
/ru {[Domaine\]Utilisateur | "System"}
Permet d'exécuter les tâches avec les autorisations du compte d'utilisateur spécifié. Par défaut, la tâche est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
Valeur | Description
[Domaine\]Utilisateur | Permet de spécifier un compte d'utilisateur.
"System" ou "" | Spécifie le compte d'autorité NT ou système qui est utilisé par le système d'exploitation.
/rp MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /ru. Si vous n'indiquez pas ce paramètre lorsque vous spécifiez un compte d'utilisateur, SchTasks.exe affiche un message vous demandant de saisir un mot de passe (les caractères saisis ne s'affichent pas à l'écran). Les tâches exécutées avec les autorisations du compte d'autorité NT ou système ne requièrent pas la saisie d'un mot de passe et SchTasks n'en demande pas.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants décrivent l'utilisation de la commande eventtriggers /create :

eventtriggers /create /tr "Disk Cleanup" /l system /t error /tk c:\windows\system32\cleanmgr.exe
eventtriggers /create /s srvmain /u maindom\hiropln /p p@ssW23 /tr "Low Disk Space" /eid 4133 /t warning /tk \\server\share\diskcleanup.cmd
eventtriggers /create /s srvmain /user maindom\hiropln /p p@ssW23 /tr "Disk Backup" /eid 4133 /l system /t error /tk \\server\share\ntbackup.exe

eventtriggers delete

Supprime un déclencheur d'événement d'un système sur la base de son ID de déclencheur d'événement.

Syntaxe

eventtriggers[.exe] /delete [/s Ordinateur [/u Domaine\Utilisateur [/p MotDePasse]]] /tid {ID|*}

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/tid {ID|*}
Spécifie le ou les déclencheurs d'événements à supprimer par « ID de déclencheur d'événement ». Vous pouvez utiliser le caractère générique (*).
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants décrivent l'utilisation de la commande eventtriggers/delete :

eventtriggers /delete /tid 1 /tid 2 /tid 4 /tid 6
eventtriggers /delete /s srvmain /u maindom\hiropln /p p@ssW23 /tid *
eventtriggers /delete /s srvmain /u maindom\hiropln /p p@ssW23 /tid 1

eventtriggers query

Interroge et affiche les propriétés et les paramètres des déclencheurs d'événements d'un système.

Syntaxe

eventtriggers[.exe] /query [/s Ordinateur [/u Domaine\Utilisateur [/p MotDePasse]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur où est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/fo {TABLE|LIST|CSV}
Spécifie le format à utiliser pour la sortie de la requête. Les valeurs valides sont TABLE, LIST et CSV. Le format de sortie par défaut est TABLE.
/nh
Supprime l'en-tête de colonne dans la sortie. Valide lorsque le paramètre /fo est TABLE ou CSV.
/v
Spécifie l'affichage d'informations détaillées dans la sortie.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants décrivent l'utilisation de la commande eventtriggers/query :

eventtriggers /query
eventtriggers /query /s srvmain
eventtriggers /query /s srvmain /u maindom\hiropln /p p@ssW23 /fo list

Remarques

  • Spécifié sans opération, eventtriggers renvoie une liste de déclencheurs d'événements. Pour afficher une liste de déclencheurs d'événements, tapez :

    eventtriggers

    Une sortie similaire à ce qui suit apparaît :

Trigger ID Event Trigger Name         Task

========== ========================== ==============================================

         1 Disk Cleanup               c:\windows\system32\cleanmgr.exe
  • En cas d'échec d'exécution d'un événement, eventtriggers crée un fichier journal appelé TriggerConsumer.log dans le répertoire \windows\system32\wbem\logs qui contient un message indiquant que l'événement ne s'est pas déclenché.


Evntcmd

Configure la traduction des événements en interruptions, en destinations d'interruptions, ou les deux, en fonction des informations contenues dans un fichier de configuration.

Syntaxe

evntcmd [/s NomOrdinateur] [/v NiveauDétail] [/n] NomFichier

Paramètres

/s NomOrdinateur
Spécifie, par nom, l'ordinateur sur lequel vous voulez configurer la traduction des événements en interruptions, en destinations d'interruptions, ou les deux. Si vous ne spécifiez pas d'ordinateur, la configuration se produit sur l'ordinateur local.
/v NiveauDétail
Spécifie quels types de messages d'état apparaissent lorsque les interruptions et les destinations d'interruptions sont configurées. Ce paramètre doit être un entier compris entre 0 et 10. Si vous spécifiez 10, tous les types de messages apparaissent, y compris les messages de traçage et les avertissements relatifs à la réussite ou non de la configuration des interruptions. Si vous spécifiez 0, aucun message n'apparaît.
/n
Spécifie que le service SNMP ne doit pas être redémarré si cet ordinateur reçoit des modifications de configuration des interruptions.
NomFichier
Spécifie, par nom, le fichier de configuration qui contient les informations à propos de la traduction des événements en interruptions et en destinations des interruptions que vous voulez configurer.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Si vous voulez configurer les interruptions, mais pas les destinations d'interruptions, vous pouvez créer un fichier de configuration valide à l'aide de l'utilitaire graphique Convertisseur d’événement en interruption. Si le service SNMP est installé, vous pouvez démarrer le Convertisseur d’événement en interruption en tapant evntwin dans une invite de commande. Lorsque vous avez défini les interruptions voulues, cliquez sur Exporter pour créer un fichier approprié pour evntcmd. Vous pouvez utiliser le Convertisseur d’événement en interruption pour créer facilement un fichier de configuration que vous pourrez utiliser avec evntcmd à l'invite de commande pour configurer rapidement des interruptions sur plusieurs ordinateurs.
  • La syntaxe de configuration d'une interruption est la suivante :

    #pragma ADD FichierJournalÉvénements SourceÉvénement IDÉvénement [Compte [Période]]

    • Le texte #pragma doit figurer au début de chaque entrée du fichier.
    • Le paramètre ADD spécifie que vous voulez ajouter une configuration d'événement en interruption.
    • Les paramètres FichierJournalÉvénements, SourceÉvénement et IDÉvénement sont requis. Le paramètre FichierJournalÉvénements spécifie le fichier dans lequel l'événement est enregistré. Le paramètre SourceÉvénement spécifie l'application qui génère l'événement. Le paramètre IDÉvénement spécifie le numéro unique qui identifie chaque événement. Pour trouver les valeurs qui correspondent aux événements spécifiques, démarrez le Convertisseur d’événement en interruption en tapant evntwin à une invite de commande. Cliquez sur Personnalisé, puis sur Modifier. Sous Sources d'événements, parcourez les dossiers jusqu'à ce que vous localisiez l'événement que vous voulez configurer, cliquez dessus, puis cliquez sur Ajouter. Les informations sur la source de l'événement, le fichier journal des événements et l'identificateur d'événement apparaissent respectivement sous Source, Journal et ID spécifique de l'interruption.
    • Le paramètre Compte est facultatif, et il spécifie combien de fois l'événement doit se produire avant l'envoi d'un message d'interruption. Si vous n'utilisez pas le paramètre Compte, le message d'interruption est envoyé à la première manifestation de l'événement.
    • Le paramètre Période est facultatif, mais il exige l'utilisation du paramètre Compte. Le paramètre Période spécifie une durée (en secondes) au cours de laquelle l'événement doit se produire le nombre de fois spécifié par le paramètre Compte avant l'envoi d'un message d'interruption. Si vous n'utilisez pas le paramètre Période, un message d'interruption est envoyé lorsque l'événement s'est produit le nombre de fois spécifié par le paramètre Compte, quelle que soit la durée sépara nt deux occurrences.
  • La syntaxe de suppression d'une interruption est la suivante :

    #pragma DELETE FichierJournalÉvénements SourceÉvénement IDÉvénement

    • Le texte #pragma doit figurer au début de chaque entrée du fichier.
    • Le paramètre DELETE spécifie que vous voulez supprimer une configuration d'événement en interruption.
    • Les paramètres FichierJournalÉvénements, SourceÉvénement et IDÉvénement sont requis. Le paramètre FichierJournalÉvénements spécifie le journal dans lequel l'événement est enregistré. Le paramètre SourceÉvénement spécifie l'application qui génère l'événement. Le paramètre IDÉvénement spécifie le numéro unique qui identifie chaque événement.
  • La syntaxe de configuration d'une destination d'interruption est la suivante :

    #pragma ADD_TRAP_DEST NomCommunauté IDHôte

    • Le texte #pragma doit figurer au début de chaque entrée du fichier.
    • Le paramètre ADD_TRAP_DEST spécifie que vous voulez que des messages d'interruption soient envoyés à un hôte spécifique au sein d'une communauté.
    • Le paramètre NomCommunauté spécifie, par nom, la communauté dans laquelle les messages d'interruption sont envoyés.
    • Le paramètre IDHôte spécifie, par nom ou adresse IP, l'hôte auquel vous voulez que des messages d'interruption soient envoyés.
  • La syntaxe de suppression d'une destination d'interruption est la suivante :

    #pragma DELETE_TRAP_DEST NomCommunauté IDHôte

    • Le texte #pragma doit figurer au début de chaque entrée du fichier.
    • Le paramètre DELETE_TRAP_DEST spécifie que vous ne voulez pas que des messages d'interruption soient envoyés à un hôte spécifique au sein d'une communauté.
    • Le paramètre NomCommunauté spécifie, par nom, la communauté dans laquelle les messages d'interruption sont envoyés.
    • Le paramètre IDHôte spécifie, par nom ou adresse IP, l'hôte auquel vous ne voulez pas que des messages d'interruption soient envoyés.

Exemples

Les exemples suivants illustrent les entrées dans le fichier de configuration pour la commande evntcmd. Elles ne sont pas destinées à être tapées à une invite de commande.

Pour envoyer un message d'interruption si le service Journal des événements est redémarré, tapez :

#pragma ADD System "Eventlog" 2147489653

Pour envoyer un message d'interruption si le service Journal des événements est redémarré deux fois en trois minutes, tapez :

#pragma ADD System "Eventlog" 2147489653 2 180

Pour cesser d'envoyer un message d'interruption dès que le service Journal des événements est redémarré, tapez :

#pragma DELETE System "Eventlog" 2147489653

Pour envoyer des messages d'interruption dans la communauté nommée Public vers l'hôte dont l'adresse IP est 192.168.100.100, tapez :

#pragma ADD_TRAP_DEST public 192.168.100.100

Pour envoyer des messages d'interruption dans la communauté nommée Private vers l'hôte nommé Host1, tapez :

#pragma ADD_TRAP_DEST private Host1

Pour cesser d'envoyer des messages d'interruption dans la communauté Private à l'ordinateur sur lequel vous configurez les destinations d'interruptions, tapez :

#pragma DELETE_TRAP_DEST private localhost


Exe2bin

Convertit les fichiers .exe (exécutables) au format binaire.

Syntaxe

exe2bin [lecteur1:][chemin1]FichierEntrée [[lecteur2:][chemin2]FichierSortie]

Paramètres

[lecteur1:][chemin1]FichierEntrée
Indique l'emplacement et le nom du fichier d'entrée que vous souhaitez convertir. FichierEntrée est obligatoire.
[lecteur2:][chemin2]FichierSortie
Indique l'emplacement et le nom du fichier de sortie que vous souhaitez créer.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • XOX
  • XOX
  • Exe2bin est incluse à l'intention des programmeurs de logiciel. Les simples utilisateurs n'en ont généralement pas besoin.
  • Les restrictions suivantes s'appliquent quand vous utilisez exe2bin :
    • Le fichier d'entrée doit se présenter sous le format .exe valide produit par l'éditeur de liens et ne doit pas être compressé.
    • Le code résident ou actuel ainsi que les parties de données du fichier combinées doivent compter moins de 64 ko.
    • Il ne doit pas y avoir de segment stack.
  • Exe2bin effectue les actions spécifiques suivantes, suivant les valeurs que vous utilisez pour les paramètres FichierEntrée et FichierSortie :
    • L'extension de fichier par défaut pour FichierEntrée est .exe. Exe2bin convertit le FichierEntrée .exe en fichier au format .bin (c'est-à-dire, une image mémoire du programme) et stocke ce fichier de sortie à l'endroit et sous le nom spécifiés pour [lecteur2:][chemin2]FichierSortie.
    • Si vous ne spécifiez ni lecteur2 ni chemin2, exe2bin écrit le fichier de sortie sur le lecteur et dans le répertoire en cours.
    • Si vous ne spécifiez pas de nom de fichier pour FichierSortie, exe2bin utilise le nom de fichier FichierEntrée.
    • L'extension par défaut du nom de fichier spécifié pour le paramètre FichierSortie est .bin.
  • Les types de conversions suivants sont pris en charge :
    • Si vous ne spécifiez pas CS:IP dans le fichier .exe, exe2bin procède à une conversion binaire pure. Si le programme contient des instructions nécessitant un repositionnement de segment, exe2bin vous invite à spécifier la valeur de résolution. Cette valeur représente le segment absolu où le programme doit être chargé. Vous pouvez utiliser le programme résultant uniquement lorsque vous le chargez à l'adresse mémoire absolue spécifiée par votre programme. L'interpréteur de commandes ne peut pas le charger.
    • Si vous spécifiez CS:IP en tant que 0000:100H, le fichier est exécuté comme un fichier .com avec le pointeur d'instruction établi à 100H par l'instruction d'assemblage ORG. N'omettez pas l'extension .com dans FichierSortie. Aucune correction de segment n'est autorisée, car les fichiers .com doivent être capables de repositionner les segments. Cela signifie que les fichiers .com doivent remplir les conditions d'entrée expliquées dans la documentation Microsoft Macro Assembler. L'interpréteur de commandes peut alors charger et exécuter le programme comme s'il s'agissait d'un des programmes .com fournis sur le disque Windows XP.


Exit

Quitte le script de commandes ou le programme Cmd.exe (c'est-à-dire l'interpréteur de commande) en cours et retourne au programme qui a démarré Cmd.exe ou au Gestionnaire de programmes.

Syntaxe

exit [/b] [CodeSortie]

Paramètres

/b
Quitte le script de commandes en cours.
CodeSortie
Spécifie une valeur numérique.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Si vous utilisez /b en dehors d'un script de commande, vous quittez Cmd.exe.
  • Si vous utilisez /b, Cmd.exe définit ERRORLEVEL comme étant le CodeSortie spécifié. Si vous quittez Cmd.exe, Cmd.exe définit le code de sortie du processus à l'aide du CodeSortie spécifié.


Expand

Décompresse un ou plusieurs fichiers compressés. Cette commande est utilisée pour récupérer des fichiers compressés de disquettes de distribution.

Syntaxe

expand [-r] Source [Destination]

expand -d source.cab [-f:fichiers]

expand source.cab -f:fichiers Destination

Paramètres

-r
Renomme les fichiers décompressés.
-d
Affiche la liste des fichiers à l'emplacement source. Ce paramètre ne décompresse pas ou n'extrait pas les fichiers.
-f:fichiers
Spécifie les fichiers d'un fichier cabinet (.cab) à décompresser. Vous pouvez utiliser des caractères génériques (* et ?).
Source
Spécifie les fichiers à décompresser. Source peut se composer d'une lettre de lecteur et du signe deux-points, d'un nom de répertoire, d'un nom de fichier ou d'une combinaison de ces éléments. Vous pouvez utiliser des caractères génériques (* et ?).
Destination
Spécifie l'emplacement où les fichiers doivent être décompressés. Si Source correspond à plusieurs fichiers et si -r n'est pas spécifié, la Destination doit être un répertoire. Destination peut se composer d'une lettre de lecteur et d'un deux-points, d'un nom de répertoire, d'un nom de fichier ou d'une combinaison de ces éléments.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Utilisation expand dans la console de récupération

    La commande expand, avec d'autres paramètres, est disponible à partir de la console de récupération.


Fastopen

XOX

Remarque

  • XOX


Fc

Compare deux fichiers et affiche leurs différences.

Syntaxe

fc [/a] [/b] [/c] [/l] [/lb n] [/n] [/t] [/u] [/w] [/nnnn] [lecteur1:][chemin1]nom_fichier1 [lecteur2:][chemin2]nom_fichier2

Paramètres

/a
Abrège le résultat d'une comparaison ASCII. Au lieu d'afficher toutes les lignes différentes, fc n'affiche que la première et la dernière ligne de chaque jeu de différences.
/b
Compare les fichiers en mode binaire. Fc compare les deux fichiers octet par octet et ne tente pas de resynchroniser le fichier après la découverte d'une discordance. C'est le mode de comparaison par défaut des fichiers qui possèdent les extensions de fichier suivantes : .exe, .com, .sys, .obj, .lib ou .bin.
/c
Ne distingue pas la casse.
/l
Compare les fichiers en mode ASCII. Fc compare les deux fichiers ligne par ligne et tente de resynchroniser les fichiers après la découverte d'une discordance. C'est le mode de comparaison par défaut des fichiers, à l'exception de ceux qui possèdent les extensions de fichier suivantes : .exe, .com, .sys, .obj, .lib ou .bin.
/lb n
Spécifie le nombre n de lignes de la zone tampon de lignes interne. Le nombre de lignes par défaut de cette zone s'élève à 100. Si le nombre de lignes consécutives différentes des fichiers que vous comparez est supérieur à ce nombre, fc annule la comparaison.
/n
Affiche les numéros des lignes au cours d'une comparaison ASCII.
/t
Empêche fc de convertir les tabulations en espaces. Le comportement par défaut consiste à traiter les tabulations comme s'il s'agissait d'espaces, avec des taquets tous les huit caractères.
/u
Compare les fichiers comme s'il s'agissait de fichiers texte Unicode.
/w
Compresse les espaces blancs (c'est-à-dire, les tabulations et les espaces) au cours de la comparaison. Si une ligne contient un grand nombre de tabulations ou d'espaces consécutifs, /w traite ces caractères comme un seul espace. Utilisée avec l'option de ligne de commande /w, fc ne tient pas compte (et n'effectue pas de comparaison) des espaces blancs au début et à la fin d'une ligne.
/nnnn
Indique le nombre de lignes consécutives qui doivent correspondre l'une à l'autre pour que fc considère que les fichiers doivent être resynchronisés. Si le nombre de lignes correspondantes des fichiers est inférieur à nnnn, fc affiche ces lignes en tant que différences. La valeur par défaut est 2.
[lecteur1:][chemin1]nom_fichier1
Indique l'emplacement et le nom du premier fichier à comparer. NomFichier1 est requis.
[lecteur2:][chemin2]nom_fichier2
Indique l'emplacement et le nom du second fichier à comparer. NomFichier2 est requis.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Signalement des différences entre les fichiers lors d'une comparaison ASCII

    Lorsque vous utilisez fc pour une comparaison ASCII, fc affiche les différences entre deux fichiers dans l'ordre suivant :

    • Nom du premier fichier
    • Lignes de nomfichier1 qui diffèrent entre les fichiers
    • Première ligne identiques dans les deux fichiers
    • Nom du deuxième fichier
    • Lignes de nomfichier2 qui diffèrent
    • Première ligne identique
  • Emploi de /b pour les comparaisons binaires

    /b affiche les différences trouvées au cours d'une comparaison binaire comme suit :

    xxxxxxxx: yy zz

    La valeur de xxxxxxxx représente l'adresse hexadécimale relative de la paire d'octets, telle qu'elle est mesurée à partir du début du fichier. Les adresses partent de 00000000. Les valeurs hexadécimales de yy et zz représentent respectivement les octets qui ne correspondent pas de nom_fichier1 et nom_fichier2.

  • Emploi des caractères génériques

    Vous pouvez utiliser des caractères génériques (c'est-à-dire, * et ?) dans nomfichier1 et nomfichier2. Si vous utilisez un caractère générique dans nomfichier1, fc compare tous les fichiers spécifiés au fichier désigné par NomFichier. Si vous incluez un caractère générique dans nom_fichier2, fc utilise la valeur correspondante dans nom_fichier1.

  • Utilisation de la mémoire

    Pour comparer des fichiers ASCII, fc utilise une zone tampon interne (assez grande pour contenir 100 lignes) comme espace de stockage. Si les fichiers sont plus grands que cette zone, fc compare ce qu'il peut charger dans la zone tampon. Si aucune correspondance n'est trouvée dans les portions chargées des fichiers, fc s'arrête et affiche le message suivant :

    Échec de resynchronisation. Les fichiers sont trop différents.

    Lors de la comparaison de fichiers binaires plus grands que la mémoire disponible, fc compare complètement les deux fichiers, en superposant sur les portions en mémoire les portions suivantes du disque. Les données de sortie sont identiques à celles obtenues dans le cas de fichiers qui tiennent entièrement dans la mémoire.

Exemples

Pour effectuer une comparaison ASCII de deux fichiers de texte nommés Mensuel.rpt et Ventes.rpt et afficher les résultats en format abrégé, tapez :

fc /a mensuel.rpt ventes.rpt

Pour effectuer une comparaison binaire de deux fichiers de commandes nommés Profits.bat et Benefice.bat, tapez :

fc /b profits.bat benefice.bat

Des résultats semblables aux suivants apparaîtront :

00000002: 72 43

00000004: 65 3A

0000000E: 56 92

00000012: 6D 5C

00000013: 0D 7C

00000014: 0D 0A

00000015: 0A 0D

0000001E: 43 7A

0000001F: 09 0A

00000022: 72 44

...

...

...

000005E0: 00 61

000005E1: 00 73

000005E2: 00 73

000005E3: 00 69

000005E4: 00 67

000005E5: 00 6E

000005E6: 00 6D

000005E7: 00 65

000005E8: 00 6E

FC: Benefice.bat plus long que Profits.bat

Si les fichiers Profits.bat et Benefice.bat sont identiques, fc affiche le message suivant :

FC: aucune différence détectée

Pour comparer chaque fichier .bat du répertoire en cours au fichier Nouv.bat, tapez :

fc *.bat nouv.bat

Pour comparer le fichier Nouv.bat du lecteur C au fichier Nouv.bat du lecteur D, tapez :

fc c:nouv.bat d:*.bat

Pour comparer chaque fichier de commandes du répertoire racine du lecteur C au fichier du même nom du répertoire racine du lecteur D, tapez :

fc c:*.bat d:*.bat


Fcbs

Indique le nombre de blocs de gestion de fichier (FCB) qu'il est possible d'ouvrir en même temps dans le sous-système MS-DOS. Utilisez le fichier racine_système\System32\Config.nt ou le fichier de démarrage équivalent spécifié dans le fichier PIF d'un programme pour définir le nombre de FCB.

Syntaxe

fcbs=x

Paramètres

x
Important. Indique le nombre de blocs de gestion de fichier (FCB) qu'il est possible d'ouvrir en même temps dans le sous-système MS-DOS. Les valeurs valides de x sont comprises entre 1 et 255. La valeur par défaut est 4.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • On appelle bloc de gestion de fichier une structure de données où sont enregistrées des informations concernant un fichier.
  • Si un programme tente d'ouvrir plus de x fichiers au moyen de blocs de gestion de fichier, il se peut que le sous-système MS-DOS ferme les fichiers ouverts plus tôt.
  • N'utilisez la commande fcbs que si un programme vous le demande. La plupart des programmes plus récents ne nécessitent pas de bloc de gestion de fichier. Certains programmes plus anciens, toutefois, peuvent nécessiter l'emploi de la commande fcbs dans votre fichier Config.nt.

Exemples

Pour préciser que le sous-système MS-DOS peut avoir jusqu'à huit blocs de gestion de fichier ouverts en même temps, tapez la ligne suivante dans votre fichier Config.nt :

fcbs=8


Files

Définit le nombre de fichiers auxquels le sous-système MS-DOS peut avoir simultanément accès. Utilisez le fichier racine_système\System32\Config.nt ou le fichier de démarrage équivalent spécifié dans le fichier PIF d'un programme pour spécifier le paramètre files.

Syntaxe

files=x

Paramètres

x
Important. Définit le nombre de fichiers auxquels le sous-système MS-DOS peut avoir simultanément accès. Les valeurs valides de x sont comprises entre 8 et 255. La valeur par défaut est 8.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • La valeur par défaut du paramètre x est 8, mais certains programmes exigent une valeur plus grande. Le paramètre le plus courant est 20.

Exemples

Pour indiquer que le sous-système MS-DOS peut accéder à un maximum de 20 fichiers à la fois, tapez la ligne suivante dans votre fichier Config.nt :

files=20


Find

Cherche une chaîne de texte déterminée dans un ou plusieurs fichiers. Après avoir cherché la chaîne dans le(s) fichier(s) spécifié(s), find affiche toutes les lignes de texte qui contiennent la chaîne spécifiée.

Syntaxe

find [/v] [/c] [/n] [/i] "chaîne" [[Lecteur:][Chemin]NomFichier[...]]

Paramètres

/v
Affiche toutes les lignes qui ne contiennent pas la chaîne spécifiée.
/c
Compte les lignes qui contiennent la chaîne spécifiée et affiche le total.
/n
Fait précéder chaque ligne du fichier par son numéro.
/i
Spécifie que la recherche ignore la casse.
"chaîne"
Important. Représente le groupe de caractères que vous voulez rechercher. Vous devez mettre chaîne entre guillemets (c'est-à-dire, "chaîne").
[Lecteur:][Chemin] NomDeFichier
Indique l'emplacement et le nom du fichier où la chaîne spécifiée doit être recherchée.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Spécification d'une chaîne

    Si vous n'utilisez pas /i, find recherche précisément les données spécifiées pour chaîne. Par exemple, la commande find traite différemment les caractères a et A. Toutefois, si vous utilisez /i, la commande find ignore la casse et traite a et A de la même manière.

    Si la chaîne à rechercher contient des guillemets (" "), utilisez deux paires de guillemets pour chaque paire contenue dans la chaîne (c'est-à-dire, "ChaîneContenant""Guillemets").

  • Emploi de find comme filtre

    Si vous omettez le nom de fichier, find se comporte comme un filtre, en prenant les données d'entrée de la source standard (généralement le clavier, un signe | ou un fichier redirigé) et en affichant toutes les lignes contenant la chaîne.

  • Ordre dans la syntaxe de la commande

    Vous pouvez taper les paramètres et les options de ligne de commande de la commande find dans n'importe quel ordre.

  • Emploi des caractères génériques

    Il n'est pas possible d'utiliser les caractères génériques (c'est-à-dire, * et ?) dans les noms de fichier ou les extensions que vous spécifiez avec la commande find. Pour rechercher une chaîne dans un jeu de fichiers que vous spécifiez à l'aide de caractères génériques, vous pouvez utiliser la commande find dans une commande for.

  • Utilisation de /v ou /n avec /c

    Si vous utilisez /c et /v dans la même ligne de commande, find affiche le nombre de lignes ne contenant pas la chaîne recherchée. Si vous spécifiez /c et /n dans la même ligne de commande, find ignore /n.

  • Utilisation de find avec des retours chariot

    La commande find ne reconnaît pas les retours chariot. Lorsque vous l'utilisez pour chercher un texte dans un fichier qui inclut des retours chariot, limitez la chaîne de recherche à un texte qui apparaît normalement entre ces retours (c'est-à-dire qui a peu de chances d'être interrompu par un tel retour). Par exemple, si vous cherchez la chaîne " dossier fiscal ", find ne la trouve que lorsqu'un retour chariot n'intervient pas entre le mot " dossier " et le mot " fiscal ".

Exemples

Pour afficher toutes les lignes du fichier Crayon.pub qui contiennent la chaîne « Taille-crayon », tapez :

find "Taille-crayon" crayon.pub

Pour trouver une chaîne qui contient du texte entre guillemets, vous devez d'abord mettre toute la chaîne entre guillemets. Deuxièmement, vous devez utiliser deux guillemets pour chaque guillemet contenu dans la chaîne. Pour trouver "Les chercheurs ont écrit dans leur rapport la mention "version préliminaire." Il ne s'agit pas de la version définitive du rapport." dans Rapport.doc, tapez :

find "Les chercheurs ont écrit dans leur rapport la mention ""version préliminaire." Il ne s'agit pas de la version définitive du rapport." rapport.doc

Pour chercher un jeu de fichiers, utilisez la commande find avec la commande for. Pour rechercher dans le répertoire courant les fichiers qui possèdent l'extension .bat et qui contiennent la chaîne "INVITE", tapez :

for %f in (*.bat) do find "INVITE" %f

Pour rechercher dans votre disque dur et afficher les noms de fichier du lecteur C qui contiennent la chaîne "UC", utilisez le signe | pour diriger les résultats d'une commande dir vers find, comme suit :

dir c:\ /s /b | find "UC"

Comme find distingue les majuscules des minuscules lors de la recherche et que dir produit des données de sortie en majuscules, tapez la chaîne “UC” en majuscules ou utilisez l'option de ligne de commande /i avec find.


Findstr

Recherche de structures de texte dans des fichiers à l'aide d'expressions régulières.

Syntaxe

findstr [/b] [/e] [/l] [/r] [/s] [/i] [/x] [/v] [/n] [/m] [/o] [/p] [/offline] [/g:fichier] [/f:fichier] [/c:chaîne] [/d:dirlist] [/a:AttributCouleur] [chaînes] [[Lecteur:][Chemin] NomFichier [...]]

Paramètres

/b
Ne reconnaît un modèle qu'au début d'une ligne.
/e
Ne reconnaît un modèle qu'à la fin d'une ligne.
/l
Utilise les chaînes de recherche littéralement.
/r
Utilise les chaînes de recherche comme expressions régulières. Findstr interprète tous les métacaractères comme des expressions régulières sauf si vous utilisez /l.
/s
Recherche les fichiers concordants dans le répertoire en cours ainsi que dans tous ses sous-répertoires.
/i
Imprime les lignes qui correspondent exactement.
/x
Imprime les lignes qui correspondent exactement.
/v
Imprime uniquement les lignes qui ne contiennent pas de correspondance.
/n
Imprime le numéro de ligne devant chaque ligne qui correspond.
/m
Imprime uniquement le nom de fichier si un fichier contient une correspondance.
/o
Imprime le décalage devant chaque ligne correspondante.
/p
Omet les fichiers contenant des caractères non imprimables.
/offline
Traite les fichiers avec l'attribut hors-connexion défini.
/f:fichier
Lit la liste des fichiers à partir du fichier spécifié.
/c:chaîne
Utilise le texte spécifié comme chaîne de recherche littérale.
/g:fichier
Obtient les chaînes de recherche à partir du fichier spécifié.
/d:liste_répertoire
Effectue la recherche dans une liste de répertoires séparés par des virgules.
/a:AttributCouleur
Spécifie des attributs de couleur avec deux chiffres hexadécimaux.
chaînes
Texte spécifié à rechercher dans NomFichier.
[Lecteur:][Chemin] NomDeFichier [...]
Spécifie le fichier ou les fichiers dans lesquels sera effectuée la recherche.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Utilisation d'expression régulières avec findstr

    Findstr est capable de trouver le texte exact recherché dans n'importe quel(s) fichier(s) ASCII. Il arrive cependant que vous ne disposiez que d'une partie de l'information recherchée ou que vous vouliez trouver une plus grande plage d'informations. Dans ces cas, findstr dispose d'une fonctionnalité puissante lui permettant de chercher des modèles de texte au moyen d'expressions régulières.

    On appelle expression régulière la notation utilisée pour définir des modèles de texte, par opposition aux chaînes exactes de caractères. La notation utilise des caractères littéraux et des méta-caractères. Chaque caractère qui n'a pas de signification particulière dans la syntaxe de l'expression régulière est un caractère littéral qui correspond à une occurrence quelconque de ce caractère. Les lettres et les nombres sont ainsi des caractères littéraux. Un méta-caractère est un symbole doté d'un sens particulier (opérateur ou séparateur) dans la syntaxe de l'expression régulière.

    Le tableau suivant répertorie les métacaractères acceptés par findstr.

    Caractère | Valeur
    . Caractère générique : n'importe quel caractère
    * Répétition : zéro occurrence ou plus du caractère précédent ou de la classe
    ^ Position sur la ligne : début de la ligne
    $ Position sur la ligne : fin de la ligne
    [classe] | Classe de caractère : n'importe quel caractère du jeu
    [^classe] | Classe inverse : n'importe quel caractère ne figurant pas dans le jeu
    [x-y] | Plage : n'importe quels caractères de la plage spécifiée
    \x | Échappement : utilisation littérale du méta-caractère x
    \<xyz | Position dans le mot : début du mot
    xyz\> | Position dans le mot : fin du mot

    Les caractères spéciaux de la syntaxe de l'expression régulière sont le plus performants lorsque vous les utilisez ensemble. Par exemple, la combinaison suivante du caractère générique (.) et du caractère de répétition (*) correspondent à n'importe quelle chaîne de caractères :

    .*

    Utilisez l'expression suivante en tant que partie d'une expression plus grande qui correspond à une chaîne qui commence par « b » et se termine par « ing » :

    b.*ent

Exemples

Utilisez des espaces pour séparer plusieurs chaînes de rechercher sauf si l'argument est précédé de /c. Pour rechercher « bonne » ou « nuit » dans le fichier x.y, tapez :

findstr "bonne nuit" x.y

Pour rechercher « bonne nuit » dans le fichier x.y, tapez :

findstr /c:"bonne nuit" x.y'

Pour trouver toutes les occurrences du mot Windows (avec la majuscule W) dans le fichier Devis.txt, tapez :

findstr Windows devis.txt

Pour chercher le mot Windows, sans distinguer la casse, dans tous les fichiers du répertoire en cours et de tous les sous-répertoires, tapez :

findstr /s /i Windows *.*

Pour trouver toutes les occurrences des lignes contenant le mot STOP, précédé par un nombre quelconque d'espaces (comme dans une boucle de programme informatique, par exemple) et pour inclure le numéro de ligne où se trouve chaque occurrence trouvée, tapez :

findstr /b /n /c:" *STOP" *.bas

Si vous souhaitez chercher différents éléments dans le même jeu de fichiers, créez un fichier texte contenant chaque critère de recherche sur une nouvelle ligne. Vous pouvez également indiquer les fichiers exacts que vous souhaitez rechercher dans un fichier texte. Pour utiliser les critères de recherche dans le fichier Trouver.txt, rechercher les fichiers indiqués dans ListeFich.txt, puis stocker les résultats dans le fichier Result.fin, tapez :

findstr /g:finddata.txt /f:filelist.txt > results.out

Supposons que vous souhaitiez trouver tous les fichiers du répertoire en cours et tous les sous-répertoires contenant le mot ordinateur, sans distinction de la casse. Pour obtenir la liste de tous les fichiers contenant le mot ordinateur, tapez :

findstr /s /i /m "\<ordinateur\>" *.*

Supposons maintenant que vous souhaitiez trouver non seulement le mot “ ordinateur ”, mais également n'importe quel mot commençant par les lettres ordi, tels que “ ordinal ” et “ ordinaire ”. ; comme suit :

findstr /s /i /m "\<ordi.*" *.*


Finger

Affiche des informations sur un ou plusieurs utilisateurs sur un ordinateur distant spécifié (généralement un ordinateur sous UNIX) qui exécute le service Finger ou démon. L'ordinateur distant spécifie le format et la sortie de l'affichage des informations de l'utilisateur. Utilisé sans paramètres, finger affiche des informations d'aide.

Syntaxe

finger [-l] [Utilisateur] [@hôte] [...]

Paramètres

-l
Affiche les informations utilisateur sous forme de liste longue.
Utilisateur
Spécifie l'utilisateur sur lequel vous voulez des informations. Si vous omettez le paramètre Utilisateur, finger affiche des informations sur tous les utilisateurs de l'ordinateur spécifié.
@hôte
Spécifie l'ordinateur distant exécutant le service Finger dans lequel vous recherchez des informations utilisateur. Vous pouvez spécifier un nom ou une adresse IP d'ordinateur.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Vous pouvez spécifier plusieurs paramètres Utilisateur@hôte.
  • Vous devez faire précéder les paramètres finger d'un tiret (-) à la place d'une barre oblique (/).
  • Cette commande est disponible uniquement si le protocole Internet Protocol (TCP/IP) est installé comme composant dans les propriétés d'un adaptateur réseau dans Connexions réseau.
  • Windows 2000 et Windows XP ne fournissent pas de service finger.

Exemples

Pour afficher des informations relatives à l'utilisateur1 sur l'ordinateur utilisateurs.microsoft.com, tapez la commande suivante :

finger utilisateur1@utilisateurs.microsoft.com

Pour afficher des informations relatives à tous les utilisateurs sur l'ordinateur utilisateurs.microsoft.com, tapez la commande suivante :

finger @utilisateurs.microsoft.com


For

Exécute une commande déterminée pour chaque fichier appartenant à un jeu particulier.

Syntaxe

for {%variable|%%variable} in (jeu) do commande [ OptionsLigneCommande]

Paramètres

{%variable|%%variable}
Important. Représente un paramètre remplaçable. Utilisez %variable pour exécuter for à l'invite de commandes. Utilisez %%variable pour exécuter la commande for dans un fichier de commandes. Les variables respectent la casse et doivent être représentées à l'aide d'une valeur alpha, telle que %A, %B ou %C.
(jeu)
Important. Spécifie un ou plusieurs fichiers, répertoires, plages de valeurs ou chaînes de texte que vous voulez traiter à l'aide de la commande spécifiée. Les parenthèses sont obligatoires.
commande
Important. Spécifie la commande que vous voulez exécuter sur chaque fichier, répertoire, plage de valeurs ou chaîne de texte comprise dans le (jeu) spécifié.
OptionsLigneCommande
Spécifie les options de ligne de commande que vous souhaitez utiliser avec la commande spécifiée.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • Utilisation de for

    La commande for peut être utilisée dans un fichier de commandes ou directement à l'invite de commandes.

  • Utilisation des paramètres de commande

    Les attributs suivants s'appliquent à la commande for :

    • La commande for remplace %variable (ou %%variable) par chaque chaîne de texte du jeu spécifié jusqu'à ce que la commande ait traité tous les fichiers.
    • Les noms des variables for respectent la casse, sont des variables globales et vous ne pouvez pas en activer plus de 52 au total.
    • Pour éviter toute confusion avec les paramètres de commande %0 à %9, vous pouvez utiliser pour la variable n'importe quel caractère, à l'exception des chiffres 0 à 9. Pour les fichiers de commandes simples, un seul caractère tel que %%f suffit.
    • Dans les fichiers de commandes complexes, vous pouvez utiliser plusieurs valeurs pour la variable afin de distinguer les diverses variables remplaçables.
  • Spécification d'un groupe de fichiers

    Le paramètre jeu peut représenter un seul ou plusieurs groupes de fichiers. Pour spécifier un jeu de fichiers, vous pouvez utiliser des caractères génériques (* et ?). Les jeux suivants sont tous valides :

    (*.doc)

    (*.doc *.txt *.me)

    (jan*.doc jan*.rpt fév*.doc fév*.rpt)

    (ar??1991.* ap??1991.*)

    Quand vous utilisez la commande for, la première valeur du jeu remplace %variable ou %%variable, puis la commande spécifiée traite cette valeur. Ce processus continue jusqu'à ce tous les fichiers (ou groupes de fichiers) correspondant à la ou aux valeurs du jeu aient été traités.

  • Utilisation des mots clés in et do

    In et do ne sont pas des paramètres, mais ils sont requis dans la commande for. Si vous omettez l'un ou l'autre de ces mots clés, un message d'erreur apparaît.

  • Utilisation de formes supplémentaires de for

    Si les extensions de commande sont activées (ce qui est le cas par défaut), les formes supplémentaires suivantes de la commande for sont prises en charge.

    • Répertoires seulement

      Si le jeu contient des caractères génériques (* et ?), la commande spécifiée s'exécute pour chaque répertoire (au lieu d'un jeu de fichiers dans un répertoire spécifié) qui correspond au jeu. La syntaxe de cette commande est la suivante :

      for /D [%% | %]variable in (jeu) do commande [OptionsLigneCommande]

    • Récursive

      Parcourt l'arborescence des répertoires à partir de la racine de [Lecteur:]Chemin, en exécutant l'instruction for dans chaque répertoire de l'arborescence. Si aucun répertoire n'est spécifié après /R, le répertoire en cours est utilisé. Si jeu ne contient qu'un seul caractère . (point), seule l'arborescence des répertoires est énumérée. La syntaxe de cette commande est la suivante :

      for /R [[Lecteur :]Chemin] {%% | %}variable in (jeu) do commande [OptionsLigneCommande]

    • Itération d'une page de valeurs

      Utilisez une variable itérative pour définir la valeur de début (début#) puis avancez dans une plage définie de valeurs jusqu'à ce que la valeur dépasse la valeur de fin définie (fin#). /L exécute l'itération en comparant début# et fin#. Si début# est inférieur à fin#, la commande s'exécute. Lorsque la variable itérative dépasse fin#, la commande quitte la boucle. Vous pouvez également utiliser une valeur incrément# négative pour faire défiler une plage de valeurs décroissantes. Par exemple, (1,1,5) génère la séquence 1 2 3 4 5 et (5,-1,1) génère la séquence (5 4 3 2 1). La syntaxe de cette commande est la suivante :

      for /L {%% | %}variable in (débutt#,incrément#,fin#) do commande [OptionsLigneCommande]

    • Itération et analyse de fichier

      Utilisez l'analyse de fichiers pour traiter la sortie de la commande, les chaînes et le contenu des fichiers. Utilisez des variables itératives pour définir le contenu ou les chaînes que vous voulez examiner et utilisez les différentes options MotsClésAnalyse pour continuer à modifier l'analyse. Utilisez l'option jeton MotsClésAnalyse pour spécifier quels jetons doivent être passés en tant que variables d'itération. Notez que sans l'option de jeton, /F n'examine que le premier jeton.

      L'analyse des fichiers consiste à lire la sortie, la chaîne ou le contenu du fichier, à le diviser en lignes de texte séparées, puis à analyser chaque ligne dans zéro jeton ou davantage. La boucle for est ensuite appelée avec la valeur de variable d'itération définie sur le jeton. Par défaut, /F passe le premier jeton séparé par un blanc à partir de chaque ligne de chaque fichier. Les lignes blanches sont sautées. Les autres syntaxes sont les suivantes :

      for /F ["MotsClésAnalyse"] {%% | %}variable in (jeunomfichier) do commande [OptionsLigneCommande]

      for /F ["MotsClésAnalyse"] {%% | %}variable in ("ChaîneLittérale") do commande [OptionsLigneCommande]

      for /F ["MotsClésAnalyse"] {%% | %}variable in ('commande') do commande [OptionsLigneCommande]

      L'argument jeunomfichier spécifie un ou plusieurs noms de fichier. Chaque fichier est ouvert, lu et traité avant de passer au fichier suivant du jeunomfichier. Pour passer outre le comportement d'analyse par défaut, spécifiez "MotsClésAnalyse". Il s'agit d'une chaîne placée entre guillemets qui contient un ou plusieurs mots clés pour spécifier différentes options d'analyse.

      Si vous utilisez l'option usebackq, utilisez l'une des syntaxes suivantes :

      for /F ["usebackq MotsClésAnalyse"] {%% | %}variable in ("jeunomfichier") do commande [OptionsLigneCommande]

      for /F ["usebackq MotsClésAnalyse"] {%% | %}variable in ('ChaîneLittérale') do commande [OptionsLigneCommande]

      for /F ["usebackq MotsClésAnalyse"] {%% | %}variable in (`commande`) do commande [OptionsLigneCommande]

      Le tableau suivant répertorie les mots clés d'analyse que vous pouvez utiliser dans MotsClésAnalyse.

      Mot clé | Description
      eol=c | Spécifie un caractère de fin de ligne (juste un caractère).
      skip=n | Spécifie le nombre de lignes à sauter au début du fichier.
      delims=xxx | Spécifie un jeu de séparateur. Celui-ci remplace le jeu de délimiteur par défaut constitué de l'espace et de la tabulation.
      tokens=x,y,m-n | Spécifie les jetons de chaque ligne qui doivent être passés au corps de la commande for pour chaque occurrence. Par conséquent, les noms de variables supplémentaires sont alloués. La forme m-n est une plage qui spécifie le mième au nième jetons. Si le dernier caractère de la chaîne tokens= est un astérisque (*), une variable supplémentaire est allouée pour recevoir le texte restant de la ligne après le dernier jeton analysé.
      usebackq | Spécifie que vous pouvez utiliser des guillemets pour les noms de fichier de jeunomfichier, une chaîne à guillemet inversé est exécutée comme une commande et un chaîne à guillemet simple est une commande de chaîne littérale.
    • Substitution de variable

      Les modificateurs de substitution pour les références de variable for ont été améliorés. Le tableau suivant répertorie les syntaxes facultatives (pour toute variable I).

      Variable avec modificateur | Description
      %~I | Développe %I qui supprime les guillemets ("").
      %~fI | Développe %I en nom de chemin complet.
      %~dI | Développe %I en une lettre de lecteur seulement.
      %~pI | Développe %I en chemin seulement.
      %~nI | Développe %I en nom de fichier seulement.
      %~xI | Développe %I en extension de fichier seulement.
      %~sI | Développe le chemin pour qu'il contienne seulement des noms courts.
      %~aI | Développe %I jusqu'aux attributs du fichier.
      %~tI | Développe %I jusqu'à la date et l'heure du fichier.
      %~zI | Développe %I jusqu'à la taille du fichier.
      %~$PATH:I | Recherche les répertoires énumérés dans la variable d'environnement et développe %I jusqu'au nom complet du premier répertoire trouvé. Si le nom de la variable d'environnement n'est pas défini ou si la recherche ne trouve pas de fichier, ce modificateur se développe en une chaîne vide.

      Le tableau suivant répertorie les combinaisons de modificateurs que vous pouvez utiliser pour obtenir des résultats composés.

      Variable avec modificateurs combinés | Description
      %~dpI | Développe %I en une lettre de lecteur et un chemin seulement.
      %~nxI | Développe %I en nom de fichier et une extension seulement.
      %~fsI | Développe %I en un nom de chemin complet avec des noms courts seulement.
      %~dp$PATH:I | Recherche les répertoires énumérés dans la variable d'environnement pour %I et développe jusqu'à la lettre du lecteur et au chemin du premier répertoire trouvé.
      %~ftzaI | Développe %I en une ligne de sortie semblable à dir.

      Dans les exemples ci-dessus, vous pouvez remplacer %I et le chemin par d'autres valeurs valides. Une variable for valide termine la syntaxe %~.

      L'utilisation de noms de variable en majuscules tels que %I facilite la lecture de votre code et évite toute confusion avec les modificateurs, qui ne différencient pas la casse.

  • Analyse d'une chaîne

    Vous pouvez aussi utiliser la logique d'analyse for /F sur une chaîne immédiate, en mettant entre guillemets simples le jeunomfichier entre parenthèses (c'est-à-dire, 'jeunomfichier'). jeunomfichier est traité comme une simple ligne d'entrée d'un fichier, puis est analysé.

  • Analyse de la sortie

    Vous pouvez utiliser la commande for /F pour analyser la sortie d'une commande en convertissant le jeunomfichier entre parenthèses en une chaîne à guillemet inversé. Celle-ci sera alors traitée comme une ligne de commande, qui est passée à un fichier Cmd.exe enfant tandis que la sortie est capturée en mémoire et analysée comme s'il s'agissait d'un fichier.

Exemples

Pour utiliser for dans un fichier de commandes, employez la syntaxe suivante :

for %%variable in (jeu) do commande [OptionsLigneCommande]

Pour afficher le contenu de tous les fichiers .doc ou .txt du répertoire courant à l'aide de la variable remplaçable %f, tapez :

for %f in (*.doc *.txt) do type %f

Dans cet exemple, chacun des fichiers du répertoire en cours pourvu de l'extension .doc ou .txt est substitué à la variable %f jusqu'à ce que le contenu de tous les fichiers ait été affiché. Pour utiliser cette commande dans un fichier de commandes, remplacez toutes les occurrences de %f par %%f. Sans cela, la variable est ignorée et un message d'erreur est affiché.

Pour analyser un fichier en ignorant les lignes de commentaires, tapez :

for /F "eol=; tokens=2,3* delims=," %i in (monfichier.txt) do @echo %i %j %k

Cette commande analyse chaque ligne du fichier monfichier.txt en ignorant les lignes qui commencent par un point-virgule et en passant le deuxième et le troisième jeton de chaque ligne au corps de la commande FOR (les jetons sont délimités par des virgules ou des espaces). Le corps de l'instruction FOR fait référence à %i pour obtenir le deuxième jeton, à %j pour obtenir le troisième jeton et à %k pour obtenir tous les autres jetons. Si les noms de fichier que vous indiquez contiennent des espaces, mettez le texte entre guillemets (par exemple, "NomFichier"). Pour utiliser des guillemets, utilisez usebackq. Sans cela, les guillemets sont interprétés comme s'ils définissent une chaîne littérale à analyser.

%i est déclaré de manière explicite dans l'instruction FOR tandis que %j et %k sont déclarés de manière implicite à l'aide de l'option tokens=. Vous pouvez spécifier jusqu'à 26 jetons à l'aide de tokens=, à condition que cela n'entraîne pas une tentative de déclaration d'une variable supérieure à « z » ou « Z ».

Par analyser la sortie d'une commande en plaçant jeunomfichier entre les parenthèses, tapez :

for /F "usebackq delims==" %i IN (`set`) DO @echo %i

Cet exemple énumère les noms de variable d'environnement dans l'environnement en cours.


Forcedos

Lance le programme indiqué dans le sous-système MS-DOS. Cette commande est nécessaire uniquement pour les programmes MS-DOS non reconnus comme tels par Windows XP.

Syntaxe

forcedos [/d répertoire] NomFichier [paramètres]

Paramètres

/d répertoire
Indique le répertoire en cours du programme à utiliser.
NomFichier
Important. Indique le programme à lancer. Si ce programme n'est pas dans le répertoire ou dans le chemin en cours, vous devez indiquer la lettre du lecteur ou les répertoires du programme.
paramètres
Spécifie les paramètres à passer au programme.
/?
Affiche l'aide dans l'invite de commandes.

Remarques

  • XOX
  • XOX
  • Certains programmes MS-DOS ne sont pas reconnus par Windows XP en tant que programmes MS-DOS. Utilisez forcedos pour démarrer ces programmes.
  • Tous les programmes que vous démarrez avec forcedos sont ouverts en tant qu'applications MS-DOS.

Exemples

Pour démarrer le programme Monprogramme dans le répertoire \Oldapps afin de pouvoir utiliser le répertoire \Rapports, tapez :

forcedos /d rapports \oldapps\monprog


Format

Formate le disque du volume spécifié afin qu'il puisse recevoir des fichiers Windows.

Syntaxe

format Volume [/fs:SystèmeFichiers] [/v:Étiquette] [/q] [/a:TailleUnité] [/c] [/x]

format Volume [/v:Étiquette] [/q] [/f:Taille]

format Volume [/v:Étiquette] [/q] [/t:Pistes /n:Secteurs]

format Volume [/v:Étiquette] [/q]

format Volume [/q]

Paramètres

volume
Spécifie le point de fixation, le nom de volume ou la lettre du lecteur à formater. Si vous n'utilisez aucune des options de ligne de commande suivantes, format détermine le format par défaut du disque d'après le type du volume.
/fs:système-fichier
Spécifie le système de fichier à utiliser, à savoir FAT, FAT32 ou NTFS. Les disquettes ne peuvent utiliser que le système FAT.
/v:nom
Représente le nom du volume. Si vous omettez l'option de ligne de commande /v ou si vous l'utilisez sans spécifier de nom de volume, format vous demande ce nom une fois le formatage achevé. Utilisez la syntaxe /v: pour éviter de devoir spécifier un nom de volume. Si vous formatez plusieurs disquettes au moyen d'une seule commande format, elles reçoivent toutes le même nom de volume. Pour plus d'informations sur les noms de volume de disque, cliquez sur Dir, Label et Vol dans la liste Voir aussi.
/a:TailleUnité
Spécifie la taille de l'unité d'allocation à utiliser sur les volumes FAT, FAT32 ou NTFS. Si vous ne spécifiez pas TailleUnité, le choix est déterminé par la taille du volume. Le tableau suivant répertorie les valeurs valides de TailleUnité.
Valeur | Description
512 | Crée 512 octets par cluster.
1024 | Crée 1024 octets par cluster.
2048 | Crée 2048 octets par cluster.
4096 | Crée 4096 octets par cluster.
8192 | Crée 8192 octets par cluster.
16K | Crée 16 kilo-octets par cluster.
32K | Crée 32 kilo-octets par cluster.
64K | Crée 64 kilo-octets par cluster.
/q
Effectue un formatage rapide. Supprime la table de fichiers et le répertoire racine d'un disque précédemment formaté, mais n'effectue pas de recherche secteur par secteur des zones défectueuses. N'utilisez l'option de ligne de commande /q que pour formater des volumes déjà formatés auparavant et en bon état.
/f:taille
Indique la taille de la disquette à formater. Utilisez aussi souvent que possible cette option de ligne de commande à la place des options de ligne de commande /t et /n. Windows accepte les valeurs suivantes pour spécifier la taille :

1440 ou 1440k ou 1440kb ou 1.44 ou 1.44m ou 1.44mb
Disquette 3 pouces et demi, quadruple densité, double face de 1,44 Mo

/t:pistes
Spécifie le nombre de pistes du disque. Utilisez aussi souvent que possible l'option de ligne de commande /f en lieu et place de celle-ci. Si vous utilisez l'option de ligne de commande /t, vous devez également utiliser l'option de ligne de commande /n. L'emploi de ces deux options de ligne de commande constitue une autre méthode de spécification de la taille du disque à formater. Vous ne pouvez pas utiliser l'option de ligne de commande /f avec l'option de ligne de commande /t.
/n:secteurs
Spécifie le nombre de secteurs par piste. Utilisez aussi souvent que possible l'option de ligne de commande /f en lieu et place de celle-ci. Si vous utilisez l'option de ligne de commande /n, vous devez également utiliser l'option de ligne de commande /t. L'emploi de ces deux options de ligne de commande constitue une autre méthode de spécification de la taille du disque à formater. Vous ne pouvez pas utiliser l'option de ligne de commande /f avec l'option de ligne de commande /n.
/c
NTFS seulement. Les fichiers créés sur le nouveau volume seront compressés par défaut.
/x
Commande la décompression éventuelle du volume avant son formatage. Tous les descripteurs ouverts du volume ne seront plus valides.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de format à l'aide de la console de récupération

    La commande format, ainsi que différents paramètres, sont accessibles via la console de récupération.

  • Privilèges d'administration

    Pour formater un disque dur, vous devez être membre du groupe Administrateurs.

  • Utilisation de format

    La commande format crée un répertoire racine et un système de fichiers pour le disque. Elle peut aussi vérifier si le disque comporte des zones défectueuses et supprimer toutes les données du disque. Pour pouvoir utiliser un nouveau disque, vous devez d'abord formater celui-ci au moyen de cette commande.

  • Frappe d'un nom de volume

    Après avoir formaté une disquette, la commande format affiche le message suivant :

    Nom de volume (11 caractères, ENTRÉE pour ne rien mettre) ?

    Le nom du volume peut avoir un maximum de 11 caractères (espaces compris). Si vous ne souhaitez pas assigner de nom de volume à votre disquette, appuyez simplement sur ENTRÉE. Pour plus d'informations sur les noms de volume, cliquez sur label dans la liste Voir aussi.

  • Formatage d'un disque dur

    Lorsque vous utilisez la commande format pour un disque dur, celle-ci affiche un message sous la forme suivante avant de tenter l'opération :

    AVERTISSEMENT, TOUTES LES DONNEES SUR LE DISQUE DUR
    x: SERONT PERDUES!
    Lancer le formatage (O/N) ?_

    Pour formater le disque dur, appuyez sur O ; si vous ne voulez pas formater ce disque, appuyez sur N. Pour formater un disque dur, vous devez disposer de droits d'administrateur.

  • Taille unitaire

    Les systèmes de fichiers FAT limitent le nombre de clusters à 65 526 maximum tandis que les systèmes de fichiers FAT32 autorisent entre 65 527 et 4177917 clusters.

    La compression NTFS n'est pas prise en charge pour l'assignation de tailles unitaires supérieures à 4 096.

  • Messages de la commande Format

    Une fois le formatage achevé, format affiche des messages indiquant l'espace disque total, les espaces signalés comme étant défectueux et l'espace disponible pour les fichiers.

  • Formatage rapide

    Pour accélérer le formatage, vous pouvez vous servir de l'option de ligne de commande /q. Cependant, n'utilisez cette option de ligne de commande que s'il n'y a pas de secteurs défectueux sur le disque dur.

  • Emploi de format avec un lecteur réassigné ou un lecteur réseau

    N'utilisez pas la commande format sur un lecteur préparé au moyen de la commande subst. Il est en outre impossible de formater des disques sur un réseau.

  • Codes de sortie de la commande Format

    Le tableau suivant affiche la liste de chacun des codes de sortie, accompagné d'une description sommaire.

    Code de sortie | Description
    0 | Le formatage a réussi.
    1 | Des paramètres incorrects ont été fournis.
    4 | Une erreur irrécupérable (toute erreur autre que 0, 1 ou 5) s'est produite.
    5 | En réponse à l'invite “ Lancer le formatage (O/N) ? ”, l'utilisateur a appuyé sur N pour arrêter le processus.

    Pour vérifier ces codes de sortie, vous pouvez utiliser la condition errorlevel avec la commande batch if.

Exemples

Pour formater une nouvelle disquette placée dans le lecteur A selon la taille par défaut, tapez :

format a:

Pour procéder au formatage rapide d'une disquette précédemment formatée placée dans le lecteur A, tapez :

format a: /q

Pour formater une disquette placée dans le lecteur A et lui donner le nom de volume “Données”, tapez :

format a: /v:DONNEES


Fsutil

Fsutil est un utilitaire de ligne de commande qui vous permet d'effectuer de nombreuses tâches relatives aux systèmes de fichiers FAT et NTFS, par exemple la gestion des points d'analyse et des fichiers fragmentés, ainsi que le démontage ou l'extension d'un volume. Étant donné que fsutil est un outil très puissant, son emploi doit être réservé aux utilisateurs chevronnés ayant une connaissance approfondie de Windows XP. En outre, vous devez ouvrir une session en tant qu'administrateur ou membre du groupe Administrateurs pour pouvoir utiliser fsutil.

Le tableau suivant répertorie les sous-commandes de fsutil.

Commande | Description
behavior | Interroge, modifie, active ou désactive les paramètres pour la génération de noms de fichiers de 8.3 caractères, l'autorisation d'utiliser des caractères étendus dans les noms de fichiers de 8.3 caractères sur les volumes NTFS, la mise à jour de l'horodateur de dernier accès sur les volumes NTFS, l'obtention de la fréquence d'écriture des événements de quotas dans le journal système, ainsi que l'espace disque réservé à la zone MFT.
dirty | Détermine si le bit d'impureté du volume est défini. Définit le bit d'impureté d'un volume. Si le bit d'impureté d'un volume est défini, autochk vérifie automatiquement ce volume lors du prochain redémarrage de l'ordinateur.
file | Généralement utilisé par les personnels de support technique. Recherche un fichier à partir de son identificateur de sécurité, interroge les plages allouées d'un fichier, définit le nom court, la longueur de données valides ou les données égales à zéro d'un fichier.
fsinfo | Généralement utilisé par les personnels de support technique. Affiche la liste de tous les lecteurs, fournit des informations sur le type de lecteur, le volume, les spécificités liées aux volumes NTFS ou les statistiques sur le système de fichiers.
hardlink | Crée un lien réel. Un lien réel est une entrée de répertoire pour un fichier. Vous pouvez considérer que chaque fichier possède au moins un lien réel. Sur les volumes NTFS, chaque fichier peut posséder plusieurs liens réels, par conséquent, un fichier unique peut apparaître dans de nombreux répertoires (voire dans un même répertoire sous des noms différents). Étant donné que tous les liens font référence au même fichier, les applications peuvent ouvrir n'importe quel lien et modifier le fichier. Un fichier n'est supprimé dans le système de fichiers qu'à partir du moment où tous ses liens ont été supprimés. Après avoir créé un lien réel, les programmes peuvent l'utiliser comme n'importe quel nom de fichier.
objectid | Généralement utilisé par les personnels de support technique. Gère les identificateurs d'objets, qui sont utilisés par Windows XP pour effectuer le suivi d'objets tels que les fichiers et les répertoires.
quota | Gère les quotas de disque sur les volumes NTFS pour pouvoir offrir un contrôle plus précis du stockage réseau. Les quotas de disque sont implémentés pour chaque volume et permettent d'établir des limites de stockage aussi bien matérielles que logicielles pour chaque utilisateur.
point de réanalyse | Généralement utilisé par les personnels de support technique. Interroge ou supprime des points d'analyse, autrement dit des objets du système de fichiers NTFS qui possèdent un attribut définissable contenant des données contrôlées par l'utilisateur, et qui permettent d'étendre les fonctionnalités du sous-système d'entrée/sortie (E/S). Les points d'analyse sont utilisés comme points de jonction de répertoires et comme points de montage de volumes. Ils sont également utilisés par les pilotes de filtre du système de fichiers pour marquer certains fichiers propres à ce pilote.
sparse | Gère les fichiers fragmentés. Un fichier fragmenté est un fichier dont une ou plusieurs zones contiennent des données non allouées. Une application récupérera ces zones non allouées qui contiennent des octets possédant des valeurs nulles, mais aucun espace disque n'est effectivement utilisé pour représenter ces valeurs nulles. Autrement dit, toutes les données non nulles ou significatives sont allouées, alors que toutes les données non significatives (longues chaînes de données constituées de zéros) ne sont pas allouées. Lorsqu'un fichier fragmenté est lu, les données allouées sont renvoyées sous la forme de données stockées et les données non allouées sont renvoyées par défaut sous la forme de valeurs nulles conformément à la spécification d'exigence de sécurité C2. La prise en charge des fichiers fragmentés permet de supprimer l'allocation de données à n'importe quel emplacement du fichier.
usn | Généralement utilisé par les personnels de support technique. Gère le journal de modification des numéros de séquence de mise à jour, qui fournit un enregistrement persistant de toutes les modifications apportées aux fichiers du volume.
volume | Gère un volume. Démonte un volume ou envoie une requête pour voir le montant d'espace disque disponible.

Remarque

  • Pour afficher l'aide relative aux sous-commandes disponibles à l'invite de commandes, tapez fsutil, ensuite la sous-commande, puis help (par exemple, fsutil sous-commande help).


Fsutil: behavior

Interroge les paramètres en cours pour la génération de noms de fichiers de 8.3 caractères, l'autorisation d'utiliser des caractères étendus dans les noms de fichiers de 8.3 caractères sur les volumes NTFS, la mise à jour de l'horodateur de dernier accès sur les volumes NTFS, l'obtention de la fréquence d'écriture des événements de quotas dans le journal système ainsi que la taille de la zone table de fichiers maîtres (MFT). Active ou désactive l'utilisation des noms de fichiers de 8.3 caractères, pour autoriser les caractères étendus dans les noms de fichiers de 8.3 caractères et mettre à jour l'horodateur de dernier accès sur les volumes NTFS. Permet de modifier la fréquence à laquelle les événements de quotas sont écrits dans le journal système, ainsi que l'espace disque réservé à la zone MFT.

Syntaxe

fsutil behavior query {disable8dot3|allowextchar|disablelastaccess|quotanotify|mftzone}

fsutil behavior set [{disable8dot3 {1|0}|allowextchar {1|0}|disablelastaccess {1|0}|quotanotify fréquence|mftzone valeur}]

Paramètres

query
Interroge les paramètres du mode de système de fichiers.
set
Modifie les paramètres du mode de système de fichiers.
disable8dot3 {1|0}
Désactive la création de noms de fichiers de 8.3 caractères sur les volumes formatés FAT et NTFS.
allowextchar {1|0}
Détermine si les caractères du jeu de caractères étendus, y compris les signes diacritiques, peuvent être utilisés dans les noms de fichiers courts au format 8.3 sur les volumes NTFS.
disablelastaccess {1|0}
Détermine si NTFS met à jour l'horodateur de dernier accès pour chaque répertoire lorsque celui-ci est listé sur un volume NTFS.
quotanotify fréquence
Configure la fréquence à laquelle les violations de quotas NTFS sont signalées dans le journal système. Entrez une valeur comprise entre 0 et 4294967295 secondes pour indiquer la fréquence à laquelle les violations de quotas sont écrites dans le journal système. La valeur par défaut est de 1 heure (3600 secondes).
mftzone valeur
La zone table de fichiers maîtres (MFT) est un espace réservé qui permet à MFT de s'étendre autant que nécessaire, afin d'empêcher la fragmentation de MFT. Définissez la valeur entre 1 (par défaut) et 4 (maximum). La valeur est exprimée en huitièmes de disque.

Remarques

  • La sous-commande behavior écrit les modifications dans le Registre, par conséquent, vous devez redémarrer l'ordinateur pour que ces modifications soient prises en compte.
  • Utilisation de disable8dot3 {1|0}

    Lorsque disable8dot3 est défini avec la valeur 0, chaque fois que vous créez un fichier avec un nom de fichier long, NTFS crée une seconde entrée de fichier comportant un nom de fichier de 8.3 caractères. Lorsque NTFS crée des fichiers dans un dossier, il doit rechercher les noms de fichiers de 8.3 caractères associés aux noms de fichiers longs.

    Ce paramètre met à jour la clé de Registre HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation.

  • Utilisation de allowextchar {1|0}

    Ce paramètre met à jour la clé de Registre HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsAllowExtendedCharacterIn8dot3Name.

  • Utilisation de disablelastaccess {1|0}

    Le paramètre disablelastaccess permet de réduire l'impact de journalisation de la mise à jour de l'horodateur de dernier accès sur les dossiers et répertoires. La désactivation de l'heure de dernier accès améliore la vitesse d'accès aux dossiers et fichiers.

    Chaque fichier ou dossier présent sur un volume NTFS contient un attribut appelé Heure de dernier accès. Cet attribut définit l'heure du dernier accès au fichier ou dossier, par exemple, lorsqu'un utilisateur affiche une liste de dossiers, ajoute des fichiers à un dossier, lit ou modifie un fichier. Les informations les plus récentes sur l'heure de dernier accès sont stockées en mémoire et écrites sur le disque à deux emplacements différents. Le premier emplacement est représenté par l'attribut du fichier, qui fait partie de son enregistrement MFT. Le second emplacement est représenté par l'index du répertoire contenant le fichier.

    L'heure de dernier accès sur le disque n'est pas toujours actualisée. Ce décalage se produit lorsque NTFS met du temps à écrire l'heure de dernier accès sur le disque parce que des utilisateurs ou des programmes effectuent des opérations en lecture seule sur un fichier ou un dossier, par exemple, afficher le contenu du dossier ou lire (mais pas modifier) un fichier du dossier. Si l'heure de dernier accès est actualisée sur le disque pour les opérations de lecture, toutes les opérations de lecture deviennent des opérations d'écriture, ce qui a un impact sur les performances de NTFS.

    Remarquez que les requêtes d'heure de dernier accès portant sur des fichiers restent précises même si toutes les valeurs sur disque ne sont pas actualisées. NTFS renvoie le résultat approprié lors des requêtes, car la valeur précise est stockée en mémoire.

    NTFS met généralement à jour l'attribut d'un fichier sur le disque lorsque la valeur actuellement en mémoire de l'heure de dernier accès diffère de plus d'une heure de l'heure de dernier accès stockée sur disque, ou lorsque toutes les références au fichier en mémoire ont disparu, quelle que soit la valeur la plus récente. Par exemple, si la valeur actuelle de l'heure de dernier accès à un fichier est 13:00, et que vous lisez le fichier à 13:30, NTFS ne met pas à jour l'heure de dernier accès. Si vous lisez de nouveau le fichier à 14:00, NTFS met à jour l'heure de dernier accès dans l'attribut du fichier pour refléter la valeur 14:00 car l'attribut du fichier affiche 13:00 alors que l'heure de dernier accès stockée en mémoire affiche 14:00.

    NTFS met à jour l'index du répertoire contenant le fichier lorsqu'il met à jour l'heure de dernier accès au fichier ; en outre, il détecte que l'heure de dernier accès au fichier diffère de plus d'une heure de l'heure de dernier accès stockée dans l'index du répertoire. Cette mise à jour se produit généralement après qu'un programme a fermé le handle permettant d'accéder à un fichier du répertoire. Si l'utilisateur conserve le handle ouvert pendant une période étendue, un décalage se produit avant que la modification ne s'affiche dans l'entrée d'index du répertoire.

    Remarquez qu'une heure représente le délai de report maximal utilisé par NTFS pour mettre à jour l'heure de dernier accès sur le disque. Si NTFS doit mettre à jour d'autres attributs du fichier tels que l'heure de dernière modification, et qu'une mise à jour de l'heure de dernier accès est en attente, NTFS met à jour l'heure de dernier accès en même temps que les autres mises à jour sans provoquer d'impact supplémentaire sur les performances.

    Remarquez que l'utilisation du paramètre disablelastaccess peut affecter des programmes tels que la sauvegarde et le stockage étendu qui reposent sur cette fonctionnalité.

    Ce paramètre met à jour la clé de Registre HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisableLastAccessUpdate.

  • Utilisation de mftzone valeur

    La valeur est une approximation de la taille initiale de MFT ajoutée à celle de la zone MFT d'un nouveau volume, et est définie lors du montage de chaque système de fichiers. Au fur et à mesure de l'utilisation de l'espace sur le volume, NTFS ajuste l'espace réservé à la croissance ultérieure de MFT. Si la zone MFT est déjà grande, la taille totale de la zone MFT n'est pas réservée à nouveau. Étant donné que la zone MFT est basée sur la plage contiguë située après la fin de MFT, elle se réduit proportionnellement à l'espace utilisé.

    Le système de fichiers ne redétermine pas l'emplacement de la zone MFT tant que la zone MFT actuelle n'est pas complètement utilisée. Cette situation ne se produit pas sur un système ordinaire.


Fsutil: dirty

Détermine si un bit d'impureté du volume est défini. Définit le bit d'impureté d'un volume. Si le bit d'impureté d'un volume est défini, autochk vérifie automatiquement ce volume lors du prochain redémarrage de l'ordinateur.

Syntaxe

fsutil dirty {query|set} Chemin

Paramètres

query
Interroge le bit d'impureté.
set
Définit le bit d'impureté d'un volume.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.

Remarques

  • Si le bit d'impureté d'un volume est défini, cela indique que le système de fichiers est peut-être dans un état non cohérent. Le bit d'impureté peut être défini parce que le volume est en ligne et qu'il fait l'objet d'importantes modifications, parce que des modifications ont été apportées au volume et que l'ordinateur a été arrêté avant l'écriture des modifications sur le disque, ou encore parce que des erreurs ont été détectées sur le volume. Si le bit d'impureté est défini au redémarrage de l'ordinateur, chkdsk s'exécute pour vérifier la cohérence du volume.

    Chaque fois que Windows XP démarre, Autochk.exe est appelé par le noyau pour analyser tous les volumes et vérifier si le bit d'impureté du volume est défini. Si le bit d'impureté est défini, autochk exécute immédiatement chkdsk /f sur ce volume. Chkdsk /f vérifie l'intégrité du système de fichiers et tente de résoudre les problèmes liés au volume.

Exemples

Pour interroger le bit d'impureté sur le lecteur C, tapez :

fsutil dirty query C:

Exemple de sortie :

L'intégrité du volume C: est incertaine

ou

Le volume C: est intègre

Pour définir le bit d'impureté sur le lecteur C, tapez :

fsutil dirty set C:


Fsutil: file

Généralement utilisé par les personnels de support technique. Recherche un fichier à partir de l'identificateur de sécurité, interroge les plages allouées d'un fichier, définit le nom court, la longueur de données valides ou les données égales à zéro d'un fichier, ou crée un fichier.

Syntaxe

fsutil file [createnew] Chemin Longueur

fsutil file [findbysid] Utilisateur Chemin

fsutil file [queryallocranges] offset=Offset length=Longueur Chemin

fsutil file [setshortname] Chemin NomCourt

fsutil file [setvaliddata] Chemin LongueurDonnées

fsutil file [setzerodata] offset=Offset length=Longueur Chemin

Paramètres

createnew
Crée un fichier avec un nom et une taille spécifiques, dont le contenu se compose de zéros.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
Longueur
Spécifie la longueur de données valides du fichier.
findbysid
Recherche des fichiers sur les volumes NTFS appartenant à un utilisateur spécifique. Cet utilisateur est identifié par son SID (identificateur de sécurité).
Utilisateur
Spécifie le nom de l'utilisateur ou son nom d'ouverture de session.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
queryallocranges
Interroge les plages allouées d'un fichier sur un volume NTFS. Cette option s'avère très utile pour déterminer si un fichier comporte des zones fragmentées.
offset=Offset
Spécifie le début de la plage à laquelle des zéros doivent être attribués.
length=Longueur
Spécifie la longueur de la plage, en octets.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
setshortname
Définit le nom court (nom de fichier de 8.3 caractères) d'un fichier situé sur un volume NTFS.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
NomCourt
Spécifie le nom court du fichier.
setvaliddata
Définit la longueur de données valides pour un fichier situé sur un volume NTFS.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
LongueurDonnées
Spécifie la longueur du fichier, en octets.
setzerodata
Attribue des zéros à une plage (spécifiée par Offset et Longueur) d'un fichier, ce qui permet de le vider. S'il s'agit d'un fichier fragmenté, les unités d'allocation sous-jacentes sont rendues non valides.
offset=Offset
Spécifie l'offset du fichier, c'est-à-dire le début de la plage qui doit être définie à l'aide de zéros.
length=Longueur
Spécifie la longueur de la plage à laquelle des zéros doivent être attribués.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.

Remarques

  • Utilisation de setvaliddata

    Dans NTFS, il existe deux concepts importants en matière de longueur de fichier : le marqueur de fin de fichier (EOF) et la longueur de données valides (VDL). Le marqueur de fin de fichier (EOF) indique la longueur réelle du fichier. La longueur de données valides identifie la longueur des données valides présentes sur le disque. Les lectures effectuées entre la longueur de données valides et la fin de fichier retournent automatiquement 0 afin de garantir la nécessité de réutilisation de l'objet C2.

    Le paramètre setvaliddata n'est disponible que pour les administrateurs car il nécessite le privilège de gestion de volume. Cette fonctionnalité n'est requise que dans le cadre d'une utilisation avancée du multimédia ou des réseaux système (SAN).

Exemples

Pour rechercher l'utilisateur scottb sur le lecteur C à partir de son SID, tapez :

fsutil file findbysid scottb C:\utilisat

Pour interroger les plages allouées d'un fichier sur un volume NTFS, tapez :

fsutil file queryallocranges offset=1024 length=64 C:\Temp\exemple.txt

Pour attribuer le nom court FichLong.txt au fichier NomFichierLong.txt présent sur le lecteur C, tapez :

fsutil file setshortname C:\NomFichierLong.txt FichLong.txt

Pour définir la longueur de données valides pour un fichier situé sur un volume NTFS, tapez :

fsutil file setvaliddata C:\FichTest.txt 4096

Pour attribuer des zéros à une plage d'un fichier situé sur un volume NTFS dans le but de vider le fichier, tapez :

fsutil file setzerodata offset=100 length=150 C:\Temp\Exemple.txt


Fsutil: fsinfo

Généralement utilisé par les personnels de support technique. Affiche la liste de tous les lecteurs, fournit des informations sur le type de lecteur, le volume, les spécificités liées aux volumes NTFS ou les statistiques sur le système de fichiers.

Syntaxe

fsutil fsinfo [drives]

fsutil fsinfo [drivetype] Chemin

fsutil fsinfo [ntfsinfo] CheminRacine

fsutil fsinfo [statistics] CheminVolume

fsutil fsinfo [volumeinfo] CheminRacine

Paramètres

drives
Affiche tous les lecteurs de l'ordinateur.
drivetype
Interroge un lecteur et affiche son type, par exemple lecteur de CD-ROM.
ntfsinfo
Affiche des informations spécifiques à NTFS concernant le volume spécifié, par exemple le nombre de secteurs, le nombre total de clusters, les clusters libres, ainsi que le début et la fin de la zone MFT.
statistics
Affiche des statistiques sur le système de fichiers concernant le volume spécifié, par exemple les métadonnées, le fichier journal ou les lectures et écritures MFT.
volumeinfo
Affiche des informations sur le volume spécifié, par exemple le système de fichiers ainsi que la prise en charge ou non par le volume des noms de fichiers respectant la casse, des caractères Unicode dans les noms de fichiers ou des quotas de disque.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
CheminRacine
Spécifie la lettre de lecteur (suivie d'un signe deux-points) du lecteur racine.
CheminVolume
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.

Exemples

Pour déterminer le type du lecteur C, tapez :

fsutil fsinfo drivetype C:

Résultats possibles :

  • Lecteur inconnu
  • Ce répertoire racine n'existe pas
  • Lecteur amovible, par exemple une disquette
  • Lecteur fixe
  • Lecteur réseau ou à distance
  • Lecteur de CD-ROM
  • Disque virtuel

Pour obtenir les informations relatives au volume E, tapez :

fsinfo volumeinfo E:\

Exemple de sortie :

Nom du volume :
Numéro de série du volume : 0xd0b634d9
Longueur maximale du composant : 255
Nom du système de fichiers : NTFS
Prend en charge les noms de fichiers respectant la casse
Préserve la casse des noms de fichiers
Prend en charge Unicode dans les noms de fichiers
Préserve et Applique les ACL
Prend en charge la compression de fichier
Prend en charge les quotas de disque
Prend en charge les fichiers fragmentés
Prend en charge les points d'analyse
Prend en charge les identificateurs d'objets
Prend en charge le système de fichiers cryptés
Prend en charge les flux nommés

Pour interroger le lecteur F et obtenir des informations spécifiques à NTFS, tapez :

fsutil fsinfo ntfsinfo F:\

Exemple de sortie :

NTFS Volume Serial Number : 0xe660d46a60d442cb
Number Sectors : 0x00000000010ea04f
Total Clusters : 0x000000000021d409
Free Clusters : 0x00000000000f222a
Total Reserved : 0x0000000000003550
Bytes Per Sector : 512
Bytes Per Cluster : 4096
Bytes Per FileRecord Segment : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length : 0x0000000003eab000
Mft Start Lcn : 0x0000000000000004
Mft2 Start Lcn : 0x000000000010ea04
Mft Zone Start : 0x0000000000003ea0
Mft Zone End : 0x0000000000004700

Pour interroger le lecteur E et obtenir des statistiques relatives au système de fichiers, tapez :

fsinfo statistics E:

Exemple de sortie :

File System Type : NTFS
Version : 1
UserFileReads : 75021
UserFileReadBytes : 1305244512
UserDiskReads : 71213
UserFileWrites : 8037
UserFileWriteBytes : 207685440
UserDiskWrites : 5278
MetaDataReads : 14377
MetaDataReadBytes : 58888192
MetaDataDiskReads : 14773
MetaDataWrites : 18705
MetaDataWriteBytes : 138108928
MetaDataDiskWrites : 21464

MftReads : 9394
MftReadBytes : 38477824
MftWrites : 17061
MftWriteBytes : 115359744
Mft2Writes : 0
Mft2WriteBytes : 0
RootIndexReads : 0
RootIndexReadBytes : 0
RootIndexWrites : 0
RootIndexWriteBytes : 0
BitmapReads : 136
BitmapReadBytes : 557056
BitmapWrites : 1180
BitmapWriteBytes : 11161600
MftBitmapReads : 4
MftBitmapReadBytes : 16384
MftBitmapWrites : 118
MftBitmapWriteBytes : 491520
UserIndexReads : 2938
UserIndexReadBytes : 12034048
UserIndexWrites : 2738
UserIndexWriteBytes : 20615168
LogFileReads : 4
LogFileReadBytes : 16384
LogFileWrites : 8407
LogFileWriteBytes : 180936704


Fsutil: hardlink

Un lien réel est une entrée de répertoire pour un fichier. Vous pouvez considérer que chaque fichier possède au moins un lien réel. Sur les volumes NTFS, chaque fichier peut posséder plusieurs liens réels, par conséquent, un fichier unique peut apparaître dans de nombreux répertoires (voire dans un même répertoire sous des noms différents). Étant donné que tous les liens font référence au même fichier, les applications peuvent ouvrir n'importe quel lien et modifier le fichier. Un fichier n'est supprimé dans le système de fichiers qu'à partir du moment où tous ses liens ont été supprimés. Après avoir créé un lien réel, les programmes peuvent l'utiliser comme n'importe quel nom de fichier.

Syntaxe

fsutil hardlink create NouveauNomFichier NomFichierExistant

Paramètres

create
Établit un lien réel NTFS entre un fichier existant et un nouveau fichier. Un lien réel NTFS est semblable à un lien réel POSIX.
NouveauNomFichier
Spécifie le fichier vers lequel vous souhaitez créer un lien réel.
NomFichierExistant
Spécifie le fichier à partir duquel vous souhaitez créer un lien réel.


Fsutil: objectid

Généralement utilisé par les personnels de support technique. Gère les identificateurs d'objets (également appelés OID), qui sont des objets internes utilisés par le service Client de suivi de lien distribué (DLT) et le service de réplication de fichiers (FRS) pour effectuer le suivi d'autres objets tels que les fichiers, répertoires et liens. Les identificateurs d'objets sont invisibles pour la plupart des programmes et ne doivent jamais être modifiés.

Avertissement

  • Vous ne devez pas supprimer, définir ou modifier de quelque manière que ce soit un identificateur d'objet. La suppression ou la définition d'un identificateur d'objet peut entraîner la perte de données de quelques portions d'un fichier ou de volumes entiers de données. En outre, vous risquez d'endommager sérieusement le service Client de suivi de lien distribué (DLT) et le service de réplication de fichiers (FRS).

Syntaxe

fsutil objectid [create] Chemin

fsutil objectid [delete] Chemin

fsutil objectid [query] Chemin

fsutil objectid [set] IDObjet IDVolumeParent IDObjetParent IDDomaine Chemin

Paramètres

create
Crée un identificateur d'objet si le fichier n'en possède pas déjà ; est équivalent à query.
delete
Supprime un identificateur d'objet.
query
Interroge un identificateur d'objet.
set
Définit un identificateur d'objet.
IDObjet
Identificateur hexadécimal de fichier de 16 octets, qui offre la garantie d'être unique sur un volume. Il est utilisé par le service Client de suivi de lien distribué (DLT) et le service de réplication de fichiers (FRS) pour identifier les fichiers. Tout fichier possédant un IDObjet possède également un IDVolumeParent, un IDObjetParent et un IDDomaine. Lorsque vous déplacez un fichier, l'IDObjet peut varier, mais l'IDVolumeParent et l'IDObjetParent restent les mêmes, ce qui permet à Windows XP de toujours retrouver un fichier, quel que soit son emplacement.
IDVolumeParent
Identificateur hexadécimal de 16 octets qui indique le volume où se trouvait le fichier lorsqu'il a obtenu un IDObjet pour la première fois. Cette valeur est utilisée par le service client DLT.
IDObjetParent
Identificateur hexadécimal de 16 octets qui indique l'IDObjet d'origine du fichier (remarquez que l'IDObjet peut varier lorsqu'un fichier est déplacé). Cette valeur est utilisée par le service client DLT.
IDDomaine
Identificateur de domaine hexadécimal de 16 octets. Cette valeur n'est pas utilisée actuellement et doit être définie à l'aide de zéros.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.

Exemples

Pour créer un identificateur d'objet, tapez :

fsutil objectid create C:\Temp\Exemple.txt

Pour supprimer un identificateur d'objet, tapez :

fsutil objectid delete C:\Temp\Exemple.txt

Pour interroger un identificateur d'objet, tapez :

fsutil objectid get C:\Temp\Exemple.txt

Pour définir un identificateur d'objet, tapez :

fsutil objectid set 40dff02fc9b4d4118f120090273fa9fc f86ad6865fe8d21183910008c709d19e 40dff02fc9b4d4118f120090273fa9fc 00000000000000000000000000000000 C:\Temp\Exemple.txt


Fsutil: quota

Gère les quotas de disque sur les volumes NTFS pour pouvoir offrir un contrôle plus précis du stockage réseau.

Syntaxe

fsutil quota [disable] NomVolume

fsutil quota [enforce] NomVolume

fsutil quota [modify] NomVolume Seuil Limite [NomUtilisateur]

fsutil quota [query] NomVolume

fsutil quota [track] NomVolume

fsutil quota [violations]

Paramètres

désactiver
Désactive le suivi des quotas et leur application sur le volume spécifié.
enforce
Applique les quotas sur le volume spécifié.
modify
Modifie un quota de disque existant ou crée un quota.
query
Affiche la liste des quotas de disque existants.
track
Effectue le suivi de l'utilisation du disque sur le volume spécifié.
violations
Effectue une recherche dans le journal système et le journal Applications, puis affiche un message indiquant que des violations de quotas ont été détectées, ou qu'un utilisateur a atteint son quota.
NomVolume
Spécifie la lettre de lecteur du volume (suivie du signe des deux-points).
Seuil
Limite à partir de laquelle les avertissements sont émis.
Limite
Limite d'utilisation maximale autorisée sur le disque.
NomUtilisateur
Spécifie le domaine ou le nom d'utilisateur.

Remarques

  • Les quotas de disque sont implémentés pour chaque volume et permettent d'établir des limites de stockage aussi bien matérielles que logicielles pour chaque utilisateur.
  • Vous pouvez utiliser des scripts d'écriture qui définissent des quotas à l'aide de fsutil quota chaque fois qu'un nouvel utilisateur est ajouté, ou qui effectuent automatiquement le suivi des quotas, les compilent dans un rapport et les envoient à l'administrateur système par courrier électronique.


Fsutil: reparsepoint

Généralement utilisé par les personnels de support technique. Interroge ou supprime des points d'analyse, autrement dit des objets du système de fichiers NTFS qui possèdent un attribut définissable contenant des données contrôlées par l'utilisateur, et qui permettent d'étendre les fonctionnalités du sous-système d'entrée/sortie (E/S). Les points d'analyse sont utilisés comme points de jonction de répertoires et comme points de montage de volumes. Ils sont également utilisés par les pilotes de filtre du système de fichiers pour marquer certains fichiers propres à ce pilote.

Syntaxe

fsutil reparsepoint [query] Chemin

fsutil reparsepoint [delete] Chemin

Paramètres

query
Extrait les données de point d'analyse associées au fichier ou au répertoire identifié par le handle spécifié.
delete
Supprime un point d'analyse du fichier ou du répertoire identifié par le handle spécifié, mais ne supprime pas ce fichier ou ce répertoire.

Avertissement

  • fsutil reparsepoint delete ne supprime que le fichier, pas ses points d'analyse. Ceci peut entraîner des problèmes d'ouverture de fichier dans les processus ou les services qui tentent cette opération.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.

Remarques

  • Sur un volume NTFS, un fichier ou un répertoire peut contenir un point d'analyse, lequel représente un ensemble de données définies par l'utilisateur. Le format de ces données est compréhensible par le programme chargé de les stocker, ainsi que par un filtre de système de fichiers, que vous installez pour l'interprétation des données et le traitement du fichier. Lorsqu'un programme définit un point d'analyse, il stocke les données correspondantes, ainsi qu'une balise d'analyse, qui identifie de manière unique les données stockées. Lorsque le système de fichiers ouvre un fichier contenant un point d'analyse, il essaie de trouver le filtre de système de fichiers associé au format de données identifié par la balise d'analyse. Si le filtre de système de fichiers est trouvé, celui-ci traite le fichier en fonction des données d'analyse. En l'absence de filtre de système de fichiers, l'opération d'ouverture du fichier échoue.

    Par exemple, les points d'analyse permettent d'implémenter les liens NTFS et le stockage étendu. Le stockage étendu utilise un ensemble de règles définies par l'administrateur pour déplacer les fichiers peu utilisés vers des périphériques de stockage à long terme, tels que des bandes ou des CD-ROM. Il utilise les points d'analyse pour stocker les informations relatives au fichier présent dans le système de fichiers. Ces informations sont stockées dans un fichier stub contenant un point d'analyse dont les données pointent vers le périphérique où se trouve le fichier effectif. Le filtre de système de fichiers peut utiliser ces informations pour extraire le fichier.

Exemples

Pour extraire les données de point d'analyse associées à C:\Serveur, tapez :

fsutil reparsepoint query C:\Serveur

Pour supprimer un point d'analyse du fichier ou répertoire spécifié, utilisez le format suivant :

fsutil reparsepoint delete C:\Serveur


Fsutil: sparse

Gère les fichiers fragmentés. Un fichier fragmenté est un fichier dont une ou plusieurs zones contiennent des données non allouées. Une application récupérera ces zones non allouées qui contiennent des octets possédant des valeurs nulles, mais aucun espace disque n'est effectivement utilisé pour représenter ces valeurs nulles. Autrement dit, toutes les données non nulles ou significatives sont allouées, alors que toutes les données non significatives (longues chaînes de données constituées de zéros) ne sont pas allouées. Lorsqu'un fichier fragmenté est lu, les données allouées sont renvoyées sous la forme de données stockées et les données non allouées sont renvoyées par défaut sous la forme de valeurs nulles conformément à la spécification d'exigence de sécurité C2. La prise en charge des fichiers fragmentés permet de supprimer l'allocation de données à n'importe quel emplacement du fichier.

Syntaxe

fsutil sparse [queryflag] Chemin

fsutil sparse [queryrange] Chemin

fsutil sparse [setflag] Chemin

fsutil sparse [setrange] Chemin OffsetDébut Longueur

Paramètres

queryflag
Identifie la fragmentation.
queryrange
Analyse un fichier à la recherche de plages pouvant contenir des données différentes de zéro.
setflag
Marque le fichier indiqué comme étant fragmenté.
setrange
Remplit la plage spécifiée à l'aide de zéros.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
OffsetDébut
Offset du fichier à marquer comme étant fragmenté.
Longueur
Longueur de la zone du fichier à marquer comme étant fragmentée, en octets.

Remarques

  • Dans un fichier fragmenté, les plages de zéros de grande taille ne nécessitent pas d'allocation de disque. L'espace réservé aux données différentes de zéro est alloué autant que nécessaire lors de l'écriture du fichier.
  • Seuls les fichiers compressés ou fragmentés peuvent posséder des plages de zéros identifiables par le système d'exploitation.
  • Si le fichier est fragmenté ou compressé, NTFS peut supprimer l'allocation d'espace disque dans le fichier. Cela permet d'attribuer des zéros à la plage d'octets sans étendre la taille du fichier.

Exemple

Pour marquer un fichier comme étant fragmenté, tapez :

fsutil sparse setflag C:\Temp\Exemple.txt


Fsutil: usn

Généralement utilisé par les personnels de support technique. Gère le journal de modification des numéros de séquence de mise à jour, qui fournit un enregistrement persistant de toutes les modifications apportées aux fichiers du volume. Au fur et à mesure que des fichiers, répertoires et autres objets NTFS sont ajoutés, supprimés et modifiés, NTFS entre un enregistrement dans le journal de modification USN pour chaque volume de l'ordinateur. Chaque enregistrement indique le type de modification et l'objet modifié. Les nouveaux enregistrements sont ajoutés à la fin du flux.

Les programmes peuvent consulter le journal de modification USN pour déterminer toutes les modifications apportées à un ensemble de fichiers. Le journal de modification USN est beaucoup plus efficace qu'une vérification des horodateurs ou l'inscription aux notifications des fichiers. Le journal de modification USN est activé et utilisé par le service d'indexation, le service de réplication de fichiers (FRS), le service d'installation à distance (RIS) et le stockage étendu.

Syntaxe

fsutil usn [createjournal] TailleMaximale DeltaAllocation CheminVolume

fsutil usn [deletejournal] indicateurs CheminVolume

fsutil usn [enumdata] RéfFichier UsnInférieur UsnSupérieur Chemin

fsutil usn [queryjournal] CheminVolume

fsutil usn [readdata] Chemin

Paramètres

createjournal
Crée un journal de modification USN.
m=TailleMaximale
Spécifie la taille maximale, en octets, allouée par NTFS au journal de modification.
a=DeltaAllocation
Spécifie la taille, en octets, de l'allocation de mémoire ajoutée à la fin et supprimée au début du journal de modification.
CheminVolume
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
deletejournal
Supprime ou désactive un journal de modification USN actif.
indicateurs
/D: Désactive un journal de modification USN actif et renvoie un contrôle d'E/S pendant la désactivation du journal de modification.
/N: Désactive un journal de modification USN actif et renvoie un contrôle d'E/S uniquement après la désactivation du journal de modification.
CheminVolume
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
enumdata
Énumère et affiche la liste des entrées du journal de modification entre deux limites spécifiées.
RéfFichier
Position ordinale dans les fichiers du volume à laquelle l'énumération doit commencer.
UsnInférieur
Limite inférieure de la plage de valeurs USN utilisée pour filtrer les enregistrements renvoyés. Seuls les enregistrements dont l'USN du dernier journal de modification est compris entre les valeurs membres UsnInférieur et UsnSupérieur sont renvoyés.
UsnSupérieur
Limite supérieure de la plage de valeurs USN utilisée pour filtrer les fichiers renvoyés.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
queryjournal
Interroge les données USN d'un volume pour rassembler des informations sur le journal de modification en cours, ses enregistrements et sa capacité.
CheminVolume
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.
readdata
Lit les données USN d'un fichier.
Chemin
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.

Remarques

  • Utilisation de createjournal

    Si un journal de modification existe déjà sur un volume, le paramètre createjournal met à jour les paramètres TailleMaximale et DeltaAllocation du journal de modification. Cela vous permet d'étendre le nombre d'enregistrements gérés par un journal actif sans devoir le désactiver. Si vous spécifiez zéro pour TailleMaximale et DeltaAllocation, le système choisit une valeur par défaut basée sur la taille du volume.

  • Utilisation de m=TailleMaximale

    La taille du journal de modification peut s'accroître au-delà de cette valeur cible, mais le journal de modification est tronqué au prochain point de contrôle NTFS à une valeur inférieure. NTFS examine le journal de modification et le réduit lorsque sa taille dépasse la valeur de TailleMaximale ajoutée à la valeur de DeltaAllocation. Aux points de contrôle NTFS, le système d'exploitation écrit des enregistrements dans le fichier journal NTFS qui permettent à NTFS de déterminer le traitement nécessaire lors de la récupération d'une défaillance.

  • Utilisation de a=DeltaAllocation

    La taille du journal de modification peut s'accroître au-delà de la somme des valeurs de TailleMaximale et DeltaAllocation avant d'être réduite.

  • Utilisation de deletejournal

    La suppression ou la désactivation d'un journal actif est souvent une opération fastidieuse, car le système doit accéder à tous les enregistrements de la ta ble de fichiers maîtres (MFT) et attribuer la valeur zéro au dernier attribut USN. Ce processus peut durer plusieurs minutes et se poursuivre après le redémarrage du système, si nécessaire. Durant ce processus, le journal de modification n'est pas considéré comme étant actif, ni comme étant désactivé. Pendant que le système désactive le journal, son accès est impossible ; par conséquent, toutes les opérations du journal renvoient des erreurs. Vous devez faire preuve de prudence lorsque vous désactivez un journal actif, car cette opération affecte négativement les autres applications qui utilisent le journal.

Exemples

Pour créer un journal de modification USN sur le lecteur C, tapez :

fsutil usn createjournal m=1000 a=100 C:

Pour supprimer un journal de modification USN actif sur le lecteur C, tapez :

fsutil usn deletejournal /D C:

Pour énumérer et afficher la liste des entrées du journal de modification entre deux limites spécifiées sur le lecteur C, tapez :

fsutil usn enumdata 1 0 1 C:

Pour interroger les données USN d'un volume sur le lecteur C, tapez :

fsutil usn queryjournal C:

Pour lire les données USN d'un fichier dans le dossier temporaire du lecteur C, tapez :

fsutil usn readdata C:\Temp\exemple.txt


Fsutil: volume

Gère un volume. Démonte un volume ou envoie une requête pour voir le montant d'espace disque disponible.

Syntaxe

fsutil volume [diskfree] NomLecteur

fsutil volume [dismount] CheminVolume

Paramètres

diskfree
Détermine l'espace disponible d'un volume.
NomLecteur
Spécifie la lettre de lecteur (suivie d'un signe deux-points).
démonter
Démonte un volume.
CheminVolume
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume.

Exemples

  • Pour démonter un volume sur le lecteur C, tapez :

    • fsutil volume dismount C:

  • Pour déterminer l'espace disponible d'un volume sur le lecteur C, tapez :

    • fsutil volume diskfree C:


Ftp

Transfère des fichiers vers et depuis un ordinateur exécutant un service de serveur FTP (File Transfer Protocol) comme les Services Internet (IIS, Internet Information Services). La commande Ftp peut être utilisée de façon interactive ou en mode par lot en traitant des fichiers texte ASCII.

Syntaxe

ftp [-v] [-d] [-i] [-n] [-g] [-s:NomFichier] [-a] [-w:TailleTampon] [-A] [Hôte]

Paramètres

-v
Supprime l'affichage des réponses du serveur FTP.
-d
Active le débogage (affichage de toutes les commandes transmises entre le client FTP et le serveur FTP).
-i
Désactive les messages interactifs lors des transferts de plusieurs fichiers.
-n
Supprime la possibilité d'ouvrir automatiquement une session quand la connexion initiale est établie.
-g
Désactive l'utilisation des caractères génériques dans les noms de fichier. La commande Glob permet l'utilisation de l'astérisque (*) et du point d'interrogation (?) comme caractères génériques dans les noms de fichiers et les chemins d'accès locaux. Pour plus d'informations, voir Ftp: Glob.
-s:NomFichier
Spécifie un fichier texte qui contient des commandes ftp. Ces commandes s'exécutent automatiquement après le démarrage de ftp. Ce paramètre n'autorise pas l'utilisation des espaces. Utilisez ce paramètre au lieu du signe de redirection (<).
-a
Spécifie que toutes les interfaces locales peuvent être utilisées à l'établissement de la connexion aux données FTP.
-w:TailleTampon
Spécifie la taille du tampon de transfert. La taille par défaut de ce tampon est 4 096 octets.
-A
Ouvre une session sur le serveur FTP comme utilisateur anonyme.
Hôte
Spécifie le nom d'ordinateur, l'adresse IP ou l'adresse IPv6 du serveur FTP auquel il faut se connecter. L'adresse ou le nom de l'hôte, s'ils sont spécifiés, doit figurer comme dernier paramètre de la ligne.
/?
Affiche l'aide à l'invite de commande.

Remarques

  • Vous devez préfixer les paramètres de ftp avec un trait d'union (-) au lieu d'une barre oblique (/).
  • Les paramètres de la commande en ligne Ftp respectent les majuscules et les minuscules.
  • Cette commande est disponible seulement si le Internet Protocol (TCP/IP) est installé comme composant dans les propriétés d'une carte réseau dans Connexions réseau.
  • La commande Ftp peut être utilisée de manière interactive. Après avoir démarré, ftp crée un sous-environnement où vous pouvez utiliser les commandes ftp. Vous pouvez revenir à l'invite de commande en tapant la commande quit. Le fait que le sous-environnement ftp est en cours d'exécution est indiqué par l'invite de commande ftp >.
  • Pour plus d'informations sur les sous-commandes ftp, voir les Rubriques connexes.
  • Ftp prend en charge l'utilisation de IPv6 quand le protocole IPv6 est installé. Pour plus d'informations, voir IP version 6 et Applications IPv6.

Exemples

Pour vous connecter au serveur FTP ftp.exemple.microsoft.com, tapez la commande suivante :

ftp ftp.exemple.microsoft.com

Pour vous connecter anonymement au serveur FTP ftp.exemple.microsoft.com, tapez la commande suivante :

ftp -A ftp.exemple.microsoft.com

Pour vous connecter au serveur FTP ftp.exemple.microsoft.com et exécuter les commandes ftp contenues dans un fichier appelé Resynch.txt, tapez la commande suivante :

ftp -s:resynch.txt ftp.exemple.microsoft.com


Ftp : append

Ajoute un fichier local à la suite d'un fichier sur l'ordinateur distant avec le mode de transfert de fichier en cours.

Syntaxe

append FichierLocal [Fichier Distant]

Paramètres

FichierLocal
Spécifie le fichier local à ajouter.
FichierDistant
Spécifie le fichier de l'ordinateur distant auquel le FichierLocal doit être ajouté.
? append
Affiche l'aide de la commande append.

Remarques

  • Si FichierDistant n'est pas indiqué, le nom du FichierLocal est utilisé à la place du nom du fichier distant.


Ftp : ascii

Définit le mode de transfert de fichier à ASCII.

Syntaxe

ascii

Paramètres

? ascii
Affiche l'aide de la commande ascii.

Remarques

  • Le mode de transfert de fichier est ASCII par défaut.
  • En mode ASCII, les conversions de caractères de et vers le jeu de caractères standard du réseau sont effectuées. Par exemple, les caractères de fin de ligne sont convertis en fonction du système d'exploitation cible.
  • Ftp prend en charge deux modes de transfert de fichiers : ASCII et image binaire. Vous devez utiliser le mode ASCII quand vous transférez des fichiers texte. Pour plus d'informations sur le mode de transfert de fichier binaire, voir Ftp : binary dans les rubriques connexes.


Ftp : !

Permet de sortir temporairement du sous-système ftp pour une invite de commande, de façon à permettre l'exécution de commandes Windows XP. Pour revenir au sous-système ftp, tapez exit à l'invite de commande.

Syntaxe

!

Paramètres

? !
Affiche l'aide de la commande !.

Remarques

  • Utilisez ! pour exécuter des commandes Windows XP sans quitter ftp.


Ftp : bell

Génère une indication sonore à l'issue de chaque commande de transfert de fichiers.

Syntaxe

bell

Paramètres

? bell
Affiche l'aide de la commande bell.

Remarques

  • Par défaut, bell est désactivée.


Ftp : binary

Définit le mode de transfert de fichier à binaire.

Syntaxe

binary

Paramètres

? binary
Affiche l'aide de la commande binary.

Remarques

  • Ftp prend en charge deux modes de transfert de fichiers : ASCII et image binaire. Vous devez utiliser le mode binaire quand vous transférez des fichiers exécutables. En mode binaire, le fichier sont transférés par unités d'un octet. Pour plus d'informations sur les transferts de fichier en mode ASCII, voir Ftp : Ascii dans les rubriques connexes.


Ftp : bye

Ferme la session FTP avec l'ordinateur distant et quitte ftp.

Syntaxe

bye

Paramètres

? bye
Affiche l'aide en ligne de la commande bye.


Ftp : cd

Change le répertoire de travail sur l'ordinateur distant.

Syntaxe

cd RépertoireDistant

Paramètres

RépertoireDistant
Spécifie le nouveau répertoire de travail sur l'ordinateur distant.
? cd
Affiche l'aide de la commande cd.


Ftp : close

Ferme la session FTP avec le serveur distant et reste à l'invite ftp>.

Syntaxe

close

Paramètres

? close
Affiche l'aide de la commande close.


Ftp : debug

Active ou désactive le débogage.

Syntaxe

debug

Paramètres

? debug
Affiche l'aide de la commande debug.

Remarques

  • Par défaut, le débogage est désactivé.
  • Lorsque le débogage est activé, chaque commande transmise à l'ordinateur distant est affichée, précédée du caractère « plus grand que » (>).


Ftp : delete

Supprime des fichiers sur des ordinateurs distants.

Syntaxe

delete FichierDistant

Paramètres

FichierDistant
Spécifie le fichier à supprimer.
? delete
Affiche l'aide de la commande delete.


Ftp : dir

Affiche une liste des fichiers et des sous-répertoires d'un répertoire sur un ordinateur distant.

Syntaxe

dir [RépertoireDistant] [FichierLocal]

Paramètres

RépertoireDistant
Spécifie le répertoire dont vous voulez voir la liste du contenu. Si aucun répertoire n'est spécifié, le répertoire de travail en cours de l'ordinateur distant est utilisé.
FichierLocal
Spécifie le fichier local dans lequel la liste sera placée. Si aucun fichier local n'est spécifié, les résultats apparaissent à l'écran.
? dir
Affiche l'aide de la commande dir.


Ftp : disconnect

Déconnecte l'ordinateur distant et maintient l'invite ftp>.

Syntaxe

disconnect

Paramètres

? disconnect
Affiche l'aide de la commande disconnect.


Ftp : get

Copie un fichier distant sur l'ordinateur local en utilisant le mode de transfert de fichiers en cours.

Syntaxe

get FichierDistant [FichierLocal]

Paramètres

FichierDistant
Spécifie le fichier distant à copier.
FichierLocal
Spécifie le nom de fichier à utiliser sur l'ordinateur local.
? get
Affiche l'aide de la commande get.

Remarques

  • Si FichierLocal n'est pas spécifié, le fichier reçoit le nom FichierDistant.
  • La commande get est identique à la commande recv.


Ftp : glob

Active ou désactive l'utilisation de caractères génériques pour les noms de fichiers locaux.

Syntaxe

glob

Paramètres

? glob
Affiche l'aide de la commande glob.

Remarques

  • Par défaut, l'utilisation de caractères génériques est activée.
  • L'activation de cette commande permet l'utilisation de l'astérisque (*) et du point d'interrogation (?) comme caractères génériques dans les noms de fichiers et les chemins d'accès locaux.


Ftp : hash

Active ou désactive l'impression du signe # pour chaque bloc de données transféré.

Syntaxe

hash

Paramètres

? hash
Affiche l'aide de la commande hash.

Remarques

  • La taille de chaque bloc de données est de 2 048 octets.
  • Par défaut, la commande hash est désactivée.


Ftp : help

Affiche les descriptions des sous-commandes ftp.

Syntaxe

help [Commande]

? [Commande]

Paramètres

Commande
Spécifie le nom de la commande dont vous voulez la description. Si le paramètre Commande n'est pas spécifié, une liste de toutes les commandes est affichée.


Ftp : lcd

Change le répertoire de travail sur l'ordinateur local. Par défaut, le répertoire de travail est celui dans lequel ftp est lancé.

Syntaxe

lcd [Répertoire]

Paramètres

Répertoire
Spécifie le nouveau répertoire de travail sur l'ordinateur local. Si le paramètre Répertoire n'est pas spécifié, c'est le répertoire de travail en cours de l'ordinateur local qui est affiché.
? lcd
Affiche l'aide de la commande lcd
.


Ftp : literal

Envoie des arguments mot pour mot au serveur FTP distant. Un seul code de réponse FTP est renvoyé.

Syntaxe

literal Argument [ ...]

Paramètres

Argument
Spécifie l'argument à transmettre au serveur FTP.
? literal
Affiche l'aide de la commande literal.


Ftp : ls

Affiche une liste abrégée des fichiers et des sous-répertoires d'un répertoire distant.

Syntaxe

ls [RépertoireDistant] [FichierLocal]

Paramètres

RépertoireDistant
Spécifie le répertoire dont vous souhaitez afficher le contenu. Si aucun répertoire n'est spécifié, le répertoire de travail en cours de l'ordinateur distant est utilisé.
FichierLocal
Spécifie un fichier local dans lequel la liste sera placée. Si aucun fichier local n'est spécifié, les résultats apparaissent à l'écran.
? ls
Affiche l'aide de la commande ls.


Ftp : mdelete

Supprime des fichiers sur des ordinateurs distants.

Syntaxe

mdelete FichiersDistants [ ...]

Paramètres

FichiersDistants
Spécifie les fichiers distants à supprimer.
? mdelete
Affiche l'aide de la commande mdelete.


Ftp : mdir

Affiche une liste des fichiers et des sous-répertoires d'un répertoire distant.

Syntaxe

mdir FichiersDistants [ ...] FichierLocal

Paramètres

FichiersDistants
Spécifie le répertoire dont vous souhaitez voir le contenu.
FichierLocal
Spécifie le fichier local dans lequel la liste sera placée.
? mdir
Affiche l'aide de la commande mdir.

Remarques

  • Vous pouvez utiliser mdir pour désigner plusieurs fichiers.
  • Spécification de FichiersDistants

    Tapez un trait d'union (-) pour utiliser le répertoire de travail en cours sur l'ordinateur distant.

  • Spécification d'un FichierLocal

    Tapez un trait d'union (-) pour afficher la liste à l'écran.


Ftp : mget

Copie des fichiers distants sur l'ordinateur local en utilisant le mode de transfert de fichiers en cours.

Syntaxe

mget FichiersDistants [ ...]

Paramètres

FichiersDistants
Spécifie les fichiers distants à copier sur l'ordinateur local.
? mget
Affiche l'aide de la commande mget.


Ftp : mkdir

Crée un répertoire sur l'ordinateur distant.

Syntaxe

mkdir Répertoire

Paramètres

Répertoire
Spécifie le nom du nouveau répertoire distant.
? mkdir
Affiche l'aide de la commande mkdir.


Ftp : mls

Affiche une liste abrégée des fichiers et des sous-répertoires d'un répertoire distant.

Syntaxe

mls FichiersDistants [ ...] FichierLocal

Paramètres

FichiersDistants
Spécifie les fichiers dont vous souhaitez afficher la liste.
FichierLocal
Spécifie le fichier local dans lequel la liste sera placée.
? mls
Affiche l'aide de la commande mls.

Remarques

  • Spécification des FichiersDistants

    Tapez un trait d'union (-) pour utiliser le répertoire de travail en cours sur l'ordinateur distant.

  • Spécification d'un FichierLocal

    Tapez un trait d'union (-) pour afficher la liste à l'écran.


Ftp : mput

Copie des fichiers locaux sur l'ordinateur distant en utilisant le mode de transfert de fichiers en cours.

Syntaxe

mput FichiersLocaux [ ...]

Paramètres

FichiersLocaux
Spécifie les fichiers locaux à copier sur l'ordinateur distant.
? mput
Affiche l'aide de la commande mput.


Ftp : open

Se connecte au serveur FTP spécifié.

Syntaxe

open Ordinateur [Port]

Paramètres

Ordinateur
Requis. Spécifie l'ordinateur distant auquel vous voulez vous connecter.
Port
Spécifie un numéro de port TCP à utiliser pour contacter un serveur FTP. Par défaut, c'est le port TCP 21 qui est utilisé.
? open
Affiche l'aide de la commande open.

Remarques

  • Vous pouvez utiliser une adresse IP ou un nom d'ordinateur (auquel cas un serveur DNS ou un fichier Hosts doit être disponible) pour spécifier Ordinateur. Si la connexion automatique est activée, ftp essaie de connecter automatiquement l'utilisateur au serveur FTP. Pour plus d'informations sur la désactivation de la connexion automatique avec ftp, voir les rubriques connexes.


Ftp : prompt

Active ou désactive le mode prompt.

Syntaxe

prompt

Paramètres

? prompt
Affiche l'aide de la commande prompt.

Remarques

  • Par défaut, le mode prompt est activé.
  • Ftp affiche des invites lors des transferts portant sur plusieurs fichiers pour vous permettre d'extraire ou de stocker sélectivement des fichiers. Mget et mput transfèrent tous les fichiers si invite est désactivé.


Ftp : put

Copie un fichier local sur l'ordinateur distant en utilisant le mode de transfert de fichiers en cours.

Syntaxe

put FichierLocal [FichierDistant]

Paramètres

FichierLocal
Spécifie le fichier local à copier.
FichierDistant
Spécifie le nom à utiliser sur l'ordinateur distant.
? put
Affiche l'aide de la commande put.

Remarques

  • Si FichierDistant n'est pas spécifié, le fichier reçoit le nom FichierLocal.


Ftp : pwd

Imprime le répertoire en cours sur l'ordinateur distant.

Syntaxe

pwd

Paramètres

? pwd
Affiche l'aide de la commande pwd.


Ftp : quit

Ferme la session FTP avec l'ordinateur distant et quitte ftp pour l'invite de commande.

Syntaxe

quit

Paramètres

? quit
Affiche l'aide de la commande quit.


Ftp : quote

Envoie des arguments mot pour mot au serveur FTP distant. Un seul code de réponse FTP est renvoyé.

Syntaxe

quote Argument [ ...]

Paramètres

Argument
Spécifie l'argument à transmettre au serveur FTP.
? quote
Affiche l'aide de la commande quote.

Remarques

  • La commande quote est identique à la commande literal.


Ftp : recv

Copie un fichier distant sur l'ordinateur local en utilisant le mode de transfert de fichiers en cours.

Syntaxe

recv FichierDistant [FichierLocal]

Paramètres

FichierDistant
Spécifie le fichier distant à copier.
FichierLocal
Spécifie le nom à utiliser sur l'ordinateur local.
? recv
Affiche l'aide de la commande recv.

Remarques

  • La commande recv est identique à la commande get.
  • Si FichierLocal n'est pas spécifié, le fichier reçoit le nom FichierDistant.


Ftp : remotehelp

Affiche l'aide pour des commandes distantes.

Syntaxe

remotehelp [Commande]

Paramètres

Commande
Spécifie le nom de la commande sur laquelle vous voulez de l'aide. Si le paramètre commande n'est pas spécifié, ftp affiche une liste de toutes les commandes distantes.
? remotehelp
Affiche l'aide de la commande remotehelp.


Ftp : rename

Renomme des fichiers distants.

Syntaxe

rename NomFichier NouveauNomFichier

Paramètres

NomFichier
Spécifie le fichier à renommer.
NouveauNomFichier
Spécifie le nouveau nom de fichier.
? rename
Affiche l'aide de la commande rename.


Ftp : rmdir

Supprime un répertoire distant.

Syntaxe

rmdir Répertoire

Paramètres

Répertoire
Spécifie le nom du répertoire distant à supprimer.
? rmdir
Affiche l'aide de la commande rmdir.


Ftp : send

Copie un fichier local sur l'ordinateur distant en utilisant le mode de transfert de fichiers en cours.

Syntaxe

send FichierLocal [FichierDistant]

Paramètres

FichierLocal
Spécifie le fichier local à copier.
FichierDistant
Spécifie le nom à utiliser sur l'ordinateur distant.
? send
Affiche l'aide de la commande send.

Remarques

  • La commande send est identique à la commande put.
  • Si FichierDistant n'est pas spécifié, le fichier reçoit le nom FichierLocal.


Ftp : status

Affiche l'état actuel des connexions FTP.

Syntaxe

status

Paramètres

? status
Affiche l'aide de la commande status.


Sous-commandes Ftp

Pour plus d'informations, cliquez sur une commande :

  • Ftp: !
  • Ftp: ?
  • Ftp: append
  • Ftp: ascii
  • Ftp: bell
  • Ftp: binary
  • Ftp: Bye
  • Ftp: cd
  • Ftp: close
  • Ftp: debug
  • Ftp: delete
  • Ftp: dir
  • Ftp: disconnect
  • Ftp: get
  • Ftp: glob
  • Ftp: hash
  • Ftp: help
  • Ftp: lcd
  • Ftp: literal
  • Ftp: ls
  • Ftp: mdelete
  • Ftp: mdir
  • Ftp: mget
  • Ftp: mkdir
  • Ftp: mls
  • Ftp: mput
  • Ftp: open
  • Ftp: prompt
  • Ftp: put
  • Ftp: pwd
  • Ftp: quit
  • Ftp: quote
  • Ftp: recv
  • Ftp: remotehelp
  • Ftp: rename
  • Ftp: rmdir
  • Ftp: send
  • Ftp: status
  • Ftp: trace
  • Ftp: type
  • Ftp: user
  • Ftp: verbose


Ftp : trace

Active ou désactive le suivi des paquets.

Syntaxe

trace

Paramètres

? trace
Affiche l'aide de la commande trace.

Remarques

  • Trace affiche la série d'appels aux fonctions FTP internes lors de l'exécution d'une commande ftp.


Ftp : type

Sélectionne ou affiche le mode de transfert de fichiers.

Syntaxe

type [NomType]

Paramètres

NomType
Spécifie le mode de transfert des fichiers.
? type
Affiche l'aide de la commande type.

Remarques

  • Si le paramètre NomType n'est pas spécifié, c'est le mode en cours qui est affiché.
  • Ftp prend en charge deux modes de transfert de fichiers : ASCII et binaire.

    Le mode de transfert par défaut est le mode ASCII. La commande ascii doit être utilisée lors du transfert de fichiers texte. En mode ASCII, les conversions de caractères de et vers le jeu de caractères standard du réseau sont effectuées. Par exemple, les caractères de fin de ligne sont convertis si nécessaire, en fonction du système d'exploitation cible.

    La commande binary doit être utilisée pour transférer des fichiers exécutables. En mode binaire, les fichiers sont transférés par unités d'un octet.


Ftp : user

Spécifie un utilisateur à l'ordinateur distant.

Syntaxe

user NomUtilisateur [MotDePasse] [Compte]

Paramètres

NomUtilisateur
Spécifie le nom d'utilisateur employé pour se connecter à l'ordinateur distant.
MotDePasse
Spécifie le mot de passe de l'utilisateur NomUtilisateur. Si un mot de passe n'est pas spécifié mais qu'il est requis, ftp demande d'entrer ce mot de passe.
Compte
Spécifie le compte à utiliser pour se connecter à l'ordinateur distant. Si un Compte n'est pas spécifié mais qu'il est requis, ftp demande d'entrer ce compte.
? user
Affiche l'aide de la commande user.


Ftp : verbose

Active ou désactive le mode verbose.

Syntaxe

verbose

v

Paramètres

? verbose
Affiche l'aide de la commande verbose.

Remarques

  • Par défaut, verbose est activé. Quand verbose est activé, les réponses de ftp sont affichées. Quand un transfert de fichiers est terminé, des statistiques sur l'efficacité du transfert sont également affichées.


Ftype

Affiche ou modifie les types des fichiers employés dans les associations d'extensions de fichiers. Utilisé sans paramètres, ftype affiche les types de fichiers possédant des chaînes de commandes d'ouverture définies.

Syntaxe

Ftype [TypeFichier[=[ChaîneCommandeOuverture]]]

Paramètres

TypeFichier
Spécifie le type de fichier que vous voulez afficher ou modifier.
ChaîneCommandeOuverture
Spécifie la commande d'ouverture à utiliser pour ouvrir les fichiers de ce type.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Dans ChaîneCommandeOuverture, ftype substitue les variables suivantes :
    • %0 ou %1 sont remplacées par le nom du fichier à ouvrir.
    • %* est remplacée par tous les paramètres.
    • %~n est remplacée par tous les paramètres restants, en commençant par le paramètre nième, où n correspond à n'importe quel nombre compris entre 2 et 9.
    • %2 est remplacée par le premier paramètre, %3 par le deuxième, etc.

Exemples

Pour afficher les types de fichiers actuels possédant des chaînes de commandes d'ouverture définies, tapez :

ftype

Pour afficher la chaîne de commande d'ouverture en cours pour un type de fichier spécifique, tapez :

ftype TypeFichier

Pour supprimer la chaîne de commande d'ouverture d'un type de fichier spécifique, tapez :

ftype TypeFichier=

Type :

ASSOC .pl=PerlScript FTYPE PerlScript=perl.exe %1 %*

Pour appeler le script Perl, tapez :

script.pl 1 2 3

Pour ne plus avoir à taper les extensions, tapez :

set PATHEXT=.pl;%PATHEXT%

Pour appeler le script Perl, tapez :

script 1 2 3 XOX


Getmac

Renvoie l'adresse de contrôle d'accès au média (MAC) et la liste des protocoles réseau associés à chaque adresse pour toutes les cartes réseau de chaque ordinateur, aussi bien localement que sur le réseau.

Syntaxe

getmac[.exe] [/s Ordinateur [/u Domaine\Utilisateur [/p MotDePasse]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur d'où provient la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/fo {TABLE|LIST|CSV}
Spécifie le format à utiliser pour la sortie de la requête. Les valeurs valides sont TABLE, LIST et CSV. Le format de sortie par défaut est TABLE.
/nh
Supprime l'en-tête de colonne dans la sortie. Valide lorsque le paramètre /fo est TABLE ou CSV.
/v
Spécifie que le résultat affiché doit comporter des informations détaillées.
/?
Affiche l'aide à l'invite de commandes.

Remarque

  • Getmac peut être utile pour entrer l'adresse MAC dans un analyseur de réseau ou pour déterminer les protocoles actuellement utilisés sur chaque carte réseau d'un ordinateur.

Exemples

Les exemples suivants montrent comment utiliser la commande getmac :

getmac /fo table /nh /v
getmac /s srvmain
getmac /s srvmain /u maindom\hiropln
getmac /s srvmain /u maindom\hiropln /p p@ssW23
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo list /v
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo table /nh


Goto

Dans un programme de commandes, renvoie Windows XP à une ligne identifiée par une étiquette. Lorsque l'étiquette est trouvée, les commandes commençant à la ligne suivante sont traitées.

Syntaxe

goto Étiquette

Paramètres

Étiquette
Spécifie la ligne du programme de commandes à laquelle vous souhaitez aller.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation d'extensions de commandes

    Si les extensions de commandes sont activées (option par défaut) et que vous utilisez la commande goto avec l'étiquette cible :EOF, vous transférez le contrôle à la fin du fichier de script de commandes en cours pour sortir du fichier sans définir d'étiquette. Lorsque vous utilisez goto avec l'étiquette :EOF, vous devez insérer le signe des deux-points devant l'étiquette. Exemple :

    goto :EOF

    Pour obtenir une description des extensions utiles à la commande call, consultez cmd dans les rubriques connexes.

  • Utilisation de valeurs d'étiquettes valides

    Vous pouvez utiliser des espaces dans le paramètre étiquette, mais vous ne pouvez pas inclure d'autres séparateurs (par exemple, le signe du point-virgule ou le signe égal). La commande goto n'utilise que les huit premiers caractères d'une étiquette. Par exemple, les étiquettes suivantes sont équivalentes à :hithere0:

    :hithere0

    :hithere01

    :hithere02

  • Correspondance entre le paramètre étiquette et l'étiquette figurant dans le programme de commandes

    La valeur étiquette que vous avez spécifiée doit correspondre à une étiquette présente dans le programme de commandes. L'étiquette présente dans le programme de commandes doit commencer par le signe des deux-points (:). Windows XP reconnaît que la ligne d'un programme de commandes commençant par le signe des deux-points (:) est une étiquette, par conséquent, il ne la traite pas comme une commande. Si une ligne commence par le signe des deux-points, toutes les commandes situées sur cette ligne sont ignorées. Si votre programme de commandes ne contient pas l'étiquette spécifiée, il s'arrête et affiche le message suivant :

    Étiquette introuvable

  • Utilisation de goto pour des opérations conditionnelles

    Vous pouvez utiliser goto avec d'autres commandes pour effectuer des opérations conditionnelles. Pour plus d'informations sur l'utilisation de goto pour des opérations conditionnelles, consultez if dans les rubriques connexes.

Exemples

Le programme de commandes suivant formate une disquette placée dans le lecteur A comme une disquette système. En cas de réussite de l'opération, la commande goto renvoie Windows XP à l'étiquette :end :

echo off
format a: /s
if not errorlevel 1 goto end
echo Une erreur s'est produite durant le formatage.
:end
echo Fin du programme de commandes.


Gpresult

Affiche les paramètres de stratégie de groupe et le jeu de stratégie résultant (RSOP) pour un utilisateur ou un ordinateur.

Syntaxe

gpresult [/s Ordinateur [/u Domaine\Utilisateur /p MotDePasse]] [/user NomUtilisateurCible] [/scope {user|computer}] [/v] [/z]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant. (N'utilisez pas de barres obliques inverses.) Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. L'autorisation par défaut est celle de l'utilisateur qui a actuellement ouvert une session sur l'ordinateur qui émet la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/user NomUtilisateurCible
Spécifie le nom de l'utilisateur dont les données RSOP doivent être affichées.
/scope {user|computer}
Affiche les résultats pour user ou computer. Les valeurs valides pour le paramètre /scope sont user ou computer. Si vous omettez le paramètre /scope, gpresult affiche les paramètres user et computer.
/v
Spécifie que le résultat affiché doit comporter des informations détaillées.
/z
Spécifie que le résultat affiché doit comporter toutes les informations disponibles sur la stratégie de groupe. Étant donné que ce paramètre produit davantage d'informations que le paramètre /v, redirigez le résultat vers un fichier texte (par exemple, gpresult /z >strategi.txt).
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • La stratégie de groupe constitue l'outil principal d'administration permettant de définir et de contrôler le comportement des programmes, des ressources réseau et du système d'exploitation vis-à-vis des utilisateurs et des ordinateurs, au sein d'une organisation. Dans un environnement Active Directory, la stratégie de groupe est appliquée aux utilisateurs ou aux ordinateurs en fonction de leur appartenance à des sites, à des domaines ou à des unités d'organisation.
  • Étant donné que vous pouvez appliquer des niveaux de stratégies superposés à un ordinateur ou un utilisateur, la fonctionnalité Stratégie de groupe génère un jeu de stratégie résultant lors de l'ouverture de session. Gpresult affiche le jeu de stratégie résultant appliqué à l'ordinateur pour l'utilisateur spécifié lors de l'ouverture de session.

Exemples

Les exemples suivants montrent comment utiliser la commande gpresult :

gpresult /user NomUtilisateurCible /scope computer
gpresult /s srvmain /u maindom\hiropln /p p@ssW23 /user NomUtilisateurCible /scope USER
gpresult /s srvmain /u maindom\hiropln /p p@ssW23 /user NomUtilisateurCible /z >strategi.txt
gpresult /s srvmain /u maindom\hiropln /p p@ssW23


Graftabl

Donne la possibilité d'afficher un jeu de caractères étendus en mode graphique.

Syntaxe

graftabl [xxx] [/status]

Paramètres

xxx
Indique la page de codes pour laquelle vous souhaitez définir la présentation des caractères étendus en mode graphique. Le tableau suivant affiche la liste des numéros d'identification de chaque page de codes valide ainsi que le pays/région ou la langue correspondante :
Valeur | Pays/région
437 | États-Unis
850 | Multilingue (Latin I)
852 | Slave (Latin II)
855 | Cyrillique (Russe)
857 | Turc
860 | Portugais
861 | Islandais
863 | Français (Canada)
865 | Nordique
866 | Russe
869 | Grec moderne
/status
Identifie la page de codes utilisée par graftabl.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour plus d'informations sur l'utilisation des pages de codes, consultez chcp ou mode (définition des pages de codes des périphériques) dans les rubriques connexes.
  • Graftabl ne change pas la page de codes en entrée de console. Graftabl n'affecte que l'affichage à l'écran des caractères étendus de la page de codes spécifiée. Pour utiliser une autre page de codes, employez la commande mode ou chcp.
  • Présentation des codes de sortie de graftabl

    Le tableau suivant affiche la liste de chacun des codes de sortie, accompagné d'une description sommaire.

    Code de sortie | Description
    0 | Le jeu de caractères a été correctement chargé. Aucune page de codes précédente n'a été chargée.
    1 | Un paramètre incorrect a été spécifié. Aucune action n'a été entreprise.
    2 | Une erreur fichier s'est produite.
  • Vous pouvez utiliser le paramètre errorlevel sur la ligne de commande if dans un programme de commandes pour traiter les codes de sortie renvoyés par graftabl.

Exemples

Pour charger en mémoire le jeu de caractères graphiques correspondant à la page de codes 437 (États-Unis), tapez :

graftabl 437

Pour charger en mémoire le jeu de caractères graphiques correspondant à la page de codes 850 (multilingue), tapez :

graftabl 850


Graphismes

Image Microsoft Windows

Graphics

XOX


Help

Fournit des informations en ligne sur les commandes système (en d'autres termes, les commandes qui ne sont pas associées au réseau). Utilisé sans paramètres, help répertorie et décrit brièvement toutes les commandes système.

Syntaxe

{help [Commande]|[Commande]/?}

Paramètres

Commande
Représente le nom de la commande sur laquelle vous voulez obtenir des informations.

Remarques

  • Pour obtenir de l'aide en ligne sur une commande particulière, vous disposez de deux méthodes. Vous pouvez taper help Commande ou Commande /?. /? est un petit peu plus rapide.
  • Pour plus d'informations sur les commandes réseau, cliquez sur net help dans les rubriques connexes.

Exemple

Pour consulter les informations relatives à la commande xcopy, tapez l'une des deux formulations suivantes :

help xcopy
xcopy /?


Helpctr

Démarre le centre d'Aide et de support. Utilisé sans paramètres, helpctr affiche la page d'accueil du centre d'Aide et de support.

Syntaxe

helpctr [/url [URL]] [/mode [URL]] [/hidden] [/fromstarthelp]

Paramètres

/url [URL]
Spécifie l'URL à afficher dans le centre d'Aide et de support.
/mode [URL]
Spécifie un fichier de définition XML compatible avec le schéma Launch_Description.dtd, qui contrôle le contexte, la mise en page et le contenu du centre d'Aide et de support.
/hidden
Démarre le centre d'Aide et de support sans afficher l'interface utilisateur. Cette commande peut charger une rubrique. Vous pouvez utiliser cette commande pour exécuter des scripts administrés à distance.
/fromstarthelp
Démarre une nouvelle instance du centre d'Aide et de support.
/?
Affiche l'aide à l'invite de commandes.

Remarque

  • Utilisation de URL

    Lorsque vous utilisez /url ou /mode, vous pouvez mettre des guillemets autour de URL (comme ceci : "URL"). Si un espace existe dans URL, remplacez-le par %20 (comme ceci : "URL%20 Adresse").

Exemple

Pour démarrer une session d'assistance à distance avec un fichier .msrincident, tapez :

HelpCtr /mode "hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/RAClientLayout.xml" /url "hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/Interaction/Client/rctoolScreen1.htm?IncidentFile=rahelp.msrincident"


Hostname

Affiche le nom d'hôte inclus dans le nom complet de l'ordinateur.

Syntaxe

hostname

Paramètres

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour plus d'informations sur la spécification du nom complet de l'ordinateur, consultez les rubriques connexes.
  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est installé comme composant dans les propriétés d'une carte réseau dans Connexions réseau.

Exemple

Pour afficher le nom de l'ordinateur, tapez :

hostname

XOX

Rubriques connexes


If

Assure le traitement conditionnel dans les programmes de commandes.

Syntaxe

if [not] errorlevel Nombre Commande [else Expression]

if [not] Chaîne1==Chaîne2 Commande [else Expression]

if [not] exist NomFichier Commande [else Expression]

Si les extensions de commandes sont activées, utilisez la syntaxe suivante :

if [/i] Chaîne1 OpComparaison Chaîne2 Commande [else Expression]

if cmdextversion Nombre Commande [else Expression]

if defined Variable Commande [else Expression]

Paramètres

not
Spécifie que la commande doit être exécutée uniquement si la condition est fausse.
errorlevel Nombre
Spécifie que la condition est vraie uniquement si le programme précédent exécuté par Cmd.exe a renvoyé un code de sortie égal ou supérieur à Nombre.
Commande
Spécifie la commande qui doit être exécutée si la condition précédente est remplie.
Chaîne1==Chaîne2
Ne reconnaît que la condition est vraie que si Chaîne1 et Chaîne2 sont identiques. Ces valeurs peuvent être des chaînes littérales ou des variables de fichier de commandes (par exemple, %1). Vous n'avez pas besoin d'utiliser de guillemets autour des chaînes littérales.
exist NomFichier
Ne reconnaît la condition comme étant vraie que si NomFichier existe.
OpComparaison
Spécifie un opérateur de comparaison en trois lettres. Le tableau suivant répertorie les valeurs valides de OpComparaison.
Opérateur | Description
EQU | Égal à
NEQ | Différent de
LSS | Inférieur à
LEQ | Inférieur ou égal à
GTR | Supérieur à
GEQ | Supérieur ou égal à
/i
Force les comparaisons de chaînes à ne pas tenir compte de la casse. Vous pouvez utiliser /i sur la forme Chaîne1==Chaîne2 de if. Ces comparaisons sont génériques, en ce sens que si Chaîne1 et Chaîne2 sont tous deux constitués uniquement de chiffres numériques, les chaînes sont converties en nombres et une comparaison numérique est effectuée.
cmdextversion Nombre
Spécifie qu'une condition est vraie uniquement si le numéro de version interne associé à l'extension de commande de Cmd.exe est supérieur ou égal à Nombre. La première version est égale à 1. Elle est incrémentée d'une unité lorsque des améliorations significatives sont ajoutées aux extensions de commandes. L'expression conditionnelle cmdextversion n'est jamais vraie lorsque les extensions de commandes sont désactivées (par défaut, les extensions de commandes sont activées).
defined Variable
Ne reconnaît la condition comme étant vraie que si Variable est défini.
Expression
Spécifie qu'une commande de ligne de commande et tous ses paramètres doivent être transmis à la commande dans une clause else.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si la condition spécifiée dans une commande if est vraie, la commande qui suit la condition est exécutée. Si la condition est fausse, la commande contenue dans la clause if est ignorée et déclenche l'exécution de la commande contenue dans la clause else, si cette commande existe.
  • Lorsqu'un programme s'arrête, il renvoie un code de sortie. Vous pouvez utiliser les codes de sortie comme conditions en utilisant le paramètre errorlevel.
  • Utilisation de defined Variable

    Si vous utilisez defined Variable, les trois variables suivantes sont ajoutées : %errorlevel%, %cmdcmdline% et %cmdextversion%.

    %errorlevel% se développe en une représentation sous forme de chaîne de la valeur en cours de errorlevel, à condition qu'il n'existe pas encore de variable d'environnement nommée ERRORLEVEL, auquel cas vous obtenez plutôt sa valeur. L'exemple suivant montre comment utiliser errorlevel après avoir exécuté un programme de commandes :

    goto answer%errorlevel%
    :answer0
    echo Le programme a renvoyé le code 0
    :answer1
    echo Le programme a renvoyé le code 1
    goto end
    :end
    echo Terminé !

    Vous pouvez également utiliser les opérateurs de comparaison OpComparaison suivants :

    if %errorlevel% LEQ 1 goto okay

    %cmdcmdline% développe la ligne de commande d'origine passée à Cmd.exe avant un traitement quelconque par Cmd.exe, à condition qu'il n'existe pas encore de variable d'environnement nommée cmdcmdline, auquel cas vous obtenez plutôt sa valeur.

    %cmdextversion% se développe en une représentation sous forme de chaîne de la valeur en cours de cmdextversion, à condition qu'il n'existe pas encore de variable d'environnement nommée CMDEXTVERSION, auquel cas vous obtenez plutôt sa valeur.

  • Utilisation de la clause else

    Vous devez utiliser la clause else sur la même ligne que la commande, après la clause if. Exemple :

        IF EXIST nomfichier. (

del nomfichier.

) ELSE (

echo nomfichier. manquant.

)

    L'exemple de code suivant ne fonctionne pas car vous devez terminer la commande del par une nouvelle ligne :

        IF EXIST nomfichier. del nomfichier. ELSE echo nomfichier. manquant

    L'exemple de code suivant ne fonctionne pas car vous devez utiliser la clause else sur la même ligne que la fin de la commande if :

        IF EXIST nomfichier. del nomfichier.

ELSE echo nomfichier. manquant

    Pour tout mettre en forme sur une seule ligne, utilisez la structure suivante de l'instruction d'origine :

        IF EXIST nomfichier. (del nomfichier.) ELSE echo nomfichier. manquant

Exemples

Si le fichier Produit.dat est introuvable, le message suivant s'affiche :

if not exist produit.dat echo Impossible de trouver le fichier de données

Si une erreur survient pendant le formatage de la disquette placée dans le lecteur A, l'exemple suivant affiche un message d'erreur :

:begin
@echo off
format a: /s
if not errorlevel 1 goto end
echo Une erreur s'est produite durant le formatage.
:end
echo Fin du programme de commandes.

Si aucune erreur ne s'est produite, le message d'erreur ne s'affiche pas.

Vous ne pouvez pas utiliser la commande if pour vérifier directement l'existence d'un répertoire ; cependant, un périphérique fictif (NUL) existe dans chaque répertoire. Par conséquent, vous pouvez vérifier sa présence pour déterminer si un répertoire existe. L'exemple suivant vérifie l'existence d'un répertoire :

if exist c:monrep\nul goto traitement


Install

Charge en mémoire un programme résident. Utilisez le fichier RacineSystème\System32\Config.nt ou le fichier de démarrage équivalent spécifié dans le fichier PIF (fichier d'informations programme) d'un programme, pour désigner le programme à installer.

Syntaxe

install=[Lecteur:][Chemin] NomFichier [ParamètresCommande]

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du programme résident que vous voulez exécuter.
ParamètresCommande
Définit des paramètres pour le programme spécifié par NomFichier.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisez Install pour charger en mémoire un programme résident juste avant de démarrer l'application qui nécessite ce dernier. Si un programme résident est chargé en mémoire à l'aide du fichier Autoexec.nt, il l'est également chaque fois que l'invite de commandes est démarrée, ce qui entraîne un gaspillage de la mémoire.
  • N'utilisez pas Install pour charger des programmes qui se servent de variables d'environnement, de touches de raccourci ou qui exigent la présence de Cmd.exe pour traiter les erreurs critiques.

Exemple

Pour charger un programme en mémoire dans le fichier Config.nt, tapez :

install

XOX

Rubriques connexes


Ipconfig

Affiche toutes les valeurs actuelles de la configuration du réseau TCP/IP et actualise les paramètres DHCP (Dynamic Host Configuration Protocol) et DNS (Domain Name System). Utilisé sans paramètres, ipconfig affiche l'adresse IP, le masque de sous-réseau et la passerelle par défaut de toutes les cartes.

Syntaxe

ipconfig [/all] [/renew [Carte]] [/release [Carte]] [/flushdns] [/displaydns] [/registerdns] [/showclassid Carte] [/setclassid Carte [IDClasse]]

Paramètres

/all
Affiche la configuration TCP/IP complète de toutes les cartes. Sans ce paramètre, ipconfig affiche uniquement l'adresse IP, le masque de sous-réseau et les valeurs de la passerelle par défaut de chaque carte. Les cartes peuvent représenter des interfaces physiques, par exemple les cartes réseau installées, ou des interfaces logiques, par exemple les connexions d'accès à distance.
/renew [Carte]
Renouvelle la configuration DHCP de tous les cartes (si aucune carte n'est spécifiée) ou d'une carte spécifique si le paramètre Carte est inclus. Ce paramètre est disponible uniquement sur les ordinateurs dont les cartes sont configurées de manière à obtenir automatiquement une adresse IP. Pour spécifier un nom de carte, tapez celui qui apparaît quand vous utilisez ipconfig sans paramètre.
/release [Carte]
Envoie un message DHCPRELEASE au serveur DHCP pour libérer la configuration DHCP actuelle et annuler la configuration d'adresse IP de toutes les cartes (si aucune carte n'est spécifié) ou d'une carte spécifique si le paramètre Carte est inclus. Ce paramètre désactive TCP/IP pour les cartes configurées de manière à obtenir automatiquement une adresse IP. Pour spécifier un nom de carte, tapez celui qui apparaît quand vous utilisez ipconfig sans paramètre.
/flushdns
Vide et réinitialise le contenu du cache de résolution du client DNS. Au cours de la résolution des problèmes DNS, vous pouvez utiliser cette procédure pour exclure les entrées de cache négatives ainsi que toutes les autres entrées ajoutées de façon dynamique.
/displaydns
Affiche le contenu du cache de résolution du client DNS, qui inclut les entrées préchargées à partir du fichier des hôtes locaux ainsi que tous les enregistrements de ressources récemment obtenus pour les requêtes de noms résolues par l'ordinateur. Le service Client DNS utilise ces informations pour résoudre rapidement les noms fréquemment sollicités, avant d'interroger ses serveurs DNS configurés.
/registerdns
Entame une inscription dynamique manuelle des noms DNS et des adresses IP configurés sur un ordinateur. Vous pouvez utiliser ce paramètre pour résoudre un problème d'échec d'inscription de nom DNS ou un problème de mise à jour dynamique entre un client et le serveur DNS sans redémarrage du client. Les paramètres DNS des propriétés avancées du protocole TCP/IP déterminent les noms enregistrés dans DNS.
/showclassid Carte
Affiche l'ID de classe DHCP d'une carte spécifique. Pour visualiser l'ID de classe DHCP de toutes les cartes, utilisez l'astérisque (*) comme caractère générique à la place de Carte. Ce paramètre est disponible uniquement sur les ordinateurs dont les cartes sont configurées de manière à obtenir automatiquement une adresse IP.
/setclassid Carte [IDClasse]
Configure l'ID de classe DHCP d'une carte spécifique. Pour définir l'ID de classe DHCP de toutes les cartes, utilisez l'astérisque (*) comme caractère générique à la place de Carte. Ce paramètre est disponible uniquement sur les ordinateurs dont les cartes sont configurées de manière à obtenir automatiquement une adresse IP. Si aucun ID de classe DHCP n'est spécifié, l'ID de classe en cours est supprimé.
/?
Affiche l'aide dans l'invite de commandes.

Remarque

  • La commande ipconfig représente l'équivalent sous forme de ligne de commande de la commande winipcfg, disponible dans Windows Millennium Edition, Windows 98 et Windows 95. Bien que Windows XP ne dispose pas de l'équivalent graphique de la commande winipcfg, vous pouvez utiliser Connexions réseau pour afficher et renouveler une adresse IP. Pour ce faire, ouvrez Connexions réseau, cliquez avec le bouton droit sur une connexion réseau, cliquez sur État, puis sur l'onglet Prise en charge.
  • Cette commande est très utile sur les ordinateurs configurés de manière à obtenir automatiquement une adresse IP. Cela permet aux utilisateurs de déterminer les valeurs de configuration TCP/IP utilisées par DHCP, APIPA (Automatic Private IP Addressing) ou un autre type de configuration.
  • Si le nom de la Carte contient des espaces, utilisez des guillemets autour de ce nom (comme ceci : "Nom carte").
  • En ce qui concerne les noms de cartes, ipconfig prend en charge l'utilisation de l'astérisque (*) comme caractère générique pour spécifier des cartes dont le nom commence par la chaîne indiquée ou des cartes dont le nom contient une chaîne spécifique. Par exemple, Local* recherche toutes les cartes commençant par la chaîne Local et *Con* recherche toutes les cartes contenant la chaîne Con.
  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est déclaré comme composant dans les propriétés d'une carte réseau dans les Connexions réseau.

Exemple

Pour afficher la configuration TCP/IP de base de toutes les cartes, tapez :

ipconfig

Pour afficher la configuration TCP/IP complète de toutes les cartes, tapez :

ipconfig /all

Pour renouveler une configuration d'adresse IP assignée par DHCP uniquement pour la carte Connexion au réseau local, tapez :

ipconfig /renew "Connexion au réseau local"

Pour vider le cache de résolution DNS et résoudre les problèmes de noms DNS, tapez :

ipconfig /flushdns

Pour afficher l'ID de classe DHCP de toutes les cartes dont le nom commence par Local, tapez :

ipconfig /showclassid Local*

Pour attribuer la valeur TEST à l'ID de classe DHCP de la carte Connexion au réseau local, tapez :

ipconfig /setclassid "Connexion au réseau local" TEST


Ipseccmd

Configure des stratégies IPSec (Internet Protocol Security) dans un service d'annuaire, ou dans un Registre local ou distant. Ipseccmd est une ligne de commande qui constitue une autre forme d'utilisation du composant logiciel enfichable MMC (Microsoft Management Console ) pour les stratégies IPSec (Internet Protocol Security). Ipseccmd comporte trois modes : le mode dynamique, le mode statique et le mode requête.

Pour afficher la syntaxe de la commande, cliquez sur celle-ci :

Mode dynamique de ipseccmd

Vous pouvez utiliser le mode dynamique de Ipseccmd pour inclure des règles anonymes dans la stratégie IPSec existante, en ajoutant ces règles à la base de données des stratégies IPSec (Internet Protocol Security). Les règles ajoutées seront présentes même après le redémarrage des services IPSEC. L'utilisation du mode dynamique a pour avantage de faire coexister les règles que vous ajoutez avec la stratégie IPSec basée sur le domaine. Le mode dynamique est le mode par défaut pour Ipseccmd.

Syntaxe

  • Pour ajouter une règle, utilisez la syntaxe suivante :

    • ipseccmd [\\NomOrdinateur] -f ListeFiltres [-n ListeStratégiesNégociation] [-t AdresseTunnel] [-a ListeMéthodesAuth] [-1s ListeMéthodesSécurité] [-1k ParamètresChangementCléModePrincipal] [-1p] [-1f ListeFiltresModePrincipal] [-1e DélaiExpirationSALogicielle] [-soft] [-confirm] [{-dialup | -lan}]

  • Pour supprimer toutes les stratégies dynamiques, utilisez la syntaxe suivante :

    • ipseccmd -u

Paramètres

\\NomOrdinateur
Spécifie le nom d'un ordinateur distant auquel vous souhaitez ajouter une règle.
-f ListeFiltres
Nécessaire pour la première syntaxe. Spécifie un ou plusieurs filtres, séparés par des espaces, pour les associations de sécurité (SA) de mode rapide. Chaque spécification de filtre définit un ensemble du trafic réseau affecté par cette règle.
-n ListeStratégiesNégociation
Spécifie une ou plusieurs méthodes de sécurité, séparées par des espaces, pour la sécurisation du trafic défini par la liste des filtres.
-t AdresseTunnel
Spécifie le point d'arrêt du tunnel pour le mode de tunnel sous la forme d'une adresse IP ou d'un nom de domaine DNS.
-a ListeMéthodesAuth
Spécifie une ou plusieurs méthodes d'authentification, séparées par des espaces.
-1s ListeMéthodesSécurité
Spécifie une ou plusieurs méthodes de sécurité d'échange de clés, séparées par des espaces.
-1k ParamètresChangementCléModePrincipal
Spécifie les paramètres de changement de clé SA du mode principal.
-1p
Implémente le mécanisme PFS (Perfect Forward Secrecy ) activé pour la clé principale.
-1f ListeFiltresModePrincipal
Spécifie un ou plusieurs filtres, séparés par des espaces, pour les associations de sécurité du mode principal.
-1e DélaiExpirationSALogicielle
Spécifie le délai d'expiration des associations de sécurité logicielles en secondes.
-soft
Active les associations de sécurité logicielles.
-confirm
Spécifie l'affichage d'un message de confirmation avant l'ajout de la règle ou de la stratégie.
{-dialup | -lan}
Spécifie si la règle s'applique uniquement à des connexions d'accès à distance ou à des connexions aux réseaux locaux (LAN).
-u
Nécessaire pour la seconde syntaxe. Spécifie que toutes les règles dynamiques sont supprimées.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Ipseccmd ne peut pas être utilisé pour configurer des règles sur des ordinateurs exécutant Windows 2000.
  • Si vous ne spécifiez pas le paramètre NomOrdinateur, la règle est ajoutée à l'ordinateur local.
  • Si vous utilisez le paramètre NomOrdinateur, vous devez le faire avant tous les autres paramètres ; en outre, vous devez disposer d'autorisations d'administrateur sur l'ordinateur auquel vous souhaitez ajouter la règle.
  • Pour le paramètre -f, une spécification de filtre se compose d'un ou plusieurs filtres séparés par des espaces et définis par le format :

    • AdresseSource/MasqueSource:PortSource=AdresseDest/MasqueDest:PortDest:Protocole

    • MasqueSource, PortSource, MasqueDest et PortDest sont facultatifs. Si vous les omettez, le masque 255.255.255.255 et tous les ports sont utilisés pour le filtre.
    • Protocole est facultatif. Si vous l'omettez, tous les protocoles sont utilisés pour le filtre. Si vous spécifiez un protocole, vous devez également spécifier le port ou faire précéder le protocole de deux signes des deux-points (::). (Consultez le premier exemple pour le mode dynamique.) Le protocole doit être le dernier élément du filtre. Vous pouvez utiliser les symboles de protocoles suivants : ICMP, UDP, RAW ou TCP.
    • Vous pouvez créer des filtres en miroir en remplaçant le signe égal (=) par un signe plus (+).
    • Vous pouvez remplacer AdresseSource/MasqueSource ou AdresseDest/MasqueDest par les valeurs du tableau suivant.
      • Valeur | Description
0 | Mon adresse ou mes adresses
* | N'importe quelle adresse
NomDNS | Nom de domaine DNS. Si le nom DNS correspond à plusieurs adresses, il est ignoré.
GUID | Identificateur unique global (GUID) d'une interface réseau locale ayant la forme 12345678-1234-1234-1234-123456789ABC. La spécification d'un GUID n'est pas prise en charge lorsque le paramètre -n est utilisé en mode statique.
    • Vous pouvez activer la règle de réponse par défaut en indiquant default pour la spécification de filtre.
    • Vous pouvez spécifier un filtre d'autorisation en mettant la spécification de filtre entre parenthèses. Vous pouvez spécifier un filtre de blocage en mettant la spécification de filtre entre crochets ([ ]).
    • Si vous utilisez des masques de sous-réseau basés sur une classe d'adresse Internet (les masques de sous-réseau sont définis le long de frontières d'octets), vous pouvez recourir à une notation sous forme de caractères génériques pour spécifier ces masques de sous-réseau. Par exemple, 10.*.*.* est identique à 10.0.0.0/255.0.0.0 et 10.92.*.* est identique à 10.92.0.0/255.255.0.0.

    Exemples de filtres

    Pour créer des filtres en miroir dans le but de filtrer le trafic TCP entre Ordinateur1 et Ordinateur2, tapez :

    Ordinateur1+Ordinateur2::TCP

    Pour créer un filtre applicable à tout le trafic TCP entre le sous-réseau 172.31.0.0/255.255.0.0, port 80 et le sous-réseau 10.0.0.0/255.0.0.0, port 80, tapez :

    172.31.0.0/255.255.0.0:80=10.0.0.0/255.0.0.0:80:TCP

    Pour créer un filtre en miroir qui autorise le trafic entre l'adresse IP locale et l'adresse IP 10.2.1.1, tapez :

    (0+10.2.1.1)

  • Pour le paramètre -n, une ou plusieurs stratégies de négociation sont séparées par des espaces et se présentent sous l'une des formes suivantes :
    • esp[AlgCryp,AlgAuth]ChangementClé PFS[Groupe]
    • ah[AlgHach]
    • ah[AlgHach]+esp[AlgCryp,AlgAuth]

    où AlgCryp peut être none, des ou 3des, AlgAuth peut être none, md5 ou sha, et AlgHach peut être md5 ou sha.

    • La configuration esp[none,none] n'est pas prise en charge.
    • Le paramètre sha fait référence à l'algorithme de hachage SHA1.
    • Le paramètre ChangementClé est facultatif et spécifie le nombre de kilo-octets (indiqué en plaçant un K après ce nombre) ou le nombre de secondes (indiqué en plaçant un S après ce nombre) précédant un changement de clé de l'association de sécurité de mode rapide. Pour spécifier les deux paramètres de changement de clé, séparez les deux nombres par une barre transversale (/). Par exemple, pour effectuer le changement de clé de l'association de sécurité (SA) de mode rapide toutes les heures et tous les 5 méga-octets de données, tapez :

      • 3600S/5000K

    • Le paramètre PFS est facultatif et implémente le mécanisme PFS (Perfect Forward Secrecy ) activé pour la clé de session. Par défaut, le mécanisme PFS (Perfect Forward Secrecy ) activé pour la clé de session est désactivé.
    • Le paramètre Groupe est facultatif et spécifie le groupe Diffie-Hellman du mécanisme PFS (Perfect Forward Secrecy ) activé pour la clé de session. Pour le groupe Diffie-Hellman Faible(1), spécifiez PFS1 ou P1. Pour le groupe Diffie-Hellman moyen(2), spécifiez PFS2 ou P2. Par défaut, la valeur de groupe du mécanisme PFS (Perfect Forward Secrecy ) activé pour la clé de session est extraite à partir des paramètres en cours du mode principal.
    • Si vous ne spécifiez pas de stratégies de négociation, les stratégies de négociation par défaut sont les suivantes :
      • esp[3des,sha]
      • esp[3des,md5]
      • esp[des,sha]
      • esp[des,md5]
  • Si vous omettez le paramètre -t, le mode de transport IPSec est utilisé.
  • Pour le paramètre -a, une ou plusieurs méthodes d'authentification sont séparées par des espaces et se présentent sous l'une des formes suivantes :
    • preshare:"ChaîneCléPréPartagée"
    • kerberos
    • cert:"InfoAutoritéCertification"

    Le paramètre ChaîneCléPréPartagée spécifie la chaîne de caractères de la clé pré-partagée. Le paramètre InfoAutoritéCertification spécifie le nom unique du certificat tel qu'il est affiché dans le composant logiciel enfichable des stratégies de sécurité IP lorsque le certificat est sélectionné comme méthode d'authentification pour une règle. Les paramètres ChaîneCléPréPartagée et InfoAutoritéCertification respectent la casse. Vous pouvez abréger la méthode en utilisant la première lettre : p, k ou c. Si vous omettez le paramètre -a, la méthode d'authentification par défaut est Kerberos.

  • Pour le paramètre -1s, une ou plusieurs méthodes de sécurité d'échange de clés sont séparées par des espaces et définies par le format suivant :

    • AlgCryp-AlgHach-NumGroupe

    où AlgCryp peut être des ou 3des, AlgHach peut être md5 ou sha, et NumGroupe peut être 1 pour le groupe Diffie-Hellman Faible(1) ou 2 pour le groupe Diffie-Hellman Moyen(2). Si vous omettez le paramètre -1s, les méthodes de sécurité d'échange de clés par défaut sont 3des-sha-2, 3des-md5-2, des-sha-1 et des-md5-1.

  • Pour le paramètre -1k, vous pouvez spécifier le nombre d'associations de sécurité (SA) de mode rapide (indiqué en plaçant un Q après ce nombre) ou le nombre de secondes (indiqué en plaçant un S après ce nombre), afin d'effectuer un changement de clé de l'association de sécurité (SA) de mode principal. Pour spécifier les deux paramètres de changement de clé, vous devez séparer les deux nombres par une barre transversale (/). Par exemple, pour effectuer le changement de clé de l'association de sécurité (SA) de mode principal toutes les 10 associations de sécurité (SA) de mode rapide et toutes les heures, tapez :

    • 10Q/3600S

    Si vous omettez le paramètre -1k, les valeurs par défaut pour le changement de clé de mode principal sont représentées par un nombre illimité d'associations de sécurité (SA) de mode rapide et 480 minutes.

  • Le mécanisme PFS (Perfect Forward Secrecy ) activé pour la clé principale est désactivé par défaut.
  • Pour le paramètre -1f, la syntaxe permettant d'indiquer les spécifications de filtres de mode principal est la même que pour le paramètre -f, sauf que vous ne pouvez pas spécifier de filtres d'autorisation, de filtres de blocage, de ports ni de protocoles. Si vous omettez le paramètre -1f, les filtres de mode principal sont automatiquement créés d'après les filtres de mode rapide.
  • Si vous omettez le paramètre -1e, le délai d'expiration des associations de sécurité (SA) logicielles est de 300 secondes. Cependant, les associations de sécurité (SA) logicielles sont désactivées sauf si vous incluez le paramètre -soft.
  • Une confirmation est disponible en mode dynamique uniquement.
  • Si vous ne spécifiez ni le paramètre -dialup ni le paramètre -lan, la règle s'applique à toutes les cartes.

Exemples

Pour créer une règle qui utilise l'en-tête d'authentification (AH) avec le hachage MD5 pour l'ensemble du trafic entrant et sortant de l'ordinateur local, tapez :

ipseccmd -f 0+* -n ah[md5]

Pour créer une règle de tunnel destinée au trafic entre 10.2.1.1 et 10.2.1.13 via le point d'arrêt du tunnel 10.2.1.13, pour obtenir le mode de tunnel d'en-tête d'authentification via l'algorithme de hachage SHA1, pour implémenter le mécanisme PFS (Perfect Forward Secrecy ) activé pour la clé principale et recevoir un message de confirmation précédant la création de la règle, tapez :

ipseccmd -f 10.2.1.1=10.2.1.13 -t 10.2.1.13 -n ah[sha] -1p -c

Pour créer une règle sur l'ordinateur nommé servsoc1 et l'appliquer à l'ensemble du trafic entre les ordinateurs servsoc1 et servsoc2, en associant l'en-tête d'authentification à la charge de sécurité d'encapsulation (ESP), avec une authentification de clé pré-partagée, tapez :

ipseccmd \\servsoc1 -f servsoc2+servsoc1 -n ah[md5]+esp[des,sha] -a p:"authsociété"

Mode statique de ipseccmd

Vous pouvez utiliser le mode statique de Ipseccmd pour créer des stratégies nommées et des règles nommées. Vous pouvez également utiliser le mode statique pour modifier des stratégies et des règles existantes, à condition qu'elles aient été créées à l'origine avec Ipseccmd. La syntaxe du mode statique combine la syntaxe du mode dynamique à des paramètres qui lui permettent d'opérer à un niveau de stratégie.

Syntaxe

ipseccmd ParamètresModeDynamique -w Type[:Emplacement] -p NomStratégie[:FréquenceInterrogation] -r NomRègle [{-x | -y}] [-o]

Paramètres

ParamètresModeDynamique
Nécessaire. Spécifie un ensemble de paramètres de mode dynamique pour une règle IPSec, comme indiqué précédemment.
-w Type[:Emplacement]
Nécessaire. Spécifie que les stratégies et les règles sont écrites dans le Registre local, dans le Registre d'un ordinateur distant ou dans un domaine Active Directory.
-p NomStratégie[:FréquenceInterrogation]
Nécessaire. Spécifie le nom de la stratégie et la fréquence, en minutes, de la vérification des modifications de la stratégie. Si NomStratégie contient des espaces, utilisez des guillemets autour du texte (comme ceci : "Nom Stratégie").
-r NomRègle
Nécessaire. Spécifie le nom de la règle. Si NomRègle contient des espaces, utilisez des guillemets autour du texte (comme ceci : "Nom Règle").
[{-x | -y}]
Spécifie si la stratégie de Registre local est assignée. Le paramètre -x spécifie que la stratégie de Registre local est assignée. Le paramètre -y spécifie que la stratégie de Registre local n'est pas assignée.
-o
Spécifie que la règle ou la stratégie doit être supprimée.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour le paramètre -w, le Type est soit reg pour spécifier le Registre de l'ordinateur local ou d'un ordinateur distant, soit ds pour spécifier Active Directory.
    • Si vous spécifiez reg pour le paramètre Type sans utiliser le paramètre Emplacement, la règle est créée pour le Registre de l'ordinateur local.
    • Si vous spécifiez reg pour le paramètre Type et que vous spécifiez également le nom d'un ordinateur distant pour le paramètre Emplacement, la règle est créée pour le Registre de l'ordinateur distant spécifié.
    • Si vous spécifiez ds pour le paramètre Type sans utiliser le paramètre Emplacement, la règle est créée pour le domaine Active Directory auquel appartient l'ordinateur local.
    • Si vous spécifiez ds pour le paramètre Type et que vous spécifiez également un domaine Active Directory pour le paramètre Emplacement, la règle est créée pour le domaine spécifié.
  • Pour le paramètre -p, si une stratégie portant le même nom existe déjà, la règle spécifiée est ajoutée à la stratégie. Dans le cas contraire, une stratégie est créée avec le nom spécifié. Si vous spécifiez un entier pour le paramètre FréquenceInterrogation, la fréquence d'interrogation de la stratégie est définie à partir du nombre de minutes correspondant.
  • Pour le paramètre -r, si une règle portant le même nom existe déjà, la règle est modifiée pour refléter les paramètres spécifiés dans la commande. Par exemple, si vous incluez le paramètre -f dans une règle existante, seuls les filtres de cette règle sont remplacés. S'il n'existe aucune règle portant le même nom, une règle est créée avec le nom spécifié.
  • Pour le paramètre -o, tous les aspects de la stratégie spécifiée sont supprimés. N'utilisez pas ce paramètre si d'autres stratégies pointent vers les objets de la stratégie à supprimer.

  • L'utilisation du mode statique se différencie de l'utilisation du mode dynamique de la façon suivante. En mode dynamique, vous indiquez les filtres d'autorisation et de blocage dans ListeFiltres, que vous identifiez à l'aide du paramètre -f. En mode statique, vous indiquez les filtres d'autorisation et de blocage dans ListeStratégiesNégociation, que vous identifiez à l'aide du paramètre -n. Outre les paramètres décrits pour ListeStratégiesNégociation en mode dynamique, vous pouvez également utiliser les paramètres block, pass ou inpass en mode statique. Le tableau suivant répertorie ces paramètres ainsi qu'une description de leur comportement.

    Paramètre | Description
    block | Les stratégies restantes dans ListeStratégiesNégociation sont ignorées et tous les filtres sont transformés en filtres de blocage.
    pass | Les stratégies restantes dans ListeStratégiesNégociation sont ignorées et tous les filtres sont transformés en filtres d'autorisation.
    inpass | Les filtres d'entrée autorisent une communication initiale non sécurisée, mais les réponses sont sécurisées grâce à IPSec.

Exemples

Pour créer une stratégie nommée Stratégie de domaine par défaut comportant une fréquence d'interrogation de 30 minutes dans le domaine Active Directory auquel appartient l'ordinateur local, avec une règle nommée Serveurs sécurisés applicable à l'ensemble du trafic entre l'ordinateur local et les ordinateurs ServeurSécurisé1 et ServeurSécurisé2, tout en utilisant les méthodes d'authentification Kerberos et de clé pré-partagée, tapez :

ipseccmd -f 0+ServeurSécurisé1 0+ServeurSécurisé2 -a k p:"authsociété" -w ds -p "Stratégie de domaine par défaut":30 -r "Serveurs sécurisés"

Pour créer et assigner une stratégie locale nommée Moi vers les autres, avec une règle nommée Sécuriser mon trafic, en utilisant un filtre en miroir pour l'ensemble du trafic vers l'ordinateur local, ainsi qu'une méthode d'authentification par clé pré-partagée, tapez :

ipseccmd -f 0+* -a p:"authlocale" -w reg -p "Moi vers les autres" -r "Sécuriser mon trafic" -x

Mode requête de ipseccmd

Vous pouvez utiliser le mode requête de Ipseccmd pour afficher les données de la base de données des stratégies de sécurité IPSec.

Syntaxe

ipseccmd [\\NomOrdinateur] show {{[filters] | [policies] | [auth] | [stats] | [sas]} | all}

Paramètres

\\NomOrdinateur
Spécifie, à partir de son nom, l'ordinateur distant dont vous souhaitez afficher les données.
show
Nécessaire. Indique que Ipseccmd doit s'exécuter en mode requête.
filters
Affiche les filtres de mode principal et de mode rapide.
policies
Affiche les stratégies de mode principal et de mode rapide.
auth
Affiche les méthodes d'authentification de mode principal.
stats
Affiche les statistiques sur Internet Key Exchange (IKE) et IPSec.
sas
Affiche les associations de sécurité (SA) de mode principal et de mode rapide.
all
Affiche l'ensemble des types de données ci-dessus.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Ipseccmd ne peut pas être utilisé pour afficher les données IPSec des ordinateurs exécutant Windows 2000.
  • Si vous n'utilisez pas le paramètre NomOrdinateur, les informations de l'ordinateur local sont affichées.
  • Si vous utilisez le paramètre NomOrdinateur, vous devez le faire avant tous les autres paramètres ; en outre, vous devez disposer d'autorisations d'administrateur sur l'ordinateur dont vous souhaitez afficher les informations.

Exemples

Pour afficher les filtres et les stratégies de mode principal et de mode rapide pour l'ordinateur local, tapez :

ipseccmd show filters policies

Pour afficher toutes les informations IPSec de l'ordinateur distant Serveur1, tapez la commande suivante :

ipseccmd \\Server1 show all


Ipxroute

Affiche et modifie les informations relatives aux tables de routage utilisées par le protocole IPX. Utilisé sans paramètres, ipxroute affiche les paramètres par défaut des paquets envoyés aux adresses inconnues, de diffusion et multidiffusion.

Syntaxe

ipxroute serveurs [/type=x]

ipxroute ripout Réseau

ipxroute resolve {guid | name} {GUID | NomCarte}

ipxroute board=n [def] [gbr] [mbr] [remove=xxxxxxxxxxxx]

ipxroute config

Paramètres

serveurs [/type=x]
Affiche la table des points d'accès au service (SAP, Service Access Point) pour le type de serveur spécifié. x doit être un entier. /type=4, par exemple, affiche tous les serveurs de fichiers. Si vous ne spécifiez pas /type, ipxroute servers affiche tous les types de serveurs, en les répertoriant par nom.
ripout Réseau
Détecte si Réseau est accessible en consultant la table de routage de la pile IPX et en envoyant une demande RIP si nécessaire. Réseau représente le numéro de segment du réseau IPX
.
resolve {guid | name} {GUID | NomCarte}
Interprète le nom du GUID à partir de son nom convivial, ou le nom convivial à partir de son GUID.
carte=n
Spécifie la carte réseau qui fait l'objet de la requête ou pour laquelle vous définissez des paramètres.
def
Envoie les paquets en diffusion ALL ROUTES. Si un paquet est transmis à une adresse MAC unique ne figurant pas dans la table de routage source, ipxroute envoie ce paquet par défaut à la diffusion SINGLE ROUTES.
gbr
Envoie les paquets en diffusion ALL ROUTES. Si un paquet est transmis à l'adresse de diffusion (FFFFFFFFFFFF), ipxroute l'envoie par défaut à la diffusion SINGLE ROUTES.
mbr
Envoie les paquets en diffusion ALL ROUTES. Si un paquet est transmis à une adresse multidiffusion (C000xxxxxxxx), ipxroute l'envoie par défaut à la diffusion SINGLE ROUTES.
remove=xxxxxxxxxxxx
Supprime l'adresse de nœud donnée de la table de routage source.
config
Affiche des informations sur toutes les liaisons pour lesquelles IPX est configuré.
/?
Affiche l'aide à l'invite de commandes.

Exemple

Pour afficher les segments réseau liés à la station de travail, son adresse de nœud et le type de trame utilisé, tapez la commande suivante :

ipxroute config


Irftp

Envoie des fichiers par une liaison infrarouge. Utilisé sans paramètres ou avec /s, irftp ouvre la boîte de dialogue Liaison sans fil, où vous pouvez sélectionner les fichiers à envoyer sans passer par la ligne de commande.

Syntaxe

irftp [Lecteur:\] [[Chemin] NomFichier] [/h]

irftp /s

Paramètres

Lecteur:\
Spécifie l'unité qui contient les fichiers que vous voulez transmettre au moyen d'une liaison infrarouge.
[Chemin] NomFichier
Indique l'emplacement et le nom du fichier ou du jeu de fichiers à transmettre au moyen d'une liaison infrarouge. Si vous spécifiez un ensemble de fichiers, vous devez indiquer le chemin d'accès complet de chaque fichier.
/h
Spécifie le mode caché. Lorsque le mode caché est utilisé, les fichiers sont transmis sans que s'affiche la boîte de dialogue Liaison sans fil.
/s
Ouvre la boîte de dialogue Liaison sans fil, et vous permet de sélectionner le fichier ou l'ensemble de fichiers à envoyer sans passer par la ligne de commande pour spécifier le lecteur, le chemin d'accès et les noms de fichiers.

Remarques

  • Avant d'utiliser cette commande, vérifiez que les périphériques avec lesquels vous souhaitez communiquer par liaison infrarouge disposent de cette fonctionnalité, que celle-ci est activée et fonctionne correctement, et qu'une liaison infrarouge existe effectivement entre les périphériques.

Exemples

Pour envoyer un document Word nommé MonDocWord, situé dans un dossier nommé MesFichiers (sur le lecteur C de l'ordinateur source), vers l'ordinateur cible, tapez :

irftp C:\MesFichiers\MonDocWord.doc /h

Pour envoyer deux documents Word, MonDocWord1 et MonDocWord2, situés dans un dossier nommé MesFichiers (sur le lecteur C de l'ordinateur source), vers l'ordinateur cible, tapez :

irftp C:\MesFichiers\MonDocWord1.doc C:\MesFichiers\MonDocWord2.doc /h

Le mode caché est utilisé, ce qui signifie que la boîte de dialogue Liaison sans fil n'est pas affichée.


Étiquetez-les

Image Microsoft Windows

Label

Crée, change ou supprime le nom de volume d'un disque. Utilisé sans paramètres, label modifie le nom de volume en cours ou supprime le nom existant.

Syntaxe

label [Lecteur:][Nom]

label [/MP][Volume][Nom]

Paramètres

Lecteur:
Spécifie la lettre de lecteur (suivie d'un signe deux-points) du disque à nommer.
Étiquette
Spécifie le nom du volume.
/MP
Spécifie que le volume doit être considéré comme un point de montage ou un nom de volume.
volume
Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom de volume. Si un nom de volume est spécifié, le paramètre /MP n'est pas nécessaire.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Windows affiche le nom de volume dans la liste du répertoire. Si un numéro de série de volume existe, Windows l'affiche également.
  • Messages de la commande Label

    Si vous ne spécifiez pas de nom lorsque vous utilisez la commande label, celle-ci affiche un message au format suivant :

    Le volume dans lecteur A est xxxxxxxxxxx
    Le numéro de série du volume est xxxx-xxxx
    Nom de volume (11 caractères, ENTRÉE pour ne rien mettre) ?

    Si le disque n'a pas de numéro de série, la partie "Numéro de série du volume" de ce message ne s'affiche pas.

    Vous pouvez taper le nom de volume souhaité ou appuyer sur ENTRÉE pour supprimer le nom existant. Si un disque est doté d'un nom et si vous appuyez sur ENTRÉE pour le supprimer, label affiche le message suivant :

    Voulez-vous supprimer le nom du volume en cours (O/N) ?

    Appuyez sur O pour supprimer le nom ou sur N pour le conserver.
  • Restrictions applicables aux noms de volume

    Un nom de volume peut comporter jusqu'à 32 caractères pour les volumes NTFS et jusqu'à 11 caractères pour les volumes FAT. Il peut inclure des espaces, mais pas de tabulations.

    Les noms de volume FAT ne peuvent contenir aucun des caractères suivants :

    * ? / \ | . , ; : + = [ ] < > "

    Cette restriction ne s'applique pas aux volumes NTFS.

    Pour les volumes FAT, les noms de volumes sont stockés en majuscules même s'ils contiennent des lettres minuscules. Les noms de volume NTFS respectent et affichent la casse utilisée lors de la création du nom.

Exemple

Pour nommer une disquette placée dans le lecteur A et contenant des informations sur les ventes de juillet, tapez :

label a:ventes-juillet


Lastdrive

XOX

Rubriques connexes


Loadfix

S'assure qu'un programme est chargé au-dessus des premiers 64 Ko de mémoire conventionnelle et exécute le programme.

Syntaxe

loadfix [Lecteur:][Chemin] NomFichier

Paramètres

[Lecteur:][Chemin]
Indique le lecteur et le répertoire du programme.
NomFichier
Indique le nom du programme.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • XOX
  • Pour utiliser loadfix, ajoutez-le au début de la commande qui lance le programme.
  • Lorsque la totalité ou une partie d'un programme est chargée dans les premiers 64 Ko de mémoire conventionnelle et que toute exécution est impossible, certains programmes affichent le message suivant :
    Fichier compressé endommagé

    En règle générale, cette erreur se produit lorsque vous chargez des pilotes de périphérique dans la zone de mémoire supérieure, libérant ainsi une plus grande partie des premiers 64 Ko de mémoire conventionnelle. Si ce message s'affiche, utilisez la commande loadfix pour vous assurer que le programme est chargé au-dessus des premiers 64 Ko de mémoire virtuelle conventionnelle.

Exemple

Pour charger un programme nommé MonApp.exe (dans le répertoire Apps du lecteur C) et utiliser l'option de ligne de commande /c (par exemple, pour charger le programme en mode caractères), tapez :

loadfix c:\apps\monapp.exe /c

Vous pouvez également inclure cette commande dans un programme de commandes.


Loadhigh

Charge un programme dans la zone de mémoire supérieure. Le chargement d'un programme dans la zone de mémoire supérieure permet de libérer de l'espace dans la mémoire conventionnelle pour d'autres programmes. Utilisez le fichier RacineSystème\System32\Config.nt ou le fichier de démarrage équivalent spécifié dans le fichier PIF (fichier d'informations programme) d'un programme, pour désigner les programmes à charger dans la zone de mémoire supérieure.

Syntaxe

loadhigh [Lecteur:][Chemin] NomFichier [Paramètres]

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du programme à charger. NomFichier est obligatoire.
Paramètres
Spécifie les éventuelles informations de la ligne de commande requises par le programme.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • XOX
  • Pour utiliser la commande loadhigh, vous devez obligatoirement inclure la commande dos=umb dans votre fichier Config.nt ou le fichier de démarrage équivalent. Pour plus d'informations sur la commande dos=umb, consultez dos dans les rubriques connexes.
  • Avant de pouvoir charger un programme dans la zone de mémoire supérieure, vous devez installer le gestionnaire de mémoire étendue Himem.sys. Pour cela, utilisez la commande device dans votre fichier Config.nt ou le fichier de démarrage équivalent.
  • Si vous utilisez la commande loadhigh pour charger un programme, Windows XP essaie de charger ce dernier dans la zone de mémoire supérieure. Si l'espace est insuffisant dans la zone de mémoire supérieure, le programme est chargé en mémoire conventionnelle ; la zone de mémoire utilisée n'est pas indiquée.
  • Pour utiliser la commande loadhigh, la méthode la plus pratique consiste à l'inclure dans votre fichier Autoexec.nt ou le fichier de démarrage équivalent.

Exemple

Pour charger un pilote dans la zone de mémoire haute, incluez la ligne suivante dans votre fichier Autoexec.nt ou le fichier de démarrage équivalent :

lh %RacineSystème%\system32\dosx


Lodctr

Inscrit les noms et le texte d'explication des nouveaux compteurs de performance d'un service ou d'un pilote de périphérique et enregistre et restaure les valeurs et le texte d'explication des compteurs.

Syntaxe

lodctr [\\NomOrdinateur] NomFichier [/s:NomFichier] [/r:NomFichier]

Paramètres

[\\NomOrdinateur] NomFichier
Inscrit les noms de compteurs de performance et le texte d'explication fournis dans le fichier d'initialisation NomFichier. Si vous ne spécifiez pas NomOrdinateur, lodctr utilise l'ordinateur local par défaut.
/s:NomFichier
Enregistre les valeurs et le texte d'explication des compteurs de performance du Registre dans le fichier NomFichier.
/r:NomFichier
Restaure les valeurs et le texte d'explication des compteurs de performance du Registre à partir du fichier NomFichier.

Attention

  • Si vous utilisez la commande lodctr /r, vous remplacez toutes les valeurs et le texte d'explication des compteurs de performance du Registre par la configuration définie dans le fichier spécifié.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Si les informations que vous fournissez contiennent des espaces, entourez le texte de guillemets (par exemple, "Nom de l'ordinateur").

Exemples

Pour enregistrer les valeurs et le texte d'explication actuels des compteurs de performance du Registre dans un fichier nommé perf backup1.txt, tapez :

lodctr /s:"perf backup1.txt"


Lpq

Affiche l'état d'une file d'attente d'impression sur un ordinateur exécutant LPD (Line Printer Daemon). Sans paramètres, lpq affiche l'aide de la ligne de commande associée à la commande lpq.

Syntaxe

lpq -S NomServeur -P NomImprimante [-l]

Paramètres

-S NomServeur
Obligatoire. Spécifie le nom de l'ordinateur qui héberge la file d'attente d'impression dont vous souhaitez afficher l'état.
-P NomImprimante
Obligatoire. Spécifie le nom de l'imprimante associée à la file d'attente d'impression dont vous souhaitez afficher l'état.
-l
Indique que vous souhaitez afficher des détails sur l'état de la file d'attente d'impression.
/?
Affiche l'aide à l'invite de commandes.


Lpr

Envoie un fichier vers un ordinateur exécutant LPD (Line Printer Daemon) en vue de son impression. Sans paramètres, lpr affiche l'aide de la ligne de commande associée à la commande lpr.

Syntaxe

lpr [-S IDServeur] -P NomImprimante [-C ContenuBannière] [-J NomTravail] [{-o | -o l}] [-d] [-x] NomFichier

Paramètres

-S IDServeur
Spécifie le nom ou l'adresse IP de l'ordinateur qui héberge l'imprimante sur laquelle vous souhaitez imprimer le fichier. Il n'est pas nécessare de spécifier ce paramètre si l'imprimante est connectée à l'ordinateur local.
-P NomImprimante
Obligatoire. Spécifie le nom de l'imprimante sur laquelle vous souhaitez imprimer le fichier.
-C ContenuBannière
Spécifie le contenu à imprimer sur la page bannière du travail d'impression. Si vous ne spécifiez pas ce paramètre, la page bannière contiendra le nom de l'ordinateur à partir duquel le travail d'impression a été envoyé.
-J NomTravail
Spécifie le nom de travail d'impression qui sera imprimé sur la page bannière. Si vous ne spécifiez pas ce paramètre, la page bannière contiendra le nom du fichier imprimé.
{-o | -o l}
Spécifie le type de fichier que vous souhaitez imprimer. Le paramètre -o indique que vous voulez imprimer un fichier texte. Le paramètre -o l indique que vous voulez imprimer un fichier binaire (par exemple, un fichier PostScript).
-d
Spécifie que le fichier de données doit être envoyé avant le fichier de contrôle. Utilisez ce paramètre si l'imprimante exige que le fichier de données soit envoyé le premier. Pour plus d'informations, consultez la documentation de votre imprimante.
-x
Spécifie que la commande lpr doit être compatible avec le système d'exploitation SunOS de Sun Microsystems jusqu'à la version 4.1.4_u1 incluse.
NomFichier
Obligatoire. Spécifie le nom du fichier à imprimer.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Pour trouver le nom de l'imprimante, ouvrez le dossier Imprimantes et télécopies. XOX


Macfile

Utilisez les commandes macfile à l'invite de commandes pour gérer le serveur de fichiers pour les serveurs, volumes, répertoires et fichiers Macintosh. Vous pouvez automatiser les tâches d'administration en insérant une série de commandes dans des fichiers de commandes que vous lancez manuellement ou à des moments prédéterminés.

Pour modifier les répertoires situés dans des volumes accessibles aux Macintosh.

Syntaxe

macfile directory [/server:\\NomOrdinateur] /path:Répertoire [/owner:NomPropriétaire] [/group:NomGroupe] [/permissions:Autorisations]

Paramètres

/server:\\NomOrdinateur
Spécifie le serveur sur lequel se trouve le répertoire à modifier. Si ce paramètre est omis, l'opération est exécutée sur l'ordinateur local.
/path:Répertoire
Obligatoire. Spécifie le chemin d’accès du répertoire à modifier. Ce répertoire doit exister. Macfile directory ne crée pas de répertoires.
/owner:NomPropriétaire
Change le propriétaire du répertoire. Si ce paramètre est omis, le propriétaire reste inchangé.
/group:NomGroupe
Spécifie ou modifie le groupe principal Macintosh associé au répertoire. Si ce paramètre est omis, le groupe principal reste inchangé.
/permissions:Autorisations
Définit des autorisations sur le répertoire pour le propriétaire, le groupe principal et tout le monde. Les autorisations sont définies par un nombre de onze chiffres. La valeur 1 octroie une autorisation et 0 révoque une autorisation (par exemple, 11111011000). La position du chiffre détermine l'autorisation définie, comme indiqué dans le tableau suivant. Si ce paramètre est omis, les autorisations restent inchangées.
Position | Autorisation définie
Première | OwnerSeeFiles (affichage des fichiers par le propriétaire)
Deuxième | OwnerSeeFolders (affichage des dossiers par le propriétaire)
Troisième | OwnerMakeChanges (modifications par le propriétaire)
Quatrième | GroupSeeFiles (affichage des fichiers par le groupe)
Cinquième | GroupSeeFolders (affichage des dossiers par le groupe)
Sixième | GroupMakeChanges (modifications par le groupe)
Septième | WorldSeeFiles (affichage des fichiers par tout le monde)
Huitième | WorldSeeFolders (affichage des dossiers par tout le monde)
Neuvième | WorldMakeChanges (modifications par tout le monde)
Dixième | Le répertoire ne peut pas être renommé, déplacé ou supprimé.
Onzième | Les modifications s'appliquent au répertoire en cours et à tous ses sous-répertoires.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Si les informations que vous fournissez contiennent des espaces ou des caractères spéciaux, entourez le texte de guillemets (par exemple, "Nom de l'ordinateur").
  • Utilisez la commande macfile directory pour rendre un répertoire existant dans un volume accessible aux Macintosh disponible aux utilisateurs Macintosh. La commande macfile directory ne crée pas de répertoires. Utilisez le Gestionnaire de fichiers, l'invite de commandes ou la commande macintosh new folder pour créer un répertoire dans un volume accessible aux Macintosh avant d'utiliser la commande macfile directory.

Exemples

Cet exemple modifie les autorisations du sous-répertoire « ventes de mai » du volume « statistiques » accessible aux Macintosh situé sur le disque E du serveur local. Il octroie les autorisations SeeFiles (affichage des fichiers), SeeFolders (affichage des dossiers) et MakeChanges (modification) au propriétaire et les autorisations SeeFiles et SeeFolders à tous les autres utilisateurs, tout en empêchant que le répertoire soit renommé, déplacé ou supprimé.

macfile directory /path:"e:\statistiques\ventes de mai" /permissions:11111011000

Pour joindre les branches de ressources et de données d'un fichier Macintosh

Syntaxe

macfile forkize [/server:\\NomOrdinateur] [/creator:NomCréateur] [/type:NomType] [/datafork:CheminFichier] [/resourcefork:CheminFichier] /targetfile:CheminFichier

Paramètres

/server:\\NomOrdinateur
Spécifie le serveur sur lequel les fichiers doivent être joints. Si ce paramètre est omis, l'opération est exécutée sur l'ordinateur local.
/creator:NomCréateur
Spécifie le créateur du fichier. Le Finder Macintosh utilise l'option de ligne de commande /creator pour déterminer quelle application a créé le fichier.
/type:NomType
Spécifie le type du fichier. Le Finder Macintosh utilise l'option de ligne de commande /type pour déterminer le type du fichier dans l'application qui a créé ce fichier.
/datafork:CheminFichier
Spécifie l'emplacement de la branche de données qui doit être jointe. Vous pouvez spécifier un chemin distant.
/resourcefork:CheminFichier
Spécifie l'emplacement de la branche de ressources qui doit être jointe. Vous pouvez spécifier un chemin distant.
/targetfile:CheminFichier
Obligatoire. Spécifie l'emplacement du fichier créé en joignant une branche de données et une branche de ressources, ou spécifie l'emplacement du fichier dont vous modifiez le type ou le créateur. Le fichier doit se trouver sur le serveur spécifié.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Si les informations que vous fournissez contiennent des espaces ou des caractères spéciaux, entourez le texte de guillemets (par exemple, "Nom de l'ordinateur").

Exemples

Pour créer le fichier Treeapp sur le volume D:\Release accessible aux Macintosh en utilisant la branche de ressources C:\Cross\Mac\Appcode et pour présenter ce nouveau fichier aux clients Macintosh en tant qu'application (les applications Macintosh utilisent le type APPL) avec MAGNOLIA comme créateur (signature), tapez :

macfile forkize /resourcefork:c:\cross\mac\appcode /type:APPL /creator:MAGNOLIA /targetfile:D:\Release\Treeapp

Pour modifier le créateur en Microsoft Word 5.1 pour le fichier WORD.txt situé dans le répertoire D:\Word documents\Group files sur le serveur\\SERVERA, tapez :

macfile forkize /server:\\servera /creator:MSWD /type:TEXT /targetfile:"d:\Word documents\Group files\Word.txt"

Pour modifier le message d'ouverture de session et limiter les sessions

Syntaxe

macfile server [/server:\\NomOrdinateur] [/maxsessions:{Nombre | unlimited}] [/loginmessage:Message]

Paramètres

/server:\\NomOrdinateur
Spécifie le serveur sur lequel des paramètres doivent être modifiés. Si ce paramètre est omis, l'opération est exécutée sur l'ordinateur local.
/maxsessions:{Nombre | unlimited}
Spécifie le nombre maximum d'utilisateurs qui peuvent simultanément utiliser les serveurs de fichiers et d'impression Macintosh. Si ce paramètre est omis, la valeur de maxsessions pour le serveur reste inchangée.
/loginmessage:Message
Modifie le message qui s'affichera lorsque les utilisateurs de Macintosh ouvriront une session sur le serveur de fichiers du serveur Macintosh. Le message d'ouverture de session est limité à 199 caractères. Si ce paramètre est omis, le message loginmessage reste inchangé pour le serveur. Pour supprimer un message d'ouverture de session existant, spécifiez le paramètre /loginmessage, mais laissez vide la variable Message.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Si les informations que vous fournissez contiennent des espaces ou des caractères spéciaux, entourez le texte de guillemets (par exemple, "Nom de l'ordinateur").

Exemples

Pour fixer à cinq le nombre de sessions Serveur de fichiers et Serveur d'impression pour Macintosh qui sont autorisées sur le serveur local et pour ajouter le message d'ouverture de session « Déconnectez-vous des Serveurs pour Macintosh lorsque vous avez terminé. », tapez :

macfile server /maxsessions:5 /loginmessage:"Déconnectez-vous des Serveurs pour Macintosh lorsque vous avez terminé."

Pour ajouter, modifier ou supprimer des volumes accessibles aux Macintosh

Syntaxe

macfile volume {/add | /set} [/server:\\NomOrdinateur] /name:NomVolume /path:Répertoire [/readonly:{true | false}] [/guestsallowed:{true | false}] [/password:MotDePasse] [/maxusers:{Nombre| unlimited}]

macfile volume /remove [/server:\\NomOrdinateur] /name:NomVolume

Paramètres

{/add | /set}
Obligatoire lorsque vous ajoutez ou modifiez un volume accessible aux Macintosh. Ajoute ou modifie le volume spécifié.
/server:\\NomOrdinateur
Spécifie le serveur sur lequel un volume doit être ajouté, modifié ou supprimé. Si ce paramètre est omis, l'opération est exécutée sur l'ordinateur local.
/name:NomVolume
Obligatoire. Spécifie le nom du volume à ajouter, modifier ou supprimer.
/path:Répertoire
Obligatoire et valide uniquement lors de l'ajout d'un volume. Spécifie le chemin d'accès au répertoire racine du volume à ajouter.
/readonly:{true | false}
Spécifie si les utilisateurs peuvent modifier des fichiers dans le volume. Tapez true pour spécifier que les utilisateurs ne peuvent pas modifier de fichiers dans le volume. Tapez false pour spécifier que les utilisateurs peuvent modifier des fichiers dans le volume. Si ce paramètre est omis lors de l'ajout d'un volume, la modification de fichiers est autorisée. Si ce paramètre est omis lors de la modification d'un volume, le paramètre readonly pour le volume reste inchangé.
/guestsallowed:{true | false}
Spécifie si les utilisateurs qui ouvrent une session en tant qu'invités peuvent utiliser le volume. Tapez true pour spécifier que les invités peuvent utiliser le volume. Tapez false pour spécifier que les invités ne peuvent pas utiliser le volume. Si ce paramètre est omis lors de l'ajout d'un volume, les invités peuvent utiliser le volume. Si ce paramètre est omis lors de la modification d'un volume, le paramètre guestsallowed du volume reste inchangé.
/password:MotDePasse
Spécifie un mot de passe à fournir obligatoirement pour accéder au volume. Si ce paramètre est omis lors de l'ajout d'un volume, aucun mot de passe n'est créé. Si ce paramètre est omis lors de la modification d'un volume, le mot de passe reste inchangé.
/maxusers:{Nombre | unlimited}
Spécifie le nombre maximal d'utilisateurs qui peuvent utiliser simultanément les fichiers du volume. Si ce paramètre est omis lors de l'ajout d'un volume, un nombre illimité d'utilisateurs peut utiliser le volume. Si ce paramètre est omis lors de la modification d'un volume, la valeur maxusers reste inchangée.
/remove
Obligatoire lorsque vous supprimez un volume accessible aux Macintosh. Supprime le volume spécifié.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Si les informations que vous fournissez contiennent des espaces ou des caractères spéciaux, entourez le texte de guillemets (par exemple, "Nom de l'ordinateur").

Exemples

Pour créer un volume nommé Statistiques ventes US sur le serveur local en utilisant le répertoire Stats de l'unité E et pour spécifier que ce volume n'est pas accessible aux invités, tapez :

macfile volume /add /name:"Statistiques ventes US" /guestsallowed:false /path:e:\Stats

Pour modifier le volume créé ci-dessus afin qu'il soit en lecture seule et exige le mot de passe « saturn » et pour limiter à cinq le nombre maximal d'utilisateurs, tapez :

macfile volume /set /name:"Statistiques ventes US" /readonly:true /password:saturn /maxusers:5

Pour ajouter un volume nommé Conception paysage sur le serveur \\Magnolia en utilisant le répertoire Arbres de l'unité E et pour spécifier que ce volume est accessible aux invités, tapez :

macfile volume /add /server:\\Magnolia /name:"Conception paysage" /path:e:\Arbres

Pour supprimer le volume Rapports des ventes sur le serveur local, tapez :

macfile volume /remove /name:"Rapports des ventes"


Mem

Affiche des informations concernant les zones de mémoire allouées, les zones de mémoire libres et les programmes actuellement chargés en mémoire dans le sous-système MS-DOS. Utilisée sans paramètres, la commande mem affiche l'état de la mémoire utilisée et disponible du sous-système MS-DOS.

Syntaxe

mem [{/program | /debug | /classify}]

Paramètres

/program
Affiche l'état des programmes actuellement chargés en mémoire.
/debug
Affiche l'état des programmes actuellement chargés et des pilotes internes, ainsi que d'autres informations de programmation.
/classify
Affiche l'état des programmes chargés dans la mémoire conventionnelle et dans la zone de mémoire haute.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • XOX
  • XOX
  • Utilisation du paramètre /program

    Vous ne pouvez pas utiliser /program avec /debug ou /classify. Vous pouvez abréger /program en /p.

  • Utilisation du paramètre /debug

    Vous ne pouvez pas utiliser /debug avec /program ou /classify. Vous pouvez abréger /debug en /d.

  • Utilisation du paramètre /classify

    /classify affiche la taille de chaque programme en notation décimale et hexadécimale, résume l'usage de la mémoire et indique les plus grands blocs de mémoire disponibles. Vous ne pouvez pas utiliser /classify avec /program ou /debug. Vous pouvez abréger /classify en /c.

  • Affichage de l'état de la mémoire

    Le sous-système MS-DOS n'affiche l'état de la mémoire étendue que si vous avez alloué de la mémoire au-dessus de 1 mégaoctet (Mo).

Exemples

Supposons que votre sous-système MS-DOS soit configuré avec de la mémoire paginée. Pour afficher l'état de la mémoire totale du système (conventionnelle, paginée et étendue), ainsi qu'une liste des programmes actuellement chargés en mémoire, tapez :

mem /program

Les résultats de cette commande peuvent se présenter sous la forme suivante :

Adresse     Nom          Taille       Type

000000                   000400     Vecteur d'interruption

000400                   000100     Zone de communication ROM

000500                   000200     Zone de communication DOS

000700      ES           000310     Données système

000A10      MSDOS        0014D0     Données système

001EE0      ES           0018D0     Données système

                KBD        000800      Programme système

                HIMEM      000420      DEVICE=

                         000340      FILES=

                         000090      FCBS=

                         000170      LASTDRIVE=

                         000710      STACKS=

0037C0      COMMANDE      000A40     Programme

004210      MSDOS        000070     - Libre -

004290      COMMANDE      0001F0     Environnement

004490      MEM          0001D0     Environnement

004670      MEM          017550     Programme

01BBD0      MSDOS        084410     - Libre -

09FFF0      SYSTEME       028000     Programme système

0C8000      ES           0083D0     Données système

                SOURIS      0083C0      Programme système

0D03E0      MSDOS        000050     - Libre -

0D0440      REDIR        0009F0     Programme

0D0E40      DOSX         007CA0     Programme

0D8AF0      DOSX         001030     Données

0D9B30      MSDOS        0164C0     - Libre -

    655360 octets de mémoire conventionnelle totale

    655360 octets disponibles pour MS-DOS

    Taille du plus grand programme exécutable 637296

1048576 octets de mémoire paginée contiguë totale

         0 octet de mémoire paginée contiguë disponible

    405504 de mémoire XMS disponibles

           MS-DOS résident dans la zone de mémoire haute

  • La mémoire conventionnelle totale correspond à la quantité de mémoire virtuelle allouée au sous-système MS-DOS jusqu'aux premiers 640 Ko.
  • Les octets disponibles pour MS-DOS représentent la quantité de mémoire conventionnelle allouée, y compris la mémoire nécessaire à Cmd.exe.
  • La taille du plus grand programme exécutable représente le plus grand bloc contigu de mémoire conventionnelle disponible pour un programme.
  • La mémoire paginée totale (non indiquée dans l'exemple précédent) représente la quantité de mémoire paginée configurée pour le sous-système MS-DOS.
  • La mémoire paginée disponible (non indiquée dans l'exemple précédent) représente la quantité de mémoire paginée disponible pour les programmes.
  • La mémoire étendue contiguë totale représente la quantité de mémoire au-delà de 1 mégaoctet (Mo).
  • La mémoire étendue contiguë disponible est la mémoire étendue disponible pour l'interface d'interruption 15h. Cette mémoire n'est pas gérée par un gestionnaire de mémoire étendue tel que Himem.sys. Certains anciens programmes utilisent ce modèle différent de mémoire étendue.
  • La mémoire XMS disponible représente la mémoire gérée par un gestionnaire de mémoire étendue (tel que Himem.sys) et disponible pour les programmes qui peuvent l'utiliser.


Mkdir

Crée un répertoire ou sous-répertoire.

Syntaxe

mkdir [Lecteur:]Chemin

md [Lecteur:]Chemin

Paramètres

Lecteur:
Désigne le lecteur dans lequel vous voulez créer le répertoire.
Chemin
Obligatoire. Indique le nom et l'emplacement du nouveau répertoire. La longueur maximale d'un chemin est déterminée par le système de fichiers.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Lorsque vous activez les extensions de commande (ce qui est le cas par défaut), vous pouvez utiliser une seule commande mkdir pour créer des répertoires intermédiaires dans un chemin spécifié. Pour plus d'informations sur l'activation et la désactivation des extensions de commande, consultez cmd dans les Rubriques connexes.

Exemples

Pour créer un répertoire nommé Taxes et un sous-répertoire de ce dernier nommé Propriété contenant un sous-répertoire Courant, tapez :

mkdir \Taxes\Propriété\Courant

Cela équivaut à taper la suite de commandes ci-dessous quand les extensions de commande sont désactivées :

mkdir \Taxes
chdir \Taxes
mkdir Propriété
chdir Propriété
mkdir Courant XOX


Mmc

Ouvre la console MMC (Microsoft Management Console). À l'aide des options de la ligne de commande pour la commande mmc, vous pouvez ouvrir une console MMC spécifique, ouvrir MMC en mode auteur ou spécifier que la version 32 bits ou 64 bits de MMC est ouverte.

Syntaxe

mmc Chemin\nomfichier.msc [/a] [/64] [/32]

Paramètres

Chemin\nomfichier.msc
Démarre MMC et ouvre une console enregistrée. Vous devez spécifier le chemin d'accès et le nom complets du fichier de console enregistré. Si vous n'indiquez aucun nom de fichier de console, MMC ouvre une nouvelle console.
/a
Ouvre une console enregistrée en mode auteur. Permet d'apporter des modifications aux consoles enregistrées.
/64
Ouvre la version 64 bits de la console MMC (MMC64). Utilisez cette option si vous exécutez Windows XP Édition 64 bits uniquement.
/32
Ouvre la version 32 bits de la console MMC (MMC32). Lorsque vous exécutez Windows XP Édition 64 bits, vous pouvez exécuter des composants logiciels enfichables 32 bits en ouvrant MMC avec cette option de la ligne de commande.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Utilisation de l'option Chemin\nomfichier.msc de la ligne de commande

    Vous pouvez utiliser des variables d'environnement pour créer des lignes de commande ou des raccourcis qui ne dépendent pas de l'emplacement explicite des fichiers de console. Ainsi, si le chemin d'accès à un fichier de console se trouve dans le dossier système (mmc c:\winnt\system32\console_name.msc par exemple), vous pouvez utiliser la chaîne de données extensible %systemroot% pour spécifier l'emplacement (mmc %systemroot%\system32\console_name.msc). Cela peut s'avérer utile si vous devez déléguer des tâches à des membres de votre organisation qui travaillent sur différents ordinateurs.

  • Utilisation de l'option /a de la ligne de commande

    Lorsque les consoles sont ouvertes avec cette option, elles sont en mode auteur, indépendamment de leur mode par défaut. Cette option ne modifie pas définitivement le mode par défaut des fichiers. Lorsque cette option est omise, MMC ouvre les fichiers de console conformément au mode par défaut affecté à chacun d'eux.

  • Après avoir ouvert MMC ou un fichier de console en mode auteur, vous pouvez ouvrir n'importe quelle console existante en cliquant sur Ouvrir dans le menu Console.
  • Vous pouvez utiliser la ligne de commande pour créer des raccourcis permettant d'ouvrir MMC et les consoles enregistrées. Une commande de la ligne de commande fonctionne avec la commande Exécuter du menu Démarrer et dans tout raccourci, fenêtre d'invite de commandes, fichier de commandes ou programme faisant appel à cette commande.


Mode

Affiche l'état du système, modifie les paramètres du système ou reconfigure des ports ou des périphériques. Utilisée sans paramètre, la commande mode affiche tous les attributs contrôlables de la console et les périphériques COM disponibles. Comme la commande mode peut réaliser un grand nombre de tâches différentes, la syntaxe requise pour chacune d'entre elles est différente. Cliquez sur la tâche que vous souhaitez réaliser.

Pour configurer un port de communications série

Syntaxe

mode com m[:] [baud=b] [parity=p] [data=d] [stop=s] [to={on|off}] [xon={on|off}] [odsr={on|off}] [octs={on|off}] [dtr={on|off|hs}] [rts={on|off|hs|tg}] [idsr={on|off}]

Paramètres

com m[:]
Indique le numéro du port de communications asynchrones (COM).
baud=b
Spécifie la vitesse de transmission en bits par seconde. Le tableau suivant indique chacune des abréviations correctes de b et la vitesse de transmission associée :
Valeur | Vitesse
11 | 110 bauds
15 | 150 bauds
30 | 300 bauds
60 | 600 bauds
12 | 1200 bauds
24 | 2400 bauds
48 | 4800 bauds
96 | 9600 bauds
19 | 19 200 bauds
parity=p
Spécifie la manière dont le système utilise le bit de parité pour contrôler les erreurs de transmission. Le tableau suivant répertorie les valeurs valides de p. La valeur par défaut est e. Tous les ordinateurs ne prennent pas en charge les valeurs m et s.
Valeur | Description
n | aucune
e | paire
o | impaire
m | marque
s | espace
data=d
Spécifie le nombre de bits de données d'un caractère. Les valeurs valides de d s'échelonnent de 5 à 8. La valeur par défaut est 7. Tous les ordinateurs ne prennent pas en charge les valeurs 5 et 6.
stop=s
Spécifie le nombre de bits d'arrêt qui définissent la fin d'un caractère : 1, 1,5 ou 2. Si le débit en bauds est 110, la valeur par défaut est 2 ; sinon, la valeur par défaut est 1. Tous les ordinateurs ne prennent pas en charge la valeur 1,5.
to={on|off}
Indique si un délai de coupure est activé ou non. L'option par défaut est off.
xon={on|off}
Indique si le protocole xon ou xoff de contrôle de flux des données est activé ou désactivé.
odsr={on|off}
Indique si le protocole de sortie qui utilise le circuit modem prêt (DSR, Data Set Ready) est activé ou non.
octs={on|off}
Indique si le protocole de sortie qui utilise le circuit prêt à émettre (CTS, Clear To Send) est activé ou non.
dtr={on|off|hs}
Indique si le circuit terminal de données prêt (DTR, Data Terminal Ready) est activé ou non, ou établi par le protocole.
rts={on|off|hs|tg}
Indique si le circuit demande pour émettre (RTS, Request To Send) est activé, désactivé, protocole ou bascule.
idsr={on|off}
Indique si la communication est sensible ou non au circuit modem prêt (DSR).
/?
Affiche l'aide à l'invite de commandes.

Pour afficher l'état de tous les périphériques ou d'un seul.

Syntaxe

mode [périphérique] [/status]

Paramètres

périphérique
Indique le nom du périphérique dont vous voulez afficher l'état.
/status
Sollicite l'état de toute imprimante parallèle redirigée. Vous pouvez abréger l'option /status en /sta.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Utilisée sans paramètre, la commande mode affiche l'état de tous les périphériques installés sur votre système.

Pour rediriger les données de sortie d'un port parallèle vers un port de communications série

Syntaxe

mode lpt n[:]=com m[:]

Paramètres

lpt n
Obligatoire. Spécifie le port parallèle. Les valeurs valides de n vont de 1 à 3.
com m[:]
Obligatoire. Spécifie le port série. Les valeurs valides de m vont de 1 à 4.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Pour rediriger l'impression, vous devez être membre du groupe Administrateurs.

Exemples

Pour configurer votre système pour qu'il envoie des sorties d'imprimante parallèle vers une imprimante série, vous devez utiliser deux fois la commande mode. La première fois, vous utilisez la commande mode pour configurer le port série. La seconde fois, vous l'utilisez pour rediriger les données de sortie de l'imprimante parallèle vers le port série spécifié dans la première commande mode.

Par exemple, si votre imprimante série travaille à 4 800 bauds avec la parité paire et si elle est raccordée au port COM1 (première connexion série de votre ordinateur), tapez :

mode com1 48,e,,,b
mode lpt1=com1

Si vous redirigez les données de sortie d'une imprimante parallèle de LPT1 à COM1, mais décidez ensuite d'imprimer un fichier au moyen de LPT1, tapez la commande suivante avant d'imprimer le fichier.

mode lpt1

Cette commande empêche la redirection du fichier de LPT1 vers COM1.

Pour sélectionner, actualiser ou afficher les numéros des pages de codes de la console.

Syntaxe

mode périphérique codepage select=yyy

mode périphérique codepage [/status]

Paramètres

périphérique
Obligatoire. Spécifie le périphérique pour lequel vous voulez sélectionner une page de codes. CON est le seul nom valide pour un périphérique.
codepage select=
Obligatoire. Spécifie la page de codes à utiliser avec le périphérique spécifié. Vous pouvez abréger codepage et select respectivement sous les formes cp et sel.
yyy
Obligatoire. Indique le numéro de la page de codes à sélectionner. Le tableau suivant répertorie les pages de codes prises en charge et le paramètre de Pays/région ou de langue associé.
Valeur | Pays/région
437 | États-Unis
850 | Multilingue (Latin I)
852 | Slave (Latin II)
855 | Cyrillique (Russe)
857 | Turc
860 | Portugais
861 | Islandais
863 | Français (Canada)
865 | Nordique
866 | Russe
869 | Grec moderne
codepage
Obligatoire. Affiche les numéros des pages de codes éventuellement sélectionnées pour le périphérique spécifié.
/status
Affiche les numéros des pages de codes en cours sélectionnées pour le périphérique spécifié. Vous pouvez abréger /status en /sta. Que vous spécifiiez ou non /status, mode codepage affiche les numéros des pages de codes qui sont sélectionnées pour le périphérique spécifié.
/?
Affiche l'aide à l'invite de commandes.

Pour modifier la taille de la zone tampon de l'écran d'invite de commandes

Syntaxe

mode con[:] [cols=c] [lines=n]

Paramètres

con[:]
Obligatoire. Indique que le changement s'applique à la fenêtre d'invite de commandes.
cols=c
Spécifie le nombre de caractères (colonnes) définissant la largeur dans la zone tampon de l'écran d'invite de commandes.
lines=n
Spécifie le nombre de lignes définissant la hauteur de la zone tampon de l'écran d'invite de commandes.
/?
Affiche l'aide à l'invite de commandes.

Pour définir la vitesse de répétition du clavier

Syntaxe

mode con[:] [rate=r delay=d]

Paramètres

con[:]
Obligatoire. Se réfère au clavier.
rate=r
Indique la vitesse à laquelle un caractère se répète à l'écran lorsque vous maintenez une touche enfoncée.
delay=d
Spécifie l'intervalle de temps au bout duquel le caractère en sortie commence à se répéter lorsque vous maintenez une touche enfoncée.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Le délai de répétition automatique du clavier correspond à la vitesse à laquelle un caractère se répète lorsque vous maintenez la touche correspondante enfoncée. La vitesse de répétition du clavier se compose de deux éléments, la vitesse proprement dite et le délai d'attente. Cette commande n'est pas reconnue par tous les claviers.
  • Utilisation de l'option rate=r

    Les valeurs valides vont de 1 à 32, ce qui correspond respectivement à 2 et 30 caractères par seconde environ. La valeur par défaut est 20 pour les claviers compatibles IBM AT et 21 pour les claviers compatibles IBM PS/2. Si vous définissez la vitesse, vous devez également préciser le délai d'attente.

  • Utilisation de l'option delay=d

    Les valeurs valides de d sont 1, 2, 3 et 4 (ce qui représente respectivement 0,25, 0,50, 0,75 et 1 seconde). La valeur par défaut est 2. Si vous définissez le délai, vous devez également préciser la vitesse.


More

Affiche un écran de sortie à la fois.

Syntaxe

commande | more [/c] [/p] [/s] [/t n] [+n]

more [[/c] [/p] [/s] [/t n] [+n]] < [Lecteur:] [Chemin] NomFichier

more [/c] [/p] [/s] [/t n] [+n] [fichiers]

Paramètres

[Lecteur:] [Chemin] NomFichier
Désigne le fichier à afficher.
commande
Spécifie la commande dont vous souhaitez afficher les résultats.
/c
Efface l'écran avant d'afficher une page.
/p
Développe les caractères de saut de page.
/s
Remplace des lignes blanches multiples par une seule.
/t n
Remplace les tabulations par le nombre d'espaces spécifié par n.
+n
Affiche le premier fichier commençant à la ligne spécifiée par n.
fichiers
Spécifie la liste de fichiers à afficher. Séparez les noms des fichiers par des espaces.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Utilisation de la commande more sur la console de récupération

    La commande more est disponible, avec des paramètres différents, à partir de la console de récupération.

  • Utilisation des sous-commandes more

    Les commandes suivantes sont acceptées à l'invite more (-- Suite --) .

    Touche | Action
    ESPACE | Affiche la page suivante
    ENTRÉE | Affiche la ligne suivante
    f | Affiche le fichier suivant
    q | Quitte
    ? Affiche les commandes disponibles
    = Affiche le numéro de ligne
    p n | Affiche les n lignes suivantes
    s n | Saute les n lignes suivantes
  • Sources de données

    Lorsque vous utilisez le caractère de redirection (<), vous devez spécifier un nom de fichier comme source. Lorsque vous employez la barre verticale (|), vous pouvez utiliser des commandes telles que dir, sort et type.

Exemples

Pour afficher à l'écran le fichier nommé Clients.nou, tapez l'une ou l'autre des commandes suivantes :

more < clients.nou

type clients.nou | more

La commande more affiche le premier écran d'informations de Clients.nou, puis présente le message suivant :

-- Suite --

Vous pouvez alors appuyer sur la touche ESPACE pour afficher l'écran d'informations suivant.

Pour effacer l'écran et supprimer toutes les lignes blanches superflues avant d'afficher le fichier Clients.nou, tapez l'une ou l'autre des commandes suivantes :

more /c /s < clients.nou

type clients.nou | more /c /s

La commande more affiche le premier écran d'informations de Clients.nou, puis présente le message suivant :

-- Suite --

Pour afficher le fichier une ligne à la fois, appuyez sur ENTRÉE.

Pour afficher la page suivante, appuyez sur ESPACE.

Pour afficher le prochain fichier indiqué sur la ligne de commande, tapez f.

Pour quitter more, tapez q.

Ajoutez des commandes à l'invite more comme le montre l'exemple suivant :

-- Suite [Options: psfq=<space><ret>] --

Pour afficher le numéro de la ligne en cours, tapez =. Le numéro de la ligne en cours est ajouté à l'invite more, comme le montre l'exemple suivant :

-- Suite [Line: 24] --

Pour afficher un nombre précis de lignes, tapez p. More vous demande le nombre de lignes à afficher de la manière suivante :

-- Suite -- Lignes:

Tapez le nombre de lignes à afficher et appuyez sur ENTRÉE. La commande more affiche le nombre de lignes indiqué.

Pour sauter un nombre précis de lignes, tapez s. More vous demande le nombre de lignes à sauter de la manière suivante :

-- Suite -- Lignes:

Tapez le nombre de lignes à ignorer et appuyez sur ENTRÉE. La commande more ignore le nombre de lignes indiqué et affiche l'écran d'informations suivant.


Mountvol

Crée, supprime ou répertorie le point de montage d'un volume. Mountvol permet de lier des volumes sans avoir recours à une lettre de lecteur.

Syntaxe

mountvol [Lecteur:]Chemin NomVolume

mountvol [Lecteur:]Chemin /d

mountvol [Lecteur:]Chemin /L

mountvol Lecteur: /s

Paramètres

[Lecteur:]Chemin
Spécifie le dossier du répertoire NTFS existant où résidera le point de montage.
NomVolume
Indique le nom de volume qui correspond à la cible du point de montage. Le nom de volume est de la forme \\?\Volume{GUID}\, où {GUID} est un globally unique identifier (GUID) (par exemple, \\?\Volume\{2eca078d-5cbc-43d3-aff8-7e8511f60d0e}\).
/d
Supprime le point de montage du volume dans le dossier spécifié.
/L
Affiche la liste des noms de volume du dossier spécifié.
/s
Ordinateurs Itanium uniquement. Monte la Partition système EFI sur le lecteur spécifié.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Si vous n'avez plus de lettres de lecteur disponibles, montez vos volumes locaux sans lettre de lecteur.
  • Si vous devez augmenter l'espace d'un volume sans reformater ni remplacer un disque dur, vous pouvez ajouter un chemin de montage vers un autre volume.
  • Cette méthode s'avère utile quand vous utilisez un même volume avec plusieurs chemins de montage, car elle permet d'accéder à tous les volumes locaux à l'aide d'une seule lettre de lecteur (par exemple, C:). Il n'est pas nécessaire de mémoriser la correspondance entre volumes et lettres de lecteur ; vous pouvez néanmoins monter des volumes locaux en les assignant à des lettres de lecteur.


Move

Transfère un ou plusieurs fichiers d'un répertoire vers le répertoire spécifié.

Syntaxe

move [{/y|/-y}] [Source] [cible]

Paramètres

/y
Supprime la confirmation de remplacement d'un fichier de destination existant.
/-y
Demande la confirmation de remplacement d'un fichier de destination existant.
Source
Indique le chemin d'accès et le nom du ou des fichiers à transférer. Si vous souhaitez transférer ou renommer un répertoire, Source doit contenir le nom et le chemin du répertoire en cours.
cible
Indique le chemin d'accès et le nom de la destination des fichiers transférés. Si vous souhaitez transférer ou renommer un répertoire, cible doit contenir le nom et le chemin du répertoire souhaité.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Utilisation de l'option /y de la ligne de commande

    L'option /y de la ligne de commande peut être prédéfinie dans la variable d'environnement COPYCMD. Cette option peut être annulée en spécifiant /-y sur la ligne de commande. Par défaut, vous êtes invité à confirmer le remplacement, sauf si la commande copy est exécutée à partir d'un script de commande.

  • Déplacement de fichiers cryptés

    Une tentative de transfert de fichiers cryptés vers un volume qui ne prend pas en charge le système de fichiers de cryptage (EFS) provoque une erreur. Décryptez les fichiers au préalable ou déplacez-les vers un volume qui prend en charge EFS.

Exemples

Pour déplacer tous les fichiers portant l'extension .xls du répertoire \Données vers le répertoire \Second_Q\Rapports, tapez :

move \données\*.xls \second_q\rapports\


Msiexec

Permet d'installer ou modifier un produit ou d'effectuer d'autres opérations dans Windows Installer à partir de la ligne de commande.

Pour installer ou configurer un produit

Syntaxe

msiexec /i {package|CodeProduit}

Paramètres

/i
Installe ou configure un produit.
package
Spécifie le nom du fichier de package Windows Installer.
CodeProduit
Spécifie l'identificateur global unique (GUID) du package d'installation de Windows Installer.

Notes

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

Pour installer un produit à partir de A:\Example.msi, tapez :

msiexec /i A:\Example.msi

Pour utiliser l'option d'installation administrative

Syntaxe

msiexec /a package

Paramètres

/a
Applique l'option d'installation administrative
package
Nom du fichier de package Windows Installer.

Notes

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Pour réparer un produit

Syntaxe

msiexec /f [p][o][e][d][c][a][u][m][s][v]{package|CodeProduit}

Paramètres

/f
Active une ou plusieurs des options de la ligne de commande répertoriées dans le tableau suivant.
Commande | Description
p | Procède à la réinstallation uniquement si le fichier est absent.
o | Procède à la réinstallation si le fichier est absent ou si une version antérieure est installée.
e | Procède à la réinstallation si le fichier est absent ou si une version égale ou antérieure est installée.
d | Procède à la réinstallation si le fichier est absent ou si une version différente est installée.
c | Procède à la réinstallation si le fichier est absent ou si la somme de contrôle stockée ne correspond pas à la valeur calculée.
a | Force la réinstallation de tous les fichiers.
u | Réécrit toutes les entrées de Registre spécifiques à l'utilisateur.
m | Réécrit toutes les entrées de Registre spécifiques à l'ordinateur
s | Remplace tous les raccourcis existants.
v | S'exécute à partir de la source et remet en mémoire cache le package local.
package
Nom du fichier de package Windows Installer.
CodeProduit
Identificateur global unique (GUID) du package d'installation Windows Installer.

Notes

  • Cette option ignore toutes les valeurs de propriétés que vous tapez sur la ligne de commande.
  • Cette option de ligne de commande prend par défaut la valeur /fpecms.
  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

Pour réparer le package d'installation, tapez :

msiexec /fpecms Example.msi

Pour désinstaller un produit

Syntaxe

msiexec /x {package|CodeProduit}

Paramètres

/x
Désinstalle un produit.
package
Nom du fichier de package Windows Installer.
CodeProduit
Identificateur global unique (GUID) du package d'installation Windows Installer.

Notes

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

Pour supprimer ou désinstaller un package, tapez :

msiexec /x Example.msi

Pour annoncer un produit

Syntaxe

msiexec /j [{u|m}] package

msiexec {u|m} package /t ListeTransform

msiexec {u|m} package /g IDLangue

Paramètres

/j
Annonce un produit.
u
Annonce le produit à l'utilisateur en cours.
m
Annonce le produit à tous les utilisateurs de l'ordinateur.
package
Spécifie le fichier de package Windows Installer.
/g IDLangue
Identifie la langue.
/t ListeTransform
Applique la transformation au package d'installation annoncé.

Notes

  • Cette option ignore toutes les valeurs de propriétés que vous tapez sur la ligne de commande.
  • Si vous souhaitez installer l'application avec des droits élevés, utilisez /jm.
  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

Pour annoncer un package à tous les utilisateurs de l'ordinateur local, tapez :

msiexec /jm Example.msi

Pour annoncer un package à tous les utilisateurs de l'ordinateur local, tapez :

msiexec /jm Example.msi

Pour définir un niveau de journalisation

Syntaxe

msiexec /L [i][w][e][a][r][u][c][m][p][v][+][!]FichierJournal.txt

Paramètres

/L
Spécifie le chemin d'accès du fichier journal.
i
Enregistre dans le journal les messages d'état.
w
Enregistre dans le journal les avertissements récupérables.
e
Enregistre dans le journal tous les messages d'erreur.
a
Enregistre dans le journal les actions démarrées.
r
Enregistre dans le journal des informations spécifiques aux actions.
u
Enregistre dans le journal les demandes des utilisateurs.
c
Enregistre dans le journal les paramètres initiaux de l'interface utilisateur.
m
Enregistre dans le journal les cas de mémoire insuffisante.
p
Enregistre dans le journal les propriétés du terminal.
v
Enregistre dans le journal des données détaillées. Pour utiliser l'option v, spécifiez /L*v.
+
Ajoute au fichier journal existant.
!
Force l’écriture de chaque ligne dans le fichier journal.
*
Enregistre toutes les informations dans le journal, à l'exception de l'option v. Il s'agit d'un caractère générique.
FichierJournal.txt
Nom et chemin du fichier texte du journal.

Notes

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour insérer l'option v dans un fichier journal à l'aide de l'indicateur de caractère générique, tapez /L*v à l'invite de commande.
  • Les options du fichier journal de Windows Installer peuvent aussi être utilisées avec les processus de désinstallation et de réparation.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

Pour installer un package d'installation et créer un fichier journal contenant des informations d'état ou relatives à l'insuffisance de la mémoire ainsi que les messages d'erreur, tapez :

msiexec /i Example.msi /Lime logfile.txt

Pour appliquer un correctif

Syntaxe

msiexec /p PackageCorrectif

Paramètres

/p
Applique un correctif.
PackageCorrectif
Spécifie le correctif à appliquer.

Notes

  • Pour appliquer un correctif à un package d'installation administrative, utilisez la syntaxe suivante :

    msiexec /p PackageCorrectif /a Exemple.msi

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Pour installer une transformation à l'aide de la ligne de commande

Syntaxe

msiexec /i package TRANSFORMS=ListeTransform

Paramètres

/i
Installe ou configure un produit.
package
Spécifie le fichier de package Windows Installer.
TRANSFORMS=
Propriété utilisée pour spécifier les fichiers de transformation (.mst) à appliquer au package.
ListeTransform
Liste de chemins séparés par des points-virgules.

Notes

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Pour installer et publier un produit avec une transformation à l'aide de la ligne de commande

Syntaxe

msiexec /i package /j[u][m] /t ListeTransform

Paramètres

/i
Installe ou configure un produit.
package
Nom du fichier de package Windows Installer.
/j
Annonce un produit. Cette option ignore toute valeur de propriété entrée dans la ligne de commande.
u
Annonce le produit à l'utilisateur en cours.
m
Annonce le produit à tous les utilisateurs de l'ordinateur.
/t
Applique la transformation au package d'installation annoncé.
ListeTransform
Liste de chemins séparés par des points-virgules.

Notes

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Pour définir le niveau d'interface utilisateur

Syntaxe

msiexec /q{n|b|r|f|n+|b+|b-}

Paramètres

/qn
N'affiche aucune interface utilisateur.
/qb
Affiche une interface utilisateur de base.
/qr
Affiche une interface utilisateur réduite avec une boîte de dialogue modale à la fin de l'installation.
/qf
Affiche l'interface utilisateur intégrale avec une boîte de dialogue modale à la fin.
/qn+
N'affiche aucune interface utilisateur à l'exception de la boîte de dialogue modale à la fin.
/qb+
Affiche l'interface utilisateur de base avec une boîte de dialogue modale à la fin.
/qb-
Affiche une interface utilisateur de base sans aucune boîte de dialogue modale.

Notes

  • /qb+- n'est pas un niveau d'interface utilisateur pris en charge. La boîte de dialogue modale ne s'affiche pas si l'utilisateur annule l'installation.
  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

Pour afficher les options de l'interface utilisateur de base pendant l'installation du package Example.msi, tapez :

msiexec /qb Example.msi

Pour afficher les informations de copyright de Windows Installer

Syntaxe

msiexec {/?|/h}

Paramètres

{/?|/h}
Affiche les informations de copyright et la version de Windows Installer.

Notes

  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Appeler le système API DllRegisterServer pour auto-inscrire les modules passés dans la ligne de commande

Syntaxe

msiexec /y module

Paramètres

/y
Appelle l'API système DllRegisterServer pour auto-enregistrer les modules passés dans la ligne de commande.
module
Spécifie le nom de fichier du module.

Notes

  • Cette option est utilisée uniquement pour les informations de Registre qui ne peuvent pas être ajoutées à l'aide des tables de Registre du fichier .msi.
  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

L'exemple suivant montre comment utiliser la commande msiexec /y :

msiexec /y mon_fichier.dll

Appeler le système API DllUnRegisterServer pour désinscrire les modules passés dans la ligne de commande

Syntaxe

msiexec /z module

Paramètres

/z
Appelle l'API système DllUnRegisterServer pour annuler l'enregistrement des modules passés dans la ligne de commande.
module
Nom de fichier du module.

Notes

  • Cette option est utilisée uniquement pour les informations de Registre qui ne peuvent pas être ajoutées à l'aide des tables de Registre du fichier .msi.
  • Les options de ligne de commande de Windows Installer ne respectent pas la casse.
  • Pour plus d'informations sur les options de ligne de commande de Windows Installer, consultez les Rubriques connexes.

Exemples

L'exemple suivant montre comment utiliser la commande msiexec /z :

msiexec /z mon_fichier.dll


Msinfo32

Affiche une vue détaillée de votre matériel, des composants système et de l'environnement logiciel.

Syntaxe

msinfo32 [/?] [/pch] [/nfo NomFichier] [/report NomFichier] [/computer NomOrdinateur] [/showcategories] [/category IDcatégorie] [/categories IDcatégorie]

Paramètres

NomFichier
Spécifie le fichier à ouvrir. Il peut s'agir d'un fichier .nfo, .xml, .txt ou .cab.
/?
Affiche l'aide relative à la commande msinfo32.
/pch
Affiche la vue Historique.
/nfo NomFichier
Enregistre le fichier exporté en tant que fichier .nfo.
/report NomFichier
Enregistre le fichier exporté en tant que fichier .txt.
/computer NomOrdinateur
Démarre les Informations système pour l'ordinateur distant spécifié.
/showcategories
Démarre les Informations système avec tous les ID de catégorie disponibles affichés.
/category IDcatégorie
Démarre les Informations système en sélectionnant la catégorie spécifiée. Utilisez /showcategories pour afficher la liste des ID de catégorie disponibles.
/categories IDcatégorie
Démarre les Informations système en affichant uniquement la ou les catégories spécifiées. Ce paramètre limite également les résultats aux catégories spécifiées. Utilisez /showcategories pour afficher la liste des ID de catégorie disponibles.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Certaines catégories d'informations système contiennent de grandes quantités de données. Vous pouvez utiliser la commande start /wait pour optimiser les performances de création du rapport pour ces catégories. Pour plus d'informations, consultez les Rubriques connexes.

Exemples

Pour afficher la liste des ID de catégorie disponibles, tapez :

msinfo32 /showcategories

Pour démarrer les Informations système en affichant toutes les informations disponibles à l'exception des modules chargés, tapez :

msinfo32 /categories +all -loadedmodules

Pour afficher uniquement les informations de la catégorie Résumé système et créer un fichier nommé syssum.nfo contenant ces informations, tapez :

msinfo32 /nfo syssum.nfo /categories +systemsummary

Pour afficher uniquement les informations relatives aux conflits de ressources et créer un fichier nommé conflicts.nfo contenant ces informations, tapez :

msinfo32 /nfo conflicts.nfo /categories +componentsproblemdevices+resourcesconflicts+resourcesforcedhardware


Nbtstat

Affiche les statistiques du protocole NetBIOS sur TCP/IP (NetBT), les tables de noms NetBIOS associées à l'ordinateur local et aux ordinateurs distants ainsi que le cache de noms NetBIOS. Nbtstat permet d'actualiser le cache de noms NetBIOS et les noms inscrits avec le service de nom Internet Windows (WINS). Utilisée sans paramètres, la commande nbtstat affiche l'aide.

Syntaxe

nbtstat [-a NomDistant] [-A AdresseIP] [-c] [-n] [-r] [-R] [-RR] [-s] [-S] [Intervalle]

Paramètres

-a NomDistant
Affiche la table de noms NetBIOS d'un ordinateur distant, NomDistant étant le nom NetBIOS de l'ordinateur distant. La table de noms NetBIOS est la liste de noms NetBIOS correspondant aux applications NetBIOS qui s'exécutent sur l'ordinateur.
-A AdresseIP
Affiche la table de noms NetBIOS d'un ordinateur distant spécifié par son adresse IP (en notation décimale pointée).
-c
Affiche le contenu du cache de noms NetBIOS, la table de noms NetBIOS et les adresses IP correspondantes.
-n
Affiche la table de noms NetBIOS de l'ordinateur local. L'état Inscrit indique que le nom a été inscrit, par diffusion ou à l'aide d'un serveur WINS.
-r
Affiche les statistiques de la résolution de noms NetBIOS. Sur un ordinateur Windows XP configuré pour utiliser WINS, ce paramètre renvoie le nombre de noms qui ont été résolus et inscrits par diffusion et par WINS.
-R
Purge le contenu du cache de noms NetBIOS, puis charge à nouveau les entrées #PRE-tagged à partir du fichier Lmhosts.
-RR
Libère, puis actualise les noms NetBIOS pour l'ordinateur local inscrit par des serveurs WINS.
-s
Affiche les sessions NetBIOS client et serveur en essayant de convertir l'adresse IP de destination en nom.
-S
Affiche les sessions NetBIOS client et serveur, en répertoriant les ordinateurs distants par adresse IP de destination uniquement.
Intervalle
Répète l'affichage des statistiques sélectionnées en observant une pause égale à Intervalle secondes entre chaque affichage. Appuyez sur CTRL+C pour interrompre l'affichage des statistiques. Si ce paramètre est omis, nbtstat n'imprime qu'une seule fois les informations de configuration.
/?
Affiche l'aide à l'invite de commandes.

Notes

  • Les paramètre de la ligne de commande nbtstat respectent la casse.
  • Le tableau suivant décrit les colonnes générées par nbtstat.
    Titre | Description
    Entrée | Nombre d'octets reçus.
    Sortie | Nombre d'octets envoyés.
    Ent/Sor | Indique le sens de la connexion : de l'ordinateur local vers un autre système (connexion sortante) ou d'un autre système vers l'ordinateur local (connexion entrante).
    Vie | Temps restant avant la purge d'une entrée du cache de table des noms.
    Nom local | Nom NetBIOS local associé à la connexion.
    Hôte distant | Nom ou adresse IP associé à l'ordinateur distant.
    <03> | Dernier octet d'un nom NetBIOS converti en notation hexadécimale. Chaque nom NetBIOS contient 16 caractères. Le dernier octet revêt souvent une importance particulière dans la mesure où un même nom (au dernier octet près) peut apparaître plusieurs fois sur un ordinateur donné. Par exemple, <20> est un espace en texte ASCII.
    Type | Type de nom. Il peut s'agir d'un nom unique ou d'un nom de groupe.
    Statut | Indique si le service NetBIOS de l'ordinateur distant est actif (Inscrit) ou si un nom d'ordinateur identique a enregistré le même service (Conflit).
    État | État des connexions NetBIOS.
  • Le tableau suivant décrit les états de connexion NetBIOS possibles.
    État | Description
    Connecté | Une session est établie.
    Associé | Un point terminal de la connexion a été créé et associé à une adresse IP.
    Écoute | Ce point terminal est disponible pour une connexion entrante.
    Inactif | Ce point terminal a été ouvert, mais ne peut pas être connecté.
    Connexion | Une session est en phase de connexion et le mappage du nom de la destination en adresse IP est en cours de résolution.
    Acceptation | Une session entrante est en cours de validation et la connexion est imminente.
    Reconnecter | Une session tente de se reconnecter (après l'échec de la première tentative).
    Sortant | Une session est en phase de connexion et la connexion TCP est en cours de création.
    Entrant | Une session entrante est en phase de connexion.
    Déconnexion | Une session est en phase de déconnexion.
    Déconnecté | L'ordinateur local a demandé une déconnexion et attend la confirmation du système distant.
  • Cette commande est disponible uniquement si le Protocole Internet (TCP/IP) est installé comme composant dans les propriétés d'une carte réseau dans Connexions réseau.

Exemples

Pour afficher la table de noms NetBIOS de l'ordinateur distant dont le nom NetBIOS est CORP07, tapez :

nbtstat -a CORP07

Pour afficher la table de noms NetBIOS de l'ordinateur distant dont l'adresse IP est 10.0.0.99, tapez :

nbtstat -A 10.0.0.99

Pour afficher la table de noms NetBIOS de l'ordinateur local, tapez :

nbtstat -n

Pour afficher le contenu du cache de noms NetBIOS de l'ordinateur local, tapez :

nbtstat -c

Pour purger le cache de noms NetBIOS et recharger les entrées #PRE-tagged du fichier Lmhosts local, tapez :

nbtstat -R

Pour libérer les noms NetBIOS inscrits avec le serveur WINS et les inscrire à nouveau, tapez :

nbtstat -RR

Pour afficher les statistiques de session NetBIOS par adresse IP toutes les cinq secondes, tapez :

nbtstat -S 5


Net accounts

Met à jour la base de données des comptes d'utilisateurs et modifie les paramètres de mot de passe et d'ouverture de session exigés pour tous les comptes.

Syntaxe

net accounts [/forcelogoff:{minutes | no}] [/minpwlen:longueur] [/maxpwage:{jours| unlimited}] [/minpwage:jours] [/uniquepw:nombre] [/domain]

Paramètres

/forcelogoff:{minutes | no}
Définit le délai (en minutes) devant s'écouler avant que ne soit fermée la session d'un utilisateur sur un serveur lorsque le compte d'utilisateur ou le temps d'ouverture de session valide expire. La valeur par défaut, no, empêche que les utilisateurs soient forcés de fermer la session.
/minpwlen:longueur
Fixe le nombre minimal de caractères pour le mot de passe d'un compte d'utilisateur. Les valeurs peuvent être comprises dans une plage allant de 0 à 127 caractères et la longueur par défaut est de 6 caractères.
/maxpwage{jours | unlimited}
Fixe la durée maximale de validité (en jours) du mot de passe d'un compte d'utilisateur. Avec la valeur unlimited, il n'y a pas de durée maximale. L'option de ligne de commande /maxpwage doit avoir une valeur supérieure à celle de /minpwage. Les valeurs peuvent être comprises dans une plage allant de 1 à 49 710 jours (unlimited étant égal à 49 710 jours), et la valeur par défaut est 90 jours.
/minpwage:jours
Fixe le délai minimal (en jours) devant s'écouler avant qu'un utilisateur puisse changer le mot de passe. La valeur par défaut est de zéro jour, qui ne définit aucune durée minimale. Les valeurs peuvent être comprises dans une plage allant de 0 à 49 710 jours.
/uniquepw:nombre
Interdit à un utilisateur de reprendre le même mot de passe au cours d'un nombre de changements de mot de passe spécifié. Les valeurs sont comprises dans une plage allant de 0 à 24 changements de mot de passe et la valeur par défaut est de 5 changements de mot de passe.
/domain
Exécute l'opération sur le contrôleur principal de domaine du domaine en cours. Sinon, l'opération est effectuée sur l'ordinateur local.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Le service Ouverture de session réseau doit être en cours d'exécution sur l'ordinateur pour lequel vous désirez modifier les paramètres de compte. Utilisée sans paramètre, la commande net accounts affiche les paramètres en cours relatifs au mot de passe, aux conditions d'ouverture de session et aux informations sur le domaine.
  • Vous devez effectuer les tâches suivantes avant de pouvoir utiliser la commande net accounts :
    • créer des comptes d'utilisateur, en utilisant le Gestionnaire des utilisateurs ou net user ;
    • exécuter le service Ouverture de session réseau sur tous les serveurs qui vérifient les ouvertures de session dans le domaine (ce service démarra automatiquement au démarrage du système).
  • Lorsque vous utilisez /forcelogoff:minutes, un avertissement est émis quelques minutes avant que les utilisateurs ne soient obligés de fermer la session réseau. Les utilisateurs sont également avertis au cas où des fichiers seraient ouverts. Quand minutes est inférieur à 2, le système avertit les utilisateurs pour qu'il ferme immédiatement sa session réseau.

Exemples

Pour afficher les paramètres en cours, les exigences relatives au mot de passe et le rôle de serveur pour un serveur, tapez :

net accounts

Pour que les mots de passe d'un compte d'utilisateur aient une longueur minimale de 7 caractères, tapez :

net accounts /minpwlen:7

Pour indiquer que les utilisateurs peuvent réutiliser un mot de passe uniquement après le cinquième changement de mot de passe, tapez :

net accounts /uniquepw:5

Pour empêcher les utilisateurs de changer de mot de passe à intervalles de moins de 7 jours, pour les forcer à changer de mot de passe tous les 30 jours et pour les forcer à fermer la session après l'expiration du temps d'ouverture de session en les avertissant 5 minutes à l'avance, tapez :

net accounts /minpwage:7 /maxpwage:30 /forcelogoff:5

Pour garantir que les paramètres précédents prennent effet pour le domaine dans lequel l'ordinateur a ouvert une session, tapez :

net accounts /minpwage:7 /maxpwage:30 /domain


Vue d'ensemble des services Net

De nombreux services utilisent des commandes réseau commençant par le mot net. Ces commandes possèdent certaines propriétés en commun :

  • Vous pouvez afficher la liste des commandes net disponibles en tapant net /? à l'invite de commandes.
  • Vous pouvez obtenir de l'aide au niveau de la ligne de commande pour connaître la syntaxe d'une commande net en tapant net help commande à l'invite de commandes. Par exemple, pour obtenir de l'aide sur la commande net accounts, tapez ceci :

    net help accounts

  • Toutes les commandes net acceptent les options de ligne de commande /y (oui) et /n (non). Par exemple, la commande net stop server vous invite à confirmer si vous souhaitez arrêter tous les services Serveur dépendants, tandis que net stop server /y contourne l'invite de confirmation en fournissant automatiquement la réponse « Oui » et arrête le service Serveur.
  • Si le nom d'un service contient des espaces, entourez le texte de guillemets (comme dans "nom service"). Par exemple, la ligne de commande suivante démarre le service Ouverture de session réseau :

    net start "net logon"

  • Pour plus d'informations sur les commandes des services Net, consultez Commandes de services Net.


Net computer

Ajoute ou supprime des ordinateurs dans une base de données de domaine.

Syntaxe

net computer \\nom_ordinateur {/add | /del}

Paramètres

\\nom_ordinateur
Spécifie l'ordinateur à ajouter ou supprimer dans le domaine.
{/add | /del}
Ajoute ou supprime l'ordinateur spécifié dans le domaine.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • La commande net computer transmet toutes les opérations d'ajout et de suppression d'ordinateur à un contrôleur de domaine.

Exemples

Pour ajouter l'ordinateur Dept_Compta à un domaine, tapez :

net computer \\Dept_Compta /add


Net config

Affiche les services configurables qui sont en cours d'exécution, ou affiche et modifie les paramètres relatifs à un service Serveur ou Station de travail. Utilisée sans paramètre, la commande net config affiche la liste des services configurables.

Syntaxe

net config [{server|workstation}]

Paramètres

server
Affiche les paramètres du service Serveur et vous permet d'y apporter des modifications alors qu'il est en cours d'exécution.
workstation
Affiche les paramètres du service Station de travail et vous permet d'y apporter des modifications alors qu'il est en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisez la commande net config server pour modifier les paramètres configurables du service Serveur. Les modifications entrent immédiatement en vigueur et sont permanentes.
  • La commande net config server ne permet pas de modifier tous les paramètres du service Serveur. Elle affiche les informations suivantes, qu'il n'est pas possible de configurer :
    • Nom du serveur ;
    • Commentaires du serveur ;
    • Version du logiciel (numéro de version du logiciel Serveur) ;
    • Serveur actif sur (description du réseau) ;
    • Serveur caché (paramètre /hidden) ;
    • Max. de sessions ouvertes (c'est-à-dire le nombre maximal d'utilisateurs qui peuvent utiliser des ressources partagées du serveur) ;
    • Max. de fichiers ouverts sur serveur (c'est-à-dire le nombre maximal de fichiers de serveur que les utilisateurs peuvent ouvrir durant une session) ;
    • Durée d'inactivité de session (en minutes).
  • Utilisez la commande net config workstation pour modifier les paramètres configurables du service Station de travail.
  • Net config workstation affiche les informations suivantes :
    • Nom de l'ordinateur ;
    • Nom complet de l'ordinateur ;
    • Nom d'utilisateur ;
    • Station active sur (description du réseau) ;
    • Version du logiciel (numéro de version du logiciel) ;
    • Domaine de station ;
    • Nom DNS du domaine de la station de travail ;
    • Domaine de connexion ;
    • Délai d'ouverture COM (s) ;
    • Compteur d'émission COM (octets) ;
    • Délai d'émission COM (ms).


Net continue

Relance l'exécution d'un service suspendue par la commande net pause.

Syntaxe

net continue service

Paramètres

service
Obligatoire. Spécifie le service dont vous souhaitez relancer l'exécution. Le tableau suivant répertorie l'ensemble des valeurs de service.
Valeur | Description
netlogon | Redémarre le service Ouverture de session réseau.
"nt lm security support provider" | Redémarre le service Fournisseur de la prise en charge de sécurité LM NT.
schedule | Redémarre le service Planificateur de tâches.
server | Redémarre le service Serveur.
workstation | Redémarre le service Station de travail.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Pour apporter une correction mineure à une ressource, suspendez l'exécution du service. Utilisez ensuite la commande net continue pour réactiver le service ou l'imprimante, sans annuler les connexions utilisateur.
  • Les effets de l'interruption et de la réactivation peuvent varier d'un service à l'autre.
  • Si le nom d'un service contient des espaces, entourez le texte de guillemets (comme dans "nom service").

Exemples

La commande suivante réactive le service Station de travail :

net continue workstation

Si le nom du service se compose de deux mots ou davantage, vous devez le placer entre guillemets. Par exemple, tapez ceci pour relancer l'exécution du service Fournisseur de la prise en charge de sécurité LM NT :

net continue "nt lm security support provider"


Net file

Affiche les noms de tous les fichiers partagés ouverts sur un serveur et, le cas échéant, le nombre de verrous sur chaque fichier. Cette commande permet également de fermer des fichiers partagés particuliers et d'enlever des verrous de fichier. Utilisée sans paramètre, la commande net file affiche la liste des fichiers ouverts sur un serveur.

Syntaxe

net file [ID [/close]]

Paramètres

ID
Spécifie le numéro d'identification du fichier.
/close
Ferme un fichier ouvert et libère les enregistrements verrouillés. Tapez cette commande à l'invite du serveur sur lequel le fichier est partagé.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Vous pouvez également taper net files pour exécuter cette commande.
  • Utilisez la commande net file pour afficher et gérer les fichiers partagés sur le réseau. Parfois, un utilisateur laisse un fichier partagé ouvert et verrouillé par erreur. Dans ce cas, les autres ordinateurs du réseau n'ont plus accès aux parties verrouillées du fichier en question. Utilisez la commande net file /close pour enlever le verrou et fermer le fichier. La sortie de net file se présente comme suit :

    Fichier      Chemin             Nom d'utilisateur    #verrous

    ---------------------------------------------

    0         C:\A_FILE.TXT    MARYSL      0

    1         C:\DATABASE      DEBBIET     2

Exemples

Pour afficher des informations au sujet de fichiers partagés, tapez :

net file

Pour fermer un fichier ayant pour numéro d'identification 1, tapez :

net file 1 /close


Net group

Ajoute, affiche ou modifie des groupes globaux dans des domaines.

Syntaxe

net group [nom_groupe [/comment:"texte"]] [/domain]

net group [nom_groupe {/add [/comment:"texte"] | /delete} [/domain]]

net group nom_groupe nom_utilisateur[ ...] {/add | /delete} [/domain]]

Paramètres

nom_groupe
Spécifie le nom du groupe à ajouter, développer ou supprimer. Indiquez un nom de groupe pour afficher la liste des utilisateurs qui en font partie.
/comment:"texte"
Ajoute un commentaire au sujet d'un groupe nouveau ou existant. Le commentaire peut être d'une longueur maximale de 48 caractères. Placez le texte entre guillemets.
/domain
Exécute l'opération sur le contrôleur principal de domaine du domaine en cours. Sinon, l'opération est effectuée sur l'ordinateur local.
/add
Ajoute un groupe ou ajoute un nom d'utilisateur à un groupe. Il faut qu'un compte soit établi pour chacun des utilisateurs ajoutés à un groupe par cette commande.
/delete
Supprime un groupe ou supprime un nom d'utilisateur d'un groupe.
nom_utilisateur[ ...]
Indique un ou plusieurs noms d'utilisateur à ajouter dans un groupe ou à enlever. S'il y a plusieurs noms d'utilisateur, séparez-les par un espace.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Utilisée sans paramètre, la commande net group affiche le nom d'un serveur et les noms des groupes figurant sur ce serveur.
  • Vous pouvez également taper net groups.
  • Utilisez la commande net group pour réunir des utilisateurs qui exploitent le réseau de façon identique ou similaire. Lorsque vous assignez des droits à un groupe, chacun des membres du groupe est automatiquement titulaire de ces droits. Dans les résultats, net group fait précéder les groupes comprenant à la fois des utilisateurs et des groupes par un astérisque (*).

    Les résultats de la commande net group, qui donnent les groupes figurant sur le serveur, se présentent comme suit :

    Groupes de \\PRODUCTION

    ----------------------------------------------

    *Administrateurs du domaine           *Utilisateurs du domaine

Exemples

Pour afficher la liste de tous les groupes figurant sur le serveur local, tapez :

net group

Pour ajouter le groupe Cadres à la base de données des comptes d'utilisateur locale, tapez :

net group Cadres /add

Pour ajouter le groupe Cadres à la base de données du domaine, tapez :

net group Cadres /add /domain

Pour ajouter les comptes d'utilisateur existants alainbo, fabriced et isabelb au groupe Cadres sur l'ordinateur local, tapez :

net group Cadres alainbo fabriced isabelb /add

Pour ajouter les comptes d'utilisateur existants alainbo, fabriced et isabelb au groupe Cadres dans la base de données du domaine, tapez :

net group Cadres alainbo fabriced isabelb /add /domain

Pour afficher les utilisateurs du groupe Cadres, tapez :

net group Cadres

Pour ajouter un commentaire à l'enregistrement du groupe Cadres, tapez :

net group Cadres /comment:"La direction"


Net help

Fournit une liste des rubriques et commandes réseau pour lesquelles vous pouvez obtenir de l'aide ou présente des informations relatives à une commande particulière. Utilisée sans paramètre, la commande net help affiche la liste des commandes et rubriques couvertes par l'aide.

Syntaxe

net help [commande]

Paramètres

commande
/help
Affiche la syntaxe correcte et l'aide de la commande.
Spécifie la commande au sujet de laquelle vous souhaitez obtenir de l'aide.

Exemples

Pour afficher l'aide relative à la commande net use, tapez :

net help use

Vous pouvez aussi taper :

net use /help

Pour afficher uniquement la syntaxe de la commande net help, tapez :

net help /?


Net helpmsg

Explique la raison pour laquelle une erreur s'est produite et fournit des informations pour la résolution du problème.

Syntaxe

net helpmsg numéro_message

Paramètres

numéro_message
Obligatoire. Indique le numéro à quatre chiffres du message au sujet duquel vous souhaitez obtenir des informations.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Lorsqu'une opération de réseau échoue, un message du type suivant s'affiche :

    2182: Le service demandé a déjà été démarré.

Exemples

Pour obtenir plus d'informations sur le message d'erreur NET 2182, tapez :

net helpmsg 2182


Net localgroup

Ajoute, affiche ou modifie des groupes locaux. Utilisée sans paramètre, net localgroup affiche le nom du serveur et les noms des groupes locaux figurant sur l'ordinateur.

Syntaxe

net localgroup [nom_groupe [/comment:"texte"]] [/domain]

net localgroup [nom_groupe {/add [/comment:"texte"] | /delete} [/domain]]

net localgroup [nom_groupe nom [ ...] {/add | /delete} [/domain]]

Paramètres

nom_groupe
Spécifie le nom du groupe local à ajouter, développer ou supprimer. Utilisée sans paramètre supplémentaire, la commande net localgroup nom_groupe affiche une liste des utilisateurs ou groupes globaux d'un groupe local.
/comment:"texte"
Ajoute un commentaire au sujet d'un groupe nouveau ou existant. Ce commentaire peut contenir jusqu'à 48 caractères. Placez le texte entre guillemets.
/domain
Exécute l'opération sur le contrôleur principal de domaine du domaine en cours. Sinon, l'opération est effectuée sur l'ordinateur local.
nom [ ...]
Indique un ou plusieurs noms d'utilisateur ou noms de groupe à ajouter ou supprimer dans un groupe local.
/add
Ajoute un nom de groupe global ou un nom d'utilisateur à un groupe local. Il faut qu'un compte soit établi pour les utilisateurs ou les groupes globaux avant qu'ils soient ajoutés à un groupe local au moyen de cette commande.
/delete
Supprime un nom de groupe ou un nom d'utilisateur d'un groupe local.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Utilisation de /domain

    /domain s'applique uniquement aux ordinateurs Windows XP Professionnel qui sont membres d'un domaine. Par défaut, les serveurs effectuent ces opérations sur le contrôleur principal de domaine.

  • Utilisation de nom

    Séparez les entrées multiples par un espace. Les noms peuvent correspondre à des utilisateurs locaux, à des utilisateurs d'autres domaines ou à des groupes globaux, mais pas à d'autres groupes locaux. Si un utilisateur fait partie d'un autre domaine, faites précéder le nom d'utilisateur par le nom du domaine (par exemple, Ventes\FabriceD).

  • Création de groupe d'utilisateurs

    Utilisez la commande net localgroup pour réunir des utilisateurs qui se servent du réseau de façon identique ou similaire. Lorsque vous assignez des droits à un groupe local, chaque membre du groupe est automatiquement titulaire de ces mêmes droits.

Exemples

Pour afficher la liste de tous les groupes locaux figurant sur le serveur local, tapez :

net localgroup

Pour ajouter le groupe local Cadres à la base de données des comptes d'utilisateurs locale, tapez :

net localgroup cadres /add

Pour ajouter le groupe local Cadres à la base de données des comptes d'utilisateurs du domaine, tapez :

net localgroup cadres /add /domain

Pour ajouter les comptes d'utilisateur existants alainbo, fabriced et isabelb (du domaine Ventes) au groupe local Cadres sur l'ordinateur local, tapez :

net localgroup cadres alainbo fabriced ventes\isabelb /add

Pour ajouter les comptes d'utilisateur existants alainbo, fabriced et isabelb au groupe Cadres d'un domaine, tapez :

net localgroup cadres alainbo fabriced isabelb /add /domain

Pour afficher les utilisateurs du groupe local Cadres, tapez :

net localgroup cadres

Pour ajouter un commentaire à l'enregistrement du groupe local Cadres, tapez :

net localgroup cadres /comment:"Membres du collège Cadres."


Net name

Ajoute ou supprime un nom de messagerie (parfois appelé « alias »), ou affiche la liste des noms pour lesquels l'ordinateur accepte des messages. Utilisée sans paramètre, la commande net name affiche la liste de noms en cours d'utilisation.

Syntaxe

net name [nom {/add|/delete}]

Paramètres

nom
Spécifie le nom sous lequel sont reçus les messages. Le nom peut contenir jusqu'à 15 caractères.
/add
Ajoute un nom à un ordinateur.
/delete
Supprime un nom d'un ordinateur.

Remarques

  • Utilisez la commande net name afin de spécifier un nom pour la réception de messages. Vous devez démarrer le service Affichage des messages avant de pouvoir utiliser la commande net name. Chaque nom de messagerie doit être unique sur le réseau. Les noms créés au moyen de net name sont exclusivement réservés à la messagerie, et non aux noms de groupe. Windows XP utilise trois types de noms :
    • tout nom de messagerie, ajouté au moyen de la commande net name ;
    • le nom d'ordinateur de l'ordinateur, ajouté au démarrage du service Station de travail ;
    • le nom d'utilisateur, ajouté à l'ouverture de session, à condition que ce nom ne soit pas déjà utilisé comme nom de messagerie, ailleurs sur le réseau.
  • Le paramètre /add est facultatif. net name nom et net name nom add ont le même effet. L'une et l'autre permettent d'ajouter un nom à l'ordinateur.
  • Vous ne pouvez pas supprimer le nom d'ordinateur de l'ordinateur. Vous pouvez par contre supprimer le nom d'utilisateur.

Exemples

Pour afficher la liste des noms sur votre ordinateur, tapez :

net name

Pour ajouter le nom rsvp à votre ordinateur, tapez :

net name rsvp

Pour supprimer le nom rsvp de votre ordinateur, tapez :

net name rsvp /delete


Net pause

Suspend les services en cours d'exécution.

Syntaxe

net pause service

Paramètres

service
Obligatoire. Spécifie le service dont vous souhaitez suspendre l'exécution. Le tableau suivant répertorie l'ensemble des valeurs de service.
Valeur | Description
netlogon | Suspend l'exécution du service Ouverture de session réseau.
"nt lm security support provider" | Suspend l'exécution du service Fournisseur de la prise en charge de sécurité LM NT.
schedule | Suspend l'exécution du service Planificateur de tâches.
server | Suspend l'exécution du service Serveur.
workstation | Suspend l'exécution du service Station de travail.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Utilisez la commande net pause sur un serveur avant d'arrêter un service afin de laisser aux utilisateurs le temps de terminer leurs tâches ou se déconnecter des ressources. Suspendre l'exécution d'un service met celui-ci en attente, mais le logiciel n'est pas supprimé de la mémoire. Les utilisateurs déjà connectés à la ressource peuvent achever leurs tâches, mais il est impossible d'établir de nouvelles connexions à la ressource.

    Si vous envisagez d'arrêter un service qui affecte des ressources partagées, suspendez-le d'abord. Utilisez la commande net send pour diffuser un message signalant l'arrêt imminent du service. Après avoir laissé aux utilisateurs suffisamment de temps pour qu'ils finissent l'opération exécutée sur une ressource, utilisez net stop pour arrêter le service.

    Pour relancer un service suspendu, utilisez la commande net continue.

  • Vous ne pouvez pas suspendre l'exécution de tous les services. Voici les conséquences qu'a une suspension des services :
    • La suspension du service Connexion réseau empêche l'ordinateur de traiter les demandes de connexion. Si le domaine possède d'autres serveurs de connexion, les utilisateurs peuvent toujours se connecter au réseau.
    • La suspension du service Serveur empêche les utilisateurs d'établir de nouvelles connexions aux ressources partagées du serveur. Elle empêche les ouvertures de session utilisateur sur le réseau si ce dernier ne comporte pas d'autre serveur d'ouverture de session. Cette opération n'a aucun impact sur les connexions existantes. Les administrateurs peuvent se connecter au serveur même quand il est suspendu.
    • Quand le service Station de travail est suspendu, le nom d'utilisateur, le mot de passe et les connexions restent définis, mais les demandes d'impression sont envoyées aux imprimantes reliées à l'ordinateur et non aux imprimantes raccordées au réseau.
  • Si le nom d'un service contient des espaces, entourez le texte de guillemets (comme dans "nom service").

Exemples

Pour suspendre le service Serveur, tapez :

net pause server

Si le nom du service se compose de deux mots ou davantage, vous devez le placer entre guillemets. Par exemple, tapez ceci pour suspendre l'exécution du service Fournisseur de la prise en charge de sécurité LM NT :

net pause "nt lm security support provider"


Net print

Affiche des informations sur une file d'attente d'impression spécifique, sur toutes les files d'attente d'impression hébergées par un serveur d'impression spécifique ou sur un travail d'impression spécifique, ou bien contrôle un travail d'impression spécifique. Utilisée sans paramètre, la commande net print affiche une aide au niveau de la ligne de commande sur la commande net print.

Pour afficher des informations sur une file d'attente d'impression spécifiée ou sur toutes les files d'attente d'impression hébergées par un serveur d'impression spécifique

Syntaxe

net print \\nom_ordinateur[\nom_file_attente]

Paramètres

\\nom_ordinateur
Obligatoire. Désigne par son nom l'ordinateur qui héberge la file d'attente d'impression sur laquelle vous souhaitez obtenir des informations.
\nom_file_attente
Désigne par son nom la file d'attente d'impression sur laquelle vous souhaitez obtenir des informations. Si vous indiquez un ordinateur mais pas une file d'attente, la commande affiche des informations sur toutes les files d'attente d'impression hébergées par le serveur d'impression spécifié.
net help net print
Affiche l'aide relative à la commande net print.

Remarques

  • La commande net print affiche plusieurs types d'informations sur les files d'attente d'impression. Voici un exemple de rapport généré pour toutes les files d'attente d'impression présentes sur le serveur Production :

    Files d'impression sur \\PRODUCTION

Nom             Numéro de travail      Taille      État

---------------------------------------------------------

File LASER       1 travail               *File active*

     UTILISATEUR1          84        0      Mise en file d'attente

Exemples

Pour afficher le contenu de la file d'attente d'impression Dotmatrix sur l'ordinateur \\Production, tapez :

net print \\production\dotmatrix

Pour afficher des informations sur un travail d'impression spécifié ou le contrôler

Syntaxe

net print [\\nom_ordinateur] numéro_travail [{/hold | /release | /delete}]

Paramètres

\\nom_ordinateur
Désigne par son nom l'ordinateur qui héberge le travail d'impression que vous voulez contrôler. Omettre le nom d'ordinateur revient à spécifier le nom de l'ordinateur local.
numéro_travail
Obligatoire. Indique le numéro du travail d'impression que vous souhaitez contrôler. Ce numéro est affecté par l'ordinateur hébergeant la file d'attente d'impression auquel est envoyé le travail. Dès qu'un numéro a été affecté à un travail par un ordinateur, il ne peut plus être attribué à un autre travail de n'importe quelle file d'attente hébergée par ce même ordinateur.
{/hold | /release | /delete}
Indique l'action à exécuter sur le travail d'impression. Le paramètre /hold diffère le travail, ce qui permet à d'autres travaux de le court-circuiter jusqu'à ce qu'il soit libéré. Quant au paramètre /release, il libère un travail d'impression ayant été différé. Enfin, le paramètre /delete supprime un travail d'impression d'une file d'attente d'impression. Si vous indiquez un numéro de travail sans préciser d'action, la commande affiche des informations sur le travail d'impression en question.
net help net print
Affiche l'aide relative à la commande net print.

Remarques

  • Voici un exemple de rapport généré pour un travail d'impression :

    Travail nº            35

État           En attente

Taille             3096

Note

Propriétaire  UTILISATEUR2

Notifier           UTILISATEUR2

Type de données du travail

Paramètres du travail

Infos supplémentaires

Exemples

Pour obtenir des informations sur le travail numéro 35 sur l'ordinateur \\Production, tapez :

net print \\production 35

Pour différer travail numéro 263 sur l'ordinateur \\Production, tapez :

net print \\production 263 /hold

Pour libérer le travail numéro 263 sur l'ordinateur \\Production, tapez :

net print \\production 263 /release


Net send

Envoie des messages à d'autres utilisateurs, ordinateurs ou noms de messagerie sur le réseau.

Syntaxe

net send {nom | * | /domain[:nom] | /users} message

Paramètres

nom
Spécifie le nom d'utilisateur, le nom d'ordinateur ou le nom de messagerie auquel le message doit être envoyé. Si l'information que vous fournissez contient des espaces, entourez le texte de guillemets (comme dans "nom ordinateur"). Les noms d'utilisateur longs peuvent être à l'origine de problèmes si vous les utilisez comme des noms NetBIOS. Les noms NetBIOS sont en effet limités à 16 caractères, le seizième caractère étant réservé par le système.
*
Envoie le message à tous les noms de votre domaine ou votre groupe de travail.
/domain:nom
Envoie le message à tous les noms du domaine de l'ordinateur. Vous pour spécifier un nom pour envoyer le message à tous les noms du domaine ou groupe de travail indiqué.
/users
Envoie le message à tous les utilisateurs connectés au serveur.
message
Obligatoire. Indique le texte du message.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Vous ne pouvez envoyer un message qu'à un nom qui est actif sur le réseau. Si le message est envoyé à un nom d'utilisateur, ce dernier doit avoir ouvert une session et avoir lancé le service Affichage des messages pour pouvoir recevoir le message.
  • Vous pouvez diffuser un message à tous les noms du domaine de votre ordinateur (en utilisant * ou /domain) ou d'un autre domaine (/domain:nom_domaine). Les messages de diffusion peuvent contenir jusqu'à 128 caractères. Soyez prudent lorsque vous envoyez des messages à plusieurs utilisateurs.
  • Le paramètre /users vous permet d'envoyer un message à tous les utilisateurs qui ont établi une session avec le serveur. Soyez prudent lorsque vous envoyez des messages à plusieurs utilisateurs.
  • Pour recevoir des messages, le service Affichage des messages doit être en cours d'exécution. Pour plus d'informations sur le démarrage d'un service, consultez Rubriques connexes.

Exemples

Pour envoyer le message « Réunion reportée à 15:00 au même endroit » à l'utilisateur robertf, tapez :

net send robertf Réunion reportée à 15:00 au même endroit.

Pour envoyer un message à tous les utilisateurs connectés au serveur, tapez :

net send /users Ce serveur va s'arrêter dans 5 minutes.

Pour envoyer un message incluant une barre oblique inverse (/), tapez :

net send robertf "Formatez votre disque avec FORMAT /4"


Net session

Gère les connexions à un serveur. Utilisée sans paramètre, la commande net session affiche des informations sur toutes les sessions actuellement ouvertes sur l'ordinateur local.

Syntaxe

net session [\\nom_ordinateur] [/delete]

Paramètres

\\nom_ordinateur
Identifie l'ordinateur dont les sessions doivent être répertoriées ou déconnectées.
/delete
Met fin à la session de l'ordinateur avec \\nom_ordinateur et ferme tous les fichiers ouverts sur l'ordinateur pendant cette session. Si vous omettez nom_ordinateur, toutes les sessions sur l'ordinateur local sont annulées.
net help commande
Affiche l'aide de la commande net spécifiée.

Attention

  • L'utilisation de la commande net session peut entraîner un perte de données. Il est sans doute préférable d'avertir les utilisateurs avant de fermer une session.

Remarques

  • Vous pouvez également utiliser net sessions ou net sess pour exécuter net session.
  • Utilisez la commande net session pour afficher les noms d'ordinateur ou les noms d'utilisateur des utilisateurs qui accèdent à un serveur, pour savoir s'ils ont ouvert des fichiers et pour connaître la durée d'inactivité de la session pour chaque utilisateur.

    Les informations s'affichent dans un format semblable à celui-ci :

    Ordinateur      Nom d'utilisateur        Type de client  Ouvertures   Délai d'inactivité

------------------------------------------------------------------------

\\BASSETT     CHRISDR          Windows 2000            1     00:00:13

\\SHARONCA    Administrateur    DOS LM 2.1     0     01:05:13

  • Pour afficher la session d'un utilisateur, insérez nom_ordinateur dans la commande. Les informations relatives à un seul utilisateur comprennent la liste des ressources partagées avec lesquelles l'utilisateur a établi des connexions.
  • Une session est enregistrée quand un utilisateur client réussit à contacter un serveur. La session est ouverte quand les deux systèmes se trouvent sur le même réseau et que l'utilisateur possède un nom d'utilisateur et un mot de passe acceptés par le serveur. L'utilisateur d'un client doit ouvrir une session sur le serveur avant de pouvoir utiliser les ressources de ce dernier et la session n'est établie que lorsque l'utilisateur du client se connecte à une ressource. Un client et un serveur ne possèdent qu'une seule session, mais peuvent avoir plusieurs points d'entrée ou connexions aux ressources.
  • Afin de déterminer le temps pendant lequel une session peut rester inactive avant d'être automatiquement fermée, activez la fonction de déconnexion automatique au moyen de la commande net config server /autodisconnect. Pour plus d'informations sur net config server, consultez Rubriques connexes. La déconnexion automatique est transparente à l'utilisateur, car la session est automatiquement rouverte dès que l'utilisateur accède à nouveau à la ressource.
  • Pour mettre fin à une session ouverte sur un serveur, utilisez la commande net session \\nom_ordinateur /delete.

Exemples

Pour afficher la liste des informations relatives aux sessions établies avec le serveur local, tapez :

net session

Pour afficher les informations relatives aux sessions du client portant le nom d'ordinateur Dupont, tapez :

net session \\dupont

Pour mettre fin à toutes les sessions entre le serveur et les clients qui y sont connectés, tapez :

net session /delete


Net share

Gère les ressources partagées. Utilisée sans paramètre, la commande net share affiche des informations sur toutes les ressources actuellement partagées sur l'ordinateur local.

Syntaxe

net share [nom_partage] net share [nom_partage=lecteur:chemin [{/users:nombre|/unlimited}] [/remark:"texte"] [/cache: {manual|automatic|no}]]net share [nom_partage [{/users:nombre|unlimited}] [/remark:"texte"] [/cache: {manual|automatic|no}]] net share [{nom_partage|lecteur:chemin} /delete]

Paramètres

nom_partage
Indique le nom réseau de la ressource partagée. Tapez net share avec un nom_partage pour afficher des informations sur ce partage uniquement.
lecteur:chemin
Indique le chemin absolu du répertoire à partager.
/users:nombre
Définit le nombre maximal d'utilisateurs autorisés à accéder simultanément à la ressource partagée.
/unlimited
Spécifie un nombre illimité d'utilisateurs autorisés à accéder simultanément à la ressource partagée.
/remark:"texte"
Ajoute une description concernant la ressource. Placez le texte entre guillemets.
/cache:automatic
Active la mise en cache du client hors connexion avec réintégration automatique.
/cache:manual
Active la mise en cache du client hors connexion avec réintégration manuelle.
/cache:no
Signale au client que la mise en cache hors connexion n'est pas appropriée.
/delete
Met fin au partage de la ressource.
net help commande
Affiche l'aide de la commande net spécifiée.

Remarques

  • Pour partager un répertoire avec un chemin contenant un espace, placez le lecteur ainsi que le chemin d'accès du répertoire entre guillemets (par exemple, "C:\nom chemin").
  • Quand vous affichez toutes les ressources partagées sur un ordinateur, le système indique le nom de partage de la ressource, les noms de périphériques ou le chemin associés à la ressource ainsi qu'une description de la ressource. La sortie se présente comme suit :

    Nom de partage  Ressource                     Remarque

------------------------------------------------------

ADMIN$     C:\WINNT                     Administrateur distant

C$         C:\                          Partage par défaut à usage interne

print$     C:\WINNT\SYSTEM\SPOOL

IPC$                                    IPC distant

LASER      LPT1               Spoulée   Imprimante laser

  • Les partages sont enregistrés au fur et à mesure de leur création sur un serveur. Quand vous arrêtez le service Serveur, tous les partages sont déconnectés, mais sont automatiquement reconnectés au prochain démarrage du service ou lorsque l'ordinateur est relancé. Pour plus d'informations sur les services, consultez Services.
  • Les noms de ressource partagée qui finissent par un caractère $ ne sont pas affichés si vous parcourez l'ordinateur local à la recherche d'un ordinateur distant.

Exemples

Pour afficher des informations concernant toutes les ressources partagées sur l'ordinateur, tapez :

net share

Pour partager le répertoire C:\Données d'un ordinateur avec le nom de partage PartageDonnées et inclure une remarque, tapez :

net share PartageDonnées=c:\Données/remark:"Pour le département 123."

Pour mettre fin au partage du dossier PartageDonnées créé par l'exemple précédent, tapez :

net share PartageDonnées /delete

Pour partager le répertoire C:\Liste images d'un ordinateur avec le nom de partage Liste, tapez :

net share liste="c:\liste images"


Net start

Démarre un service. Utilisée sans paramètre, la commande net start affiche la liste des services en cours d'exécution.

Syntaxe

net start [service]

Paramètres

service
Démarre le service spécifié. Le tableau suivant répertorie les valeurs de service.
Valeur | Description | Remarques
alerter Démarre le service Avertissements.
  • Démarre le service Avertissements pour envoyer des messages d'alerte à des utilisateurs désignés qui sont connectés au serveur. Les messages d'alerte avertissent les utilisateurs en cas de problème de sécurité, d'accès et de session utilisateur.
  • Utilisez le Gestionnaire de serveur (autrement dit systemroot\System32\Srvmgr.exe) pour spécifier les administrateurs qui doivent recevoir des alertes administratives. Le Gestionnaire de serveur est disponible uniquement sur les ordinateurs Windows Server 2000.
  • Les messages d'alerte sont envoyés sous forme de messages du serveur vers l'ordinateur d'un utilisateur. Le service Affichage des messages doit être en cours d'exécution sur l'ordinateur de l'utilisateur pour que ce dernier puisse recevoir des messages d'alerte.
browser Démarre le service Explorateur d'ordinateur.
  • Le service Explorateur d'ordinateur conserve une liste mise à jour des ordinateurs du réseau et la fournit aux programmes qui la demandent.
"client service for netware" Démarre le Service client pour NetWare.
  • Cette commande est disponible uniquement si vous avez installé le Service client pour NetWare.
clipbook Démarre le service Album.
  • Le service Album permet de couper et de coller du texte et des images sur le réseau.
  • Le service Album prend en charge le Gestionnaire de l'Album, qui permet l'affichage de pages par des albums distants.
dhcp client Démarre le service Client DHCP.
  • Cette commande est disponible uniquement si vous avez installé le protocole TCP/IP.
  • Le service Client DHCP gère la configuration réseau en enregistrant et en mettant à jour des adresses IP et des noms DNS. Le service Client DHCP prend en charge l'obtention d'une adresse IP à partir du service DHCP.
  • Vous ne pouvez pas arrêter ou interrompre le service Client DHCP.
eventlog Démarre le service Journal d'événements.
  • Ce service consigne les messages d'événements émis par les programmes et par Windows XP. Ses rapports contiennent des informations qui peuvent être utiles en vue de diagnostiquer des problèmes. Les rapports peuvent peuvent être visualisés dans l'Observateur d'événements. Le service Journal d'événements doit être démarré avant d'utiliser l'Observateur d'événements pour afficher les événements consignés.
  • Vous ne pouvez pas arrêter ou suspendre le service Journal d'événements.
file replication | Démarre le service de réplication de fichiers.
messenger Démarre le service Affichage des messages.
  • Le service Affichage des messages permet à un ordinateur de recevoir des messages.
  • Un message est envoyé à un ordinateur à l'aide des noms qui lui sont assignés comme identification.
netlogon Démarre le service Connexion réseau.
  • Le service Ouverture de session réseau vérifie les demandes d'ouverture de session et contrôle la réplication de la base de données des comptes d'utilisateurs au niveau du domaine.
  • Démarre le service Connexion réseau sur tous les serveurs d'un domaine qui utilisent une copie de la base de données des comptes d'utilisateurs du domaine.
"nt lm security support provider" Démarre le Service de sécurité NT LM.
  • Cette commande est disponible uniquement si vous avez installé le Fournisseur de la prise en charge de sécurité LM NT.
"plug and play" | Démarre le service Plug-and-Play.
"remote access connection manager" Démarre le service Gestionnaire de connexions d'accès distant.
  • Cette commande est disponible uniquement si vous avez installé le service d'accès distant.
"routing and remote access" | Démarre le service Routage et accès distant.
rpclocator Démarre le service Localisateur d'appels de procédure distante (RPC).
  • Permet aux applications distribuées d'utiliser le service de noms Microsoft RPC.
  • Le service Localisateur d'appels de procédure distante (RPC) est le service de noms RPC de Microsoft Windows XP. Le détecteur d'appel RPC gère la base de données du service de noms RPC.
  • Le côté serveur de l'application distribuée enregistre sa disponibilité au moyen du service Détecteur d'appel RPC. Le côté client de l'application distribuée interroge ce service pour trouver des applications serveur compatibles qui soient disponibles.
rpcss Démarre le service Appel de procédure distante (RPC).
  • Le service Appel de procédure distante (RPC) est le sous-système RPC de Microsoft Windows XP. Le sous-système RPC comprend le mappeur de point final et d'autres services RPC divers. La commande net start rpcss démarre le service Appel de procédure distante (RPC), qui permet aux applications distribuées d'utiliser des points finals dynamiques. Ce service gère la base de données du mappeur de point final.

    Le côté serveur de l'application distribuée enregistre ses points finals auprès du service Appel de procédure distante (RPC). La bibliothèque d'exécution du client interroge, pour le compte du côté client de l'application distribuée, le service Appel de procédure distante (RPC) pour obtenir les informations relatives aux points finals. Pour déterminer si une application distribuée utilise le serveur de mappeur de point final, consultez la documentation qui l'accompagne.

schedule Démarre le service Planificateur de tâches.
  • Le Planificateur de tâches permet de démarrer des programmes à un moment déterminé à l'aide de la commande at. Il se peut que vous deviez exécuter d'autres services pour pouvoir exécuter des commandes planifiées.
  • Le service Planificateur de tâches est initialement configuré pour être exécuté sur le compte système de l'ordinateur local. Si le Planificateur de tâches est exécuté à l'aide de ce compte, vous pouvez exécuter tous les types de travaux avec le Planificateur de tâches. Ces travaux possèdent toutefois un accès réseau limité, car le compte système d'un ordinateur local n'est pas reconnu par d'autres ordinateurs.
  • Pour contourner les limites d'accès réseau, vous pouvez configurer le Planificateur de tâches de façon à ce qu'il s'exécute sur un compte d'utilisateur. Dans ce cas, les travaux exécutés par le Planificateur de tâches sont régis par l'accès réseau du compte d'utilisateur. Néanmoins, comme le Planificateur de tâches n'utilise pas le compte système local dans ce cas-ci, seuls les travaux qui ne nécessitent pas la présence d'une fenêtre peuvent être exécutés.
server Démarre le service Serveur.
  • Vous pouvez utiliser le service Serveur pour partager des ressources du serveur avec les utilisateurs du réseau.
spooler Démarre le service Spouleur d'impression.
  • Le service Spouleur d'impression charge les fichiers en mémoire en vue de l'impression.
"tcp/ip netbios helper" Démarre le service NetBIOS Helper sur TCP, qui active les services NetBIOS sur TCP/IP (NetBT).
  • Les services NetBT fournissent des datagrammes NetBIOS, des sessions NetBIOS et la gestion de noms NetBIOS (comme l'enregistrement et la résolution de noms) aux applications NetBIOS qui utilisent le protocole TCP/IP.
  • Cette commande est disponible uniquement si le protocole Internet Protocol (TCP/IP) est installé comme composant dans les propriétés d'une carte réseau dans les Connexions réseau.
ups Démarre le service Onduleur.
  • Le service Onduleur gère un onduleur (UPS) connecté à l'ordinateur.
  • Vous pouvez configurer le service Onduleur à l'aide de l'application Options d'alimentation du Panneau de configuration. Si vous configurez le service Onduleur de manière à ce qu'il exécute un fichier de commande à la fermeture, l'exécution du fichier de commande doit s'interrompre dans un délai de 30 secondes. Une durée d'exécution supérieure à 30 secondes peut affecter la capacité de Windows XP à réaliser un arrêt ordonné du système.
workstation Démarre le service Station de travail.
  • Ce service permet à un ordinateur de se connecter et d'utiliser des ressources réseau.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • L'ensemble des services et applications affichés peuvent varier en fonction des options que vous avez sélectionnées au moment de l'installation ou de la configuration.

  • Pour plus d'informations sur les services, consultez le guide « System Essentials Guide » accessible sur le Site Web de Microsoft.(http://www.microsoft.com/)

  • Certains services dépendent d'autres services.
  • Vous pouvez utiliser le composant logiciel enfichable Services pour configurer l'arrêt et le démarrage automatiques de certains services. Ce composant logiciel enfichable permet aussi d'arrêter, de démarrer, de suspendre et de reprendre manuellement des services réseau.
  • Vous pouvez recourir à la commande net start pour démarrer des services non compris dans Windows XP.
  • Si le nom d'un service contient des espaces, entourez le texte de guillemets (comme dans "Nom Service").

Exemples

Pour afficher la liste des services actuellement en cours d'exécution, tapez :

net start

Pour démarrer le Service client pour NetWare, tapez :

net start "client service for netware"


Net statistics

Affiche le journal des statistiques du service Station de travail ou Serveur local ou bien les services en cours d'exécution pour lesquels des statistiques sont disponibles. Utilisée sans paramètre, la commande net statistics affiche la liste des services en cours d'exécution pour lesquels des statistiques sont disponibles.

Syntaxe

net statistics [{workstation | server}]

Paramètres

workstation
Affiche les statistiques pour le service Station de travail local.
server
Affiche les statistiques pour le service Serveur local.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Vous pouvez également taper net stats.
  • Pour le service Station de travail, Windows XP signale le nom d'ordinateur, la date et l'heure de la dernière mise à jour des statistiques ainsi que les informations suivantes :
    • nombre d'octets et de blocs de message serveur (SMB, Server Message Blocks) reçus et transmis ;
    • nombre d'opérations de lecture et d'écriture ayant réussi ou échoué ;
    • nombre d'erreurs réseau ;
    • nombre de sessions ayant échoué, ayant été fermées ou rétablies ;
    • nombre de connexions aux ressources partagées ayant réussi ou échoué.
  • Pour le service Serveur, Windows XP signale le nom d'ordinateur, la date et l'heure de la dernière mise à jour des statistiques ainsi que les informations suivantes :
    • nombre de sessions démarrées, fermées automatiquement et fermées en raison d'une erreur ;
    • nombre de kilo-octets envoyés et reçus ainsi que temps de réponse moyen du serveur ;
    • nombre d'erreurs et de violations des limites de mot de passe et d'autorisation ;
    • nombre d'utilisations des fichiers partagés, des imprimantes et des périphériques de communication ;
    • nombre de dépassement de la taille des tampons de mémoire.

Exemples

Pour afficher les statistiques du service Serveur et empêcher l'affichage de défiler, tapez :

net statistics server | more


Net stop

Arrête un service en cours d'exécution.

Syntaxe

net stop service

Paramètres

service
Arrête le service spécifié. Le tableau suivant répertorie les valeurs de service.
Valeur | Description | Remarques
alerter Arrête le service Avertissements.
  • Arrête le service Avertissements qui envoie des messages d'alerte à des utilisateurs désignés qui sont connectés au serveur. Les messages d'alerte avertissent les utilisateurs en cas de problème de sécurité, d'accès et de session utilisateur.
  • Utilisez le Gestionnaire de serveur (autrement dit systemroot\System32\Srvmgr.exe) pour spécifier les administrateurs qui doivent recevoir des alertes administratives. Le Gestionnaire de serveur est disponible uniquement sur les ordinateurs Windows 2000 Server.
  • Les messages d'alerte sont envoyés sous forme de messages du serveur vers l'ordinateur d'un utilisateur. Le service Affichage des messages doit être en cours d'exécution sur l'ordinateur de l'utilisateur pour qu'il puisse recevoir des messages d'alerte.
browser Arrête le service Explorateur d'ordinateur.
  • Le service Explorateur d'ordinateur conserve une liste mise à jour des ordinateurs du réseau et la fournit aux programmes qui la demandent.
"client service for netware" Arrête le Service client pour NetWare.
  • Cette commande est disponible uniquement si vous avez installé le Service client pour NetWare.
clipbook Arrête le service Album.
  • Le service Album permet de couper et de coller du texte et des images sur le réseau.
  • Le service Album prend en charge le Gestionnaire de l'Album, qui permet l'affichage de pages par des albums distants.
dhcp client Vous ne pouvez pas arrêter ou interrompre le service Client DHCP.
  • Le service Client DHCP gère la configuration réseau en enregistrant et en mettant à jour des adresses IP et des noms DNS. Le service Client DHCP prend en charge l'obtention d'une adresse IP à partir du service DHCP.
file replication | Démarre le service de réplication de fichiers.
messenger Arrête le service Affichage des messages.
  • Le service Affichage des messages permet à un ordinateur de recevoir des messages.
  • Un message est envoyé à un ordinateur à l'aide des noms qui lui sont assignés comme identification.
netlogon Démarre le service Ouverture de session réseau.
  • Le service Ouverture de session réseau vérifie les demandes d'ouverture de session et contrôle la réplication de la base de données des comptes d'utilisateurs au niveau du domaine.
  • Arrête le service Ouverture de session réseau sur tous les serveurs d'un domaine qui utilisent une copie de la base de données des comptes d'utilisateur du domaine.
"nt lm security support provider" Arrête le service Fournisseur de la prise en charge de sécurité LM NT.
  • Cette commande est disponible uniquement si vous avez installé le Fournisseur de la prise en charge de sécurité LM NT.
"remote access connection manager" Arrête le service Gestionnaire de connexions d'accès distant.
  • Cette commande est disponible uniquement si vous avez installé le service d'accès distant.
"routing and remote access" | Arrête le service Routage et accès distant.
rpclocator Arrête le service Localisateur d'appels de procédure distante (RPC).
  • Permet aux applications distribuées d'utiliser le service de noms Microsoft RPC.
  • Le service Localisateur d'appels de procédure distante (RPC) est le service de noms RPC de Microsoft Windows XP. Le détecteur d'appel RPC gère la base de données du service de noms RPC.
  • Le côté serveur de l'application distribuée enregistre sa disponibilité au moyen du service Détecteur d'appel RPC. Le côté client de l'application distribuée interroge ce service pour trouver des applications serveur compatibles qui soient disponibles.
schedule Arrête le service Planificateur de tâches.
  • Le Planificateur de tâches permet de démarrer des programmes à un moment déterminé à l'aide de la commande at. Il se peut que vous deviez exécuter d'autres services pour pouvoir exécuter des commandes planifiées.
  • Le service Planificateur de tâches est initialement configuré pour être exécuté sur le compte système de l'ordinateur local. Si le Planificateur de tâches est exécuté à l'aide de ce compte, vous pouvez exécuter tous les types de travaux avec le Planificateur de tâches. Ces travaux possèdent toutefois un accès réseau limité, car le compte système d'un ordinateur local n'est pas reconnu par d'autres ordinateurs.
  • Pour contourner les limites d'accès réseau, vous pouvez configurer le Planificateur de tâches de façon à ce qu'il s'exécute sur un compte d'utilisateur. Dans ce cas, les travaux exécutés par le Planificateur de tâches sont régis par l'accès réseau du compte d'utilisateur. Néanmoins, comme le Planificateur de tâches n'utilise pas le compte système local dans ce cas-ci, seuls les travaux qui ne nécessitent pas la présence d'une fenêtre peuvent être exécutés.
server Arrête le service Serveur.
  • Vous pouvez utiliser le service Serveur pour partager des ressources du serveur avec les utilisateurs du réseau.
spooler Arrête le service Spouleur d'impression.
  • Le service Spouleur d'impression charge les fichiers en mémoire en vue de l'impression.
"tcp/ip netbios helper" Arrête le service NetBIOS helper sur TCP, qui active les services NetBIOS sur TCP/IP (NetBT).
  • Les services NetBT fournissent des datagrammes NetBIOS, des sessions NetBIOS et la gestion de noms NetBIOS (comme l'enregistrement et la résolution de noms) aux applications NetBIOS qui utilisent le protocole TCP/IP.
  • Cette commande est disponible uniquement si le protocole Internet Protocol (TCP/IP) est installé comme composant dans les propriétés d'une carte réseau dans les Connexions réseau.
ups Arrête le service Onduleur.
  • Le service Onduleur gère un onduleur (UPS) connecté à l'ordinateur.
  • Vous pouvez configurer le service Onduleur à l'aide de l'application Options d'alimentation du Panneau de configuration. Si vous configurez le service Onduleur de manière à ce qu'il exécute un fichier de commande à la fermeture, l'exécution du fichier de commande doit s'interrompre dans un délai de 30 secondes. Une durée d'exécution supérieure à 30 secondes peut affecter la capacité de Windows XP à réaliser un arrêt ordonné du système.
workstation Arrête le service Station de travail.
  • Ce service permet à un ordinateur de se connecter et d'utiliser des ressources réseau.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • L'ensemble des services et applications affichés peuvent varier en fonction des options que vous avez sélectionnées au moment de l'installation ou de la configuration.

  • Pour plus d'informations sur les services, consultez les Kits de Ressources Techniques Microsoft Windows.

  • Certains services dépendent d'autres services.
  • Utilisez la commande net stop pour arrêter un service et retirer le logiciel de la mémoire.
  • L'arrêt du service Serveur empêche les utilisateurs d'accéder aux ressources partagées de l'ordinateur. Si vous arrêtez ce service alors que certains utilisent des ressources du serveur, un message d'avertissement s'affiche. Une réponse o (pour oui) annule toutes les connexions à l'ordinateur. Avant d'arrêter le service Serveur, exécutez les tâches suivantes :
  • Utilisez la commande net pause pour suspendre l'exécution d'un service, afin d'empêcher toute nouvelle connexion.
  • Utilisez la commande net send pour envoyer un message qui conseille aux utilisateurs de se déconnecter des ressources du serveur.
  • Si le nom d'un service contient des espaces, entourez le texte de guillemets (comme dans "nom service").
  • La commande net stop peut également arrêter des services non compris dans Windows XP.

Exemples

La commande suivante arrête le service Serveur :

net stop server

Placez les noms de service constitués d'au moins deux mots entre guillemets. Par exemple, la commande suivante arrête le Service client pour NetWare :

net stop "client service for netware"


Commandes de services Net

Pour plus d'informations, cliquez sur une commande :

  • Net accounts
  • Net computer
  • Net config
  • Net continue
  • Net file
  • Net group
  • Net help
  • Net helpmsg
  • Net localgroup
  • Net name
  • Net pause
  • Net print
  • Net send
  • Net session
  • Net share
  • Net start
  • Net statistics
  • Net stop
  • Net time
  • Net use
  • Net user
  • Net view


Net time

Synchronise l'horloge de l'ordinateur avec celle d'un autre ordinateur ou d'un domaine. Utilisée sans paramètre, la commande net time affiche l'heure d'un autre ordinateur ou domaine.

Syntaxe

net time [{\\nom_ordinateur | /domain[:nom_domaine] | /rtsdomain[:nom_domaine]}] [/set]

net time [\\nom_ordinateur] [/querysntp] [/setsntp[:liste_serveurs_NTP]]

Paramètres

\\nom_ordinateur
Spécifie le nom du serveur dont vous voulez contrôler l'horloge ou avec lequel vous souhaitez synchroniser votre horloge.
/domain[:nom_domaine]
Spécifie le domaine avec lequel vous souhaitez synchroniser l'horloge.
/rtsdomain[:nom_domaine]
Spécifie le domaine du serveur de référence de synchronisation avec lequel vous souhaitez synchroniser l'horloge.
/set
Synchronise l'horloge de l'ordinateur avec celle de l'ordinateur ou du domaine spécifié.
/querysntp
Affiche le nom du serveur N (Network Time Protocol) actuellement configuré pour l'ordinateur local ou pour l'ordinateur spécifié par nom_ordinateur.
/setsntp[:liste serveurs NTP]
Indique une liste de serveurs de temps NTP à utiliser par l'ordinateur local. Cette liste peut contenir des adresses IP ou des noms DNS, séparés par des espaces. Si vous utilisez plusieurs serveurs de temps, vous devez entourer la liste de guillemets.
net help commande
Affiche l'aide pour la commande net spécifiée.


Net use

Connecte ou déconnecte un ordinateur d'une ressource partagée, ou affiche des informations relatives aux connexions de l'ordinateur. Cette commande contrôle aussi les connexions réseau persistantes. Utilisée sans paramètre, la commande net use extrait une liste des connexions réseau.

Syntaxe

net use [{nom_périphérique | *}] [\\nom_ordinateur\nom_partage[\volume]] [{mot_de_passe | *}]] [/user:[nom_domaine\]nom_utilisateur] [/user:[nom_domaine_pointé\]nom_utilisateur] [/user: [nom_utilisateur@nom_domaine_pointé] [/savecred] [/smartcard] [{/delete | /persistent:{yes | no}}]

net use [nom_périphérique [/home[{mot_de_passe | *}] [/delete:{yes | no}]]

net use [/persistent:{yes | no}]

Paramètres

nom_périphérique
Assigne un nom pour établir la connexion à la ressource ou désigne le périphérique à déconnecter. Il existe deux types de noms de périphérique : lecteurs de disque (soit de D: à Z:) et imprimantes (soit de LPT1: à LPT3:). Tapez un astérisque (*) en lieu et place d'un nom de périphérique déterminé pour attribuer le nom de périphérique disponible suivant.
\\nom_ordinateur\nom_partage
Spécifie le nom du serveur et de la ressource partagée. Si nom_ordinateur contient des espaces, placez entre guillemets (" ") la totalité du nom d'ordinateur, c'est-à-dire de la double barre oblique inverse (\\) jusqu'à la fin du nom (par exemple, "\\nom_ordinateur\nom_partage"). Le nom d'ordinateur peut contenir entre 1 et 15 caractères.
\volume
Spécifie un volume NetWare sur le serveur. Le Service client pour NetWare doit être installé et en cours d'exécution pour pouvoir établir une connexion aux serveurs NetWare.
mot_de_passe
Spécifie le mot de passe requis pour accéder à la ressource partagée. Tapez un astérisque (*) de manière à produire une invite pour le mot de passe. Le mot de passe ne s'affiche pas quand vous le tapez à l'invite du mot de passe.
/user
Spécifie un autre nom d'utilisateur avec lequel la connexion est établie.
nom_domaine
Spécifie un autre domaine. Si vous omettez le nom_domaine, net use utilise le domaine actuellement connecté.
UserName
Spécifie le nom d'utilisateur avec lequel vous vous connectez.
nom_domaine_pointé
Indique le nom de domaine complet du domaine qui contient le compte d'utilisateur.
/savecred
Stocke les informations d'identification fournies en vue de leur réutilisation.
/smartcard
Indique que la connexion réseau doit utiliser les informations d'identification d'une carte à puce. Si plusieurs cartes à puce sont disponibles, vous devez indiquez l'information d'identification requise.
/delete
Annule la connexion réseau spécifiée. Si vous spécifiez la connexion à l'aide d'un astérisque (*), toutes les connexions réseau sont annulées.
/persistent:{yes | no}
Gère l'emploi des connexions réseau persistantes. Le paramètre par défaut correspond au dernier paramètre utilisé. Les connexions sans périphérique ne sont pas permanentes. Yes enregistre toutes les connexions au fur et à mesure qu'elles sont établies et les restaure lors de l'ouverture de session suivante. No n'enregistre pas la connexion qui est établie ou celles qui suivent. Les connexions existantes sont restaurées lors de la prochaine connexion. Utilisez le paramètre /delete pour supprimer les connexions permanentes.
/home
Connecte un utilisateur au répertoire d'origine.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Connexion à une ressource réseau et déconnexion

    Utilisez la commande net use pour vous connecter à une ressource réseau et vous en déconnecter, ainsi que pour afficher les connexions actuellement établies avec des ressources réseau. Vous ne pouvez pas vous déconnecter d'un répertoire partagé si celui-ci vous sert de lecteur en cours ou si un processus l'utilise.

  • Affichage des informations sur la connexion

    Pour obtenir des informations relatives à une connexion, procédez de l'une ou l'autre des façons suivantes :

    • Tapez net use nom_périphérique pour obtenir des informations sur une connexion spécifique.
    • Tapez net use pour obtenir la liste de toutes les connexions de l'ordinateur.
  • Utilisation de connexions sans périphérique

    Les connexions sans périphérique ne sont pas permanentes.

  • Connexion à des serveurs NetWare

    Après avoir installé et démarré le Service client pour NetWare, vous pouvez vous connecter à un serveur NetWare d'un réseau Novell. Utilisez la même syntaxe que celle employée pour vous connecter à un serveur de réseau Windows, à l'exception du fait que vous devez inclure le volume auquel vous souhaitez vous connecter.

  • Utilisation de guillemets

    Si lenom_serveur que vous fournissez contient des espaces, entourez le texte de guillemets (comme dans "nom serveur"). Si vous omettez les guillemets, un message d'erreur s'affiche.

Exemples

Pour assigner le nom de périphérique de lecteur de disque E: au répertoire partagé Lettres sur le serveur \\Finances, tapez :

net use e: \\finances\lettres

Pour assigner (mapper) le nom de périphérique de lecteur de disque M: au répertoire Michel dans le volume Lettres sur le serveur \\Finances NetWare, tapez :

net use m: \\finances\lettres\michel

Pour connecter l'utilisateur identifié par Daniel comme si la connexion était établie à partir du domaine Comptabilité, tapez :

net use d:\\serveur\partage /user:Comptabilité\Daniel

Pour vous déconnecter du répertoire \\Finances\Public, tapez :

net use f: \\finances\public /delete

Pour vous connecter à la ressource partagée mémos du serveur \\Finances 2, tapez :

net use k: "\\finances 2" \mémos

Pour que les connexions en cours soient rétablies à l'ouverture de chaque session, indépendamment de toutes modifications ultérieures, tapez :

net use /persistent:yes


Net user

Ajoute ou modifie des comptes d'utilisateurs ou affiche des informations relatives aux comptes d'utilisateurs.

Syntaxe

net user [nom_utilisateur [mot_de_passe | *] [options]] [/domain]

net user [nom_utilisateur {mot_de_passe | *} /add [options] [/domain]]

net user [nom_utilisateur [/delete] [/domain]]

Paramètres

UserName
Indique le nom du compte d'utilisateur à ajouter, supprimer, modifier ou afficher. Ce nom peut comporter jusqu'à 20 caractères.
Password
Assigne ou modifie le mot de passe du compte d'utilisateur. Tapez un astérisque (*) de manière à produire une invite pour le mot de passe. Le mot de passe ne s'affiche pas quand vous le tapez à l'invite du mot de passe.
/domain
Exécute l'opération sur le contrôleur de domaine du domaine principal de l'ordinateur.
options
Indique une option de ligne de commande. Le tableau suivant répertorie les options de ligne de commande valides.
Syntaxe des options de ligne de commande | Description
/active:{no | yes} | Désactive ou active le compte d'utilisateur. Si le compte d'utilisateur n'est pas actif, l'utilisateur ne peut pas accéder aux ressources sur l'ordinateur. La valeur par défaut est yes (active).
/comment:"texte" | Fournit un commentaire descriptif du compte d'utilisateur. Ce commentaire peut comporter jusqu'à 48 caractères. Placez le texte entre guillemets.
/countrycode:nnn | Utilise les codes pays/région du système d'exploitation afin de mettre en œuvre les fichiers de langue spécifiés pour l'aide et les messages d'erreur d'un utilisateur. La valeur 0 désigne le code pays/région par défaut.
/expires:{{mm/jj/aaaa | jj/mm/aaaa | mmm,jj ,aaaa} | never} | Provoque l'expiration du compte d'utilisateur si vous indiquez une date. En fonction du code pays/région, les dates d'expiration peuvent être aux formats suivants : [mm/jj/aaaa], [jj/mm/aaaa] ou [mmm,jj ,aaaa]. Notez que le compte expire au début de la date spécifiée. Pour la valeur correspondant au mois, vous pouvez utiliser des chiffres, écrire le mois en toutes lettres ou employer l'abréviation à trois lettres (par exemple, jan fév mar avr mai jun jul aoû sep oct nov déc). Quant à la valeur de l'année, elle peut être représentée par deux ou quatre chiffres. Utilisez des virgules ou des barres obliques pour séparer les éléments de la date. Les espaces sont interdits. Si vous omettez aaaa, c'est l'occurrence suivante de la date (en fonction de la date et l'heure de votre ordinateur) qui est prise en compte. Par exemple, les entrées suivantes sont équivalentes si elles sont entrées entre le 10 janvier 1994 et le 8 janvier 1995 : jan,9 1/9/95 janvier,9,1995 1/9
/fullname:"nom" | Spécifie le nom complet de l'utilisateur plutôt qu'un nom d'utilisateur. Placez le nom entre guillemets.
/homedir:chemin | Indique le chemin du répertoire d'origine de l'utilisateur. Ce chemin doit exister.
/passwordchg:{yes | no} | Indique si les utilisateurs peuvent modifier leur propre mot de passe. La valeur par défaut est yes.
/passwordreq:{yes | no} | Indique si un compte d'utilisateur doit posséder un mot de passe. La valeur par défaut est yes.
/profilepath:[chemin] | Définit le chemin du profil de connexion de l'utilisateur. Ce chemin pointe vers un profil du registre.
/scriptpath:chemin | Définit le chemin du script d'ouverture de session de l'utilisateur. Le chemin ne peut pas être un chemin d'accès absolu. Il est relatif à %systemroot%\System32\Repl\Import\Scripts.
/times:{jour[-jour][,jour[-jour]] ,heure[-heure][,heure[-heure]] [;…] | all} | Précise quand l'utilisateur est autorisé à employer l'ordinateur. L'heure est limitée à des incréments d'une heure. Quant aux valeurs de jour, elles peuvent être écrites en toutes lettres ou représentées par les abréviations (L, Ma, Me, J, V, S, D). Les heures peuvent suivre le format de notation en 12 ou 24 heures. Si vous optez pour le format 12 heures, utilisez AM/PM ou A.M./P.M. La valeur all signifie qu'un utilisateur peut ouvrir une session en permanence. La valeur nulle (blanc) signifie qu'un utilisateur ne peut jamais se connecter. Séparez le jour et l'heure par des virgules et les unités du jour et de l'heure par des points-virgules (par exemple, L,16:00-17:00;Ma,13:00-15:00). N'utilisez pas d'espaces pour désigner les heures.
/usercomment:"texte" | Indique qu'un administrateur peut ajouter ou modifier le « Commentaire de l'utilisateur » pour le compte. Placez le texte entre guillemets.
/workstations:{nom_ordinateur[,...] | *} | Répertorie jusqu'à huit stations de travail à partir desquelles un utilisateur peut se connecter au réseau. Séparez les entrées multiples de la liste par des virgules. Si /workstations ne possède pas de liste ou si celle-ci correspond à l'astérisque (*), cela signifie que l'utilisateur peut ouvrir une session à partir de n'importe quel ordinateur.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Utilisée sans paramètre, la commande net user affiche la liste des comptes d'utilisateurs sur l'ordinateur. Vous pouvez également taper net users.
  • Un mot de passe doit respecter la longueur minimale définie à l'aide de la commande net accounts /minpwlen. Il peut comporter jusqu'à 127 caractères. Cependant, si vous utilisez Windows 2000 ou Windows XP sur un réseau qui comprend également des ordinateurs Windows 95 ou Windows 98, utilisez de préférence des mots de passe d'une longueur inférieure à 14 caractères. Windows 95 et Windows 98 prennent en charge les mots de passe allant jusqu'à 14 caractères. Si votre mot de passe est plus long, vous ne pourrez peut-être pas ouvrir de session sur le réseau à partir de ces ordinateurs.

Exemples

Afin d'afficher la liste de tous les comptes d'utilisateurs pour l'ordinateur local, tapez :

net user

Pour affichez des informations sur le compte d'utilisateur robertf, tapez :

net user robertf

Pour ajouter un compte d'utilisateur pour Suzanne Duprez et l'autoriser à ouvrir une session entre 08:00 et 17:00, du lundi au vendredi (pas d'espace dans la désignation des heures) avec le mot de passe obligatoire (suzanned) et le nom complet de l'utilisateur, tapez :

net user suzanned /add /passwordreq:yes /times:lundi-vendredi,8:00-17:00 /fullname:"Suzanne Duprez"

Pour définir l'heure de connexion de johnsw (08:00 à 17:00) dans la plage 24 heures, tapez :

net user johnsw /time:M-F,08:00-17:00

Pour définir l'heure de connexion de johnsw (08:00 à 17:00) dans la plage 12 heures, tapez :

net user johnsw /time:M-F,8am-5pm

Pour autoriser marysl à se connecter entre 04:00 et 17:00 le lundi, entre 13:00 et 15:00 le mardi et entre 08:00 et 17:00 du mercredi au vendredi, tapez :

net user marysl /time:L,4:00-17:00;Ma,13:00-15:00;Me-V,8:00-17:00


Net view

Affiche la liste des domaines, des ordinateurs ou des ressources partagées par l'ordinateur spécifié. Utilisée sans paramètre, la commande net view affiche la liste des ordinateurs de votre domaine en cours.

Syntaxe

net view [\\nom_ordinateur] [/domain[:nom_domaine]]

net view /network:nw [\\nom_ordinateur]

Paramètres

\\nom_ordinateur
Indique l'ordinateur contenant les ressources partagées que vous souhaitez afficher.
/domain[:nom_domaine]
Désigne le domaine dont vous voulez afficher les ordinateurs disponibles. Si vous omettez nom_domaine, /domain affiche tous les domaines du réseau.
/network:nw
Affiche la liste des serveurs disponibles sur un réseau NetWare. Si vous indiquez un nom d'ordinateur, /network:nw affiche les ressources disponibles sur cet ordinateur du réseau NetWare. Vous pouvez également désigner d'autres réseaux ajoutés au système.
net help commande
Affiche l'aide pour la commande net spécifiée.

Remarques

  • Utilisez la commande net view pour afficher une liste d'ordinateurs. La sortie se présente comme suit :

    Nom du serveur           Remarque

    -------------------------------------------------

    \\Production          Serveur de fichier de production

    \\Print1              Pièce de l'imprimante, premier étage

    \\Print2              Pièce de l'imprimante, deuxième étage

Exemples

Pour afficher la liste des ressources partagées par l'ordinateur \\Production, tapez :

net view \\production

Pour afficher les ressources disponibles sur le serveur NetWare \\Marketing, tapez :

net view /network:nw \\marketing

Pour afficher la liste des ordinateurs du domaine ou du groupe de travail Ventes, tapez :

net view /domain:ventes

Pour afficher tous les serveurs d'un réseau NetWare, tapez :

net view /network:nw


Commandes Netsh pour AAAA

Vous pouvez utiliser des commandes dans le contexte Netsh AAAA pour afficher et définir la configuration de la base de données d'authentification, d'autorisation, de gestion des comptes et d'audit (AAAA) utilisée par IAS (Internet Authentication Service) et le service de routage et d'accès distant. La base de données AAAA porte également le nom de base de données IAS (Ias.mdb). La principale utilisation des commandes dans le contexte Netsh AAAA est d'exporter la configuration d'un serveur IAS sous la forme d'un script Netsh, puis d'importer cette configuration à l'aide de la commande netsh exec sur un autre serveur IAS.

Vous ne pouvez pas exécuter ces commandes Netsh en local sur Windows XP Professionnel ou Windows XP Édition Personnelle. Pour exécuter ces commandes Netsh sur un ordinateur distant fonctionnant sous Windows 2000 Server, vous devez tout d'abord utiliser Connexion au Bureau à distance pour vous connecter à un ordinateur fonctionnant sous Windows 2000 Server qui exécute Terminal Server. Vous pouvez exécuter ces commandes à partir de l'invite de commandes de Windows 2000 ou à partir de l'invite de commandes du contexte Netsh AAAA. Pour que ces commandes fonctionnent à l'invite de commandes de Windows 2000, vous devez taper netsh aaaa avant de taper les commandes et paramètres tels qu'ils apparaissent dans la syntaxe ci-dessous. Des différences fonctionnelles peuvent apparaître entre les commandes du contexte Netsh sur Windows 2000 et Windows XP.

Pour plus d'informations sur Netsh, consultez Utilisation de Netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

dump

Affiche la configuration du fichier de base de données IAS (Ias.mdb) sous la forme d'un script de commande Netsh.

Syntaxe

dump

Remarques

  • La commande dump affiche le script de commande Netsh que vous pouvez utiliser pour dupliquer la configuration du serveur exécutant IAS ou le service de routage et d'accès distant sur lequel la commande est exécutée. Le script de commande Netsh contient la configuration du fichier de base de données IAS (Ias.mdb) dans un format de texte compressé sous la forme d'un vaste bloc de données. Ce bloc de données est utilisé par la commande set config contenue dans le script pour importer la configuration d'un bloc de données enregistré dans une base de données IAS existante sur le même ou un autre ordinateur utilisant la commande netsh exec. Pour enregistrer le script de commande Netsh dans un fichier, tapez à l'invite de commandes : netsh aaaa show config > Chemin\Fichier.txt
  • La commande dump n'est pas prise en charge sur les ordinateurs qui exécutent Windows 2000 Server.

show config

Affiche la configuration du fichier de base de données IAS (Ias.mdb) sous la forme d'un script de commande Netsh.

Syntaxe

show config

Remarques

  • La commande show config est équivalente à la commande dump.
  • La commande show config affiche le script de commande Netsh que vous pouvez utiliser pour dupliquer la configuration du serveur exécutant IAS ou le service de routage et d'accès distant sur lequel la commande est exécutée. Le script de commande Netsh contient la configuration du fichier de base de données IAS (Ias.mdb) dans un format de texte compressé sous la forme d'un vaste bloc de données. Ce bloc de données est utilisé par la commande set config contenue dans le script pour importer la configuration d'un bloc de données enregistré dans une base de données IAS existante sur le même ou un autre ordinateur utilisant la commande netsh exec. Pour enregistrer le script de commande Netsh dans un fichier, tapez à l'invite de commandes : netsh aaaa show config > Chemin\Fichier.txt
  • La commande show config n'est pas prise en charge sur les ordinateurs qui exécutent Windows 2000 Server.

set config

Configure une base de données IAS avec les informations qui figurent dans le bloc de données spécifié.

Syntaxe

set config [blob=] BlocDonnées

Paramètres

[blob=] BlocDonnées
Requis. Spécifie la configuration de la base de données IAS dans un format de texte compressé tel que produit par les commandes dump ou show config.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Il n'y a aucune raison d'exécuter manuellement la commande set config. Cette commande doit être utilisée uniquement dans un script de commande Netsh créé à l'aide des commandes dump ou show config.
  • La version de la base de données IAS à partir de laquelle le bloc de données a été exporté doit correspondre à la version de la base de données IAS dans laquelle le bloc est importé. Pour afficher la version de la base de données IAS sur laquelle la configuration a été exportée, affichez le fichier de script de commande Netsh. Pour afficher la version de la base de données IAS sur laquelle le script Netsh s'exécute, utilisez la commande show version.

show version

Affiche la version de la base de données IAS.

Syntaxe

show version

Exemples

Pour afficher le script de commande Netsh qui reflète la base de données IAS dans son état actuel, tapez :

show config

Pour afficher la version de la base de données IAS qui s'exécute sur un serveur, tapez :

show version


Commandes Netsh pour DHCP

Les commandes Netsh pour DHCP offre un outil de ligne de commande utile à l'administration des serveurs DHCP et fournit une solution alternative équivalente à la gestion sur console. Elles sont utiles dans les cas suivants :

  • Lorsque vous gérez des serveurs DHCP sur des réseaux étendus (WAN), vous pouvez utiliser ces commandes en mode interactif à l'invite de commandes Netsh pour une meilleure gestion sur des liaisons de réseau de faible débit.
  • Lorsque vous gérez un grand nombre de serveurs DHCP, vous pouvez utiliser ces commandes en mode batch à l'invite de commande Netsh pour créer des scripts et automatiser les tâches d'administration récurrentes qui doivent être effectuées sur tous les serveurs DHCP.

Les commandes suivantes sont disponibles à l'invite de commande Netsh (par comparaison avec l'invite de commande Windows XP). Vous ne pouvez pas les exécuter localement sur Windows XP Professional ou Windows XP Home Edition. Pour exécuter ces commandes Netsh sur un serveur Windows 2000 à distance, utilisez d'abord la Connexion au Bureau à distance pour vous connecter à un serveur Windows 2000 sur lequel est exécuté Terminal Server. Quelques différences fonctionnelles entre les commandes de contexte Netsh peuvent apparaître sur Windows 2000 et Windows XP. Pour plus d'informations sur l'utilisation des commandes Netsh fournies pour DHCP, consultez Utiliser les outils de ligne de commande DHCP.

Pour obtenir un exemple d'utilisation des commandes Netsh pour DHCP dans des fichiers batch et des scripts, consultez Exemple Netsh DHCP.

Pour plus d'informations sur les commandes Netsh, consultez Utilitaire de ligne de commande Netsh.

Pour plus d'informations sur netsh, consultez Utilisation de Netsh.

Netsh DHCP

Les commandes suivantes sont disponibles à l'invite de commande dhcp> ayant pour racine l'environnement netsh.

Pour afficher la syntaxe d'une commande, sélectionnez-la :

add server

Ajoute un serveur DHCP à la liste des serveurs autorisés dans Active Directory.

Syntaxe

add server DNSServeur IPServeur

Paramètres

DNSServeur
Obligatoire. Spécifie le serveur DHCP à ajouter et identifie le serveur selon le nom du domaine DNS.
IPServeur
Obligatoire. Spécifie le serveur DHCP à ajouter et identifie le serveur selon l'adresse IP.

Exemples

Dans l'exemple ci-dessous, la commande ajoute un serveur avec le nom DNS dhcpsrv1.exemple.microsoft.com et l'adresse IP 10.2.2.2 à la liste des serveurs autorisés dans Active Directory.

add server dhcpsrv1.exemple.microsoft.com 10.2.2.2

delete server

Supprime un serveur DHCP de la liste des serveurs autorisés dans Active Directory.

Syntaxe

delete server DNSServeur IPServeur

Paramètres

DNSServeur
Obligatoire. Spécifie le serveur DHCP à supprimer et identifie le serveur selon le nom du domaine DNS.
IPServeur
Obligatoire. Spécifie le serveur DHCP à supprimer et identifie le serveur selon l'adresse IP.

Exemples

Dans l'exemple ci-dessous, la commande supprime le serveur avec le nom DNS dhcpsrv1.exemple.microsoft.com et l'adresse IP 10.2.2.2 de la liste des serveurs autorisés dans Active Directory..

delete server dhcpsrv1.exemple.microsoft.com 10.2.2.2

dump

Exporte la configuration d'un serveur DHCP vers la fenêtre d'invite de commande ou dans un fichier texte. Si aucun paramètre n'est utilisé, la commande exporte la configuration du serveur local vers la fenêtre d'invite de commande.

Syntaxe

[{\\NomServeur | AdresseIP}] dump > [NomFichier]

Paramètres

[{\\NomServeur | AdresseIP}]
Spécifie le nom du serveur DHCP à distance (non local) à partir duquel vous souhaitez exporter la configuration et identifie le serveur selon son nom ou son adresse IP. Si ce paramètre n'est pas spécifié, c'est la configuration du serveur local qui est exportée.
NomFichier
Spécifie le nom du fichier de destination vers lequel vous souhaitez exporter la configuration du serveur DHCP. Si ce paramètre n'est pas spécifié, la configuration du serveur DHCP est exportée vers la fenêtre d'invite de commande.

Remarques

  • Cette commande exporte la configuration DHCP sous forme de texte dans la fenêtre d'invite de commande. Il est également possible de copier ou de rediriger le texte en question dans un fichier pour consultation ultérieure dans un éditeur de texte. Une fois la sortie fichier créée, vous pouvez utiliser la commande exec pour exécuter le fichier de sortie afin de configurer un autre serveur DHCP.
  • Avant d'exécuter la commande dump sur le serveur source, rapprochez toutes les étendues et corrigez toutes les incohérences relevées.
  • La commande suivante permet d'exporter la configuration actuelle du serveur DHCP local (serveur source) vers un fichier texte intitulé dhcpcfg.dmp. Ce dernier peut ensuite être copié sur un nouveau serveur DHCP (serveur de destination) et utilisé pour recréer la configuration source sur le serveur de destination.

    dump > dhcpcfg.dmp

  • Avant d'utiliser la commande exec pour exécuter un fichier d'exportation sur le serveur de destination, effectuez les opérations suivantes :
    1. Fermez la console DHCP sur le serveur de destination. Ne la rouvrez qu'à la fin de l'exécution de la commande exec.
    2. Supprimez toutes les définitions d'options par défaut et toute classe utilisateur et fournisseur présente sur le serveur de destination.
  • Les exemples ci-dessous démontrent comment utiliser les commandes Netsh delete optiondef et del class pour mener à bien cette suppression. Vous pouvez exécuter les commandes suivantes à l'invite de commande dhcp server> ayant pour racine l'environnement netsh.
    • delete optiondef 01
    • delete optiondef 76
    • del class "Routage par défaut et classe d'accès à distance"
    • del class "Classe BOOTP par défaut"
    • del class "Options Microsoft Windows 2000"
    • del class "Options Microsoft Windows 98"
    • del class "Options Microsoft"
  • Sur le serveur de destination, la commande exec permet de charger et d'exécuter la configuration enregistrée :

    netsh exec dhcpcfg.dmp

  • Aprés avoir utilisé la commande exec pour charger le fichier d'exportation, rapprochez à nouveau toutes les étendues. Utilisez ensuite la commande net stop dhcpserver pour arrêter le service Serveur DHCP et la commande net start dhcpserver pour le relancer afin que les modifications de la base de données soient validées.

Exemples

Dans le premier exemple, la commande exporte la configuration du serveur DHCP \\DHCP-A vers un fichier texte intitulé dhcpcfg.dmp.

Dans le deuxième exemple, la commande exporte la configuration du serveur DHCP 10.0.0.1 vers un fichier texte intitulé dhcpcfg.dmp.

Dans le troisième exemple, la commande exporte la configuration du serveur DHCP local vers un fichier texte intitulé dhcpcfg.dmp.

\\DHCP-A dump > dhcpcfg.dmp

10.0.0.1 dump > dhcpcfg.dmp

dump > dhcpcfg.dmp

serveur

Déplace le contexte de la ligne de commande Netsh DHCP actuelle vers un serveur DHCP différent. Si aucun paramètre n'est utilisé, la commande server déplace le contexte de la ligne de commande actuelle vers l'ordinateur local.

Syntaxe

server [{\\NomServeur | IPServeur}]

Paramètres

{\\NomServeur | IPServeur}
Spécifie le serveur DHCP vers lequel vous souhaitez déplacer le contexte de la ligne de commande actuelle et identifie le serveur selon son nom NetBIOS ou son adresse IP.

Exemples

Dans le premier exemple, la commande remplace le contexte de la ligne de commande Netsh DHCP par le serveur DHCP intitulé \\DHCP-SRV1.

Dans le deuxième exemple, la commande remplace le contexte de la ligne de commande Netsh DHCP par l'adresse IP 10.0.0.1 du serveur DHCP.

server \\DHCP-SRV1

server 10.0.0.1

show server

Affiche une liste des serveurs autorisés dans Active Directory.

Syntaxe

show server

Paramètres

Aucun

Serveur Netsh DHCP

Les commandes suivantes sont disponibles à l'invite de commande dhcp> ayant pour racine l'environnement netsh.

Pour afficher la syntaxe d'une commande, sélectionnez-la :

add class

Ajoute une classe au serveur DHCP spécifié.

Syntaxe

add class NomClasse [CommentaireClasse] [Données] [[IsVendor=]{0 | 1}] [[IsBinary=]{B | b}]

Paramètres

NomClasse
Obligatoire. Spécifie le nom de la classe à créer.
CommentaireClasse
Spécifie le commentaire à associer avec la classe.
Données
Spécifie les données de la classe au format ASCII ou binaire selon le paramètre IsBinary défini. Si ce paramètre n'est pas spécifié, les données sont par défaut lues au format ASCII.
[IsVendor=]{0 | 1}
Indique si la classe à ajouter est une classe utilisateur ou une classe fournisseur : 0 - Classe utilisateur (valeur par défaut), 1 - Classe fournisseur.
[IsBinary=]{B | b}
Indique si les données de la classe sont au format binaire. Si ce paramètre n'est pas spécifié, les données sont par défaut lues au format ASCII.

Exemples

Dans le premier exemple, la commande crée une classe fournisseur intitulée MaClasse avec un commentaire ClasseTest et des données DonnéesTestPourMaClasse au format ASCII.

Dans le deuxième exemple, la commande crée une classe utilisateur intitulée MaClasseUtilisateur avec des données binaires 4345335532 (ASCII-CE3U2).

Le troisième exemple offre une solution de syntaxe de commande en remplacement éventuel du deuxième exemple.

add class MaClasse ClasseTest DonnéesTestPourMaClasse1

add class MaClasseUtilisateur ClasseTest1 4345335532 B

add class MaClasseUtilisateur ClasseTest1 4345335532 0 b

add mscope

Ajoute une étendue de multidiffusion au serveur DHCP spécifié.

Syntaxe

add mscope NomÉtendueM [CommentaireÉtendueM] [TTL]

Paramètres

NomÉtendueM
Obligatoire. Spécifie le nom de l'étendue de multidiffusion à ajouter.
CommentaireMscope
Fournit une description de l'étendue de multidiffusion actuelle.
TTL
Spécifie la valeur de durée de vie (TTL) de l'étendue de multidiffusion. La valeur correcte pour ce champ doit être comprise entre 1 et 255 ; la valeur par défaut est 32.

Exemples

Dans l'exemple ci-dessous, la commande crée une étendue de multidiffusion intitulée MonÉtendueMultidiffusion avec un commentaire MonÉtendueMultidiffusionTest et une valeur de durée de vie définie à 40.

add mscope "MonÉtendueMultidiffusion" MonÉtendueMultidiffusionTest 40

add optiondef

Ajoute une nouvelle définition d'option au serveur DHCP spécifié.

Syntaxe

add optiondef CodeOption NomOption {BYTE | WORD | DWORD | STRING | IPADDRESS} [[IsArray=]{0 | 1}] [vendor=ClasseFournisseur] [comment=CommentaireOption] [ValeurDéfaut]

Paramètres

CodeOption
Obligatoire. Spécifie le type d'option à définir et l'identifie avec un code d'option unique. Pour la valeur du code, choisissez un nombre compris entre 0 et 255.
NomOption
Obligatoire. Spécifie le nom du type d'option.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Obligatoire. Indique le type de données de l'option.
[IsArray=]{0 | 1}
Indique si le type de données est tableau ou non-tableau : 0 - Unaire ou non-tableau (valeur par défaut), 1 - Tableau.
vendor=ClasseFournisseur
Spécifie la classe fournisseur de l'option. Si ce paramètre n'est pas spécifié, la classe fournisseur par défaut (classe des options DHCP standard) est utilisée.
comment=CommentaireOption
Spécifie un commentaire à ajouter à la nouvelle définition de type d'option. Si ce paramètre n'est pas spécifié, la valeur par défaut est NULL.
ValeurDéfaut
Spécifie une valeur par défaut à utiliser pour ce type d'option (si aucune valeur n'est autrement définie).

Remarques

  • La valeur IsArray doit être définie à 0 pour les options de type STRING.

Exemples

Dans le premier exemple, la commande définit un nouveau type d'option intitulé CheminExtensions avec le code 18 et un type de données STRING et l'associe à la classe d'options DHCP standard en lui attribuant par défaut la valeur c:\temp.

Dans les deuxième et troisième exemples, la commande définit un nouveau type d'option intitulé OptionTest avec le code 231 et le type de données IPADDRESS. Dans le deuxième exemple, l'option est définie pour fournir une adresse IP unique. Les valeurs IsArray et ValeurDéfaut ne sont pas nécessaires car les valeurs par défaut conviennent. Dans le troisième exemple, les paramètres ValeurDéfaut et IsArray sont nécessaires pour créer un tableau contenant les valeurs d'adresse IP 10.1.1.1, 10.1.1.2 et 10.1.1.3.

add optiondef 18 CheminExtensions STRING 0 c:\temp

add optiondef 231 OptionTest IPADDRESS

add optiondef 231 OptionTest IPADDRESS 1 vendor=MaClasseFournisseur 10.1.1.1 10.1.1.2 10.1.1.3

add scope

Ajoute une étendue au serveur DHCP spécifié.

Syntaxe

add scope AdresseÉtendue MasqueSousRéseau NomÉtendue [CommentaireÉtendue]

Paramètres

AdresseÉtendue
Obligatoire. Spécifie l'étendue à ajouter et l'identifie selon le numéro du réseau IP.
MasqueSousRéseau
Obligatoire. Spécifie le masque de sous-réseau de l'étendue à ajouter.
NomÉtendue
Obligatoire. Spécifie un nom identifiant l'étendue.
CommentaireÉtendue
Spécifie un commentaire associé à l'étendue.

Exemples

Dans l'exemple ci-dessous, la commande ajoute une étendue au serveur DHCP spécifié avec l'adresse 10.2.2.0, le masque de sous-réseau 255.255.255.0, le nom MonÉtendue et le commentaire associé MonCommentaire.

add scope 10.2.2.0 255.255.255.0 MonÉtendue MonCommentaire

delete class

Supprime une classe du serveur DHCP spécifié.

Syntaxe

delete class Nom

Paramètres

Nom
Obligatoire. Spécifie la classe utilisateur ou fournisseur à supprimer.

Exemples

Dans l'exemple ci-dessous, la commande supprime la classe intitulée MaClasse.

delete class MaClasse

delete mscope

Supprime une étendue de multidiffusion du serveur DHCP spécifié.

Syntaxe

delete mscope NomÉtendueM

Paramètres

NomÉtendueM
Obligatoire. Spécifie l'étendue de multidiffusion à supprimer. NomÉtendueM tient compte de la casse.

Exemples

Dans l'exemple ci-dessous, la commande supprime l'étendue de multidiffusion MonÉtendueMultidiffusion du serveur DHCP actuellement spécifié.

delete mscope MonÉtendueMultidiffusion

delete optiondef

Supprime un type d'option défini du serveur DHCP spécifié.

Syntaxe

delete optiondef CodeOption [[vendor=]NomFournisseur]

Paramètres

CodeOption
Obligatoire. Spécifie l'identificateur unique du type d'option à supprimer.
vendor=NomFournisseur
Spécifie le nom de la classe fournisseur auquel le type d'option est associé. Si ce paramètre n'est pas spécifié, la définition du type d'option est supprimée de la classe spécifique non-fournisseur des options DHCP standard.

Remarques

  • Cette option s'applique uniquement aux serveurs DHCP exécutant Windows 2000 Server.

Exemples

Dans l'exemple ci-dessous, la commande supprime un type d'option avec le code 18 de la classe des options DHCP standard.

delete optiondef 18

delete optionvalue

Supprime la valeur actuelle du type d'option spécifié pour le serveur DHCP actuel.

Syntaxe

delete optionvalue CodeOption [[vendor=]ClasseFournisseur] [[user=]ClasseUtilisateur]

Paramètres

CodeOption
Obligatoire. Spécifie l'identificateur unique de l'option de serveur globale avec une valeur à supprimer.
vendor=ClasseFournisseur
Spécifie le nom de la classe fournisseur auquel le type d'option est associé. Si la balise n'est pas fournie, le paramètre global NomFournisseur défini par set vendorclass est utilisé. Si la balise est utilisée mais qu'aucune valeur n'est spécifiée, aucune classe fournisseur n'est alors utilisée. Ce paramètre est disponible uniquement pour les ordinateurs exécutant Windows 2000 Server.
user=ClasseUtilisateur
Spécifie le nom de la classe utilisateur auquel le type d'option est associé. Si la balise n'est pas fournie, le paramètre global NomUtilisateur défini par set userclass est utilisé Si la balise est utilisée mais qu'aucune valeur n'est spécifiée, aucune classe utilisateur n'est alors utilisée. Ce paramètre est disponible uniquement pour les ordinateurs exécutant Windows 2000 Server.

Exemples

Dans l'exemple ci-dessous, la commande supprime la valeur actuelle du type d'option avec le code 18.

delete optionvalue 18

delete scope

Supprime une étendue du serveur DHCP spécifié.

Syntaxe

delete scope AdresseÉtendue {DHCPNOFORCE | DHCPFULLFORCE}

Paramètres

AdresseÉtendue
Obligatoire. Spécifie l'adresse de l'étendue à supprimer.
{DHCPNOFORCE | DHCPFULLFORCE}
Obligatoire. Indique la force avec laquelle l'étendue est supprimée : DHCPNOFORCE supprime l'étendue si aucun client actif n'y figure, DHCPFULLFORCE supprime l'étendue même si des clients actifs y figurent.

Exemples

Dans l'exemple ci-dessous, la commande force la suppression de l'étendue 10.2.2.0 du serveur DHCP et ignore tous les avertissements émis.

delete scope 10.2.2.0 dhcpfullforce

delete superscope

Supprime une super-étendue du serveur DHCP spécifié.

Syntaxe

delete superscope NomSuperscope

Paramètres

NomSuperÉtendue
Obligatoire. Spécifie le nom de la super-étendue à supprimer.

Remarques

  • Vous pouvez définir la super-étendue à partir du contexte de l'étendue à l'aide de la commande set superscope.
  • Le nom de la super-étendue tient compte de la casse.

Exemples

Dans l'exemple ci-dessous, la commande supprime la super-étendue intitulée MaSuperÉtendue du serveur DHCP spécifié.

delete superscope "Mon Superscope"

export

Exporte la configuration du service DHCP dans un fichier.

Syntaxe

export [Chemin]NomFichier {all | ListeScope}

Paramètres

[Chemin] NomFichier
Obligatoire. Spécifie, par son nom, le fichier dans lequel la configuration DHCP sera stockée. Si le chemin, le nom de fichier, ou les deux contiennent des espaces, des guillemets doivent être utilisés.
{all | ListeScope}
Obligatoire. Spécifie quelles étendues vous voulez exporter. Le paramètre all exporte toutes les étendues. Le paramètres ListeEtendue exporte les étendues qui correspondent aux adresses IP que vous listez. Chaque adresse IP de la liste doit être séparée par des espaces.

Remarques

  • Cette commande ne fonctionne que sur le serveur local.
  • Pendant que la commande export est exécutée, le service DHCP est arrêté et ne répond pas aux clients DHCP qui recherchent de nouveaux bails ou des renouvellements de bail .
  • Si le service DHCP a un grand nombre d'étendues ou un grand nombre de baux d'adresses client, l'exécution de cette commande peut prendre un certain temps.

Exemples

Dans le premier exemple, cette commande exporte la configuration du service DHCP complet dans le fichier c:\temp\dhcpdb.

Dans le second exemple, cette commande exporte la configuration DHCP pour les étendues 10.0.0.0 et 192.168.0.0 dans le fichier c:\temp\dhcpdb.

Dans le troisième exemple, cette commande exporte la configuration du service DHCP complet dans le fichier C:\My Folder\Dhcp Configuration. Remarque : le chemin d'accès et le nom de fichier contiennent des espaces ; c'est pourquoi des guillemets sont utilisés.

export c:\temp\dhcpdb all

export c:\temp\dhcpdb 10.0.0.0 192.168.0.0

export "C:\My Folder\Dhcp Configuration" all

import

Importe une configuration de service DHCP à partir d'un fichier vers le service local.

Syntaxe

import [Chemin]NomFichier {all | ListeScope}

Paramètres

[Chemin] NomFichier
Obligatoire. Spécifie, par son nom, le fichier à partir duquel la configuration DHCP sera importée. Si le chemin, le nom de fichier, ou les deux contiennent des espaces, des guillemets doivent être utilisés.
{all | ListeScope}
Obligatoire. Spécifie quelles étendues vous voulez importer. Le paramètre all permet d'importer toutes les étendues représentées dans le fichier que vous spécifiez. Le paramètre ListeEtendue permet d'importer les étendues qui correspondent aux adresses IP que vous listez. Chaque adresse IP de la liste doit être séparée par des espaces.

Remarques

  • Cette commande ne fonctionne que sur le serveur local.
  • Pendant que la commande import est exécutée, le service DHCP est arrêté et ne répond pas aux clients DHCP qui recherchent de nouveaux baux ou des renouvellements de bail .
  • Si le service DHCP a un grand nombre d'étendues ou un grand nombre de baux d'adresses client, l'exécution de cette commande peut prendre un certain temps.

Exemples

Dans le premier exemple, cette commande importe la configuration du service DHCP complet à partir du fichier c:\temp\dhcpdb.

Dans le second exemple, cette commande importe la configuration DHCP pour les étendues 10.0.0.0 et 192.168.0.0 à partir du fichier c:\temp\dhcpdb.

Dans le troisième exemple, cette commande importe la configuration du service DHCP complet dans le fichier C:\My Folder\Dhcp Configuration. Remarque : le chemin d'accès et le nom de fichier contiennent des espaces ; c'est pourquoi des guillemets sont utilisés.

import c:\temp\dhcpdb all

import c:\temp\dhcpdb 10.0.0.0 192.168.0.0

import "C:\My Folder\Dhcp Configuration" all

initiate auth

Active l'autorisation du serveur DHCP spécifié dans Active Directory.

Syntaxe

initiate auth

Paramètres

Aucun

mscope

Bascule le contexte de commande vers une étendue de multidiffusion DHCP.

Syntaxe

mscope NomÉtendueM

Paramètres

NomÉtendueM
Obligatoire. Spécifie le nom de l'étendue de multidiffusion vers laquelle le contexte de commande est basculé.

Remarques

  • Cette commande vous permet d'utiliser une des commandes d'étendue de multidiffusion DHCP sur l'étendue de multidiffusion DHCP spécifiée. Les opérations ultérieures seront effectuées sur cette étendue de multidiffusion sur le serveur spécifié.
  • Le nom de l'étendue de multidiffusion tient compte de la casse.

Exemples

Dans l'exemple ci-dessous, la commande bascule le contexte de commande vers une étendue de multidiffusion intitulée MonÉtendueMultidiffusion.

mscope "MonÉtendueMultidiffusion"

scope

Bascule le contexte de commande vers une étendue DHCP.

Syntaxe

scope AdresseIPÉtendue

Paramètres

AdresseIPÉtendue
Obligatoire. Spécifie l'étendue vers laquelle basculer le contexte de commande et l'identifie selon l'adresse IP du réseau ou du sous-réseau.

Remarques

  • Cette commande vous permet d'utiliser une des commandes d'étendue DHCP disponibles dans l'étendue de multidiffusion DHCP spécifiée. Les opérations ultérieures seront effectuées sur cette étendue sur le serveur spécifié.

Exemples

Dans l'exemple ci-dessous, la commande bascule le contexte de commande vers l'étendue dont l'adresse IP est 10.0.0.0.

scope 10.0.0.0

set auditlog

Définit les paramètres de chemin d'accès du journal d'audit pour le serveur DHCP spécifié.

Syntaxe

set auditlog NouveauCheminAudit

Paramètres

NouveauCheminAudit
Obligatoire. Spécifie pour le serveur DHCP un dossier local à utiliser lors du stockage des fichiers journaux d'audit. Un chemin de dossier valide est nécessaire et le dossier doit résider localement sur le serveur DHCP où le chemin est défini.

Remarques

  • Après avoir exécuté cette commande, vous devez arrêter et redémarrer le service DHCP pour que cette modification soit prise en compte.

Exemples

Dans l'exemple ci-dessous, la commande définit le serveur DHCP pour stocker des fichiers journaux d'audit dans le répertoire c:\Journaux.

set auditlog c:\Journaux

set databasebackupinterval

Définit l'intervalle de sauvegarde pour le serveur DHCP spécifié.

Syntaxe

set databasebackupinterval NouvelIntervalle

Paramètres

NouvelIntervalle
Obligatoire. Spécifie l'intervalle de sauvegarde en minutes.

Exemples

Dans l'exemple ci-dessous, la commande définit à 1440 minutes (24 heures) l'intervalle de sauvegarde de la base de données du serveur DHCP spécifié.

set databasebackupinterval 1440

set databasebackuppath

Définit le chemin de sauvegarde de la base de données du serveur DHCP spécifié.

Syntaxe

set databasebackuppath NouveauCheminSauvegarde

Paramètres

NouveauCheminSauvegarde
Obligatoire. Spécifie pour le serveur DHCP un dossier local à utiliser lors du stockage des fichiers journaux d'audit. Un chemin de dossier valide est nécessaire et le dossier doit résider localement sur le serveur DHCP où le chemin est défini.

Exemples

Dans l'exemple ci-dessous, la commande définit c:\winnnt\dhcp\backup comme chemin de sauvegarde de la base de données.

set databasebackuppath c:\winnt\dhcp\backup

set databasecleanupinterval

Définit l'intervalle de nettoyage de la base de données du serveur DHCP spécifié.

Syntaxe

set databasecleanupinterval NouvelIntervalle

Paramètres

NouvelIntervalle
Obligatoire. Spécifie l'intervalle de nettoyage de la base de données en minutes.

Exemples

Dans l'exemple ci-dessous, la commande définit l'intervalle de nettoyage de la base de données à 10 080 minutes (tous les sept jours).

set databasecleanupinterval 10080

set databaseloggingflag

Active ou désactive l'indicateur de journalisation de la base de données du serveur DHCP spécifié. Si aucun paramètre n'est utilisé, la commande désactive l'indicateur de journalisation de la base de données.

Syntaxe

set databaseloggingflag [{0 | 1}]

Paramètres

{0 | 1}
Indique le paramètre d'indicateur de journalisation de la base de données : 0 désactive l'indicateur (valeur par défaut), 1 active l'indicateur.

Exemples

Dans l'exemple ci-dessous, la commande désactive l'indicateur de journalisation de la base de données du serveur DHCP actuellement spécifié.

set databaseloggingflag 0

set databasename

Définit le nom du fichier base de données du serveur DHCP spécifié.

Syntaxe

set databasename NouveauNomFichier

Paramètres

NouveauNomFichier
Obligatoire. Spécifie un nouveau nom pour le fichier base de données du serveur DHCP.

Remarques

  • Vous devez arrêter, puis redémarrer le service Serveur DHCP pour que cette modification soit prise en compte.

Exemples

Dans l'exemple ci-dessous, la commande définit newdatabase.mdb comme nom de fichier base de données du serveur DHCP.

set databasename newdatabase.mdb

set databasepath

Définit le chemin du fichier base de données du serveur DHCP spécifié.

Syntaxe

set databasepath NouveauChemin

Paramètres

NouveauChemin
Obligatoire. Spécifie le chemin du fichier base de données DHCP.

Remarques

  • Vous devez arrêter, puis redémarrer le service Serveur DHCP pour que cette modification soit prise en compte.

Exemples

Dans l'exemple ci-dessous, la commande définit c:\winnt\dhcp comme chemin du fichier base de données du serveur DHCP.

set databasepath c:\winnt\dhcp

set databaserestoreflag

Active ou désactive l'indicateur de restauration de la base de données du serveur DHCP spécifié. Si aucun paramètre n'est utilisé, la commande désactive l'indicateur de restauration de la base de données.

Syntaxe

set databaserestoreflag [{0 | 1}]

Paramètres

{0 | 1}
Indique le paramètre d'indicateur de restauration de la base de données : 0 désactive l'indicateur (valeur par défaut), 1 active l'indicateur.

Exemples

Dans l'exemple ci-dessous, la commande désactive l'indicateur de restauration de la base de données du serveur DHCP actuellement spécifié.

set databaserestoreflag 1

set detectconflictretry

Définit le nombre de tentatives de détection de conflit pour le serveur DHCP spécifié.

Syntaxe

set detectconflictretry NombreTentatives

Paramètres

NombreTentatives
Obligatoire. Spécifie le nombre de tentatives de détection de conflit que le serveur DHCP doit effectuer pour une adresse IP d'étendue avant de l'allouer à un client.

Remarques

  • Le nombre maximal de NouvelleTentatives autorisées est cinq. Toutes les valeurs supérieures à cinq seront par défaut ramenées à cinq.

Exemples

Dans l'exemple ci-dessous, la commande définit le serveur DHCP afin qu'il tente à quatre reprises de détecter un éventuel conflit pour une adresse IP d'étendue avant de l'utiliser dans un nouveau bail d'adresse.

set detectconflictretry 4

set dnsconfig

Définit la configuration de la mise à jour DNS dynamique pour le serveur DHCP spécifié.

Syntaxe

set dnsconfig [Enable=]{0|1} [[Update=]{0|1}] [[Lookup=]{0|1}] [[NonDyn=]{0|1}]

Paramètres

[Enable=]{0|1}
Obligatoire. Indique s'il faut activer ou désactiver les mises à jour dynamiques des informations du client DNS : 0 désactive les mises à jour dynamiques des informations du client DNS, 1 active les mises à jour dynamiques des informations du client DNS
[Update=]{0|1}
Indique le type de mise à jour à rechercher : 0 désactive les mises à jour selon la demande du client, 1 met à jour les recherches de nom directes et inversées.
[Lookup=]{0|1}
Indique s'il faut activer ou désactiver la recherche directe de clients lorsque des baux expirent : 0 désactive la recherche directe, 1 active la recherche directe.
[NonDyn=]{0|1}
Indique s'il faut mettre à jour les informations DNS pour les clients qui ne prennent pas en charge les mises à jour dynamiques : 0 désactive les mises à jour pour les clients qui ne prennent pas en charge les mises à jour dynamiques, 1 active ces mises à jour.

Remarques

  • Cette commande est uniquement prise en charge pour les serveurs DHCP exécutant Windows 2000 Server.
  • Le serveur DNS préféré configuré (propriétés TCP/IP du serveur DHCP) est mis à jour avec les enregistrements du client DHCP lorsque les mises à jour dynamiques sont activées. Si ce serveur n'est pas disponible sur le réseau, c'est le serveur DNS auxiliaire qui est mis à jour.

Exemples

Dans l'exemple ci-dessous, la commande permet d'activer la mise à jour dynamique des informations DNS par le serveur DHCP et de toujours configurer les mises à jour pour des recherches directes et inversées à la fois. Dans cet exemple, il est également possible de désactiver l'option permettant de lancer une recherche directe lorsque des baux expirent et d'activer les mises à jour de clients non dynamiques.

set dnsconfig 1 1 0 1

set optionvalue

Définit la valeur d'une option de serveur DHCP à appliquer à toutes les étendues définies sur le serveur DHCP spécifié.

Syntaxe

set optionvalue CodeOption {BYTE | WORD | DWORD | STRING | IPADDRESS} [[user=]NomUtilisateur] [[vendor=]NomFournisseur] [ValeurOption]

Paramètres

CodeOption
Obligatoire. Spécifie l'identifica teur unique pour le type d'option dont la valeur doit être définie.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Obligatoire. Spécifie le type de données pour le type d'option dont la valeur doit être définie.
[user=]NomUtilisateur
Définit le nom de la classe utilisateur à laquelle cette commande doit s'appliquer. Si ce paramètre n'est pas spécifié, la classe utilisateur par défaut est utilisée.
[vendor=]NomFournisseur
Définit le nom de la classe fournisseur à laquelle cette commande doit s'appliquer. Si ce paramètre n'est pas spécifié, la classe des options DHCP standard est utilisée.
[ValeurOption]
Spécifie la nouvelle valeur par défaut du serveur pour le type d'option identifié par le paramètre CodeOption. Cette valeur doit correspondre au type de données associé.

Remarques

  • Les classes fournisseur et utilisateur sont prises en charge uniquement pour les serveurs DHCP exécutant Windows 2000 Server.
  • Pour modifier les paramètres par défaut actuels d'une classe non spécifiée, utilisez la commande set userclass ou set vendorclass.

Exemples

Dans le premier exemple, la commande définit la valeur du code d'option 003 pour afficher deux adresses IP du routeur : 10.1.1.1 et 10.1.1.2.

Dans le deuxième exemple, la commande détaille mieux encore le premier exemple et définit la valeur spécifiée à appliquer uniquement aux clients de l'étendue identifiés comme membres de la classe fournisseur Fournisseur1. Pour que cet exemple puisse s'appliquer, cette classe doit déjà être définie sur le serveur, de même que le type d'option spécifié pour son usage.

set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

set optionvalue 003 IPADDRESS vendor=Fournisseur1 10.1.1.1 10.1.1.2

set server

Remplace le contexte de la ligne de commande Netsh par le serveur spécifié. Si aucun paramètre n'est utilisé, le serveur local est utilisé.

Syntaxe

set server [{IPServeur | \\DNSServeur}]

Paramètres

{IPServeur | \\DNSServeur}
Spécifie l'adresse IP ou le nom DNS du serveur DHCP spécifié.

Remarques

  • Lorsque vous utilisez cette commande et remplacez le contexte de la ligne de commande Netsh par un autre serveur, toutes les opérations de commande ultérieures sont effectuées sur le serveur spécifié. Pour les effectuer sur un autre serveur, vous devez réexécuter cette commande à l'aide de l'adresse IP ou du nom DNS du nouveau serveur.

Exemples

Dans l'exemple ci-dessous, la commande bascule le contexte de la ligne de commande du serveur DHCP vers le serveur à l'adresse IP 10.1.1.1

set server 10.1.1.1

set userclass

Définit le nom de la classe utilisateur actuelle. Si aucun paramètre n'est utilisé, la classe utilisateur actuelle reprend sa valeur par défaut.

Syntaxe

set userclass [ClasseUtilisateur]

Paramètres

ClasseUtilisateur
Spécifie le nom de la classe utilisateur du serveur DHCP actuellement spécifié.

Remarques

  • Cette commande est disponible uniquement pour les serveurs DHCP exécutant Windows 2000 Server.

Exemples

Dans le premier exemple, la commande définit MaClasseUtilisateur comme nom de la classe utilisateur.

Dans le deuxième exemple, la commande redéfinit la classe utilisateur actuelle à sa valeur par défaut.

set userclass MaClasseUtilisateur

set userclass

set vendorclass

Définit le nom de la classe fournisseur actuelle. Si aucun paramètre n'est utilisé, la classe fournisseur actuelle reprend sa valeur de classe par défaut (classe des options DHCP standard).

Syntaxe

set vendorclass [ClasseFournisseur]

Paramètres

ClasseFournisseur
Spécifie le nom de la classe fournisseur du serveur actuellement spécifié.

Remarques

  • Cette commande est disponible uniquement pour les serveurs DHCP exécutant Windows 2000 Server.

Exemples

Dans le premier exemple, la commande définit MaClasseFournisseur comme nom de la classe fournisseur.

Dans le deuxième exemple, la commande redéfinit la classe fournisseur actuelle à sa valeur de classe par défaut (classe des options DHCP standard).

set vendorclass MaClasseFournisseur

set vendorclass

show all

Affiche toutes les informations de configuration et d'état du serveur DHCP spécifié.

Syntaxe

show all

Paramètres

Aucun

Remarques

  • Cette commande répertorie toutes les informations détaillées sur la configuration et l'état du serveur DHCP actuellement spécifié, notamment les informations MIB (Management Information Base) qui y sont stockées.

show auditlog

Affiche toutes les informations du journal d'audit du serveur DHCP spécifié.

Syntaxe

show auditlog

Paramètres

Aucun

show bindings

Affiche les informations sur les liaisons du serveur DHCP spécifié.

Syntaxe

show bindings

Paramètres

Aucun

Remarques

  • Cette commande affiche les informations relatives aux liaisons du serveur DHCP actuel et indique quelles connexions actives du réseau, configurées avec des adresses IP statiques, sont activées ou désactivées afin de servir les clients DHCP présents sur votre réseau.
  • Le service DHCP désactive automatiquement les connexions réseau recevant dynamiquement de liaisons de services leur configuration d'adresse IP. Il s'agit du comportement par défaut.

show class

Énumère et affiche toutes les informations sur les classes du serveur DHCP spécifié. Cela comprend à la fois les informations de classe utilisateur et fournisseur.

Syntaxe

show class

Paramètres

Aucun

show detectconflictretry

Affiche le nombre configuré de tentatives de détection de conflit sur le serveur DHCP spécifié.

Syntaxe

show detectconflictretry

Paramètres

Aucun

Remarques

  • Cette commande affiche le nombre actuel de tentatives PING effectuées pour essayer de détecter des conflits d'adresses pour les adresses IP de l'étendue distribuées par le serveur.

show dnsconfig

Affiche la configuration de la mise à jour DNS dynamique pour le serveur DHCP spécifié.

Syntaxe

show dnsconfig

Paramètres

Aucun

Remarques

  • Si la configuration DNS n'a été ni activée ni définie, vous pouvez utiliser la console DNS ou la commande set dnsconfig pour configurer ces paramètres.

show mibinfo

Affiche les informations MIB (Management Information Base) pour le serveur DHCP spécifié.

Syntaxe

show mibinfo

Paramètres

Aucun

show mscope

Affiche toutes les informations sur les étendues de multidiffusion pour le serveur DHCP spécifié.

Syntaxe

show mscope

Paramètres

Aucun

show optiondef

Affiche tous les types d'options définis et disponibles à utiliser sur le serveur DHCP spécifié. Si aucun paramètre n'est utilisé, toutes les options s'affichent.

Syntaxe

show optiondef [vendor=NomFournisseur]

Paramètres

vendor=NomFournisseur
Indique quels types d'options définis ou disponibles doivent être affichés. Si ce paramètre n'est pas spécifié, la valeur NomFournisseur utilisée par défaut est la classe fournisseur actuellement définie pour le serveur DHCP.

Remarques

  • Vous pouvez redéfinir cette classe fournisseur par défaut à l'aide de la commande set vendorclass.
  • Le paramètre NomFournisseur s'applique uniquement aux serveurs DHCP exécutant Windows 2000 Server.

Exemples

Dans le premier exemple, la commande affiche tous les types d'options définis pour la classe fournisseur actuelle.

Dans le deuxième exemple, la commande affiche les types d'options définis et disponibles pour une utilisation avec la classe spécifiée Fournisseur1.

show optiondef

show optiondef vendor=Fournisseur1

show optionvalue

Affiche toutes les valeurs d'options disponibles actuellement définies pour le serveur DHCP spécifié. Si aucun paramètre n'est utilisée, toutes les valeurs d'options s'affichent, y compris les valeurs utilisées à la fois pour les classes utilisateur et les classes fournisseur.

Syntaxe

show optionvalue [user=NomUtilisateur | vendor=NomFournisseur]

Paramètres

user=NomUtilisateur
Spécifie les valeurs par défaut définies pour les types d'options disponibles pour une utilisation avec la classe utilisateur actuelle.
vendor=NomFournisseur
Spécifie les valeurs par défaut définies pour les types d'options disponibles pour une utilisation avec la classe fournisseur actuelle.

Remarques

  • Les paramètres user=NomUtilisateur et vendor=NomFournisseur sont uniquement disponibles pour les serveurs DHCP exécutant Windows 2000 Server.
  • Si vous définissez des valeurs pour NomUtilisateur ou NomFournisseur, leurs balises respectives (user= ou vendor=) sont obligatoires. Si elles ne sont pas fournies, la classe utilisateur actuelle (précédemment définie à l'aide de la commande set userclass) est utiliseé par défaut.

Exemples

Dans l'exemple ci-dessous, la commande affiche tous les types d'options disponibles disposant de valeurs définies sur le serveur DHCP actuellement spécifié.

show optionvalue

show scope

Affiche toutes les informations sur les étendues du serveur DHCP spécifié.

Syntaxe

show scope

Paramètres

Aucun

show server

Affiche les informations sur le serveur DHCP spécifié, y compris le nom complet du domaine et l'adresse IP du serveur.

Syntaxe

show server

Paramètres

Aucun

show dbproperties

Affiche les informations de configuration de la base de données du serveur DHCP spécifié.

Syntaxe

show dbproperties

Paramètres

Aucun

Remarques

  • Cette commande affiche les informations de configuration de la base de données suivantes :
    • DatabaseName
    • DatabasePath
    • DatabaseBackupPath
    • DatabaseBackupInterval
    • DatabaseLoggingFlag
    • DatabaseRestoreFlag
    • DatabaseCleanupInterval

show serverstatus

Affiche les informations d'état du serveur DHCP spécifié.

Syntaxe

show serverstatus

Paramètres

Aucun

Remarques

  • L'exemple ci-dessous montre le type d'informations d'état qu'affiche cette commande :

    Attributs du serveur - serveur traitant les clients :TRUE

    Attributs du serveur - prise en charge BootP dynamique activée :TRUE

    Attributs du serveur - serveur DHCP faisant partie du DS :TRUE

    Attributs du serveur - serveur DHCP reconnaissant les liaisons :TRUE

    Attributs du serveur - droits administratifs :TRUE

show userclass

Affiche le paramètre actuel de classe utilisateur pour le serveur DHCP spécifié.

Syntaxe

show userclass

Paramètres

Aucun

Remarques

  • L'exemple ci-dessous montre le type d'informations de paramètres qu'affiche cette commande :

    Le nom de classe actuel défini pour le serveur dhcpsrv1.exemple.microsoft.com est Aucun.

show vendorclass

Affiche le paramètre actuel de classe fournisseur pour le serveur DHCP spécifié.

Syntaxe

show vendorclass

Paramètres

Aucun

Remarques

  • L'exemple ci-dessous montre le type d'informations de paramètres qu'affiche cette commande :

    Le nom de fournisseur actuel défini pour le serveur dhcpsrv1.exemple.microsoft.com est Aucun.

show version

Affiche les informations sur la version actuelle du serveur DHCP spécifié.

Syntaxe

show version

Paramètres

Aucun

Remarques

  • L'exemple ci-dessous montre le type d'informations de version qu'affiche cette commande :

    La version du serveur DHCP 192.168.0.100 est 5.6.

Étendue du serveur Netsh DHCP

Les commandes suivantes sont disponibles à l'invite de commande dhcp server scope> ayant pour racine l'environnement netsh.

Pour afficher la syntaxe d'une commande, sélectionnez-la :

add excluderange

Ajoute une plage d'adresses à exclure de la distribution dans l'étendue actuelle.

Syntaxe

add excluderange IPDébut IPFin

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage d'exclusion.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage d'exclusion.

Exemples

Dans l'exemple ci-dessous, la commande exclut les adresses IP de la plage 10.2.2.10 à 10.2.2.20 de la distribution au sein de l'étendue.

add excluderange 10,2.2.10 10,2.2.20

add iprange

Ajoute une plage d'adresses IP à l'étendue actuelle.

Syntaxe

add iprange IPDébut IPFin [{DHCP | BOOTP | BOTH}] [MaxBootP]

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage.
{DHCP | BOOTP | BOTH}
Spécifie le type de client à servir dans cette étendue et cette plage IP. Le paramètre DHCP est utilisé par défaut.
MaxBootP
Spécifie le nombre maximal de clients BOOTP.

Remarques

  • Le paramètre MaxBootP est utile uniquement si TypeClient est défini pour prendre en charge les clients de type BOOTP pour l'étendue. Si une option de ligne de commande facultative est utilisée, toutes les options de la ligne de commande (obligatoires comme facultatives) placées avant celle-ci doivent être fournies dans l'ordre approprié.

Exemples

Dans l'exemple ci-dessous, la commande ajoute des clients DHCP contenus dans les plages d'adresses IP 10.2.2.10 à 10.2.2.20 à la plage de distribution dans l'étendue.

add iprange 10,2.2.10 10,2.2.20

add reservedip

Réserve une adresse IP destinée à une adresse MAC (Media Access Control) spécifiée dans l'étendue actuelle.

Syntaxe

add reservedip IPRéservée AdresseMAC [NomClient] [CommentaireClient] [{DHCP | BOOTP | BOTH}]

Paramètres

IPRéservée
Obligatoire. Spécifie l'adresse IP à réserver.
AdresseMAC
Obligatoire. Spécifie l'adresse de matériel physique ou MAC (Media Access Control) à associer à l'adresse IP réservée.
NomClient
Spécifie un nom de client à associer à cette entrée de client réservée. Si ce paramètre n'est pas spécifié, aucun nom de client n'est associé à cette entrée.
CommentaireClient
Spécifie un commentaire client à associer à cette entrée de client réservée. Si ce paramètre n'est pas spécifié, aucun commentaire client n'est associé à cette entrée.
{DHCP | BOOTP | BOTH}
Spécifie le type de client à associer à cette entrée de client réservée. Le paramètre DHCP est utilisé par défaut.

Remarques

  • Si une option de ligne de commande facultative est utilisée, toutes les options de la ligne de commande (obligatoires comme facultatives) placées avant celle-ci doivent être fournies dans l'ordre approprié.

Exemples

Dans l'exemple ci-dessous, la commande réserve l'adresse IP 10.2.2.32 pour l'utiliser avec le client DHCP dont l'adresse MAC identifiée lors de l'obtention d'un bail dans l'étendue actuelle est 08-00-2b-30-36-9b.

add reservedip 10.2.2.32 08002b30369B

delete excluderange

Supprime une plage d'adresses IP précédemment exclues de l'étendue actuelle.

Syntaxe

delete excluderange IPDébut IPFin

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage d'exclusion.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage d'exclusion.

Exemples

Dans l'exemple ci-dessous, la commande supprime de l'étendue actuelle la plage d'exclusion qui commence par l'adresse IP 10.2.1.5 et termine par l'adresse IP 10.2.1.10.

delete excluderange 10,20,1.10 224.2.2.20

delete iprange

Supprime une plage d'adresses IP de l'étendue actuelle.

Syntaxe

delete iprange IPDébut IPFin

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage à supprimer.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage à supprimer.

Exemples

Dans l'exemple ci-dessous, la commande supprime de l'étendue actuelle les adresses IP contenues dans la plage 10.2.1.5 à 10.2.1.10.

delete iprange 10,20,1.10 224.2.2.20

delete optionvalue

Supprime ou efface la valeur affectée à une option d'étendue dans l'étendue actuelle.

Syntaxe

delete optionvalue CodeOption [user=NomUtilisateur] [vendor=NomFournisseur]

Paramètres

CodeOption
Obligatoire. Spécifie l'identificateur unique de l'option dont la valeur est à supprimer.
user=NomUtilisateur
Spécifie la classe utilisateur de laquelle vous souhaitez supprimer la valeur d'option actuellement définie. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe utilisateur actuelle par défaut qui est utilisée.
vendor=NomFournisseur
Spécifie la classe fournisseur de laquelle vous souhaitez supprimer la valeur d'option actuellement définie. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe fournisseur actuelle par défaut qui est utilisée.

Remarques

  • Les classes fournisseur et utilisateur sont prises en charge uniquement pour les serveurs DHCP exécutant Windows 2000 Server.
  • Si vous spécifiez une classe utilisateur, une classe fournisseur, ou les deux, la commande supprime la valeur d'option définie uniquement des clients de l'étendue identifiés comme membres de la ou les classes spécifiées.
  • Pour modifier les paramètres par défaut actuels d'une classe non spécifiée utilisée avec cette commande, utilisez la commande set userclass ou set vendorclass.

Exemples

Dans le premier exemple, la commande supprime de l'étendue actuelle la valeur d'option actuellement définie pour le code d'option 18.

Dans le deuxième exemple, la commande supprime de la classe fournisseur MaClasseFournisseur la valeur d'option actuellement définie pour le code d'option 18.

delete optionvalue 18

delete optionvalue 18 vendor="MaClasseFournisseur"

delete reservedip

Supprime la réservation d'une adresse IP de l'étendue actuelle.

Syntaxe

delete reservedip IPRéservée AdresseMAC

Paramètres

IPRéservée
Obligatoire. Spécifie la réservation de l'adresse IP à supprimer de l'étendue actuelle.
AdresseMAC
Obligatoire. Spécifie la chaîne d'adresse MAC (Media Access Control) ou de matériel physique pour laquelle l'adresse IP a été réservée.

Exemples

Dans l'exemple ci-dessous, la commande supprime de l'étendue actuelle la réservation d'adresse IP 10.2.1.32 pour l'adresse MAC 08002B30369B.

delete reservedip 10.2.1.32 08002B30369B

delete reservedoptionvalue

Supprime une valeur d'option actuellement attribuée à un client réservé dans l'étendue actuelle.

Syntaxe

delete reservedoptionvalue IPRéservée CodeOption [User=NomUtilisateur] [vendor=NomFournisseur]

Paramètres

IPRéservée
Obligatoire. Spécifie l'adresse IP du client réservé.
CodeOption
Obligatoire. Spécifie le code unique du type d'option actuellement attribué au client réservé.
User=NomUtilisateur
Spécifie la classe utilisateur de laquelle vous souhaitez supprimer la valeur d'option. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe utilisateur actuelle par défaut qui est utilisée.
vendor=NomFournisseur
Spécifie la classe fournisseur de laquelle vous souhaitez supprimer la valeur d'option. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe fournisseur actuelle qui est utilisée.

Remarques

  • Les classes fournisseur et utilisateur sont prises en charge uniquement pour les serveurs DHCP exécutant Windows 2000 Server.
  • Pour modifier les paramètres par défaut actuels d'une classe non spécifiée utilisée avec cette commande, utilisez la commande set userclass ou set vendorclass.

Exemples

Dans l'exemple ci-dessous, la commande supprime de l'étendue actuelle la valeur actuellement définie de l'option identifiée par le code 18 pour l'adresse IP réservée 10.2.2.32.

delete reservedoptionvalue 10.2.2.32 18

initiate reconcile

Vérifie et rapproche l'étendue actuelle. Si aucun paramètre n'est utilisé, la commande vérifie les étendues, recherche les incohérences éventuelles mais ne résout pas celles qu'elle trouve dans la base de données.

Syntaxe

initiate reconcile [fix]

Paramètres

[fix]
Indique que la commande va résoudre, dans la mesure du possible, toutes les incohérences trouvées dans la base de données.

Exemples

Dans le premier exemple, la commande vérifie les étendues et recherche les incohérences.

Dans le deuxième exemple, la commande vérifie les étendues, recherche les incohérences et résout celles qu'elle trouve.

initiate reconcile

initiate reconcile fix

set comment

Définit le commentaire pour l'étendue actuelle. Si aucun paramètre n'est utilisé, set comment supprime la commande actuelle.

Syntaxe

set comment [NouveauCommentaire]

Paramètres

[NouveauCommentaire]
Spécifie une nouvelle châine de commentaire ou une chaîne modifiée pour l'étendue actuelle.

Exemples

Dans le premier exemple, la commande définit une chaîne de commentaire dépourvue d'espaces.

Dans le deuxième exemple, la commande définit une chaîne de commentaire comprenant des espaces.

set comment NouveauCommentaireSansEspace

set comment "Nouveau Commentaire Avec Espaces"

set name

Définit le nom de l'étendue actuelle.

Syntaxe

set name NouveauNom

Paramètres

NouveauNom
Obligatoire. Spécifie le nouveau nom de l'étendue.

Exemples

Dans le premier exemple, la commande définit un nom dépourvu d'espaces.

Dans le deuxième exemple, la commande définit un nom comprenant des espaces.

set name NouveauNomSansEspace

set name "Nouveau Nom Avec Espaces"

set optionvalue

Définit une valeur d'option pour l'étendue actuelle.

Syntaxe

set optionvalue CodeOption {BYTE | WORD | DWORD | STRING | IPADDRESS} [user=NomUtilisateur] [vendor=NomFournisseur] ValeurOption

Paramètres

CodeOption
Obligatoire. Spécifie le code du type d'option dont la valeur doit être définie.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Obligatoire. Spécifie le type de données du type d'option dont la valeur doit être définie.
user=NomUtilisateur
Spécifie la classe utilisateur. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe utilisateur actuelle par défaut qui est utilisée.
vendor=NomFournisseur
Spécifie la classe fournisseur. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe fournisseur par défaut qui est utilisée.
ValeurOption
Obligatoire. Spécifie la valeur attribuée au type d'option spécifié dans CodeOption. Si le type d'option prend en charge un tableau contenant plus d'une châine numérique unique ou une valeur d'adresse IP, fournissez les valeurs supplémentaires, dans l'ordre de votre choix, à la fin de la commande ; chaque valeur doit être séparée par un espace.

Remarques

  • Les classes fournisseur et utilisateur sont prises en charge uniquement pour les serveurs DHCP exécutant Windows 2000 Server.
  • Pour modifier les paramètres par défaut actuels d'une classe non spécifiée utilisée avec cette commande, utilisez la commande set userclass ou set vendorclass.

Exemples

Dans le premier exemple, la commande définit la valeur du code d'option 003 pour répertorier les deux adresses IP du routeur (10.1.1.1 et 10.1.1.2).

Dans le deuxième exemple, la commande définit la valeur spécifiée dans le premier exemple pour l'appliquer uniquement aux clients de l'étendue identifiés comme membres de la classe fournisseur Fournisseur1 (classe précédemment définie sur le serveur avec ce type d'option spécifié pour son utilisation).

set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

set optionvalue 003 IPADDRESS vendor=Fournisseur1 10.1.1.1 10.1.1.2

set reservedoptionvalue

Définit la valeur d'une option pour la réservation d'une adresse IP dans l'étendue actuelle.

Syntaxe

set reservedoptionvalue IPRéservée CodeOption {BYTE | WORD | DWORD | STRING | IPADDRESS} [user=NomUtilisateur] [vendor=NomFournisseur] ValeurOption

Paramètres

IPRéservée
Obligatoire. Spécifie l'adresse IP réservée dont la valeur d'option doit être définie.
CodeOption
Obligatoire. Spécifie le code du type d'option dont la valeur doit être définie.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Obligatoire. Spécifie le type de données du type d'option dont la valeur doit être définie.
user=NomUtilisateur
Spécifie la classe utilisateur actuelle par défaut ou la classe spécifiée sous NomUtilisateur. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe utilisateur actuelle par défaut qui est utilisée.
vendor=NomFournisseur
Spécifie la classe fournisseur actuelle par défaut ou la classe spécifiée sous NomFournisseur. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe fournisseur actuelle par défaut qui est utilisée.
ValeurOption
Obligatoire. Spécifie la valeur attribuée au type d'option spécifié dans CodeOption. Si le type d'option prend en charge un tableau contenant plus d'une châine numérique unique ou une valeur d'adresse IP, fournissez les valeurs supplémentaires, dans l'ordre de votre choix, à la fin de la commande ; chaque valeur doit être séparée par un espace.

Remarques

  • Les classes fournisseur et utilisateur sont prises en charge uniquement pour les serveurs DHCP exécutant Windows 2000 Server.
  • Pour modifier les paramètres par défaut actuels d'une classe non spécifiée utilisée avec cette commande, utilisez la commande set userclass ou set vendorclass.

Exemples

Dans l'exemple ci-dessous, la commande définit la valeur de l'option du routeur (code 003) pour l'adresse IP 10.1.1.50 du client réservé dans l'étendue actuelle afin de définir les adresses IP 10.1.1.1 et 10.1.1.2 pour ses routeurs configurés (passerelles par défaut).

set reservedoptionvalue 10.1.1.50 003 IPADDRESS 10.1.1.1 10.1.1.2

set scope

Définit l'étendue à utiliser pour toute opération ultérieure.

Syntaxe

set scope AdresseÉtendue

Paramètres

AdresseÉtendue
Obligatoire. Spécifie l'adresse IP de l'étendue à utiliser lors d'opérations de commandes ultérieures.

Exemples

Dans l'exemple ci-dessous, la commande définit l'adresse IP 10.2.2.0 comme étendue actuelle pour les opérations ultérieures.

set scope 10.2.2.0

set state

Active ou désactive l'état de l'étendue actuelle. Si aucun paramètre n'est utilisé, la commande active l'étendue.

Syntaxe

set state [{0 | 1 | 2 | 3}]

Paramètres

{0 | 1 | 2 | 3}
Indique l'état de l'étendue : 0 désactive l'étendue, 1 active l'étendue (comportement par défaut), 2 désactive l'étendue et la marque comme « commutée », 3 active l'étendue et la marque comme « commutée ».

Remarques

  • Les valeurs 2 et 3 sont généralement utilisées sur des réseaux commutés ou sur des réseaux dans lesquels plusieurs réseaux logiques sont hébergés sur un seul réseau physique.

Exemples

Dans le premier exemple, la commande active une étendue.

Dans le deuxième exemple, la commande désactive une étendue.

set state 1

set state 0

set superscope

Définit la super-étendue à utiliser dans les opérations ultérieures.

Syntaxe

set superscope NomSuperÉtendue {0 | 1}

Paramètres

NomSuperÉtendue
Obligatoire. Spécifie le nom de la super-étendue à inclure dans l'étendue actuelle. Le paramètre NomSuperÉtendue tient compte de la casse.
{0 | 1}
Obligatoire. Indique s'il faut activer ou désactiver l'état de la super-étendue : 0 désactive la super-étendue, 1 active la super-étendue.

Exemples

Dans l'exemple ci-dessous, la commande ajoute l'étendue actuelle à la super-étendue MaSuperÉtendue et active cette dernière.

set superscope MaSuperÉtendue 1

show clients

Affiche tous les clients de version 4 disponibles pour l'étendue actuelle. Si aucun paramètre n'est utilisé, cette commande affiche pour chaque client les informations suivantes : adresse IP, masque de sous-réseau, identificateur unique, expiration du bail et type de données.

Syntaxe

show clients [{0 | 1}]

Paramètres

{0 | 1}
Indique le niveau de détail des données en sortie : 0 affiche pour chaque client les informations suivantes : adresse IP, masque de sous-réseau, identificateur unique, expiration du bail et type de données (par défaut) ; 1 affiche toutes les informations fournies par la valeur 0 ainsi que le nom complet du domaine de chaque client.

Remarques

  • Pour afficher correctement les données en sortie de cette commande, augmentez la largeur de la fenêtre de commande jusqu'à 95 caractères au moins.

show clientsv5

Affiche tous les clients de version 5 disponibles pour l'étendue actuelle. Si aucun paramètre n'est utilisé, cette commande affiche pour chaque client les informations suivantes : adresse IP, masque de sous-réseau, identificateur unique, expiration du bail et type de données.

Syntaxe

show clientsv5 [{0 | 1}]

Paramètres

{0 | 1}
Indique le niveau de détail des données en sortie : 0 affiche pour chaque client les informations suivantes : adresse IP, masque de sous-réseau, identificateur unique, expiration du bail et type de données (par défaut) ; 1 affiche toutes les informations fournies par la valeur 0 ainsi que le nom complet du domaine de chaque client.

Remarques

  • Pour afficher correctement les données en sortie de cette commande, augmentez la largeur de la fenêtre de commande jusqu'à 95 caractères au moins.

show excluderange

Affiche toutes les plages d'exclusion actuellement définies pour les adresses IP de l'étendue actuelle.

Syntaxe

show excluderange

Paramètres

Aucun

Remarques

  • Utilisez d'autres commandes de niveau d'étendue pour ajouter et supprimer des plages d'exclusion.

show iprange

Affiche toutes les plages d'adresses disponibles dans l'étendue actuelle.

Syntaxe

show iprange

Paramètres

Aucun

show optionvalue

Affiche toutes les valeurs d'options définies pour l'étendue actuelle. Si aucun paramètre n'est utilisé, cette commande utilise les classes utilisateur et fournisseur actuelles par défaut.

Syntaxe

show optionvalue [user=NomUtilisateur] [vendor=NomFournisseur]

Paramètres

user=NomUtilisateur
Indique que les options définies pour la classe utilisateur spécifiée s'affichent. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe utilisateur actuelle par défaut qui est utilisée.
vendor=NomFournisseur
Indique que les options définies pour la classe fournisseur spécifiée s'affichent. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe fournisseur actuelle par défaut qui est utilisée.

Remarques

  • Les classes fournisseur et utilisateur sont prises en charge uniquement pour les serveurs DHCP exécutant Windows 2000 Server.
  • Pour modifier les paramètres par défaut actuels d'une classe non spécifiée utilisée avec cette commande, utilisez la commande set userclass ou set vendorclass.

Exemples

Dans l'exemple ci-dessous, la commande affiche toutes les options et les valeurs définies pour la classe Ma Classe Utilisateur définie par l'utilisateur dans l'étendue actuelle.

show optionvalue user="Ma Classe Utilisateur"

show reservedip

Affiche toutes les adresses IP actuellement réservées pour l'étendue en cours.

Syntaxe

show reservedip

Paramètres

Aucun

show reservedoptionvalue

Affiche toutes les valeurs d'options actuellement définies pour une adresse IP de client réservée dans l'étendue actuelle.

Syntaxe

show reservedoptionvalue IPRéservée [user=NomUtilisateur] [vendor=NomFournisseur]

Paramètres

IPRéservée
Obligatoire. Spécifie la réservation de l'adresse IP pour laquelle les options actuellement attribuées doivent s'afficher.
user=NomUtilisateur
Indique que les options définies pour la classe utilisateur spécifiée s'affichent. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe utilisateur actuelle par défaut qui est utilisée.
vendor=NomFournisseur
Indique que les options définies pour la classe fournisseur spécifiée s'affichent. Si la balise est fournie alors qu'aucune valeur n'est spécifiée, c'est la classe fournisseur actuelle par défaut qui est utilisée.

Remarques

  • Les classes fournisseur et utilisateur sont prises en charge uniquement pour les serveurs DHCP exécutant Windows 2000 Server.
  • Pour modifier les paramètres par défaut actuels d'une classe non spécifiée utilisée avec cette commande, utilisez la commande set userclass ou set vendorclass.

Exemples

Dans l'exemple ci-dessous, la commande affiche les valeurs d'options définies pour l'adresse IP réservée 10.2.2.100 dans l'étendue actuelle.

show reservedoptionvalue 10.2.2.100

show scope

Affiche les informations de l'étendue actuelle.

Syntaxe

show scope

Paramètres

Aucun

show state

Affiche l'état de l'étendue actuelle (actif ou inactif).

Syntaxe

show state

Paramètres

Aucun

Étendue de multidiffusion du serveur Netsh DHCP

Les commandes suivantes sont disponibles à l'invite de commande dhcp server mscope> ayant pour racine l'environnement netsh.

Pour afficher la syntaxe d'une commande, sélectionnez-la :

add excluderange

Ajoute une plage d'adresses exclues à l'étendue de multidiffusion actuelle.

Syntaxe

add excluderange IPDébut IPFin

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage d'exclusion.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage d'exclusion.

Remarques

  • La plage d'exclusion doit être une sous-plage de la plage d'adresses globale de l'étendue.

Exemples

Dans l'exemple ci-dessous, la commande ajoute une plage d'exclusion commençant à 224.2.2.10 et se terminant à 224.2.2.20 à la plage de distribution de l'étendue de multidiffusion actuelle.

add excluderange 224.2.2.10 224.2.2.20

add iprange

Ajoute une plage d'adresses IP à l'étendue de multidiffusion actuelle.

Syntaxe

add iprange IPDébut IPFin

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage.

Remarques

  • La plage doit être comprise dans l'intervalle admis pour les adresses IP de multidiffusion (de 224.0.0.0 à 239.255.255.255).

Exemples

Dans l'exemple ci-dessous, la commande ajoute la plage d'adresse IP 224.2.2.10 à 224.2.2.20 à la plage de distribution de l'étendue de multidiffusion.

add iprange 224.2.2.10 224.2.2.20

delete excluderange

Supprime une plage d'exclusion d'adresses IP précédemment exclues dans l'étendue de multidiffusion actuelle.

Syntaxe

delete excluderange IPDébut IPFin

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage d'exclusion.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage d'exclusion.

Exemples

Dans l'exemple ci-dessous, la commande supprime une exclusion de l'étendue de multidiffusion dans une plage d'adresses IP commençant à 224.2.2.10 et se terminant à 224.2.2.20.

delete excluderange 224.2.2.10 224.2.2.20

delete iprange

Supprime une plage d'adresses IP de l'étendue de multidiffusion actuelle.

Syntaxe

delete iprange IPDébut IPFin

Paramètres

IPDébut
Obligatoire. Spécifie l'adresse IP qui commence la plage à supprimer.
IPFin
Obligatoire. Spécifie l'adresse IP qui termine la plage à supprimer.

Exemples

Dans l'exemple ci-dessous, la commande ajoute la plage d'adresses IP 224.2.2.10 à 224.2.2.20 à la plage globale de toute l'étendue de multidiffusion.

delete iprange 224.2.2.10 224.2.2.20

initiate reconcile

Vérifie et rapproche l'étendue de multidiffusion actuelle.

Syntaxe

initiate reconcile

Paramètres

Aucun

Remarques

  • Cette commande vérifie l'intégrité de l'étendue de multidiffusion actuelle en comparant le contenu de la base de données du serveur avec une copie mise en miroir des mêmes informations dans le registre Windows. Si le système détecte des incohérences, elles sont automatiquement résolues sur la base de ces informations dupliquées du Registre. Toute incohérence trouvée fait automatiquement l'objet d'une tentative de résolution.

set comment

Définit le commentaire de l'étendue de multidiffusion actuelle.

Syntaxe

set comment NouveauCommentaire

Paramètres

NouveauCommentaire
Obligatoire. Spécifie le nouveau commentaire ou le commentaire révisé de l'étendue de multidiffusion.

Exemples

Dans le premier exemple, la commande modifie le commentaire de l'étendue de multidiffusion et le remplace par un nouveau commentaire dépourvu d'espaces.

Dans le deuxième exemple, la commande modifie le commentaire de l'étendue de multidiffusion et le remplace par un nouveau commentaire comprenant des espaces.

set comment NouveauCommentaireSansEspace

set comment "Nouveau Commentaire Avec Espaces"

set lease

Définit la durée de bail des adresses IP de l'étendue de multidiffusion.

Syntaxe

set lease Durée

Paramètres

Durée
Obligatoire. Spécifie la durée du bail des clients de l'étendue de multidiffusion. La valeur -1 permet de définir le bail de l'adresse IP pour une durée illimitée ou infinie.

Exemples

Dans l'exemple ci-dessous, la commande définit la durée du bail des clients de l'étendue de multidiffusion à 691 200 secondes (huit jours).

set lease 691200

set mscope

Définit l'étendue de multidiffusion à utiliser dans les opérations ultérieures.

Syntaxe

set mscope NouveauNom

Paramètres

NouveauNom
Obligatoire. Spécifie le nom de l'étendue de multidiffusion supposée remplacer le contexte de la commande. Le paramètre NouveauNom tient compte de la casse.

Remarques

  • Cette commande modifie le contexte de l'invite de commande netsh dhcp server mscope> en remplaçant une étendue de multidiffusion par une autre.
  • Elle ne permet pas de renommer l'étendue de multidiffusion actuelle. Pour changer le nom de l'étendue, utilisez la commande set name.

Exemples

Dans le premier exemple, la commande remplace le contexte de commande par une étendue de multidiffusion intitulée MonÉtendueMultidiffusion. Notez que le nom de l'étendue de multidiffusion ne contient aucun espace.

Dans le deuxième exemple, la commande remplace le contexte de commande par une étendue de multidiffusion intitulée Mon Étendue Multidiffusion. Notez que, dans ce cas, le nom de l'étendue de multidiffusion contient des espaces.

set mscope MonÉtendueMultidiffusion

set mscope "Mon Étendue Multidiffusion"

set name

Modifie le nom de l'étendue de multidiffusion actuelle.

Syntaxe

set name NouveauNom

Paramètres

NouveauNom
Obligatoire. Spécifie un nouveau nom pour l'étendue de multidiffusion actuelle.

Exemples

Dans le premier exemple, la commande définit pour l'étendue de multidiffusion actuelle un nouveau nom dépourvu d'espaces.

Dans le deuxième exemple, la commande définit pour l'étendue de multidiffusion actuelle un nouveau nom comprenant des espaces.

set name NouveauNomSansEspace

set name "Nouveau Nom Avec Espaces"

set state

Active ou désactive l'état de l'étendue de multidiffusion actuelle.

Syntaxe

set state {0 | 1}

Paramètres

{0 | 1}
Obligatoire. Définit l'état de l'étendue de multidiffusion actuelle : 0 désactive l'étendue de multidiffusion actuelle, 1 l'active.

Exemples

Dans le premier exemple, la commande active l'étendue de multidiffusion actuelle.

Dans le deuxième exemple, la commande désactive l'étendue de multidiffusion actuelle.

set state 1

set state 0

set ttl

Définit la durée de vie (TTL) de l'étendue de multidiffusion actuelle.

Syntaxe

set ttl TTL

Paramètres

TTL
Obligatoire. Spécifie la valeur de durée de vie (TTL). La valeur correcte pour ce paramètre doit être un nombre compris entre 1 et 255.

Exemples

Dans l'exemple ci-dessous, la commande définit la valeur de durée de vie de l'étendue de multidiffusion actuelle à 32.

set ttl 32

show clients

Affiche tous les clients disponibles pour l'étendue de multidiffusion actuelle.

Syntaxe

show clients

Paramètres

Aucun

Remarques

  • Pour afficher correctement les données en sortie de cette commande, augmentez la largeur de la fenêtre de commande jusqu'à 95 caractères au moins.

show excluderange

Affiche toutes les plages d'adresses IP actuellement exclues de l'étendue de multidiffusion actuelle.

Syntaxe

show excluderange

Paramètres

Aucun

Remarques

  • Si aucune plage d'exclusion n'a été au préalable définie pour l'étendue, cette commande génère une liste vide.

show iprange

Affiche toutes les plages d'adresses IP disponibles pour l'étendue de multidiffusion actuelle.

Syntaxe

show iprange

Paramètres

Aucun

show lease

Affiche les paramètres actuels de durée de bail pour l'étendue de multidiffusion en cours.

Syntaxe

show lease

Paramètres

Aucun

show mibinfo

Affiche les informations MIB (Management Information Base) de l'étendue de multidiffusion actuelle.

Syntaxe

show mibinfo

Paramètres

Aucun

show mscope

Affiche les informations de l'étendue de multidiffusion actuelle.

Syntaxe

show mscope

Paramètres

Aucun

show state

Affiche l'état de l'étendue de multidiffusion actuelle.

Syntaxe

show state

Paramètres

Aucun

show ttl

Affiche la durée de vie (TTL) de l'étendue de multidiffusion actuelle.

Syntaxe

show ttl

Paramètres

Aucun


Exemple Netsh DHCP

Vous pouvez utiliser les commandes Netsh pour DHCP (Dynamic Host Configuration Protocol) dans des fichiers batch et d'autres scripts pour automatiser des tâches. Le modèle de fichier batch ci-dessous démontre comment utiliser ces commandes pour réaliser un nombre varié de tâches liées les unes aux autres.

Dans le cadre de cet exemple de procédure, DHCP-01 est un serveur DHCP dont l'adresse IP est 192.168.0.2. La procédure ajoute une nouvelle étendue à DHCP-01 intitulée MonÉtendue, une adresse IP 192.168.10.0, un masque de sous-réseau 255.255.255.0 et un commentaire NouvelleÉtendue. Elle configure ensuite l'étendue avec une plage d'adresses (de 192.168.10.1 à 192.168.10.254), une plage d'exclusion (de 192.168.10.1 à 192.168.10.25) et des adresses IP du routeur (option DHCP 003). L'étendue est alors définie à un état actif.

Pour plus d'informations, consultez Configuration des étendues, Configuration des options et options DHCP.

Pour obtenir plus d'informations ainsi qu'une liste des commandes Netsh pour DHCP, consultez Commandes Netsh pour DHCP.

Dans cet exemple de procédure, les lignes qui contiennent les commentaires sont précédées des trois premières lettres (rem) du mot « remarque ». Netsh ignore les commentaires.

rem un serveur DHCP :

rem (DHCP-01) 192.168.0.2

rem 1. Connexion à (DHCP-01) et ajout de l'étendue MonÉtendue avec l'adresse IP 192.168.10.0,

rem 1.1  le masque de sous-réseau 255.255.255.0 et le commentaire NouvelleÉtendue.

netsh dhcp server 192.168.0.2 add scope 192.168.10.0 255.255.255.0 MonÉtendue NouvelleÉtendue

rem 2. Connexion à (DHCP-01 MonÉtendue) et ajout de la plage d'adresses 192.168.10.1 à 192.168.10.254 pour distribution

rem 2.1  et de la valeur TypeClient par défaut de DHCP.

netsh dhcp server 192.168.0.2 scope 192.168.10.0 add iprange 192.168.10.1 192.168.10.254

rem 3. Connexion à (DHCP-01 MonÉtendue) et ajout de la plage d'exclusion IP 192.168.10.1 à 192.168.100.25

rem 3.1  et de la valeur TypeClient par défaut de DHCP.

netsh dhcp server 192.168.0.2 scope 192.168.10.0 add excluderange 192.168.10.1 192.168.10.25

rem 4. Connexion à (DHCP-01 MonÉtendue) et définition de la valeur de code d'option 003

rem 4.1   pour répertorier les deux adresses IP du routeur (10.1.1.1 et 10.1.1.2).

netsh dhcp server 192.168.0.2 scope 192.168.10.0 set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

rem 5.  Connexion à (DHCP-01 MonÉtendue) et définition de l'état de l'étendue à actif.

netsh dhcp server 192.168.0.2 scope 192.168.10.0 set state 1

rem 6. Fin du modèle de fichier batch.

Le tableau ci-dessous répertorie les commandes netsh dhcp utilisées dans ce modèle de procédure.

Commande | Description
server | Bascule le contexte actuel de ligne de commande DHCP vers le serveur identifié par son nom ou son adresse IP.
add scope | Ajoute une nouvelle étendue au serveur DHCP spécifié.
scope | Bascule le contexte de commande vers l'étendue DHCP identifiée par son adresse IP.
add iprange | Ajoute une plage d'adresses IP à l'étendue actuelle.
add excluderange | Ajoute une plage d'adresses exclues à l'étendue actuelle.
set optionvalue | Définit une valeur d'option pour l'étendue actuelle.
set state | Active ou désactive l'état de l'étendue actuelle.


Commandes de diagnostic (diag) Netsh

Vous pouvez utiliser les commandes de diagnostic réseau Netsh, c'est-à-dire le contexte diag, pour l'administration et la résolution des problèmes liés au système d'exploitation et aux paramètres de service réseau à partir de la ligne de commande. L'invite de commandes du contexte de diagnostic Netsh est netsh diag>.

Les commandes suivantes sont disponibles à l'invite de commandes du contexte de diagnostic Netsh (distinct de l'invite de commandes Windows XP). Le contexte Netsh Diag est une nouveauté de Windows XP. Vous ne pouvez pas effectuer de commandes Netsh Diag à distance sur un ordinateur exécutant Windows 2000 Server.

Pour plus d'informations sur netsh, consultez Utilisation de Netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

connect ieproxy

Établit, vérifie puis lance une connexion TCP/IP avec le serveur proxy spécifié dans Internet Explorer.

Syntaxe

connect ieproxy

Paramètres

aucun

Remarques

  • Si aucun serveur proxy n'est spécifié dans Internet Explorer, la commande génère un résultat tel que :
    Proxy Internet Explorer (Non configuré)

    Non configuré
  • Si vous avez spécifié dans Internet Explorer un serveur proxy nommé corpproxy avec un port de 80, la commande génère un résultat tel que :
    Proxy Internet Explorer (corpproxy)

    IEProxyPort = 80

    IEProxy = corpproxy

    Serveur fonctionnant sur le(s) port(s) [80]

connect iphost

Établit, vérifie puis lance une connexion TCP/IP avec un hôte et via un port spécifiés.

Syntaxe

connect iphost Hôte Port

Paramètres

Hôte
Spécifie l'adresse IP, le nom NetBIOS ou le nom de domaine complet de l'hôte avec lequel vous souhaitez vous connecter.
Port
Spécifie le port par le biais duquel vous souhaitez vous connecter.

Exemples

Pour vous connecter à l'hôte nommé microsoft.com via le port 28, tapez :

connect iphost microsoft.com 28

connect mail

Établit, vérifie puis lance une connexion TCP/IP avec le nœud spécifié en tant que serveur de messagerie dans le profil Outlook Express par défaut de l'utilisateur actuel.

Syntaxe

connect mail

Paramètres

aucun

connect news

Établit, vérifie puis lance une connexion TCP/IP avec le nœud spécifié en tant que serveur de News dans le profil Outlook Express par défaut de l'utilisateur actuel.

Syntaxe

connect news

Paramètres

aucun

dump

Crée un script contenant la configuration actuelle.

Syntaxe

dump

Paramètres

aucun

Remarques

  • Si vous enregistrez ce script dans un fichier, vous pouvez utiliser celui-ci pour rétablir des paramètres de configuration qui ont été modifiés.

gui

Démarre l'outil de diagnostic réseau dans le centre d'Aide et de support.

Syntaxe

gui

Paramètres

aucun

ping

Vérifie la connectivité avec un hôte distant spécifié.

Syntaxe

ping Hôte

Paramètres

Hôte
Spécifie l'adresse IP, le nom NetBIOS ou le nom de domaine complet de l'hôte avec lequel vous souhaitez vérifier la connectivité.

ping adapter

Vérifie la connectivité avec les ordinateurs et autres périphériques (par exemple des routeurs) identifiés dans les propriétés TCP/IP de la (des) carte(s) réseau spécifiée(s). Utilisée sans paramètres, la commande ping adapter vérifie la connectivité au travers de toutes les cartes installées.

Syntaxe

ping adapter [{NuméroIndex | NomCompletCarte | NomPartielCarte}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez vérifier la connectivité. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.

Remarques

  • Cette commande vérifie la connectivité avec tous les ordinateurs et autres périphériques configurés dans les propriétés TCP/IP de chaque carte réseau que vous spécifiez. Par exemple, si vous possédez une carte réseau dont les propriétés TCP/IP sont configurées avec des adresses IP pour un serveur DNS par défaut, une passerelle par défaut et un serveur DHCP, la commande ping adapter vérifie la connectivité avec chacun de ces périphériques.
  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour vérifier la connectivité avec tous les ordinateurs et autres périphériques configurés dans les propriétés TCP/IP de chaque carte réseau, tapez :

ping adapter

Pour vérifier la connectivité avec tous les ordinateurs et autres périphériques configurés dans les propriétés TCP/IP de chaque carte réseau dont le numéro d'index est égal à 2, tapez :

ping adapter 2

Pour vérifier la connectivité avec tous les ordinateurs et autres périphériques configurés dans les propriétés TCP/IP de chaque carte réseau dont le nom commence par « net », tapez :

ping adapter net*

ping dhcp

Vérifie la connectivité avec les serveurs DHCP (Dynamic Host Configuration Protocol) configurés dans les propriétés TCP/IP de la (des) carte(s) réseau spécifiée(s). Utilisée sans paramètres, la commande ping dhcp vérifie la connectivité avec les serveurs DHCP au travers de toutes les cartes installées.

Syntaxe

ping dhcp [{NuméroIndex | NomCompletCarte | NomPartielCarte}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez vérifier la connectivité. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour vérifier la connectivité avec le serveur DHCP configuré dans les propriétés TCP/IP de chaque carte réseau, tapez :

ping dhcp

Pour vérifier la connectivité avec le serveur DHCP configuré dans les propriétés TCP/IP de la carte réseau dont le numéro d'index est égal à 2, tapez :

ping dhcp 2

Pour vérifier la connectivité avec le serveur DHCP configuré dans les propriétés TCP/IP de chaque carte réseau dont le nom commence par « net », tapez :

ping dhcp net*

ping dns

Vérifie la connectivité avec les serveurs DNS (Domain Name System) configurés dans les propriétés TCP/IP de la (des) carte(s) réseau spécifiée(s). Utilisée sans paramètres, la commande ping dns vérifie la connectivité avec les serveurs DNS au travers de toutes les cartes installées.

Syntaxe

ping dns [{NuméroIndex | NomCompletCarte | NomPartielCarte}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez vérifier la connectivité. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour vérifier la connectivité avec le serveur DNS configuré dans les propriétés TCP/IP de chaque carte réseau, tapez :

ping dns

Pour vérifier la connectivité avec le serveur DNS configuré dans les propriétés TCP/IP de la carte réseau dont le numéro d'index est égal à 2, tapez :

ping dns 2

Pour vérifier la connectivité avec le serveur DNS configuré dans les propriétés TCP/IP de chaque carte réseau dont le nom commence par « net », tapez :

ping dns net*

ping gateway

Vérifie la connectivité avec les serveurs des passerelles par défaut configurés dans les propriétés TCP/IP de la (des) carte(s) réseau spécifiée(s). Utilisée sans paramètres, la commande ping gateway vérifie la connectivité au travers de toutes les cartes installées.

Syntaxe

ping gateway [{NuméroIndex | NomCompletCarte | NomPartielCarte}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez vérifier la connectivité. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour vérifier la connectivité avec le serveur de passerelle configuré dans les propriétés TCP/IP de chaque carte réseau, tapez :

ping gateway

Pour vérifier la connectivité avec le serveur de passerelle configuré dans les propriétés TCP/IP de la carte réseau dont le numéro d'index est égal à 2, tapez :

ping gateway 2

Pour vérifier la connectivité avec le serveur de passerelle configuré dans les propriétés TCP/IP de chaque carte réseau dont le nom commence par « net », tapez :

ping gateway net*

ping ieproxy

Vérifie la connectivité avec le serveur Web proxy pour Internet Explorer.

Syntaxe

ping ieproxy

Paramètres

aucun

ping ip

Vérifie la connectivité avec toutes les adresses IP de la (des) carte(s) réseau spécifiée(s). Utilisée sans paramètres, la commande ping ip vérifie la connectivité au travers de toutes les cartes installées.

Syntaxe

ping ip [{NuméroIndex | NomCompletCarte | NomPartielCarte}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez vérifier la connectivité. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour vérifier la connectivité avec chaque carte réseau, tapez :

ping ip

Pour vérifier la connectivité avec la carte réseau dont le numéro d'index est égal à 2, tapez :

ping ip 2

Pour vérifier la connectivité avec chaque carte réseau dont le nom commence par « net », tapez :

ping ip net*

ping iphost

Vérifie la connectivité avec un hôte distant ou local.

Syntaxe

ping iphost Nœud

Paramètres

Nœud
Spécifie un hôte par le biais de son adresse IP, de son nom NetBIOS ou de son nom de domaine complet.

Exemples

Pour vérifier la connectivité avec l'hôte local (à l'adresse de boucle 127.0.0.1), tapez :

ping iphost 127.0.0.1

Pour vérifier la connectivité avec l'hôte microsoft.com, tapez :

ping iphost microsoft.com

ping loopback

Vérifie la connectivité avec l'adresse de boucle de l'hôte local (127.0.0.1).

Syntaxe

ping loopback

Paramètres

aucun

ping mail

Vérifie la connectivité avec le serveur de messagerie configuré dans le profil Outlook Express par défaut de l'utilisateur actuel.

Syntaxe

ping mail

Paramètres

aucun

ping news

Vérifie la connectivité avec le serveur de messagerie configuré dans le profil Outlook Express par défaut de l'utilisateur actuel.

Syntaxe

ping news

Paramètres

aucun

ping wins

Vérifie la connectivité avec les serveurs WINS (Windows Internet Name Service) par défaut et auxiliaire pour la (les) carte(s) réseau spécifiée(s). Utilisée sans paramètres, la commande ping wins vérifie la connectivité au travers de toutes les cartes installées.

Syntaxe

ping wins [{NuméroIndex | NomCompletCarte | NomPartielCarte}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez vérifier la connectivité. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour vérifier la connectivité avec les serveurs WINS dont les adresses IP sont configurées dans les propriétés TCP/IP de chaque carte installée, tapez :

ping wins

Pour vérifier la connectivité avec les serveurs WINS dont les adresses IP sont configurées dans les propriétés TCP/IP de chaque carte installée dont le numéro d'index est égal à 2, tapez :

ping wins 2

show adapter

Affiche des informations sur la (les) carte(s) logique(s) spécifiée(s). Utilisée sans paramètres, la commande show adapter affiche des informations à propos de toutes les cartes définies pour ce serveur.

Syntaxe

show adapter [{NuméroIndex | NomCompletCarte | NomPartielCarte}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes à propos desquelles vous souhaitez afficher des informations. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Cette commande liste les cartes par numéro d'index inclus entre crochets, suivi par le nom de la carte tel qu'il est inscrit. Voici un exemple typique de résultat de cette commande :

    • Cartes réseau

    1. [00000001] Contrôleur Fast Ethernet intégré 3Com 3C920 (compatible 3C905C-TX)
    2. [00000002] Carte Async RAS
    3. [00000003] WAN Miniport (L2TP)
    4. [00000004] WAN Miniport (PPTP)
    5. [00000005] WAN Miniport (PPPOE)
    6. [00000006] Parallèle direct
    7. [00000007] WAN Miniport (IP)
    8. [00000008] WAN Miniport (Moniteur réseau)

Exemples

Pour afficher les cartes logiques définies sur l'ordinateur, tapez :

show adapter

show all

Affiche la liste de tous les objets réseau définis pour le serveur local. Utilisée sans paramètres, la commande show all affiche des informations de configuration générales pour les composants matériels et logiciels suivants : Courrier d'Outlook Express par défaut, Outlook Express News par défaut, Proxy Web Internet Explorer, Boucle, Système de l'ordinateur, Système d'exploitation, Version, Modems, Cartes réseau et Clients réseau.

Syntaxe

show all [{/v | /p}]

Paramètres

{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Le résultat de cette commande peut être volumineux et inclut des informations de configuration sur les serveurs de messagerie, de News et les serveurs proxy. Il inclut également des informations sur l'adresse de boucle TCP/IP ainsi que des détails sur l'ordinateur, le système d'exploitation et tous les clients et cartes réseau.

show client

Affiche la liste de tous les clients réseau définis pour la (les) carte(s) spécifiée(s). Utilisée sans paramètres, la commande show client affiche la liste des clients définis pour toutes les cartes installées.

Syntaxe

show client [{NuméroIndex | NomCompletCarte | NomPartielCarte}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez afficher la liste des clients. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour afficher la liste de tous les clients réseau définis pour toutes les cartes réseau sur l'hôte, tapez :

show client

Pour afficher la liste de tous les champs contenant des valeurs non NULL pour tous les clients réseau définis pour la carte portant le numéro 2, tapez :

show client 2 /p

show computer

Affiche des détails sur WMI (Windows Management Interface) pour le serveur. Utilisée sans paramètres, la commande show computer affiche le nom NetBIOS de l'ordinateur local.

Syntaxe

show computer [{/v | /p}]

Paramètres

{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Exemples

Pour afficher la liste de tous les paramètres d'interface WMI non NULL pour le serveur :

show computer /p

show dhcp

Affiche la liste de tous les serveurs DHCP définis pour la carte spécifiée. Utilisée sans paramètres, la commande show dhcp affiche la liste des serveurs définis pour toutes les cartes installées.

Syntaxe

show dhcp {NuméroIndex | NomCompletCarte | NomPartielCarte} [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez afficher la liste des serveurs. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour afficher les détails de tous les serveurs DHCP définis pour toutes les cartes réseau, tapez :

show dhcp /v

Pour afficher les détails des serveurs DHCP définis pour la carte réseau portant le numéro 2, tapez :

show dhcp 2

show dns

Affiche la liste de tous les serveurs DNS définis pour une carte spécifiée. Utilisée sans paramètres, la commande show dns affiche la liste des serveurs définis pour toutes les cartes installées.

Syntaxe

show dns [{NuméroIndex | NomCompletCarte | NomPartielCarte}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez afficher la liste des serveurs. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour afficher tous les détails non NULL de tous les serveurs DNS définis pour toutes les cartes réseau, tapez :

show dns /p

Pour afficher la liste des serveurs DNS définis pour la carte réseau portant le numéro 2, tapez :

show dns 2

show gateway

Affiche la liste de toutes les passerelles Internet définies pour la (les) carte(s) spécifiée(s). Utilisée sans paramètres, la commande show gateway affiche la liste des passerelles définies pour toutes les cartes installées.

Syntaxe

show gateway [{NuméroIndex | NomCompletCarte | NomPartielCarte}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez afficher la liste des passerelles. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour afficher tous les détails disponibles à propos de toutes les passerelles Internet définies pour toutes les cartes, tapez :

show gateway /v

Pour afficher la liste de toutes les valeurs non NULL disponibles pour les passerelles définies pour la carte réseau portant le numéro 3, tapez :

show gateway 3 /p

show ieproxy

Affiche la liste des serveurs proxy Internet Explorer définis pour la (les) carte(s) spécifiée(s). Utilisée sans paramètres, la commande show ieproxy affiche la liste des serveurs définis pour toutes les cartes installées.

Syntaxe

show ieproxy [{NuméroIndex | NomCompletCarte | NomPartielCarte}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez afficher la liste des serveurs. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour afficher la liste de tous les serveurs proxy Internet Explorer définis pour toutes les cartes réseau dans le serveur, tapez :

show ieproxy

show ip

Affiche des informations à propos de la ou des cartes spécifiées pour lesquelles TCP/IP est activé. Utilisée sans paramètres, la commande show ip affiche des informations relatives à toutes les cartes installées.

Syntaxe

show ip [{NuméroIndex | NomCompletCarte | NomPartielCarte}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes à propos desquelles vous souhaitez afficher des informations. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.

Exemples

Pour afficher le numéro d'index, le nom et l'adresse TCP/IP de toutes les cartes pour lesquelles TCP/IP est activé, tapez :

show ip

show mail

Affiche le serveur de messagerie électronique Outlook Express spécifié pour l'ordinateur local. Utilisée sans paramètres, la commande show mail affiche des informations de configuration générales pour le Courrier d'Outlook Express par défaut.

Syntaxe

show mail [{/v | /p}]

Paramètres

{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Exemples

Pour afficher le serveur de messagerie configuré pour l'ordinateur local, tapez :

show mail

show modem

Affiche des détails relatifs au(x) périphérique(s) modem(s) spécifié(s) et configuré(s) sur l'ordinateur local. Utilisée sans paramètres, la commande show modem affiche des détails sur tous les périphériques modems.

Syntaxe

show modem [{NuméroIndex | NomCompletModem | NomPartielModem}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletModem | NomPartielModem}
Spécifie le ou les périphériques modems pour lesquels vous souhaitez afficher des détails. Le paramètre NuméroIndex spécifie le numéro d'index du périphérique. Le paramètre NomCompletModem spécifie le nom du périphérique tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielModem spécifie le(s) périphérique(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Exemples

Pour afficher tous les détails, même ceux avec des valeurs NULL, à propos de tous les périphériques modems configurés sur l'ordinateur local, tapez :

show modem /v

Pour afficher le nom et le numéro d'index de tous les périphériques modems configurés sur l'ordinateur local et dont le nom commence par « dialup », tapez :

show modem dialup*

show news

Affiche des informations de configuration à propos du serveur de News défini pour l'ordinateur local. Utilisée sans paramètres, la commande show news affiche des informations de configuration générales pour le composant Outlook Express News par défaut.

Syntaxe

show news [{/v | /p}]

Paramètres

{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Exemples

Pour afficher le nom et l'adresse TCP/IP du serveur de News, tapez :

show news

show os

Affiche des informations à propos du système d'exploitation fonctionnant sur l'ordinateur local.

Syntaxe

show os [/v]

Paramètres

/v
Spécifie que les champs contenant une valeur NULL doivent apparaître.

Remarques

  • Les informations affichées par le biais de cette commande sont collectées par le fournisseur d'infrastructure WMI win32_operatingsystem.

show test

Affiche tous les objets réseau définis pour l'ordinateur local et vérifie la connectivité avec chaque objet à l'aide de la commande ping. Utilisée sans paramètres, la commande show test affiche des informations de configuration générales pour les composants matériels et logiciels suivants : Courrier d'Outlook Express par défaut, Outlook Express News par défaut, Proxy Web Internet Explorer, Boucle, Système de l'ordinateur, Système d'exploitation, Version, Modems, Cartes réseau et Clients réseau. En outre, cette commande vérifie la connectivité avec la carte de bouclage et toutes les adresses IP configurées comme une option client dans les propriétés TCP/IP de chaque carte réseau.

Syntaxe

show test [{/v | /p}]

Paramètres

{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Le résultat de cette commande peut être volumineux et requérir quelques minutes d'attente. Il comprend des informations de configuration sur les serveurs de messagerie, de News et les serveurs proxy, ainsi que les résultats des tentatives de vérification de la connectivité avec ces serveurs à l'aide de la commande ping. Cette commande vérifie la connectivité avec l'adresse de boucle TCP/IP et affiche des informations sur celle-ci. Elle affiche également des détails à propos de l'ordinateur, du système d'exploitation et de tous les clients et cartes réseau. Elle vérifie enfin la connectivité avec les clients et cartes réseau à l'aide de la commande ping, et affiche les résultats.

Exemples

Pour afficher toutes les informations disponibles dans le contexte de diagnostic Netsh, tapez :

show test /v

show version

Affiche la version du système d'exploitation et, facultativement, la version de WMI (Windows Management Infrastructure). Utilisée sans paramètres, la commande show version affiche le numéro de version du système d'exploitation installé sur l'ordinateur local.

Syntaxe

show version [{/v | /p}]

Paramètres

{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • La première ligne du résultat de cette commande indique la version du système d'exploitation. La deuxième ligne indique la version de WMI. Voici un exemple typique de résultat de cette commande :
    • Version (5.1.2416)

    Version = 5.1.2416

    BuildVersion = 2416.0000

Exemples

Pour afficher la version du système d'exploitation et de WMI, en incluant les champs avec une valeur NULL, tapez :

show version /v

show wins

Affiche la liste des serveurs WINS pour la (les) carte(s) spécifiée(s). Utilisée sans paramètres, la commande show wins affiche la liste des serveurs définis pour toutes les cartes installées.

Syntaxe

show wins [{NuméroIndex | NomCompletCarte | NomPartielCarte}] [{/v | /p}]

Paramètres

{NuméroIndex | NomCompletCarte | NomPartielCarte}
Spécifie la ou les cartes pour lesquelles vous souhaitez afficher la liste des serveurs. Le paramètre NuméroIndex spécifie le numéro d'index de la carte. Le paramètre NomCompletCarte spécifie le nom de la carte tel qu'il est inscrit dans le système d'exploitation. Le paramètre NomPartielCarte spécifie le(s) carte(s) dont le nom contient la séquence de caractères indiquée dans le paramètre. Si la séquence de caractères doit apparaître au début du nom, tapez un astérisque à la fin du paramètre. Si la séquence de caractères doit apparaître à la fin du nom, tapez un astérisque au début du paramètre. Si la séquence de caractères peut apparaître n'importe où dans le nom, tapez un astérisque au début et à la fin du paramètre.
{/v | /p}
Spécifie si les champs contenant une valeur NULL doivent apparaître. Le paramètre /v spécifie que ces champs doivent apparaître. Le paramètre /p spécifie que ces champs ne doivent pas apparaître.

Remarques

  • Vous pouvez utiliser la commande show adapter pour afficher les numéros d'index et les noms complets de toutes les cartes logiques définies sur l'ordinateur.
  • Si vous spécifiez une carte par le biais de son numéro d'index, il n'est pas nécessaire de taper les zéros en en-tête.
  • Voici un exemple typique de résultat de cette commande :
    • Serveurs WINS

    2. [00000002] Contrôleur Fast Ethernet intégré 3Com 3C920 (3C905C-TX Compatible)

    WINSPrimaryServer = 172.16.44.17

    WINSSecondaryServer = 172.16.32.22

Exemples

Pour afficher la liste des serveurs WINS définis pour toutes les cartes sur le serveur, tapez :

show wins

Pour afficher la liste des serveurs WINS spécifiés pour la carte dont le numéro d'index est égal à 2, tapez :

show wins 2


Commandes Netsh pour l'interface IP

Vous pouvez utiliser des commandes dans le contexte Netsh Interface IP pour configurer le protocole TCP/IP (notamment les adresses, les passerelles par défaut, les serveurs DNS et les serveurs WINS) et afficher des informations de configuration et des statistiques.

Vous pouvez exécuter ces commandes à partir de l'invite de commandes Windows XP ou de l'invite de commandes du contexte Netsh Interface IP. Pour que ces commandes fonctionnent à l'invite de commandes Windows XP, vous devez taper netsh interface ip avant de taper les commandes et paramètres tels qu'ils apparaissent dans la syntaxe ci-dessous. Pour exécuter ces commandes Netsh sur un ordinateur distant fonctionnant sous Windows 2000 Server, vous devez tout d'abord utiliser Connexion au Bureau à distance pour vous connecter à un ordinateur fonctionnant sous Windows 2000 Server qui exécute Terminal Server. Des différences fonctionnelles peuvent apparaître entre les commandes du contexte Netsh sur Windows 2000 et Windows XP.

Pour plus d'informations sur Netsh, consultez Utilisation de Netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

set address

Configure une adresse IP et une passerelle par défaut sur une interface spécifiée.

Syntaxe

set address [name=]NomInterface [source=]{dhcp | static [addr=]AdresseIP [mask=]MasqueSousRéseau [gateway=]{none | PasserelleParDéfaut [[gwmetric=]MétriquePasserelle]}}

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez configurer les informations d'adresse et de passerelle. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[source=]{dhcp | static [addr=]AdresseIP [mask=]MasqueSousRéseau [gateway=]{none | PasserelleParDéfaut [[gwmetric=]MétriquePasserelle]}}
Requis. Spécifie si l'adresse IP à configurer provient d'un serveur Dynamic Host Configuration Protocol (DHCP) ou s'il s'agit d'une adresse statique. Si l'adresse est statique, AdresseIP spécifie l'adresse à configurer et MasqueSousRéseau spécifie le masque de sous-réseau de l'adresse IP en cours de configuration. Si l'adresse est statique, vous devez également spécifier si vous souhaitez conserver la passerelle par défaut actuelle (si elle existe) ou si vous voulez en configurer une pour l'adresse. Si vous configurez une passerelle par défaut, PasserelleParDéfaut spécifie l'adresse IP de la passerelle par défaut à configurer et MétriquePasserelle indique la valeur métrique de cette passerelle par défaut.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Vous pouvez utiliser cette commande pour basculer une interface d'une configuration DHCP à une configuration statique et vice versa. Si l'interface est configurée statiquement, les adresses des serveurs DNS et WINS de cette interface doivent également être configurées statiquement.
  • L'omission du paramètre PasserelleParDéfaut n'efface pas la configuration de la passerelle mais préserve la configuration précédente.

add address

Ajoute une adresse IP et une passerelle par défaut à une interface spécifiée et configurée avec une adresse IP statique.

Syntaxe

add address [name=]NomInterface [addr=]AdresseIP [mask=]MasqueSousRéseau [[gateway=] PasserelleParDéfaut [gwmetric=]MétriquePasserelle]

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface à laquelle vous souhaitez ajouter les informations d'adresse et de passerelle. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseIP [mask=]MasqueSousRéseau
Requis. Indique l'adresse IP à ajouter ainsi que le masque de sous-réseau de cette adresse IP.
[gateway=]PasserelleParDéfaut [gwmetric=]MétriquePasserelle
Indique l'adresse IP de la passerelle par défaut à ajouter ainsi que la valeur métrique de cette passerelle par défaut.
/?
Affiche de l'aide à l'invite de commandes.

delete address

Supprime une adresse IP ou une passerelle par défaut sur une interface configurée statiquement.

Syntaxe

delete address [name=]NomInterface [addr=] AdresseIP [[gateway=]{PasserelleParDéfaut | all}]

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez supprimer les informations d'adresse et de passerelle. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseIP
Requis. Spécifie l'adresse IP à supprimer.
[gateway=]{PasserelleParDéfaut | all}
Spécifie s'il faut supprimer une seule passerelle par défaut ou toutes les passerelles par défaut. Si une seule passerelle par défaut doit être supprimée, PasserelleParDéfaut spécifie l'adresse IP de la passerelle par défaut à supprimer.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Cette commande ne va pas supprimer la dernière adresse IP sur l'interface.

show address

Affiche les informations relatives aux adresses IP statiques et aux passerelles par défaut sur une interface spécifiée. Utilisée sans paramètres, la commande show address affiche les informations relatives aux adresses pour toutes les interfaces.

Syntaxe

show address [[name=]NomInterface]

Paramètres

[name=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher les informations relatives aux adresses. Le NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Pour les interfaces configurées à l'aide de DHCP, utilisez la commande ipconfig pour afficher les adresses IP assignées, les paramètres de bail et d'autres informations sur DHCP.

set dns

Configure une adresse de serveur DNS pour une interface spécifiée.

Syntaxe

set dns [name=]NomInterface [source=]{dhcp | static [addr=]{AdresseDNS | none}} [[ddns=]{disabled | enabled}] [[suffix=]{interface | primary}]

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez définir les informations de type DNS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[source=]{dhcp | static [addr =]{AdresseDNS | none}}
Requis. Indique si l'adresse IP du serveur DNS est configurée par DHCP ou est statique. Si l'adresse IP est statique, AdresseDNS spécifie l'adresse IP du serveur DNS à configurer et none indique que la configuration DNS doit être supprimée.
[ddns=]{disabled | enabled}
Spécifie si l'ordinateur doit tenter l'inscription de mise à jour dynamique DNS des adresses IP de cette connexion et du nom complet de l'ordinateur. Le nom complet de l'ordinateur est défini dans l'élément Système du Panneau de configuration, dans l'onglet Nom de l'ordinateur. Le paramètre enabled indique que la tentative doit avoir lieu. Le paramètre disabled indique que la tentative ne doit pas avoir lieu.
[suffix=]{interface | primary}
Spécifie si l'ordinateur doit tenter la mise à jour dynamique DNS pour inscrire les adresses IP et le nom de domaine spécifique à cette connexion, en plus du nom complet de l'ordinateur. Le nom DNS spécifique à cette connexion résulte de la concaténation entre le nom de l'ordinateur (première partie du nom complet de l'ordinateur) et le suffixe DNS de la connexion. Le paramètre interface indique qu'il faut inscrire à la fois le nom complet de l'ordinateur et le nom spécifique à cette connexion. Le paramètre primary indique que seul le nom complet de l'ordinateur doit être inscrit.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Si l'interface est déjà configurée statiquement, le paramètre static remplace la liste existante des adresses de serveurs DNS par celle qui est spécifiée dans la commande.
  • Le paramètre par défaut pour ddns= est enabled.
  • Le paramètre par défaut pour suffix= est primary.

add dns

Ajoute un serveur DNS à une liste de serveurs DNS pour une interface spécifiée.

Syntaxe

add dns [name=]NomInterface [addr=] AdresseDNS [[index=]IndexDNS]

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface à laquelle vous souhaitez ajouter des informations de type DNS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr= ]AdresseDNS
Requis. Spécifie l'adresse IP du serveur DNS à ajouter.
[index=]IndexDNS
Spécifie la position du serveur DNS ajouté dans la liste des serveurs DNS pour l'interface.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Un nombre petit pour le paramètre IndexDNS correspond à une plus grande préférence. Si aucun index n'est spécifié, le serveur est ajouté avec le niveau de préférence le plus bas.

delete dns

Supprime un ou tous les serveurs DNS d'une liste de serveurs DNS pour une interface spécifiée ou pour toutes les interfaces.

Syntaxe

delete dns [name=]NomInterface [addr=]{AdresseDNS | all}

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez supprimer les informations de type DNS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]{AdresseDNS | all}
Requis. Spécifie si vous voulez supprimer l'adresse d'un serveur DNS ou de tous les serveurs pour toutes les interfaces. Si un seul serveur DNS doit être supprimé, AdresseDNS spécifie l'adresse IP du serveur DNS à supprimer.
/?
Affiche de l'aide à l'invite de commandes.

show dns

Affiche la configuration DNS d'une interface spécifiée. Utilisée sans paramètres, la commande show dns affiche les configurations DNS de toutes les interfaces.

Syntaxe

show dns [[name=]NomInterface]

Paramètres

[name=]NomInterface
Indique le nom de l'interface dont vous souhaitez afficher la configuration DNS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
/?
Affiche de l'aide à l'invite de commandes.

set wins

Définit la configuration du serveur WINS en tant que mode DHCP ou mode statique pour une interface spécifiée.

Syntaxe

set wins [name=]NomInterface [source=]{dhcp | static [addr=]{AdresseWINS | none }}

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez définir les informations de type WINS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[source=]{dhcp | static [addr=]{AdresseWINS | none }}
Requis. Indique si l'adresse IP du serveur WINS à configurer doit être assignée par DHCP ou s'il s'agit d'une adresse statique. Si l'adresse IP est statique, AdresseWINS spécifie l'adresse IP du serveur WINS à configurer et none indique que la configuration WINS doit être supprimée.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Si l'interface est déjà configurée statiquement, le paramètre static remplace la liste existante des adresses de serveurs WINS par celle qui est spécifiée dans la commande set wins.

add wins

Ajoute un serveur WINS à une liste de serveurs WINS pour une interface spécifiée.

Syntaxe

add wins [name=]NomInterface [addr=] AdresseWINS [[index=]IndexWINS]

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface à laquelle vous souhaitez ajouter des informations de type WINS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseWINS
Requis. Spécifie l'adresse IP du serveur WINS à ajouter.
[index=]IndexWINS
Spécifie la position du serveur WINS ajouté dans la liste des serveurs WINS pour cette interface.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Un nombre petit pour le paramètre IndexWINS correspond à une plus grande préférence. Si aucun index n'est spécifié, le serveur est ajouté avec le niveau de préférence le plus bas.

delete wins

Supprime un ou plusieurs serveurs WINS d'une liste de serveurs WINS pour une interface spécifiée ou pour toutes les interfaces.

Syntaxe

delete wins [name=]NomInterface [addr=]{AdresseWINS | all}

Paramètres

[name=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez supprimer un ou plusieurs serveurs WINS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]{AdresseWINS | all}
Requis. Spécifie si vous voulez supprimer uniquement un serveur pour une interface ou tous les serveurs pour toutes les interfaces. Si un seul serveur doit être supprimé, AdresseWINS spécifie l'adresse IP du serveur WINS à supprimer.
/?
Affiche de l'aide à l'invite de commandes.

show wins

Affiche la configuration WINS d'une interface spécifiée. Utilisée sans paramètres, la commande show wins affiche les configurations WINS de toutes les interfaces.

Syntaxe

show wins [[name=]NomInterface]

Paramètres

[name=]NomInterface
Indique le nom de l'interface dont vous souhaitez afficher les informations de type WINS. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
/?
Affiche de l'aide à l'invite de commandes.

show icmp

Affiche les statistiques ICMP. Utilisée sans paramètres, la commande show icmp n'affiche les statistiques qu'une seule fois.

Syntaxe

show icmp [[rr=]TauxRafraîchissement]

Paramètres

[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

show interface

Affiche les statistiques pour une interface spécifiée. Utilisée sans paramètres, la commande show interface n'affiche les statistiques de toutes les interfaces qu'une seule fois.

Syntaxe

show interface [[index=]IndexInterface] [[rr=]TauxRafraîchissement]

Paramètres

[index=]IndexInterface
Spécifie l'index d'interface, à savoir un entier qui identifie l'interface.
[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Pour obtenir l'index d'une interface, consultez le résultat de la commande show interface utilisée sans paramètres.

show ipaddress

Affiche des informations pour une adresse IP spécifiée. Utilisée sans paramètres, la commande show ipaddress affiche des informations pour toutes les adresses IP de toutes les interfaces.

Syntaxe

show ipaddress [[index=]AdresseIP] [[rr=]TauxRafraîchissement]

Paramètres

[index=]AdresseIP
Spécifie une adresse IP d'une interface.
[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Pour obtenir les adresses IP de toutes les interfaces, consultez le résultat de la commande show ipaddress utilisée sans paramètres.

show ipnet

Affiche le contenu du cache ARP (Address Resolution Protocol), qui contient les adresses matérielles des adresses IP résolues du tronçon suivant. Utilisée sans paramètres, la commande show ipnet n'affiche les informations qu'une seule fois.

Syntaxe

show ipnet [[rr=]TauxRafraîchissement]

Paramètres

[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

show ipstats

Affiche les statistiques IP. Utilisée sans paramètres, la commande show ipstats n'affiche les statistiques qu'une seule fois.

Syntaxe

show ipstats [[rr=]TauxRafraîchissement]

Paramètres

[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

show joins

Affiche les groupes de multidiffusion IP qui ont été joints pour l'adresse IP spécifiée. Utilisée sans paramètres, la commande show joins affiche des informations relatives à toutes les adresses IP.

Syntaxe

show joins [[index=]AdresseIP]

Paramètres

[index=]AdresseIP
Spécifie une adresse IP d'une interface.
/?
Affiche de l'aide à l'invite de commandes.

Remarques

  • Pour obtenir les adresses IP de toutes les interfaces, consultez le résultat de la commande show ipaddress utilisée sans paramètres.

show tcpconn

Affiche des informations relatives à une connexion TCP spécifiée. Utilisée sans paramètres, la commande show tcpconn n'affiche les informations de toutes les connexions TCP qu'une seule fois.

Syntaxe

show tcpconn [[index=]{AdresseIPLocale | PortLocal | AdresseIPDistante | PortDistant}] [[rr=]TauxRafraîchissement]

Paramètres

[index=]{AdresseIPLocale | PortLocal | AdresseIPDistante | PortDistant}
Spécifie la connexion à propos de laquelle vous souhaitez afficher des informations. Le paramètre AdresseIPLocale spécifie une adresse IP d'une interface. Le paramètre PortLocal spécifie un port TCP pour un processus local. Le paramètre AdresseIPDistante spécifie une adresse IP d'un hôte distant. Le paramètre PortDistant spécifie un port TCP pour un processus distant.
[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des informations).
/?
Affiche de l'aide à l'invite de commandes.

show tcpstats

Affiche les statistiques TCP. Utilisée sans paramètres, la commande show tcpstats n'affiche les statistiques qu'une seule fois.

Syntaxe

show tcpstats [[rr=]TauxRafraîchissement]

Paramètres

[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

show udpconn

Affiche des informations relatives aux ports UDP utilisés pour chaque adresse IP. Utilisée sans paramètres, la commande show udpconn n'affiche les informations relatives aux ports UDP pour toutes les adresses IP qu'une seule fois.

Syntaxe

show udpconn [[index=]{AdresseIPLocale | PortLocal}] [[rr=]TauxRafraîchissement]

Paramètres

[index=]{AdresseIPLocale | PortLocal}
Spécifie la connexion à propos de laquelle vous souhaitez afficher des informations. Le paramètre AdresseIPLocale spécifie une adresse IP d'une interface. Le paramètre PortLocal spécifie un port UDP pour un processus local.
[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

show udpstats

Affiche les statistiques UDP. Utilisée sans paramètres, la commande show udpstats n'affiche les statistiques qu'une seule fois.

Syntaxe

show udpstats [[rr=]TauxRafraîchissement]

Paramètres

[rr=]TauxRafraîchissement
Spécifie le taux de rafraîchissement (nombre de secondes entre chaque rafraîchissement de l'affichage des statistiques).
/?
Affiche de l'aide à l'invite de commandes.

show config

Affiche l'adresse IP et d'autres informations de configuration pour une interface spécifiée. Utilisée sans paramètres, la commande show config affiche des informations de configuration pour toutes les interfaces.

Syntaxe

show config [[name=]NomInterface]

Paramètres

[name=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations de configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
/?
Affiche de l'aide à l'invite de commandes.

show offload

Affiche les tâches qui peuvent être effectuées par la carte réseau pour l'interface spécifiée correspondant au matériel réseau installé. Utilisée sans paramètres, la commande show offload affiche des informations de déchargement pour toutes les interfaces correspondant au matériel réseau installé.

Syntaxe

show offload [[name=]NomInterface]

Paramètres

[name=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations de déchargement. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
/?
Affiche de l'aide à l'invite de commandes.

delete arpcache

Supprime les entrées dans le cache ARP (Address Resolution Protocol) pour une interface spécifiée. Utilisée sans paramètres, la commande delete arpcache supprime les entrées dans les caches ARP de toutes les interfaces.

Syntaxe

delete arpcache [[name=]NomInterface]

Paramètres

[name=]NomInterface
Indique le nom de l'interface dont vous souhaitez supprimer les entrées du cache ARP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
/?
Affiche de l'aide à l'invite de commandes.

dump

Affiche la configuration actuelle sous la forme d'une série de commandes Netsh Interface IP.

Syntaxe

dump

Paramètres

aucun

Remarques

  • Pour créer un fichier de script de configuration, redirigez la sortie de cette commande vers un fichier.

Exemple Netsh Interface IP

La commande ci-dessous configure l'interface nommée Connexion au réseau local avec l'adresse IP statique 10.0.5.99, le masque de sous-réseau 255.255.255.0 et une passerelle par défaut 10.0.5.1 :

set address name="Connexion au réseau local" source=static addr=10.0.5.99 mask=255.255.255.0 gateway=10.0.5.1 XOX


Commandes Netsh pour RAS

Vous pouvez administrer des serveurs d'accès distant en tapant des commandes à l'invite de commandes du contexte Netsh RAS. L'invite de commandes Netsh RAS vous permet d'administrer des serveurs plus rapidement sur des connexions réseau lentes, et de créer des scripts afin d'automatiser l'administration d'un grand nombre de serveurs.

Pour exécuter ces commandes Netsh sur un ordinateur distant fonctionnant sous Windows 2000 Server, vous devez tout d'abord utiliser Connexion au Bureau à distance pour vous connecter à un ordinateur fonctionnant sous Windows 2000 Server qui exécute Terminal Server. Des différences fonctionnelles peuvent apparaître entre les commandes du contexte Netsh sur Windows 2000 et Windows XP.

Pour plus d'informations sur Netsh, consultez Utilisation de Netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

help

Affiche l'aide de ligne de commande pour les commandes disponibles dans le contexte Netsh RAS.

Syntaxe

help

Paramètres

aucun

Remarques

  • Vous pouvez également afficher l'aide de ligne de commande en tapant l'une des commandes ci-dessous à l'invite de commandes du contexte Netsh RAS : ?, /? ou -?.

show activeservers

Affiche la liste des annonces des serveurs d'accès distant.

Syntaxe

show activeservers

Paramètres

aucun

show client

Affiche la liste des clients d'accès distant connectés à ce serveur.

Syntaxe

show client

Paramètres

aucun

dump

Affiche la configuration du serveur d'accès distant sous forme de script.

Syntaxe

dump

Paramètres

aucun

show tracing

Affiche si le suivi est activé pour le composant spécifié. Utilisée sans paramètres, la commande show tracing affiche la liste de tous les composants installés et indique si le suivi est activé pour chacun d'eux.

Syntaxe

show tracing [Composant]

Paramètres

Composant
Spécifie le composant à propos duquel vous souhaitez afficher des informations.

set tracing

Active ou désactive le suivi pour le composant spécifié.

Syntaxe

set tracing Composant {enabled | disabled}

Paramètres

Composant
Requis. Indique le composant dont vous souhaitez activer ou désactiver le suivi. Utilisez * pour désigner tous les composants.
{enabled | disabled}
Requis. Spécifie si vous voulez activer ou désactiver le suivi pour le composant spécifié.

Remarques

  • Pour afficher la liste de tous les composants installés, utilisez la commande show tracing sans paramètres.

Exemples

Pour définir le suivi pour le composant PPP, tapez :

set tracing ppp enabled

show authmode

Affiche si les clients de l'accès à distance qui utilisent certains types de périphériques doivent être authentifiés.

Syntaxe

show authmode

Paramètres

aucun

set authmode

Spécifie si les clients de l'accès à distance qui utilisent certains types de périphériques doivent être authentifiés.

Syntaxe

set authmode {standard | nodcc | bypass}

Paramètres

{standard | nodcc | bypass}
Requis. Spécifie si les clients de l'accès à distance qui utilisent certains types de périphériques doivent être authentifiés. Le paramètre standard indique que les clients qui utilisent n'importe quel type de périphérique doivent être authentifiés. Le paramètre nodcc indique que les clients qui utilisent n'importe quel type de périphérique, à l'exception d'un périphérique à connexion directe, doivent être authentifiés. Le paramètre bypass indique qu'aucun client ne doit être authentifié.

add authtype

Ajoute un type d'authentification à la liste de ceux que le serveur d'accès distant doit utiliser pour tenter de négocier l'authentification.

Syntaxe

add authtype {pap|spap|md5chap|mschap|mschapv2|eap}

Paramètres

{pap|spap|md5chap|mschap|mschapv2|eap}
Requis. Spécifie quel type d'authentification ajouter à la liste de ceux que le serveur d'accès distant doit utiliser pour tenter de négocier l'authentification. Le paramètre pap spécifie que le serveur d'accès distant doit utiliser le protocole d'authentification de mot de passe (PAP, Password Authentication Protocol) (texte en clair). Le paramètre spap spécifie que le serveur d'accès distant doit utiliser le protocole d'authentification de mot de passe Shiva (SPAP, Shiva Password Authentication Protocol). Le paramètre md5chap spécifie que le serveur d'accès distant doit utiliser le protocole d'authentification de négociation par défi (CHAP, Challenge Handshake Authentication Protocol), utilisant le schéma de hachage Message Digest 5 pour crypter la réponse. Le paramètre mschap spécifie que le serveur d'accès distant doit utiliser le protocole d'authentification de négociation par défi Microsoft (MSCHAP, Microsoft Challenge-Handshake Authentication Protocol). Le paramètre mschapv2 spécifie que le serveur d'accès distant doit utiliser la Version 2 de MSCHAP. Le paramètre eap spécifie que le serveur d'accès distant doit utiliser le protocole EAP (Extensible Authentication Protocol).

Remarques

  • Le serveur d'accès distant tentera de négocier l'authentification en commençant par le protocole le plus sécurisé et en terminant par le moins sécurisé. Après que le client et le serveur se sont mis d'accord sur un type d'authentification, la négociation PPP s'effectue en fonction des RFC appropriés.

delete authtype

Supprime un type d'authentification de la liste de ceux que le serveur d'accès distant doit utiliser pour tenter de négocier l'authentification.

Syntaxe

delete authtype {pap|spap|md5chap|mschap|mschapv2|eap}

Paramètres

{pap|spap|md5chap|mschap|mschapv2|eap}
Requis. Spécifie quel type d'authentification supprimer de la liste de ceux que le serveur d'accès distant doit utiliser pour tenter de négocier l'authentification. Le paramètre pap spécifie que le serveur d'accès distant ne doit pas utiliser le protocole d'authentification de mot de passe (PAP, Password Authentication Protocol) (texte en clair). Le paramètre spap spécifie que le serveur d'accès distant ne doit pas utiliser le protocole d'authentification de mot de passe Shiva (SPAP, Shiva Password Authentication Protocol). Le paramètre md5chap spécifie que le serveur d'accès distant ne doit pas utiliser le protocole d'authentification de négociation par défi (CHAP, Challenge Handshake Authentication Protocol), utilisant le schéma de hachage Message Digest 5 pour crypter la réponse. Le paramètre mschap spécifie que le serveur d'accès distant ne doit pas utiliser le protocole d'authentification de négociation par défi Microsoft (MSCHAP, Microsoft Challenge-Handshake Authentication Protocol). Le paramètre mschapv2 spécifie que le serveur d'accès distant ne doit pas utiliser la Version 2 de MSCHAP. Le paramètre eap spécifie que le serveur d'accès distant ne doit pas utiliser le protocole EAP (Extensible Authentication Protocol).

show authtype

Indique le(s) type(s) d'authentification que le serveur d'accès distant utilise pour tenter de négocier l'authentification.

Syntaxe

show authtype

Paramètres

aucun

add link

Ajoute une propriété de liaison à la liste des propriétés de liaison que PPP doit négocier.

Syntaxe

add link {swc | lcp}

Paramètres

{swc | lcp}
Requis. Indique la propriété de liaison à ajouter à la liste des propriétés de liaison que PPP doit négocier. Le paramètre swc indique la prise en compte de la compression logicielle (MPPC). Le paramètre lcp indique l'implémentation des extensions LCP (Link Control Protocol) de la suite de protocoles PPP.

delete link

Supprime une propriété de liaison de la liste des propriétés de liaison que PPP doit négocier.

Syntaxe

delete link {swc | lcp}

Paramètres

{swc | lcp}
Requis. Indique la propriété de liaison à supprimer de la liste des propriétés de liaison que PPP doit négocier. Le paramètre swc indique la suppression de la compression logicielle (MPPC). Le paramètre lcp indique la suppression des extensions LCP (Link Control Protocol) de la suite de protocoles PPP.

show link

Affiche les propriétés de liaison que PPP doit négocier.

Syntaxe

show link

Paramètres

aucun

add multilink

Ajoute un type de liaisons multiples à la liste des types de liaisons multiples que PPP doit négocier.

Syntaxe

add multilink {multi | bacp}

Paramètres

{multi | bacp}
Requis. Indique le type de liaisons multiples à ajouter à la liste des types de liaisons multiples que PPP doit négocier. Le paramètre multi indique la prise en compte des sessions PPP à liaisons multiples. Le paramètre bacp indique la prise en charge du protocole de contrôle d'attribution de bande passante (BACP, Bandwidth Allocation Control Protocol).

delete multilink

Supprime un type de liaisons multiples de la liste des types de liaisons multiples que PPP doit négocier.

Syntaxe

delete multilink {multi | bacp}

Paramètres

{multi | bacp}
Requis. Indique le type de liaisons multiples à supprimer de la liste des types de liaisons multiples que PPP doit négocier. Le paramètre multi indique la suppression des sessions PPP à liaisons multiples. Le paramètre bacp indique la suppression du protocole de contrôle d'attribution de bande passante (BACP, Bandwidth Allocation Control Protocol).

show multilink

Affiche les types de liaisons multiples que PPP doit négocier.

Syntaxe

show multilink

Paramètres

aucun

add registeredserver

Inscrit le serveur spécifié en tant que serveur d'accès distant dans le domaine Active Directory indiqué. Utilisée sans paramètres, la commande add registeredserver inscrit l'ordinateur sur lequel vous tapez la commande dans son domaine principal.

Syntaxe

add registeredserver [[domain=]NomDomaine] [[server=]NomServeur]

Paramètres

[domain=]NomDomaine
Indique le nom du domaine dans lequel il faut inscrire le serveur. Si vous ne spécifiez pas de domaine, le serveur est inscrit dans son domaine principal.
[server=]NomServeur
Indique le nom DNS ou l'adresse IP du serveur à inscrire. Si vous ne spécifiez pas de serveur, l'ordinateur sur lequel vous tapez la commande est inscrit.

delete registeredserver

Supprime l'inscription du serveur spécifié en tant que serveur d'accès distant du domaine Active Directory indiqué. Utilisée sans paramètres, la commande delete registeredserver supprime l'inscription de l'ordinateur sur lequel vous tapez la commande de son domaine principal.

Syntaxe

delete registeredserver [[domain=]NomDomaine] [[server=]NomServeur]

Paramètres

[domain=]NomDomaine
Indique le nom du domaine dans lequel il faut supprimer l'inscription. Si vous ne spécifiez pas de domaine, l'inscription est supprimée du domaine primaire de l'ordinateur sur lequel vous tapez la commande.
[server=]NomServeur
Indique le nom DNS ou l'adresse IP du serveur dont vous voulez supprimer l'inscription. Si vous ne spécifiez pas de serveur, l'inscription de l'ordinateur sur lequel vous tapez la commande est supprimée.

show registeredserver

Affiche les informations d'état du serveur spécifié et inscrit en tant que serveur d'accès distant dans le domaine Active Directory indiqué. Utilisée sans paramètres, la commande show registeredserver affiche les informations de l'ordinateur sur lequel vous tapez la commande dans son domaine principal.

Syntaxe

show registeredserver [[domain=]NomDomaine] [[server=]NomServeur]

Paramètres

[domain=]NomDomaine
Indique le nom du domaine dans lequel est inscrit le serveur à propos duquel vous souhaitez afficher des informations. Si vous ne spécifiez pas de domaine, les informations du serveur inscrit dans le domaine primaire de l'ordinateur sur lequel vous tapez la commande sont affichées.
[server=]NomServeur
Indique le nom DNS ou l'adresse IP du serveur dont vous voulez afficher les informations. Si vous ne spécifiez pas de serveur, les informations de l'ordinateur sur lequel vous tapez la commande sont affichées.

show user

Affiche les propriétés d'un ou plusieurs utilisateurs d'accès distant particuliers. Utilisée sans paramètres, la commande show user affiche les propriétés de tous les utilisateurs d'accès distant.

Syntaxe

show user [name=NomUtilisateur] [[mode=] {permit | report}]

Paramètres

name=NomUtilisateur
Indique le nom d'ouverture de session de l'utilisateur dont vous souhaitez afficher les propriétés. Si vous ne spécifiez aucun utilisateur, les propriétés de tous les utilisateurs sont affichées.
mode= {permit | report}
Spécifie s'il faut afficher les propriétés de tous les utilisateurs ou uniquement de ceux dont l'autorisation d'accès à distance est activée (paramètre « permit »). Le paramètre permit spécifie qu'il faut afficher les propriétés uniquement des utilisateurs dont l'autorisation d'accès à distance est activée. Le paramètre report spécifie qu'il faut afficher les propriétés de tous les utilisateurs.

set user

Définit les propriétés de l'utilisateur d'accès distant spécifié.

Syntaxe

set user [name=]NomUtilisateur [dialin] {permit | deny | policy} [cbpolicy] {none | caller | admin [cbnumber=]NuméroRappel}

Paramètres

name=NomUtilisateur
Requis. Indique le nom d'ouverture de session de l'utilisateur dont vous souhaitez définir les propriétés.
[dialin] {permit | deny | policy}
Requis. Spécifie dans quelles circonstances l'utilisateur doit être autorisé à se connecter. Le paramètre permit spécifie que l'utilisateur est toujours autorisé à se connecter. Le paramètre deny spécifie que l'utilisateur n'est jamais autorisé à se connecter. Le paramètre policy spécifie que les stratégies d'accès distant doivent déterminer si l'utilisateur est autorisé à se connecter ou non.
[cbpolicy] {none | caller | admin [cbnumber=]NuméroRappel}
Requis. Spécifie la stratégie de rappel pour l'utilisateur. La fonctionnalité de rappel permet à l'utilisateur d'économiser le coût de l'appel téléphonique utilisé pour la connexion à un serveur d'accès distant. Le paramètre none spécifie qu'il ne faut pas rappeler l'utilisateur. Le paramètre caller spécifie qu'il faut rappeler l'utilisateur au numéro indiqué par celui-ci au moment de la connexion. Le paramètre admin indique qu'il faut rappeler l'utilisateur au numéro spécifié par le paramètre NuméroRappel.

Remarques

  • Pour les utilisateurs qui se trouvent dans un domaine en mode mixte, les paramètres policy et deny sont équivalents.

Exemples

Pour permettre à l'utilisateur « GuestUser » de se connecter et d'être rappelé au numéro 4255551212, tapez :

set user guestuser permit admin 4255551212

Commandes du contexte Netsh RAS IP

Les commandes suivantes sont spécifiques au contexte RAS IP de l'environnement Netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

dump

Crée un script contenant la configuration IP d'un serveur d'accès distant. Si vous enregistrez ce script dans un fichier, vous pouvez utiliser celui-ci pour rétablir les paramètres de configuration IP.

Syntaxe

dump

Paramètres

aucun

show config

Affiche la configuration IP actuelle du serveur d'accès distant.

Syntaxe

show config

Paramètres

aucun

set negotiation

Spécifie si le serveur d'accès distant doit autoriser la configuration IP pour toutes les connexions client que le serveur accepte.

Syntaxe

set negotiation {allow | deny}

Paramètres

{allow | deny}
Requis. Spécifie si IP est autorisé pour les connexions client. Le paramètre allow autorise IP pour les connexions client. Le paramètre deny interdit IP pour les connexions client.

set access

Spécifie si le trafic réseau IP provenant des clients doit être transmis au(x) réseau(x) au(x)quel(s) est connecté le serveur d'accès distant.

Syntaxe

set access {all | serveronly}

Paramètres

{all | serveronly}
Requis. Spécifie si les clients peuvent accéder au serveur d'accès distant ainsi qu'à tout réseau auquel celui-ci est connecté. Le paramètre all autorise les clients à atteindre d'autres réseaux par l'intermédiaire du serveur. Le paramètre serveronly autorise les clients à atteindre uniquement le serveur.

set addrassign

Définit la méthode utilisée par le serveur d'accès distant pour assigner des adresses IP à ses clients.

Syntaxe

set addrassign {auto | pool}

Paramètres

{auto | pool}
Requis. Spécifie si les adresses IP doivent être assignées à l'aide de DHCP ou à partir d'un pool d'adresses détenu par le serveur d'accès distant. Le paramètre auto spécifie que les adresses doivent être assignées à l'aide de DHCP. Si aucun serveur DHCP n'est disponible, une adresse privée aléatoire est assignée. Le paramètre pool spécifie que les adresses doivent être assignées à partir d'un pool.

set addrreq

Spécifie si les clients de l'accès à distance sont autorisés à demander leurs propres adresses IP.

Syntaxe

set addrreq {allow | deny}

Paramètres

{allow | deny}
Requis. Spécifie si les clients sont autorisés à demander leurs propres adresses IP. Le paramètre allow autorise les clients à demander des adresses. Le paramètre deny empêche les clients de demander des adresses.

set broadcastnameresolution

Active ou désactive la résolution de noms de diffusion à l'aide de NetBIOS sur TCP/IP.

Syntaxe

set broadcastnameresolution {enabled | disabled}

Paramètres

{enabled | disabled}
Requis. Spécifie l'activation ou la désactivation de la résolution de noms de diffusion à l'aide de NetBIOS sur TCP/IP.

add range

Ajoute une plage d'adresses au pool d'adresses IP statiques que le serveur d'accès distant peut assigner aux clients.

Syntaxe

add range [from=]AdresseIPDébut [to=]AdresseIPFin

Paramètres

[from=]AdresseIPDébut [to=]AdresseIPFin
Requis. Spécifie la plage d'adresses IP à ajouter. Le paramètre AdresseIPDébut indique la première adresse IP de la plage d'adresses. Le paramètre AdresseIPFin indique la dernière adresse IP de la plage d'adresses.

Exemples

Pour ajouter la plage d'adresses IP allant de 10.2.2.10 à 10.2.2.20 au pool d'adresses IP statiques que le serveur d'accès distant peut assigner, tapez :

add range from=10.2.2.10 to=10.2.2.20

delete range

Supprime une plage d'adresses du pool d'adresses IP statiques que le serveur d'accès distant peut assigner aux clients.

Syntaxe

delete range [from=]AdresseIPDébut [to=]AdresseIPFin

Paramètres

[from=]AdresseIPDébut [to=]AdresseIPFin
Requis. Spécifie la plage d'adresses IP à supprimer. Le paramètre AdresseIPDébut indique la première adresse IP de la plage d'adresses. Le paramètre AdresseIPFin indique la dernière adresse IP de la plage d'adresses.

Exemples

Pour supprimer la plage d'adresses IP allant de 10.2.2.10 à 10.2.2.20 du pool d'adresses IP statiques que le serveur d'accès distant peut assigner, tapez :

delete range from=10.2.2.10 to=10.2.2.20

delete pool

Supprime toutes les adresses du pool d'adresses IP statiques que le serveur d'accès distant peut assigner aux clients.

Syntaxe

delete pool

Paramètres

aucun

Commandes du contexte Netsh RAS IPX

Les commandes suivantes sont spécifiques au contexte RAS IPX de l'environnement Netsh. XOX

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

dump

Crée un script contenant la configuration IPX du serveur d'accès distant. Si vous enregistrez ce script dans un fichier, vous pouvez utiliser celui-ci pour rétablir les paramètres de configuration IPX.

Syntaxe

dump

Paramètres

aucun

show config

Affiche la configuration IPX actuelle du serveur d'accès distant.

Syntaxe

show config

Paramètres

aucun

set negotiation

Spécifie si le serveur d'accès distant doit autoriser la configuration IPX pour toutes les connexions client que le serveur accepte.

Syntaxe

set negotiation {allow | deny}

Paramètres

{allow | deny}
Requis. Spécifie si le système autorise la configuration IPX. Le paramètre allow autorise la configuration IPX. Le paramètre deny empêche la configuration IPX.

set access

Spécifie si le trafic réseau IPX provenant des clients doit être transmis au(x) réseau(x) au(x)quel(s) est connecté le serveur d'accès distant.

Syntaxe

set access {all | serveronly}

Paramètres

{all | serveronly}
Requis. Spécifie si le trafic IPX doit être transféré. Le paramètre all permet au trafic IPX d'être transféré. Le paramètre serveronly empêche au trafic d'être transféré.

set netassign

Définit la méthode utilisée par le serveur d'accès distant pour assigner des adresses IPX à ses clients.

Syntaxe

set netassign [method] {auto | pool | autosame | poolsame}

Paramètres

[method] {auto | pool | autosame | poolsame}
Requis. Spécifie la méthode utilisée par le serveur d'accès distant pour assigner des adresses IPX aux clients. Le paramètre auto indique que le serveur d'accès distant doit assigner un numéro réseau IPX aléatoire différent à chaque client. Le paramètre pool indique que le serveur d'accès distant doit assigner une adresse IPX différente à chaque client à partir d'un pool d'adresses. Le paramètre autosame indique que le serveur d'accès distant doit générer un numéro réseau IPX aléatoire et l'assigner à tous les clients. Le paramètre poolsame indique que le serveur d'accès distant doit assigner une adresse à tous les clients à partir d'un pool d'adresses.

Remarques

  • Dans la plupart des configurations, les paramètres autosame et poolsame sont recommandés car ils conservent les numéros réseau et réduisent le trafic réseau.
  • Avant d'assigner un numéro réseau à un client, le serveur d'accès distant doit vérifier si ce numéro est déjà utilisé sur l'Intranet auquel le serveur est connecté. Par conséquent, il se peut que certaines adresses du pool ne soient pas assignées.

set pool

Spécifie le pool d'adresses IPX à partir duquel le serveur d'accès distant peut assigner des adresses aux clients.

Syntaxe

set pool [firstnet=]AdresseIPX [size=]{TaillePool | 0}

Paramètres

[firstnet=]AdresseIPX
Requis. Spécifie, en notation hexadécimale, la première adresse IPX du pool.
[size=]{TaillePool | 0}
Requis. Spécifie la taille du pool ou indique que cette taille peut augmenter en fonction des besoins. Le paramètre TaillePool indique, en notation décimale, le nombre d'adresses IPX dans le pool. Le paramètre 0 indique que la taille du pool peut augmenter en fonction des besoins.

Exemples

Pour spécifier que le pool d'adresses IPX doit démarrer à AAAAAAA et que sa taille peut augmenter en fonction des besoins, tapez :

set pool AAAAAAA 0

set nodereq

Spécifie si les clients de l'accès à distance sont autorisés à demander leurs propres numéros de nœud IPX.

Syntaxe

set nodereq {allow | deny}

Paramètres

{allow | deny}
Requis. Spécifie si les clients sont autorisés à demander leurs propres numéros de nœud IPX. Le paramètre allow autorise de telles demandes. Le paramètre deny les interdit.

Commandes du contexte Netsh RAS AppleTalk

Les commandes suivantes sont spécifiques au contexte RAS AppleTalk de l'environnement Netsh. Le protocole AppleTalk n'est pas disponible dans Windows XP Édition Familiale et Windows XP Professionnel.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

dump

Crée un script contenant la configuration AppleTalk du serveur d'accès distant. Si vous enregistrez ce script dans un fichier, vous pouvez utiliser celui-ci pour rétablir les paramètres de configuration AppleTalk.

Syntaxe

dump

Paramètres

aucun

show config

Affiche la configuration AppleTalk actuelle du serveur d'accès distant.

Syntaxe

show config

Paramètres

aucun

set negotiation

Spécifie si le serveur d'accès distant doit autoriser la configuration AppleTalk pour toutes les connexions client que le serveur accepte.

Syntaxe

set negotiation {allow | deny}

Paramètres

{allow | deny}
Requis. Spécifie si le système autorise la configuration AppleTalk. Le paramètre allow autorise la configuration. Le paramètre deny empêche la configuration.

set access

Spécifie si le trafic réseau AppleTalk provenant des clients doit être transféré au(x) réseau(x) au(x)quel(s) est connecté le serveur d'accès distant.

Syntaxe

set access {all | serveronly}

Paramètres

{all | serveronly}
Requis. Spécifie s'il faut transférer le trafic réseau AppleTalk. Le paramètre all permet au trafic d'être transféré. Le paramètre serveronly empêche au trafic d'être transféré.

Commandes du contexte Netsh RAS AAAA

Les commandes suivantes sont spécifiques au contexte RAS AAAA de l'environnement Netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

dump

Affiche la configuration AAAA d'un serveur d'accès distant sous forme de script.

Syntaxe

dump

Paramètres

aucun

add acctserv

Spécifie l'adresse IP ou le nom DNS d'un serveur RADIUS à utiliser pour la gestion des comptes, ainsi que les options de la gestion des comptes.

Syntaxe

add acctserv [name=]IDServeur [[secret=]SecretPartagé] [[init-score=]PrioritéServeur] [[port=]Port] [[timeout=]Secondes] [[messages] {enabled | disabled}]

Paramètres

[name=]IDServeur
Requis. Indique le nom DNS ou l'adresse IP du serveur RADIUS.
[secret=]SecretPartagé
Spécifie le secret partagé.
[init-score=]PrioritéServeur
Spécifie l'étendue initiale (priorité serveur).
[port=]Port
Spécifie le port vers lequel les demandes de gestion de comptes doivent être envoyées.
[timeout=]Secondes
Spécifie le délai, exprimé en secondes, au terme duquel le serveur RADIUS doit être marqué comme non disponible s'il demeure inactif.
[messages] {enabled | disabled}
Spécifie s'il faut envoyer les messages indiquant une comptabilisation active/inactive. Le paramètre enabled indique que les messages doivent être envoyés. Le paramètre disabled indique que les messages ne doivent pas être envoyés.

delete acctserv

Supprime un serveur RADIUS de gestion de comptes.

Syntaxe

delete acctserv [name=]IDServeur

Paramètres

[name=]IDServeur
Requis. Indique le nom DNS ou l'adresse IP du serveur à supprimer.

set acctserv

Fournit l'adresse IP ou le nom DNS d'un serveur RADIUS à utiliser pour la gestion de comptes.

Syntaxe

add acctserv [name=]IDServeur [[secret=]SecretPartagé] [[init-score=]PrioritéServeur] [[port=]Port] [[timeout=]Secondes] [[messages] {enabled | disabled}]

Paramètres

[name=]IDServeur
Requis. Indique le nom DNS ou l'adresse IP du serveur RADIUS.
[secret=]SecretPartagé
Spécifie le secret partagé.
[init-score=]PrioritéServeur
Spécifie l'étendue initiale (priorité serveur).
[port=]Port
Spécifie le port sur lequel envoyer les demandes d'authentification.
[timeout=]Secondes
Spécifie le délai, exprimé en secondes, au terme duquel le serveur RADIUS doit être marqué comme non disponible.
[messages=] {enabled | disabled}
Spécifie s'il faut envoyer les messages indiquant une comptabilisation active/inactive.

show acctserv

Affiche des informations détaillées à propos d'un serveur de gestion de comptes. Utilisée sans paramètres, la commande show acctserv affiche des informations sur tous les serveurs de gestion de comptes qui sont configurés.

Syntaxe

show acctserv [[name=]IDServeur]

Paramètres

[name=]IDServeur
Spécifie le nom DNS ou l'adresse IP du serveur RADIUS à propos duquel vous souhaitez afficher des informations.

add authserv

Fournit l'adresse IP ou le nom DNS du serveur RADIUS auquel les demandes d'authentification doivent être transmises.

Syntaxe

add authserv [name=]IDServeur [[secret=]SecretPartagé] [[init-score=]PrioritéServeur] [[port=]Port] [[timeout=]Secondes] [[signature] {enabled | disabled}]

Paramètres

[name=]IDServeur
Requis. Indique le nom DNS ou l'adresse IP du serveur RADIUS.
[secret=]SecretPartagé
Spécifie le secret partagé.
[init-score=]PrioritéServeur
Spécifie l'étendue initiale (priorité serveur).
[port=]Port
Spécifie le port vers lequel les demandes d'authentification doivent être envoyées.
[timeout=]Secondes
Spécifie le délai, exprimé en secondes, au terme duquel le serveur RADIUS doit être marqué comme non disponible s'il demeure inactif.
[signature] {enabled | disabled}
Spécifie s'il faut utiliser les signatures numériques. Le paramètre enabled indique que les signatures numériques doivent être utilisées. Le paramètre disabled indique que les signatures numériques ne doivent pas être utilisées.

delete authserv

Supprime un serveur RADIUS d'authentification.

Syntaxe

delete authserv [name=]IDServeur

Paramètres

[name=]IDServeur
Requis. Indique le nom DNS ou l'adresse IP du serveur à supprimer.

set authserv

Fournit l'adresse IP ou le nom DNS du serveur RADIUS auquel les demandes d'authentification doivent être transmises.

Syntaxe

set authserv [name=]IDServeur [[secret=]SecretPartagé] [[init-score=]PrioritéServeur] [[port=]Port] [[timeout=]Secondes] [[signature] {enabled | disabled}]

Paramètres

[name=]IDServeur
Requis. Indique le nom DNS ou l'adresse IP du serveur RADIUS.
[secret=]SecretPartagé
Spécifie le secret partagé.
[init-score=]PrioritéServeur
Spécifie l'étendue initiale (priorité serveur).
[port=]Port
Spécifie le port sur lequel envoyer les demandes d'authentification.
[timeout=]Secondes
Spécifie le délai, exprimé en secondes, au terme duquel le serveur RADIUS doit être marqué comme non disponible.
[signature=] {enabled | disabled}
Spécifie s'il faut utiliser les signatures numériques.

show authserv

Affiche des informations détaillées à propos d'un serveur d'authentification. Utilisée sans paramètres, la commande show authserv affiche des informations sur tous les serveurs d'authentification qui sont configurés.

Syntaxe

show authserv [[name=]IDServeur]

Paramètres

[name=]IDServeur
Spécifie le nom DNS ou l'adresse IP du serveur RADIUS à propos duquel vous souhaitez afficher des informations.

set acco

Spécifie le fournisseur de comptes.

Syntaxe

set acco provider {windows | radius | none}

Paramètres

provider {windows | radius | none}
Requis. Spécifie si la gestion de comptes doit être effectuée et par quel serveur. Le paramètre windows spécifie que la sécurité Windows doit effectuer la gestion de comptes. Le paramètre radius spécifie qu'un serveur RADIUS doit effectuer la gestion de comptes. Le paramètre none spécifie qu'il ne faut pas effectuer de gestion de comptes.

show acco

Affiche le fournisseur de comptes.

Syntaxe

show acco

Paramètres

aucun

set authe

Spécifie le fournisseur d'authentification.

Syntaxe

set authe provider {windows | radius}

Paramètres

provider {windows | radius}
Requis. Spécifie quelle technologie doit effectuer l'authentification. Le paramètre windows spécifie que la sécurité Windows doit effectuer l'authentification. Le paramètre radius spécifie qu'un serveur RADIUS doit effectuer l'authentification.

show authe

Affiche le fournisseur d'authentification.

Syntaxe

show authe

Paramètres

aucun


Commandes Netsh pour le routage

Vous pouvez utiliser les commandes Netsh pour le routage pour administrer le routage de serveurs à partir de la ligne de commande, plutôt que par le biais de la console de routage et d'accès distant. L'administration de serveurs à partir de la ligne de commande présente les avantages suivants :

  • Ce type d'administration est plus rapide qu'en cas d'utilisation d'une console. Cette caractéristique est particulièrement importante si vous utilisez une liaison réseau à faible vitesse, par exemple une connexion sur un réseau étendu (WAN, Wide Area Network).
  • Ce type d'administration vous permet également de gérer le routage des serveurs de manière plus cohérente, en intégrant ces commandes dans un script que vous pouvez exécuter sur de nombreux serveurs.

Vous pouvez utiliser les commandes suivantes à l'invite de commandes du contexte Netsh approprié (distinct de l'invite de commandes Windows XP) afin d'administrer le routage des serveurs. Pour exécuter ces commandes Netsh sur un ordinateur distant fonctionnant sous Windows 2000 Server, vous devez tout d'abord utiliser Connexion au Bureau à distance pour vous connecter à un ordinateur fonctionnant sous Windows 2000 Server qui exécute Terminal Server. Des différences fonctionnelles peuvent apparaître entre les commandes du contexte Netsh sur Windows 2000 et Windows XP.

Pour plus d'informations sur Netsh, consultez Utilisation de Netsh.

Commandes Netsh de routage IP IGMP

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP IGMP.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

add interface

Configure IGMP sur l'interface spécifiée.

Syntaxe

add interface [InterfaceName=]NomInterface [[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}] [[IfEnabled=]{enable | disable}] [[RobustVar=]Entier] [[GenQueryInterval=]Entier] [[GenQueryRespTime=]Entier] [[StartUpQueryCount=]Entier] [[StartUpQueryInterval=]Entier] [[LastMemQueryCount=]Entier] [[LastMemQueryInterval=Entier] [[AccNonRtrAlertPkts=]{yes | no}]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous souhaitez configurer IGMP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}
Indique le type de protocole à configurer sur l'interface. Le type par défaut est igmprtrv2.
[IfEnabled=]{enable | disable}
Spécifie si le protocole que vous configurez doit être activé ou désactivé. Le protocole est activé par défaut.
[RobustVar=]=Entier
Spécifie la variable de robustesse. La valeur doit être supérieure à zéro (0). La valeur par défaut est 2.
[GenQueryInterval=]Entier
Spécifie l'intervalle, en secondes, auquel les requêtes générales doivent être envoyées sur l'interface. La valeur par défaut est 125 secondes.
[GenQueryRespTime=]Entier
Spécifie le délai de réponse maximal (exprimé en secondes) au terme duquel les hôtes doivent avoir répondu à une requête générale. La valeur par défaut est 10 secondes.
[StartUpQueryCount=]Entier
Spécifie le nombre de requêtes générales qui seront envoyées lors du démarrage. La valeur par défaut est 2.
[StartUpQueryInterval=]Entier
Spécifie l'intervalle, en secondes, entre les requêtes générales envoyées lors du démarrage. La valeur par défaut est 31 secondes.
[LastMemQueryCount=]Entier
Spécifie le nombre de requêtes propres au groupe envoyées à la réception d'une notification de départ d'un hôte du groupe. La valeur par défaut est 2.
[LastMemQueryInterval=]Entier
Spécifie l'intervalle, en millisecondes, entre les requêtes propres au groupe. La valeur par défaut est 1000 ms.
[AccNonRtrAlertPkts=]{yes | no}
Spécifie s'il faut accepter les paquets IGMP dont l'option d'alerte du routeur n'est pas définie. La valeur par défaut est yes.

Exemples

Pour modifier l'intervalle de requête au démarrage par défaut à la valeur de 21 secondes, en vue d'une utilisation avec la configuration IGMP de l'interface nommée Connexion au réseau local, tapez :

add interface "Connexion au réseau local" startupqueryinterval=21

install

Installe un routeur/proxy IGMP et définit l'enregistrement global. Utilisée sans paramètres, la commande install installe le routeur/proxy IGMP et spécifie l'enregistrement des erreurs relatives à IGMP mais pas celui des autres événements IGMP.

Syntaxe

install [[LogLevel=]{none | error | warn | info}]

Paramètres

[LogLevel=]{none | error | warn | info}
Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à IGMP. Le paramètre error indique que seules les erreurs relatives à IGMP doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à IGMP doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à IGMP doivent être enregistrés.

delete interface

Supprime un routeur ou un proxy IGMP de l'interface spécifiée.

Syntaxe

delete interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface de laquelle vous souhaitez supprimer un routeur ou un proxy IGMP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

Exemples

delete interface "Connexion au réseau local"

uninstall

Supprime le routeur/proxy IGMP de toutes les interfaces.

Syntaxe

uninstall

Paramètres

aucun

set interface

Modifie les paramètres de configuration d'interface.

Syntaxe

set interface [InterfaceName=]NomInterface [[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}] [[IfEnabled=]{enable | disable}] [[RobustVar=]Entier] [[GenQueryInterval=]Entier] [[GenQueryRespTime=]Entier] [[StartUpQueryCount=]Entier] [[StartUpQueryInterval=]Entier] [[LastMemQueryCount=]Entier] [[LastMemQueryInterval=]Entier] [[AccNonRtrAlertPkts=]{yes | no}]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous souhaitez configurer IGMP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}
Indique le type de protocole à configurer sur l'interface. Le type par défaut est igmprtrv2.
[IfEnabled=]{enable | disable}
Spécifie si le protocole que vous configurez doit être activé ou désactivé. Le protocole est activé par défaut.
[RobustVar=]Entier
Spécifie la variable de robustesse. La valeur doit être supérieure à zéro (0). La valeur par défaut est 2.
[GenQueryInterval=]Entier
Spécifie l'intervalle, en secondes, auquel les requêtes générales doivent être envoyées sur l'interface. La valeur par défaut est 125 secondes.
[GenQueryRespTime=]Entier
Spécifie le délai de réponse maximal (exprimé en secondes) au terme duquel les hôtes doivent avoir répondu à une requête générale. La valeur par défaut est 10 secondes.
[StartUpQueryCount=]Entier
Spécifie le nombre de requêtes générales qui seront envoyées lors du démarrage. La valeur par défaut est 2.
[StartUpQueryInterval=]Entier
Spécifie l'intervalle, en secondes, entre les requêtes générales envoyées lors du démarrage. La valeur par défaut est 31 secondes.
[LastMemQueryCount=]Entier
Spécifie le nombre de requêtes propres au groupe envoyées à la réception d'une notification de départ d'un hôte du groupe. La valeur par défaut est 2.
[LastMemQueryInterval=]Entier
Spécifie l'intervalle, en millisecondes, entre les requêtes propres au groupe. La valeur par défaut est 1.000 ms.
[AccNonRtrAlertPkts=]{yes | no}
Spécifie s'il faut accepter les paquets IGMP dont l'option d'alerte du routeur n'est pas définie. L'option par défaut est d'accepter ces paquets.

Exemples

Pour modifier l'intervalle de requête au démarrage par défaut à la valeur de 21 secondes, en vue d'une utilisation avec la configuration IGMP d'une interface nommée Connexion au réseau local, tapez :

set interface "Connexion au réseau local" startupqueryinterval=21

set global

Définit les paramètres IGMP globaux. Utilisée sans paramètres, la commande set global spécifie que les avertissements sont enregistrés, contrairement à tous les autres événements relatifs à IGMP.

Syntaxe

set global [LogLevel=]{none | error | warn | info}

Paramètres

[LogLevel=]{none | error | warn | info}
Requis. Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à IGMP. Le paramètre error indique que seules les erreurs relatives à IGMP doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à IGMP doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à IGMP doivent être enregistrés.

show interface

Affiche la configuration IGMP de l'interface spécifiée. Utilisée sans paramètres, la commande show interface affiche les informations de configuration IGMP de toutes les interfaces.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

show global

Affiche les paramètres IGMP globaux.

Syntaxe

show global

Paramètres

aucun

show ifstats

Affiche les statistiques IGMP de l'interface spécifiée. Utilisée sans paramètres, la commande show ifstats affiche une seule fois les statistiques IGMP de toutes les interfaces.

Syntaxe

show ifstats [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Spécifie un nombre identifiant l'interface à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Exemples

Pour afficher les statistiques IGMP toutes les 5 secondes d'une interface de valeur d'index égale à 1001, tapez :

show ifstats index=1001 rr=5

show iftable

Affiche les groupes d'hôtes IGMP d'une interface spécifiée. Utilisée sans paramètres, la commande show iftable affiche une seule fois les groupes d'hôtes IGMP de toutes les interfaces.

Syntaxe

show iftable [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Indique le numéro d'index de l'interface à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Exemples

Pour afficher les groupes d'hôtes IGMP toutes les 5 secondes d'une interface de valeur d'index égale à 1001, tapez :

show iftable index=1001 rr=5

show grouptable

Affiche la table de groupe d'hôtes IGMP pour un groupe de multidiffusion. Utilisée sans paramètres, la commande show grouptable affiche une seule fois les tables de groupe d'hôtes IGMP pour tous les groupes de multidiffusion sur toutes les interfaces associées au routeur.

Syntaxe

show grouptable [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Indique l'adresse IP du groupe de multidiffusion à propos duquel vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Exemples

Pour afficher la table de groupe d'hôtes IGMP toutes les 5 secondes pour un groupe de multidiffusion IGMP identifié par l'adresse IP 192.168.100.239, tapez :

show grouptable index=192.168.100.239 rr=5

show rasgrouptable

Affiche la table de groupe d'hôtes pour une interface client d'accès distant. Utilisée sans paramètres, la commande show rasgrouptable affiche une seule fois les tables de groupe d'hôtes pour toutes les interfaces client d'accès distant.

Syntaxe

show rasgrouptable [[Index=]AdresseIP] [[Rr=]Entier]

Paramètres

[Index=]AdresseIP
Indique l'adresse IP de l'interface client d'accès distant à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Exemples

Pour afficher la table de groupe d'hôtes pour une interface client d'accès distant d'adresse IP 10.10.1.100 et actualiser les informations toutes les cinq secondes, tapez :

show rasgrouptable index=10.10.1.100 rr=5

show proxygrouptable

Affiche la table de groupe d'hôtes IGMP pour une interface proxy IGMP. Utilisée sans paramètres, la commande show proxygrouptable affiche une seule fois les informations pour toutes les interfaces.

Syntaxe

show proxygrouptable [[InterfaceName=]NomInterface] [[Rr=]Entier]

Paramètres

[InterfaceName=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Exemples

Pour afficher les tables de groupes d'hôtes IGMP pour toutes les interfaces proxy IGMP et actualiser les informations toutes les cinq secondes, tapez :

show proxygrouptable rr=5

Commandes Netsh de routage IP Découverte de routeurs

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP Découverte de routeurs

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

add interface

Configure la découverte de routeurs pour l'interface spécifiée.

Syntaxe

add interface [InterfaceName=]NomInterface [[Disc=]{enable | disable}] [[MinInt=]Entier] [[MaxInt=]Entier] [[Life=]Entier] [[Level=]Entier]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez configurer la découverte de routeurs. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Disc=]{enable | disable}
Spécifie si la découverte de routeurs doit avoir lieu sur cette interface. Le paramètre enable indique que la découverte de routeurs doit avoir lieu, tandis que le paramètre disable désactive la découverte de routeurs sur cette interface.
[MinInt=]Entier
Spécifie un intervalle minimal, en minutes, entre l'envoi de paquets de découverte de routeurs.
[MaxInt=]Entier
Spécifie un intervalle maximal, en minutes, entre l'envoi de paquets de découverte de routeurs.
[Life=]Entier
Spécifie le délai de validité, en minutes, d'un paquet de découverte de routeurs envoyé par ce routeur ou serveur.
[Level=]Entier
Spécifie un nombre indiquant le niveau de préférence d'utilisation de cette interface comme passerelle par défaut. Si plusieurs interfaces sont activées pour la découverte de routeurs, un nombre élevé indique un niveau de préférence supérieur.

Remarques

  • Une fois ajoutées, les annonces de découverte de routeurs sont envoyées à des moments aléatoires, délimités par les intervalles minimal et maximal définis.

Exemples

Pour activer la découverte de routeurs pour l'interface Connexion au réseau local, avec un intervalle minimal de 7 minutes, un intervalle maximal de 10 minutes, une durée de vie de 30 minutes pour les paquets de découverte de routeurs et une valeur égale à zéro (0) pour le niveau de préférence, tapez :

add interface "Connexion au réseau local" enable 7 10 30 0

set interface

Configure la découverte de routeurs pour une interface.

Syntaxe

set interface [InterfaceName=]NomInterface [[Disc=]{enable | disable}] [[MinInt=]Entier] [[MaxInt=]Entier] [[Life=]Entier] [[Level=]Entier]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez configurer la découverte de routeurs. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Disc=]{enable | disable}
Spécifie si la découverte de routeurs doit avoir lieu sur cette interface. Le paramètre enable indique que la découverte de routeurs doit avoir lieu, tandis que le paramètre disable désactive la découverte de routeurs sur cette interface.
[MinInt=]Entier
Spécifie un intervalle minimal, en minutes, entre l'envoi de paquets de découverte de routeurs.
[MaxInt=]Entier
Spécifie un intervalle maximal, en minutes, entre l'envoi de paquets de découverte de routeurs.
[Life=]Entier
Spécifie le délai de validité, en minutes, d'un paquet de découverte de routeurs envoyé par ce routeur ou serveur.
[Level=]Entier
Spécifie un nombre indiquant le niveau de préférence d'utilisation de cette interface comme passerelle par défaut. Un nombre élevé indique un niveau de préférence supérieur.

Exemples

Pour activer la découverte de routeurs pour l'interface Connexion au réseau local, avec un intervalle minimal de 7 minutes, un intervalle maximal de 10 minutes, une durée de vie de 30 minutes pour les paquets de découverte de routeurs et une valeur égale à zéro (0) pour le niveau de préférence, tapez :

set interface "Connexion au réseau local" enable 7 10 30 0

delete interface

Supprime la configuration de découverte de routeurs.

Syntaxe

delete interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez supprimer la configuration de découverte de routeurs. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

Exemples

Pour supprimer la configuration de découverte de routeurs pour une interface nommée Connexion au réseau local, tapez :

delete interface name="Connexion au réseau local"

show interface

Affiche les informations de découverte de routeurs. Utilisée sans paramètres, la commande show interface affiche des informations pour toutes les interfaces.

Syntaxe

show interface [[InterfaceName=]NomInterface]

Paramètres

[InterfaceName=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

Exemples

Pour afficher les informations de découverte de routeurs pour une interface nommée Connexion au réseau local, tapez :

show interface "Connexion au réseau local"

Commandes Netsh de routage IP RIP

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP RIP.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

add peerfilter

Ajoute un filtre pour les serveurs qui peuvent être acceptés comme des homologues.

Syntaxe

add peerfilter [Server=]AdresseIP

Paramètres

[Server=]AdresseIP
Requis. Spécifie l'adresse IP du serveur homologue dont vous voulez filtrer le trafic.

add acceptfilter

Ajoute un filtre d'acceptation pour les itinéraires reçus sur une interface.

Syntaxe

add acceptfilter [InterfaceName=]NomInterface [Addr=]AdresseIP1 AdresseIP2

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom d'une interface sur laquelle RIP est disponible. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Addr=]AdresseIP1 AdresseIP2
Requis. Spécifie une paire d'adresses IP. La première adresse correspond à l'adresse IP basse et la seconde à l'adresse IP haute, elles sont utilisées pour construire le filtre.

Exemples

Pour ajouter un filtre d'acceptation pour une interface nommée Connexion au réseau local et une plage d'adresses IP allant de 10.0.0.2 à 10.11.21.154, tapez :

add acceptfilter "Connexion au réseau local" 10.0.0.2 10.11.21.154

add announcefilter

Ajoute un filtre pour les itinéraires annoncés sur une interface.

Syntaxe

add announcefilter [InterfaceName=]NomInterface [Addr=]AdresseIP1 AdresseIP2

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom d'une interface sur laquelle RIP est disponible. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Addr=]AdresseIP1 AdresseIP2
Requis. Spécifie une paire d'adresses IP. La première adresse correspond à l'adresse IP basse et la seconde à l'adresse IP haute, elles sont utilisées pour construire le filtre.

Exemples

Pour ajouter un filtre pour les itinéraires annoncés sur une interface nommée Connexion au réseau local et une plage d'adresses IP allant de 10.0.0.2 à 10.11.21.154, tapez :

add announcefilter Connexion au réseau local 10.0.0.2 10.11.21.154

add neighbor

Ajoute un voisin RIP sur une interface.

Syntaxe

add neighbor [InterfaceName=]NomInterface [addr=]AdresseIP

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom d'une interface sur laquelle RIP est disponible. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseIP
Requis. Spécifie l'adresse IP du voisin RIP que vous voulez ajouter.

Exemples

Pour ajouter un voisin RIP situé à l'adresse IP 10.0.0.2 pour une interface nommée Connexion au réseau local, tapez :

add neighbor "Connexion au réseau local" 10.0.0.2

add interface

Ajoute RIP à une interface spécifiée.

Syntaxe

add interface [InterfaceName=]NomInterface [[Metric=]Entier] [[UpdateMode=]{demand | periodic}] [[Announce=]{none | rip1 | rip1compat | rip2}] [[Accept=]{none | rip1 | rip1compat | rip2}] [[Expire=]Entier] [[Remove=]Entier] [[Update=]Entier] [[AuthMode=]{authnone | authsimplepassword}] [[Tag=]Entier] [[Unicast=]{also | only | disable}] [[AccFiltMode=]{include | exclude | disable}] [[AnnFiltMode=]{include | exclude | disable}] [[Password=]Chaîne]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à laquelle vous souhaitez ajouter RIP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Metric=]Entier
Spécifie une valeur métrique pour les itinéraires basés sur cette interface.
[UpdateMode=]{demand | periodic}
Spécifie à quel moment les mises à jour doivent avoir lieu. Le paramètre demand indique que les mises à jour doivent être effectuées sur demande. Le paramètre periodic indique que les mises à jour doivent être effectuées à des intervalles réguliers.
[Announce=]{none | rip1 | rip1compat | rip2}
Spécifie quels itinéraires doivent être annoncés. Le paramètre none indique que tous les itinéraires doivent être annoncés. Le paramètre rip1 indique que seuls les itinéraires RIP version 1 doivent être annoncés. Le paramètre rip1compat indique que les annonces doivent être effectuées en utilisant le mode compatible des versions RIP. Le paramètre rip2 indique que seuls les itinéraires RIP version 2 doivent être annoncés.
[Accept=]{none | rip1 | rip1compat | rip2}
Spécifie quels itinéraires doivent être acceptés. Le paramètre none indique que tous les itinéraires doivent être acceptés. Le paramètre rip1 indique que seuls les itinéraires RIP version 1 doivent être acceptés. Le paramètre rip1compat indique que les itinéraires doivent être acceptés en utilisant le mode compatible des versions RIP. Le paramètre rip2 indique que seuls les itinéraires RIP version 2 doivent être acceptés.
[Expire=]Entier
Indique la valeur de l'intervalle d'expiration d'itinéraire, en secondes.
[Remove=]Entier
Indique la valeur de l'intervalle de suppression d'itinéraire, en secondes.
[Update=]Entier
Indique la valeur de l'intervalle de mise à jour complète, en secondes.
[AuthMode=]{authnone | authsimplepassword}
Spécifie si l'autorisation doit être requise. Le paramètre authnone indique qu'aucune autorisation n'est requise. Le paramètre authsimplepassword indique que l'autorisation par mot de passe doit être requise.
[Tag=]Entier
Spécifie l'indicateur d'itinéraire.
[Unicast=]{also | only | disable}
Spécifie l'utilisation du mode monodiffusion. Le paramètre also indique que le mode monodiffusion est également utilisé. Le paramètre only indique que seul le mode monodiffusion est utilisé. Le paramètre disable indique que le mode monodiffusion doit être désactivé.
[AccFiltMode=]{include | exclude | disable}
Spécifie si les filtres d'acceptation doivent être inclus, exclus ou désactivés. Le paramètre include indique que les filtres d'acceptation doivent être inclus. Le paramètre exclude indique que les filtres d'acceptation doivent être exclus. Le paramètre disable indique que les filtres d'acceptation doivent être désactivés.
[AnnFiltMode=]{include | exclude | disable}
Spécifie si les filtres d'annonce doivent être inclus, exclus ou désactivés. Le paramètre include indique que les filtres d'annonce doivent être inclus. Le paramètre exclude indique que les filtres d'annonce doivent être exclus. Le paramètre disable indique que les filtres d'annonce doivent être désactivés.
[Password=]Chaîne
Spécifie un mot de passe en texte brut de 16 caractères maximum.

add helper

Installe une DLL d'application d'assistance sous RIP.

Syntaxe

add helper NomDLL

Paramètres

NomDLL
Requis. Spécifie une DLL qui prend en charge ce contexte.

delete peerfilter

Supprime un filtre pour un serveur homologue accepté.

Syntaxe

delete peerfilter [Server=]AdresseIP

Paramètres

[Server=]AdresseIP
Requis. Spécifie l'adresse IP du serveur homologue dont vous ne voulez pas filtrer le trafic.

delete acceptfilter

Supprime un filtre d'acceptation pour les itinéraires reçus sur une interface spécifiée.

Syntaxe

delete acceptfilter [InterfaceName=]NomInterface [Addr=]AdresseIP1 AdresseIP2

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom d'une interface sur laquelle RIP est disponible. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Addr=]AdresseIP1 AdresseIP2
Requis. Spécifie une paire d'adresses IP. La première adresse correspond à l'adresse IP basse et la seconde à l'adresse IP haute, elles sont utilisées pour construire le filtre.

Exemples

Pour supprimer un filtre d'acceptation pour une interface nommée Connexion au réseau local et une plage d'adresses IP allant de 10.0.0.2 à 10.11.21.154, tapez :

delete acceptfilter "Connexion au réseau local" 10.0.0.2 10.11.21.154

delete announcefilter

Supprime un filtre d'annonce défini pour une interface.

Syntaxe

delete announcefilter [InterfaceName=]NomInterface [Addr=]AdresseIP1 AdresseIP2

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom d'une interface sur laquelle RIP est disponible. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Addr=]AdresseIP1 AdresseIP2
Requis. Spécifie une paire d'adresses IP. La première adresse correspond à l'adresse IP basse et la seconde à l'adresse IP haute, elles sont utilisées pour construire le filtre.

Exemples

Pour supprimer un filtre d'annonce pour une interface nommée Connexion au réseau local et une plage d'adresses IP allant de 10.0.0.2 à 10.11.21.154, tapez :

delete announcefilter "Connexion au réseau local" 10.0.0.2 10.11.21.154

delete neighbor

Supprime un voisin RIP d'une interface.

Syntaxe

delete neighbor [InterfaceName=]NomInterface AdresseIP

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom d'une interface sur laquelle RIP est disponible. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
AdresseIP
Requis. Spécifie l'adresse IP du voisin RIP à supprimer.

Exemples

Pour supprimer un voisin RIP situé à l'adresse IP 10.0.0.2 pour une interface nommée Connexion au réseau local, tapez :

delete neighbor "Connexion au réseau local" 10.0.0.2

delete interface

Supprime RIP de l'interface spécifiée.

Syntaxe

delete interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface de laquelle vous souhaitez supprimer RIP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

delete helper

Supprime une DLL d'application d'assistance spécifiée de Netsh.

Syntaxe

delete helper NomApplicationAssistance

Paramètres

NomApplicationAssistance
Requis. Spécifie le nom de fichier de la DLL d'application d'assistance à supprimer.

set interface

Configure RIP sur une interface spécifiée.

Syntaxe

set interface [InterfaceName=]NomInterface [[Metric=]Entier] [[UpdateMode=]{demand | periodic}] [[Announce=]{none | rip1 | rip1compat | rip2}] [[Accept=]{none | rip1 | rip1compat | rip2}] [[Expire=]Entier] [[Remove=]Entier] [[Update=]Entier] [[AuthMode=]{authnone | authsimplepassword}] [[Tag=]Entier] [[Unicast=]{also | only | disable}] [[AccFiltMode=]{include | exclude | disable}] [[AnnFiltMode=]{include | exclude | disable}] [[Password=]Chaîne]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous souhaitez configurer RIP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[Metric=]Entier
Spécifie une valeur métrique pour les itinéraires basés sur cette interface.
[UpdateMode=]{demand | periodic}
Spécifie à quel moment les mises à jour doivent avoir lieu. Le paramètre demand indique que les mises à jour doivent être effectuées sur demande. Le paramètre periodic indique que les mises à jour doivent être effectuées à des intervalles réguliers.
[Announce=]{none | rip1 | rip1compat | rip2}
Spécifie quels itinéraires doivent être annoncés. Le paramètre none indique que tous les itinéraires doivent être annoncés. Le paramètre rip1 indique que seuls les itinéraires RIP version 1 doivent être annoncés. Le paramètre rip1compat indique que les annonces doivent être effectuées en utilisant le mode compatible des versions RIP. Le paramètre rip2 indique que seuls les itinéraires RIP version 2 doivent être annoncés.
[Accept=]{none | rip1 | rip1compat | rip2}
Spécifie quels itinéraires doivent être acceptés. Le paramètre none indique que tous les itinéraires doivent être acceptés. Le paramètre rip1 indique que seuls les itinéraires RIP version 1 doivent être acceptés. Le paramètre rip1compat indique que les itinéraires doivent être acceptés en utilisant le mode compatible des versions RIP. Le paramètre rip2 indique que seuls les itinéraires RIP version 2 doivent être acceptés.
[Expire=]Entier
Indique la valeur de l'intervalle d'expiration d'itinéraire, en secondes.
[Remove=]Entier
Indique la valeur de l'intervalle de suppression d'itinéraire, en secondes.
[Update=]Entier
Indique la valeur de l'intervalle de mise à jour complète, en secondes.
[AuthMode=]{authnone | authsimplepassword}
Spécifie si l'autorisation doit être requise. Le paramètre authnone indique qu'aucune autorisation n'est requise. Le paramètre authsimplepassword indique que l'autorisation par mot de passe doit être requise.
[Tag=]Entier
Spécifie l'indicateur d'itinéraire.
[Unicast=]{also | only | disable}
Spécifie l'utilisation du mode monodiffusion. Le paramètre also indique que le mode monodiffusion est également utilisé. Le paramètre only indique que seul le mode monodiffusion est utilisé. Le paramètre disable indique que le mode monodiffusion doit être désactivé.
[AccFiltMode=]{include | exclude | disable}
Spécifie si les filtres d'acceptation doivent être inclus, exclus ou désactivés. Le paramètre include indique que les filtres d'acceptation doivent être inclus. Le paramètre exclude indique que les filtres d'acceptation doivent être exclus. Le paramètre disable indique que les filtres d'acceptation doivent être désactivés.
[AnnFiltMode=]{include | exclude | disable}
Spécifie si les filtres d'annonce doivent être inclus, exclus ou désactivés. Le paramètre include indique que les filtres d'annonce doivent être inclus. Le paramètre exclude indique que les filtres d'annonce doivent être exclus. Le paramètre disable indique que les filtres d'annonce doivent être désactivés.
[Password=]Chaîne
Spécifie un mot de passe en texte brut de 16 caractères maximum.

Exemples

Pour modifier la configuration RIP sur l'interface nommée Connexion au réseau local, en spécifiant une valeur métrique égale à 2 et l'exécution des mises à jour sur demande, tapez :

set interface "Connexion au réseau local" metric=2 updatemode=periodic

set flags

Définit les indicateurs RIP pour une interface spécifiée.

Syntaxe

set flags [InterfaceName=]NomInterface [clear,][splithorizon,][poisonreverse,][triggeredupdates,][cleanupupdates][accepthostroutes,][acceptdefaultroutes,][senddefaultroutes,][nosubnetsummary]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous souhaitez définir les indicateurs. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[clear,][splithorizon,][poisonreverse,][triggeredupdates,][cleanupupdates,][accepthostroutes,][acceptdefaultroutes,][senddefaultroutes,][nosubnetsummary]
Spécifie les stratégies utilisées pour les indicateurs RIP. Le paramètre clear indique qu'il faut effacer tous les indicateurs RIP définis. Le paramètre splithorizon indique qu'il faut activer RIP pour le découpage d'horizon. Le paramètre poisonreverse indique qu'il faut activer RIP pour l'anti-poison. Le paramètre triggeredupdates indique que les mises à jour déclenchées pour RIP doivent avoir lieu. Le paramètre cleanupupdates indique que les mises à jour de nettoyage pour RIP doivent avoir lieu. Le paramètre accepthostroutes indique qu'il faut accepter les itinéraires d'hôtes. Le paramètre acceptdefaultroutes indique qu'il faut accepter les itinéraires par défaut. Le paramètre senddefaultroutes indique qu'il faut envoyer les itinéraires par défaut. Le paramètre nosubnetsummary indique qu'il faut désactiver le résumé de sous-réseau.

Remarques

  • Il ne faut pas placer de virgule après le dernier paramètre de stratégie.

set global

Définit les paramètres RIP globaux.

Syntaxe

set global {[[loglevel=]{none | error | warn | info}] | [[mintrig=]Entier] | [[peermode=]{include | exclude | disable}]}

Paramètres

[loglevel=]{none | error | warn | info}
Spécifie quels événements RIP doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement RIP. Le paramètre error indique que seules les erreurs relatives à RIP doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à RIP doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à RIP doivent être enregistrés.
[mintrig=]Entier
Indique le délai minimal, en minutes, qui doit s'écouler entre les déclencheurs.
[peermode=]{include | exclude | disable}
Spécifie si les homologues doivent être inclus et si le mode homologue doit être désactivé. Le paramètre include indique que les homologues doivent être inclus. Le paramètre exclude indique que les homologues doivent être exclus. Le paramètre disable indique que le mode homologue doit être désactivé.

show interface

Affiche la configuration RIP de l'interface spécifiée. Utilisée sans paramètres, la commande show interface affiche les informations de configuration de toutes les interfaces.

Syntaxe

show interface [[InterfaceName=]NomInterface]

Paramètres

[InterfaceName=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

show flags

Affiche les indicateurs RIP définis pour une interface spécifiée. Utilisée sans paramètres, la commande show flags affiche des informations pour toutes les interfaces.

Syntaxe

show flags [[InterfaceName=]NomInterface]

Paramètres

[InterfaceName=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

show global

Affiche les paramètres RIP globaux.

Syntaxe

show global

Paramètres

aucun

show ifstats

Affiche les statistiques RIP pour une interface spécifiée. Utilisée sans paramètres, la commande show ifstats affiche une seule fois des informations pour toutes les interfaces.

Syntaxe

show ifstats [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Indique le numéro d'index de l'interface à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Remarques

  • Pour afficher la liste des valeurs d'index de chaque interface, utilisez la commande show interface dans le contexte Netsh d'interface IP.

Exemples

Pour afficher les statistiques RIP toutes les 5 secondes d'une interface de valeur d'index égale à 1, tapez :

show ifstats index=1 rr=5

show ifbinding

Affiche les liens d'adresse IP pour les interfaces RIP. Utilisée sans paramètres, la commande show ifbinding affiche une seule fois les informations pour toutes les interfaces.

Syntaxe

show ifbinding [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Indique le numéro d'index de l'interface à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Remarques

  • Pour afficher la liste des valeurs d'index de chaque interface, utilisez la commande show interface dans le contexte Netsh d'interface IP.

Exemples

Pour afficher les liens toutes les 5 secondes pour une interface de valeur d'index égale à 1, tapez :

show ifbinding index=1 rr=5

Commandes Netsh de routage IP de relais

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP de relais.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

add dhcpserver

Ajoute un serveur DHCP à la liste des serveurs DHCP dont les messages seront transférés par l'agent relais DHCP.

Syntaxe

add dhcpserver AdresseIP

Paramètres

AdresseIP
Requis. Spécifie l'adresse IP du serveur DHCP que vous voulez ajouter.

add interface

Active l'agent relais DHCP sur l'interface spécifiée.

Syntaxe

add interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous voulez activer l'agent relais DHCP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

delete interface

Désactive l'agent relais DHCP sur l'interface spécifiée.

Syntaxe

delete interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous voulez désactiver l'agent relais DHCP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

delete dhcpserver

Supprime un serveur DHCP de la liste des serveurs DHCP dont les messages seront transférés par l'agent relais DHCP.

Syntaxe

delete dhcpserver AdresseIP

Paramètres

AdresseIP
Requis. Spécifie l'adresse IP du serveur DHCP à supprimer.

set global

Définit les paramètres globaux d'enregistrement pour la configuration de l'agent relais DHCP.

Syntaxe

set global [LogLevel=]{none | error | warn | info}

Paramètres

[LogLevel=]{none | error | warn | info}
Requis. Spécifie quels événements de l'agent relais DHCP doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à l'agent relais DHCP. Le paramètre error indique que seules les erreurs relatives à l'agent relais DHCP doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à l'agent relais DHCP doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à l'agent relais DHCP doivent être enregistrés.

set interface

Met à jour la configuration de l'agent relais DHCP sur chaque interface.

Syntaxe

set interface [InterfaceName=]NomInterface [relaymode=]{enable | disable} [[maxhop=]Entier] [[minsecs=]Entier]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous voulez mettre à jour la configuration de l'agent relais DHCP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[relaymode=]{enable | disable}
Requis. Spécifie si l'agent relais DHCP est activé ou désactivé. Le paramètre enable indique que l'agent relais DHCP doit être activé pour cette interface. Le paramètre disable désactive l'agent relais DHCP pour cette interface.
[maxhop=]Entier
Spécifie le nombre de sauts qu'un paquet DHCP peut effectuer avant de devoir être supprimé et ne plus pouvoir être relayé.
[minsecs=]Entier
Spécifie le délai minimal, en secondes, depuis l'amorçage qui doit apparaître dans un paquet DHCP avant de devoir être envoyé à un serveur DHCP contenu dans la liste des serveurs dont les messages seront transférés par l'agent relais DHCP.

Exemples

Pour mettre à jour la configuration de l'agent relais DHCP sur l'interface nommée Connexion au réseau local avec un nombre maximal de sauts égal à 16 et une valeur de 4 secondes pour le délai minimal depuis l'amorçage, tapez :

set interface "Connexion au réseau local" enable 16 4

show interface

Affiche les informations de configuration pour l'agent relais DHCP sur l'interface spécifiée.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

show global

Affiche la configuration globale de l'agent relais DHCP.

Syntaxe

show global [[Rr=]Entier]

Paramètres

[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

show ifconfig

Affiche les informations de configuration de l'agent relais DHCP pour l'interface spécifiée. Utilisée sans paramètres, la commande show ifconfig affiche une seule fois les informations pour toutes les interfaces où l'agent relais DHCP est activé.

Syntaxe

show ifconfig [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Indique la valeur d'index de l'interface à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

show ifbinding

Affiche les liens d'adresse IP pour l'interface spécifiée. Utilisée sans paramètres, la commande show ifbinding affiche une seule fois les informations pour toutes les interfaces où l'agent relais DHCP est activé.

Syntaxe

show ifbinding [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Indique la valeur d'index de l'interface à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

show ifstats

Affiche les statistiques de l'agent relais DHCP pour l'interface spécifiée. Utilisée sans paramètres, la commande show ifstats affiche une seule fois les informations pour toutes les interfaces où l'agent relais DHCP est activé.

Syntaxe

show ifstats [[Index=]Entier] [[Rr=]Entier]

Paramètres

[Index=]Entier
Indique la valeur d'index de l'interface à propos de laquelle vous souhaitez afficher des informations.
[Rr=]Entier
Spécifie, en secondes, la fréquence d'actualisation des informations.

Commandes Netsh de routage IP OSPF

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP OSPF.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

Remarque

  • Le protocole OSPF n'est pas disponible sur Windows XP Édition 64 bits.

add range

Ajoute la paire adresse IP / masque qui définit une plage d'adresses appartenant à cette zone.

Syntaxe

add range [Areaid=]AdresseIP [Range=]AdresseIP MasqueSousRéseau

Paramètres

[Areaid=]AdresseIP
Requis. Spécifie l'adresse IP de la zone à laquelle la plage est ajoutée.
[Range=]AdresseIP MasqueSousRéseau
Requis. Spécifie l'adresse IP et le masque de la plage à ajouter.

Remarques

  • Les plages OSPF sont utilisées pour résumer les itinéraires au sein de la zone OSPF.

add area

Ajoute un ID pour la zone.

Syntaxe

add area [Areaid=]AdresseIP

Paramètres

[Areaid=]AdresseIP
Requis. Spécifie l'adresse IP de la zone à laquelle vous voulez ajouter la plage.

Remarques

  • Le paramètre Areaid est un nombre 32 bits exprimé en notation décimale pointée, qui identifie la zone OSPF. L'ID de zone ne doit pas forcément correspondre à une adresse IP ou à un ID de réseau IP. L'ID de zone égal à 0.0.0.0 est réservé au segment principal du réseau. Si la zone représente un réseau mis en sous-réseau, vous pouvez utiliser le numéro de réseau IP du réseau mis en sous-réseau comme ID pour cette zone.

add virtif

Ajoute une interface virtuelle à un routeur.

Syntaxe

add virtif [transareaid=]IDZoneTransition [virtnbrid=]IDVoisinVirtuel

Paramètres

[transareaid=]IDZoneTransition
Requis. Spécifie l'adresse IP de la zone de transition utilisée pour l'échange des informations de routage entre le routeur de limite de zone du segment principal et le routeur de limite de zone de la zone non contiguë.
[virtnbrid=]IDVoisinVirtuel
Requis. Spécifie l'adresse IP de l'ID de routeur du voisin virtuel à ajouter.

add neighbor

Ajoute un voisin OSPF à l'interface spécifiée.

Syntaxe

add neighbor [InterfaceName=]NomInterface [addr=]AdresseIP [nbraddr=]AdresseIP [nbrprio=]Priorité

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom de l'interface à laquelle vous voulez ajouter un voisin. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseIP
Requis. Spécifie l'adresse IP de l'interface OSPF.
[nbraddr=]AdresseIP
Requis. Spécifie l'adresse IP du voisin que vous voulez ajouter.
[nbrprio=]Priorité
Requis. Spécifie la priorité de routeur OSPF du voisin que vous voulez ajouter.

add interface

Configure OSPF sur l'interface spécifiée.

Syntaxe

add interface [InterfaceName=]NomInterface [areaid=]AdresseIP [addr=]AdresseIP [mask=]MasqueSousRéseau

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom de l'interface sur laquelle vous voulez ajouter OSPF. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[areaid=]AdresseIP
Requis. Spécifie l'adresse IP de la zone à laquelle l'interface appartient.
[addr=]AdresseIP
Requis. Spécifie l'adresse IP de l'interface à ajouter.
[mask=]MasqueSousRéseau
Requis. Spécifie le masque de sous-réseau de l'interface à ajouter.

add routefilter

Ajoute un filtre d'itinéraire OSPF.

Syntaxe

add routefilter [Filter=]AdresseIP MasqueSousRéseau

Paramètres

[Filter=]AdresseIP MasqueSousRéseau
Requis. Spécifie l'adresse IP et le masque de sous-réseau de l'itinéraire que vous voulez filtrer.

add protofilter

Ajoute un filtre de protocole OSPF.

Syntaxe

add protofilter [filter=]{autostatic | local | rip | snmp | nondod | static}

Paramètres

[filter=]{autostatic | local | rip | snmp | nondod | static}
Requis. Spécifie le filtre de protocole que vous voulez ajouter. Le paramètre autostatic indique un itinéraire autostatique RIP. Le paramètre local indique un itinéraire ajouté par le réseau auquel l'ordinateur est connecté. Le paramètre rip indique que le filtre est ajouté à l'aide de RIP. Le paramètre snmp indique que l'itinéraire est ajouté à l'aide de SNMP. Le paramètre nondod indique un itinéraire RTM qui est présent uniquement lorsqu'une interface DOD est connectée. Le paramètre static indique un itinéraire RTM.

Remarques

  • La commande add protofilter est utilisée sur un routeur OSPF agissant en tant que routeur de limites de systèmes autonomes. Les filtres que vous ajoutez filtrent les autres sources d'itinéraires par source de protocole, comme les itinéraires statiques et RIP, de manière à ce que ces itinéraires ne soient pas redistribués dans le système autonome OSPF.

install

Installe OSPF.

Syntaxe

install

Paramètres

aucun

delete range

Supprime la plage spécifiée pour l'ID de zone.

Syntaxe

delete range [Areaid=]AdresseIP [Range=]AdresseIP MasqueSousRéseau

Paramètres

[Areaid=]AdresseIP
Requis. Spécifie l'adresse IP de la zone que vous voulez supprimer.
[Range=]AdresseIP MasqueSousRéseau
Requis. Spécifie l'adresse IP et le masque de sous-réseau de la zone que vous voulez supprimer.

delete area

Supprime la zone spécifiée.

Syntaxe

delete area [Areaid=]AdresseIP

Paramètres

[Areaid=]AdresseIP
Requis. Spécifie l'adresse IP de la zone que vous voulez supprimer.

Remarques

L'ID de zone est un nombre 32 bits exprimé en notation décimale pointée, qui identifie la zone OSPF. L'ID de zone ne doit pas forcément correspondre à une adresse IP ou à un ID de réseau IP. L'ID de zone égal à 0.0.0.0 est réservé au segment principal du réseau. Si la zone représente un réseau mis en sous-réseau, vous pouvez utiliser le numéro de réseau IP du réseau mis en sous-réseau comme ID pour cette zone.

delete virtif

Supprime l'interface virtuelle spécifiée.

Syntaxe

delete virtif [transareaid=]IDZoneTransition [virtnbrid=]IDVoisinVirtuel

Paramètres

[transareaid=]IDZoneTransition
Requis. Spécifie l'adresse IP de la zone de transition utilisée pour l'échange des informations de routage entre le routeur de limite de zone du segment principal et le routeur de limite de zone de la zone non contiguë.
[virtnbrid=]IDVoisinVirtuel
Requis. Spécifie l'ID de routeur du voisin virtuel à supprimer.

delete neighbor

Supprime le voisin OSPF spécifié.

Syntaxe

delete neighbor [InterfaceName=]NomInterface [addr=]AdresseIP [nbraddr=]AdresseIP [nbrprio=]Priorité

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom de l'interface de laquelle vous voulez supprimer un voisin. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseIP
Requis. Spécifie l'adresse IP de l'interface de laquelle vous voulez supprimer un voisin.
[nbraddr=]AdresseIP
Requis. Spécifie l'adresse IP du voisin à supprimer.
[nbrprio=]Priorité
Requis. Spécifie la priorité de routeur OSPF du voisin à supprimer.

delete interface

Supprime OSPF de l'interface spécifiée.

Syntaxe

delete interface [InterfaceName=]NomInterface [addr=]AdresseIP [mask=]MasqueSousRéseau

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom de l'interface de laquelle vous voulez supprimer OSPF. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseIP
Requis. Spécifie l'adresse IP de l'interface à supprimer.
[mask=]MasqueSousRéseau
Requis. Spécifie le masque de sous-réseau de l'interface à supprimer.

delete routefilter

Supprime le filtre d'itinéraire OSPF spécifié.

Syntaxe

delete routefilter [Filter=]AdresseIP MasqueSousRéseau

Paramètres

[Filter=]AdresseIP MasqueSousRéseau
Requis. Spécifie l'adresse IP et le masque de sous-réseau du filtre d'itinéraire que vous voulez supprimer.

delete protofilter

Supprime le filtre de protocole OSPF spécifié.

Syntaxe

delete protofilter [filter=]{autostatic | local | rip | snmp | nondod | static}

Paramètres

[filter=]{autostatic | local | rip | snmp | nondod | static}
Requis. Spécifie le filtre de protocole que vous voulez supprimer. Le paramètre autostatic indique un itinéraire autostatique RIP. Le paramètre local indique un itinéraire ajouté par le réseau auquel l'ordinateur est connecté. Le paramètre rip indique que le filtre est ajouté à l'aide de RIP. Le paramètre snmp indique que l'itinéraire est ajouté à l'aide de SNMP. Le paramètre nondod indique un itinéraire RTM qui est présent uniquement lorsqu'une interface DOD est connectée. Le paramètre static indique un itinéraire RTM.

Remarques

  • La commande delete protofilter est utilisée sur un routeur OSPF agissant en tant que routeur de limites de systèmes autonomes. Les filtres que vous ajoutez filtrent les autres sources d'itinéraires par source de protocole, comme les itinéraires statiques et RIP (Routing Information Protocol), de manière à ce que ces itinéraires ne soient pas redistribués dans le système autonome OSPF.

uninstall

Supprime OSPF.

Paramètres

aucun

set area

Modifie les paramètres de la zone spécifiée.

Syntaxe

set area [areaid=]IDZone [[auth=]{none | password}] [[stubarea=]{yes | no}] [[metric=]MétriqueStub] [[sumadv=]{yes | no}]

Paramètres

[areaid=]IDZone
Requis. Spécifie l'adresse IP de la zone OSPF dont vous voulez modifier les paramètres.
[auth=]{none | password}
Spécifie si la zone requiert des mots de passe. Si la zone requiert des mots de passe, toutes les interfaces qui se trouvent dans la même zone et sur le même segment de réseau doivent utiliser le même mot de passe, tandis que toutes les interfaces qui se trouvent dans la même zone mais sur des segments de réseau différents peuvent avoir des mots de passe différents. Par défaut, les mots de passe sont requis et le mot de passe est 12345678. Les mots de passe étant transmis en texte brut, cette option sert à l'identification et non à la sécurité.
[stubarea=]{yes | no}
Spécifie si cette zone est configurée comme une zone de stub, à savoir une zone OSPF qui n'énumère pas d'itinéraires externes. Les itinéraires provenant de l'extérieur du système autonome OSPF ne sont pas répartis dans ou via les zones de stub. Le routage vers les destinations externes au système autonome dans ces zones s'effectue uniquement sur la base d'un itinéraire résumé par défaut. Cela permet de réduire le temps système pour les routeurs dans la zone de stub.
[metric=]MétriqueStub
Spécifie le coût de l'itinéraire résumé par défaut annoncé par le routeur dans la zone de stub.
[sumadv=]{yes | no}
Spécifie s'il faut importer les annonces de résumé.

set virtif

Configure les paramètres de l'interface virtuelle spécifiée.

Syntaxe

set virtif [transareaid=]IDZoneTransition [virtnbrid=]IDVoisinVirtuel [[transdelay=]DélaiTransition] [[retrans=]IntervalleRetransmission] [[hello=]IntervalleSalutation] [[dead=]IntervalleInactivité] [[password=]MotDePasse]

Paramètres

[transareaid=]IDZoneTransition
Requis. Spécifie l'adresse IP de la zone de transition.
[virtnbrid=]IDVoisinVirtuel
Requis. Spécifie l'ID de routeur du voisin virtuel.
[transdelay=]DélaiTransition
Spécifie la durée estimée en secondes pour la transmission d'un paquet de mise à jour de l'état des liaisons sur cette interface. Si vous ne spécifiez aucune valeur pour ce paramètre, le délai estimé est de 1 seconde.
[retrans=]IntervalleRetransmission
Spécifie la durée en secondes entre les retransmissions des annonces de l'état des liaisons pour les éléments adjacents qui appartiennent à cette interface. Une valeur typique de ce paramètre pour un LAN est 5 secondes.
[hello=]IntervalleSalutation
Spécifie, en secondes, l'intervalle entre les transmissions des paquets de salutation par le routeur sur l'interface. La valeur de ce paramètre doit être identique pour tous les routeurs connectés à un même réseau. Une valeur typique de ce paramètre pour un LAN est 10 secondes.
[dead=]IntervalleInactivité
Spécifie, en secondes, le délai pendant lequel un routeur peut ne pas répondre avant qu'un routeur voisin considère ce routeur comme défaillant. Ce paramètre doit être un multiple entier de l'intervalle de salutation (en général 4). La valeur de ce paramètre doit être identique pour tous les routeurs OSPF connectés à un même segment de réseau.
[password=]MotDePasse
Spécifie le mot de passe pour cette interface, si des mots de passe sont requis pour la zone. Toutes les interfaces qui se trouvent dans la même zone et sur le même réseau doivent utiliser le même mot de passe. Par défaut, les mots de passe sont requis et le mot de passe est 12345678.

set interface

Configure les paramètres OSPF pour une interface.

Syntaxe

set interface [interfacename=]NomInterface [addr=]AdresseIP [mask=]MasqueSousRéseau [[state=]{enable | disable}] [[areaid=]IDZone] [[type=]{nbma | p2p | broadcast}] [[prio=]Priorité] [[transdelay=]DélaiTransition] [[retrans=]IntervalleRetransmission] [[hello=]IntervalleSalutation] [[dead=]IntervalleInactivité] [[poll=]IntervalleInterrogation] [[metric=]Métrique] [[password=]MotDePasse] [[mtu=]TailleMTU]

Paramètres

[interfacename=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez configurer les paramètres. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[addr=]AdresseIP
Requis. Spécifie l'adresse IP de l'interface.
[mask=]MasqueSousRéseau
Requis. Spécifie le masque de sous-réseau de l'interface.
[state=]{enable | disable}
Spécifie si l'interface est activée. Le paramètre enable active l'interface. Le paramètre disable désactive l'interface.
[areaid=]IDZone
Spécifie l'adresse IP de la zone d'interface.
[type=]{nbma | p2p | broadcast}
Spécifie le type d'interface OSPF pour lequel vous voulez configurer les paramètres. Le paramètre nbma désigne une interface OSPF de type NBMA (Non-Broadcast Multiple Access). Le paramètre p2p désigne une interface OSPF de type point à point. Le paramètre broadcast désigne une interface OSPF de type diffusion.
[prio=]Priorité
Spécifie la priorité d'interface.
[transdelay=]DélaiTransition
Spécifie la durée estimée en secondes pour la transmission d'un paquet de mise à jour de l'état des liaisons sur cette interface. Si vous ne spécifiez aucune valeur pour ce paramètre, le délai estimé est de 1 seconde.
[retrans=]IntervalleRetransmission
Spécifie la durée en secondes entre les retransmissions des annonces de l'état des liaisons pour les éléments adjacents qui appartiennent à cette interface. Une valeur typique de ce paramètre pour un LAN est 5 secondes.
[hello=]IntervalleSalutation
Spécifie, en secondes, l'intervalle entre les transmissions des paquets de salutation par le routeur sur l'interface. La valeur de ce paramètre doit être identique pour tous les routeurs connectés à un même réseau. Une valeur typique de ce paramètre pour un LAN est 10 secondes.
[dead=]IntervalleInactivité
Spécifie, en secondes, le délai pendant lequel un routeur peut ne pas répondre avant qu'un routeur voisin considère ce routeur comme défaillant. Ce paramètre doit être un multiple entier de l'intervalle de salutation (en général 4). La valeur de ce paramètre doit être identique pour tous les routeurs OSPF connectés à un même segment de réseau.
[poll=]IntervalleInterrogation
Spécifie le délai en secondes entre les interrogations réseau OSPF pour les interfaces NBMA (Non-Broadcast Multiple Access) uniquement. Vous devez définir l'intervalle d'interrogation à au moins le double de la valeur de l'intervalle d'inactivité. Une valeur typique pour un réseau X.25 est deux minutes.
[metric=]Métrique
Spécifie le coût de l'envoi d'un paquet depuis cette interface. La valeur définie ici est publiée comme étant le coût de la liaison pour cette interface dans l'annonce de l'état des liaisons effectuée par le routeur. Les interfaces rapides sont généralement moins coûteuses. La valeur maximale pour ce paramètre est 32 767.
[password=]MotDePasse
Spécifie le mot de passe pour cette interface, si des mots de passe sont requis pour la zone. Toutes les interfaces qui se trouvent dans la même zone et sur le même réseau doivent utiliser le même mot de passe. Par défaut, les mots de passe sont requis et le mot de passe est 12345678.
[mtu=]TailleMTU
Indique la taille maximale, en octets, des paquets IP contenant les informations OSPF qui peuvent être envoyées sans fragmentation. La valeur par défaut de la taille IP MTU pour un réseau Ethernet est de 1.500 octets.

set global

Configure les paramètres OSPF globaux.

Syntaxe

set global [routerid=]AdresseIP [asborder=]{yes | no} [[loglevel=]{none | error | warn | info}]

Paramètres

[routerid=]AdresseIP
Requis. Indique l'adresse IP du routeur dont vous souhaitez configurer les paramètres.
[asborder=]{yes | no}
Requis. Spécifie si le routeur fonctionne comme un routeur de frontière de système autonome.
[loglevel=]{none | error | warn | info}
Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à OSPF. Le paramètre error indique que seules les erreurs relatives à OSPF doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à OSPF doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à OSPF doivent être enregistrés.

set routefilter

Configure l'action de filtrage d'itinéraire OSPF.

Syntaxe

set routefilter [action=]{drop | accept}

Paramètres

[action=]{drop | accept}
Requis. Spécifie si le filtre d'itinéraire rejette ou accepte les paquets. Le paramètre drop indique que les paquets doivent être rejetés. Le paramètre accept indique que les paquets doivent être acceptés.

set protofilter

Configure l'action de filtrage de protocole OSPF.

Syntaxe

set protofilter [action=]{drop | accept}

Paramètres

[action=]{drop | accept}
Requis. Spécifie si le filtre de protocole rejette ou accepte les paquets. Le paramètre drop indique que les paquets doivent être rejetés. Le paramètre accept indique que les paquets doivent être acceptés.

show global

Affiche les paramètres OSPF globaux.

Syntaxe

show global

Paramètres

aucun

show area

Affiche les paramètres de zone.

Syntaxe

show area

Paramètres

aucun

show virtif

Affiche les paramètres de toutes les interfaces virtuelles.

Syntaxe

show virtif

Paramètres

aucun

show interface

Affiche les informations de configuration OSPF pour l'interface spécifiée.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

show routefilter

Affiche les informations relatives au filtrage d'itinéraire OSPF.

Syntaxe

show routefilter

Paramètres

aucun

show protofilter

Affiche les informations relatives au filtrage de protocole OSPF.

Syntaxe

show protofilter

Paramètres

aucun

show area

Affiche les informations relatives aux zones OSPF.

Syntaxe

show area

Paramètres

aucun

show virtif

Affiche les informations relatives aux interfaces virtuelles OSPF.

Syntaxe

show virtif

Paramètres

aucun

Commandes Netsh de routage IP Autodhcp

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP Autodhcp.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

add exclusion

Ajoute une exclusion à l'étendue de l'allocateur DHCP.

Syntaxe

add exclusion AdresseIP

Paramètres

AdresseIP
Requis. Spécifie une adresse IP à exclure de l'étendue de l'allocateur DHCP.

delete exclusion

Supprime une exclusion de l'étendue de l'allocateur DHCP.

Syntaxe

delete exclusion AdresseIP

Paramètres

AdresseIP
Requis. Spécifie une adresse IP déjà exclue de l'étendue de l'allocateur DHCP.

install

Installe le protocole de routage sous IP.

Syntaxe

install

Paramètres

aucun

set global

Configure les paramètres globaux pour l'allocation DHCP.

Syntaxe

set global {[[scopenetwork=]AdresseIP] | [[scopemask=]MasqueSousRéseau] | [[leasetime=]Minutes] | [[loglevel=]{none | error | warn | info}]}

Paramètres

[scopenetwork=]AdresseIP
Spécifie l'adresse IP pour l'étendue de l'allocateur DHCP.
[scopemask=]MasqueSousRéseau
Spécifie le masque de sous-réseau associé à l'adresse IP pour l'étendue.
[leasetime=]Minutes
Spécifie, en minutes, la durée du bail.
[LogLevel=]{none | error | warn | info}
Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à DHCP. Le paramètre error indique que seules les erreurs relatives à DHCP doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à DHCP doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à DHCP doivent être enregistrés.

Exemples

Pour définir le réseau IP pour l'allocation DHCP à 10.10.10.0, avec un masque de sous-réseau d'étendue associé de 255.255.255.0, une durée de bail de 11.520 minutes (8 jours) et l'enregistrement des informations pour tous les événements apparentés, tapez :

set global 10.10.10.0 255.255.255.0 11520 info

Pour ajuster uniquement la durée de bail de manière globale pour toutes les étendues sur toutes les interfaces à la valeur de 4320 minutes (3 jours), tapez :

set global leasetime=4320

set interface

Configure les paramètres de l'allocateur DHCP pour l'interface spécifiée.

Syntaxe

set interface [InterfaceName=]NomInterface [mode=]{enable | disable}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous souhaitez configurer les paramètres. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{enable | disable}
Requis. Spécifie si l'allocation DHCP est activée ou désactivée pour l'interface.

show global

Affiche la configuration globale de l'allocateur DHCP.

Syntaxe

show global

Paramètres

aucun

show interface

Affiche la configuration de l'allocateur DHCP pour l'interface spécifiée.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

uninstall

Supprime le protocole de routage sous IP.

Syntaxe

uninstall

Paramètres

aucun

Commandes Netsh de routage IP Dnsproxy

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP Dnsproxy.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

set global

Définit les paramètres de proxy DNS globaux.

Syntaxe

set global [querytimeout=]Entier [[dnsmode=]{enable | disable}] [[winsmode=]{enable | disable}] [[loglevel=]{none | error | warn | info}]

Paramètres

[querytimeout=]Entier
Requis. Spécifie un délai d'expiration, en secondes, pour les requêtes de proxy DNS.
[dnsmode=]{enable | disable}
Spécifie si l'opération de proxy DNS est activée ou désactivée.
[winsmode=]{enable | disable}
Spécifie si l'opération de proxy WINS est activée ou désactivée.
[loglevel=]{none | error | warn | info}
Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif au proxy DNS. Le paramètre error indique que seules les erreurs relatives au proxy DNS doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs au proxy DNS doivent être enregistrés. Le paramètre info indique que tous les événements relatifs au proxy DNS doivent être enregistrés.

Exemples

Pour spécifier un délai d'expiration de 10 secondes pour les requêtes, activer l'opération de proxy DNS et de proxy WINS, et désactiver l'enregistrement des événements relatifs au proxy DNS, tapez :

set global 10 enable enable none

install

Installe le protocole de routage sous IP.

Syntaxe

install

Paramètres

aucun

set interface

Configure les paramètres de proxy DNS pour une interface.

Syntaxe

set interface [InterfaceName=]NomInterface [[mode=]{enable | disable | default}]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez configurer les paramètres. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{enable | disable | default}
Spécifie si le proxy DNS est activé, désactivé, ou défini à la valeur par défaut pour l'interface spécifiée. Le paramètre enable indique que le proxy DNS est activé. Le paramètre disable indique que le proxy DNS est désactivé. Le paramètre default indique que le proxy DNS est défini à la valeur par défaut pour l'interface.

show global

Affiche la configuration globale du proxy DNS.

Syntaxe

show global

Paramètres

aucun

show interface

Affiche la configuration du proxy DNS pour l'interface spécifiée.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

uninstall

Supprime le protocole de routage sous IP.

Syntaxe

uninstall

Paramètres

aucun

Commandes Netsh de routage IP NAT

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IP NAT.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

add addressmapping

Ajoute un mappage d'adresse IP au pool d'adresses NAT (Network Address Translation) pour l'interface spécifiée.

Syntaxe

add addressmapping [InterfaceName=]NomInterface [public=]AdresseIP [private=]AdresseIP [inboundsessions=]{enable | disable}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous voulez utiliser NAT. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[public=]AdresseIP
Requis. Spécifie l'adresse IP utilisée sur un réseau public.
[private=]AdresseIP
Requis. Spécifie l'adresse IP dans le pool des adresses disponibles sur le réseau privé.
[inboundsessions=]{enable | disable}
Requis. Spécifie si les sessions entrantes sont activées ou désactivées. Le paramètre enable indique que les sessions entrantes sont activées. Le paramètre disable indique que les sessions entrantes sont désactivées.

Exemples

Pour mapper l'adresse IP publique 10.11.11.1 sur l'adresse IP privée 10.10.10.1 et désactiver les sessions entrantes pour ce mappage de table NAT, tapez :

add addressmapping "Connexion au réseau local" 10.11.11.1 10.10.10.1 disable

add addressrange

Ajoute une plage d'adresses au pool d'adresses NAT pour l'interface spécifiée.

Syntaxe

add addressrange [InterfaceName=]NomInterface [start=]AdresseIP [end=]AdresseIP [mask=]MasqueSousRéseau

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez ajouter une plage d'adresses au pool d'adresses.
[start=]AdresseIP
Requis. Spécifie l'adresse IP de début de la plage d'adresses.
[end=]AdresseIP
Requis. Spécifie l'adresse IP de fin de la plage d'adresses.
[mask=]MasqueSousRéseau
Requis. Spécifie le masque de sous-réseau IP associé à la plage réseau délimitée par les adresses IP de début et de fin.

add interface

Configure NAT sur l'interface spécifiée.

Syntaxe

add interface [InterfaceName=]NomInterface [[mode=]{full | addressonly | private}]

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom de l'interface sur laquelle vous voulez configurer NAT. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{full | addressonly | private}
Indique le type de mode utilisé par l'interface (intégral, adresse uniquement ou privé).

add portmapping

Ajoute un mappage de port de protocole sur l'interface NAT.

Syntaxe

add portmapping [InterfaceName=]NomInterface [proto=]{tcp | udp} [publicip=]{AdresseIP | 0.0.0.0} [publicport=]Entier [privateip=]AdresseIP [privateport=]Entier

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à laquelle vous souhaitez ajouter un mappage de port. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[proto=]{tcp | udp}
Requis. Spécifie si le type de protocole est TCP ou UDP.
[publicip=]{AdresseIP | 0.0.0.0}
Requis. Spécifie soit une adresse IP externe sur le réseau public, soit 0.0.0.0 pour indiquer toutes les adresses IP non spécifiées dans la plage d'adresses du réseau privé.
[publicport=]Entier
Requis. Spécifie le port de protocole public à l'aide d'un nombre compris entre 0 et 9999.
[privateip=]AdresseIP
Requis. Spécifie une adresse IP dans la plage d'adresses du réseau privé.
[privateport=]Entier
Requis. Spécifie le port de protocole privé à l'aide d'un nombre compris entre 0 et 9999.

delete addressmapping

Supprime un mappage d'adresse du pool d'adresses NAT pour l'interface spécifiée.

Syntaxe

delete addressmapping [InterfaceName=]NomInterface [[public=]AdresseIP]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez supprimer un mappage d'adresse. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[public=]AdresseIP
Spécifie l'adresse IP à supprimer. Si vous ne spécifiez aucune adresse, tous les mappages d'adresses du pool d'adresses NAT sont supprimés de l'interface.

delete addressrange

Supprime une plage d'adresses du pool d'adresses NAT pour l'interface spécifiée.

Syntaxe

delete addressrange [InterfaceName=]NomInterface [start=]AdresseIP

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface de laquelle vous souhaitez supprimer une plage d'adresses. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[start=]AdresseIP
Requis. Indique l'adresse IP du début de la plage à supprimer.

delete interface

Supprime NAT (Network Address Translation) de l'interface spécifiée.

Syntaxe

delete interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom de l'interface pour laquelle vous voulez supprimer l'utilisation de NAT. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

delete portmapping

Supprime un mappage de port de protocole de l'interface NAT spécifiée.

Syntaxe

delete portmapping [InterfaceName=]NomInterface [[proto=]{tcp | udp}] [publicip=]{AdresseIP | 0.0.0.0}] [[publicport=]Entier] [[privateip=]AdresseIP] [privateport=]Entier]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez supprimer un mappage de port. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[proto=]{tcp | udp}
Spécifie le type de protocole. Le paramètre tcp indique que le type de protocole est TCP (Transmission Control Protocol). Le paramètre udp indique que le type de protocole est UDP (User Datagram Protocol).
[publicip=]{AdresseIP | 0.0.0.0}
Spécifie soit une adresse IP externe sur le réseau public, soit 0.0.0.0 pour indiquer toutes les adresses IP non spécifiées dans la plage d'adresses du réseau privé.
[publicport=]Entier
Spécifie le port de protocole public à l'aide d'un nombre compris entre 0 et 9999.
[privateip=]AdresseIP
Spécifie une adresse IP dans la plage d'adresses du réseau privé.
[privateport=]Entier
Spécifie le port de protocole privé à l'aide d'un nombre compris entre 0 et 9999.

set global

Définit les paramètres NAT globaux.

Syntaxe

set global {[[tcptimeoutmins=]Entier] | [[udptimeoutmins=]Entier] | [[LogLevel=]{none | error | warn | info}]}

Paramètres

[tcptimeoutmins=]Entier
Spécifie, en minutes, la valeur du délai d'expiration pour les mappages TCP.
[udptimeoutmins=]Entier
Spécifie, en minutes, la valeur du délai d'expiration pour les mappages UDP.
[LogLevel=]{none | error | warn | info}
Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à NAT. Le paramètre error indique que seules les erreurs relatives à NAT doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à NAT doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à NAT doivent être enregistrés.

set interface

Configure les paramètres NAT pour l'interface spécifiée.

Syntaxe

set interface [InterfaceName=]NomInterface [mode=]{Full | AddressOnly | Private}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez configurer les paramètres. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{Full | AddressOnly | Private}
Requis. Indique le type de mode utilisé par l'interface (intégral, adresse uniquement ou privé).

show global

Affiche la configuration globale de l'interface NAT (Network Address Translation).

Syntaxe

show global

Paramètres

aucun

show interface

Affiche la configuration NAT (Network Address Translation) pour l'interface spécifiée.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

Commandes Netsh de routage IPX

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IPX.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

show interface

Affiche les informations de configuration pour l'interface spécifiée.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

add interface

Ajoute des entrées d'interface à la configuration IPX.

Syntaxe

add interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Spécifie le nom de l'interface à laquelle vous voulez ajouter des entrées. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

delete interface

Supprime des entrées d'interface de la configuration IPX.

Syntaxe

delete interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface de laquelle vous souhaitez supprimer des entrées. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

set interface

Met à jour la configuration IPX sur l'interface spécifiée.

Syntaxe

set interface [InterfaceName=]NomInterface {[[admstate=]{enabled | disabled}] | [[wanprotocol=]{ppp | ipxwan}]}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez mettre à jour la configuration IPX. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[admstate=]{enabled | disabled}
Spécifie si le paramètre « admstate » est activé ou désactivé sur l'interface.
[wanprotocol=]{ppp | ipxwan}
Spécifie le protocole sur l'interface, PPP ou ipxwan.

show route

Affiche des informations de routage pour une adresse réseau spécifiée.

Syntaxe

show route AdresseRéseau

Paramètres

AdresseRéseau
Requis. Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

show staticroute

Affiche des informations de configuration.

Syntaxe

show staticroute [InterfaceName=]NomInterface AdresseRéseau

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
AdresseRéseau
Requis. Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

add staticroute

Ajoute des entrées à la configuration IPX de l'interface spécifiée.

Syntaxe

add staticroute [InterfaceName=]NomInterface {[AdresseRéseau] | [[nexthopmacaddress=]AdresseMAC] | [[ticks=]Entier] | [[hops=]Entier]}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez ajouter des entrées à la configuration IPX. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
AdresseRéseau
Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[nexthopmacaddress=]AdresseMAC
Spécifie une adresse MAC de tronçon suivant sur 6 octets dont la longueur n'est pas supérieure à 12 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[ticks=]Entier
Spécifie le nombre de cycles sous la forme d'un entier décimal.
[hops=]Entier
Spécifie le nombre de tronçons sous la forme d'un entier décimal.

delete staticroute

Supprime une entrée de la configuration IPX de l'interface spécifiée.

Syntaxe

delete staticroute [InterfaceName=]NomInterface {[AdresseRéseau] | [[nexthopmacaddress=]AdresseMAC] | [[ticks=]Entier] | [[hops=]Entier]}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface de laquelle vous souhaitez supprimer une entrée. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
AdresseRéseau
Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[nexthopmacaddress=]AdresseMAC
Spécifie une adresse MAC de tronçon suivant sur 6 octets dont la longueur n'est pas supérieure à 12 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[ticks=]Entier
Spécifie le nombre de cycles sous la forme d'un entier décimal.
[hops=]Entier
Spécifie le nombre de tronçons sous la forme d'un entier décimal.

set staticroute

Met à jour la configuration IPX de l'interface spécifiée.

Syntaxe

set staticroute [InterfaceName=]NomInterface {[AdresseRéseau] | [[nexthopmacaddress=]AdresseMAC] | [[ticks=]Entier] | [[hops=]Entier]}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez mettre à jour la configuration IPX. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
AdresseRéseau
Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[nexthopmacaddress=]AdresseMAC
Spécifie une adresse MAC de tronçon suivant sur 6 octets dont la longueur n'est pas supérieure à 12 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[ticks=]Entier
Spécifie le nombre de cycles sous la forme d'un entier décimal.
[hops=]Entier
Spécifie le nombre de tronçons sous la forme d'un entier décimal.

show service

Affiche des informations de configuration de noms de services. Utilisée sans paramètres, la commande show service affiche tous les types et noms de services.

Syntaxe

show service [TypeService] [NomService]

Paramètres

TypeService
Spécifie un type de service sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
NomService
Indique le nom du service à propos duquel vous souhaitez afficher des informations.

show staticservice

Affiche des informations de configuration à propos du service d'itinéraire statique.

Syntaxe

show staticservice [InterfaceName=]NomInterface [TypeService] [NomService]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
TypeService
Spécifie un type de service sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
NomService
Spécifie un nom de service.

add staticservice

Ajoute des entrées à la configuration IPX d'une interface spécifiée.

Syntaxe

add staticservice [InterfaceName=]NomInterface {[TypeService] | [NomService] | [AdresseRéseau] | [[node=]AdresseNœud] | [[socket=]AdresseSocket] | [[hops=]Entier]}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez ajouter des entrées à la configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
TypeService
Spécifie un type de service sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
NomService
Spécifie un nom de service.
AdresseRéseau
Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[node=]AdresseNœud
Spécifie une adresse de nœud sur 6 octets dont la longueur n'est pas supérieure à 12 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[socket=]AdresseSocket
Spécifie une adresse de socket sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[hops=]Entier
Spécifie le nombre de tronçons sous la forme d'un entier décimal.

delete staticservice

Supprime une entrée de la configuration IPX d'une interface spécifiée.

Syntaxe

delete staticservice [InterfaceName=]NomInterface {[TypeService] | [NomService] | [AdresseRéseau] | [[node=]AdresseNœud] | [[socket=]AdresseSocket] | [[hops=]Entier]}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez supprimer une entrée de la configuration IPX. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
TypeService
Spécifie un type de service sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
NomService
Spécifie un nom de service.
AdresseRéseau
Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[node=]AdresseNœud
Spécifie une adresse de nœud sur 6 octets dont la longueur n'est pas supérieure à 12 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[socket=]AdresseSocket
Spécifie une adresse de socket sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[hops=]Entier
Spécifie le nombre de tronçons sous la forme d'un entier décimal.

set staticservice

Met à jour la configuration d'itinéraire statique IPX.

Syntaxe

set staticservice [InterfaceName=]NomInterface {[TypeService] | [NomService] | [AdresseRéseau] | [[node=]AdresseNœud] | [[socket=]AdresseSocket] | [[hops=]Entier]}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez mettre à jour la configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
TypeService
Spécifie un type de service sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
NomService
Spécifie un nom de service.
AdresseRéseau
Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[node=]AdresseNœud
Spécifie une adresse de nœud sur 6 octets dont la longueur n'est pas supérieure à 12 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[socket=]AdresseSocket
Spécifie une adresse de socket sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[hops=]Entier
Spécifie le nombre de tronçons sous la forme d'un entier décimal.

set filter

Met à jour la configuration du filtre du routeur IPX.

Syntaxe

set filter [InterfaceName=]NomInterface [[mode=]{input | output}] [[action=]{permit | deny}]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez mettre à jour la configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Spécifie le mode (entrée ou sortie).
[action=]{permit | deny}
Spécifie l'action (autoriser ou refuser).

show filter

Affiche des informations de configuration de filtre IPX pour l'interface spécifiée.

Syntaxe

show filter [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

add filter

Ajoute des entrées de filtre de routeur à la configuration IPX.

Syntaxe

add filter [InterfaceName=]NomInterface [mode=]{input | output} [[srcnet=]SousRéseauSource] [[srcnode=]NœudSource] [[srcsocket=]SocketSource] [[dstnet=]SousRéseauDestination] [[dstnode=]NœudDestination] [[dstsocket=]SocketDestination] [[pkttype=]TypePaquet]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à laquelle vous souhaitez ajouter des entrées de filtre. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode.
[srcnet=]SousRéseauSource
Spécifie un masque de réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[srcnode=]NœudSource
Spécifie une adresse de nœud sur 6 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[srcsocket=]SocketSource
Spécifie une adresse de socket sur 2 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[dstnet=]SousRéseauDestination
Spécifie un masque de réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[dstnode=]NœudDestination
Spécifie une adresse de nœud sur 6 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[dstsocket=]SocketDestination
Spécifie une adresse de socket sur 2 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[pkttype=]TypePaquet
Spécifie un type de paquet sur 1 octet dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

delete filter

Supprime des entrées de filtre de routeur de la configuration IPX.

Syntaxe

delete filter [InterfaceName=]NomInterface [mode=]{input | output} [[srcnet=]SousRéseauSource] [[srcnode=]NœudSource] [[srcsocket=]SocketSource] [[dstnet=]SousRéseauDestination] [[dstnode=]NœudDestination] [[dstsocket=]SocketDestination] [[pkttype=]TypePaquet]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface de laquelle vous souhaitez supprimer une entrée de filtre. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode.
[srcnet=]SousRéseauSource
Spécifie un masque de réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[srcnode=]NœudSource
Spécifie une adresse de nœud sur 6 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[srcsocket=]SocketSource
Spécifie une adresse de socket sur 2 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[dstnet=]SousRéseauDestination
Spécifie un masque de réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[dstnode=]NœudDestination
Spécifie une adresse de nœud sur 6 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[dstsocket=]SocketDestination
Spécifie une adresse de socket sur 2 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[pkttype=]TypePaquet
Spécifie un type de paquet sur 1 octet dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

show global

Affiche les informations de configuration IPX globale.

Syntaxe

show global

Paramètres

aucun

set global

Configure les paramètres IPX globaux.

Syntaxe

set global [LogLevel=]{none | error | warn | info}

Paramètres

[LogLevel=]{none | error | warn | info}
Requis. Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à IPX. Le paramètre error indique que seules les erreurs relatives à IPX doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à IPX doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à IPX doivent être enregistrés.

Commandes Netsh de routage IPX NetBIOS

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IPX NetBIOS.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

show interface

Affiche la propagation des diffusions et du trafic IPX NetBIOS sur les interfaces de routage.

Syntaxe

show interface [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

set interface

Configure la propagation des diffusions et du trafic IPX NetBIOS sur les interfaces de routage.

Syntaxe

set interface [InterfaceName=]NomInterface [[bcastaccept=]{enabled | disabled}] [[bcastdeliver=]{enabled | disabled | staticonly | onlywhenup}]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface sur laquelle vous souhaitez configurer la propagation. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[bcastaccept=]{enabled | disabled}
Spécifie si l'interface de routage doit accepter les diffusions et le trafic NetBIOS.
[bcastdeliver=]{enabled | disabled | staticonly | onlywhenup}
Spécifie si et comment l'interface de routage doit délivrer les diffusions et le trafic NetBIOS. Si le paramètre bcastdeliver est activé, toutes les diffusions et le trafic sont transférés. Si le paramètre bcastdeliver est désactivé, aucune diffusion et aucun trafic n'est transféré. Le paramètre onlywhenup indique que les diffusions et le trafic sont transférés uniquement lorsque l'interface est active. Le paramètre staticonly indique que les diffusions et le trafic sont transférés uniquement pour les itinéraires statiques.

show nbname

Affiche les noms NetBIOS statiques sur l'interface de routage spécifiée.

Syntaxe

show nbname [InterfaceName=]NomInterface

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

add nbname

Ajoute un nom NetBIOS statique à l'interface de routage spécifiée.

Syntaxe

add nbname [InterfaceName=]NomInterface NomNetBIOS [[nbtype=]Type]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à laquelle vous souhaitez ajouter un nom. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
NomNetBIOS
Requis. Spécifie le nom NetBIOS que vous voulez ajouter.
[nbtype=]Type
Spécifie un type de nom NetBIOS sur 1 octet dont la longueur n'est pas supérieure à 2 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

delete nbname

Supprime un nom NetBIOS statique de l'interface de routage spécifiée.

Syntaxe

delete nbname [InterfaceName=]NomInterface NomNetBIOS [nbtype=]Type

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface de laquelle vous souhaitez supprimer un nom. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
NomNetBIOS
Requis. Spécifie le nom NetBIOS que vous voulez supprimer.
[nbtype=]Type
Spécifie un type de nom NetBIOS sur 1 octet dont la longueur n'est pas supérieure à 2 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

Commandes Netsh de routage IPX RIP

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IPX RIP.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

show interface

Affiche l'état IPX RIP de l'interface spécifiée. Utilisée sans paramètres, la commande show interface affiche des informations pour toutes les interfaces.

Syntaxe

show interface [[InterfaceName=]NomInterface]

Paramètres

[InterfaceName=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

set interface

Configure des interfaces IPX RIP.

Syntaxe

set interface [InterfaceName=]NomInterface [[admstate=]{enabled | disabled}] [[advertise=]{enabled | disabled}] [[listen=]{enabled | disabled}] [[gnsreply=]{enabled | disabled}] [[updatemode=]{standard | none | autostatic}] [[interval=]Entier] [[agemultiplier=]Entier]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface que vous voulez configurer. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[admstate=]{enabled | disabled}
Spécifie si le paramètre « admstate » est activé ou désactivé.
[advertise=]{enabled | disabled}
Spécifie si le paramètre « advertise » est activé ou désactivé.
[listen=]{enabled | disabled}
Spécifie si le paramètre « listen » est activé ou désactivé.
[gnsreply=]{enabled | disabled}
Spécifie si le paramètre « gnsreply » est activé ou désactivé.
[updatemode=]{standard | none | autostatic}
Spécifie à quel moment et de quelle manière les mises à jour se produisent.
[interval=]Entier
Indique la valeur de l'intervalle de mise à jour, en secondes.
[agemultiplier=]Entier
Spécifie le multiplicateur de services.

show global

Affiche les paramètres IPX RIP globaux.

Syntaxe

show global

Paramètres

aucun

set global

Configure les paramètres IPX RIP globaux.

Syntaxe

set global [LogLevel=]{none | error | warn | info}

Paramètres

[LogLevel=]{none | error | warn | info}
Requis. Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à IPX RIP. Le paramètre error indique que seules les erreurs relatives à IPX RIP doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à IPX RIP doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à IPX RIP doivent être enregistrés.

set filter

Configure IPX RIP sur l'interface spécifiée.

Syntaxe

set filter [InterfaceName=]NomInterface [mode=]{input | output} [action=]{permit | deny}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez mettre à jour la configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode (entrée ou sortie).
[action=]{permit | deny}
Requis. Spécifie l'action (autoriser ou refuser).

show filter

Affiche les informations de configuration IPX RIP.

Syntaxe

show filter [InterfaceName=]NomInterface [[mode=]{input | output}]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Spécifie le mode (entrée ou sortie).

add filter

Ajoute une entrée de filtre de routage à la configuration IPX RIP de l'interface spécifiée.

Syntaxe

add filter [InterfaceName=]NomInterface [mode=]{input | output} [net=]AdresseRéseau [mask=]MasqueSousRéseau

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez ajouter des entrées à la configuration IPX RIP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode (entrée ou sortie).
[net=]AdresseRéseau
Requis. Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[mask=]MasqueSousRéseau
Requis. Spécifie un masque de réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

delete filter

Supprime une entrée de filtre de routage de la configuration IPX RIP de l'interface spécifiée.

Syntaxe

delete filter [InterfaceName=]NomInterface [mode=]{input | output} [net=]AdresseRéseau [mask=]MasqueSousRéseau

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez supprimer une entrée de la configuration IPX RIP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode (entrée ou sortie).
[net=]AdresseRéseau
Requis. Spécifie une adresse réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[mask=]MasqueSousRéseau
Requis. Spécifie un masque de réseau sur 4 octets dont la longueur n'est pas supérieure à 8 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.

Commandes Netsh de routage IPX SAP

Les commandes suivantes sont disponibles dans le contexte Netsh de routage IPX SAP.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

show interface

Affiche l'état IPX SAP pour l'interface spécifiée. Utilisée sans paramètres, la commande show interface affiche des informations pour toutes les interfaces.

Syntaxe

show interface [[InterfaceName=]NomInterface]

Paramètres

[InterfaceName=]NomInterface
Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").

set interface

Configure des interfaces IPX SAP.

Syntaxe

set interface [InterfaceName=]NomInterface [[admstate=]{enabled | disabled}] [[advertise=]{enabled | disabled}] [[listen=]{enabled | disabled}] [[gnsreply=]{enabled | disabled}] [[updatemode=]{standard | none | autostatic}] [[interval=]Entier] [[agemultiplier=]Entier]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez configurer IPX SAP. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[admstate=]{enabled | disabled}
Spécifie si le paramètre « admstate » est activé ou désactivé.
[advertise=]{enabled | disabled}
Spécifie si le paramètre « advertise » est activé ou désactivé.
[listen=]{enabled | disabled}
Spécifie si le paramètre « listen » est activé ou désactivé.
[gnsreply=]{enabled | disabled}
Spécifie si le paramètre « gnsreply » est activé ou désactivé.
[updatemode=]{standard | none | autostatic}
Spécifie à quel moment et de quelle manière les mises à jour se produisent.
[interval=]Entier
Indique la valeur de l'intervalle de mise à jour, en secondes.
[agemultiplier=]Entier
Spécifie le multiplicateur de services.

show global

Affiche les paramètres IPX SAP globaux.

Syntaxe

show global

Paramètres

aucun

set global

Configure les paramètres IPX SAP globaux.

Syntaxe

set global [LogLevel=]{none | error | warn | info}

Paramètres

[LogLevel=]{none | error | warn | info}
Requis. Spécifie quels événements doivent être enregistrés. Le paramètre none indique qu'il ne faut enregistrer aucun événement relatif à IPX SAP. Le paramètre error indique que seules les erreurs relatives à IPX SAP doivent être enregistrées. Le paramètre warn indique que seuls les avertissements relatifs à IPX SAP doivent être enregistrés. Le paramètre info indique que tous les événements relatifs à IPX SAP doivent être enregistrés.

set filter

Met à jour la configuration IPX SAP.

Syntaxe

set filter [InterfaceName=]NomInterface [mode=]{input | output} [action=]{permit | deny}

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface dont vous souhaitez mettre à jour la configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode (entrée ou sortie).
[action=]{permit | deny}
Requis. Spécifie l'action (autoriser ou refuser).

show filter

Affiche les informations de configuration IPX SAP pour l'interface spécifiée.

Syntaxe

show filter [InterfaceName=]NomInterface [[mode=]{input | output}]

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface à propos de laquelle vous souhaitez afficher des informations. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Spécifie le mode (entrée ou sortie).

add filter

Ajoute des entrées à la configuration IPX SAP de l'interface spécifiée.

Syntaxe

add filter [InterfaceName=]NomInterface [mode=]{input | output} [svtype=]TypeService [svname=]NomService

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez ajouter des entrées à la configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode (entrée ou sortie).
[svtype=]TypeService
Requis. Spécifie un type de service sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[svname=]NomService
Requis. Spécifie un nom de service.

delete filter

Supprime des entrées de configuration de filtre de la configuration IPX SAP de l'interface spécifiée.

Syntaxe

delete filter [InterfaceName=]NomInterface [mode=]{input | output} [svtype=]TypeService [svname=]NomService

Paramètres

[InterfaceName=]NomInterface
Requis. Indique le nom de l'interface pour laquelle vous souhaitez supprimer des entrées de la configuration. Le paramètre NomInterface doit correspondre au nom de l'interface spécifié dans Connexions réseau. Si NomInterface contient des espaces, placez le texte entre guillemets (par exemple, "Nom d'interface").
[mode=]{input | output}
Requis. Spécifie le mode (entrée ou sortie).
[svtype=]TypeService
Requis. Spécifie un type de service sur 2 octets dont la longueur n'est pas supérieure à 4 chiffres hexadécimaux. Les zéros d'en-tête sont facultatifs.
[svname=]NomService
Requis. Spécifie un nom de service.

Exemple de routage avec Netsh

Pour activer la découverte de routeurs pour l'interface nommée Connexion au réseau local, avec un intervalle minimal de 7 minutes, un intervalle maximal de 10 minutes, une durée de vie de 30 minutes pour les paquets de découverte de routeurs et une valeur égale à zéro (0) pour le niveau de préférence, tapez :

add interface "Connexion au réseau local" enable 7 10 30 0


Commandes Netsh pour WINS

Les commandes Netsh pour WINS offrent un outil de ligne de commande pour l'administration des serveurs WINS, qui constitue une alternative à la gestion sur console. Elles sont utiles dans les cas suivants :

  • Lorsque vous gérez des serveurs WINS sur des réseaux étendus (WAN), vous pouvez utiliser ces commandes en mode interactif à l'invite de commandes Netsh pour une meilleure gestion des liaisons réseau à faible débit.
  • Lorsque vous gérez un grand nombre de serveurs WINS, vous pouvez utiliser ces commandes en mode batch pour créer des scripts et automatiser les tâches d'administration récurrentes qui doivent être effectuées sur tous les serveurs WINS.

Les commandes suivantes sont disponibles à l'invite de commandes Netsh (distinct de l'invite de commandes Windows XP). Pour plus d'informations sur l'utilisation des commandes Netsh pour WINS, consultez Utiliser les outils de ligne de commande WINS.

Remarques

  • Sauf spécification contraire, les balises de champs (tels que Name= et EndChar=) sont en option. Si vous utilisez des balises, celles-ci doivent être appliquées à tous les paramètres de la commande. Si vous n'utilisez pas de balises, vous devez fournir une valeur pour chaque enregistrement pris en charge dans cette commande.
  • Le terme « Persona Non Grata » se réfère aux fonctionnalités de serveur WINS Windows 2000 Bloquer les enregistrements pour ces propriétaires.
  • Pour plus d'informations sur netsh, consultez Utilisation de Netsh.
  • Pour un exemple d'utilisation de commandes Netsh pour WINS dans des fichiers batch et des scripts, consultez Exemple Netsh WINS.
  • Vous ne pouvez pas exécuter ces commandes Netsh en local sur Windows XP Professionnel ou Windows XP Édition Familiale. Pour exécuter ces commandes Netsh sur un ordinateur distant fonctionnant sous Windows 2000 Server, vous devez tout d'abord utiliser Connexion au Bureau à distance pour vous connecter à un ordinateur fonctionnant sous Windows 2000 Server qui exécute Terminal Server. Vous pouvez exécuter ces commandes à partir de l'invite de commandes de Windows 2000 ou à partir de l'invite de commandes du contexte Netsh WINS. Pour que ces commandes fonctionnent à l'invite de commandes de Windows 2000, vous devez taper netsh dhcp avant de taper les commandes et paramètres tels qu'ils apparaissent dans la syntaxe ci-dessous. Des différences fonctionnelles peuvent apparaître entre les commandes du contexte Netsh sur Windows 2000 et Windows XP.

Netsh WINS

Les commandes suivantes sont disponibles à l'invite de commandes wins>, dont la racine se trouve dans l'environnement netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

server

Bascule vers le contexte du serveur spécifié. Utilisée sans paramètres, cette commande désigne le serveur WINS local par défaut.

Syntaxe

server [{\\NomServeur | AdresseIP}]

Paramètres

{\\NomServeur | AdresseIP}
Spécifie le serveur WINS distant (non local) vers lequel basculer le contexte de ligne de commande Netsh WINS. Identifie le serveur par son nom de serveur ou son adresse IP.

Exemples

Dans le premier exemple, la commande bascule le contexte Netsh vers le serveur WINS local.

Dans le deuxième exemple, la commande bascule le contexte Netsh vers un serveur distant nommé \\WINS-SRV1.

Dans le troisième exemple, la commande bascule le contexte Netsh vers un serveur distant dont l'adresse IP est 10.0.0.1.

server

server \\WINS-SRV1

server 10.0.0.1

Serveur Netsh WINS

Les commandes suivantes sont disponibles à l'invite de commandes wins server>, dont la racine se trouve dans l'environnement netsh.

Pour afficher la syntaxe d'une commande, cliquez sur la commande :

add

add filter

Ajoute un filtre défini par l'utilisateur au serveur WINS spécifié.

Syntaxe

add filter [ID=]ID [Desc=]DescriptionFiltre

Paramètres

[ID=]ID
Requis. Spécifie l'ID du filtre que vous voulez ajouter, en notation hexadécimale.
[Desc=]DescriptionFiltre
Requis. Spécifie une description du filtre que vous voulez ajouter.

add name

Ajoute un enregistrement de nom à la base de données sur le serveur WINS spécifié.

Syntaxe

add name [Name=]NomOrdinateur [[EndChar=]16èmeCarEnHex] [[Scope=]NomÉtendue] [[RecType=]{0 | 1}] [[Group=]{0 | 1 | 2 | 3 | 4}] [[Node=]{0 | 1 | 3}] [IP=]{AdresseIP1[,AdresseIP2,AdresseIP3… ]}

Paramètres

[Name=]NomOrdinateur
Requis. Spécifie le nom à ajouter et inscrire dans la base de données du serveur WINS.
[EndChar=]16èmeCarEnHex
Indique le 16ème caractère du nom en notation hexadécimale. Si ce paramètre est omis, les types d'enregistrement sont ajoutés sur base de la valeur de Group=. Pour plus d'informations, consultez Remarques.
[Scope=]NomÉtendue
Spécifie le nom de l'étendue NetBIOS.
[RecType=]{0 | 1}
Indique le type d'enregistrement : 0-Statique (par défaut), 1-Dynamique.
[Group=]{0 | 1 | 2 | 3 | 4}
Indique le type de groupe : 0-Unique (par défaut), 1-Groupe, 2-Internet 3-Multi-hébergement, 4-Nom de domaine.
[Node=]{0 | 1 | 3}
Indique le type de nœud NetBIOS : 0-Nœud B, 1-Nœud P (par défaut), 3-Nœud H.
[IP=]{AdresseIP1[,AdresseIP2,AdresseIP3…]}
Requis. Spécifie l'adresse IP de l'enregistrement de nom à ajouter. Si l'ordinateur est de type multi-hébergement, il est possible de spécifier plusieurs adresses IP. Utilisez des accolades ({}) pour entourer une ou plusieurs adresses IP, et séparez les adresses par des virgules.

Remarques

  • Si les paramètres EndChar= et Group= sont tous les deux utilisés, EndChar= remplace Group=.
  • Si EndChar= n'est pas spécifié, les types d'enregistrement suivants sont ajoutés à la base de données WINS sur base de la valeur de Group= :
    Valeur du paramètre de groupe | Type d'enregistrement ajouté
    Groupe unique (0) | 03h, 20h, 00h
    Groupe normal (1) | 1eh
    Groupe spécial / Internet (2) | 20h
    Groupe multi-hébergement (3) | 03h, 20h, 00h
    Groupe spécial / domaine (4) | 1ch

Exemples

Dans le premier exemple, la commande ajoute un jeu d'enregistrements NetBIOS par défaut de type 00h, 03h et 20h pour un ordinateur nommé HÔTEA avec une adresse IP mappée égale à 10.0.0.1.

Dans le second exemple, la commande ajoute un enregistrement 20h pour HÔTEB, qui est un ordinateur multi-hébergement d'adresses IP 10.0.0.2 et 10.0.0.3, sur SOUSRÉSEAUA, avec un type d'enregistrement statique et une configuration de nœud P.

add name Name=HÔTEA IP={10.0.0.1}

add name HÔTEB 20 SOUSRÉSEAUA 0 3 1{10.0.0.2,10.0.0.3}

add partner

Ajoute un partenaire de réplication à la liste des partenaires de réplication sur le serveur WINS spécifié.

Syntaxe

add partner [Server=]AdresseIP [[NetBIOS=]NomServeurNetBIOS] [[Type=]{0 | 1 | 2}]

Paramètres

[Server=]AdresseIP
Requis. Spécifie le partenaire de réplication à ajouter au serveur WINS. Identifie le serveur partenaire par son adresse IP.
[NetBIOS=]NomServeurNetBIOS
Spécifie le partenaire de réplication à ajouter au serveur WINS. Identifie le serveur partenaire par son nom NetBIOS.
[Type=]{0 | 1 | 2}
Indique le type de partenaire à ajouter : 0-Collecteur, 1-Émetteur, 2-Les deux (par défaut).

Remarques

  • Si l'adresse IP ne se résout pas, le paramètre de nom NetBIOS est utilisé pour créer l'enregistrement du partenaire. Autrement, le paramètre NetBIOS n'est pas utilisé.

Exemples

Dans l'exemple suivant, la commande ajoute un partenaire de réplication d'émission/collecte avec une adresse IP égale à 10.2.2.2 au serveur WINS actuel.

add partner 10.2.2.2

add pngserver

Ajoute une liste de serveurs Persona Non Grata au serveur WINS spécifié.

Syntaxe

add pngserver [Servers=]{ListeAdressesIPServeurs}

Paramètres

[Servers=]{ListeAdressesIPServeurs}
Requis. Spécifie le(s) serveur(s) Persona Non Grata à ajouter. Identifie chaque serveur par son adresse IP, placée entre accolades ({}). Si vous fournissez une liste, les adresses IP doivent être séparées par des virgules et placées entre accolades ({}).

Remarques

  • Cette commande permet d'ajouter le ou les nouveaux serveurs après avoir vérifié s'ils n'étaient pas en double. La liste Persona Non Grata (PNG) est utilisée pour spécifier les propriétaires (autres serveurs WINS) dont les enregistrements doivent être bloqués pendant la réplication.

Exemples

Dans l'exemple suivant, la commande ajoute les serveurs WINS 10.2.2.2 et 10.2.2.3 à la liste Persona Non Grata pour le serveur WINS actuel.

add pngserver {10.2.2.2,10.2.2.3}

add server

Ajoute un serveur WINS à la console WINS.

Syntaxe

add server [Server=]{\\NomServeur | AdresseIPServeur}

Paramètres

[Server=]{\\NomServeur | AdresseIPServeur}
Requis. Spécifie le serveur WINS à ajouter. Identifie le serveur par son nom NetBIOS ou son adresse IP.

Exemples

Dans l'exemple suivant, la commande ajoute un serveur d'adresse IP 172.17.32.28 à la console WINS.

add server Server=172.17.32.28

check

check database

Vérifie la cohérence de la base de données WINS. Utilisée sans paramètres, cette commande vérifie la cohérence de tous les réplicas dont l'intervalle de vérification a expiré. En conditions de surcharge, la vérification de la cohérence n'est pas effectuée immédiatement, mais après l'expiration de l'intervalle de vérification.

Syntaxe

check database [[All=]{1 | 0}] [[Force=]{1 | 0}]

Paramètres

[All=]{1 | 0}
Indique s'il faut effectuer une vérification de la cohérence sur tous les réplicas ou sur ceux dont l'intervalle de vérification a expiré : 1-Tous, 0-Autrement (par défaut).
[Force=]{1 | 0}
Indique s'il faut remplacer la vérification de la cohérence WINS en conditions de surcharge : 1-Remplacer, 0-Autrement (par défaut).

Remarques

  • La vérification de la cohérence pour tous les réplicas est une opération intensive pour le réseau et qui peut consommer beaucoup de ressources.
  • Des conditions de surcharge se produisent lorsque plusieurs commandes de vérification de la cohérence sont exécutées en moins d'une heure.

Exemples

Dans l'exemple suivant, la commande effectue une vérification de la cohérence pour tous les réplicas. Si des conditions de surcharge existent, la vérification de la cohérence est effectuée après l'expiration de l'intervalle de vérification.

check database 1

check name

Vérifie une liste d'enregistrements de noms par rapport à une série de serveurs WINS spécifiés.

Syntaxe

check name {NameFile=NomFichier | NameList={ListeNoms}} {ServerFile=NomFichier | ServerList={ListeAdressesIPServeurs}}[InclPartner={Y | y}]

Paramètres

{NameFile=NomFichier | NameList={ListeNoms}}
Requis. Spécifie le fichier contenant la liste de noms à vérifier ou spécifie une liste de noms à vérifier. Si vous fournissez une liste, les noms doivent être séparés par des virgules et placés entre accolades ({}).
{ServerFile=NomFichier | ServerList={ListeAdressesIPServeurs}}
Requis. Spécifie le fichier contenant la liste des adresses IP des serveurs à vérifier ou spécifie une liste d'adresses IP de serveurs à vérifier. Si vous fournissez une liste, les adresses IP doivent être séparées par des virgules et placées entre accolades ({}).
InclPartner={Y | y}
Spécifie que tous les partenaires seront inclus dans la liste de serveurs. Par défaut, les partenaires ne sont pas inclus dans la liste.

Remarques

  • Cette commande requiert l'utilisation de balises. Si le système détecte des incohérences, il essaie de les résoudre.
  • Le format de Nom à la fois dans NomFichier et ListeNoms est Nom*16èmecar, où Nom est le nom de l'enregistrement et 16èmecar est le 16ème caractère de l'enregistrement.
  • Dans le fichier, les noms sont séparés par des virgules ou des retours chariot / changements de ligne.

Exemples

Dans le premier exemple, la commande vérifie les données WINS dans les fichiers Noms.txt et Serveurs.txt, en supposant que ces fichiers sont situés à l'emplacement du chemin d'accès spécifié (racine du lecteur D).

Dans le second exemple, la commande vérifie les noms Nom1 avec comme 16ème caractère 03, 00 et 20h respectivement sur les serveurs d'adresse IP 10.2.2.2 et 10.2.2.3.

check name NameFile=D:\Noms.txt ServerFile=D:\Serveurs.txt

check name NameList={Nom1*03,Nom1*00,Nom1*20} ServerList={10.2.2.2,10.2.2.3}

check version

Vérifie la cohérence des numéros d'identification de version pour les propriétaires d'enregistrements WINS dans la base de données WINS.

Syntaxe

check version [Server=]AdresseIP [[File=]NomFichier]

Paramètres

[Server=]AdresseIP
Requis. Spécifie l'adresse IP du serveur WINS de départ.
[File=]NomFichier
Spécifie le fichier dans lequel stocker l'index de la table des adresses IP. Si vous omettez ce paramètre, la commande check version crée le fichier Wins.rec dans le répertoire en cours et stocke l'index de la table des adresses IP à cet endroit.

Remarques

  • Si vous fournissez un nom de fichier non valide, NomFichier devient Wins.rec dans le répertoire en cours.
  • Il se peut que vous deviez élargir la fenêtre de commande afin de pouvoir visualiser correctement la table.

Exemples

Dans l'exemple suivant, la commande vérifie la cohérence des numéros de version des enregistrements des partenaires de réplication pour un serveur WINS d'adresse IP 10.2.2.2.

check version 10.2.2.2

delete

delete name

Supprime un nom inscrit dans la base de données du serveur WINS.

Syntaxe

delete name [Name=]NomInscrit [EndChar=]16èmeCarEnHex [[Scope=]NomÉtendue]

Paramètres

[Name=]NomInscrit
Requis. Indique le nom inscrit à supprimer.
[EndChar=]16èmeCarEnHex
Requis. Indique le 16ème caractère du nom de l'enregistrement à supprimer en notation hexadécimale.
[Scope=]NomÉtendue
Spécifie l'identificateur d'étendue NetBIOS pour l'enregistrement à supprimer.

Exemples

Dans l'exemple suivant, la commande supprime les enregistrements d'affichage des messages (03h) avec comme nom d'enregistrement HÔTEA de la base de données WINS.

delete name Name=HÔTEA EndChar=03

delete owners

Supprime ou désactive une liste de propriétaires ainsi que leurs enregistrements de la base de données située sur le serveur WINS spécifié.

Syntaxe

delete owners [Servers=]{ListeAdressesIPServeurs} [[Op=]{0 | 1}]

Paramètres

[Servers=]{ListeAdressesIPServeurs}
Requis. Spécifie une liste de serveurs propriétaires dont les enregistrements doivent être supprimés. Identifie les serveurs par le biais de leurs adresses IP, qui doivent être séparées par des virgules et placées entre accolades ({}).
[Op=]{0 | 1}
Indique votre option : 0-Désactiver (par défaut), 1-Supprimer.

Exemples

Dans l'exemple suivant, la commande supprime tous les enregistrements appartenant au serveur WINS d'adresse IP 10.0.0.1.

delete owners Servers={10.0.0.1} Op=1

delete partner

Supprime soit tous les partenaires de réplication soit un partenaire de réplication spécifique de la liste des partenaires de réplication sur le serveur WINS spécifié. Si cette commande est utilisée sans paramètres, tous les partenaires de réplication sont supprimés des listes de partenaires à la fois émetteurs et collecteurs sans demande de confirmation de la part du système.

Syntaxe

delete partner [[Server=]AdresseIP] [[Type=]{0 | 1 | 2}] [[Confirm=]{Y|y}]

Paramètres

[Server=]AdresseIP
Indique le partenaire à supprimer. Identifie le partenaire par son adresse IP.
[Type=]{0 | 1 | 2}
Indique le type de liste de partenaires à supprimer : 0-Collecte, 1-Émission, 2-Les deux (par défaut).
[Confirm=]{Y|y}
Déclenche et termine l'opération sans demande de confirmation.

Exemples

Dans l'exemple suivant, la commande supprime un partenaire de type émission/collecte avec une adresse IP égale à 10.0.0.1 du serveur WINS actuel sans demande de confirmation.

delete partner Server=10.0.0.1 Type=2 Confirm=Y

delete pngserver

Supprime la totalité ou une partie des serveurs Persona Non Grata de la liste des serveurs Persona Non Grata sur le serveur WINS spécifié.

Syntaxe

delete pngserver [Servers=]{ListeAdressesIPServeurs}

Paramètres

[Servers=]{ListeAdressesIPServeurs}
Requis. Spécifie une liste de serveurs Persona Non Grata à supprimer. Identifie les serveurs Persona Non Grata par le biais de leurs adresses IP, qui doivent être séparées par des virgules et placées entre accolades ({}).

Remarques

  • La liste Persona Non Grata (PNG) spécifie les propriétaires (autres serveurs WINS) dont les enregistrements doivent être bloqués pendant la réplication. Si vous spécifiez un ensemble vide ({}), la commande delete pngserver supprime tous les serveurs de la liste de serveurs PNG.

Exemples

Dans l'exemple suivant, la commande supprime les serveurs WINS 10.2.2.2 et 10.2.2.3 de la liste Persona Non Grata pour ce serveur WINS.

delete pngserver Servers={10.2.2.2,10.2.2.3}

delete records

Supprime la totalité ou une partie des enregistrements du serveur WINS actuel ou marque les enregistrements comme désactivés.

Syntaxe

delete records [MinVer=]{Haut,Bas} [MaxVer=]{Haut,Bas} [[Op=]{0 | 1}]

Paramètres

[MinVer=]{Haut,Bas}
Requis. Spécifie les numéros de version d'enregistrement minimum haut et minimum bas où commencer la suppression. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).
[MaxVer=]{Haut,Bas}
Requis. Spécifie les numéros de version d'enregistrement maximum haut et maximum bas où terminer la suppression. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).
[Op=]{0 | 1}
Indique votre option : 0-Supprimer (par défaut), 1-Désactiver.

Remarques

  • Si vous définissez à la fois MinVer= et MaxVer= à la valeur {0,0}, la commande delete records supprime tous les enregistrements.

Exemples

Dans le premier exemple, la commande marque tous les enregistrements situés sur le serveur WINS comme désactivés.

Dans le second exemple, la commande supprime tous les enregistrements compris entre 2de2d et 2de3f inclus.

delete records MinVer={0,0} MaxVer={0,0} Op=1

delete records MinVer={0,2de2d} MaxVer={0,2de3f}

delete server

Supprime un serveur WINS de la console WINS.

Syntaxe

delete server [Server=]{\\NomServeur | AdresseIPServeur}

Paramètres

[Server=]{\\NomServeur | AdresseIPServeur}
Requis. Spécifie le serveur WINS à supprimer. Identifie le serveur par son nom NetBIOS ou son adresse IP.

Exemples

Dans l'exemple suivant, la commande supprime le serveur d'adresse IP 172.31.255.254 de la console WINS.

delete server Server=172.31.255.254

init

init backup

Déclenche la sauvegarde de la base de données WINS dans un répertoire spécifié. Utilisée sans paramètres, cette commande effectue une sauvegarde complète dans le chemin de sauvegarde par défaut actuellement défini.

Syntaxe

init backup [[Dir=]RépSauvegarde] [[Type=]{0 | 1}]

Paramètres

[Dir=]RépSauvegarde
Spécifie le répertoire dans lequel les sauvegardes sont stockées. Si ce paramètre est omis, le chemin de sauvegarde par défaut actuellement défini est utilisé.
[Type=]{0 | 1}
Indique le type de sauvegarde : 0-Sauvegarde complète (par défaut), 1-Sauvegarde incrémentielle.

Remarques

  • Une sauvegarde WINS ne peut être utilisée que pour une sauvegarde locale sur le même serveur. La sauvegarde de serveurs WINS distants n'est pas prise en charge.
  • Les fichiers de sauvegarde sont automatiquement créés dans le sous-répertoire wins_bak du répertoire Dir=.

Exemples

Dans l'exemple suivant, la commande provoque une sauvegarde complète de la base de données WINS sur le serveur WINS local dans le dossier C:\FichiersWINS\wins_bak. WINS crée automatiquement le sous-répertoire wins_bak.

init backup Dir=C:\FichiersWINS Type=0

init compact

Déclenche le compactage de la base de données du serveur WINS.

Syntaxe

init compact

Paramètres

aucun

init export

Déclenche l'exportation de la base de données du serveur WINS dans un fichier.

Syntaxe

init export

Paramètres

aucun

init import

Déclenche l'importation de mappages statiques depuis un fichier Lmhosts.

Syntaxe

init import [File=]FichierImportation

Paramètres

[File=]FichierImportation
Requis. Spécifie le fichier texte au format Lmhosts utilisé pour l'importation des mappages statiques dans la base de données WINS.

Exemples

Dans l'exemple suivant, la commande importe les mappages statiques du fichier Fixedip.sam, situé à l'emplacement du chemin d'accès C:\FichiersWINS, en tant que nouveaux mappages statiques dans la base de données WINS locale.

init import File=C:\FichiersWINS\Fixedip.sam

init pull

Active et envoie un déclencheur de collecte à un autre serveur WINS.

Syntaxe

init pull [Server=]{NomServeurCollecte | AdresseIP}

Paramètres

[Server=]{\\NomServeurCollecte | AdresseIP}
Requis. Spécifie le serveur WINS vers lequel envoyer un déclencheur de collecte. Identifie le serveur par son nom de serveur ou son adresse IP.

Remarques

  • Si le nom de serveur fourni ne peut pas être résolu en une adresse IP, l'opération échoue.

Exemples

Dans l'exemple suivant, la commande active et envoie un déclencheur de collecte au serveur WINS 10.2.2.2.

init pull Server=10.2.2.2

init pullrange

Active et récupère une série d'enregistrements d'un autre serveur WINS.

Syntaxe

init pullrange [Owner=]IPServeurPropriétaire [Server=]IPServeurCollecte [MaxVer=]{Haut,Bas} [MinVer=]{Haut,Bas}

Paramètres

[Owner=]IPServeurPropriétaire
Requis. Spécifie le serveur WINS contenant les enregistrements à collecter. Identifie le serveur par son adresse IP.
[Server=]IPServeurCollecte
Requis. Spécifie le serveur WINS qui collecte la série d'enregistrements. Identifie le serveur par son adresse IP.
[MaxVer=]{Haut,Bas}
Requis. Spécifie les numéros de version maximum haut et maximum bas des enregistrements à collecter. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).
[MinVer=]{Haut,Bas}
Requis. Spécifie les numéros de version minimum haut et minimum bas des enregistrements à collecter. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).

Remarques

  • Si vous définissez à la fois MaxVer= et MinVer= à la valeur {0,0}, la commande init pullrange collecte la série complète d'enregistrements.

Exemples

Dans l'exemple suivant, la commande active et envoie un déclencheur de collecte au serveur WINS 10.2.2.3 pour tous les enregistrements appartenant au serveur WINS 10.2.2.2.

init pullrange Owner=10.2.2.2 Server=10.2.2.3 MaxVer={0,0} MinVer={0,0}

init push

Active et envoie un déclencheur d'émission à un autre serveur WINS.

Syntaxe

init push [Server=]{\\NomServeurÉmission | AdresseIP} [[PropReq=]{0 | 1}]

Paramètres

[Server=]{\\NomServeurÉmission | AdresseIP}
Requis. Spécifie le serveur WINS vers lequel envoyer un déclencheur d'émission. Identifie le serveur par son nom ou son adresse IP.
[PropReq=]{0 | 1}
Indique votre demande de propagation : 0-Émettre vers le serveur spécifié uniquement (par défaut), 1-Obliger le serveur à propager le déclencheur d'émission vers tous ses partenaires.

Remarques

  • Si le nom de serveur fourni ne peut pas être résolu en une adresse IP, l'opération échoue.

Exemples

Dans l'exemple suivant, la commande active et envoie un déclencheur d'émission au serveur WINS 10.2.2.2 et oblige celui-ci à propager le déclencheur vers tous ses partenaires de réplication.

init push Server=10.2.2.2 PropReq=1

init replicate

Déclenche et force une réplication immédiate de la base de données avec les partenaires de réplication.

Syntaxe

init replicate

Paramètres

aucun

Remarques

  • Cette commande déclenche une réplication d'émission/collecte avec tous les partenaires de réplication pour ce serveur.

init restore

Déclenche la restauration de la base de données WINS depuis un répertoire et un fichier du serveur WINS spécifié.

Syntaxe

init restore [Dir=]RépRestauration

Paramètres

[Dir=]RépRestauration
Requis. Spécifie le répertoire à partir duquel restaurer les fichiers.

Remarques

  • Les sauvegardes WINS ne peuvent être que restaurées localement sur le même serveur. Vous ne pouvez pas restaurer la base de données WINS depuis un ordinateur distant.
  • Dir= doit contenir un sous-répertoire wins_bak, qui lui-même contient le fichier de base de données, mais ce sous-répertoire ne doit pas être inclus dans le paramètre Dir=.

Exemples

Dans l'exemple suivant, la commande restaure la base de données WINS à partir du fichier de sauvegarde de base de données situé à l'emplacement C:\FichiersWINS.

init restore Dir=C:\FichiersWINS

init scavenge

Déclenche le nettoyage de la base de données WINS pour le serveur WINS spécifié.

Syntaxe

init scavenge

Paramètres

aucun

Remarques

  • Cette commande supprime les informations obsolètes de la base de données WINS.

init search

Déclenche la recherche du nom d'enregistrement spécifié dans la base de données WINS.

Syntaxe

init search [Name=]NomEnregistrement [[EndChar=]CaractèreFin] [[Case=]{0 | 1}] [[File=]NomFichier]

Paramètres

[Name=]NomEnregistrement
Requis. Spécifie le nom de l'enregistrement à rechercher.
[EndChar=]CaractèreFin
Indique le 16ème caractère de l'enregistrement de nom NetBIOS. Si ce paramètre est omis, la recherche renvoie tous les enregistrements qui correspondent à la chaîne de caractères introduite en tant que valeur de Name=. Pour plus d'informations, consultez Remarques.
[Case=]{0 | 1}
Indique la préférence de casse pour le nom : 0-Ignorer la casse du nom (par défaut), 1-Respecter la casse du nom.
[File=]NomFichier
Spécifie le fichier dans lequel stocker la sortie ASCII en texte brut. Si ce paramètre est omis, la sortie est affichée dans la fenêtre d'invite de commandes.

Remarques

  • Si vous n'introduisez aucune valeur pour EndChar=, la recherche renvoie tous les enregistrements qui correspondent à la chaîne de caractères introduite en tant que valeur de Name=. Par exemple, si la base de données contient un enregistrement nommé MYPC-1, une recherche qui utilise MYPC comme valeur du paramètre de nom renvoie tous les enregistrements commençant par ce modèle de nom, indépendamment du type d'enregistrement :

    • Nom d'enregistrement | Type d'enregistrement
MYPC-1 | [00h]Station de travail
MYPC-1 | [01h]Autre
MYPC-1 | [03h]Affichage des messages

    Si vous spécifiez une valeur pour EndChar=, seuls les enregistrements qui correspondent au nom et au type d'enregistrement sont renvoyés. Par exemple, si la valeur de Name= est MYPC et que la valeur de EndChar est 00, la recherche suivante renvoie les résultats ci-dessous :

    Nom d'enregistrement | Type d'enregistrement
MYPC-1 | [00h]Station de travail

Exemples

Dans l'exemple suivant, la commande recherche les enregistrements nommés dc1 avec 1c comme caractère de fin, ignore la casse du nom, et envoie les informations dans le fichier noms.txt situé dans C:\FichiersWINS.

init search Name=dc1 EndChar=1c Case=0 File=C:\FichiersWINS\noms.txt

reset

reset counter

Réinitialise les statistiques pour le serveur WINS local.

Syntaxe

reset counter

Paramètres

aucun

set

set autopartnerconfig

Définit les informations de configuration automatique des partenaires de réplication pour le serveur. Utilisée sans paramètres, cette commande réinitialise la configuration automatique des partenaires (désactivée).

Syntaxe

set autopartnerconfig [[State=]{0 | 1}] [[Interval=]Valeur] [[TTL=]Valeur]

Paramètres

[State=]{0 | 1}
Indique le paramétrage des informations de configuration automatique des partenaires de réplication : 0-Réinitialiser (par défaut), 1-Définir.
[Interval=]Valeur
Indique la valeur de l'intervalle de multidiffusion, en secondes.
[TTL=]Valeur
Indique la valeur de la durée de vie (TTL, Time-To-Live) des datagrammes de multidiffusion entre les serveurs WINS partenaires. La valeur de la durée de vie doit être comprise entre 1 et 32.

Exemples

Dans l'exemple suivant, la commande définit les informations de configuration automatique pour ce serveur WINS à un intervalle de multidiffusion de 3.600 secondes et une valeur de durée de vie de 20.

set autopartnerconfig State=0 Interval=3600 TTL=20

set backuppath

Définit les paramètres de sauvegarde pour le serveur WINS spécifié.

Syntaxe

set backuppath [Dir=]NouveauChemin [[Shutdown=]{0 | 1}]

Paramètres

[Dir=]NouveauChemin
Requis. Spécifie le chemin d'accès de sauvegarde pour la base de données du serveur. Si ce paramètre est omis, le chemin d'accès par défaut est C:\.
[Shutdown=]{0 | 1}
Indique le paramétrage de la sauvegarde pendant l'arrêt : 0-Désactiver la sauvegarde de la base de données WINS pendant l'arrêt (par défaut), 1-Activer la sauvegarde de la base de données WINS pendant l'arrêt.

Exemples

Dans l'exemple suivant, la commande provoque la sauvegarde automatique de la base de données WINS dans C:\FichiersWINS par le serveur WINS lors de chaque arrêt du serveur.

set backuppath Dir=C:\FichiersWINS Shutdown=1

set burstparam

Définit les paramètres de la prise en charge du traitement en rafale pour le serveur WINS spécifié.

Syntaxe

set burstparam [State=]{0 | 1} [[Value=]TailleFileAttente]

Paramètres

[State=]{0 | 1}
Requis. Indique le paramétrage de la prise en charge du traitement en rafale : 0-Réinitialiser ou désactiver la prise en charge du traitement en rafale pour le serveur WINS, 1-Définir ou activer la prise en charge du traitement en rafale pour le serveur WINS.
[Value=]TailleFileAttente
Spécifie la valeur de la taille de file d'attente pour le mode rafale. La taille de file d'attente doit être comprise entre 50 et 5.000.

Exemples

Dans l'exemple suivant, la commande définit la taille de la file d'attente pour le mode rafale de manière à permettre 1.000 demandes d'inscription et de renouvellement de clients avant que le serveur WINS n'utilise la prise en charge du traitement en rafale.

set burstparam State=1 Value=1000

set defaultparam

Définit les paramètres par défaut pour la configuration du serveur WINS.

Syntaxe

set defaultparam

Paramètres

aucun

Remarques

  • Cette commande définit tous les paramètres de configuration du serveur WINS à leur valeur par défaut. Il est recommandé d'exécuter cette commande après l'installation du service WINS afin de configurer le serveur avec des paramètres par défaut.

set logparam

Définit ou réinitialise la base de données ainsi que les paramètres d'enregistrement des événements détaillés. Utilisée sans paramètres, cette commande conserve les valeurs actuelles.

Syntaxe

set logparam [[DBChange=]{0 | 1}] [[Event=]{0 | 1}]

Paramètres

[DBChange=]{0 | 1}
Indique si vous voulez enregistrer dans un journal les modifications apportées à la base de données : 1-Permettre l'enregistrement des modifications de la base de données dans des fichiers journaux JET (par défaut), 0-Réinitialiser cette option.
[Event=]{0 | 1}
Indique les détails des événements : 1-Enregistrer les événements détaillés dans le journal des événements du système, 0-Réinitialiser cette option (par défaut).

Remarques

  • Le moteur de la base de données WINS peut enregistrer les modifications apportées à la base de données dans des fichiers séparés. Cette option est activée par défaut car elle améliore les performances des opérations de la base de données.
  • Le serveur WINS peut enregistrer les informations des événements détaillés dans le journal des événements du système. Cette option est désactivée par défaut car elle consomme une grande quantité de ressources.

Exemples

Dans l'exemple suivant, la commande définit les paramètres de journalisation pour ce serveur WINS afin de permettre l'enregistrement des modifications de la base de données dans des fichiers JET et d'enregistrer les événements détaillés dans le journal des événements du système.

set logparam Event=1

set migrateflag

Définit l'indicateur de migration pour le serveur WINS spécifié.

Syntaxe

set migrateflag [State=]{0 | 1}

Paramètres

[State=]{0 | 1}
Requis. Indique l'état de l'indicateur de migration : 0-Définir l'indicateur de migration inactif, 1-Définir l'indicateur de migration actif.

Remarques

  • L'indicateur de migration détermine si des mappages statiques uniques peuvent être remplacés par des enregistrements dynamiques.

Exemples

Dans l'exemple suivant, la commande définit l'indicateur de migration afin de permettre le remplacement des mappages statiques uniques par des enregistrements dynamiques pour le serveur WINS spécifié.

set migrateflag State=1

set namerecord

Définit les intervalles utilisés pour déterminer à quel moment les enregistrements de noms WINS sont renouvelés, supprimés et vérifiés sur le serveur WINS spécifié. Utilisée sans paramètres, cette commande conserve les valeurs actuelles.

Syntaxe

set namerecord [[Renew=]Valeur] [[Extinction=]Valeur] [[ExTimeout=]Valeur] [[Verification=]Valeur]

Paramètres

[Renew=]Valeur
Indique la valeur de l'intervalle de taux de renouvellement, en secondes.
[Extinction=]Valeur
Indique la valeur de l'intervalle d'extinction, en secondes.
[ExTimeout=]Valeur
Indique la valeur du délai d'extinction, en secondes.
[Verification=]Valeur
Indique la valeur de l'intervalle de vérification, en secondes.

Remarques

  • Tous les paramètres sont en option. Les valeurs précédemment définies ou par défaut des paramètres non utilisés sont conservées.

Exemples

Dans l'exemple suivant, la commande définit chacune de ces valeurs pour les enregistrements de noms sur ce serveur WINS.

set namerecord Renew=3600 Extinction=7200 ExTimeout=86400 Verification=2073600

set periodicdbchecking

Définit les paramètres de vérification périodique de la cohérence de la base de données pour le serveur WINS spécifié. Utilisée sans paramètres, cette commande conserve les valeurs actuelles.

Syntaxe

set periodicdbchecking [[State=]{0 | 1}] [[MaxRec=]Valeur] [[CheckAgainst=]{0 | 1}] [[CheckEvery=]Valeur] [[Start=]Valeur]

Paramètres

[State=]{0 | 1}
Requis. Indique s'il faut vérifier l'état de la base de données WINS : 0-Désactiver, 1-Activer (par défaut). Si vous définissez la valeur de ce paramètre à 0, toutes les vérifications seront désactivées indépendamment de la valeur des autres paramètres.
[MaxRec=]Valeur
Spécifie le nombre maximal d'enregistrements vérifiés à chaque période. Si ce paramètre est omis, sa valeur par défaut est 30.000.
[CheckAgainst=]{0 | 1}
Indique le serveur auquel il faut se référer pour la vérification : 0-Serveur propriétaire (par défaut), 1-Serveur sélectionné de manière aléatoire.
[CheckEvery=]Valeur
Spécifie la fréquence de la vérification de la cohérence de la base de données WINS, en heures. Si ce paramètre est omis, sa valeur par défaut est 24 heures.
[Start=]Valeur
Spécifie l'heure, en secondes, à laquelle il faut démarrer la vérification de la cohérence.

Remarques

  • Afin de définir des intervalles de vérification périodiques de la cohérence, il est recommandé de spécifier des valeurs pour les paramètres CheckEvery et Start. Si vous voulez modifier les paramètres existants de la vérification périodique de la cohérence, indiquez uniquement des valeurs pour le paramètre State ainsi que pour le ou les paramètres que vous voulez modifier. Les paramètres pour lesquels vous ne fournissez pas de valeur restent inchangés.

Exemples

Dans l'exemple suivant, la commande vérifie la base de données WINS en fonction d'un partenaire de réplication aléatoire, chaque heure et en commençant à 3.600 secondes.

set periodicdbchecking State=1 MaxRec=1000 CheckAgainst=1 CheckEvery=1 Start=3600

set pullparam

Définit les paramètres du partenaire collecteur par défaut pour le serveur WINS spécifié. Utilisée sans paramètres, cette commande conserve les valeurs précédemment définies ou par défaut.

Syntaxe

set pullparam [[State=]{0 | 1}] [[Strtup=]{0 | 1}] [[Start=]Valeur] [[Interval=]Valeur] [[Retry=]Valeur]

Paramètres

[State=]{0 | 1}
Requis. Indique si vous voulez que les connexions permanentes soient utilisées avec les partenaires collecteurs : 0-Ne pas utiliser les connexions permanentes avec les partenaires collecteurs, 1-Utiliser les connexions permanentes avec les partenaires collecteurs.
[Strtup=]{0 | 1}
Indique si la réplication de collecte doit commencer au démarrage : 0-Ne pas commencer la réplication de collecte au démarrage (par défaut), 1-Commencer la réplication de collecte au démarrage.
[Start=]Valeur
Spécifie l'heure de démarrage du déclencheur de collecte, en secondes.
[Interval=]Valeur
Indique la valeur de l'intervalle de réplication, en secondes.
[Retry=]Valeur
Spécifie le nombre de réessais de la réplication.

Remarques

  • Si vous ne spécifiez pas de valeur pour Interval=, seule une réplication a lieu.
  • Si vous ne spécifiez pas de valeur pour Start=, l'exécution de la commande démarre le déclencheur de collecte.

Exemples

Dans l'exemple suivant, la commande définit les paramètres du partenaire collecteur par défaut pour ce serveur WINS de manière à utiliser une connexion permanente avec les partenaires collecteurs, commencer la réplication au démarrage, démarrer le déclencheur de collecte dans 23.600 secondes avec un intervalle de 259.200 secondes, et réessayer la réplication à sept reprises.

set pullparam State=1 Strtup=1 Start=23600 Interval=259200 Retry=7

set pullpartnerconfig

Définit les paramètres de configuration pour le partenaire collecteur spécifié.

Syntaxe

set pullpartnerconfig [[State=]{0 | 1}] [Server=]NomServeur [[Start=]Valeur] [[Interval=]Valeur]

Paramètres

[State=]{0 | 1}
Indique l'état de l'indicateur de connexion permanente : 0-Désactiver, 1-Activer (par défaut).
[Server=]NomServeur
Requis. Indique le nom de serveur ou l'adresse IP du partenaire de réplication de collecte.
[Start=]Valeur
Indique l'heure du début de la réplication, en secondes.
[Interval=]Valeur
Indique la valeur de l'intervalle entre les réplications de collecte, en secondes.

Remarques

  • Si le nom de serveur que vous fournissez pour le paramètre Server= ne peut pas être résolu en une adresse IP, la fonction échoue.

Exemples

Dans l'exemple suivant, la commande définit la configuration du partenaire collecteur pour le serveur WINS actuel et pour le serveur WINS partenaire 10.2.2.2. La réplication de collecte commence dans 3.600 secondes et s'effectue toutes les 4.320 secondes.

set pullpartnerconfig State=1 Server=10.2.2.2 Start=3600 Interval=4320

set pushparam

Définit les paramètres du partenaire émetteur par défaut pour le serveur WINS spécifié.

Syntaxe

set pushparam [State=]{0 | 1} [[Strtup=]{0 | 1}] [[AddChange=]{0 | 1}] [[Update=]Valeur]

Paramètres

[State=]{0 | 1}
Requis. Indique si vous voulez que les connexions permanentes soient utilisées avec les partenaires émetteurs : 0-Ne pas utiliser les connexions permanentes avec les partenaires émetteurs, 1-Utiliser les connexions permanentes avec les partenaires émetteurs.
[Strtup=]{0 | 1}
Indique si la réplication d'émission doit commencer au démarrage : 0-Ne pas commencer la réplication d'émission au démarrage (par défaut), 1-Commencer la réplication d'émission au démarrage.
[AddChange=]{0 | 1}
Indique si vous voulez que la réplication soit déclenchée suite à une modification d'adresse : 0-Ne pas déclencher la réplication suite à une modification d'adresse (par défaut), 1-Déclencher la réplication suite à une modification d'adresse.
[Update=]Valeur
Spécifie le nombre de modifications d'ID de version qui peuvent se produire avant la réplication.

Exemples

Dans l'exemple suivant, la commande définit les paramètres du partenaire émetteur par défaut pour ce serveur WINS de manière à utiliser les connexions permanentes avec les partenaires émetteurs, commencer la réplication d'émission au démarrage et en cas de modification des adresses, et émettre vers les partenaires après deux mises à jour de l'ID de version des enregistrements dont ce serveur WINS est le propriétaire.

set pushparam State=1 Strtup=1 AddChange=1 Update=2

set pushpartnerconfig

Définit les paramètres de configuration pour le partenaire émetteur spécifié.

Syntaxe

set pushpartnerconfig [[State=]{0 | 1}] [Server=]\\NomServeur [Update=]Valeur

Paramètres

[State=]{0 | 1}
Indique l'état de l'indicateur de connexion permanente : 0-Désactiver, 1-Activer (par défaut).
[Server=]\\NomServeur
Requis. Spécifie le serveur partenaire émetteur pour lequel vous souhaitez définir les paramètres de configuration. Identifie le serveur par son nom de serveur ou son adresse IP.
[Update=]Valeur
Requis. Spécifie le seuil des mises à jour.

Remarques

  • Si le nom de serveur fourni ne peut pas être résolu en une adresse IP, la fonction échoue.

Exemples

Dans l'exemple suivant, la commande définit la configuration du partenaire émetteur du serveur WINS actuel par un serveur WINS partenaire d'adresse IP 10.2.2.2 et définit à la valeur 2 la limite du nombre de modifications d'ID de version autorisées avant d'en informer les partenaires émetteurs.

set pushpartnerconfig State=1 Server=10.2.2.2 Update=2

set replicateflag

Définit l'indicateur de réplication pour le serveur WINS spécifié.

Syntaxe

set replicateflag [State=]{0 | 1}

Paramètres

[State=]{0 | 1}
Requis. Indique l'état de l'indicateur de réplication : 0-Définir l'indicateur de réplication inactif, 1-Définir l'indicateur de réplication actif.

Exemples

Dans l'exemple suivant, la commande active l'indicateur de réplication pour ce serveur.

set replicateflag State=1

set startversion

Définit la valeur de départ du numéro d'identification de version pour la base de données.

Syntaxe

set startversion [Version=]{Haut,Bas}

Paramètres

[Version=]{Haut,Bas}
Requis. Spécifie la valeur de départ du numéro d'identification de version pour la base de données WINS. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).

Exemples

Dans l'exemple suivant, la commande définit la valeur de départ du numéro d'identification de version pour la base de données WINS à 0.

set startversion Version={0,0}

show

show browser

Affiche tous les enregistrements actifs [1Bh] de l'explorateur principal de domaine pour le serveur WINS spécifié.

Syntaxe

show browser

Paramètres

aucun

show database

Affiche la base de données et les enregistrements pour une liste partielle ou complète de serveurs propriétaires spécifiés.

Syntaxe

show database [Servers=]{AdressesIP} [[RecType=]{0 | 1 | 2}] [[Count=]Compteur] [[Start=]{0 | 1}] [[EndChar=]16èmeCarEnHex] [[File=]NomFichier]

Paramètres

[Servers=]{AdressesIP}
Requis. Spécifie une liste de serveurs propriétaires dont les enregistrements doivent être affichés. Identifie les serveurs propriétaires par le biais de leurs adresses IP, qui doivent être séparées par des virgules et placées entre accolades ({}).
[RecType=]{0 | 1 | 2}
Indique le type d'enregistrement : 0-Les deux (par défaut), 1-Statique, 2-Dynamique.
[Count=]Compteur
Spécifie le nombre d'enregistrements que vous voulez afficher. Si ce paramètre est omis, tous les enregistrements qui correspondent aux paramètres de la requête sont renvoyés.
[Start=]{0 | 1}
Indique où commencer le tri de l'affichage : 0-Commencer à partir du début de la base de données (par défaut), 1-Commencer à partir de la fin de la base de données.
[EndChar=]16èmeCarEnHex
Indique le 16ème caractère des enregistrements, en notation hexadécimale. Ce nombre filtre les enregistrements qui sont récupérés de la base de données. Si ce paramètre est omis, tous les types d'enregistrement sont renvoyés.
[File=]NomFichier
Spécifie le fichier dans lequel la sortie formatée est enregistrée. Si ce paramètre est omis, la sortie est affichée dans la fenêtre d'invite de commandes.

Remarques

  • Si vous spécifiez un ensemble vide ({}) pour Servers=, la commande show database affiche les enregistrements pour tous les serveurs propriétaires.

Exemples

Dans l'exemple suivant, la commande enregistre les 1000 premiers enregistrements dynamiques de la base de données WINS pour le serveur 10.2.2.2 dans le fichier texte sortie.txt.

show database Servers={10.2.2.2} RecType=2 Count=1000 Start=0 Endchar=0 File=C:\FichiersWINS\sortie.txt

show info

Affiche les informations de configuration pour le serveur WINS spécifié.

Syntaxe

show info

Paramètres

aucun

Remarques

  • Si elle est définie, cette commande affiche les informations de configuration WINS suivantes pour le serveur actuel :
    • Chemin d'accès de sauvegarde
    • Paramétrage des enregistrements de noms
    • Vérification périodique de la cohérence des bases de données
    • Prise en charge du traitement en rafale
    • Paramètres de journalisation
    • Valeur de départ du compteur de version

show name

Demande et affiche des informations détaillées concernant un enregistrement spécifique de la base de données du serveur WINS actuel.

Syntaxe

show name [Name=]NomEnregistrement [EndChar=]16èmeCarEnHex [[Scope=]NomÉtendue]

Paramètres

[Name=]NomEnregistrement
Requis. Spécifie l'enregistrement qui est l'objet de la requête.
[EndChar=]16èmeCarEnHex
Requis pour toutes les requêtes sauf pour les enregistrements de type unique. Indique le 16ème caractère en notation hexadécimale.
[Scope=]NomÉtendue]
Spécifie l'étendue NetBIOS, si celle-ci est utilisée.

Exemples

Dans l'exemple suivant, la commande affiche les informations actuellement enregistrées pour l'enregistrement nommé HÔTEA, du type Serveur de fichiers [20h], qui existe dans la base de données WINS sur le serveur WINS spécifié.

show name Name=HÔTEA EndChar=20

show partner

Affiche tous les partenaires collecteurs, émetteurs ou émetteurs/collecteurs pour le serveur WINS spécifié. Utilisée sans paramètres, cette commande affiche tous les partenaires collecteurs, émetteurs et émetteurs/collecteurs pour le serveur WINS spécifié.

Syntaxe

show partner [[Type=]{0 | 1 | 2 | 3}]

Paramètres

[Type=]{0 | 1 | 2 | 3}
Indique le type de partenaire à afficher : 0-Tous (par défaut), 1-Collecte, 2-Émission, 3-Émission et collecte.

Exemples

Dans l'exemple suivant, la commande affiche le nom du serveur, l'adresse IP et le type de réplication de chaque partenaire de réplication pour ce serveur WINS.

show partner

show partnerproperties

Affiche les informations de configuration des partenaires par défaut pour le serveur WINS spécifié.

Syntaxe

show partnerproperties

Paramètres

aucun

Remarques

  • Cette commande affiche la configuration automatique de partenaire ainsi que les paramètres d'émission/collecte par défaut pour le serveur WINS actuel.

show pullpartnerconfig

Affiche les informations de configuration d'un partenaire collecteur.

Syntaxe

show pullpartnerconfig [Server=]{Nom | AdresseIP}

Paramètres

[Server=]{Nom | AdresseIP}
Requis. Spécifie le partenaire collecteur pour lequel vous souhaitez afficher des informations de configuration. Identifie le partenaire par son nom ou son adresse IP.

Remarques

  • Si le nom fourni ne peut pas être résolu en une adresse IP, la fonction échoue.

Exemples

Dans l'exemple suivant, la commande affiche les informations de configuration du partenaire collecteur pour le serveur WINS 10.2.2.2.

show pullpartnerconfig Server=10.2.2.2

show pushpartnerconfig

Affiche les informations de configuration d'un partenaire émetteur.

Syntaxe

show pushpartnerconfig [Server=]{Nom | AdresseIP}

Paramètres

[Server=]{Nom | AdresseIP}
Requis. Spécifie le partenaire émetteur pour lequel vous souhaitez afficher des informations de configuration. Identifie le partenaire émetteur par son nom ou son adresse IP.

Remarques

  • Si le nom fourni ne peut pas être résolu en une adresse IP, la fonction échoue.

Exemples

Dans l'exemple suivant, la commande affiche les informations de configuration du partenaire émetteur pour le serveur WINS 10.2.2.2.

show pushpartnerconfig Server= 10.2.2.2

show recbyversion

Affiche un jeu d'enregistrements pour un propriétaire, spécifié par une plage d'identificateurs de version, et trie les enregistrements par version.

Syntaxe

show recbyversion [Server=]AdresseIP [MaxVer=]{Haut,Bas} [MinVer=]{Haut,Bas} [[Name=]NomEnregistrement] [[EndChar=]16èmeCar] [Case=]{0 | 1}

Paramètres

[Server=]AdresseIP
Requis. Spécifie le serveur propriétaire pour lequel vous souhaitez afficher un jeu d'enregistrements. Identifie le serveur par son adresse IP.
[MaxVer=]{Haut,Bas}
Requis. Spécifie la plage d'enregistrements à renvoyer par les numéros de version maximum haut et maximum bas. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).
[MinVer=]{Haut,Bas}
Requis. Spécifie la plage d'enregistrements à renvoyer par les numéros de version minimum haut et minimum bas. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).
[Name=]NomEnregistrement
Spécifie les enregistrements à prendre en compte.
[EndChar=]16èmeCar
Indique le caractère à prendre en compte, en notation hexadécimale.
[Case=]{0 | 1}
Indique s'il faut créer une comparaison qui respecte la casse : 0-Ignorer la casse (par défaut), 1-Créer une comparaison qui respecte la casse.

Remarques

  • Si Name= n'est pas spécifié, EndChar= et Case= sont ignorés.
  • Si vous définissez à la fois MinVer= et MaxVer= à la valeur {0,0}, la commande show recbyversion affiche la plage complète d'enregistrements.

Exemples

Dans l'exemple suivant, la commande affiche le nombre total d'enregistrements (par version d'enregistrement) appartenant au serveur WINS 10.2.2.2.

show recbyversion Server=10.2.2.2 MaxVer={0,0} MinVer={0,0}Name=dc1 EndChar=1c Case=0

show reccount

Affiche le nombre d'enregistrements appartenant à un serveur WINS spécifique.

Syntaxe

show reccount [Server=]AdresseIP [MaxVer=]{Haut,Bas} [MinVer=]{Haut,Bas}

Paramètres

[Server=]AdresseIP
Requis. Spécifie le serveur propriétaire pour lequel vous souhaitez afficher le nombre d'enregistrements. Identifie le serveur par son adresse IP.
[MaxVer=]{Haut,Bas}
Requis. Spécifie les numéros de version maximum haut et maximum bas des enregistrements à afficher. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).
[MinVer=]{Haut,Bas}
Requis. Spécifie les numéros de version minimum haut et minimum bas des enregistrements à afficher. Les valeurs haute et basse sont séparées par une virgule et placées entre accolades ({}).

Remarques

  • Si vous définissez à la fois MinVer= et MaxVer= à la valeur {0,0}, la commande show reccount compte la plage complète d'enregistrements.

Exemples

Dans l'exemple suivant, la commande affiche le nombre total d'enregistrements pour le serveur WINS 10.2.2.2.

show reccount Server=10.2.2.2 MaxVer={0,0} MinVer={0,0}

show server

Affiche des informations pour le serveur WINS spécifié.

Syntaxe

show server

Paramètres

aucun

Remarques

  • Cette commande affiche le nom et l'adresse IP du serveur WINS spécifié.

show serverstatistics

Affiche des statistiques pour le serveur WINS spécifié.

Syntaxe

show statistics

Paramètres

aucun

show version

Affiche la valeur maximale du compteur de version en cours pour le serveur WINS spécifié.

Syntaxe

show version

Paramètres

aucun

show versionmap

Affiche la table de mappage de numéro de version maximum d'ID de propriétaire pour le serveur WINS spécifié.

Syntaxe

show versionmap

Paramètres

aucun


Exemple Netsh WINS

Vous pouvez utiliser les commandes Netsh pour WINS (Windows Internet Name Service) dans des fichiers de commandes et autres scripts afin d'automatiser des tâches. L'exemple suivant de fichier de commandes illustre l'utilisation des commandes Netsh pour WINS en vue d'exécuter diverses tâches.

Dans cet exemple de procédure, WINS-A est un serveur WINS d'adresse IP 192.168.125.30 et WINS-B est un serveur WINS d'adresse IP 192.168.0.189. La procédure ajoute un enregistrement de nom dynamique avec l'adresse IP 192.168.0.205, MON_ENREGISTREMENT [04h], à WINS-A, définit WINS-B en tant que partenaire de réplication par émission/collecte de WINS-A, se connecte à WINS-B, puis définit WINS-A en tant que partenaire de réplication par émission/collecte de WINS-B. Ensuite, la procédure initie une réplication par émission de WINS-A vers WINS-B, puis se connecte à WINS-B pour vérifier que le nouvel enregistrement, MON_ENREGISTREMENT, a été répliqué avec succès.

Pour plus d'informations, consultez Réplication WINS, Informations de référence sur les noms NetBIOS et Configurer la réplication.

Pour obtenir la liste complète des commandes Netsh pour WINS, consultez Commandes Netsh pour WINS.

Dans l'exemple de procédure suivant, les lignes qui contiennent des commentaires sont précédées des trois premières lettres (rem) du mot « remarque ». Netsh ignore les commentaires.

rem deux serveurs WINS :

rem (WINS-A) 192.168.125.30

rem (WINS-B) 192.168.0.189

rem 1. Se connecte à (WINS-A) et ajoute le nom dynamique MON_ENREGISTREMENT [04h] à la base de données (WINS-A).

netsh wins server 192.168.125.30 add name Name=MON_ENREGISTREMENT EndChar=04 IP={192.168.0.205}

rem 2. Se connecte à (WINS-A) et définit (WINS-B) en tant que partenaire de réplication par émission/collecte de (WINS-A).

netsh wins server 192.168.125.30 add partner Server=192.168.0.189 Type=2

rem 3. Se connecte à (WINS-B) et définit (WINS-A) en tant que partenaire de réplication par émission/collecte de (WINS-B).

netsh wins server 192.168.0.189 add partner Server=192.168.125.30 Type=2

rem 4. Se reconnecte à (WINS-A) et initie une réplication par émission vers (WINS-B).

netsh wins server 192.168.125.30 init push Server=192.168.0.189 PropReq=0

rem 5. Se connecte à (WINS-B) et vérifie que l'enregistrement MON_ENREGISTREMENT [04h] a été répliqué avec succès.

netsh wins server 192.168.0.189 show name Name=MON_ENREGISTREMENT EndChar=04

rem 6. Fin de l'exemple de fichier de commandes.

Le tableau suivant indique les commandes netsh wins qui sont utilisées dans cet exemple de procédure.

Commande | Description
server | Bascule le contexte actuel de ligne de commandes WINS vers le serveur indiqué par son nom ou son adresse IP.
add name | Inscrit un nom sur le serveur.
add partner | Ajoute un partenaire de réplication sur le serveur.
init push | Initie et envoie un déclencheur d'émission vers un serveur WINS.
show name | Affiche des informations détaillées concernant un enregistrement spécifique de la base de données du serveur WINS.


Netstat

Affiche les connexions TCP actives, les ports sur lesquels l'ordinateur procède à l'écoute, la table de routage IP ainsi que des statistiques Ethernet, IPv4 (pour les protocoles IP, ICMP, TCP et UDP) et IPv6 (pour les protocoles IPv6, ICMPv6, TCP sur IPv6 et UDP sur IPv6). Utilisée sans paramètre, la commande netstat affiche les connexions TCP actives.

Syntaxe

netstat [-a] [-e] [-n] [-o] [-p protocole] [-r] [-s] [intervalle]

Paramètres

-a
Affiche toutes les connexions TCP actives ainsi les ports TCP et UDP utilisés par l'ordinateur pour l'écoute.
-e
Affiche des statistiques Ethernet, comme le nombre d'octets et de paquets envoyés et reçus. Ce paramètre peut être combiné à -s.
-n
Affiche les connexions TCP actives, mais les numéros de port et les adresses sont au format numérique et aucune tentative n'est effectuée pour déterminer les noms.
-o
Affiche les connexions TCP actives et inclut l'ID de processus (PID) de chaque connexion. Vous pouvez déterminer l'application sur la base du PID indiqué sous l'onglet Processus du Gestionnaire des tâches Windows. Ce paramètre peut être combiné à -a, -n et -p.
-p protocole
Affiche les connexions utilisant le protocole indiqué par protocole. Dans ce cas, le protocole peut être tcp, udp, tcpv6 ou udpv6. Si ce paramètre est employé avec -s pour afficher des statistiques par protocole, le protocole peut être tcp, udp, icmp, ip, tcpv6, udpv6, icmpv6 ou ipv6.
-s
Affiche des statistiques par protocole. Par défaut, les statistiques de TCP, UDP, ICMP et IP sont affichées. Si le protocole IPv6 de Windows XP est installé, les statistiques portent sur TCP sur IPv6, UDP sur IPv6, ICMPv6 et IPv6. Le paramètre -p peut être utilisé pour spécifier un ensemble de protocoles.
-r
Affiche le contenu de la table de routage IP. Ce paramètre est l'équivalent de la commande route print.
intervalle
Affiche de nouveau les informations sélectionnées toutes les intervalle secondes. Appuyez sur CTRL+C pour interrompre l'affichage répété des statistiques. Si ce paramètre est omis, netstat n'imprime qu'une seule fois les informations sélectionnées.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les paramètres utilisés avec cette commande doivent être précédés d'un trait d'union (-) et non d'une barre oblique (/).
  • La commande netstat fournit des statistiques sur les éléments suivants :
    • Proto

      Nom du protocole (TCP ou UDP).

    • Adresse locale

      Adresse IP de l'ordinateur local et numéro de port utilisé. Le nom de l'ordinateur local qui correspond à l'adresse IP et le nom du port sont affichés, à moins que le paramètre -n ne soit spécifié. Si le port n'est pas encore établi, le numéro de port apparaît sous la forme d'un astérisque (*).

    • Adresse extérieure

      Numéro de port et adresse IP de l'ordinateur distant auquel le socket est connecté. Les noms qui correspondent à l'adresse IP et au port sont affichés, à moins que le paramètre -n ne soit spécifié. Si le port n'est pas encore établi, le numéro de port apparaît sous la forme d'un astérisque (*).

    • (état)

      Indique l'état d'une connexion TCP. Les états possibles sont :

      CLOSE_WAIT

      CLOSED

      ESTABLISHED

      FIN_WAIT_1

      FIN_WAIT_2

      LAST_ACK

      LISTEN

      SYN_RECEIVED

      SYN_SEND

      TIMED_WAIT

      • Pour plus d'informations sur les états d'une connexion TCP, consultez la RFC 793.

  • Cette commande est disponible uniquement si le protocole Internet Protocol (TCP/IP) est installé comme composant dans les propriétés d'une carte réseau dans les Connexions réseau.

Exemples

Pour afficher à la fois les statistiques Ethernet et les statistiques de tous les protocoles, tapez la commande suivante :

netstat -e -s

Pour afficher seulement les statistiques des protocoles TCP et UDP, tapez la commande suivante :

netstat -s -p tcp udp

Pour afficher les connexions TCP actives et les ID de processus toutes les cinq secondes, tapez la commande suivante :

nbtstat -o 5

Pour afficher les connexions TCP actives et les ID de processus au format numérique, tapez la commande suivante :

nbtstat -n -o


Nlsfunc

Charge des informations spécifiques au pays et à la région. XOX

Syntaxe

nlsfunc [[lecteur:][chemin][nom_fichier]]

Paramètres

[[lecteur:][chemin][nom_fichier]]
Spécifie le fichier contenant des informations spécifiques au pays et à la région.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • XOX
  • XOX


Nslookup

Affiche des informations que vous pouvez utiliser pour diagnostiquer l'infrastructure DNS (Domain Name System). Avant d'utiliser cet outil, vous devez vous familiariser avec le fonctionnement du DNS. L'outil de la ligne de commande Nslookup est disponible uniquement si vous avez installé le protocole TCP/IP.

Syntaxe

nslookup [-SousCommande ...] [{Ordinateur| [-Serveur]}]

Paramètres

-SousCommande ...
Spécifie une ou plusieurs sous-commandes nslookup comme options de la ligne de commande. Pour connaître la liste des sous-commandes, consultez la section Rubriques connexes.
Ordinateur
Recherche des informations pour Ordinateur en utilisant le serveur de noms DNS actuel par défaut, si aucun autre serveur n'est spécifié. Pour effectuer une recherche sur un ordinateur qui n'appartient pas au domaine DNS en cours, ajoutez un point au nom.
-Serveur
Spécifie le serveur à utiliser comme serveur de noms DNS. Si vous omettez le paramètre _Serveur, le serveur de noms DNS par défaut est utilisé.
{Aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • Si le paramètre Ordinateur est une adresse IP et l'interrogation est pour un type d'enregistrement de ressources A ou PTR, le nom de l'ordinateur est renvoyé. Si le paramètre Ordinateur est un nom et ne comporte pas de point à la fin, le nom de domaine DNS par défaut est ajouté au nom. Ce comportement dépend de l'état des sous-commandes set suivantes : domain, srchlist, defname et search.
  • Si vous tapez un tiret (-) à la place du paramètre Ordinateur, l'invite de commande passe au mode interactif de nslookup.
  • La longueur de la ligne de commande doit être inférieure à 256 caractères.
  • Nslookup propose deux modes : interactif et non interactif.

    Pour rechercher une seule donnée, choisissez le mode non interactif. Comme premier paramètre, tapez le nom ou l'adresse IP de l'ordinateur sur lequel la recherche est effectuée. Comme deuxième paramètre, tapez le nom ou l'adresse IP d'un serveur de noms DNS. Si vous omettez le deuxième paramètre, nslookup utilise le serveur de noms DNS par défaut.

    Pour rechercher plusieurs données, choisissez le mode interactif. Tapez un tiret (-) pour le premier paramètre et le nom ou l'adresse IP d'un serveur de noms DNS comme deuxième paramètre. Si vous omettez les deux paramètres, nslookup utilise le serveur de noms DNS par défaut. Vous trouverez ci-dessous des conseils pour travailler en mode interactif.

    • Pour interrompre à tout moment une commande interactive, appuyez sur CTRL+B.
    • Pour quitter, tapez exit.
    • Pour traiter une commande intégrée comme un nom d'ordinateur, faites-la précéder d'un caractère d'échappement (\).
    • Une commande non identifiée est interprétée comme un nom d'ordinateur.
  • En cas d'échec de la demande de recherche, nslookup imprime un message d'erreur. Les messages d'erreur susceptibles d'apparaître sont répertoriés dans le tableau suivant.
    Message d'erreur | Description
    Délai dépassé | Le serveur n'a pas répondu à une interrogation après un certain délai et plusieurs essais infructueux. Vous pouvez définir le délai d'expiration avec la sous-commande set timeout. Vous pouvez définir le nombre de nouvelles tentatives après le premier échec avec la sous-commande set retry.
    Aucune réponse du serveur | Aucun serveur de noms DNS ne fonctionne sur l'ordinateur serveur.
    Pas d'enregistrements | Le serveur de noms DNS ne dispose pas des enregistrements ressources correspondant au mode d'interrogation actuel de l'ordinateur, bien que le nom de l'ordinateur soit valide. Le mode d'interrogation est spécifié par la commande set querytype.
    Domaine inexistant | L'ordinateur ou le nom de domaine DNS n'existe pas.
    Connexion refusée

    - ou -

    Réseau inaccessible

             La connexion au serveur de noms DNS ou au serveur finger n'a pas pu être établie. Cette erreur se produit fréquemment avec des demandes ls et finger.
    Échec serveur | Le serveur de noms DNS a trouvé une incohérence interne dans sa base de données et n'a pas pu renvoyer une réponse valide.
    Refusé | Le serveur de noms DNS refuse de répondre à la demande.
    Erreur de format | Le serveur de noms DNS a spécifié que le format du paquet de demandes n'était pas approprié. Cela peut indiquer la présence d'une erreur dans nslookup.
  • Pour plus d'informations sur la commande nslookup et DNS, reportez-vous aux ressources suivantes :

    • Site Web des kits de ressources Microsoft Windows (http://www.microsoft.com/)

    • Lee, T., Davies, J. 2000. Microsoft Windows 2000 TCP/IP Protocols and Services Technical Reference. Redmond, Washington : Microsoft Press.
    • Albitz, P., Loukides, M. et C. Liu. 1998. DNS and BIND. Troisième édition. Sebastopol, Californie : O'Reilly and Associates, Inc.

Exemples

Chaque option de la ligne de commande se compose d'un tiret (-) suivi du nom de la commande et, dans certains cas, d'un signe égal (=) et d'une valeur. Par exemple, pour sélectionner le mode d'interrogation par défaut du serveur hôte et un délai d'expiration initial de 10 secondes, tapez :

nslookup -querytype=hinfo -timeout=10


Sous-commandes nslookup

Pour plus d'informations, cliquez sur une commande :

  • Nslookup : exit
  • Nslookup : finger
  • Nslookup : help
  • Nslookup : ls
  • Nslookup : lserver
  • Nslookup : root
  • Nslookup : server
  • Nslookup : set
  • Nslookup : set all
  • Nslookup : set class
  • Nslookup : set d2
  • Nslookup : set debug
  • Nslookup : set defname
  • Nslookup : set domain
  • Nslookup : set ignore
  • Nslookup : set port
  • Nslookup : set querytype
  • Nslookup : set recurse
  • Nslookup : set retry
  • Nslookup : set root
  • Nslookup : set search
  • Nslookup : set srchlist
  • Nslookup : set timeout
  • Nslookup : set type
  • Nslookup : set vc
  • Nslookup : view


Nslookup : exit

Quitte nslookup.

Syntaxe

exit

Paramètres

{help|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : finger

Effectue la connexion avec le serveur finger sur l'ordinateur en cours.

Syntaxe

finger [NomUtilisateur] [{[>] NomFichier|[>>] NomFichier}]

Paramètres

NomUtilisateur
Spécifie le nom de l'utilisateur recherché.
NomFichier
Spécifie le nom de fichier dans lequel enregistrer la sortie. Vous pouvez utiliser un ou deux symboles supérieur à (>) ou pour rediriger la sortie de manière habituelle.
{help|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • L'ordinateur en cours est défini lorsqu'une recherche précédente a abouti et a renvoyé des informations d'adresse. Pour plus d'informations sur la sous-commande set querytype, consultez la section Rubriques connexes.


Nslookup : help

Affiche un résumé succinct des sous-commandes nslookup.

Syntaxe

{help|?}

Paramètres

{help|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : ls

Répertorie les informations pour un domaine DNS (Domain Name System).

Syntaxe

ls [Option] DomaineDNS [{[>] NomFichier|[>>] NomFichier}]

Paramètres

Option
Le tableau suivant présente les options valides.
Option | Description
-t TypeInterrogation | Affiche tous les enregistrements du type spécifié. Pour une description de TypeInterrogation, consultez set querytype dans la section Rubriques connexes.
-a | Affiche la liste des alias des ordinateurs du domaine DNS. Ce paramètre est un synonyme de -t CNAME.
-d | Affiche tous les enregistrements du domaine DNS. Ce paramètre est un synonyme de -t ANY.
-h | Affiche des informations relatives à l'UC et au système d'exploitation pour le domaine DNS. Ce paramètre est un synonyme de -t HINFO.
-s | Affiche la liste des services connus des ordinateurs du domaine DNS. Ce paramètre est un synonyme de -t WKS.
DomaineDNS
Spécifie le domaine DNS sur lequel vous recherchez des informations.
NomFichier
Spécifie le nom de fichier dans lequel enregistrer la sortie. Vous pouvez utiliser un ou deux symboles supérieur à (>) ou pour rediriger la sortie de manière habituelle.
{help|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • La sortie par défaut contient des noms d'ordinateurs et les adresses IP correspondantes. Lorsque la sortie est dirigée vers un fichier, des symboles # sont imprimés pour tous les 50 enregistrements reçus du serveur.
XOX Rubriques connexes


Nslookup : lserver

Remplace le serveur par défaut par le domaine DNS (Domain Name System) spécifié.

Syntaxe

lserver DomaineDNS

Paramètres

DomaineDNS
Spécifie le nouveau domaine DNS du serveur par défaut.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • La commande lserver utilise le serveur initial pour rechercher des informations relatives au domaine DNS spécifié. Cette commande est opposée à la commande server, qui utilise le serveur par défaut actuel.


Nslookup : root

Remplace le serveur par défaut par le serveur racine de l'espace de noms du domaine DNS (Domain Name System).

Syntaxe

root

Paramètres

{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • Actuellement, le serveur de noms ns.nic.ddn.mil est utilisé. Cette commande est synonyme de lserver ns.nic.ddn.mil. Vous pouvez modifier le nom du serveur racine à l'aide de la commande set root.


Nslookup : server

Remplace le serveur par défaut par le domaine DNS (Domain Name System) spécifié.

Syntaxe

server DomaineDNS

Paramètres

DomaineDNS
Requis. Spécifie le nouveau domaine DNS du serveur par défaut.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • La commande server utilise le serveur par défaut actuel pour rechercher des informations relatives au domaine DSN spécifié. Cette commande est opposée à la commande lserver, qui utilise le serveur initial.


Nslookup : set

Modifie les paramètres de configuration qui affectent le fonctionnement des recherches.

Syntaxe

set MotClé[=Valeur]

Paramètres

MotClé
Identifie les sous-commandes dérivées de la sous-commande set. Par exemple, la sous-commande set d2 possède un mot clé [no]d2. Pour obtenir la liste des sous-commandes dérivées de la sous-commande set, consultez la section Rubriques connexes.
Valeur
Spécifie la valeur du paramètre de configuration nslookup de chaque sous-commande.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • Utilisez set all pour afficher la liste des paramètres actuels.


Nslookup : set all

Imprime les valeurs actuelles des paramètres de configuration.

Syntaxe

set all

Paramètres

{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • Set all imprime aussi des informations sur l'ordinateur et le serveur par défaut (c'est-à-dire l'hôte).


Nslookup : set class

Change la classe d'interrogation. La classe spécifie le groupe de protocoles des informations.

Syntaxe

set cl[ass]=Classe

Paramètres

Classe
La classe par défaut est IN. Le tableau suivant répertorie les valeurs valides de cette commande.
Valeur | Description
IN | Spécifie la classe Internet.
CHAOS | Spécifie la classe Chaos.
HESIOD | Spécifie la classe MIT Athena Hesiod.
ANY | Spécifie l'un des caractères génériques énumérés précédemment.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : set d2

Active et désactive le mode de débogage exhaustif. Tous les champs de chaque paquet sont imprimés.

Syntaxe

set [no]d2

Paramètres

nod2
Désactive le mode de débogage exhaustif. La syntaxe par défaut est nod2.
d2
Active le mode de débogage exhaustif.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : set debug

Active et désactive le mode débogage.

Syntaxe

set [no]deb[ug]

Paramètres

nodeb[ug]
Désactive le mode débogage. La syntaxe par défaut est nodebug.
deb[ug]
Active le mode débogage.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • Lorsque le débogage est activé, des informations complémentaires sur le paquet transmis au serveur et la réponse correspondante sont imprimées.


Nslookup : set defname

Ajoute le nom de domaine DNS (Domain Name System) par défaut à une demande de recherche de composant unique. Un composant unique est un composant qui ne contient pas de point.

Syntaxe

set [no]def[name]

Paramètres

nodef[name]
N'ajoute pas le nom de domaine DNS par défaut à une demande de recherche de composant unique.
def[name]
Ajoute le nom de domaine DNS par défaut à une demande de recherche de composant unique. La syntaxe par défaut est defname.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : set domain

Remplace le nom de domaine DNS (Domain Name System) par défaut par le nom spécifié.

Syntaxe

set do[main]=NomDomaine

Paramètres

NomDomaine
Spécifie un nouveau nom pour le nom de domaine DNS par défaut. Le nom de domaine par défaut est le nom d'hôte.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • Le nom du domaine DNS par défaut est ajouté à une demande de recherche en fonction de l'état des options defname et search. Si le nom contient au minimum deux composants, la liste de recherche du domaine DNS contient les parents du domaine DNS par défaut. Par exemple, si le domaine DNS par défaut est mfg.widgets.com, la liste de recherche contient mfg.widgets.com et widgets.com. La commande set srchlist permet de spécifier une liste différente et la commande set all permet d'afficher la liste.


Nslookup : set ignore

Ignore les erreurs de tronquage de paquet.

Syntaxe

set [no]ig[nore]

Paramètres

noig[nore]
N'ignore pas les erreurs de tronquage de paquet. Le paramètre par défaut est noignore.
ig[nore]
Ignore les erreurs de tronquage de paquet.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : set port

Assigne la valeur spécifiée au port TCP/UDP par défaut du serveur de noms DNS (Domain Name System).

Syntaxe

set po[rt]=Port

Paramètres

Port
Spécifie la nouvelle valeur du port TCP/UDP par défaut du serveur de noms DNS. Le port par défaut est 53.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : set querytype

Change le type d'enregistrement ressources de l'interrogation.

Syntaxe

set q[uerytype]=TypeEnregistrementRessources

Paramètres

TypeEnregistrementRessources
Spécifie un type d'enregistrement ressources DNS. Le type d'enregistrement ressources par défaut est A. Le tableau suivant répertorie les valeurs valides de cette commande.
Valeur | Description
A | Spécifie l'adresse IP d'un ordinateur.
ANY | Spécifie tous les types de données.
CNAME | Spécifie un nom canonique d'alias.
GID | Spécifie un identificateur de groupe d'un nom de groupe.
HINFO | Spécifie le type de système d'exploitation et d'unité centrale d'un ordinateur.
MB | Spécifie un nom de domaine d'une boîte aux lettres.
MG | Spécifie un membre d'un groupe de messagerie.
MINFO | Spécifie des informations sur une liste de messagerie ou une boîte aux lettres.
MR | Spécifie le nom de domaine de la messagerie renommée.
MX | Spécifie le serveur de messagerie.
NS | Spécifie un serveur de noms DNS pour la zone nommée.
PTR | Spécifie un nom d'ordinateur si l'interrogation correspond à une adresse IP. Dans le cas contraire, spécifie le pointeur vers d'autres informations.
SOA | Spécifie le début d'autorité d'une zone DNS.
TXT | Spécifie les informations de texte.
UID | Spécifie l'identificateur de l'utilisateur.
UINFO | Spécifie les informations de l'utilisateur.
WKS | Décrit un service connu.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • La commande set type a la même fonction que la commande set querytype.
  • Pour plus d'informations sur les types d'enregistrements ressources, consultez la norme RFC (Request For Comment) 1035.


Nslookup : set recurse

Indique au serveur de noms DNS (Domain Name System) d'interroger d'autres serveurs s'il ne trouve pas les informations.

Syntaxe

set [no]rec[urse]

Paramètres

norec[urse]
Le serveur de noms DNS (Domain Name System) n'interroge pas d'autres serveurs s'il ne trouve pas les informations.
rec[urse]
Indique au serveur de noms DNS (Domain Name System) d'interroger d'autres serveurs s'il ne trouve pas les informations. La syntaxe par défaut est recurse.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : set retry

Définit le nombre de tentatives.

Syntaxe

set ret[ry]=nombre

Paramètres

nombre
Spécifie le nombre de tentatives successives. Le nombre par défaut est 4.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • En l'absence de réponse à une interrogation pendant une période donnée, le délai d'expiration est doublé et la demande renvoyée. La valeur du paramètre définit le nombre de tentatives avant l'abandon. Vous pouvez modifier le délai d'expiration avec la sous-commande set timeout.


Nslookup : set root

Change le nom du serveur racine utilisé pour les interrogations.

Syntaxe

set ro[ot]=ServeurRacine

Paramètres

ServeurRacine
Spécifie le nouveau nom du serveur racine. La valeur par défaut est ns.nic.ddn.mil.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • La sous-commande set root a une incidence sur la sous-commande root.


Nslookup : set search

Ajoute à l'interrogation les noms de domaine DNS (Domain Name System) dans la liste de recherche de domaine DNS jusqu'à ce qu'une réponse soit reçue. Ceci s'applique lorsque les interrogations set et lookup contiennent au moins un point, mais ne se terminent pas par un point de fin.

Syntaxe

set [no]sea[rch]

Paramètres

nosea[rch]
N'ajoute pas à l'interrogation les noms de domaine DNS (Domain Name System) dans la liste de recherche de domaine DNS.
sea[rch]
Ajoute à l'interrogation les noms de domaine DNS (Domain Name System) dans la liste de recherche de domaine DNS jusqu'à ce qu'une réponse soit reçue. La syntaxe par défaut est search.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : set srchlist

Modifie la liste de recherche et le nom de domaine DNS (Domain Name System) par défaut.

Syntaxe

Set srchl[ist]=NomDomaine[/...]

Paramètres

NomDomaine
Spécifie les nouveaux noms de liste de recherche et de domaine DNS par défaut. La valeur du nom de domaine par défaut est basée sur le nom d'hôte. Vous pouvez spécifier jusqu'à six noms séparés par des barres obliques (/).
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • La commande set srchl remplace la liste de recherche et le nom de domaine DNS par défaut définis par la commande set domain. Utilisez la commande set all pour afficher la liste.

Exemples

Pour que le domaine DNS corresponde à mfg.widgets.com et la liste de recherche aux trois noms, tapez :

set srchlist=mfg.widgets.com/mrp2.widgets.com/widgets.com


Nslookup : set timeout

Change le délai d'attente initial (en secondes) de la réponse à une demande.

Syntaxe

set ti[meout]=Nombre

Paramètres

Nombre
Spécifie le délai d'attente (en secondes) pour une réponse. Le nombre de secondes par défaut est 5.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • En l'absence de réponse à une demande durant le délai spécifié, le délai d'expiration est doublé et la demande renvoyée. Vous pouvez utiliser la commande set retry pour définir le nombre de nouvelles tentatives.


Nslookup : set type

Change le type d'enregistrement ressources de l'interrogation.

Syntaxe

set ty[pe]=TypeEnregistrementRessources

Paramètres

TypeEnregistrementRessources
Spécifie un type d'enregistrement ressources DNS. Le type d'enregistrement ressources par défaut est A. Le tableau suivant répertorie les valeurs valides de cette commande.
Valeur | Description
A | Spécifie l'adresse IP d'un ordinateur.
ANY | Spécifie tous les types de données.
CNAME | Spécifie un nom canonique d'alias.
GID | Spécifie un identificateur de groupe d'un nom de groupe.
HINFO | Spécifie le type de système d'exploitation et d'unité centrale d'un ordinateur.
MB | Spécifie un nom de domaine d'une boîte aux lettres.
MG | Spécifie un membre d'un groupe de messagerie.
MINFO | Spécifie des informations sur une liste de messagerie ou une boîte aux lettres.
MR | Spécifie le nom de domaine de la messagerie renommée.
MX | Spécifie le serveur de messagerie.
NS | Spécifie un serveur de noms DNS pour la zone nommée.
PTR | Spécifie un nom d'ordinateur si l'interrogation correspond à une adresse IP. Dans le cas contraire, spécifie le pointeur vers d'autres informations.
SOA | Spécifie le début d'autorité d'une zone DNS.
TXT | Spécifie les informations de texte.
UID | Spécifie l'identificateur de l'utilisateur.
UINFO | Spécifie les informations de l'utilisateur.
WKS | Décrit un service connu.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.

Remarques

  • La commande set type a la même fonction que la commande set querytype.
  • Pour plus d'informations sur les types d'enregistrements ressources, consultez la norme RFC (Request For Comment) 1035.


Nslookup : set vc

Spécifie si un circuit virtuel doit être utilisé ou non pour transmettre des demandes au serveur.

Syntaxe

set [no]v[c]

Paramètres

nov[c]
Indique qu'un circuit virtuel ne doit jamais être utilisé pour la transmission des demandes au serveur. La syntaxe par défaut est novc.
v[c]
Indique qu'un circuit virtuel doit systématiquement être utilisé pour la transmission des demandes au serveur.
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Nslookup : view

Trie et affiche la sortie de la sous-commande ls ou des sous-commandes ls précédente(s).

Syntaxe

view Nom_fichier

Paramètres

NomFichier
Spécifie le nom du fichier qui contient la sortie de la ou des sous-commandes ls précédente(s).
{aide|?}
Affiche un résumé succinct des sous-commandes nslookup.


Logman
Image Microsoft Windows

Logman

Gère et planifie les collections des journaux de suivi d'événements et de compteur de performances sur les systèmes locaux et distants.

Verbes de la syntaxe

Logman [create {counter | trace} collection_name ] [start collection_name] [stop collection_name] [delete collection_name] [query {collection_name|providers}] [update collection_name]

Paramètres

create {counter | trace} collection_name
Crée des interrogations pour les collections de compteurs ou d'événements. Vous pouvez utiliser les options de la ligne de commande pour spécifier les paramètres.
start collection_name
Démarre l'interrogation pour la collection de données nom_collection. Utilisez cette option pour passer des collections planifiées aux collections manuelles. Utilisez le paramètre update de la ligne de commande avec heure de début (-b), heure de fin (-e) ou durée de répétition (-rt) pour replanifier les collections.
stop nom_collection
Arrête l'interrogation pour la collection de données nom_collection. Utilisez cette option pour passer des collections planifiées aux collections manuelles. Utilisez le paramètre update de la ligne de commande avec heure de début (-b), heure de fin (-e) ou durée de répétition (-rt) pour replanifier les collections.
delete nom_collection
Supprime l'interrogation pour la collection de données nom_collection. Si le nom_collection n'existe pas, une erreur est renvoyée.
query {nom_collection|providers}
Si aucun nom_collection ou fournisseur n'est donné, l'état de toutes les interrogations pour les collections existantes s'affiche. Utilisez nom_collection pour afficher les propriétés d'une collection donnée. Pour afficher les propriétés sur des ordinateurs distants, utilisez l'option -s ordinateur distant dans la ligne de commande. Utilisez fournisseurs comme mot clé à la place de nom_collection pour afficher les fournisseurs enregistrés qui sont installés sur votre système local. Pour répertorier les fournisseurs enregistrés qui sont installés sur le système distant, utilisez l'option -s dans la ligne de commande.
update collection_name
Met à jour les interrogations pour les collections de compteurs et d'événements. Dans le cas des collections pour les compteurs, les modifications apportées à l'interrogation s'arrêteront, puis les collections redémarreront. Dans le cas des collections pour le suivi d'événements, utilisez les paramètres suivants dans la ligne de commande pour effectuer une interrogation sans arrêter la collection : -p fournisseur [(indicateurs[,indicateurs ...])] Niveau, - max n, - o NomChemin, -ft mm:ss, ou -fd.

Options de syntaxe

[-s nom_ordinateur] [-config NomFichier] [-b M/j/aaaa h:mm:ss[AM | PM]] [-e M/j/aaaa h:mm:ss[AM | PM]] [-m [démarrer] [arrêter]] [-[-]r] [-o {Chemin | journal_compteurDNS!}] [-f {bin | bincirc | csv | tsv | SQL}] [-[-]a] [-[-]v [{nnnnn | mmjjhhmm}]] [-[-] rc [NomFichier]] [-[-] {valeur max}] [-[-]cnf [[[hh:]]mm:]ss] [-c {Chemin [chemin ...] | -cf NomFichier}] [-si [[hh:]mm:]ss] [-ln nom_journal] [-ets] [-[-] rt] [-p {GUID | fournisseur [(indicateurs [,indicateurs...]}] Niveau | -pf NomFichier}] [-[-] ul] [-bs valeur] [-ft [[hh:]mm:]ss] [-nb min max] [-fd nom journal] [-[-]u mot de passe utilisateur] [-rf [[hh:]mm:]ss] [-y] [-mode {mode_suivi [mode_suivi ...]}]

Paramètres

-s nom_ordinateur
Spécifie que les commandes créer, arrêter, supprimer ou mettre à jour seront exécutées sur le système distant. Par défaut, le système local est utilisé pour les commandes.
-config Nom_fichier
Spécifie le chemin d'accès du fichier de paramètres contenant les paramètres de la ligne de commande.
-b M/j/aaaa h:mm:ss[AM | PM]
Précise l’heure de début des collections (format 24 heures). Vous pouvez également spécifier l'heure de début des collections au format 12 heures en ajoutant AM ou PM dans la ligne de commande. Sauf spécification contraire, le jour et l'heure en cours sont utilisés par défaut. Utilisez l'option de démarrage manuel pour démarrer la collection immédiatement.
-e M/j/aaaa h:mm:ss[AM | PM]
Précise l’heure de fin des collections (format 24 heures). Vous pouvez également spécifier l'heure de fin des collections au format 12 heures en ajoutant AM ou PM dans la ligne de commande. Sauf spécification contraire, le jour et l'heure en cours sont utilisés par défaut. Utilisez l'arrêt manuel puis répétez l'option pour spécifier une heure d'arrêt avant l'heure actuelle, ou vous recevrez un message d'erreur.
-m start stop
Spécifie que les collections s'arrêtent et démarrent manuellement en utilisant les paramètres démarrer et arrêter dans la ligne de commande. Vous ne pouvez pas utiliser conjointement les paramètres -m démarrer et -b, ou -m arrêter et -e, ou -rf dans la ligne de commande pour la même interrogation.
-r
Répète la collection tous les jours aux périodes spécifiées par les options -b et -rf, ou les options -b et -e. Cette commande est valide uniquement pour les périodes de début et de fin spécifiées le même jour, le même mois et la même année.
--r
Désactive l'option de répétition.
-o {Chemin | Journal_compteurDSN!}
Spécifie le chemin d'accès au fichier de sortie qui rassemble les données de suivi d'événements et de compteur de performances, ou l'emplacement de la base de données et du groupe de données SQL. Pour spécifier SQL avec le format DSN!journal_compteur, utilisez l'option -f dans la ligne de commande. Par défaut, le nom du fichier journal est composé du nom de la requête de collection, suivi de l'extension .blg pour les compteurs de performances ou .etl pour les données de suivi.
-f {bin | bincirc | csv | tsv | SQL}
Spécifie le format de fichier utilisé pour recueillir les données de suivi et de compteur de performances. Vous pouvez utiliser des formats binaires, binaires circulaires, séparés par des virgules et des tabulations, ou des formats de base de données SQL pour les relevés de compteurs de performances. Vous devez utiliser l'option -o dans la ligne de commande avec l'option Journal_CompteurDNS!. Pour les formats de bases de données SQL, le DNS (Database System Name) doit être prédéfini et les autorisations doivent être accordées pour l'écriture dans la base de données. Le journal_compteur est créé dans la base de données et il est spécifié par le DSN. La valeur par défaut est binaire.
-a
Utilisez cette option si vous souhaitez ajouter le fichier.
--a
Désactive l'option de la commande d'ajout et retourne au mode de remplacement.
-v {nnnnn | mmjjhhmm}
Joint les informations de contrôle de version à la fin du fichier de sortie et du nom du chemin d'accès. Utilisez le format numérique nnnnn, ou le format de date mmjjhhmm (mois, jour, 24 heures, minute) pour le contrôle de version.
--v
Désactive l'option de version.
-rc NomFichier
Spécifie que cette commande doit être exécutée après la fermeture du fichier, durant la période de collecte ou à la fin de celle-ci. Utilisez l'option -rf avec -cnf pour fermer les fichiers durant les périodes de collecte. Si vous utilisez l'option -stop, cette commande n'est pas désactivée. Les commandes sont toujours exécutées au premier plan.
--rc
Désactive l'exécution de cette option de commande.
-max valeur
Indique la taille maximale en méga-octets du fichier journal obtenu. Si la taille du journal dépasse la taille maximale autorisée, la collecte s’arrête. Pour une base de données SQL, la taille maximale correspond au nombre d’enregistrements à écrire.
--max
Désactive l'option de taille limite maximale. Il s'agit de l'option par défaut.
-cnf [[hh:]mm:]ss
Crée un nouveau fichier lorsque les fichiers de sortie dépassent une taille maximale ou lorsque l'heure spécifiée est écoulée. Vous devez inclure l'option -v lorsque vous exécutez cette commande. Par défaut, un seul fichier journal est créé durant chaque collecte.
--cnf
Désactive l'option de création de nouveau fichier.
-c {Chemin [chemin ...] | -cf NomChemin}
Spécifie le chemin du compteur de performances vers le journal, ou spécifie le nom du chemin du fichier journal qui répertorie ces compteurs. Pour répertorier plusieurs chemins de compteurs, séparez la ligne de commande par un espace, ou utilisez l'option -cf pour répertorier les chemins de compteurs dans un fichier d'entrée, à raison d'une entrée par ligne.

Le format général des chemins de compteur est le suivant : [\\Ordinateur]\objet[parent/instance#index]\compteur] où :

Les composants parent, instance, index et compteur du format peuvent contenir un nom valide ou un caractère générique. Les composants ordinateur, parent, instance et index ne sont pas nécessaires pour tous les compteurs.

Vous déterminez les chemins d'accès des compteurs en fonction du compteur proprement dit. Par exemple, l'objet DisqueLogique a un index d'instance. Vous devez donc spécifier le #index ou un caractère générique. Par conséquent, vous pouvez utiliser le format suivant :

\DisqueLogique(*/*#*)\*

Par comparaison, l'objet Processus ne nécessite pas d'index d'instance. Par conséquent, vous pouvez utiliser le format suivant :

\Processus(*)\Processus ID

La liste ci-dessous présente les formats possibles :

  • \\machine\objet(parent/instance#index)\compteur
  • \\machine\objet(parent/instance)\compteur
  • \\machine\objet(instance#index)\compteur
  • \\machine\objet(instance)\compteur
  • \\machine\objet\compteur
  • \objet(parent/instance#index)\compteur
  • \objet(parent/instance)\compteur
  • \objet(instance#index)\compteur
  • \objet(instance)\compteur
  • \objet\compteur

Si un caractère générique est spécifié dans le nom du parent, toutes les instances de l'objet spécifié correspondant à l'instance spécifiée et aux champs du compteur sont renvoyées.

Si un caractère générique est spécifié dans le nom de l'instance, toutes les instances de l'objet et de l'objet parent spécifiés seront renvoyées si tous les noms d'instance correspondant à l'index spécifié correspondent au caractère générique.

Si un caractère générique est spécifié dans le nom de compteur, tous les compteurs de l'objet spécifié sont renvoyés.

Les chemins de compteur partiels (par exemple, pro*) ne sont pas pris en charge.

-si [[hh:]mm:]ss
Spécifie les intervalles d'échantillonnage des compteurs de performances en heures, minutes et secondes. La valeur par défaut est 15 secondes.
-ln nom_journal
Spécifie un nom défini par l'utilisateur pour la session du journal de suivi d'événements. Par défaut, le nom de collection est utilisé comme nom de journal.
-ets
Crée et démarre une session de suivi d'événements avec les options spécifiées sur la ligne de commande. Vous pouvez utiliser ce paramètre facultatif avec les paramètres create trace, update, query et delete.
-rt
Spécifie que la session de suivi d'événements s'exécute en mode temps réel, et n'est pas enregistrée dans un fichier. Par défaut, les données sont enregistrées dans un fichier.
--rt
Désactive l'option de journalisation en temps réel.
-p {GUID | fournisseur [(indicateurs[,indicateurs ...])] Niveau] | -pf {NomFichier}
Spécifie les fournisseurs (collecteurs de données de suivi) à utiliser pour effectuer un suivi de la collecte des données. Utilisez les fournisseurs des interrogations logman pour trouver le nomf (fournisseurs nommés) dans la liste des fournisseurs enregistrés. Utilisez l'option -pf pour répertorier plusieurs fournisseurs. L'option -pf identifie le fichier d'entrée contenant le nom des fournisseurs. Les noms des fournisseurs sont insérés entre des guillemets droits (""), ou dans le cas des GUID, entre des accolades, des masques d'indicateurs et des entiers (activer le niveau). Les indicateurs sont au format hexadécimal (OXFFFF) ou (indicateur, indicateur).
-ul
Spécifie que la session de suivi d'événements est exécutée en mode utilisateur. Si vous utilisez l'option -ul, seul un fournisseur peut être activé pour la session de suivi d'événements.
--ul
Spécifie que le mode utilisateur est désactivé, et la session de suivi d'événements est exécutée en mode kernel.
-bs valeur
Indique la taille de la zone tampon en n kilo-octets pour les collections de données de suivi.
-ft [[hh:]mm:]ss
Spécifie l'intervalle de l'horloge de vidage en minutes et en secondes pour les collections de données de suivi.
-nb min max
Spécifie le nombre minimal et le nombre maximal de tampons pour la collection des données de suivi. La valeur minimale par défaut correspond au nombre de processeurs sur le système, plus deux. La valeur maximale par défaut correspond à 25.
-fd nom_journal
Vide tous les tampons actifs d'une session de suivi d'événements existante sur un disque. Utilisez cette commande avec l'option -ln.
-u mot de passe utilisateur
Spécifie le mot de passe et le nom de compte que l'interrogation utilise sur les systèmes locaux ou distants. Pour démarrer la collecte des données des interrogations de données, enregistrez les journaux et les alertes de performance sur un système distant. Vous pouvez utilliser * comme mot de passe dans la ligne de commande pour générer une invite pour le mot de passe.
--u
Rétablit le nom de compte au compte de service des journaux et alertes de performance.
-rf [[hh:]mm:]ss
Spécifie que les collections sont exécutées pendant une durée définie.
-y
Annule les paramètres d'un nom de collection et applique les nouveaux paramètres sans interroger l'utilisateur final.
-mode {mode_suivi [mode_suivi ...]}
Spécifie les options avancées pour les sessions de suivi uniquement lorsque mode_suivi peut être globalsequence, localsequence ou pagedmemory. Globalsequence spécifie que le journal d'événements ajoute un numéro de séquence à chaque événement qu'il reçoit, quelle que soit la session de suivi qui a reçu l'événement. Localsequence spécifie que le journal d'événements ajoute un numéro de séquence pour les événements reçus lors d'une session de suivi donnée. Lorsque l'option localsequence est utilisée, des numéros de séquence en double peuvent exister entre toutes les sessions, mais les numéros de séquence sont uniques au sein de chaque session de suivi. Pagedmemory spécifie que le journal d'événements utilise une mémoire paginée et non la mémoire pool par défaut non paginée pour ses affectations de mémoires tampon internes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les options valides pour les verbes de la ligne de commande create update, start, stop, delete, et query sont :

    -s nom machine distante

    -[-]u Domaine/mot de passe utilisateur

  • Les options valides pour les verbes create et update, et les options pour compteur et suivi sont :

    -y

    -b M/jaaaa h:mm:ss [AM|PM]

    -e M/j/aaaa h:mm:ss [AM|PM]

    -rf hh:mm:ss

    -m start stop

    -f bin|bincirc

    -[-]r

    -o PathName

    -[-]a

    -[-]v nnnnn|mmddhhmm

    -[-]rc command pathname

    -[-]max n

    -[-]cnf hh:mm:ss

  • Common options for counters only are:

    -f bin|bincirc|csv|tsv|SQL

    -o PathName | DSN!counter_log

  • Common options for create counter are:

    -c counterpath | -cf input file

    -si [[hh:]mm:]ss

    Ces options mettent à jour le compteur, et elles arrêteront et démarreront les collectes.

  • Les options de la commande update pour la collection pour le suivi sont :

    - max n

    - o PathName

    -ft mm:ss

    -fd

    Ces options interrogeront les collections pour le suivi sans arrêter les collections.

  • Valid options with counters only are:

    -f bin|bincirc|csv|tsv|SQL

    -o PathName | DSN!counter_log

  • Valid options with create counter commands are:

    chemincompteur | -cf fichier entrée

    -si hh:mm:ss

  • Les options valides pour les commandes create suivi sont :

    -ln nom journal

    -[-]rt

    -p Guid | fournisseur (indicateurs[,indicateurs ...]) niveau | -pf NomFichier

    -[-]ul

    -bs n

    -ft mm:ss

    -nb min max

    -fd nom journal

    -ets

  • Utilisation de l'option -config

    Le contenu du fichier de paramètres utilisé avec l'option -config doit avoir le format suivant :

    [option_commande]

    valeur

    où option_commande est une option de ligne de commande et valeur spécifie sa valeur. Par exemple :

    [create]

    counter logx

    [-s]

    mysystem

    [-u]

    mypassword

  • Utilisation de l'option -mode

    Utilisez cette option uniquement si vous êtes un utilisateur avancé.

  • Gestion de l'analyseur de performances

    Vous pouvez utiliser Logman pour gérer les systèmes qui fonctionnent sous Windows 2000 ou Windows XP.

  • Pour plus d'informations sur l'incorporation de Logman dans vos scripts Windows Management Instrumentation (WMI), reportez-vous à l'analyse et aux journaux de scripts à l'adresse site Web des kits de ressources Microsoft Windows.(http://www.microsoft.com/)

Exemples

Les formats de date dans les exemples suivants sont uniquement pour l'heure américaine locale.

Pour créer des interrogations quotidiennes pour les collections de compteurs avec des heures de début et de fin et répéter les collections, les numéros de contrôle de version, les chemins de compteurs et les intervalles d'échantillonnage, tapez :

Logman create counter daily_perf_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -c "\Processor(_Total)\% Processor Time" "\Memory\Available bytes" -si 00:15 -o "c:\perflogs\daily_log"

Pour créer des interrogations quotidiennes pour les collections avec des heures de début et de fin et répéter les collections, les collections de fichiers de sortie, les numéros de contrôle de version, les chemins de compteurs et les intervalles d'échantillonnage, tapez :

Logman create counter daily_perf_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -o "c:\perflogs\daily_log" -v mmddhhmm -c "\Processor(_Total)\% Processor Time" "\Memory\Available bytes" -si 00:15

Pour créer des interrogations quotidiennes pour les collections en utilisant le fichier de configuration à la place du fichier de ligne de commande, tapez :

Logman -config file daily_perf.txt

Pour créer des interrogations quotidiennes pour le suivi avec des heures de début et de fin et répéter les collections, les numéros de contrôle de version, les noms des fournisseurs, les collections de fichiers d'entrée et de sortie, tapez :

Logman create trace daily_kernel_trace_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -p "Windows Kernel Trace" 0xFFFFFFFF -rf 100 -o "c:\perflogs\daily_nt_trace"

Pour créer des interrogations quotidiennes pour le suivi avec des heures de début et de fin et répéter les collections, les numéros de contrôle de version, les noms de GUID et de journaux, les collections de fichiers d'entrée et de sortie, tapez :

Logman create trace daily_lsass_trace_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -p "Local Security Authority(LSA) " 0x00000001 -rf 30:00 -o " c:\perflogs\daily_lsass_trace"

Pour créer des interrogations quotidiennes pour les compteurs avec des heures de début et de fin et répéter les collections, les numéros de contrôle de version, les chemins de compteurs, les intervalles d'échantillonnage et les formats SQL ainsi que les collections de fichiers de sortie, tapez :

Logman create counter daily_perf_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -c "\Processor(_Total)\% Processor Time" "\Memory\Available bytes" -si 00:15 -f sql -o perfdb!daily_log

Pour démarrer les collections quotidiennes avec des intervalles d'échantillonnage, des mots de passe et noms de comptes, tapez :

Logman start daily_perf_log -s \\%computer_name% -u admin "adminpassword"

Pour démarrer les collections de données manuelles, tapez :

Logman start daily_perf_log

Pour arrêter les collections de données, tapez :

Logman stop daily_perf_log

Pour supprimer les collections de données, tapez :

Logman delete daily_perf_log

Pour afficher l'état des interrogations pour les collections, tapez les commandes suivantes :

Logman query

Logman query daily_perf_log


Perfmon

Vous permet d'ouvrir une console de performances Windows XP configurée avec des fichiers de paramètres de la version Windows NT 4.0 de l'analyseur de performances.

Syntaxe

perfmon.exe [nom_fichier] [/HTMLFILE:fichier_converti fichier_paramètres]

Paramètres

.exe
Spécifie le nom de l'extension de fichier.
nom_fichier
Spécifie le nom du fichier de paramètres.
/HTMLFILE:fichier_converti fichier_paramètres
Spécifie le nom des fichiers convertis et le nom du fichier de paramètres Windows NT 4.0 d'origine.

Remarques

  • Cette procédure fonctionne pour les types suivants de fichiers de paramètres de l'Analyseur de performances Windows NT 4.0 : courbe (.pmc), rapport (.pmr), alerte (.pma) et journal (.pml).
  • Pour afficher le fichier de configuration de Windows NT 4.0 dans le Moniteur système, le système le convertit temporairement afin qu'il soit utilisé par le Moniteur système Windows XP, puis il annule la version convertie une fois que la console a démarré. Si vous souhaitez enregistrer le fichier de configuration pour l'utiliser en permanence avec le Moniteur système, tapez :

    Perfmon [nom_fichier] [/HTMLFILE:fichier_converti fichier_paramètres]

    où /HTMLFILE:fichier_converti représente le nom donné au fichier converti et fichier_paramètres le nom du fichier de paramètres d'origine de Windows NT 4.0.

  • Pour plus d'informations sur l'incorporation de Perfmon dans vos scripts Windows Management Instrumentation (WMI), reportez-vous à l'analyse et aux journaux de scripts à l'adresse site Web des kits de ressources Microsoft Windows.(http://www.microsoft.com/)

Exemples

Pour répertorier votre fichier de paramètres, tapez :

Perfmon myfile_overview

Pour répertorier les noms de fichiers d'origine et convertis, tapez :

Perfmon myfile_overview /Commands:newfile_review oldfile_sample.pml


Relog

Extrait des compteurs de performances des journaux de compteurs de performances dans d'autres formats, tels que TSV (pour le texte délimité par des tabulations), CSV (pour le texte délimité par des virgules), BIN (pour le texte binaire) ou SQL.

Syntaxe

relog [NomFichier [nomfichier ...]] [-a] [-c Chemin [chemin ...]] [-cf NomFichier] [-f {bin|csv|tsv|SQL}] [-t valeur] [-o {fichiersortie | Compteur_journalDSN!}] [-b M/j/aaaa [[hh:]mm:]ss] [-e M/j/aaaa [[hh:]mm:]ss] [-config NomFichier] [-q]

Paramètres

NomFichier [nomfichier ...]
Spécifie le chemin du journal d'un compteur de performances existant. Vous pouvez indiquer plusieurs fichiers d'entrée.
-a
Ajoute le fichier de sortie au lieu de l'écraser. Cette option ne s'applique pas au format SQL pour lequel la valeur par défaut est toujours l'ajout.
-c Chemin [chemin ...]
Spécifie le chemin d'accès du compteur de performances à enregistrer. Pour spécifier plusieurs chemins d'accès de compteurs de performances, séparez-les par un espace et insérez les chemins d'accès des compteurs entre guillemets (par exemple, "CheminCompteur1 CheminCompteur2").
-cf Nomfichier
Spécifie le chemin d'accès du fichier texte qui répertorie les compteurs de performances à inclure dans un fichier d'enregistrement. Utilisez cette option pour répertorier les chemins d'accès dans un fichier d'entrée, à raison d'un chemin par ligne. Par défaut, tous les compteurs dans le fichier journal d'origine sont enregistrés.
-f {bin|csv|tsv|SQL}
Spécifie le chemin d'accès du format de fichier de sortie. Le format par défaut est bin. Dans le cas d'une base de données SQL, le fichier de sortie spécifie le journal_compteurDSN!. Pour spécifier l'emplacement de la base de données, vous pouvez utiliser le Gestionnaire ODBC afin de configurer le DNS (Database System Name).
-t valeur
Spécifie les intervalles d'échantillon dans "n" enregistrements. Inclut chaque énième point de données dans le fichier d'enregistrement. La valeur par défaut est chaque point de données.
-o {fichiersortie | Journal_CompteurDSN!}
Spécifie le chemin d'accès de la base de données SQL ou du fichier de sortie dans lesquels les compteurs seront écrits.
-b M/j/aaaa hh[:mm[:ss]]
Spécifie l'heure de début pour la copie du premier enregistrement à partir du fichier d'entrée. La date et l'heure doivent posséder le format adéquat (M/j/aaaa hh:mm:ss).
-e M/j/aaaa hh[:mm[:ss]]
Spécifie l'heure de fin pour la copie du dernier enregistrement à partir du fichier d'entrée. La date et l'heure doivent posséder le format adéquat (M/j/aaaa hh:mm:ss).
-config Nom_fichier
Spécifie le chemin d'accès du fichier de paramètres contenant les paramètres de la ligne de commande.
-q
Affiche les compteurs de performances et les plages horaires des fichiers journaux spécifiés dans le fichier d'entrée.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Format du chemin d'accès du compteur

    Le format général des chemins de compteur est le suivant : [\\Ordinateur]\objet[parent/instance#index]\compteur] où :

    Les composants parent, instance, index et compteur du format peuvent contenir un nom valide ou un caractère générique. Les composants ordinateur, parent, instance et index ne sont pas nécessaires pour tous les compteurs.

    Vous déterminez les chemins d'accès des compteurs en fonction du compteur proprement dit. Par exemple, l'objet DisqueLogique a un index d'instance. Vous devez donc spécifier le #index ou un caractère générique. Par conséquent, vous pouvez utiliser le format suivant :

    \DisqueLogique(*/*#*)\*

    Par comparaison, l'objet Processus ne nécessite pas d'index d'instance. Par conséquent, vous pouvez utiliser le format suivant :

    \Processus(*)\Processus ID

    La liste ci-dessous présente les formats possibles :

    • \\machine\objet(parent/instance#index)\compteur
    • \\machine\objet(parent/instance)\compteur
    • \\machine\objet(instance#index)\compteur
    • \\machine\objet(instance)\compteur
    • \\machine\objet\compteur
    • \objet(parent/instance#index)\compteur
    • \objet(parent/instance)\compteur
    • \objet(instance#index)\compteur
    • \objet(instance)\compteur
    • \objet\compteur

    Si un caractère générique est spécifié dans le nom du parent, toutes les instances de l'objet spécifié correspondant à l'instance spécifiée et aux champs du compteur sont renvoyées.

    Si un caractère générique est spécifié dans le nom de l'instance, toutes les instances de l'objet et de l'objet parent spécifiés seront renvoyées si tous les noms d'instance correspondant à l'index spécifié correspondent au caractère générique.

    Si un caractère générique est spécifié dans le nom de compteur, tous les compteurs de l'objet spécifié sont renvoyés.

    Les chemins de compteur partiels (par exemple, pro*) ne sont pas pris en charge.

  • Fichiers compteur

    Les fichiers compteur sont des fichiers texte qui répertorient un ou plusieurs compteurs de performances dans le journal existant. Copiez le nom complet du compteur à partir du journal ou de la sortie -q au format [\\Ordinateur \ objet [instance] \ compteur]. Indiquez un chemin de compteur par ligne.

  • Copie des compteurs

    Lors de son exécution, la commande Relog copie les compteurs spécifiés à partir de chaque enregistrement dans le fichier d'entrée, en convertissant le format si nécessaire. Les chemins d'accès avec des caractères génériques sont autorisés dans le fichier compteur.

  • Enregistrement des sous-ensembles de fichiers d'entrée

    Utilisez le paramètre -t pour indiquer que les fichiers d'entrée sont insérés dans des fichiers de sortie, tous les énièmes enregistrements. Par défaut, les données sont reconsignées à partir de chaque enregistrement.

  • Utilisation des paramètres -b et -e avec les fichiers journaux

    Vous pouvez spécifier que vos journaux de sortie incluent des enregistrements antérieurs à l'heure de début (-b) afin de fournir des données pour les compteurs qui nécessitent des valeurs de calcul de la valeur formatée. Le fichier de sortie comprendra les derniers enregistrements des fichiers d'entrée avec des dates antérieures au paramètre d'heure de fin (-e).

  • Utilisation de l'option -config

    Le contenu du fichier de paramètres utilisé avec l'option -config doit avoir le format suivant :

    [option_commande]

    valeur

    où option_commande est une option de la ligne de commande et valeur spécifie sa valeur. Par exemple :

    [o]

    output.txt

    [f]

    csv

    [t]

    5

  • Pour plus d'informations sur l'incorporation de Relog dans vos scripts WMI (Windows Management Instrumentation), reportez-vous à l'analyse et aux journaux de scripts à l'adresse site Web des kits de ressources Microsoft Windows.(http://www.microsoft.com/)

Exemples

Pour échantillonner les journaux de suivi existants à des intervalles fixes de 30, répertorier les chemins d'accès de compteurs, les fichiers de sortie et les formats, tapez la commande suivante :

Relog c:\perflogs\daily_trace_log.blg -cf counter_file.txt -o c:\perflogs\reduced_log.csv -t 30 -f csv

Pour échantillonner les journaux de suivi existants à des intervalles fixes de 30, répertorier les chemins d'accès de compteurs et les fichiers de sortie, tapez la commande suivante :

Relog c:\perflogs\daily_trace_log.blg -cf counter_file.txt -o c:\perflogs\reduced_log.blg -t 30


Tracerpt

Traite les journaux de suivi d'événements ou les données en temps réel des fournisseurs de suivi d'événements instrumentés et vous permet de générer des rapports d'analyse de suivi ainsi que des fichiers CSV (délimités par des virgules) pour les événements générés.

Syntaxe

tracerpt [NomFichier [nomfichier ...]] [-o [NomFichier]] [-report [NomFichier]] [-rt nom_session [nom_session ...]] [-summary [NomFichier]] [-config [NomFichier]

Paramètres

NomFichier [nomfichier ...]
Spécifie le nom du fichier de la session de suivi d'événements. Vous pouvez indiquer plusieurs fichiers.
-o [NomFichier]
Spécifie le nom du fichier CSV (délimité par des virgules). Si aucun fichier n'est spécifié, le fichier par défaut est dumpfile.csv, et non summary.txt.
-report [NomFichier]
Spécifie le nom du fichier de rapport de sortie. Le fichier par défaut est workload.txt.
-rt nom_session [nom_session ...]
Obtient des données de la source de données en temps réel. Pour utiliser cette option, incluez la session de suivi d'événements.
-summary Nom_fichier
Spécifie le nom du fichier de résumé de sortie. Le fichier par défaut est summary.txt.
-config Nom_fichier
Spécifie le chemin d'accès du fichier de paramètres contenant les paramètres de la ligne de commande. Utilisez ce paramètre pour entrer les options de ligne de commande dans un fichier.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Affichage des fichiers dumpfile.csv dans Microsoft Excel

    Lorsque vous ouvrez le format dumpfile.csv dans Microsoft Excel, vous pouvez visualiser les événements dans l'ordre chronologique. Ces fichiers incluent des enregistrements d'en-tête suivis par du texte délimité par des virgules. Ces champs d'en-tête sont répertoriés ci-dessous :

    Champ | Description
    TID | Identificateur de thread
    Temps horloge | Espace réservé événement
    Kernel (ms) | Temps processeur en mode kernel
    Utilisateur (ms) | Temps processeur en mode utilisateur
    Données utilisateur | Variable de données d'en-tête basée sur la structure MOF (Managed Object Format)
    IID | ID d'instance
    PIID | ID d'instance parent
  • Utilisation de l'option -report

    Pour utiliser l'option report, vous devez inclure un fichier « suivi Windows kernel » et tous les autres fichiers de suivi d'événements dans votre ligne de commande. En l'absence de ces éléments dans la ligne de commande, vous recevrez un message d'erreur.

  • Utilisation de l'option -summary

    Lorsque vous utilisez l'option -summary, le fichier suivant est généré :

    Fichiers traités | liste des fichiers
    Mémoires tampons totales traitées | N
    Événements totaux traités | N
    Événements totaux perdus | N
    Heure de démarrage | jj MMM aaaa hh:mm:ss.ttt
    Heure de fin | jj MMM aaaa hh:mm:ss.ttt
    Temps écoulé | N sec
  • Utilisation de l'option -config

    Le contenu du fichier de paramètres utilisé avec l'option -config doit avoir le format suivant :

    [option_commande]

    valeur

    où option_commande est une option de la ligne de commande et valeur spécifie sa valeur. Par exemple :

    [o]

    output.txt

    [report]

    report.txt

    [summary]

    summary.txt

  • Pour plus d'informations sur l'incorporation de Tracerpt dans vos scripts Windows Management Instrumentation (WMI), reportez-vous à l'analyse et aux journaux de scripts à l'adresse site Web des kits de ressources Microsoft Windows.(http://www.microsoft.com/)


Typeperf

Affiche les données du compteur de performances dans la fenêtre de commande ou dans un format de fichier journal pris en charge. Pour arrêter Typeperf, appuyez sur CTRL+C.

Syntaxe

Typeperf [Chemin [chemin...]] [-cf NomFichier] [-f {csv|tsv|bin}] [-si intervalle] [-o NomFichier] [-q [objet]] [-qx [objet]] [-sc échantillons] [-config NomFichier] [-s nom_ordinateur]

Paramètres

-c {Chemin [chemin ...] | -cf NomChemin}
Spécifie le chemin d'accès du compteur de performances à enregistrer. Pour indiquer plusieurs chemins d'accès de compteurs, séparez chaque chemin de commande par un espace.
-cf Nomfichier
Spécifie le nom de fichier du fichier qui contient les chemins des compteurs que vous voulez contrôler, à raison d'un chemin par ligne.
-f {csv|tsv|bin}
Spécifie le format du fichier de sortie. Les formats de fichiers sont csv (délimité par des virgules), tsv (délimité par des tabulations) et bin (binaire). Le format par défaut est csv.
-si interval [mm:] ss
Spécifie la durée entre les échantillons, au format [mm:] ss. La valeur par défaut est 1 seconde.
-o NomFichier
Spécifie le chemin d'accès du fichier de sortie. La valeur par défaut est stdout.
-q [objet]
Affiche et interroge les compteurs disponibles sans instances. Pour afficher les compteurs d'un objet, incluez le nom de l'objet.
-qx [objet]
Affiche et interroge tous les compteurs disponibles avec instances. Pour afficher les compteurs d'un objet, incluez le nom de l'objet.
-sc échantillons
Spécifie le nombre d'échantillons à collecter. Par défaut, l'échantillonnage se poursuit jusqu'à ce que vous appuyiez sur CTRL+C.
-config Nom_fichier
Spécifie le chemin d'accès du fichier de paramètres contenant les paramètres de la ligne de commande.
-s nom_ordinateur
Spécifie le système à contrôler si aucun serveur n'est indiqué dans le chemin du compteur.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Format du chemin d'accès du compteur

    Le format général des chemins de compteur est le suivant : [\\Ordinateur]\objet[parent/instance#index]\compteur] où :

    Les composants parent, instance, index et compteur du format peuvent contenir un nom valide ou un caractère générique. Les composants ordinateur, parent, instance et index ne sont pas nécessaires pour tous les compteurs.

    Vous déterminez les chemins d'accès des compteurs en fonction du compteur proprement dit. Par exemple, l'objet DisqueLogique a un index d'instance. Vous devez donc spécifier le #index ou un caractère générique. Par conséquent, vous pouvez utiliser le format suivant :

    \DisqueLogique(*/*#*)\*

    Par comparaison, l'objet Processus ne nécessite pas d'index d'instance. Vous pouvez donc utiliser le format suivant :

    \Processus(*)\Processus ID

    La liste ci-dessous présente les formats possibles :

    • \\machine\objet(parent/instance#index)\compteur
    • \\machine\objet(parent/instance)\compteur
    • \\machine\objet(instance#index)\compteur
    • \\machine\objet(instance)\compteur
    • \\machine\objet\compteur
    • \objet(parent/instance#index)\compteur
    • \objet(parent/instance)\compteur
    • \objet(instance#index)\compteur
    • \objet(instance)\compteur
    • \objet\compteur

    Si un caractère générique est spécifié dans le nom du parent, toutes les instances de l'objet spécifié correspondant à l'instance spécifiée et aux champs du compteur sont renvoyées.

    Si un caractère générique est spécifié dans le nom de l'instance, toutes les instances de l'objet et de l'objet parent spécifiés seront renvoyées si tous les noms d'instance correspondant à l'index spécifié correspondent au caractère générique.

    Si un caractère générique est spécifié dans le nom de compteur, tous les compteurs de l'objet spécifié sont renvoyés.

    Les chemins de compteur partiels (par exemple, pro*) ne sont pas pris en charge.

  • Format des interrogations

    Pour les interrogations pour les chemins de compteurs, utilisez le format Typeperf [{-q | -qx [\\Ordinateur\] [objet] [-o fichiersortie}].

    Utilisez les lignes de commande suivantes pour des interrogations complètes :

    Typeperf [\\Ordinateur]\objet[instance]\compteur]

    Typeperf -cf fichier entrée

  • Utilisation de l'option -config

    Le contenu du fichier de paramètres utilisé avec l'option -config doit avoir le format suivant :

    [option_commande]

    valeur

    où option_commande est une option de la ligne de commande et valeur spécifie sa valeur. Par exemple :

    [-c]

    \Windows\mypath

    [-o]

    report.csv

    [-s]

    mysystem

  • Pour plus d'informations sur l'incorporation de Typeperf dans vos scripts Windows Management Instrumentation (WMI), reportez-vous à l'analyse et aux journaux de scripts à l'adresse site Web des kits de ressources Microsoft Windows.(http://www.microsoft.com/)

Exemples

Pour afficher les compteurs de mémoire et de processeur, tapez :

typeperf "\Mémoire\Octets disponibles" "\processeur(_total)\% temps processeur"

Pour afficher les compteurs de processus toutes les trois secondes dans un format de fichier de sortie CSV, tapez :

typeperf "\Processus(Explorer)\Compteur thread" -si 3 -o typeperf.csv

Pour afficher 50 échantillons de compteurs RAS sur l'ordinateur nom_serveur, tapez :

typeperf "\port RAS(LPT1)\Octets transmis" -sc 50 -s Server_name

Pour afficher les valeurs de compteurs de 50 échantillons de compteurs figurant dans le fichier input.txt, à des intervalles d'échantillonnage de 120 secondes, tapez :

typeperf -cf input.txt -si 120 -sc 50 -f TSV -o domain2.tsv

Pour interroger les compteurs installés avec des instances, tapez la commande suivante. Notez que le paramètre -qx renverra un nombre de compteurs de performances beaucoup plus élevé que le paramètre -q.

typeperf -qx

Pour interroger des compteurs de disque physique sans instance sur l'ordinateur Server5 et les écrire dans un fichier appelé diskctrs.txt, tapez :

typeperf -q \\Server5\DisquePhyshique-o diskctrs.txt


Ntbackup

Effectuez des opérations de sauvegarde à partir de l'invite de commandes ou d'un fichier de commandes, grâce à la commande ntbackup suivie de divers paramètres.

Syntaxe

ntbackup backup [systemstate] "nom fichier @bks" /J {"nom tâche"} [/P {"nom pool"}] [/G {"nom guid"}] [/T { "nom bande"}] [/N {"nom média"}] [/F {"nom fichier"}] [/D {"description"}] [/DS {"nom serveur"}] [/IS {"nom serveur"}] [/A] [/V:{yes|no}] [/R:{yes|no}] [/L:{f|s|n}] [/M {type sauvegarde}] [/RS:{yes|no}] [/HC:{on|off}] [/SNAP:{on|off}]

Paramètres

systemstate
Indique que vous voulez sauvegarder les données sur l'état du système. Lorsque vous sélectionnez cette option, le type de sauvegarde passera à normale ou copie.
nom fichier @bks
Spécifie le nom du fichier de sélection de sauvegarde (fichier .bks) à utiliser pour cette opération. Le caractère (@) doit précéder le nom du fichier de sélection de sauvegarde. Un fichier de sélection de sauvegarde contient des informations sur les fichiers et les dossiers sélectionnés pour la sauvegarde. Vous devez créer ce fichier à partir de l'interface utilisateur graphique (GUI) de l'utilitaire de sauvegarde.
/J {"nom tâche"}
Spécifie le nom de la tâche à utiliser dans le fichier journal. Le nom de la tâche décrit généralement les fichiers et les dossiers en cours de sauvegarde, ainsi que la date et l'heure de leur sauvegarde.
/P {"nom pool"}
Spécifie le pool de médias à partir duquel vous souhaitez utiliser le média. Il s'agit généralement d'un sous-ensemble de la liste des médias de sauvegarde, tel que 4mm DDS. Si vous sélectionnez ce paramètre, vous ne pouvez pas utiliser les options de ligne de commande /A, /G, /F ou /T.
/G {"nom GUID"}
Remplace ou effectue un ajout à cette bande. N'utilisez pas ce commutateur en même temps que /P.
/T {"nom bande"}
Remplace ou effectue un ajout à cette bande. N'utilisez pas ce commutateur en même temps que /P.
/N {"nom média"}
Spécifie le nouveau nom de la bande. Vous ne devez pas utiliser /A avec ce commutateur.
/F {"nom fichier"}
Chemin du disque logique et nom de fichier. Vous ne devez pas utiliser les commutateurs suivants avec ce commutateur : /P /G /T.
/D {"description jeu"}
Spécifie une étiquette pour chaque jeu de sauvegarde.
/DS {"nom serveur"}
Sauvegarde le fichier du service d'annuaire pour le serveur Microsoft Exchange spécifié.
/IS {"nom serveur"}
Sauvegarde le fichier du magasin d'informations pour le serveur Microsoft Exchange spécifié.
/A
Effectue un ajout. /G ou /T doivent être utilisés avec ce commutateur. N'utilisez pas ce commutateur en même temps que /P.
/V:{yes|no}
Vérifie les données une fois la sauvegarde terminée.
/R:{yes|no}
Limite l'accès à la bande au propriétaire ou aux membres du groupe Administrateurs.
/L:{f|s|n}
Spécifie le type du fichier journal : f=full (complet), s=summary (résumé), n=none (aucun fichier journal n'est créé).
/M {type sauvegarde}
Spécifie le type de sauvegarde. Il doit s'agir de l'une des options suivantes : normale, copie, différentielle, incrémentielle ou quotidienne.
/RS:{yes|no}
Sauvegarde les fichiers de données migrés dans le stockage étendu. L'option /RS de la ligne de commande n'est pas nécessaire pour sauvegarder la base de données destockage étendu locale (qui contient les fichiers de substitution de stockage étendu). Lorsque vous sauvegardez le dossier %racinesystème%, la base de données de stockage étendu est également sauvegardée automatiquement.
/HC:{on|off}
Utilise si possible, la compression matérielle sur le lecteur de bande.
/SNAP:{on|off}
Spécifie si la sauvegarde est, ou non, un instantané du volume.
/M {type sauvegarde}
Spécifie le type de sauvegarde. Il doit s'agir de l'une des options suivantes : normale, copie, différentielle, incrémentielle ou quotidienne.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous ne pouvez pas restaurer des fichiers depuis la ligne de commande, à l'aide de la commande ntbackup.
  • Les options suivantes de la ligne de commande prennent les valeurs par défaut définies dans l'interface utilisateur graphique (GUI) de l'utilitaire de sauvegarde, sauf si elles sont modifiées par une option de la ligne de commande : /V /R /L /M /RS /HC. Par exemple, si la compression matérielle est activée dans la boîte de dialogue Options de l'utilitaire de sauvegarde, elle est utilisée à condition que /HC ne figure pas dans la ligne de commande. Cependant, si vous indiquez /HC:off dans la ligne de commande, cette option annule le paramètre de la boîte de dialogue Option et la compression n'est pas utilisée.
  • Si vous disposez des services Windows Media sur votre ordinateur, et que vous souhaitez sauvegarder les fichiers associés à ces services, consultez « Exécuter une sauvegarde avec les Services Windows Media » dans la documentation en ligne des services Windows Media. Vous devez suivre les procédures décrites dans cette documentation en ligne avant de sauvegarder ou de restaurer les fichiers associés aux services Windows Media.
  • Vous pouvez sauvegarder les données sur l'état du système uniquement sur un ordinateur local. Vous ne pouvez pas sauvegarder les données sur l'état du système sur un ordinateur distant
  • Si vous utilisez le Stockage amovible pour gérer des médias, ou le Stockage étendu pour stocker des données, vous devez sauvegarder régulièrement les fichiers situés dans les dossiers suivants :

    RacineSystème\System32\Ntmsdata

    RacineSystème\System32\Remotestorage

    Cette opération permet de garantir la restauration de la totalité des données du Stockage amovible et du Stockage étendu.

Exemples

Exemple 1

L'exemple suivant effectue une sauvegarde normale appelée « Mon travail 1 » du partage distant \\iggy-multi\c$. Cet exemple extrait une bande du pool de médias de sauvegarde, et la nomme « Sauvegarde ligne de commande 1 ». « Fonctionnalité ligne de commande » correspond à la description de la sauvegarde. La sauvegarde est vérifiée une fois terminée, son accès n'est pas restreint au propriétaire/administrateur, le niveau de journalisation n'est défini qu'au résumé, les données du Stockage étendu ne sont pas sauvegardées, et la compression matérielle est activée.

ntbackup backup \\iggy-multi\c$ /m normal /j "My Job 1" /p "Backup" /n "Command Line Backup 1" /d "Fonctionnalité ligne de commande" /v:yes /r:no /l:s /rs:no /hc:on

Exemple 2

L'exemple suivant effectue une sauvegarde de copie appelée « Mon travail 2 » du lecteur local D:\. Les fichiers et les dossiers sauvegardés sont ajoutés à la bande nommée « Sauvegarde ligne de commande 1 ». Par défaut, toutes les autres options sont celles spécifiées dans le programme de sauvegarde.

ntbackup backup d:\ /j "My Job 2" /a /t "Sauvegarde ligne de commande 1" /m copy

Exemple 3

L'exemple suivant effectue une sauvegarde en fonction du type de sauvegarde spécifié dans le programme de sauvegarde. Il utilise le fichier de sélection de sauvegarde nommé Lignecommande.bks, qui est situé dans le répertoire C:\Program Files\Windows NT\ntbackup\data\, afin de choisir les fichiers à sauvegarder. La sauvegarde est nommée « Mon travail 3 » et doit remplacer la bande nommée « Sauvegarde ligne de commande 1 » par « Sauvegarde ligne de commande 2 ».

ntbackup backup "@C:\Program Files\Windows NT\ntbackup\data\commandline.bks" /j "My Job 3" /t "Sauvegarde ligne de commande 1" /n "Sauvegarde ligne de commande 2"

Exemple 4

Les exemples suivants indiquent comment effectuer une sauvegarde dans un fichier à partir de la ligne de commande. Dans ces trois exemples, le type de sauvegarde, le paramètre de vérification, le niveau de journalisation, la compression matérielle, et toutes les autres restrictions utilisées correspondent aux valeurs par défaut du programme de sauvegarde. Le premier exemple indique comment sauvegarder \\iggy-multi\d$ dans le fichier D:\sauvegarde.bkf. Le deuxième exemple indique comment ajouter la même sauvegarde au même fichier. Le troisième exemple indique comment remplacer ce fichier à partir de la même sauvegarde. Dans ces trois exemples, un nom UNC complet peut remplacer la lettre du lecteur (en l'occurrence, au lieu de d:\sauvegarde.bkf, l'utilisateur peut spécifier \\iggy-multi\d$\sauvegarde.bkf comme destination de la sauvegarde).

ntbackup backup \\iggy-multi\d$ /j "Sauvegarde ligne de commande 4" /f "D:\backup.bkf"

ntbackup backup \\iggy-multi\d$ /j "Sauvegarde ligne de commande 5" /f "D:\sauvegarde.bkf" /a

ntbackup backup \\iggy-multi\d$ /j "Sauvegarde ligne de commande 6" /f "D:\backup.bkf"


Ntcmdprompt

Exécute l'interpréteur de commandes Cmd.exe, au lieu de Command.com, après l'exécution d'un programme résident en mémoire ou après le lancement de l'invite de commandes à partir d'une application MS-DOS.

Syntaxe

ntcmdprompt

Paramètres

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Lors de l'exécution de Command.com, certaines fonctionnalités de Cmd.exe, telles que l'affichage doskey de l'historique des commandes, ne sont pas disponibles. Si vous préférez exécuter l'interpréteur des commandes Cmd.exe après avoir lancé un programme résident en mémoire (TSR) ou l'invite de commandes à partir d'une application MS-DOS, vous pouvez utiliser la commande ntcmdprompt. Cependant, n'oubliez pas que le programme TSR peut ne pas être disponible lorsque vous exécutez Cmd.exe. Vous pouvez inclure la commande ntcmdprompt dans votre fichier Config.nt ou le fichier de démarrage personnalisé équivalent dans le fichier PIF (fichier d'informations programme) d'une application.

Exemples

Pour inclure ntcmdprompt dans votre fichier Config.nt ou dans le fichier de démarrage de configuration spécifié dans le fichier PIF, tapez :

ntcmdprompt

XOX

Rubriques connexes


Ntsd

La commande Ntsd est incluse en option pour les développeurs logiciels. Seuls les développeurs système doivent utiliser cette commande. Pour plus d'informations, consultez le fichier d'aide inclus dans NTSD.


Openfiles

Interroge ou affiche les fichiers ouverts. Interroge, affiche ou déconnecte également les fichiers ouverts par les utilisateurs du réseau.

Pour afficher la syntaxe d'une commande, cliquez sur une commande :

openfiles disconnect

Déconnecte un ou plusieurs utilisateurs à distance connectés à des fichiers partagés ouverts.

Syntaxe

openfiles.exe /disconnect [/s Ordinateur [/u Domaine\Utilisateur [/p Mot de passe]]] {[/id IDFichierOuvert]|[/a NomUtilisateur]|[/o ModeOuvert]} [/se NomSession] [/op NomFichierOuvert]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant. (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur qui émet la commande.
/p Mot de passe
Spécifie le mot de passe du compte utilisateur spécifié par le paramètre /u.
/id IDFichierOuvert
Déconnecte le fichier ouvert avec l'IDFichierOuvert numérique spécifié sur l'ordinateur spécifié par le paramètre /s. Utilisez openfiles.exe /query pour connaître l'ID du fichier. Le caractère générique (*) peut être utilisé pour déconnecter tous les fichiers ouverts sur l'ordinateur spécifié.
/a NomUtilisateur
Déconnecte tous les fichiers ouverts qui ont été ouverts par l'utilisateur spécifié sur l'ordinateur spécifié par le paramètre /s. Le caractère générique (*) peut être utilisé pour déconnecter tous les fichiers ouverts sur l'ordinateur spécifié.
/o ModeOuvert
Déconnecte tous les fichiers ouverts avec le ModeOuvert spécifié sur l'ordinateur spécifié par le paramètre /s. Le paramètre ModeOuvert inclut les modes Lecture/Écriture et Lecture. Le caractère générique (*) peut être utilisé pour déconnecter tous les fichiers ouverts sur l'ordinateur spécifié.
/se NomSession
Déconnecte tous les fichiers ouverts qui ont été créés par la session spécifiée sur l'ordinateur spécifié par le paramètre /s. Le caractère générique (*) peut être utilisé pour déconnecter tous les fichiers ouverts sur l'ordinateur spécifié.
/op NomFichierOuvert
Déconnecte le fichier ouvert qui a été créé avec le NomFichierOuvert spécifié sur l'ordinateur spécifié par le paramètre /s. Le caractère générique (*) peut être utilisé pour déconnecter tous les fichiers ouverts sur l'ordinateur spécifié.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants indiquent comment la commande openfiles /disconnect peut être utilisée :

openfiles.exe /disconnect /id 1
openfiles.exe /disconnect /a hiropln
openfiles.exe /disconnect /o read/write
openfiles.exe /disconnect /op "c:\my documents\somedoc.doc"
openfiles /disconnect /session machine /id 5
openfiles.exe /disconnect /s srvmain /u maindom\hiropln /id 5
openfiles /disconnect /s srvmain /u maindom\hiropln /p p@ssW23 /id *

openfiles query

Interroge et affiche tous les fichiers ouverts.

Syntaxe

openfiles.exe /query [/s Ordinateur [/u Domaine\Utilisateur [/p Mot de passe]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas les barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur qui émet la commande.
/p Mot de passe
Spécifie le mot de passe du compte utilisateur spécifié par le paramètre /u.
/fo {TABLE|LIST|CSV}
Spécifie le format à utiliser pour la sortie de la requête. Les valeurs valides sont TABLE, LIST et CSV. La valeur de sortie par défaut est TABLE.
/nh
Supprime l'en-tête de colonne dans la sortie. Valide uniquement lorsque le paramètre /fo correspond à TABLE ou CSV.
/v
Spécifie l'affichage des commentaires sur les tâches dans la sortie.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants indiquent comment la commande openfiles /query peut être utilisée :

openfiles.exe /query
openfiles.exe /query /fo table /nh
openfiles.exe /query /fo list /v
openfiles.exe /query /s srvmain /u maindom\hiropln /p p@ssW23


Pagefileconfig.vbs

Permet à un administrateur d'afficher et de configurer les paramètres de mémoire virtuelle d'un fichier d'échange d'un système.

Pour connaître la syntaxe d'une commande, cliquez sur une commande :

pagefileconfig change

Modifie les paramètres de mémoire virtuelle d'un fichier d'échange d'un système.

Syntaxe

pagefileconfig[.vbs] /change [/s Ordinateur [/u Domaine\Utilisateur [/p Mot de passe]]] {[/i TailleInitialeFichierÉchange]|[/m TailleMaximaleFichierÉchange]} /vo {LettreVolume|*} [/vo {LettreVolume2|*} [...]]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute le script avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur qui émet la commande.
/p Mot de passe
Spécifie le mot de passe du compte utilisateur spécifié par le paramètre /u.
/i TailleInitialeFichierÉchange
Spécifie la nouvelle taille initiale (en Mo) à utiliser pour le fichier d'échange spécifié.
/m TailleMaximaleFichierÉchange
Spécifie la nouvelle taille maximale (en Mo) à utiliser pour le fichier d'échange spécifié.
/vo {LettreVolume|*}
Spécifie le volume ou les volumes des paramètres du fichier d'échange à modifier. Le volume est spécifié par une lettre suivie d'un signe deux-points (par exemple "C:").
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants indiquent comment la commande openfiles /change peut être utilisée :

pagefileconfig.vbs /change /m 400 /vo c:
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /m 400 /vo c:
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /i 20 /vo *
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /p p@ssW23 /i 200 /m 500 /vo c: /vo d:

pagefileconfig create

Crée ou ajoute un fichier d'échange supplémentaire à un système.

Syntaxe

pagefileconfig.vbs /create [/s Ordinateur [/u Domaine\Utilisateur [/p Mot de passe]]] /i TailleInitialeFichierÉchange /m TailleMaximaleFichierÉchange /vo {LettreVolume|*} [/vo {LettreVolume2|*} [...]]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute le script avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur qui émet la commande.
/p Mot de passe
Spécifie le mot de passe du compte utilisateur spécifié par le paramètre /u.
/i TailleInitialeFichierÉchange
Spécifie la nouvelle taille initiale (en Mo) à utiliser pour le fichier d'échange spécifié.
/m TailleMaximaleFichierÉchange
Spécifie la nouvelle taille maximale (en Mo) à utiliser pour le fichier d'échange spécifié.
/vo {LettreVolume|*}
Spécifie le volume ou les volumes des paramètres du fichier d'échange à créer. Le volume est spécifié par une lettre suivie d'un signe deux-points (par exemple "C:").
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants indiquent comment la commande pagefileconfig /create peut être utilisée :

pagefileconfig.vbs /create /i 140 /m 300 /vo d:
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /i 150 /m 300 /vo d:
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /i 50 /m 200 /vo *
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /p p@ssW23 /i 100 /m 600 /vo d: /vo e: /vo f:

pagefileconfig delete

Supprime un fichier d'échange d'un système.

Syntaxe

pagefileconfig.vbs /delete [/s Ordinateur [/u Domaine\Utilisateur [/p Mot de passe]]] /vo {LettreVolume|*} [/vo {LettreVolume2|*} [...]]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute le script avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur qui émet la commande.
/p Mot de passe
Spécifie le mot de passe du compte utilisateur spécifié par le paramètre /u.
/vo {LettreVolume|*}
Spécifie le volume ou les volumes des paramètres du fichier d'échange à supprimer. Le volume est spécifié par une lettre suivie d'un signe deux-points (par exemple "C:").
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants indiquent comment la commande pagefileconfig /delete peut être utilisée :

pagefileconfig.vbs /delete /vo d:
pagefileconfig.vbs /delete /s srvmain /u maindom\hiropln /vo d:
pagefileconfig.vbs /delete /s srvmain /u maindom\hiropln /p p@ssW23 /vo d: /vo e: /vo f:

pagefileconfig query

Interroge et affiche les paramètres de mémoire virtuelle d'un fichier d'échange d'un système.

pagefileconfig.vbs /query [/s Ordinateur [/u Domaine\Utilisateur [/p Mot de passe]]] [/fo {TABLE|LIST|CSV}]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute le script avec les autorisations de compte de l'utilisateur spécifié par Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur qui émet la commande.
/p Mot de passe
Spécifie le mot de passe du compte utilisateur spécifié par le paramètre /u.
/fo {TABLE|LIST|CSV}
Spécifie le format à utiliser pour la sortie de la requête. Les valeurs valides sont TABLE, LIST et CSV. La syntaxe par défaut est LIST.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants indiquent comment la commande pagefileconfig /query peut être utilisée :

pagefileconfig.vbs /query
pagefileconfig.vbs /query /fo table
pagefileconfig.vbs /query /s srvmain /u maindom\hiropln
pagefileconfig.vbs /query /s srvmain /u maindom\hiropln /p p@ssW23 /fo list

Remarques

  • La taille maximale du fichier d'échange est limitée à l'espace disque disponible moins les paramètres de récupération après vidage sur incident pour le lecteur d'amorçage.


Path

Définit la commande path dans la variable d'environnement PATH, qui correspond aux répertoires utilisés pour rechercher les fichiers exécutables. Si vous utilisez la commande path sans paramètre, elle affiche le chemin de commande actuel.

Syntaxe

path [[%path%] [Lecteur:]Chemin [;...]]

Paramètres

[Lecteur:]Chemin
Spécifie le lecteur et le répertoire à définir dans le chemin de la commande.
;
Sépare les répertoires dans le chemin de la commande.
%path%
Indique à Windows XP d'ajouter le chemin de la commande au groupe de répertoires figurant dans la variable d'environnement PATH.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de ;

    Lorsque ; est le seul paramètre utilisé, la valeur du chemin de commande trouvée dans la variable PATH est supprimée.

  • Utilisation de %path%

    Lorsque vous incluez %path% dans la syntaxe, Cmd.exe remplace ce paramètre par la valeur du chemin de commande trouvée dans la variable PATH ; par conséquent, il n'est plus nécessaire d'entrer manuellement ces valeurs dans la ligne de commande. Pour plus d'informations sur le remplacement des valeurs de variables d'environnement, consultez Vue d'ensemble de l'invite de commandes dans la section Rubriques connexes.

  • Répertoire actuel

    Le système d'exploitation effectue toujours la recherche dans le répertoire actuel, avant de poursuivre la recherche dans les répertoires dans le chemin de commande.

  • Fichiers portant les mêmes noms et des extensions différentes

    Certains fichiers au sein du même répertoire peuvent porter le même nom mais utiliser des extensions différentes. Par exemple, dans un répertoire, un fichier nommé Accnt.com peut démarrer un programme de comptabilité et un autre fichier nommé Accnt.bat peut connecter votre système au réseau du système de comptabilité.

    Le système d'exploitation recherche un fichier en utilisant les extensions de noms de fichiers par défaut dans l'ordre de priorité suivant : .exe, .com, .bat et .cmd. Pour exécuter le fichier Accnt.bat lorsque le fichier Accnt.com se trouve dans le même répertoire, vous devez inclure l'extension .bat dans la ligne de commande.

  • Présence d'au moins deux noms de fichiers identiques dans le chemin d'accès

    Si plusieurs fichiers dans le chemin de la ligne de commande portent le même nom et la même extension, Windows XP recherche d'abord le nom de fichier spécifié dans le répertoire actuel, puis dans les répertoires dans le chemin de ligne de commande, en respectant l'ordre dans lequel ils apparaissent dans PATH.

  • Recherche du sous-système MS-DOS

    Si vous placez la commande path dans votre fichier Autoexec.nt, le chemin de recherche spécifié du sous-système MS-DOS est automatiquement ajouté au chemin de recherche de Windows XP chaque fois que vous ouvrez une session sur l'ordinateur. Le fichier Cmd.exe n'utilise pas le fichier Autoexec.nt. Lorsque vous exécutez fichier Cmd.exe à partir d'un raccourci, il hérite des variables d'environnement définies dans Poste de travail/Propriétés/Avancé/Environnement.

Exemples

La commande suivante spécifie que Windows XP doit rechercher des commandes externes dans trois répertoires. Les chemins de ces répertoires sont C:\Utilisateur\Taxes, B:\Utilisateur\Invest et B:\Bin :

path c:\user\taxes;b:\user\invest;b:\bin


Pathping

Fournit des informations sur la latence du réseau et la perte réseau au niveau des relais intermédiaires entre une source et une destination. La commande Pathping envoie plusieurs messages requête d'écho à chaque routeur entre une source et une destination sur une période donnée, puis calcule les résultats en fonction des paquets renvoyés par chaque routeur. Étant donné que pathping affiche le degré de perte de paquets au niveau de n'importe quel routeur ou lien, vous pouvez déterminer quels routeurs ou sous-réseaux peuvent être confrontés à des problèmes de réseau. La commande pathping est l'équivalent de la commande tracert : elle identifie les routeurs qui se trouvent sur l'itinéraire. Ensuite, elle envoie régulièrement des commandes ping à tous les routeurs sur une période spécifiée et calcule les statistiques en fonction des chiffres renvoyés. Utilisée sans paramètres, la commande pathping affiche l'aide.

Syntaxe

pathping [-n] [-h RelaisMaximum] [-g ListeHôte] [-p Délai] [-q NombreInterrogations [-w Temporisation] [-T] [-R] [NomCible]

Paramètres

-n
Empêche pathping d'effectuer la résolution de noms d'adresses IP de routeurs intermédiaires. Ceci peut accélérer l'affichage des résultats de pathping.
-h RelaisMaximum
Spécifie le nombre maximal de relais dans le chemin d'accès pour rechercher la cible (destination). La valeur par défaut est 30 relais.
-g ListeHôte
Spécifie que les messages requête d'écho utilisent l'option Itinéraire source libre de l'en-tête IP avec l'ensemble des destinations intermédiaires spécifiées dans ListeHôte. Avec le routage de source souple, les destinations intermédiaires successives peuvent être séparées par un ou plusieurs routeurs. Le nombre maximal d'adresses ou de noms de la liste d'hôtes équivaut à 9. La ListeHôte est une série d'adresses IP (en notation décimale à point) séparées par des espaces.
-p Délai
Spécifie le nombre de millisecondes d'attente entre les commandes ping consécutives. La valeur par défaut est 250 millisecondes (1/4 seconde).
-q NombreInterrogations
Spécifie le nombre de messages requête écho envoyés à chaque routeur sur l'itinéraire. La valeur par défaut est 100 interrogations.
-w Temporisation
Spécifie le nombre de millisecondes d'attente pour chaque réponse. La valeur par défaut est 3 000 millisecondes (3 secondes).
-T
Associe une balise de priorité de type Layer-2 (par exemple, 802.1p) aux messages requête écho envoyés à chacun des périphériques réseau sur l'itinéraire. Cela permet d'identifier les périphériques réseau qui ne sont pas configurés pour la fonctionnalité de type Layer-2. Ce commutateur est utilisé pour tester la connectivité QoS (Quality of Service).
-R
Détermine si chaque périphérique réseau sur l'itinéraire prend en charge le protocole RSVP (Resource Reservation Setup Protocol), qui permet à l'ordinateur hôte de réserver une quantité de bande passante spécifiée pour un flux de données. Ce commutateur est utilisé pour tester la connectivité QoS (Quality of Service).
NomCible
Spécifie la destination, identifiée soit par l'adresse IP, soit par un nom d'hôte.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les paramètres de Pathping respectent la casse.
  • Pour éviter toute congestion du réseau, les commandes ping doivent être envoyées à rythme assez lent.
  • Pour réduire les effets des pertes de transmission en rafale, évitez d'envoyer des commandes ping trop fréquemment.
  • Lorsque vous utilisez le paramètre -p, les commandes ping sont envoyées séparément à chaque relais intermédiaire. Pour cette raison, l'intervalle entre deux commandes ping envoyées au même relais est délai multiplié par le nombre de relais.
  • Lorsque vous utilisez le paramètre -w, plusieurs commandes ping peuvent être envoyées en parallèle. Pour cette raison, la durée spécifiée dans le paramètre Temporisation n'est pas liée à la durée spécifiée dans le paramètre Délai pour l'attente entre les commandes ping.
  • Utilisation du paramètre -T

    • L'activation de la priorité de type Layer-2 sur l'ordinateur hôte permet aux paquets d'être envoyés avec une balise de priorité de type Layer-2, laquelle peut être utilisée par les périphériques de type Layer-2 pour affecter une priorité au paquet. Les périphériques anciens qui ne reconnaissent pas la priorité de type layer-2 rejetteront ces paquets dans la mesure où ils sembleront incorrects. Ce paramètre vous aide à identifier les ordinateurs réseau qui rejettent ces paquets.

  • Utilisation du paramètre -R

    • Un message de réservation RSVP pour une session inexistante est envoyé à chaque périphérique réseau sur l'itinéraire. Si le périphérique ne prend pas en charge RSVP, il renvoie un message d'inaccessibilité du protocole ICMP (Internet Control Message Protocol). Si le périphérique prend en charge RSVP, il renvoie un message d'erreur de réservation RSVP. Certains périphériques ne renvoient aucun des deux types de messages. Si tel est le cas, un message de délai dépassé s'affiche.

  • Cette commande est disponible uniquement si le protocole Internet Protocol (TCP/IP) est installé comme composant dans les propriétés d'une carte réseau dans Connexions réseau.

Exemples

Les exemples suivants présentent la sortie de la commande pathping :

D:\>pathping -n corp1

Itinéraire vers corp1 [10.54.1.196]

sur un maximum de 30 relais :

  0  172.16.87.35

  1  172.16.87.218

  2  192.168.52.1

  3  192.168.80.1

  4  10.54.247.14

  5  10.54.1.196

Calcul des statistiques pour 125 secondes...

            De la source vers ici   Ce nœud/lien

Relais RTT    Perdu/Envoyé = %  Perdu/Envoyé = %  Adresse

  0                                           172.16.87.35

                                0/ 100 =  0%   |

  1   41ms     0/ 100 =  0%     0/ 100 =  0%  172.16.87.218

                               13/ 100 = 13%   |

  2   22ms    16/ 100 = 16%     3/ 100 =  3%  192.168.52.1

                                0/ 100 =  0%   |

  3   24ms    13/ 100 = 13%     0/ 100 =  0%  192.168.80.1

                                0/ 100 =  0%   |

  4   21ms    14/ 100 = 14%     1/ 100 =  1%  10.54.247.14

                                0/ 100 =  0%   |

  5   24ms    13/ 100 = 13%     0/ 100 =  0%  10.54.1.196

Suivi terminé.

Lorsque la commande pathping est exécutée, les premiers résultats indiquent le chemin. Il s'agit du même itinéraire que celui qui est indiqué en utilisant la commande tracert. Ensuite, un message occupé s'affiche durant approximativement 90 secondes (la durée varie en fonction du nombre de relais). Pendant ce temps, des informations provenant de tous les routeurs répertoriés précédemment et des liaisons qui les relient sont rassemblées. À la fin de cette période, les résultats du test s'affichent.

Dans l'exemple de rapport précédent, les colonnes Ce noeud/Lien, Perdu/Envoyé = % et Adresse montrent que la liaison entre 172.16.87.218 et 192.168.52.1 perd 13 % des paquets. Les routeurs situés au niveau des relais 2 et 4 perdent également des paquets qui leur sont adressés, mais cette perte n'a aucune incidence sur leur capacité à transférer le trafic qui ne leur est pas adressé.

Les taux de pertes affichés pour les liaisons, identifiées par une barre verticale (|) dans la colonne Adresse, indiquent une congestion de la liaison, provoquant la perte de paquets transférés sur l'itinéraire. Les taux de pertes affichés pour les routeurs (identifiés par leurs adresses IP) indiquent que ces routeurs peuvent être surchargés.


Pause

Interrompt le traitement d'un programme de commandes et affiche un message invitant l'utilisateur à appuyer sur une touche pour continuer.

Syntaxe

pause

Paramètres

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Lorsque vous exécutez la commande prompt, le message suivant apparaît :

    Appuyez sur une touche pour continuer. . .

  • Si vous appuyez sur CTRL+C pour arrêter un programme de commandes, le message suivant apparaît :

    Voulez-vous terminer le programme de commandes (O/N) ?

    Si vous tapez O (pour oui) en réponse à ce message, le programme de commandes s'arrête et le contrôle repasse au système d'exploitation. Vous pouvez donc insérer la commande pause avant une section du fichier de commandes que vous ne voulez pas traiter. Lorsque pause interrompt le traitement du programme de commandes, appuyez sur CTRL+C, puis O pour arrêter ce programme.

Exemples

Pour créer un programme de commandes qui invite l'utilisateur à changer de disquette dans l'un des lecteurs, tapez :

@echo off
:begin
copy a:*.*
echo Placez une nouvelle disquette dans le lecteur A
pause
goto begin

Dans cet exemple, tous les fichiers de la disquette insérée dans le lecteur A sont copiés dans le répertoire en cours. Lorsque le commentaire affiché vous invite à placer une autre disquette dans le lecteur A, la commande pause interrompt le traitement afin de vous permettre de changer de disquette, puis d'appuyer sur une touche pour reprendre le traitement. Ce programme de commandes produit une boucle sans fin. La commande goto BEGIN renvoie l'interpréteur de commandes à l'étiquette début du fichier de commandes. Pour arrêter ce programme de commandes, appueyz sur CTRL+C, puis sur O.


Pbadmin

Administre les annuaires téléphoniques. Utilisée sans paramètre, la commande pbadmin démarre l'Administrateur des annuaires téléphoniques.

Syntaxe

pbadmin.exe /N NomAnnuaireTéléphonique [/R CheminFichierRégions\NomFichierRégions] [/P CheminFichierDonnées\NomFichierDonnées]

pbadmin.exe /I NomAnnuaireTéléphonique [/R CheminFichierRégions\NomFichierRégions

pbadmin.exe /I NomAnnuaireTéléphonique /P CheminFichierDonnées\NomFichierDonnées

pbadmin.exe /O NomAnnuaireTéléphonique NomServeur Mot de passe Utilisateur

pbadmin.exe /B NomAnnuaireTéléphonique

Paramètres

/N NomAnnuaireTéléphonique
Crée un annuaire téléphonique (.mdb). Le paramètre NomAnnuaireTéléphonique spécifie le nom du fichier à créer.
/ NomAnnuaireTéléphonique
Importe des données dans un annuaire (.mdb) à partir d'un fichier de régions (.txt) ou d'un fichier d'annuaire téléphonique (.pbk ou .txt). Le paramètre NomAnnuaireTéléphonique spécifie l'annuaire téléphonique dans lequel vous voulez importer les données. Vous devez utiliser le paramètre /R ou /P avec le paramètre /I.
/R CheminFichierRégions\NomFichierRégions
Spécifie l'emplacement et le nom du fichier de régions que vous voulez importer dans un annuaire téléphonique.
/P CheminFichierDonnées\NomFichierDonnées
Spécifie l'emplacement et le nom du fichier d'annuaire téléphonique (.pbk or .txt) que vous voulez importer dans un annuaire téléphonique.
/O NomAnnuaireTéléphonique NomServeur Mot de passe Utilisateur
Configure les options d'un annuaire téléphonique. Le paramètre NomAnnuaireTéléphonique spécifie le nom de l'annuaire téléphonique pour lequel vous voulez définir des options. Le paramètre NomServeur spécifie le nom du serveur sur lequel l'annuaire téléphonique est publié. Le paramètre NomUtilisateur spécifie un compte utilisateur avec des autorisations FTP sur le serveur PBS (Phone Book Service). Le paramètre Mot de passe spécifie le mot de passe du compte utilisateur sur le serveur PBS.
/B NomAnnuaireTéléphonique
Publie un annuaire téléphonique. Le paramètre NomAnnuaireTéléphonique spécifie le nom de l'annuaire téléphonique à publier. Avant d'utiliser le paramètre /B, vous devez configurer l'annuaire téléphonique avec le paramètre /O.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour créer un annuaire téléphonique (.mdb), utilisez la syntaxe suivante :

    • pbadmin.exe /N NomAnnuaireTéléphonique [/R CheminFichierRégions\NomFichierRégions] [/P CheminFichierDonnées\NomFichierDonnées]

  • Pour importer des données dans un annuaire téléphonique à partir d'un fichier de régions, utilisez la syntaxe suivante :

    • pbadmin.exe /I NomAnnuaireTéléphonique [/R CheminFichierRégions\NomFichierRégions

  • Pour importer des données dans un annuaire téléphonique à partir d'un fichier d'annuaire téléphonique (.pbk) ou d'un fichier texte (.txt) au format approprié, utilisez la syntaxe suivante :

    • pbadmin.exe /I NomAnnuaireTéléphonique /P CheminFichierDonnées\NomFichierDonnées

  • Pour configurer les options de publication d'un annuaire téléphonique, utilisez la syntaxe suivante :

    • pbadmin.exe /O NomAnnuaireTéléphonique NomServeur Mot de passe Utilisateur

  • Pour publier un annuaire téléphonique, utilisez la syntaxe suivante :

    • pbadmin.exe /B NomAnnuaireTéléphonique

  • Pour pbadmin, le terme « annuaire » fait référence à un annuaire téléphonique (.mdb), et le terme « fichier annuaire » fait référence à un fichier d'annuaire téléphonique (.pbk).
  • Les paramètres de la ligne de commande respectent la casse.
  • Un annuaire téléphonique doit comporter au maximum huit caractères et ne doit pas comporter uniquement des chiffres. Il ne doit contenir aucun espace ni les symboles suivants : ! , ; * = / \ : ? ' " < > | . & % {} [] @ ( ) ´ ` ~
  • Si vous spécifiez un chemin d'accès, vous devez spécifier le chemin complet. Vous ne pouvez pas utiliser d'espaces dans le chemin d'accès à l'annuaire téléphonique, à un fichier d'annuaire téléphonique ou à un fichier de régions.
  • Pour utiliser la commande pbadmin, vous devez installer l'Administrateur des annuaires téléphoniques puis taper la commande à partir de l'annuaire PBA. Pour installer l'Administrateur des annuaires téléphoniques, insérez le CD d'installation de Windows XP Professionnel ou de Windows 2000 dans votre lecteur de CD-ROM, puis cliquez sur Parcourir ce CD. Ouvrez le dossier VALUEADD, ouvrez le dossier MSFT, ouvrez le dossier MGMT, puis ouvrez le dossier PBA. Double-cliquez sur PBAINST, puis suivez les instructions qui s'affichent à l'écran.

Exemples

Dans les exemples suivants, des données fictives sont utilisées.

Pour créer un annuaire nommé Références, tapez :

pbadmin.exe /N Références

Pour importer des données dans un annuaire téléphonique nommé Références à partir d'un fichier de régions nommé Région1.txt qui est situé dans le répertoire C:\Temp, tapez :

pbadmin.exe /I Références /R C:\Temp\Région1.txt

Pour configurer un annuaire téléphonique avec le nom Références, le nom de serveur Rainier, le nom d'utilisateur PaulB et le mot de passe MonMotdePasse, tapez :

pbadmin.exe /O Références Rainier PaulB MonMotdePasse

Pour publier un annuaire nommé Références, tapez :

pbadmin.exe /B Références


Pentnt

Détecte, s'il y a lieu, les erreurs de division en virgule flottante du Pentium, désactive la virgule flottante du processeur et active son émulation.

Syntaxe

pentnt [-c] [-f] [-o]

Paramètres

-c
Active l'émulation conditionnelle.
-f
Active l'émulation forcée.
-o
Désactive l'émulation forcée et active à nouveau la virgule flottante du processeur si elle est disponible.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les paramètres utilisés avec cette commande doivent être précédés d'un tiret (-) et non d'une barre oblique (/).
  • Utilisation de l'option -c de la ligne de commande

    L'émulation de virgule flottante est activée seulement si lors du démarrage, le système détecte une erreur de division en virgule flottante du processeur Pentium. Si vous choisissez ce paramètre, vous devez redémarrer l'ordinateur pour que les modifications soient prises en compte.

  • Lorsque vous utilisez l'option de la ligne de commande -f, la virgule flottante du processeur est désactivée et l'émulation de virgule flottante est toujours forcée, que le système affiche l'erreur de division en virgule flottante du Pentium ou non. Ce paramètre est très utile pour tester des émulateurs logiciels et pour contourner les défauts matériels reconnus par le système d'exploitation. Si vous choisissez ce paramètre, vous devez redémarrer l'ordinateur pour que les modifications soient prises en compte.
  • Lorsque vous utilisez l'option de la ligne de commande -o si vous choisissez ce paramètre, vous devez redémarrer l'ordinateur pour que les modifications soient prises en compte.


Ping

Vérifie la connectivité IP à un autre ordinateur TCP/IP en envoyant des messages Requête d'écho ICMP (Internet Control Message Protocol). Le reçu des messages Réponse à écho correspondants s'affiche, ainsi que les temps des parcours circulaires. Ping est la principale commande TCP/IP utilisée pour résoudre les problèmes de connectivité, d'accessibilité et de résolution de nom. Utilisée sans paramètres, la commande ping affiche l'aide.

Syntaxe

ping [-t] [-a] [-n Nombre] [-l Taille] [-f] [-i TTL] [-v TOS] [-r Nombre] [-s Nombre] [{-j ListeHôte | -k ListeHôte}] [-w DélaiAttente] [NomCible]

Paramètres

-t
Spécifie que la commande ping continue d'envoyer des messages Requête d'écho à la destination jusqu'à son interruption. Pour interrompre la commande et afficher les statistiques, appuyez sur CTRL-Pause. Pour interrompre la commande et quitter ping, appuyez sur CTRL-C.
-a
Spécifie que la résolution de nom inversé est effectuée sur l'adresse IP de destination. Si la résolution de nom est effectuée correctement, la commande ping affiche le nom d'hôte correspondant.
-n Nombre
Spécifie le nombre de messages Requête d'écho envoyés. La valeur par défaut est 4.
-l Taille
Spécifie la longueur, en octets, du champ Données dans les messages de Requête d'écho envoyés. La valeur par défaut est 32. La taille maximale est 65 527.
-f
Spécifie que les messages Requête d'écho sont envoyés sans l'indicateur Ne pas fragmenter dans l'en-tête IP définie à 1. Le message Requête d'écho ne peut pas être fragmenté par les routeurs dans le chemin de la destination. Ce paramètre est utile pour résoudre les problèmes de chemin PMTU (Maximum Transmission Unit).
-i TTL
Spécifie la valeur du champ TTL dans l'en-tête IP des messages Requête d'écho envoyés. La valeur par défaut est la valeur TTL par défaut de l'hôte. Pour les hôtes Windows XP, cette valeur est en général 128. La valeur TTL maximale est 255.
-v TOS
Spécifie la valeur du champ Type de Service (TOS) dans l'en-tête IP des messages Requête d'écho envoyés. La valeur par défaut est 0. TOS est spécifié en tant que valeur décimale de 0 à 255.
-r Nombre
Spécifie que l'option Itinéraire d'enregistrement dans l'en-tête IP permet d'enregistrer le chemin pris par le message Requête d'écho et le message Réponse à Écho correspondant. Chaque tronçon dans le chemin utilise une entrée dans l'option Itinéraire d'enregistrement. Si possible, spécifiez un Nombre qui est égal ou supérieur au nombre de tronçons entre la source et la destination. Le Nombre doit être au minimum 1 et au maximum 9.
-s Nombre
Spécifie que l'option Internet Timestamp dans l'en-tête IP permet d'enregistrer l'heure d'arrivée du message Requête d'écho et du message Réponse à Écho correspondant pour chaque tronçon. Le Nombre doit être au minimum 1 et au maximum 4.
-j ListeHôte
Spécifie que les messages Requête d'écho utilisent l'option Itinéraire source libre dans l'en-tête IP avec le groupe de destinations intermédiaires spécifiées dans ListeHôte. Avec l'itinéraire source libre, les destinations intermédiaires successives peuvent être séparées par un ou plusieurs routeurs. Le nombre maximal d'adresses ou de noms dans la liste hôte est 9. La liste hôte est une série d'adresses IP (en notation décimale à points) séparées par des espaces.
-k ListeHôte
Spécifie que les messages Requête d'écho utilisent l'option Itinéraire source strict dans l'en-tête IP avec le groupe de destinations intermédiaires spécifiées dans ListeHôte. Avec l'itinéraire source strict, la destination intermédiaire suivante doit être directement accessible (elle doit être un voisin sur une interface du routeur). Le nombre maximal d'adresses ou de noms dans la liste hôte est 9. La liste hôte est une série d'adresses IP (en notation décimale à points) séparées par des espaces.
-w DélaiAttente
Spécifie la durée d'attente, en millisecondes, avant que le message Réponse à écho correspondant à un message Requête d'écho donné soit reçu. Si le message Requête d'écho n'est pas reçu au cours du délai d'attente, le message d'erreur « Délai d'attente de la demande dépassé » s'affiche. Le délai d'attente par défaut est 4000 (4 secondes).
NomCible
Spécifie la destination, identifiée soit par l'adresse IP soit par le nom d'hôte.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez exécuter la commande ping pour tester le nom d'ordinateur et l'adresse IP de l'ordinateur. Si le test de l'adresse IP réussit mais pas le nom d'ordinateur, vous êtes peut-être confronté à un problème de résolution de nom. Dans ce cas, assurez-vous que le nom d'ordinateur que vous spécifiez peut être résolu par le biais du fichier local Hôte. Pour ce faire, utilisez les techniques de requêtes DNS (Domain Name System) ou de résolution de nom NetBIOS.
  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est installé en tant que composant dans les propriétés d'une carte réseau dans Connexions réseau.

Exemples

L'exemple suivant présente la sortie de la commande ping :

C:\>ping exemple.microsoft.com

Commande Ping exemple.microsoft.com [192.168.239.132] avec 32 octets de données :

Réponse de 192.168.239.132 : octets=32 temps=101ms TTL=124

Réponse de 192.168.239.132 : octets=32 temps=100ms TTL=124

Réponse de 192.168.239.132 : octets=32 temps=120ms TTL=124

Réponse de 192.168.239.132 : octets=32 temps=120ms TTL=124

Pour exécuter la commande Ping sur la destination 10.0.99.221 et résoudre 10.0.99.221 à son nom d'hôte, tapez :

ping -a 10.0.99.221

Pour exécuter la commande ping sur la destination 10.0.99.221 avec 10 messages Requête d'écho, chacun ayant un champ Données de 1000 octets, tapez :

ping -n 10 -l 1000 10.0.99.221

Pour exécuter la commande Ping sur la destination 10.0.99.221 et enregistrer l'itinéraire de 4 tronçons, tapez :

ping -r 4 10.0.99.221

Pour exécuter la commande ping sur la destination 10.0.99.221 et spécifier l'itinéraire source libre de 10.12.0.1-10.29.3.1-10.1.44.1, tapez :

ping -j 10.12.0.1 10.29.3.1 10.1.44.1 10.0.99.221


Popd

Remplace le répertoire en cours par le répertoire stocké par la commande pushd.

Syntaxe

popd

Paramètres

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Chaque fois que vous utilisez la commande pushd, un seul répertoire est stocké en vue de son utilisation. Vous pouvez toutefois utiliser la commande pushd à plusieurs reprises pour stocker plusieurs répertoires.

    Les répertoires sont stockés de manière séquentielle dans une pile virtuelle. Si vous utilisez une seule fois la commande pushd, le répertoire dans lequel vous utilisez la commande est placé au bas de la pile. Si vous utilisez à nouveau la commande, le deuxième répertoire est placé avant le premier répertoire. Le processus se répète chaque fois que vous utilisez la commande pushd.

    Vous pouvez utiliser la commande popd pour remplacer le répertoire actuel par le répertoire le plus récent stocké à l'aide de la commande pushd. Si vous utilisez la commande popd, le répertoire situé au sommet de la pile est supprimé de la pile au moment où le répertoire actuel est remplacé par ce répertoire. Si vous utilisez à nouveau la commande popd, le répertoire suivant dans la pile est supprimé.
  • Lorsque les extensions de commandes sont activées, la commande popd supprime toutes les affectations de lettres de lecteurs créées par la commande pushd.

Exemples

Vous pouvez utiliser les commandes pushd et popd dans un fichier de commandes pour utiliser un autre répertoire actuel que celui dans lequel le fichier de commandes était exécuté, et pour le remplacer de nouveau. Le fichier de commandes utilisé comme exemple ci-dessous vous indique comment procéder :

@echo off

rem Ce fichier de commandes supprime tous les fichiers .txt du répertoire spécifié.

pushd %1

del *.txt

popd

cls

echo Tous les fichiers texte sont supprimés du répertoire %1


Print

Envoie un fichier texte à une imprimante.

Syntaxe

print [/d:Imprimante] [Lecteur:][Chemin] NomFichier [ ...]

Paramètres

/d:Imprimante
Spécifie l'imprimante sur laquelle vous voulez imprimer les travaux d'impression. Vous pouvez spécifier une imprimante locale en indiquant le port de votre ordinateur auquel l'imprimante est connectée. Les valeurs valides pour les ports parallèles sont LPT1, LPT2 et LPT3. Les valeurs valides pour les ports série sont COM1, COM2, COM3 et COM4. Vous pouvez également spécifier une imprimante grâce au nom de sa file d'attente (\\NomServeur\NomPartage). Si vous ne spécifiez aucune imprimante, le travail d'impression est envoyé à LTP1.
Lecteur:
Spécifie le lecteur physique ou logique sur lequel est situé le fichier que vous voulez imprimer. Ce paramètre n'est pas nécessaire si le fichier que vous souhaitez imprimer est situé sur le lecteur actif.
Chemin
Spécifie l'emplacement, sur le lecteur, du fichier que vous voulez imprimer. Ce paramètre n'est pas nécessaire si le fichier à imprimer est situé dans le répertoire actif.
NomFichier [...]
Requis. Spécifie le nom du fichier que vous voulez imprimer. Vous pouvez inclure plusieurs fichiers dans une commande.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Un fichier peut s'imprimer en arrière plan si vous l'envoyez à une imprimante connectée à un port parallèle ou série sur l'ordinateur local.
  • De nombreux programmes ont leurs propres commandes d'impression. Vous devez utiliser la commande print pour qu'un programme imprime des fichiers que vous créez avec ce programme.
  • Vous pouvez effectuer de nombreuses tâches de configuration à partir de la ligne de commande en utilisant la commande mode. Pour plus d'informations sur la configuration d'une imprimante connectée à un port parallèle ou à un port série, l'affichage de l'état d'une imprimante ou la préparation d'une imprimante pour la modification des pages de code, consultez mode dans la section Rubriques connexes.

Exemples

Pour envoyer le fichier Rapport.txt situé dans le répertoire actif à une imprimante connectée à LPT2 sur l'ordinateur local, tapez :

print /d:LPT2 rapport.txt

Pour envoyer le fichier Rapport.txt situé dans le répertoire c:\Comptabilité à la file d'impression de Imprimante1 sur le serveur \\SallePhotocopie, tapez :

print /d:\\SallePhotocopie\imprimante1 c:\comptabilité\rapport.txt


Prncnfg.vbs

Configure une imprimante ou affiche les informations de configuration d'une imprimante. Utilisée sans paramètres, prncnfg.vbs affiche l'aide de la ligne de commande correspondant à la commande prncnfg.vbs.

Pour afficher les informations de configuration d'une imprimante

Syntaxe

cscript prncnfg.vbs -g [-s OrdinateurDistant] -p NomImprimante [-u NomUtilisateur -w Mot de passe]

Paramètres

-g
Requis. Spécifie que vous voulez afficher les informations de configuration d'une imprimante.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant qui gère l'imprimante pour laquelle vous voulez afficher les informations. Si vous ne spécifiez aucun ordinateur, l'ordinateur local est utilisé.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante pour laquelle vous voulez afficher des informations.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur qui héberge l'imprimante pour laquelle vous voulez afficher des informations, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour afficher les informations de configuration d'une imprimante nommée ImprimanteCouleur_2 dont la file d'impression est hébergée par l'ordinateur distant nommé ServeurHR, tapez :

cscript prncnfg.vbs -g -s ServeurHR -p ImprimanteCouleur_2

Pour configurer une imprimante

Syntaxe

cscript prncnfg.vbs -t [-s OrdinateurDistant] -p NomImprimante [-u NomUtilisateur -w Mot de passe] [-r NomPort] [-l Emplacement] [-m Commentaire] [-h NomPartage] [-f TexteSéparation] [-y TypeDonnées] [-st HeureDébut] [-ut HeureFin] [-o Priorité] [-i PrioritéParDéfaut] [{+ | -}shared] [{+ | -}direct] [{+ | -}published] [{+ | -}hidden] [{+ | -}rawonly] [{+ | -}queued] [{+ | -}keepprintedjobs] [{+ | -}workoffline] [{+ | -}enabledevq] [{+ | -}docompletefirst][{+ | -}enablebidi]

Paramètres

-t
Requis. Spécifie que vous voulez configurer une imprimante.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant qui gère l'imprimante que vous voulez configurer. Si vous ne spécifiez aucun ordinateur, l'imprimante est configurée sur l'ordinateur local.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante que vous voulez configurer.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur sur lequel vous voulez configurer une imprimante, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
-r NomPort
Spécifie le port auquel l'imprimante est connectée. S'il s'agit d'un port parallèle ou série, utilisez l'ID du port (par exemple, LPT1 ou COM1). S'il s'agit d'un port TCP/IP, utilisez le nom de port que vous avez spécifié lors de l'ajout du port. Pour plus d'informations, consultez la section Rubriques connexes.
-l Emplacement
Spécifie l'emplacement de l'imprimante, tel que « Salle de photocopie ».
-m Commentaire
Spécifie la chaîne de commentaire.
-h NomPartage
Spécifie le nom du partage.
-f TexteSéparation
Spécifie un fichier qui contient le texte apparaissant sur la page de séparation.
-y TypeDonnées
Spécifie les types de données que l'imprimante peut accepter. Pour plus d'informations sur les types de données, consultez la section Rubriques connexes.
-st HeureDébut
Configure l'imprimante pour une disponibilité limitée. Spécifie l'heure après laquelle l'imprimante est disponible. Si vous envoyez un document vers une imprimante lorsque celle-ci n'est pas disponible, le document est retenu (spoulé) jusqu'à ce que l'imprimante soit disponible. Vous devez utiliser une horloge de 24 heures. Par exemple, pour spécifier 11 heures du soir, tapez 2300.
-ut HeureFin
Configure l'imprimante pour une disponibilité limitée. Spécifie l'heure après laquelle l'imprimante n'est plus disponible. Si vous envoyez un document vers une imprimante lorsque celle-ci n'est pas disponible, le document est retenu (spoulé) jusqu'à ce que l'imprimante soit disponible. Vous devez utiliser une horloge de 24 heures. Par exemple, pour spécifier 11 heures du soir, tapez 2300.
-o Priorité
Spécifie une priorité que le spouler utilise pour acheminer les travaux d'impression. Une file d'attente d'impression bénéficiant d'une priorité élevée reçoit tous ses travaux avant les files d'attente dont la priorité est faible.
-i PrioritéParDéfaut
Spécifie la priorité par défaut qui est affecté à chaque tâche d'impression.
{+ | -}shared
Spécifie si l'imprimante est partagé sur le réseau.
{+ | -}direct
Spécifie si le document doit être envoyé directement à l'imprimante sans être spoulé.
{+ | -}published
Spécifie si l'imprimante doit être publiée dans Active Directory. Si vous publiez l'imprimante, d'autres utilisateurs peuvent effectuer une recherche en fonction de son emplacement et des ses fonctions (par exemple impression couleur et agrafage).
{+ | -}hidden
Fonction réservée.
{+ | -}rawonly
Spécifie si seuls les travaux d'impression de données brutes peuvent être envoyés sur cette imprimante.
{+ | -}queued
Spécifie que l'imprimante ne doit pas commencer l'impression avant que la dernière page du document soit spoulée. Le programme d'impression n'est pas disponible tant que le document n'est pas complètement imprimé. Cependant, l'utilisation de cette option garantit la disponibilité de l'intégralité du document pour l'imprimante.
{+ | -}keepprintedjobs
Spécifie que le spouleur doit conserver les documents une fois qu'ils ont été imprimés. Lorsque vous activez cette option, vous pouvez resoumettre un document à l'imprimante à partir de la file d'attente d'impression au lieu du programme d'impression.
{+ | -}workoffline
Spécifie que vous devez être en mesure d'envoyer des travaux d'impression à la file d'attente d'impression même si votre ordinateur n'est pas connecté au réseau.
{+ | -}enabledevq
Spécifie si les travaux d'impression qui ne correspondent pas à la configuration de l'imprimante (par exemple des fichiers PostScript envoyés à des imprimantes non PostScript) doivent être conservés dans la file d'attente au lieu d'être imprimés.
{+ | -}docompletefirst
Spécifie si le spouleur doit envoyer à la file d'attente appropriée les travaux d'impression avec une priorité faible qui ont été spoulés avant d'envoyer à la même file d'attente les travaux d'impression avec une priorité élevée qui n'ont pas été spoulés. Si cette option est activée et si aucun document n'a été intégralement spoulé, l'imprimante enverra les documents de taille importante avant d'envoyer les documents de faible taille. Vous devez activer cette option si vous souhaitez optimiser l'efficacité de l'imprimante au dépend de la priorité des travaux d'impression. Si cette option est désactivée, le spouleur envoie toujours les travaux dont la priorité est élevée aux files d'attente d'impression respectives.
{+ | -}enablebidi
Spécifie que l'imprimante envoie des informations d'état au spouleur.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour configurer une imprimante appelée ImprimanteCouleur_2 pour que le spouleur de l'ordinateur appelé ServeurHR conserve les travaux d'impression une fois qu'ils ont été imprimés, tapez :

cscript prncnfg.vbs -t -s ServeurHR -p ImprimanteCouleur_2 +conservertravauximpression

Pour modifier le nom d'une imprimante

Syntaxe

cscript prncnfg.vbs -x [-s OrdinateurDistant] -p NomImprimante -z NouveauNomImprimante [-u NomUtilisateur -w Mot de passe]

Paramètres

-x
Requis. Spécifie que vous voulez changer le nom d'une imprimante.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant qui gère l'imprimante que vous voulez renommer. Si vous ne spécifiez aucun ordinateur, l'ordinateur local est utilisé.
-p NomImprimante
Requis. Spécifie le nom actuel de l'imprimante.
-z NouveauNomImprimante
Requis. Spécifie le nouveau nom de l'imprimante.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur qui héberge l'imprimante que vous voulez renommer, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour remplacer le nom d'une imprimante ImprimanteCouleur_2 par ImprimanteCouleur_3 sur l'ordinateur distant appelé ServeurHR, tapez :

cscript prncnfg.vbs -x -s ServeurHR-p ImprimanteCouleur_2 -z ImprimanteCouleur_3


Prndrvr.vbs

Ajoute, supprimer et répertorie les pilotes d'imprimante. Si vous utilisez la commande prndrvr.vbs sans paramètre, elle affiche l'aide pour la commande prndrvr.vbs.

Pour installer un pilote d'imprimante

Syntaxe

cscript prndrvr.vbs -a [-m NomLecteur] [-v {0 | 1 | 2 | 3}] [-e Environnement] [-s OrdinateurDistant] [-h Chemin] [-i NomFichier.inf] [-u NomUtilisateur -w Mot de passe]

Paramètres

-a
Requis. Ce paramètre spécifie que vous voulez installer un pilote.
-m NomLecteur
Spécifie le nom du pilote que vous voulez installer. Les pilotes sont souvent nommés en fonction du modèle d'imprimante qu'ils prennent en charge. Consultez la documentation relative à l'imprimante pour obtenir plus d'informations.
-v {0 | 1 | 2 | 3}
Spécifie la version du pilote que vous voulez installer. Reportez-vous à la description du paramètre -e Environnement pour plus d'informations sur les versions disponibles pour chaque environnement. Si vous ne spécifiez aucune version, la version du pilote appropriée pour la version de Windows utilisée sur l'ordinateur sur lequel vous installez le périphérique est installée.
  • La version 0 prend en charge Windows 95, Windows 98 et Windows Millennium Edition.
  • La version 1 prend en charge Windows NT 3.51.
  • La version 2 prend en charge Windows NT 4.0.
  • La version 3 prend en charge Windows XP et Windows 2000.
-e Environnement
Spécifie l'environnement pour le pilote que vous voulez installer. Si vous ne spécifiez aucun environnement, l'environnement de l'ordinateur sur lequel vous installez le pilote est utilisé. Le tableau suivant répertorie les environnements de pilote disponibles et les versions correspondantes pour chacun.
Environnement | Versions disponibles
"Windows NT x86" | 1, 2 et 3
"Windows NT Alpha_AXP" | 1 et 2
"Windows IA64" | 3
"Windows NT R4000" | 1
"Windows NT PowerPC" | 1
"Windows 4.0" | 0
-s OrdinateurDistant
Spécifie l'ordinateur distant sur lequel vous voulez installer le pilote. Si vous ne spécifiez aucun ordinateur, le pilote est installé sur l'ordinateur local.
-h Chemin
Spécifie le chemin d'accès du fichier du pilote. Si vous ne spécifiez aucun chemin, le chemin d'accès à l'emplacement à partir duquel Windows a été installé est utilisé.
-i NomFichier.inf
Spécifie la version du pilote que vous voulez installer. Si vous ne spécifiez aucun nom de fichier, le fichier ntprint.inf est utilisé.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion, en utilisant les services WMI (Windows Management Instrumentation), sur l'ordinateur sur lequel vous voulez installer le pilote. Tous les membres du groupe Administrateurs pour cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez être connecté à un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour ajouter la version 3 du pilote d'imprimante nommé « Pilote d'imprimante couleur 1 » à l'ordinateur local, qui offre un environnement Windows NT x86, tapez :

cscript prndrvr.vbs -a -m "Pilote d'imprimante couleur 1" -v 3 -e "Windows NT x86"

Pour supprimer un pilote d'imprimante

Syntaxe

cscript prndrvr.vbs -d [-s OrdinateurDistant] -m NomLecteur -v {0 | 1 | 2 | 3} -e Environnement

[-u NomUtilisateur -w Mot de passe]

Paramètres

-d
Requis. Ce paramètre spécifie que vous voulez supprimer un pilote.
-s OrdinateurDistant
Spécifie l'ordinateur distant à partir duquel vous voulez supprimer le pilote. Si vous ne spécifiez aucun ordinateur, le pilote est supprimé de l'ordinateur local.
-m NomLecteur
Requis. Spécifie le nom du pilote que vous voulez installer. Les pilotes sont souvent nommés en fonction du modèle d'imprimante qu'ils prennent en charge. Consultez la documentation relative à l'imprimante pour obtenir plus d'informations.
-v {0 | 1 | 2 | 3}
Requis. Indique la version du pilote à supprimer. Reportez-vous à la description du paramètre -e Environnement pour plus d'informations sur les versions disponibles pour chaque environnement.
  • La version 0 prend en charge Windows 95, Windows 98 et Windows Millennium Edition.
  • La version 1 prend en charge Windows NT 3.51.
  • La version 2 prend en charge Windows NT 4.0.
  • La version 3 prend en charge Windows XP et Windows 2000.
-e Environnement
Requis. Spécifie l'environnement du pilote que vous voulez supprimer. Le tableau suivant répertorie les environnements de pilote disponibles et les versions correspondantes pour chacun d'entre eux.
Environnement | Versions disponibles
"Windows NT x86" | 1, 2 et 3
"Windows NT Alpha_AXP" | 1 et 2
"Windows IA64" | 3
"Windows NT R4000" | 1
"Windows NT PowerPC" | 1
"Windows 4.0" | 0
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur sur lequel vous voulez supprimer le pilote, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs sur cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez être connecté à un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Lorsque vous supprimez un pilote, vous devez inclure les paramètres d'environnement et de version.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour répertorier les pilotes d'imprimante sur un ordinateur

Syntaxe

cscript prndrvr.vbs -l [-s OrdinateurDistant] [-u NomUtilisateur -w Mot de passe]

Paramètres

-l
Requis. Spécifie que vous voulez répertorier tous les pilotes sur un ordianteur.
-s OrdinateurDistant
Spécifie l'ordinateur distant pour lequel vous voulez répertorier les pilotes. Si vous ne spécifiez aucun ordinateur, les pilotes sur l'ordinateur local sont répertoriés.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur pour lequel vous voulez répertorier les pilotes, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs sur cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez être connecté à un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour supprimer tous les pilotes d'imprimante non utilisés d'un ordinateur

Syntaxe

cscript prndrvr.vbs -x [-s OrdinateurDistant] [-u NomUtilisateur -w Mot de passe]

Paramètres

-x
Requis. Spécifie que vous voulez supprimer tous les pilotes inutilisés d'un ordinateur.
-s OrdinateurDistant
Spécifie l'ordinateur distant pour lequel vous voulez supprimer les pilotes. Si vous ne spécifiez pas d'ordinateur, les pilotes sont supprimés de l'ordinateur local.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur pour lequel vous voulez supprimer les pilotes, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs sur cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez être connecté à un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").


Prnjobs.vbs

Interrompt, reprend, annule et répertorie les travaux d'impression. Utilisée sans paramètres, prnjobs.vbs affiche l'aide de la ligne de commande correspondant à la commande prnjobs.vbs.

Pour interrompre un travail d'impression

Syntaxe

cscript prnjobs -z [-s OrdinateurDistant] -p NomImprimante -j NuméroTâche [-u NomUtilisateur -w Mot de passe]

Paramètres

-z
Requis. Spécifie que vous voulez interrompre un travail d'impression.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant auquel la tâche d'impression interrompue a été envoyée. Si vous ne spécifiez aucun ordinateur, l'ordinateur local est utilisé.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante qui doit imprimer le travail d'impression que vous voulez interrompre.
-j NuméroTâche
Requis. Spécifie le numéro d'identification de la tâche d'impression que vous voulez interrompre.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur auquel la tâche d'impression que vous voulez interrompre a été envoyée, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Pour afficher la liste des travaux d'impression et leurs numéros d'identification, utilisez cette commande avec le paramètre -l.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour interrompre une tâche d'impression dont l'identificateur est 27 et qui a été envoyée à l'ordinateur distant appelé ServeurHR en vue de son impression sur une imprimante couleur appelée ImprimanteCouleur, tapez :

cscript prnjobs.vbs -z -s ServeurHR -p ImprimanteCouleur -j 27

Pour reprendre un travail d'impression

Syntaxe

cscript prnjobs -m [-s OrdinateurDistant] -p NomImprimante -j NuméroTâche [-u NomUtilisateur -w Mot de passe]

Paramètres

-m
Requis. Spécifie que vous voulez reprendre une tâche d'impression.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant auquel la tâche d'impression que vous voulez reprendre a été envoyée. Si vous ne spécifiez aucun ordinateur, l'ordinateur local est utilisé.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante qui doit imprimer le travail d'impression que vous voulez reprendre.
-j NuméroTâche
Requis. Spécifie le numéro d'identification du travail d'impression que vous voulez reprendre.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur auquel le travail d'impression que vous voulez reprendre a été envoyé, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Pour afficher une liste de travaux d'impression et leurs numéros d'identification, utilisez cette commande avec le paramètre -l.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour annuler un travail d'impression

Syntaxe

cscript prnjobs -x [-s OrdinateurDistant] -p NomImprimante -j NuméroTâche [-u NomUtilisateur -w Mot de passe]

Paramètres

-x
Requis. Spécifie que vous voulez annuler une tâche d'impression.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant auquel la tâche d'impression que vous voulez annuler a été envoyée. Si vous ne spécifiez aucun ordinateur, l'ordinateur local est utilisé.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante qui devrait imprimer le document que vous voulez annuler.
-j NuméroTâche
Requis. Spécifie le numéro d'identification de la tâche d'impression que vous voulez annuler.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur auquel la tâche d'impression que vous voulez annuler a été envoyée, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Pour afficher la liste des travaux d'impression et leurs numéros d'identification, utilisez cette commande avec le paramètre -l.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour répertorier les travaux d'impression dans une file d'attente d'impression

Syntaxe

cscript prnjobs -l [-s OrdinateurDistant] [-p NomImprimante] [-u NomUtilisateur -w Mot de passe]

Paramètres

-l
Requis. Spécifie que vous voulez répertorier tous les travaux d'impression d'une file d'attente d'impression.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant qui héberge la file d'attente d'impression dont vous voulez répertorier les travaux d'impression. Si vous ne spécifiez aucun ordinateur, l'ordinateur local est utilisé.
-p NomImprimante
Spécifie le nom de l'imprimante dont la file d'attente d'impression contient les travaux d'impression que vous voulez répertorier. Si vous ne spécifiez aucune imprimante, tous les travaux d'impression situés dans les files d'attente d'impression sont répertoriés.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur qui héberge la file d'attente d'impression dont vous voulez répertorier les travaux d'impression, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Pour afficher la liste des travaux d'impression et leurs numéros d'identification, utilisez cette commande avec le paramètre -l.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour répertorier tous les travaux d'impression en cours dans la file d'attente de l'imprimante locale nommée ImprimanteCouleur_2, tapez :

cscript prnjobs.vbs -l -p ImprimanteCouleur_2


Prnmngr.vbs

Ajoute, supprime et répertorie les imprimantes ou les connexions à une imprimante. Définit et affiche également l'imprimante par défaut. Utilisée sans paramètres, prnmngr.vbs affiche l'aide de la ligne de commande correspondant à la commande prnmngr.vbs.

Pour ajouter une imprimante locale

Syntaxe

cscript prnmngr.vbs -a -p NomImprimante [-s OrdinateurDistant] -m NomLecteur -r NomPort [-u NomUtilisateur -w Mot de passe]

Paramètres

-a
Requis. Spécifie que vous voulez ajouter une imprimante locale.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant auquel vous voulez ajouter une imprimante locale. Si vous ne spécifiez aucun ordinateur, l'imprimante est ajoutée à l'ordinateur local.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante locale que vous voulez ajouter.
-m NomLecteur
Requis. Spécifie le nom du lecteur correspondant à l'imprimante locale que vous voulez ajouter. Les lecteurs sont souvent nommés en fonction du modèle d'imprimante qu'ils prennent en charge. Consultez la documentation relative à l'imprimante pour plus d'informations.
-r NomPort
Requis. Spécifie le port auquel l'imprimante est connectée. S'il s'agit d'un port parallèle ou série, utilisez l'ID du port (par exemple, LPT1 ou COM1). S'il s'agit d'un port TCP/IP, utilisez le nom de port que vous avez spécifié lors de l'ajout du port. Pour plus d'informations, consultez la section Rubriques connexes.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur auquel vous voulez ajouter une imprimante, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour ajouter une imprimante nommée ImprimanteCouleur_2 qui est connectée au port LPT1 sur l'ordinateur local et qui requiert un pilote d'imprimante nommé Pilote Imprimante Couleur1, tapez :

cscript prnmngr.vbs -a -p ImprimanteCouleur_2 -m "Pilote Imprimante Couleur1" -r lpt1:

Pour ajouter une connexion d'imprimante

Syntaxe

cscript prnmngr.vbs -ac -p NomImprimante

Paramètres

-ac
Requis. Spécifie que vous voulez ajouter une connexion d'imprimante.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante pour laquelle vous voulez ajouter une connexion.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour supprimer une imprimante

Syntaxe

cscript prnmngr.vbs -d -p NomImprimante [-u NomUtilisateur -w Mot de passe] [-s OrdinateurDistant]

Paramètres

-d
Requis. Spécifie que vous voulez supprimer une imprimante.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante que vous voulez supprimer.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur sur lequel vous voulez supprimer une imprimante, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant auquel vous voulez ajouter une imprimante locale. Si vous ne spécifiez aucun ordinateur, l'imprimante est ajoutée à l'ordinateur local.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour supprimer l'imprimante nommée ImprimanteCouleur_2 de l'ordinateur distant nommé ServeurHR, tapez :

cscript prnmngr.vbs -d -s ServeurHR -p ImprimanteCouleur_2

Pour supprimer toutes les imprimantes d'un ordinateur

Syntaxe

cscript prnmngr.vbs -x [-s OrdinateurDistant] [-u NomUtilisateur] [-w Mot de passe]

Paramètres

-x
Requis. Spécifie que vous voulez supprimer toutes les imprimantes d'un ordinateur.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant sur lequel vous voulez supprimer toutes les imprimantes. Si vous ne spécifiez aucun ordinateur, toutes les imprimantes sont supprimées de l'ordinateur local.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur sur lequel vous voulez supprimer toutes les imprimantes, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour afficher l'imprimante par défaut

Syntaxe

cscript prnmngr.vbs -g

Paramètres

-g
Requis. Spécifie que vous voulez afficher l'imprimante par défaut.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour définir l'imprimante par défaut

Syntaxe

cscript prnmngr.vbs -t -p NomImprimante

Paramètres

-t
Requis. Spécifie que vous voulez définir l'imprimante par défaut.
-p NomImprimante
Requis. Spécifie le nom de l'imprimante que vous voulez définir comme imprimante par défaut.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour répertorier toutes les imprimantes d'un ordinateur

Syntaxe

cscript prnmngr.vbs -l [-s OrdinateurDistant] [-u NomUtilisateur -w Mot de passe]

Paramètres

-l
Requis. Spécifie que vous voulez répertorier toutes les imprimantes d'un ordinateur.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant pour lequel vous voulez répertorier les imprimantes. Si vous ne spécifiez aucun ordinateur, les imprimantes ajoutées à l'ordinateur local sont répertoriées.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations de connexion à l'ordinateur pour lequel vous voulez répertorier les imprimantes, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").


Prnport.vbs

Crée, supprime et répertorie les ports d'imprimante TCP/IP. Affiche et modifie également la configuration des ports. Si vous utilisez la commande prnport.vbs sans paramètre, elle affiche l'aide pour la commande prnport.vbs.

Pour créer un port d'imprimante TCP/IP standard

Syntaxe

cscript prnport.vbs -a -r NomPort [-s OrdinateurDistant] -h AdresseIP [-u NomUtilisateur -w Mot de passe] [-o {raw -n NuméroPort | lpr}] [-q NomFileAttente] [-m{e | d}] [-i NomIndex] [-y NomCommunauté] [-2{e | d}]

Paramètres

-a
Requis. Spécifie que vous voulez créer un port d'imprimante TCP/IP standard.
-r NomPort
Requis. Spécifie le port auquel l'imprimante est connectée.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant auquel vous voulez ajouter le port. Si vous ne spécifiez aucun ordinateur, le port est ajouté à l'ordinateur local.
-h AdresseIP
Requis. Spécifie l'adresse IP que vous voulez affecter au port.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur sur lequel vous voulez créer un port d'imprimante TCP/IP standard, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
-o {raw -n NuméroPort | lpr}
Spécifie le protocole que le port utilise : TCP en tant que tel ou TCP LPR. Si vous utilisez TCP en tant que tel, ce paramètre spécifie le numéro de port d'un port d'imprimante TCP en tant que tel. Par défaut, ce numéro de port est 9100. Pour plus d'informations, consultez la section Rubriques connexes. La plupart des imprimantes utilisent TCP en tant que tel. Sur les réseaux UNIX, les imprimantes utilisent souvent TCP LPR. Pour plus d'informations sur TCP en tant que tel, consultez la section Rubriques connexes. Pour plus d'informations sur TCP LPR, consultez la norme RFC 1179 sur le site Web RFC Editor.
-q NomFileAttente
Spécifie le nom de la file d'attente d'un port TCP en tant que tel.
-m{e | d}
Spécifie si SNMP est activé. Le paramètre e active SNMP. Le paramètre d désactive SNMP.
-i NomIndex
Spécifie l'index SNMP, si SNMP est activé. Pour plus d'informations, consultez la norme RFC 1759 sur le site Web RFC Editor.
-y NomCommunauté
Spécifie le nom de la communauté SNMP, si SNMP est activé. Pour plus d'informations, consultez la section Rubriques connexes.
-2{e | d}
Spécifie si les spoules doubles (également appelés respooling) sont activés pour les ports TCP LPR. Les spoules doubles sont nécessaires car TCP LPR doit inclure un nombre d'octets exact dans le fichier de contrôle envoyé à l'imprimante, mais le protocole ne peut pas obtenir ce nombre du fournisseur d'impression local. Par conséquent, lorsqu'un fichier est envoyé vers une file d'attente d'impression TCP LPR, il est également envoyé en tant que fichier temporaire dans le répertoire system32. TCP LPR détermine la taille du fichier temporaire et envoie la taille au serveur qui exécute LPD. Le paramètre e active les spoules doubles. Le paramètre d désactive les spoules doubles.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si vous voulez modifier la configuration d'un port d'imprimante TCP/IP standard après l'avoir créé, vous pouvez utiliser la commande cscript prnport.vbs avec le paramètre -t.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").
  • XOX

Pour supprimer un port d'imprimante TCP/IP standard

Syntaxe

cscript prnport.vbs -d -r NomPort [-s OrdinateurDistant] [-u NomUtilisateur -w Mot de passe]

Paramètres

-d
Requis. Spécifie que vous voulez supprimer un port d'imprimante TCP/IP standard.
-r NomPort
Requis. Spécifie le port d'imprimante TCP/IP standard que vous voulez supprimer.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant pour lequel vous voulez supprimer le port. Si vous ne spécifiez aucun ordinateur, le port est supprimé de l'ordinateur local.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur sur lequel vous voulez supprimer un port d'imprimante TCP/IP standard, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour supprimer le port d'imprimante TCP/IP standard nommé IP_192.168.12.128 de l'ordinateur distant nommé ServeurHR, tapez :

cscript prnport.vbs -d -r IP_192.168.12.128 -s ServeurHR

Pour répertorier tous les ports d'imprimante TCP/IP standard sur un ordinateur

Syntaxe

cscript prnport.vbs -l [-s OrdinateurDistant] [-u NomUtilisateur -w Mot de passe]

Paramètres

-l
Requis. Spécifie que vous voulez répertorier tous les ports d'imprimante TCP/IP standard sur un ordinateur.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant dont vous voulez répertorier les ports. Si vous ne spécifiez aucun ordinateur, les ports sur l'ordinateur local sont répertoriés.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur pour lequel vous voulez répertorier tous les ports d'imprimante TCP/IP standard, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Exemple

Pour répertorier tous les ports d'imprimante TCP/IP standard sur l'ordinateur distant nommé ServeurHR, tapez :

cscript prnport.vbs -l -s ServeurHR

Pour afficher la configuration d'un port d'imprimante TCP/IP standard

Syntaxe

cscript prnport.vbs -g -r NomPort [-s OrdinateurDistant] [-u NomUtilisateur -w Mot de passe]

Paramètres

-g
Requis. Spécifie que vous voulez afficher la configuration d'un port d'imprimante TCP/IP standard.
-r NomPort
Requis. Spécifie le port dont vous voulez afficher la configuration.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant qui héberge le port dont vous voulez afficher la configuration. Si vous ne spécifiez aucun ordinateur, les informations sont affichées pour le port avec sa configuration sur l'ordinateur local.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur qui héberge le port dont vous voulez afficher la configuration, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").

Pour configurer un port d'imprimante TCP/IP standard

Syntaxe

cscript prnport.vbs -t -r NomPort [-s OrdinateurDistant] [-o {raw -n NuméroPort | lpr}] [-h AdresseIP] [-q NomFileAttente] [-m{e | d}] [-i NomIndex] [-y NomCommunauté] [-2{e | d}] [-u NomUtilisateur -w Mot de passe]

Paramètres

-t
Requis. Spécifie que vous voulez configurer un port d'imprimante TCP/IP standard.
-r NomPort
Requis. Spécifie le port auquel l'imprimante est connectée.
-s OrdinateurDistant
Spécifie le nom de l'ordinateur distant sur lequel vous voulez configurer le port. Si vous ne spécifiez aucun ordinateur, le port est configuré sur l'ordinateur local.
-o {raw -n NuméroPort | lpr}
Spécifie le protocole que le port utilise : TCP en tant que tel ou TCP LPR. Si vous utilisez TCP en tant que tel, spécifie le numéro de port d'un port d'imprimante TCP en tant que tel. Par défaut, le numéro de port est 9100. Pour plus d'informations, consultez la section Rubriques connexes. La plupart des imprimantes utilisent TCP en tant que tel. Sur le réseaux UNIX, les ports d'imprimante utilisent souvent TCP LPR. Pour plus d'informations sur TCP en tant que tel, consultez la section Rubriques connexes. Pour plus d'informations sur TCP LPR, consultez la norme RFC 1179 sur le site Web RFC Editor.
-h AdresseIP
Spécifie l'adresse IP de l'imprimante pour laquelle vous voulez configurer le port.
-q NomFileAttente
Spécifie le nom de la file d'attente pour un port TCP en tant que tel.
-m{e | d}
Spécifie si SNMP est activé. Le paramètre e active SNMP. Le paramètre d désactive SNMP.
-i NomIndex
Spécifie l'index SNMP si SNMP est activé. Pour plus d'informations, consultez la norme RFC 1759 sur le site Web RFC Editor.
-y NomCommunauté
Spécifie le nom de la communauté SNMP si SNMP est activé. Pour plus d'informations, consultez la section Rubriques connexes.
-2{e | d}
Spécifie si les spoules doubles (également appelés respooling) sont activés pour les ports TCP LPR. Les spoules doubles sont nécessaires car TCP LPR doit inclure un nombre d'octets exact dans le fichier de contrôle envoyé à l'imprimante, mais le protocole ne peut pas obtenir ce nombre du fournisseur d'impression local. Par conséquent, lorsqu'un fichier est envoyé à une file d'attente d'impression TCP LPR, il est également envoyé en tant que fichier temporaire dans le répertoire system32. TCP LPR détermine la taille du fichier temporaire et envoie la taille au serveur qui exécute LPD. Le paramètre e active les spoules doubles. Le paramètre d désactive les spoules doubles.
-u NomUtilisateur -w Mot de passe
Spécifie un compte avec des autorisations pour la connexion à l'ordinateur sur lequel vous voulez configurer un port, en utilisant les services WMI (Windows Management Instrumentation). Tous les membres du groupe Administrateurs de cet ordinateur bénéficient de ces autorisations, mais les autorisations peuvent également être octroyées à d'autres utilisateurs. Si vous ne spécifiez aucun compte, vous devez avoir ouvert une session sur un compte bénéficiant de ces autorisations pour que la commande fonctionne. Pour plus d'informations sur WMI, consultez la section Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui est situé dans le répertoire racinesystème\system32. Vous devez taper cette commande à l'invite de commandes en utilisant ce répertoire comme répertoire actuel, ou vous devez taper le chemin d'accès complet à ce répertoire au début de la commande cscript.
  • Si les informations que vous fournissez contiennent des espaces, insérez le texte entre guillemets (par exemple "Nom Ordinateur").
  • XOX


Prnqctl.vbs

Permet d'imprimer une page de test, d'interrompre ou de reprendre une impression et de supprimer une impression d'une file d'attente. Utilisée sans paramètres, la commande prnqctl.vbs permet d'afficher l'aide relative à l'utilisation de la commande prnqctl.vbs.

Pour interrompre une impression

Syntaxe

cscript prnqctl.vbs -z [-s OrdinateurDistant] -p NomImprimante [-u NomUtilisateur -w MotDePasse]

Paramètres

-z
Obligatoire. Demande la pause de l'impression.
-s OrdinateurDistant
Indique le nom de l'ordinateur distant auquel est reliée l'imprimante sur laquelle vous souhaitez interrompre une impression. Si vous n'indiquez pas de nom d'ordinateur, ce sont les impressions lancées sur l'imprimante reliée à l'ordinateur local qui sont interrompues.
-p NomImprimante
Obligatoire. Spécifie le nom de l'imprimante sur laquelle vous voulez interrompre les impressions.
-u NomUtilisateur -w MotDePasse
Spécifie un compte avec les autorisations qui lui permettent, au moyen des services WMI (Windows Management Instrumentation), de se connecter à l'ordinateur auquel l'imprimante est reliée et sur laquelle vous voulez interrompre les impressions. Tous les membres du groupe Administrateurs pour cet ordinateur disposent de ces autorisations, mais celles-ci peuvent aussi être accordées à d'autres utilisateurs. Si vous n'indiquez pas de compte, vous devez vous connecter sous un compte autorisé à lancer cette commande. Pour plus d'informations sur WMI, consultez Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui se trouve dans le répertoire RacineSystème\system32. Lorsque vous tapez cette commande à l'invite de commandes, ce répertoire doit être le répertoire courant. Dans le cas contraire, vous devez taper le chemin d'accès complet à ce répertoire avant la commande cscript.
  • Si les informations que vous devez saisir contiennent des espaces, encadrez le texte de guillemets (par exemple, "Nom Ordinateur").

Exemple

Pour interrompre les impressions sur toutes les imprimantes appelées ImprimantesCouleur_2 reliées à l'ordinateur distant HRServeur, tapez :

cscript prnqctl.vbs -z -s HRServeur -p ImprimanteCouleur_2

Pour reprendre une impression

Syntaxe

cscript prnqctl.vbs -m [-s OrdinateurDistant] -p NomImprimante [-u NomUtilisateur -w MotDePasse]

Paramètres

-m
Obligatoire. Demande la reprise de l'impression.
-s OrdinateurDistant
Indique le nom de l'ordinateur distant auquel est reliée l'imprimante sur laquelle vous souhaitez reprendre les impressions. Si vous n'indiquez pas de nom d'ordinateur, ce sont les impressions lancées sur l'imprimante reliée à l'ordinateur local qui sont reprises.
-p NomImprimante
Obligatoire. Spécifie le nom de l'imprimante sur laquelle vous voulez reprendre les impressions.
-u NomUtilisateur -w MotDePasse
Spécifie un compte et les autorisations qui lui permettent, au moyen des services WMI (Windows Management Instrumentation), de se connecter à l'ordinateur qui gère l'imprimante sur laquelle vous voulez reprendre les impressions. Tous les membres du groupe Administrateurs pour cet ordinateur disposent de ces autorisations, mais celles-ci peuvent aussi être accordées à d'autres utilisateurs. Si vous n'indiquez pas de compte, vous devez vous connecter sous un compte autorisé à lancer cette commande. Pour plus d'informations sur WMI, consultez Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui se trouve dans le répertoire RacineSystème\system32. Lorsque vous tapez cette commande à l'invite de commandes, ce répertoire doit être le répertoire courant. Dans le cas contraire, vous devez taper le chemin d'accès complet à ce répertoire avant la commande cscript.
  • Si les informations que vous devez saisir contiennent des espaces, encadrez le texte de guillemets (par exemple, "Nom Ordinateur").

Exemple

Pour reprendre les impressions sur toutes les imprimantes appelées ImprimantesCouleur_2 reliées à l'ordinateur distant HRServeur, tapez :

cscript prnqctl.vbs -m -s HRServeur -p ImprimanteCouleur_2

Pour imprimer une page de test

Syntaxe

cscript prnqctl.vbs -e [-s OrdinateurDistant] -p NomImprimante [-u NomUtilisateur -w MotDePasse]

Paramètres

-e
Obligatoire. Indique que vous voulez imprimer une page de test.
-s OrdinateurDistant
Indique le nom de l'ordinateur distant auquel est reliée l'imprimante sur laquelle vous souhaitez imprimer une page de test. Si vous n'indiquez pas de nom d'ordinateur, l'opération est effectuée sur l'ordinateur local.
-p NomImprimante
Obligatoire. Spécifie le nom de l'imprimante sur laquelle vous voulez imprimer une page de test.
-u NomUtilisateur -w MotDePasse
Spécifie un compte et les autorisations qui lui permettent, au moyen des services WMI (Windows Management Instrumentation), de se connecter à l'ordinateur qui gère l'imprimante sur laquelle vous voulez imprimer une page de test. Tous les membres du groupe Administrateurs pour cet ordinateur disposent de ces autorisations, mais celles-ci peuvent aussi être accordées à d'autres utilisateurs. Si vous n'indiquez pas de compte, vous devez vous connecter sous un compte autorisé à lancer cette commande. Pour plus d'informations sur WMI, consultez Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui se trouve dans le répertoire RacineSystème\system32. Lorsque vous tapez cette commande à l'invite de commandes, ce répertoire doit être le répertoire courant. Dans le cas contraire, vous devez taper le chemin d'accès complet à ce répertoire avant la commande cscript.
  • Si les informations que vous devez saisir contiennent des espaces, encadrez le texte de guillemets (par exemple, "Nom Ordinateur").

Pour annuler tous les travaux d'impression mis en attente sur une imprimante

Syntaxe

cscript prnqctl.vbs -x [-s OrdinateurDistant]-p NomImprimante [-u NomUtilisateur -w MotDePasse]

Paramètres

-x
Obligatoire. Spécifie que vous voulez annuler tous les travaux d'impression mis en attente sur une imprimante.
-s OrdinateurDistant
Indique le nom de l'ordinateur distant auquel est reliée l'imprimante sur laquelle vous souhaitez annuler tous les travaux d'impression. Si vous n'indiquez pas de nom d'ordinateur, l'opération est effectuée sur l'ordinateur local.
-p NomImprimante
Obligatoire. Spécifie le nom de l'imprimante sur laquelle vous voulez annuler tous les travaux d'impression.
-u NomUtilisateur -w MotDePasse
Spécifie un compte et les autorisations qui lui permettent, au moyen des services WMI (Windows Management Instrumentation), de se connecter à l'ordinateur auquel est reliée l'imprimante sur laquelle vous voulez annuler tous les travaux d'impression. Tous les membres du groupe Administrateurs pour cet ordinateur disposent de ces autorisations, mais celles-ci peuvent aussi être accordées à d'autres utilisateurs. Si vous n'indiquez pas de compte, vous devez vous connecter sous un compte autorisé à lancer cette commande. Pour plus d'informations sur WMI, consultez Rubriques connexes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande lance un script qui se trouve dans le répertoire RacineSystème\system32. Lorsque vous tapez cette commande à l'invite de commandes, ce répertoire doit être le répertoire courant. Dans le cas contraire, vous devez taper le chemin d'accès complet à ce répertoire avant la commande cscript.
  • Si les informations que vous devez saisir contiennent des espaces, encadrez le texte de guillemets (par exemple, "Nom Ordinateur").


Prompt

Permet de modifier l'invite de l'exécutable Cmd.exe. Utilisée sans paramètres, la commande prompt permet de rétablir les paramètres par défaut de l'invite de commandes, à savoir la lettre du lecteur en cours, suivie du répertoire en cours et du symbole supérieur à (>).

Syntaxe

prompt [texte]

Paramètres

texte
Représente n'importe quels textes et informations à inclure dans l'invite de commandes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • L'invite de commandes peut être personnalisée de manière à afficher n'importe quel texte de votre choix, y compris des informations telles que le nom du répertoire courant, la date et l'heure ou le numéro de la version de Windows XP utilisée.
  • Le tableau ci-dessous contient la liste des combinaisons de caractères qu'il est possible d'inclure à la place ou en plus de toute chaîne de caractères dans l'option de ligne de commandes texte. Avec cette liste est également fournie une brève description du texte ou de l'information que chacune de ces combinaisons ajoute à l'invite de commandes.
    Caractère | Description
    $q | = (signe égal)
    $$ $ (signe dollar)
    $t | Heure actuelle
    $d | Date actuelle
    $p | Lecteur et chemin en cours
    $v | Numéro de version de Windows XP
    $n | Lecteur en cours
    $g | > (signe supérieur à)
    $l | < (signe inférieur à)
    $b | (barre verticale)
    $_ ENTRÉE-SAUT DE LIGNE
    $e | Code d'échappement ANSI (code 27)
    $h | Retour arrière (pour supprimer un caractère écrit sur la ligne de commandes de l'invite)
    $a | & (et commercial)
    $c | ( (parenthèse gauche)
    $f | ) (parenthèse droite)
    $s | espace
  • Lorsque les extensions de commandes sont activées, ce qui est le cas par défaut, la commande prompt prend en charge les caractères de formatage énumérés dans le tableau ci-dessous.
    Caractère | Description
    $+ Zéro ou plus et signe plus (+), selon la profondeur de la pile du répertoire pushd, un caractère pour chaque niveau de la pile.
    $m | Nom distant associé à la lettre de lecteur en cours ou chaîne vide si le lecteur en cours n'est pas un lecteur réseau.
  • Si vous incluez le caractère $p dans le paramètre texte, le disque est lu après chaque commande afin de déterminer le lecteur et le chemin en cours. Ceci risque de prendre du temps, surtout lorsqu'il s'agit de lecteurs de disquette.

Exemples

Dans l'exemple ci-dessous, l'invite de commandes est définie de façon à afficher le lecteur et le chemin courants suivis du symbole > :

prompt $p$g

La commande suivante affiche une invite de deux lignes : l'heure actuelle apparaît sur la première ligne et la date actuelle sur la deuxième :

prompt time is: $t$_date is: $d


Pushd

Mémorise le nom du répertoire en cours qui doit être utilisé par la commande popd avant de remplacer le répertoire courant par celui spécifié.

Syntaxe

pushd [Chemin]

Paramètres

Chemin
Spécifie le répertoire qui doit remplacer le répertoire en cours. Cette commande accepte des chemins relatifs.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • À chaque fois que vous utilisez la commande pushd, un seul répertoire est stocké pour votre utilisation. Toutefois, vous pouvez stocker plusieurs répertoires en utilisant la commande pushd plusieurs fois.

    Les répertoires sont stockés séquentiellement dans une pile virtuelle. Si vous utilisez une seule fois la commande pushd, le répertoire dans lequel vous utilisez la commande est placé en bas de la pile. Si vous utilisez de nouveau la commande, le deuxième répertoire est placé en haut du premier répertoire. Le processus se répète chaque fois que vous utilisez la commande pushd .

    Vous pouvez utiliser la commande popd pour remplacer le répertoire actuel par le répertoire le plus récent stocké à l'aide de la commande pushd. Si vous utilisez la commande popd, le répertoire situé en haut de la pile est supprimé de la pile au moment où le répertoire actuel est remplacé par ce répertoire. Si vous utilisez de nouveau la commande popd, le répertoire suivant de la pile est supprimé.
  • Si les extensions de commande sont activées, la commande pushd accepte un chemin de réseau ou une lettre de lecteur local et un chemin.
  • Si vous indiquez un chemin de réseau, la commande pushd attribue temporairement la première lettre de lecteur non utilisée, en commençant par la lettre Z: à la ressource réseau spécifiée. La commande permet ensuite de remplacer le lecteur en cours et le répertoire par le répertoire spécifié par la lettre de lecteur nouvellement attribuée. Si vous utilisez la commande popd avec les extensions de commande activées, elle supprime l'attribution de la lettre de lecteur créée par la commande pushd.

Exemples

Vous pouvez utiliser la commande pushd et la commande popd dans un programme de commandes pour remplacer le répertoire courant par celui dans lequel le programme de commandes a été lancé, puis effectuer l'opération inverse. Le programme de commandes suivant fourni en exemple montre comment procéder :

@echo off

rem Ce fichier de commandes supprime tous les fichiers .txt du répertoire spécifié.

pushd %1

del *.txt

popd

cls

echo Tous les fichiers texte sont supprimés du répertoire %1


Rasdial

Permet d'automatiser le processus de connexion pour les clients Microsoft. Utilisée sans options, la commande rasdial permet d'afficher l'état des connexions en cours.

Syntaxe

rasdial NomConnexion [NomUtilisateur [{MotDePasse|*}]] [/domain:Domaine] [/phone:NuméroTéléphone] [/callback:NuméroRappel] [/phonebook:CheminAnnuaireTéléphonique] [/prefixsuffix]

rasdial [NomConnexion] /disconnect

Paramètres

NomConnexion
Requis pour la connexion à une entrée (.pbk) de l'annuaire. Spécifie une entrée du fichier .pbk en cours situé dans le dossier RacineSystème\System32\Ras. Si le NomConnexion contient un espace ou des caractères spéciaux, encadrez-le de guillemets (par exemple, "Nom Connexion").

Le fichier Rasphone.pbk est utilisé, excepté si l'option Annuaire téléphonique personnel est sélectionnée. Si l'option Annuaire téléphonique personnel est sélectionnée, c'est le fichier NomUtilisateur.pbk qui est utilisé. Le nom est affiché dans la barre de titre Rasphone si l'option Annuaire téléphonique personnel est sélectionnée. Des numéros sont ajoutés en cas de conflit de noms.

NomUtilisateur [{MotDePasse|*}]
Spécifie un nom d'utilisateur et un mot de passe avec lesquels se connecter. Si un astérisque est utilisé, le système demande un mot de passe à l'utilisateur, mais n'affiche pas les caractères saisis.
/domain:Domaine
Spécifie le domaine de l'emplacement du compte d'utilisateur. Si celui-ci n'est pas indiqué, la dernière valeur de la zone Domaine de la boîte de dialogue Se connecter à est utilisée.
/phone:NuméroTéléphone
Remplace le numéro de téléphone spécifié par le numéro de téléphone de l'entrée dans Rasphone.pbk.
/callback:NuméroRappel
Remplace le numéro de téléphone de rappel spécifié par le numéro de téléphone de rappel de l'entrée dans Rasphone.pbk.
/phonebook:CheminAnnuaireTéléphonique
Spécifie le chemin d'accès du fichier de l'annuaire téléphonique. Par défaut, il s'agit du chemin RacineSystème\System32\Ras\NomUtilisateur.pbk. Vous pouvez spécifier un chemin complet vers le fichier.
/prefixsuffix
Applique au numéro de téléphone les paramètres de numérotation de l'emplacement TAPI actuel. Ces paramètres sont configurés dans Téléphonie, à partir du Panneau de configuration. Cette option est désactivée par défaut.
/disconnect
Obligatoire pour la déconnexion. Déconnecte l'entrée spécifiée. Vous pouvez également effectuer la déconnexion en tapant /d.

Remarques

  • Les fonctionnalités suivantes de Rasphone.exe ne sont pas prises en charge avec la commande rasdial :
    • les entrées qui requièrent l'entrée utilisateur en mode Terminal lors de la séquence de numérotation ;
    • la numérotation assistée par un opérateur ou la numérotation manuelle.

Exemples

Dans l'exemple suivant, la commande utilisée permet la connexion à l'entrée BUREAU de Rasphone.pbk :

rasdial bureau

Dans l'exemple suivant, la commande utilisée permet la connexion à l'entrée BUREAU 2 de Rasphone.pbk et indique un numéro de rappel :

rasdial "bureau 2" /rappel:555-0100

Dans l'exemple suivant, la commande utilisée permet la déconnexion de l'entrée BUREAU EST :

rasdial "BUREAU EST" /d


Rcp

Permet de copier des fichiers entre un ordinateur fonctionnant sous Windows XP et un système qui exécute le service rshd, le service du noyau distant (le démon). Windows XP et Windows 2000 ne fournissent pas le service rshd. Utilisée sans paramètres, la commande rcp permet d'afficher l'aide.

Syntaxe

rcp [{-a | -b}] [-h] [-r] [Hôte][.Utilisateur:] [Source] [Hôte][.Utilisateur:] [Chemin\Destination]

Paramètres

-a
Spécifie le mode de transfert ASCII. Ce mode convertit les caractères de fin de ligne en un retour chariot pour UNIX et en un retour chariot/saut de ligne pour les ordinateurs. Il s'agit du mode de transfert par défaut.
-b
Spécifie le mode de transfert d'images binaires. Aucune conversion retour chariot/saut de ligne n'est effectuée.
-h
Transfert les fichiers source, qui sont marqués avec l'attribut masqué, vers l'ordinateur Windows XP. Sinon, les fichiers masqués ne sont pas copiés.
-r
Copie de manière récursive vers la destination le contenu de tous les sous-répertoires de la source.
Hôte
Spécifie l'hôte local ou distant. Si l'Hôte est spécifié en tant qu'adresse IP ou bien, si le nom de l'hôte contient des points (.), vous devez indiquer l'utilisateur.
Utilisateur
Spécifie le nom d'utilisateur. Si le nom de l'utilisateur n'est pas indiqué, c'est le nom de l'utilisateur actuellement connecté qui est utilisé.
Source
Spécifie les fichiers à copier.
Chemin\Destination
Spécifie le chemin d'accès relatif au répertoire de connexion sur l'hôte distant. Utilisez les caractères d'échappement : barre oblique inverse (\), guillemets (") ou apostrophe (‘) dans les chemins d'accès distants pour utiliser des caractères génériques sur l'hôte distant. Lorsque plusieurs fichiers sources sont spécifiés, la destination doit être un répertoire.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Transferts vers des environnements de tierces parties

    La commande rcp, qui est une commande de connexion, peut également être utilisée pour les transferts vers des ordinateurs fonctionnant sous des environnements de tierces parties. Vous pouvez exécuter la commande rcp depuis un ordinateur exécutant Windows XP pour copier des fichiers entre deux autres ordinateurs qui exécutent le service rshd. Le démon rshd est disponible sur des ordinateurs Unix, et l'ordinateur qui exécute Windows XP peut prendre part au transfert vers des ordinateurs fonctionnant sous des environnements de tierces parties uniquement en tant que système à partir duquel les commandes sont exécutées.

  • Utilisation du paramètre -r

    Les paramètres Source et Chemin\Destination doivent désigner des répertoires. Vous pouvez toutefois utiliser le paramètre -r sans récursivité si la source n'est pas un répertoire.

  • Utilisation des paramètres Source et Chemin\Destination

    Les noms de fichier qui ne commencent pas par une barre oblique (/) sous Unix ou une barre oblique inverse (\) sous Windows XP sont recherchés dans le répertoire de travail en cours. Sous Windows XP, il s'agit du répertoire à partir duquel la commande est exécutée. Sur le système distant, il s'agit du répertoire de connexion de l'utilisateur distant. Un point (.) désigne le répertoire en cours. Vous pouvez utiliser les caractères d'échappement : barre oblique inverse (\), guillemets (") ou apostrophe (‘) dans les chemins d'accès distants en tant que caractères génériques sur l'ordinateur distant.

  • Privilèges distants

    La commande rcp ne permet pas d'afficher une invite pour indiquer des mots de passe. Le nom d'utilisateur courant ou spécifié doit exister sur l'ordinateur distant et autoriser l'exécution des commandes à distance avec la commande rcp.

  • Fichier .rhosts

    Le fichier .rhosts spécifie les utilisateurs ou les systèmes distants autorisés à accéder à un compte local en utilisant rsh ou rcp. Ce fichier (ou un équivalent Hosts) est nécessaire pour accéder à un système distant en utilisant ces commandes. Les commandes rsh et rcp transmettent toutes deux le nom d'utilisateur local au système distant. Le système distant utilise ce nom et l'adresse IP (généralement convertie en nom d'ordinateur) du système demandeur pour autoriser ou non l'accès. Il n'existe aucun moyen de spécifier un mot de passe pour accéder à un compte en utilisant ces commandes.

    Si l'utilisateur est connecté à un domaine, le contrôleur de domaine principal doit être disponible pour convertir le nom de connexion car celui-ci n'est pas mis en cache sur l'ordinateur local. Le nom d'utilisateur est indispensable dans le protocole rsh et la commande échoue s'il ne peut être obtenu.

    Le fichier .rhosts est un fichier texte dont chaque ligne correspond à une entrée. Une entrée se compose du nom d'ordinateur local, du nom d'utilisateur local et de commentaires éventuels. Chaque entrée est séparée par une tabulation ou un espace et les commentaires commencent par le signe dièse (#), par exemple :

    ordinateur5marie #Cet ordinateur se trouve dans la salle 31A

    Le fichier .rhosts doit se trouver dans le répertoire de base de l'utilisateur sur l'ordinateur distant. Pour plus d'informations sur l'implémentation du fichier .rhosts sur un ordinateur distant, consultez la documentation du système distant.

    Par ailleurs, vous pouvez ajouter le nom de votre ordinateur dans le fichier \Etc\Hosts sur l'ordinateur distant. Ainsi, le système distant peut authentifier les demandes émises à distance pour votre ordinateur lorsque vous utilisez les utilitaires TCP/IP de Windows XP.

  • Désignation des ordinateurs (hôtes)

    Utilisez les paramètres Ordinateur.Utilisateur pour utiliser un nom d'utilisateur qui n'est pas le nom d'utilisateur courant. Si Ordinateur.Utilisateur est spécifié avec le paramètre Source, le fichier .rhosts sur l'ordinateur distant doit contenir une entrée pour Utilisateur, comme ci-dessous :

    rcp hôte99.utilisateur7:fichier1 corp7.admin:fichier2

    Le fichier .rhosts sur corp7 doit avoir une entrée pour l'utilisateur7 sur l'hôte99.

    Quand un nom d'ordinateur est spécifié sous la forme d'un nom de domaine complet avec des points, un nom d'utilisateur doit y être ajouté, comme décrit ci-dessus. Cela évite d'interpréter la dernière partie du nom de domaine comme un nom d'utilisateur, comme ci-dessous :

    rcp domaine1.utilisateur:simon domaine2.utilisateur:louise

  • Traitement à distance

    Sur la plupart des systèmes Unix, les traitements à distance sont effectués via une commande exécutée à partir de l'environnement de connexion de l'utilisateur. Le fichier .profile ou .cshrc de l'utilisateur est exécuté avant l'analyse des noms de fichier. Les variables d'environnement exportées peuvent être utilisées (au moyen de caractères d'échappement ou de guillemets) dans les noms de fichier distants.

  • Copie de fichiers

    Si vous tentez de copier plusieurs fichiers vers un fichier plutôt que dans un répertoire, seul le dernier est copié. La commande rcp ne permet pas de copier un fichier sur lui-même (les paramètres Source et Chemin/Destination ne peuvent pas être les mêmes.)

    Si vous êtes connecté à un ordinateur Windows XP Professionnel en utilisant un domaine autre que le domaine local et si le contrôleur de domaine principal n'est pas disponible, la commande échoue, car rcp ne peut pas déterminer le nom d'utilisateur local. La même restriction s'applique à rsh.

  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est déclaré comme composant dans les propriétés d'une carte réseau dans Connexions réseau.

Exemples

Pour copier un fichier local dans le répertoire de connexion d'un ordinateur distant, tapez :

rcp nomfichier ordinateurdistant

Pour copier un fichier local dans un répertoire existant et sous un nouveau nom de fichier sur un ordinateur distant, tapez :

rcp nomfichier ordinateurdistant:/répertoire/nouveaunomfichier

Pour copier plusieurs fichiers locaux dans un sous-répertoire d'un répertoire de connexion distant, tapez :

rcp fichier1 fichier2 fichier3 ordinateurdistant:sous-répertoire/répertoirefichiers

Pour effectuer une copie à partir d'une source distante vers le répertoire en cours de l'ordinateur local, tapez :

rcp ordinateurdistant:nomfichier

Pour copier plusieurs fichiers à partir de plusieurs sources distantes vers une destination distante, avec des noms d'utilisateur différents, tapez :

rcp distant1.utilisateur1:fichier1 distant2.utilisateur2:fichier2 destdistante.utildest:répertoire


Recover

Récupère les informations lisibles d'un disque endommagé ou défectueux.

Syntaxe

recover [Lecteur:][Chemin] NomFichier

Paramètres

[Lecteur:][Chemin] NomFichier
Indique l'emplacement et le nom du fichier à récupérer.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • La commande recover lit les fichiers secteur par secteur et récupère les données des secteurs en bon état. Les données des secteurs défectueux sont perdues.
  • Restrictions relatives à [Lecteur:][Chemin]NomFichier

    Il n'est pas possible d'utiliser des caractères génériques (* et ?) avec la commande recover. Vous devez obligatoirement désigner un fichier.

  • Réintroduction des données perdues

    Comme toutes les données des secteurs défectueux sont perdues lors de la récupération des fichiers, vous devez récupérer les fichiers un à un. Vous pouvez alors utiliser cette méthode pour modifier chaque fichier et y réintroduire les données manquantes après la récupération.

  • Récupération des secteurs défectueux

    Les secteurs défectueux signalés par chkdsk ont été marqués comme tels lors de la préparation initiale du disque. Ils ne présentent aucun danger et recover ne les affecte pas.

Exemples

Pour récupérer le fichier MobyDick.txt dans le répertoire \Romans du lecteur D:, tapez :

recover d:\romans\mobydick.txt


Gpupdate

Permet d'actualiser les paramètres de stratégie de groupe locaux et Active Directory, y compris les paramètres de sécurité. Cette commande remplace l'option désormais caduque /refreshpolicy de la commande secedit.

Syntaxe

gpupdate [/target:{ordinateur|utilisateur}] [/force] [/wait:valeur] [/logoff] [/boot]

Paramètres

/target:{ordinateur|utilisateur}
Permet de traiter uniquement les paramètres de l'ordinateur ou les paramètres de l'utilisateur courant. Par défaut, sont traités à la fois les paramètres de l'ordinateur et de l'utilisateur.
/force
Permet à la fonction d'actualisation d'ignorer toutes les optimisations et de réappliquer tous les paramètres.
/wait:valeur
Indique le nombre de secondes pendant lequel la stratégie en cours attend avant de prendre fin. La valeur par défaut est 600 secondes. 0 signifie « aucune attente » ; -1 signifie « attente indéfinie ».
/logoff
Permet de mettre fin à la session une fois l'actualisation terminée. Ce paramètre est obligatoire pour les extensions de stratégies de groupe côté client qui ne sont pas exécutées dans le cadre d'un cycle d'actualisation en arrière-plan mais qui sont appliquées lorsque l'utilisateur ouvre une session, telles que les stratégies d'installation de logiciel et de redirection de dossier traitées au niveau de l'utilisateur. Cette option est sans effet si, parmi les extensions appelées, aucune ne demande à l'utilisateur de mettre fin à la session ouverte.
/boot
Permet de redémarrer l'ordinateur une fois l'actualisation terminée. Ce paramètre est obligatoire pour les extensions de stratégies de groupe côté client qui ne sont pas exécutées dans le cadre d'un cycle d'actualisation en arrière-plan mais qui sont appliquées au démarrage de l'ordinateur, telles que les stratégies d'installation de logiciel traitées au niveau de l'ordinateur. Cette option est sans effet si, parmi les extensions appelées, aucune n'exige le redémarrage de l'ordinateur.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si vous faites une erreur de syntaxe, un résumé s'affiche. Sa présentation est identique à celle de la présente rubrique d'aide.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande gpupdate :

gpupdate

gpupdate /target:ordinateur

gpupdate /force /wait:100

gpupdate /boot


Reg

Permet d'ajouter, de modifier et d'afficher des valeurs et des données de sous-clés de Registre dans des entrées du Registre.

Pour afficher la syntaxe d'une commande, sélectionnez-la :

reg add

Permet d'ajouter une nouvelle sous-clé ou une entrée dans le Registre.

Syntaxe

reg add NomClé [/v NomEntrée|/ve] [/t TypeDonnées] [/s séparateur] [/d valeur] [/f]

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC.
/v NomEntrée
Spécifie le nom de l'entrée à ajouter sous la sous-clé indiquée.
/ve
Spécifie que l'entrée qui est ajoutée dans le Registre a une valeur nulle.
/t TypeDonnées
Spécifie le type de données pour la valeur de l'entrée. Les types de données peuvent être les suivants :

REG_SZ

REG_MULTI_SZ

REG_DWORD_BIG_ENDIAN

REG_DWORD

REG_BINARY

REG_DWORD_LITTLE_ENDIAN

REG_LINK

REG_FULL_RESOURCE_DESCRIPTOR

REG_EXPAND_SZ

/s séparateur
Spécifie le caractère utilisé pour séparer les instances des données. Utilisé si le type de données REG_MULTI_SZ est spécifié et si plusieurs entrées doivent être répertoriées. Si aucun séparateur n'est spécifié, le séparateur utilisé par défaut est \0.
/d valeur
Spécifie la valeur de la nouvelle entrée de Registre.
/f
Ajoute la sous-clé ou l'entrée sans demander de confirmation.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les sous-arborescences ne peuvent pas être ajoutées par cette opération. Dans cette version de Reg, aucune confirmation n'est demandée lors de l'ajout d'une sous-clé.
  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg add.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande reg add :

reg add \hklm\software\myco /v data /t reg_binary /d fe340ead
reg add "hkcu\software\microsoft\winmine" /v Name3 /t reg_sz /d Anonymous
reg add "hkcu\software\microsoft\winmine" /v Time3 /t reg_dword /d 5

reg compare

Compare les sous-clés ou les entrées du Registre que vous avez spécifiées.

Syntaxe

reg compare NomClé1 NomClé2 [/v NomEntrée | /ve] {[/oa]|[/od]|[/os]|[on]} [/s]

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC. Si un ordinateur distant est spécifié, seules les sous-arborescences HKLM et HKU peuvent être utilisées.
/v NomEntrée
Compare une entrée spécifique sous la sous-clé.
/ve
Spécifie que seules les entrées qui n'ont pas de valeur seront comparées.
{[/oa]|[/od]|[/os]|[on]}
Spécifie la façon dont sont affichées les différences et les correspondances. Le paramètre par défaut est /od.
Valeur | Description
/oa | Spécifie la façon dont sont affichées toutes les différences et les correspondances. Par défaut, seules les différences sont répertoriées.
/od | Spécifie que seules les différences sont affichées. Il s'agit du paramètre par défaut.
/os | Spécifie que seules les correspondances sont affichées. Par défaut, seules les différences sont répertoriées.
/on | Spécifie que rien ne doit être affiché. Par défaut, seules les différences sont répertoriées.
/s séparateur
Compare toutes les sous-clés et les entrées.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg compare.
    Valeur | Description
    0 | La comparaison a réussi et le résultat est identique.
    1 | La comparaison a échoué.
    2 | La comparaison a réussi et des différences ont été trouvées.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande reg compare :

reg compare "hkcu\software\microsoft\winmine" "hkcu\software\microsoft\winmine" /od /s

reg copy

Copie une entrée du Registre dans un emplacement que vous avez spécifié sur l'ordinateur local ou distant.

Syntaxe

reg copy NomClé1 NomClé2 [/s] [/f]

Paramètres

NomClé1
Spécifie le chemin d'accès complet de la sous-clé à copier. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC. Si un ordinateur distant est spécifié, seules les sous-arborescences HKLM et HKU peuvent être utilisées.
NomClé2
Spécifie le chemin d'accès complet de la destination de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC. Si un ordinateur distant est spécifié, seules les sous-arborescences HKLM et HKU peuvent être utilisées.
/s
Copie toutes les sous-clés et les entrées sous la sous-clé spécifiée.
/f
Copie la sous-clé sans demander confirmation.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Dans cette version de Reg, aucune confirmation n'est demandée lors de la copie d'une sous-clé.
  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg copy.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande reg copy :

reg copy "hkcu\software\microsoft\winmine" "hkcu\software\microsoft\winminebk" /s /f
reg copy "hkcu\software\microsoft\winminebk" "hkcu\software\microsoft\winmine" /s

reg delete

Permet de supprimer une sous-clé ou des entrées du Registre.

Syntaxe

reg delete NomEntrée [{/v NomEntrée|/ve|/va}] [/f]

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC.
/v NomEntrée
Supprime une entrée spécifique sous la sous-clé. Si aucune entrée n'est indiquée, toutes les entrées et sous-clés figurant sous la sous-clé sont supprimées.
/ve
Spécifie que seules les entrées qui n'ont pas de valeur seront supprimées.
/va
Supprime toutes les entrées sous la sous-clé spécifiée. Ce paramètre ne permet pas de supprimer les sous-clés sous la sous-clé spécifiée.
/f
Supprime la sous-clé du Registre ou l'entrée sans demander de confirmation.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg delete.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande reg delete :

reg delete "hkcu\software\microsoft\winmine" /v Name1
reg delete "hkcu\software\microsoft\winmine" /v Time1
reg delete "hkcu\software\microsoft\winmine" /va

reg export

Copie des sous-clés, des entrées et des valeurs spécifiées dans un fichier afin de pouvoir les transmettre à d'autres serveurs.

Syntaxe

reg export NomClé NomFichier

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. La commande export fonctionne uniquement avec l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC.
NomFichier
Indique le chemin d'accès et le nom du fichier à exporter. Le fichier doit avoir l'extension .reg.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg export.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

L'exemple suivant illustre la façon d'utiliser la commande reg export :

reg export "hkcu\software\microsoft\winmine" c:\data\regbackups\wmbkup.reg

reg import

Copie un fichier contenant des sous-clés de Registre, des entrées et des valeurs exportées vers le Registre d'un ordinateur local.

Syntaxe

reg import NomFichier

Paramètres

NomFichier
Spécifie le nom et le chemin d'accès du fichier qui doit être copié dans le Registre de l'ordinateur local. Ce fichier doit être créé préalablement avec la commande reg export.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg import.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

L'exemple suivant illustre la façon d'utiliser la commande reg import :

reg import "hkcu\software\microsoft\winmine" c:\data\regbackups\wmbkup.reg

reg load

Écrit les sous-clés et les entrées sauvegardées dans une autre sous-clé du Registre. Le fichier dans lequel elles sont enregistrées est un fichier temporaire utilisé pour résoudre des problèmes ou modifier des entrées de Registre.

Syntaxe

reg load NomClé NomFichier

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC.
NomFichier
Indique le chemin d'accès et le nom du fichier qui doit être chargé. Le fichier doit avoir été créé avec la commande reg save et avoir une extension .hiv.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg load.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

L'exemple suivant illustre la façon d'utiliser la commande reg load :

reg load "hkcu\software\microsoft\winminebk2" wmbkup.hiv

reg query

Affiche sous forme de liste les niveaux suivants de sous-clés et d'entrées situés sous une sous-clé du Registre.

Syntaxe

reg query NomClé [{/v NomEntrée|/ve}] [/s]

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC. Si un ordinateur distant est spécifié, seules les sous-arborescences HKLM et HKU peuvent être utilisées.
/v NomEntrée
Renvoie une entrée spécifique et sa valeur. Ce paramètre renvoie uniquement les entrées qui figure dans le niveau situé directement sous la sous-clé spécifiée. Les entrées situées dans les sous-clés de la sous-clé courante ne seront pas trouvées. Si vous n'indiquez pas le paramètre NomEntrée, toutes les entrées figurant sous la sous-clé sont renvoyées.
/ve
Spécifie que seules les entrées qui n'ont pas de valeur seront renvoyées.
/s
Renvoie toutes les sous-clés et les entrées de tous les niveaux. En l'absence de ce paramètre, seul le niveau suivant des sous-clés et des entrées est renvoyé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg query.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande reg query :

reg query "hklm\system\currentcontrolset\control\session manager" /v maxstacktracedepth

reg query "hkcu\software\microsoft\winmine" /s

reg restore

Écrit les sous-clés et les entrées sauvegardées dans le Registre.

Syntaxe

reg restore NomClé NomFichier

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. La commande restore fonctionne uniquement avec l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC.
NomFichier
Indique le chemin d'accès et le nom du fichier qui doit être de nouveau écrit dans le Registre. Le fichier doit être créé préalablement avec la commande reg save et avoir une extension .hiv.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cette commande est utilisée pour remplacer les entrées du Registre qui ont été modifiées. Avant de modifier des entrées, enregistrez la sous-clé parente avec la commande reg save. Si la modification échoue, restaurez la sous-clé au moyen de cette même commande.
  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg restore.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

L'exemple suivant illustre la façon d'utiliser la commande reg restore :

reg restore "hkcu\software\microsoft\winmine" wmbkup.hiv

reg save

Enregistre dans un fichier spécifique une copie des sous-clés, des entrées et des valeurs du Registre que vous avez spécifiées.

Syntaxe

reg save NomClé NomFichier

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC.
NomFichier
Indique le chemin d'accès et le nom du fichier à créer. Si vous n'indiquez pas de chemin d'accès, c'est le chemin courant qui est utilisé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg save.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

L'exemple suivant illustre la façon d'utiliser la commande reg save :

reg save "hkcu\software\microsoft\winmine" wmbkup.hiv

reg unload

Supprime une section du Registre qui a été chargée avec la commande reg load.

Syntaxe

reg unload NomClé

Paramètres

NomClé
Spécifie le chemin d'accès complet de la sous-clé. Pour les ordinateurs distants, spécifiez le nom de l'ordinateur avant le chemin d'accès de la sous-clé comme suit : \\NomOrdinateur\CheminVersSousClé. Si vous omettez NomOrdinateur, l'opération utilisera par défaut l'ordinateur local. Spécifiez la sous-arborescence appropriée au début du chemin d'accès. Les sous-arborescences valides sont HKLM, HKCU, HKCR, HKU et HKCC.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le tableau suivant répertorie les valeurs renvoyées par la commande reg unload.
    Valeur | Description
    0 | Succès
    1 | Échec

Exemples

L'exemple suivant illustre la façon d'utiliser la commande reg unload :

reg unload "hkcu\software\microsoft\winminebk2"

Attention

  • Une modification incorrecte du Registre peut endommager gravement votre système. Avant de modifier le Registre, il est conseillé d'effectuer une copie de sauvegarde de toutes les données importantes sur l'ordinateur.

Attention

  • Ne modifiez pas le Registre directement. Envisagez cette solution uniquement si vous n'avez pas d'autres choix. L'Éditeur du Registre ignore la sécurité standard et accepte, de ce fait, des paramètres qui risquent de diminuer les performances du système, de l'endommager voire même, de nécessiter la réinstallation de Windows. Pour modifier les paramètres du Registre et procéder en toute sécurité, utilisez la fonction Programmes du Panneau de configuration ou la console MMC (Microsoft Management Console). Si vous êtes obligé de modifier le Registre directement, pensez à le sauvegarder avant. Pour plus d'informations, consultez l'aide de l'Éditeur du Registre.

Remarques

  • La commande Reg permet de modifier directement le Registre des ordinateurs locaux ou distants. Les modifications apportées risquent de rendre les ordinateurs inopérants et de nécessiter une nouvelle installation du système d'exploitation. Pour modifier le Registre, il est conseillé, au lieu de le modifier directement, d'utiliser le Panneau de configuration ou la console MMC à chaque fois que cela est possible.
  • Certaines opérations autorisent l'affichage ou la configuration des entrées du Registre sur les ordinateurs locaux ou distants, tandis que d'autres opérations autorisent uniquement la configuration des ordinateurs locaux. Par ailleurs, l'accès à distance au Registre limite les paramètres que vous pouvez utiliser dans les commandes. Contrôlez la syntaxe des commandes pour vous assurer qu'elles peuvent être utilisées sur des ordinateurs distants et vérifier les paramètres qu'il est possible d'utiliser dans ce cas.


Regsvr32

Cet utilitaire de ligne de commandes inscrit les fichiers .dll en tant que composants de commandes dans le Registre.

Syntaxe

regsvr32 [/u] [/s] [/n] [/i[:cmdline]] nomdll

Paramètres

/u
Annule l'inscription du serveur.
/s
Indique à l'utilitaire regsvr32 de fonctionner sans avertissement et de ne pas afficher de messages.
/n
Indique de ne pas appeler DllregisterServer. Vous devez utiliser cette option avec le paramètre /i.
/i:cmdline
Appelle DllInstall en lui passant une ligne de commandes facultative. Utilisé avec le paramètre /u, permet d'appeler dll uninstall.
nomdll
Indique le nom du fichier dll qui doit être inscrit.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Pour inscrire le fichier .dll pour le schéma Active Directory, tapez :

regsvr32 schmmgmt.dll


Rem

Permet d'inclure des commentaires (des remarques) dans un fichier de commandes ou dans vos fichiers de configuration.

Syntaxe

rem [commentaire]

Paramètres

commentaire
Représente toute chaîne de caractères à inclure comme commentaire.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Emploi de la commande echo pour afficher les commentaires

    La commande rem n'affiche pas les commentaires à l'écran. Vous devez utiliser la commande echo on dans votre fichier de commandes ou votre fichier Config.nt pour afficher les commentaires à l'écran.

  • Restrictions relatives aux commentaires des fichiers de commandes

    Il est impossible d'utiliser un caractère de redirection “ ( ”, “ ) ” ou “ | ” dans un commentaire de fichier de commandes.

  • Emploi de rem pour ajouter un espace vertical

    Bien que rem puisse être utilisée sans commentaire pour ajouter un espace vertical à un fichier de commandes, vous pouvez aussi utiliser des lignes vierges. Les lignes vierges sont ignorées lors du traitement du programme de commandes.

Exemples

L'exemple suivant représente un fichier de commandes qui utilise des remarques à titre d'explication et pour l'espacement vertical :

@echo off
rem Ce programme de commandes formate et vérifie les nouvelles disquettes.
rem Il est appelé verinouv.bat.
rem
echo Insérez une nouvelle disquette dans le lecteur B.
pause
format b: /v
chkdsk b:

Supposez que vous souhaitiez inclure dans votre fichier Config.nt un commentaire explicatif avant la commande prompt. Pour cela, ajoutez les lignes suivantes dans le fichier Config.nt :

rem Crée une invite indiquant le répertoire en cours
prompt $p$g


rename (ren)

Modifie le nom d'un fichier ou d'un groupe de fichiers.

Syntaxe

rename [Lecteur:][Chemin] NomFichier1 NomFichier2

ren [Lecteur:][Chemin] NomFichier1 NomFichier2

Paramètres

[Lecteur:][Chemin] NomFichier1
Indique l'emplacement et le nom du fichier ou du groupe de fichiers à renommer.
NomFichier2
Spécifie le nouveau nom du fichier. Si vous utilisez des caractères génériques (* et ?), NomFichier2 désigne les nouveaux noms des fichiers. Il est impossible de désigner un nouveau lecteur ou chemin lorsque vous renommez des fichiers.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Modification des noms de fichier

    Vous pouvez renommer tous les fichiers correspondant au nom spécifié. Il est cependant impossible d'utiliser la commande rename pour renommer des fichiers qui se trouvent sur des unités différentes ou pour déplacer des fichiers dans un autre répertoire.

  • Utilisation de caractères génériques dans la commande rename

    Il est possible d'utiliser des caractères génériques (* et ?) dans l'un ou l'autre des paramètres NomFichier. Si vous utilisez des caractères génériques dans NomFichier2, les caractères qu'ils représentent seront identiques aux caractères correspondants dans NomFichier1.

  • La commande rename ne fonctionne pas si le paramètre NomFichier2 existe déjà.

    Si, pour NomFichier2, vous spécifiez un nom de fichier qui existe déjà, la commande rename affiche le message suivant :

    Nom de fichier déjà existant ou fichier introuvable

Exemples

Supposez que vous souhaitiez modifier les extensions de tous les noms de fichier du répertoire en cours qui portent l'extension .txt en remplaçant par exemple, les extensions .txt par des extensions .doc. Pour cela, tapez :

ren *.txt *.doc

Pour renommer un fichier ou un répertoire nommé Chap10 en Part10, tapez :

ren chap10 part10


Replace

Remplace les fichiers du répertoire de destination par les fichiers du répertoire source qui portent le même nom. Vous pouvez aussi utiliser la commande replace pour ajouter des noms de fichier uniques dans le répertoire de destination.

Syntaxe

replace [lecteur1:][chemin1] NomFichier [lecteur2:][chemin2] [/a] [/p] [/r] [/w]

replace [lecteur1:][chemin1] NomFichier [lecteur2:][chemin2] [/p] [/r] [/s] [/w] [/u]

Paramètres

[lecteur1:][chemin1] NomFichier
Indique l'emplacement et le nom du fichier ou groupe de fichiers source.
[lecteur2:][chemin2]
Indique l'emplacement du fichier de destination. Il n'est pas possible de spécifier un nom pour les fichiers que vous remplacez. Si vous ne désignez ni lecteur ni répertoire, la commande replace utilise le lecteur et le répertoire en cours comme destination.
/a
Au lieu de remplacer des fichiers existants, ajoute de nouveaux fichiers au répertoire de destination. Il est impossible d'utiliser cette option de ligne de commandes avec les options /s ou /u.
/p
Affiche une demande de confirmation avant de remplacer un fichier de destination ou d'ajouter un fichier source.
/r
Remplace aussi bien les fichiers en lecture seule que les fichiers non protégés. Si vous essayez de remplacer un fichier en lecture seule sans utiliser cette option de ligne de commandes, une erreur se produit et arrête l'opération de remplacement.
/w
Force la commande replace à attendre que vous insériez une disquette avant de commencer à chercher les fichiers sources. En l'absence du paramètre /w, la commande replace commence à remplacer ou à ajouter les fichiers immédiatement après que vous avez appuyé sur ENTRÉE.
/s
Lance les recherches dans tous les sous-répertoires du répertoire de destination et remplace tous les fichiers correspondant à la spécification. Il n'est pas possible d'utiliser l'option de ligne de commandes /s avec l'option /a. La commande replace n'effectue pas les recherches dans les sous-répertoires spécifiés par le paramètre chemin1.
/u
Remplace (met à jour) uniquement les fichiers du répertoire de destination qui sont plus anciens que ceux du répertoire source. Il n'est pas possible d'utiliser l'option de ligne de commandes /u avec l'option /a.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Messages de la commande replace

    Au fur et à mesure que la commande replace ajoute ou remplace des fichiers, leurs noms s'affichent à l'écran. Une fois l'opération terminée, la commande replace affiche une ligne récapitulative sous l'un des formats suivants :

    nnn fichiers ajoutés
    nnn fichiers remplacés

    aucun fichier ajouté
    aucun fichier remplacé

  • Remplacement des fichiers sur des disquettes

    Si vous utilisez des disquettes et si vous devez changer de disquette pendant l'opération de remplacement, vous pouvez utiliser l'option de ligne de commandes /w afin que la commande replace attende que vous échangiez les disquettes lorsque c'est nécessaire.

  • Limites de la commande replace

    Il est impossible d'utiliser la commande replace pour mettre à jour des fichiers avec des attributs fichier caché ou fichier système. Pour plus d'informations sur la modification des attributs fichier caché et fichier système, cliquez sur attrib dans la liste Rubriques connexes.

  • Codes de sortie de la commande replace

    La liste ci-dessous indique chaque code de sortie, accompagné d'une brève description :

    Code de sortie | Description
    0 | La commande replace a remplacé ou ajouté les fichiers avec succès.
    1 | La commande replace a rencontré une version non correcte de MS-DOS.
    2 | La commande replace n'a pas trouvé les fichiers sources.
    3 | La commande replace n'a pas trouvé le chemin source ou de destination.
    5 | L'utilisateur n'a pas accès aux fichiers que vous voulez remplacer.
    8 | La mémoire système est insuffisante pour exécuter la commande.
    11 | L'utilisateur a utilisé une syntaxe incorrecte sur la ligne de commande.

    Vous pouvez utiliser le paramètre errorlevel sur la ligne de commandes if dans un programme de commandes de la ligne de commandes pour traiter les codes de sortie renvoyés par replace. Pour obtenir un exemple de programme de commandes qui traite les codes de sortie, cliquez sur if dans la liste Rubriques connexes.

Exemples

Supposez que plusieurs répertoires du disque C contiennent des versions différentes d'un fichier nommé Tél.cli où sont mémorisés les noms et les numéros de téléphone des clients. Pour remplacer tous ces fichiers par la dernière version du fichier Tél.cli enregistrée sur la disquette qui se trouve dans le lecteur A, tapez la commande suivante :

replace a:\tel.cli c:\ /s

Pour ajouter de nouveaux pilotes d'imprimante dans un répertoire du disque C nommé Outils, qui contient déjà plusieurs fichiers de pilotes d'imprimante pour un programme de traitement de texte, tapez :

replace a:*.prd c:\outils /a

Cette commande cherche tous les fichiers avec l'extension .prd dans le répertoire en cours du lecteur A, puis ajoute ces fichiers dans le répertoire Outils du disque C. Comme l'option de ligne de commandes /a est incluse, la commande replace n'ajoute que les fichiers du lecteur A qui n'existent pas sur le disque C.


Rexec

Exécute des commandes sur des ordinateurs distants utilisant le service Rexec (démon). La commande rexec authentifie le nom d'utilisateur sur l'ordinateur distant avant d'exécuter la commande spécifiée. Windows XP et Windows 2000 ne fournissent pas le service Rexec. Utilisée sans paramètres, la commande rexec permet d'afficher l'aide.

Syntaxe

rexec [Hôte] [-l NomUtilisateur] [-n] [Commande]

Paramètres

Hôte
Spécifie l'hôte distant (l'ordinateur) sur lequel doit être exécutée la Commande, par adresse IP ou par nom.
-l NomUtilisateur
Spécifie le nom d'utilisateur sur l'ordinateur distant. Si cet élément est omis, le nom de l'utilisateur actuellement connecté est utilisé.
-n
Redirige l'entrée rexec vers NULL. Cela empêche l'affichage des résultats de la commande sur l'ordinateur local.
Commande
Spécifie la commande à exécuter sur l'ordinateur distant.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Séquence standard

    La commande rexec invite l'utilisateur à entrer un mot de passe et l'authentifie sur l'ordinateur distant. Si l'authentification réussit, la commande est exécutée.

    La commande rexec copie l'entrée standard vers la commande distante, la sortie standard de la Commande distante vers sa sortie standard et l'erreur standard de la commande distante vers son erreur standard. L'exécution de la commande Rexec prend fin en principe en même temps que la commande distante.

  • Utilisation des symboles de redirection

    Pour que la redirection s'exécute sur l'ordinateur distant, placez les symboles de redirection entre guillemets, (par exemple ">>"). Si vous n'utilisez pas les guillemets, la redirection est effectuée sur l'ordinateur local. Par exemple, la commande suivante ajoute le FichierDistant au fichier local FichierLocal :

    rexec autreordinateur cat fichierdistant >> fichierlocal

    La commande suivante ajoute le FichierDistant à l'AutreFichierDistant :

    rexec autreordinateur cat fichierdistant ">>" autrefichierdistant

  • Utilisation des commandes interactives

    La plupart des commandes interactives ne peuvent pas être exécutées. Par exemple, vi et emacs ne peuvent pas être exécutées à l'aide de rexec. Vous pouvez par contre utiliser à la place la commande telnet.

  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est déclaré comme composant dans les propriétés d'une carte réseau dans Connexions réseau.

Exemples

Pour exécuter la commande telcon sur l'ordinateur distant vax1 en utilisant le nom admin1, tapez la commande suivante :

rexec vax1 -l admin1 telcon


Rmdir (rd)

Supprime un répertoire.

Syntaxe

rmdir [Lecteur:]Chemin [/s] [/q]

rd [Lecteur:]Chemin [/s] [/q]

Paramètres

[Lecteur:]Chemin
Indique l'emplacement et le nom du répertoire à supprimer.
/s
Supprime le répertoire spécifié et tous ses sous-répertoires, y compris tous les fichiers qui y figurent. Ce commutateur est utilisé pour supprimer une arborescence.
/q
Exécute la commande rmdir en mode silencieux. Supprime les répertoires sans confirmation.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de la commande rmdir sur la console de récupération

    La commande rmdir est disponible, avec d'autres paramètres, à partir de la console de récupération.

  • Impossibilité de supprimer un répertoire contenant des fichiers cachés ou système

    Il est impossible de supprimer un répertoire qui contient des fichiers, fichiers cachés ou système compris. Si vous tentez de supprimer ce type de répertoire, le message suivant s'affiche :

    Répertoire non vide

    Utilisez la commande dir pour afficher la liste des fichiers cachés et système, et la commande attrib pour supprimer les attributs cachés et système de ces fichiers. Pour plus d'informations, consultez Rubriques connexes.

  • Utilisation de la barre oblique inverse avec le paramètre chemin

    Si vous insérez une barre oblique inverse (\) avant le premier nom de répertoire dans le chemin d'accès, ce répertoire est traité comme un sous-répertoire du répertoire racine et ce, quel que soit le répertoire en cours. Si vous n'insérez pas cette barre avant ce premier nom, il est traité comme un sous-répertoire du répertoire courant.

  • Suppression du répertoire en cours

    Il n'est pas possible d'utiliser la commande rmdir pour supprimer le répertoire en cours. Vous devez d'abord passer à un répertoire différent (qui n'est pas un sous-répertoire du répertoire en cours), puis utiliser rmdir suivie d'un chemin d'accès. Si vous tentez de supprimer le répertoire en cours, le message suivant s'affiche :

    Le processus ne peut pas accéder au fichier car ce fichier est utilisé par un autre processus.

Exemples

Pour supprimer un répertoire nommé \User\Simon, assurez-vous d'abord qu'il est vide comme indiqué ci-dessous : Pour effectuer cette opération, tapez :

dir \user\simon /a

Seuls les signes . (point) et .. (deux points consécutifs) doivent être affichés.

Ensuite, à partir de n'importe quel répertoire, à l'exception de \User\Simon, tapez :

rmdir \user\simon

Pour supprimer le répertoire \User et tous les fichiers et sous-répertoires qu'il contient, tapez :

rmdir /s \user


Route

Affiche et modifie les entrées dans la table de routage IP locale. Utilisée sans paramètres, la commande route permet d'afficher l'aide.

Syntaxe

route [-f] [-p] [Commande [Destination] [mask MasqueSousRéseau] [Passerelle] [metric Métrique]] [if Interface]]

Paramètres

-f
Supprime, dans la table de routage, toutes les entrées qui ne correspondent pas à des itinéraires hôtes (itinéraires avec le masque de sous-réseau 255.255.255.255), à l'itinéraire réseau de bouclage (itinéraire avec la destination 127.0.0.0 et le masque de sous-réseau 255.0.0.0) ou un itinéraire multidiffusion (itinéraires avec la destination 224.0.0.0 et le masque de sous-réseau 240.0.0.0). Lorsque cette commande est utilisée avec d'autres commandes (telles que add, change ou delete), le contenu de la table est supprimé avant l'exécution de la commande.
-p
Lorsque ce paramètre est utilisé avec la commande add, l'itinéraire spécifié est ajouté au Registre et permet d'initialiser la table de routage IP à chaque fois que le protocole TCP/IP est utilisé. Par défaut, les itinéraires ajoutés ne sont pas conservés lorsque le protocole TCP/IP est lancé. Associé à la commande print, ce paramètre affiche la liste des itinéraires persistants. Ce paramètre est ignoré pour toutes les autres commandes. Les itinéraires persistants sont stockés dans le Registre dans : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\PersistentRoutes.
Commande
Spécifie la commande à exécuter. Le tableau suivant présente la liste des commandes autorisées.
Commande | Action
add | Ajoute un itinéraire.
change | Modifie un itinéraire existant.
delete | Supprime un ou plusieurs itinéraires.
print | Imprime un ou plusieurs itinéraires.
Destination
Spécifie la destination réseau de l'itinéraire. La destination peut être une adresse réseau IP (dans laquelle les bits hôtes de l'adresse réseau sont définis à 0), une adresse IP pour un itinéraire hôte ou 0.0.0.0. pour l'itinéraire par défaut.
mask MasqueSousRéseau
Spécifie le masque de sous-réseau associé à la destination réseau. Le masque de sous-réseau peut être le masque de sous-réseau approprié d'une adresse réseau IP, 255.255.255.255 pour un itinéraire hôte ou 0.0.0.0. pour l'itinéraire par défaut. Si ce paramètre est omis, le masque de sous-réseau est 255.255.255.255. Étant donné la relation existant entre la destination et le masque de sous-réseau dans la définition des itinéraires, la destination ne peut pas être plus spécifique que son masque de sous-réseau correspondant. En d'autres termes, il est impossible de trouver un bit défini à 1 dans la destination si le bit correspondant dans le masque de sous-réseau est défini à 0.
Passerelle
Spécifie l'adresse de transmission ou le tronçon suivant de l'adresse IP par lequel il est possible d'atteindre les adresses définies par la destination réseau et le masque de sous-réseau. Pour les itinéraires de sous-réseaux liés localement, l'adresse de la passerelle correspond à l'adresse IP attribuée à l'interface liée au sous-réseau. Pour les itinéraires distants, accessibles via un ou plusieurs routeurs, l'adresse de la passerelle est une adresse IP qu'il est possible d'atteindre directement et qui est attribuée à un routeur voisin.
metric Métrique
Spécifie une métrique de coût exprimée par un nombre entier (compris entre 1 et 9999) pour l'itinéraire. Cette valeur est utilisée lorsqu'il est nécessaire de choisir parmi plusieurs itinéraires dans la table de routage qui correspondent le plus à l'adresse de destination d'un paquet en cours de transmission. C'est l'itinéraire dont la métrique est la plus faible qui est choisi. La métrique peut refléter le nombre de tronçons, la vitesse permise par le chemin d'accès, la fiabilité et le débit du chemin d'accès ou les propriétés administratives.
if Interface
Spécifie l'index d'interface permettant d'atteindre la destination. Pour obtenir la liste des interfaces et des index correspondants, utilisez la commande route print. Vous pouvez utiliser des valeurs décimales ou hexadécimales pour l'index d'interface. Si vous utilisez des valeurs hexadécimales, faites précéder la valeur de 0x. Si le paramètre if est omis, l'interface est déterminée à partir de l'adresse de la passerelle.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les valeurs élevées figurant dans la colonne metric de la table de routage autorisent le protocole TCP/IP à déterminer automatiquement la métrique des itinéraires dans la table de routage en fonction de la configuration de l'adresses IP, du masque de sous-réseau et de la passerelle par défaut pour chaque interface de réseau local. Le calcul automatique de la métrique de l'interface, activé par défaut, permet de déterminer la vitesse de chaque interface et d'ajuster les métriques des itinéraires pour chaque interface de façon à ce que l'interface la plus rapide crée l'itinéraire avec la métrique la plus faible. Pour supprimer les valeurs de métriques élevées, désactivez le calcul automatique de la métrique de l'interface à partir des propriétés avancées du protocole TCP/IP pour chaque connexion au réseau local.
  • Il est possible d'utiliser des noms pour le paramètre Destination si les entrées adéquates existent dans le fichier local Réseaux stocké dans le dossier RacineSystème\System32\Drivers\Etc. Il est également possible d'indiquer des noms pour le paramètre Passerelle à condition qu'ils puissent être convertis en adresse IP au moyen des techniques de résolution de nom hôte standard comme les demandes DNS (Domain Name System) ou bien, grâce au fichier local Hosts stocké dans le dossier RacineSystème\system32\drivers\etc et grâce à la résolution de nom NetBIOS.
  • Avec la commande print ou delete, le paramètre Passerelle peut être omis et des caractères génériques peuvent être utilisés pour la destination et la passerelle. La valeur représentant la Destination peut être une valeur générique spécifiée par un astérisque (*). Si la destination spécifiée contient un astérisque (*) ou un point d'interrogation (?), elle est traitée comme un caractère générique et seuls les itinéraires de destination correspondants sont imprimés ou supprimés. L'astérisque remplace n'importe quelle chaîne et le point d'interrogation tout caractère simple. Dans les exemples suivants : 10.*.1, 192.168.*, 127.* et *224*, l'utilisation de l'astérisque est toujours valide.
  • L'utilisation d'une combinaison incorrecte d'une destination et d'une valeur de masque de sous-réseau affiche le message d'erreur suivant : « Route: mauvais masque de réseau d'adresse de passerelle ». Ce message d'erreur apparaît lorsque la destination contient un ou plusieurs bits définis à 1 dans les emplacements de bits où le bit du masque de sous-réseau correspondant est défini à 0. Pour tester cette condition, exprimez la destination et le masque de sous-réseau en utilisant une notation binaire. Dans la notation binaire, le masque de sous-réseau correspond à une série de bits 1, pour la partie adresse réseau de la destination et à une série de bits 0 pour la partie adresse hôte de la destination. Contrôlez la destination pour savoir si elle contient des bits définis à 1 dans la partie correspondant à l'adresse hôte (telle que définie par le masque de sous-réseau).
  • Le paramètre -p est accepté dans la commande route uniquement pour Windows NT 4.0, Windows 2000, Windows Millennium Edition et Windows XP. Ce paramètre n'est pas accepté dans la commande route pour Windows 95 ou Windows 98.
  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est déclaré comme composant dans les propriétés d'une carte réseau dans lesConnexions réseau.

Exemples

Pour afficher tout le contenu de la table de routage IP, tapez :

route print

Pour afficher les itinéraires qui commencent par 10. dans la table de routage tapez :

route print 10.*

Pour ajouter un itinéraire par défaut avec l'adresse de la passerelle par défaut 192.168.12.1, tapez :

route add 0.0.0.0 mask 0.0.0.0 192.168.12.1

Pour ajouter un itinéraire à la destination 10.41.0.0 avec le masque de sous-réseau 255.255.0.0 et l'adresse de tronçon suivant 10.27.0.1, tapez :

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Pour ajouter un itinéraire persistant à la destination 10.41.0.0. avec le masque de sous-réseau 255.255.0.0 et l'adresse de tronçon suivant 10.27.0.1, tapez :

route -p add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Pour ajouter un itinéraire à la destination 10.41.0.0 avec le masque de sous-réseau 255.255.0.0, l'adresse de tronçon suivant 10.27.0.1 et la métrique de coût 7, tapez :

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 metric 7

Pour ajouter un itinéraire à la destination 10.41.0.0 avec le masque de sous-réseau 255.255.0.0, l'adresse de tronçon suivant 10.27.0.1 et pour utiliser l'index d'interface 0x3, tapez :

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 if 0x3

Pour supprimer l'itinéraire vers la destination 10.41.0.0 avec le masque de sous-réseau 255.255.0.0 tapez :

route delete 10.41.0.0 mask 255.255.0.0

Pour supprimer de la table de routage tous les itinéraires qui commencent par 10. tapez :

route delete 10.*

Pour remplacer l'adresse du tronçon suivant 10.27.0.1 par 10.27.0.25 de l'itinéraire avec la destination 10.41.0.0. et le masque de sous-réseau 255.255.0.0, tapez :

route change 10.41.0.0 mask 255.255.0.0 10.27.0.25


Rsh

Permet d'exécuter des commandes sur des ordinateurs distants qui exécutent le service ou le démon RSH. Windows XP et Windows 2000 ne fournissent pas de service RSH. Un service RSH (Rshsvc.exe) est fourni avec le kit de ressources techniques Windows 2000. Utilisée sans paramètres, la commande rsh permet d'afficher l'aide.

Syntaxe

rsh [Hôte] [-l NomUtilisateur] [-n] [Commande]

Paramètres

Hôte
Spécifie l'hôte distant (l'ordinateur) sur lequel exécuter la Commande.
-l NomUtilisateur
Spécifie le nom d'utilisateur à utiliser sur l'ordinateur distant. Si cet élément est omis, le nom de l'utilisateur actuellement connecté est utilisé.
-n
Redirige l'entrée de la commande rsh vers le périphérique défini à NULL. Cela empêche l'affichage des résultats de la commande sur l'ordinateur local.
Commande
Spécifie la commande à exécuter.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Séquence standard

    La commande rsh copie l'entrée standard vers la Commande distante, la sortie standard de la Commande distante vers sa sortie standard et l'erreur standard de la Commande distante vers son erreur standard. Rsh termine en principe son traitement en même temps que la commande distante.

  • Utilisation des symboles de redirection

    Pour que la redirection s'exécute sur l'ordinateur distant, placez les symboles de redirection entre guillemets, (par exemple ">>"). Si vous n'utilisez pas les guillemets, la redirection est effectuée sur l'ordinateur local. Par exemple, la commande suivante ajoute le FichierDistant au fichier local FichierLocal :

    rsh autreordinateur cat fichierdistant >> fichierlocal

    La commande suivante ajoute le FichierDistant à l'AutreFichierDistant :

    rsh autreordinateur cat fichierdistant ">>" autrefichierdistant

  • Utilisation de la commande rsh

    Lorsque vous utilisez un ordinateur qui exécute Windows XP Professionnel et qui est connecté à un domaine, le contrôleur de domaine principal de ce domaine doit être disponible pour vérifier le nom d'utilisateur car, dans le cas contraire, la commande rsh échoue.

  • Fichier .rhosts

    Le fichier .rhosts donne généralement les droits d'accès réseau sur les systèmes Unix. Il contient les noms d'ordinateur et les noms de connexion associés ayant accès aux ordinateurs distants. Lorsque vous exécutez à distance les commandes rcp, rexec ou rsh avec un fichier .rhosts correctement configuré, il n'est pas nécessaire de fournir les informations d'ouverture de session et les mots de passe pour l'ordinateur distant.

    Le fichier .rhosts est un fichier texte dont chaque ligne correspond à une entrée. Une entrée se compose du nom d'ordinateur local, du nom d'utilisateur local et de commentaires éventuels. Chaque entrée est séparée par une tabulation ou un espace et les commentaires commencent par le signe dièse (#). Par exemple :

    hôte7 #Cet ordinateur se trouve dans la salle 31A

    Le fichier .rhosts doit se trouver dans le répertoire de base de l'utilisateur sur l'ordinateur distant. Pour plus d'informations sur l'implémentation du fichier .rhosts sur un ordinateur distant, consultez la documentation du système distant.

  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est déclaré comme composant dans les propriétés d'une carte réseau dans Connexions réseau.

Exemples

Pour exécuter la commande telcon sur l'ordinateur distant vax1 en utilisant le nom admin1, tapez :

rsh vax1 -l admin1 telcon


Rsm

Cette commande permet de gérer les ressources du média en utilisant l'utilitaire de stockage amovible. En utilisant la commande rsm, vous pouvez lancer des scripts de commandes pour les applications qui ne prennent pas en charge l'API du média de stockage amovible.

Pour allouer un média à partir d'un pool de médias

Syntaxe

rsm allocate /m NomPoolMédias /o{errunavail|new|next} {/l{g|f}IDMédiaLogique | /p{g|f}IDPartition} [/ln NomMédiaLogique] [/ld DescriptionMédiaLogique] [/pn NomPartition] [/pd DescriptionPartition] [/t DélaiAttente] [/b]

Paramètres

/m NomPoolMédias
Les médias sont alloués à partir d'un pool de médias que vous spécifiez. Cela signifie que ce pool contiendra des médias alloués.
/o
Permet l'utilisation de l'un des paramètres répertoriés dans le tableau suivant :
Valeur | Description
errunavail | Empêche un opérateur de demander un nouveau média si aucun média ne peut être alloué en fonction des contraintes spécifiées.
new | Permet d'allouer une partition qui ne peut pas être partagée avec une autre application. Cela peut permettre de réserver la seconde face d'un média à deux faces.
next | Alloue la face suivante d'un média qui a été précédemment allouée à l'aide du paramètre new .
/l{g|f}IDMédiaLogique
Spécifie le média à allouer à l'aide de l'ID de média logique. Vous pouvez utiliser le GUID (avec l'option de commande lg) ou le nom convivial (avec l'option lf). IDMédiaLogique indique la face suivante à allouer pour les médias à plusieurs faces. Ce paramètre est facultatif et doit être utilisé avec l'option de commande /o et le paramètre next. Une fois l'allocation du média annulée, l'ID de média logique est invalide.
/p{g|f}IDPartition
Spécifie la partition à allouer à l'aide de l'ID de partition. Vous pouvez utiliser le GUID (avec l'option de commande pg) ou le nom convivial (avec l'option pf). Ce paramètre est facultatif et persiste même après la désallocation du média.
/ln NomMédiaLogique
Spécifie le média à allouer en indiquant le nom du média logique.
/ld DescriptionMédiaLogique
Spécifie le média à allouer en indiquant la description du média logique.
/pn NomPartition
Spécifie la partition à allouer en indiquant le nom de la partition.
/pd DescriptionPartition
Spécifie la partition du média à allouer en indiquant la description de la partition.
/t DélaiAttente
Spécifie le délai d'attente de la commande, en milisecondes. La valeur par défaut est Infini.
/b
Permet d'afficher uniquement le GUID pour l'opération d'allocation. Ceci simplifie les scripts lorsque vous souhaitez passer la sortie d'une commande à la suivante avec un minimum d'analyse.

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez utiliser les noms des médias logiques et les noms des faces dans d'autres commandes pour spécifier le média respectivement comme paramètre du commutateur /lf ou /pf. Si les noms de média logiques (qui sont des noms conviviaux) ne sont pas utilisés avec la commande allocate, vous pouvez utiliser uniquement les GUID dans les commandes suivantes pour spécifier les médias logiques.

Pour créer un pool de médias

Syntaxe

rsm createpool /m NomPoolMédias /a{existing|always|new} [/t{g|f}IDTypePoolMédias] [/d] [/r]

Paramètres

/m NomPoolMédias
Spécifie le nom du pool de médias à créer.
/a
Permet l'utilisation de l'un des paramètres répertoriés dans le tableau suivant :
Valeur | Description
existing | Ouvre le pool de médias existant ou renvoie une erreur si le pool de médias spécifié n'existe pas.
always | Ouvre le pool de médias existant ou, s'il est introuvable, en crée un.
new | Crée un nouveau pool de médias ou renvoie une erreur si le pool de média spécifié existe déjà.
/tg IDTypePoolMédias
Spécifie le type de média que le pool de médias doit contenir en indiquant le GUID. Le type par défaut est le type du pool de médias qui contient d'autres pools de médias.
/tf IDTypePoolMédias
Spécifie le type de média que le pool de médias doit contenir en indiquant le nom convivial. Le type par défaut est le type du pool de médias qui contient d'autres pools de médias.
/d
Permet au pool de médias de récupérer automatiquement le média dans le pool de médias disponible. Si le commutateur /d est omis, le pool de médias n'autorise pas l'extraction du média du pool de médias disponible.
/r
Permet au pool de médias de renvoyer automatiquement le média dans le pool de médias disponible. Si le commutateur /r est omis, le pool de médias n'autorise pas le renvoie du média dans le pool de médias disponible.

/?
Affiche l'aide à l'invite de commandes.

Pour désallouer un média

Syntaxe

rsm deallocate /l{g|f]IDMédiaLogique | /p{g|f}IDPartition

Paramètres

/lg IDMédiaLogique
Spécifie le média logique à désallouer en indiquant le GUID.
/lf IDMédiaLogique
Spécifie le média logique à désallouer en indiquant le nom convivial.
/pg IDPartition
Spécifie la face du média logique à désallouer en indiquant le GUID.
/pf IDPartition
Spécifie la face du média logique à désallouer en indiquant le nom convivial.

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez utiliser le nom de média logique ou le nom de la partition pour spécifier le média logique à désallouer uniquement si l'un de ces noms a été spécifié avec la commande allocate avec les commutateurs /ln ou /pn respectivement. Dans le cas contraire, vous devez spécifier soit l'ID de média logique (LMID), soit l'ID de partition (PARTID).

Pour supprimer un pool de médias

Syntaxe

rsm deletepool /m NomPoolMédias

Paramètres

/m NomPoolMédias
Spécifie le nom du pool de médias à supprimer.

/?
Affiche l'aide à l'invite de commandes.

Pour démonter un média d'un lecteur

Syntaxe

rsm dismount {/l{g|f}IDMédiaLogique | /p{g|f}IDPartition
rsm dismount [/o[deferred]]}

Paramètres

/lg IDMédiaLogique
Spécifie le média logique à démonter en indiquant le GUID.
/lf IDMédiaLogique
Spécifie le média logique à démonter en indiquant le nom convivial.
/pg IDPartition
Spécifie la face du média logique à démonter en indiquant le GUID.
/pf IDPartition
Spécifie la face du média logique à démonter en indiquant le nom convivial.
/o
Utilisée avec le paramètre facultatif deferred, cette option de commande permet de marquer le média comme étant démontable mais de le conserver dans le lecteur. Les commandes mount suivantes peuvent être exécutées normalement. S'il n'est pas utilisé, le média est immédiatement démonté du lecteur.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le nom de média logique ou le nom de partition ne permet de spécifier le média logique à démonter que si l'un de ces noms a été spécifié avec la commande allocate avec les commutateurs /ln ou /pn respectivement. Dans le cas contraire, vous devez spécifier soit l'ID de média logique (LMID), soit l'ID de partition (PARTID).

Pour éjecter un média d'une bibliothèque

Le média à éjecter peut être spécifié de l'une des trois façons suivantes :

  • vous pouvez spécifier le média logique à éjecter en utilisant soit l'ID de média physique (PMID), soit le nom de média logique.
  • Vous pouvez éjecter le média d'un connecteur que vous spécifiez dans une bibliothèque en particulier.
  • Vous pouvez éjecter le média d'un lecteur que vous spécifiez dans une bibliothèque en particulier.

Syntaxe

rsm eject {/p{g|f}IDMédiaPhysique | /s{g|f}IDConnecteur /l{g|f}IDBibliothèque | /d{g|f}IDLecteur /l{g|f}IDBibliothèque
rsm eject [/o IDOpérationÉjection]
rsm eject [/a{start|stop|queue}]
rsm eject [/b]

Paramètres

/pg IDMédiaPhysique
Spécifie le média physique à éjecter en indiquant le GUID.
/pf IDMédiaPhysique
Spécifie le média physique à éjecter en indiquant le nom convivial.
/sg IDConnecteur
Spécifie le connecteur du média à éjecter en indiquant le GUID.
/sf IDConnecteur
Spécifie le connecteur du média à éjecter en indiquant le nom convivial.
/lg IDBibliothèque
Spécifie la bibliothèque contenant le connecteur ou le lecteur à partir duquel éjecter le média, en indiquant le GUID.
/lf IDBibliothèque
Spécifie la bibliothèque contenant le connecteur ou le lecteur à partir duquel éjecter le média, en indiquant le nom convivial.
/dg IDLecteur
Spécifie le lecteur du média à éjecter en indiquant le GUID.
/df IDLecteur
Spécifie le lecteur du média à éjecter en indiquant le nom convivial.
/o IDOpérationÉjection
Utilisé pour spécifier le GUID pour une opération d'éjection en particulier. Le paramètre /o facultatif peut être utilisé en association avec le paramètre /a et le paramètre stop pour mettre fin à une opération d'éjection en particulier. Il peut également être utilisé en association avec le paramètre /a et le paramètre start pour afficher le GUID de l'opération d'éjection concernée.
/a
Permet l'utilisation de l'un des paramètres répertoriés dans le tableau suivant :
Valeur | Description
Start | La valeur par défaut permet de démarrer l'opération d'éjection immédiatement. Le média est éjecté, excepté si le délai d'attente est dépassé ou si une autre commande eject est lancée avec l'option de ligne de commande /a et le paramètre stop. Les commandes eject de ce type doivent également indiquer le GUID de l'opération d'éjection à l'aide de l'option de ligne de commande /o. Le paramètre timeout est spécifié dans l'objet bibliothèque (pour toutes les opérations d'éjection) de la bibliothèque. Pour définir ce paramètre, vous devez utiliser l'API de stockage amovible. Il peut également être utilisé en association avec le commutateur /o pour afficher le GUID d'une opération d'éjection en particulier.
Stop | Permet de mettre fin à l'opération d'éjection avant l'expiration du délai d'attente. Il est possible de mettre fin à l'opération d'éjection concernée en utilisant le GUID affiché lorsque le paramètre start est utilisé avec le commutateur /a et le commutateur /o.
Queue | Permet de mettre le média dans une file d'attente en vue d'une éjection ultérieure. Il peut être utilisé pour les bibliothèques comportant des ports d'insertion/éjection (IE) à plusieurs connecteurs.
/b
Affiche uniquement le GUID de l'opération d'éjection pour l'exécution d'un script.

/?
Affiche l'aide à l'invite de commandes.

Pour éjecter un média à partir d'un changeur ATAPI

Syntaxe

rsm ejectatapi /n NuméroChangeurAtapi

Paramètres

/n NuméroChangeurAtapi
Spécifie le numéro du changeur. NuméroChangeurAtapi correspond au chiffre situé à la fin de la chaîne du nom de périphérique du changeur. Par exemple, \\.\CdChanger0 a 0 pour numéro de changeur ATAPI.

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Avant d'exécuter cette commande, vous devez interrompre manuellement le service ntmssvc.

Pour inventorier le média dans une bibliothèque automatisée en particulier

Syntaxe

rsm inventory /l{g|f}IDBibliothèque /a{full|fast|default|none|stop}

Paramètres

/lf IDBibliothèque
Spécifie la bibliothèque à inventorier en indiquant le nom convivial.
/lg IDBibliothèque
Spécifie la bibliothèque à inventorier en indiquant le GUID.
/a
Obligatoire. Spécifie le type d'opération d'inventaire à effectuer. Le tableau suivant présente la liste des opérations d'inventaire autorisées.
Valeur | Description
Full | Permet d'effectuer un inventaire complet des médias de la bibliothèque. L'utilitaire de stockage amovible monte chaque bande ou disque dans votre bibliothèque et lit l'identificateur on-media.
Fast | Permet d'effectuer un inventaire des codes barres si la bibliothèque spécifiée dispose d'un lecteur de code barre. Si la bibliothèque ne dispose pas de lecteur de code barre, l'utilitaire de stockage amovible contrôle les connecteurs et lit l'identificateur on-media des médias reliés aux connecteurs précédemment vides.
Default | Permet d'effectuer un inventaire en utilisant la méthode par défaut spécifiée dans la boîte de dialogue Propriétés de la bibliothèque.
None | Aucun inventaire n'est effectué.
Stop | Permet d'interrompre l'inventaire en cours pour la bibliothèque spécifiée.

/?
Affiche l'aide à l'invite de commandes.

Pour monter un média dans la bibliothèque spécifiée

Le média logique à monter peut être indiqué à l'aide de l'ID de média logique (LMID) ou du nom de média logique.

Syntaxe

rsm mount {/l{g|f}IDMédiaLogique | /p{g|f}IDPartition | [/s{g|f}IDConnecteur /c{g|f}IDChangeur}
rsm mount [/d{g|f}IDLecteur]
rsm mount /o{errunavail|drive|read|write|offline}
rsm mount [/r{normal|high|low|highest|lowest}]
rsm mount [/t DélaiAttente]

Paramètres

/lf IDMédiaLogique
Spécifie le média logique à monter en indiquant le nom convivial.
/pf IDPartition
Spécifie la face du média à monter en indiquant le nom convivial.
/pg IDPartition
/lg IDMédiaLogique
Spécifie le média logique à monter en indiquant le GUID.
Spécifie la face du média à monter en indiquant le GUID.
/cg IDChangeur
Spécifie le changeur qui contient le média à monter en indiquant le GUID. Cette option et ce paramètre ne peuvent être utilisés qu'en association avec le commutateur /sg et le GUID du connecteur.
/cf IDChangeur
Spécifie le changeur qui contient le média à monter en indiquant le nom convivial. Cette option et ce paramètre ne peuvent être utilisés qu'en association avec le commutateur /sg et le GUID du connecteur.
/sg IDConnecteur
Spécifie le connecteur qui contient le média à monter en indiquant le GUID. Cette option et ce paramètre ne peuvent être utilisés qu'en association avec le commutateur /cg et le GUID du changeur.
/sf IDConnecteur
Spécifie le connecteur qui contient le média à monter en indiquant le nom convivial. Cette option et ce paramètre ne peuvent être utilisés qu'en association avec le commutateur /cg et le GUID du changeur.
/dg IDLecteur
Spécifie le lecteur sur lequel monter en particulier le média applicable, en indiquant le GUID. Ce paramètre est facultatif et doit être utilisé en association avec le commutateur /o et le paramètre drive.
/df IDLecteur
Spécifie le lecteur sur lequel monter en particulier le média applicable, en indiquant le nom convivial. Ce paramètre est facultatif et doit être utilisé en association avec le commutateur /o et le paramètre drive.
/o
Permet l'utilisation de l'un des paramètres répertoriés dans le tableau suivant :
Valeur | Description
Errunavail | Permet de générer une erreur si le média ou le lecteur n'est pas disponible.
Drive | Indique qu'un lecteur en particulier doit être monté. Ce paramètre est utilisé en association avec le commutateur /d.
Read | Monte le média pour un accès en lecture.
Write | Monte le média pour un accès en écriture. Si ce paramètre est utilisé, le média complet n'est pas monté.
Offline | Permet de générer une erreur si le média est déconnecté.
/r
Spécifie l'ordre dans lequel monter le média ou la priorité (facultatif). La priorité dans laquelle monter le média peut également être spécifiée en utilisant l'un des paramètres suivants : normal (paramètre par défaut), high, low, highest ou lowest.
/t
Spécifie le délai d'attente de la commande, en milisecondes (facultatif). La valeur par défaut est Infini.

/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Lorsque vous utilisez la commande mount, vous pouvez spécifier le média à monter en utilisant soit le commutateur /l, le commutateur /p, soit une association du commutateur /s et du commutateur /c.

Pour actualiser une bibliothèque, un média physique ou tous les périphériques d'un type de média en particulier

Cette commande génère une seule interrogation des périphériques cibles de manière à ce que la base de données de stockage amovible contienne l'état actuel du périphérique. Cette commande peut être utile après les opérations d'insertion ou d'éjection de médias.

Syntaxe

rsm refresh {/l{g|f]IDBibliothèque | /p{g|f}IDMédiaPhysique | /tg IDTypeMédia}

Paramètres

/lg IDBibliothèque
Spécifie la bibliothèque à actualiser en indiquant le GUID.
/lf IDBibliothèque
Spécifie la bibliothèque à actualiser en indiquant le nom convivial.
/pg IDMédiaPhysique
Spécifie le média physique à actualiser en indiquant le GUID.
/pf IDMédiaPhysique
Spécifie le média physique à actualiser en indiquant le nom convivial.
/tg IDTypeMédia
Spécifie le type de média à actualiser. Seul le GUID peut être spécifié. Ce paramètre permet d'actualiser tous les périphériques de type média amovible en indiquant le GUID correspondant au type de média « média amovible ». Ce GUID peut être déterminé à l'aide de la commande view de la façon suivante : rsm view /tmedia_type /guiddisplay.
/?
Affiche l'aide à l'invite de commandes.

Pour afficher la liste des objets média

Syntaxe

rsm view /t{drive|library|changer|storageslot|iedoor|ieport|physical_media| media_pool|partition|logical_media|media_type|drive_type|librequest}
rsm view [/cg IDConteneur]
rsm view [/guiddisplay]
rsm view [/b]

Paramètres

/t {drive|library|changer|storageslot|iedoor|ieport|physical_media| media_pool|partition|logical_media|media_type|drive_type|librequest}
Permet d'afficher la liste des objets média pour le type spécifié. Utilisée sans paramètres, cette commande affiche la liste de tous les pools de média du système de stockage amovible (collection de bibliothèques).
/cg IDConteneur
Spécifie le GUID du conteneur d'objets. Le type de conteneur dépend du type d'objet (paramètre) spécifié avec le commutateur /t. Si l'ID de conteneur n'est pas spécifié, toutes les instances du type d'objet applicable sont affichées.
/guiddisplay
Affiche le GUID et le nom convivial des objets.
/b
Affiche uniquement le GUID pour l'exécution d'un script.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si le commutateur /guiddisplay et le commutateur /b ne sont pas utilisés, seuls les noms conviviaux des objets sont affichés.

Remarques

  • Si une commande aboutit, le code ERROR_SUCCESS est renvoyé. Toutes les commandes qui échouent renvoient un code d'erreur, qui peut être utilisé dans des scripts. Le code d'erreur est soit un code défini par le système, soit l'un des codes présenté dans le tableau suivant :
    Code d'erreur | Description
    536870913 | Des arguments invalides ont été spécifiés. Cette erreur est en général générée par un espace placé après un commutateur d'argument, comme dans /t 50 au lieu de /t50.
    536870914 | Des doublons de commutateurs d'arguments ont été spécifiés. La commande allocate a par exemple, été utilisée avec deux commutateurs /m.
    536870915 | Aucun GUID ne correspond au nom convivial spécifié. Vérifiez les majuscules et minuscules car les noms conviviaux respectent la différence entre les majuscules et les minuscules.
    536870916 | Un nombre insuffisant de commutateurs d'arguments a été utilisé. Assurez-vous qu'aucun commutateur obligatoire n'a été omis.
    536870917 | Un GUID invalide a été spécifié. Utilisez la commande view pour déterminer le GUID correct d'un objet.
    536870918 | Cette erreur n'est renvoyée que par la commande ejectatapi. Vérifiez que le changeur ATAPI fonctionne correctement.


Runas

Permet à un utilisateur d'exécuter des outils et des programmes spécifiques avec des autorisations différentes de celles attribuées à l'ouverture de session.

Syntaxe

runas [{/profile|/noprofile}] [/env] [/netonly] [/savedcreds] [/smartcard] [/showtrustlevels] [/trustlevel] /user:NomCompteUtilisateur program

Paramètres

/profile
Permet de charger le profil de l'utilisateur. Le paramètre /profile est utilisé par défaut.
/no profile
Permet de spécifier que le profil de l'utilisateur n'est pas chargé. Cela permet à l'application de se charger plus rapidement mais cela peut parfois également entraîner un dysfonctionnement dans certaines applications.
/env
Spécifie l'utilisation de l'environnement réseau actuel au lieu de l'environnement local de l'utilisateur.
/netonly
Indique que les informations utilisateur spécifiées ne servent qu'à l'accès distant.
/smartcard
Indique si les informations d'identification sont fournies ou non par une carte à puce.
/showtrustlevels
Affiche la liste des options du paramètre /trustlevel.
/trustlevel
Spécifie le niveau d'autorisation auquel l'application doit être lancée. Utilisez le paramètre /showtrustlevels pour afficher les niveaux d'approbation disponibles.
/user:NomCompteUtilisateur
Indique le nom du compte d'utilisateur sous lequel le programme doit être exécuté. Le compte d'utilisateur doit être spécifié sous le format utilisateur@domaine ou Domaine\Utilisateur.
program
Indique le programme ou la commande à exécuter à l'aide du compte spécifié par /user.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Il est conseillé aux administrateurs d'utiliser un compte avec un nombre restreint d'autorisations pour exécuter des tâches courantes, non administratives et d'utiliser un compte avec des autorisations plus étendues uniquement pour l'exécution de tâches d'administration spécifiques. Pour que cela soit possible sans devoir fermer et réouvrir les sessions, ouvrez une session avec un compte d'utilisateur normal et utilisez la commande runas pour exécuter les outils qui nécessitent des autorisations plus étendues.
  • Si vous souhaitez des exemples d'utilisation de la commande runas, consultez Rubriques connexes.
  • L'emploi de la commande runas n'est pas limité aux comptes d'administrateur, bien que ceux-ci soient les plus fréquemment utilisés. N'importe quel utilisateur possédant plusieurs comptes peut employer la commande runas pour exécuter un programme, la console MMC ou une fonction du Panneau de configuration avec d'autres identifications.
  • Si vous souhaitez utiliser le compte Administrateur sur votre ordinateur, pour le paramètre /user:, tapez l'une des commandes suivantes :

    /user:NomCompteAdministrateur@NomOrdinateur

    /user:NomOrdinateur\NomCompteAdministrateur

  • Si vous voulez utiliser cette commande en tant qu'administrateur de domaine, tapez l'une des commandes suivantes :

    /user:NomCompteAdministrateur@NomDomaine

    /user:NomDomaine\NomCompteAdministrateur

  • La commande runas vous permet d'exécuter des programmes (*.exe), des consoles MMC enregistrées (*.msc), des raccourcis à des programmes et des consoles MMC enregistrées ainsi que des fonctions du Panneau de configuration. Vous pouvez les exécuter en tant qu'administrateur pendant que vous êtes connecté à votre ordinateur en tant que membre d'un autre groupe tel que le groupe Utilisateurs ou Utilisateurs avec pouvoir.
  • Vous pouvez utiliser la commande runas pour démarrer n'importe quel programme, console MMC ou fonction du Panneau de configuration. Dans la mesure où vous spécifiez le compte d'utilisateur et le mot de passe appropriés, le compte d'utilisateur est autorisé à se connecter à l'ordinateur et le programme, la console MMC ou la fonction du Panneau de configuration est disponible sur le système ainsi que pour le compte d'utilisateur.
  • La commande runas vous permet d'administrer un serveur dans une autre forêt (l'ordinateur à partir duquel vous exécutez un outil et le serveur que vous administrez se trouvent dans des domaines différents).
  • Si vous tentez de démarrer un programme, une console MMC ou une fonction du Panneau de configuration à partir d'un emplacement réseau avec la commande runas, celle-ci risque d'échouer car les informations d'identification utilisées pour se connecter au réseau et celles employées pour démarrer le programme sont différentes. Il se peut en effet que ces dernières identifications ne permettent pas d'accéder au même partage du réseau.
  • Certains éléments, tels que le dossier Imprimantes et les éléments du Bureau, sont ouverts indirectement et ne peuvent pas être démarrés avec la commande runas.
  • Si la commande runas échoue, il se peut que le service Secondary Logon ne soit pas en cours d'exécution ou que le compte d'utilisateur ne soit pas valide. Pour contrôler l'état de ce service, dans Gestion de l'ordinateur, cliquez sur Services et applications, puis sur Services. Pour tester le compte d'utilisateur, essayez de vous connecter au domaine approprié à l'aide du compte.

Exemples

Pour démarrer une instance de l'invite de commandes en tant qu'administrateur sur l'ordinateur local, tapez :

runas /user:NomOrdinateurLocal\administrator cmd

Lorsqu'un message vous y invite, tapez le mot de passe administrateur.

Pour démarrer une instance du composant logiciel enfichable Gestion de l'ordinateur à partir d'un compte d'administrateur de domaine nommé domaine_société\admin_domaine, tapez :

runas /user:domaine_société\admin_domaine "mmc %windir%\system32\compmgmt.msc"

Lorsqu'un message vous y invite, tapez le mot de passe du compte.

Pour démarrer une instance du Bloc-notes à partir du compte d'administrateur de domaine utilisateur dans un domaine appelé domain.microsoft.com, tapez :

runas /user:user@domain.microsoft.com "bloc-notes mon_fichier.txt"

Lorsqu'un message vous y invite, tapez le mot de passe du compte.

Pour démarrer une instance d'une fenêtre d'invite de commandes, une console MMC enregistrée, une fonction du Panneau de configuration ou un programme qui administrera un serveur dans une autre forêt, tapez :

runas /netonly /user:domaine\nom_utilisateur "command"

Le paramètre domaine\nom_utilisateur doit correspondre à un utilisateur disposant des autorisations suffisantes pour administrer le serveur. Lorsqu'un message vous y invite, tapez le mot de passe du compte.


SC

Cette commande permet de communiquer avec le contrôleur de services et les services installés. SC.exe extrait et définit les informations de contrôle relatives aux services. Vous pouvez l'utiliser pour tester et déboguer des programmes de service. Les propriétés de service stockées dans le Registre peuvent être paramétrées pour contrôler la façon dont les applications de service sont lancées au démarrage et exécutées en tant que processus d'arrière-plan. Les paramètres de SC.exe peuvent permettre de configurer un service spécifique, extraire le statut courant d'un service et arrêter et lancer un service. Vous pouvez créer des fichiers de commandes qui appellent différentes commandes de SC.exe pour automatiser le démarrage ou la fermeture d'une séquence de services. SC.exe fournit des fonctionnalités similaires à celles de la fonction Services accessible à partir des Outils d'administration du Panneau de configuration.

Pour connaître la syntaxe de commande, cliquez sur l'une des commandes sc :

sc boot

Indique si le dernier démarrage doit être enregistré en tant que dernière bonne configuration connue ou non.

Syntaxe

sc [NomServeur] boot [{bad|OK}]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit être au format UNC (Universal Naming Convention) ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
[{bad|OK}]
Indique si le dernier démarrage n'était pas correct ou non et s'il doit être enregistré en tant que dernière bonne configuration connue ou non.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc boot :

sc boot ok
sc boot bad

sc config

Permet de modifier la valeur des entrées d'un service dans le Registre et dans la base de données du gestionnaire de contrôle de services.

Syntaxe

sc [NomServeur] config [NomService] [type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}] [start= {boot|system|auto|demand|disabled}] [error= {normal|severe|critical|ignore}] [binpath= NomCheminBinaire] [group= NomGroupeService] [tag= {yes|no}] [depend= Dépendances] [obj= {NomCompte|NomObjet}] [displayname= NomAffiché] [password= MotDePasse]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit être au format UNC (Universal Naming Convention) ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}
Spécifie le type de service.
Valeur | Description
own | Le service s'exécute dans son propre processus. Il ne partage pas de fichier exécutable avec d'autres services. Il s'agit de l'option par défaut.
share | Le service s'exécute comme un processus partagé. Il partage un fichier exécutable avec d'autres services.
kernel | Pilote.
filesys | Pilote de système de fichiers.
rec | Permet d'enregistrer le pilote reconnu par le système (identifie les systèmes de fichiers utilisés sur l'ordinateur).
adapt | Pilote de carte (permet d'identifier le matériel tel que les claviers, les souris et les lecteurs de disque).
interact | Le service peut interagir avec le bureau recevant des données des utilisateurs. Les services interactifs doivent être exécutés sous le compte LocalSystem. Ce type doit être utilisé conjointement avec type= own ou type= shared (par exemple type= interact type= own). Utiliser type= interact proprement dit génère une erreur liée à un paramètre non valide.
start= {boot|system|auto|demand|disabled}
Spécifie le type de démarrage du service.
Valeur | Description
boot | Pilote de périphérique chargé par le chargeur de démarrage.
system | Pilote de périphérique démarré au cours de l'initialisation du noyau.
auto | Service lancé à chaque redémarrage de l'ordinateur, qui s'exécute même si aucun utilisateur ne se connecte à l'ordinateur.
demand | Service devant être démarré manuellement. Il s'agit de la valeur par défaut si start= n'est pas spécifié.
disabled | Service ne pouvant pas être démarré. Pour démarrer un service désactivé, changez le type de démarrage.
error= {normal|severe|critical|ignore}
Spécifie le niveau de gravité de l'erreur si le service ne parvient pas à démarrer lors de l'amorçage.
Valeur | Description
normal | L'erreur est consignée et une zone de message s'affiche, informant l'utilisateur qu'un service n'est pas parvenu à démarrer. Le démarrage se poursuit. Il s'agit du paramètre par défaut.
severe | L'erreur est consignée dans un journal (si possible). L'ordinateur essaie de redémarrer avec la dernière bonne configuration connue. Il est possible que l'ordinateur puisse redémarrer, mais que le service ne parvienne toujours pas à s'exécuter.
critical | L'erreur est consignée dans un journal (si possible). L'ordinateur essaie de redémarrer avec la dernière bonne configuration connue. Si la dernière bonne configuration connue échoue, le démarrage échoue également et le processus d'amorçage est interrompu par une erreur d'arrêt.
ignore | L'erreur est consignée et le processus de démarrage se poursuit. Aucun avertissement n'est transmis à l'utilisateur. Seule l'erreur est enregistrée dans le journal des événements.
binpath= NomCheminBinaire
Spécifie un chemin d'accès vers le fichier binaire de service.
group= NomGroupeService
Spécifie le nom du groupe auquel appartient ce service. La liste des groupes est stockée dans la sous-clé HKLM\System\CurrentControlSet\Control\ServiceGroupOrder du Registre. La valeur par défaut est Null.
tag= {yes|no}
Spécifie si la propriété TagId doit être obtenue ou non par l'appel de CreateService. Les étiquettes sont utilisées uniquement pour les pilotes de démarrage système ou d'amorçage.
depend= Dépendances
Spécifie les noms des services ou des groupes qui doivent démarrer avant ce service. Les noms sont séparés par des barres obliques (/).
obj= {NomCompte|NomObjet}
Spécifie le nom d'un compte dans lequel un service s'exécute ou spécifie le nom d'un objet Pilote Windows dans lequel le pilote s'exécute. Le paramètre par défaut est LocalSystem.
displayname= NomAffiché
Spécifie un nom explicite et convivial qui peut être utilisé dans les programmes possédant une interface utilisateur pour identifier le service auprès des utilisateurs. Prenons l'exemple d'une sous-clé de service qui a pour nom : wuauserv. Ce nom n'est pas parlant pour les utilisateurs mais le nom qui est affiché est : Mises à jour automatiques.
password= MotDePasse
Spécifie un mot de passe. L'indication d'un mot de passe est obligatoire si un compte autre que le compte LocalSystem est utilisé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Sans espace entre un paramètre et sa valeur (par exemple, type= own et non type=own), l'opération échoue.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc config :

sc config NewService binpath= "ntsd -d c:\windows\system32\NewServ.exe"

sc continue

Cette commande permet d'envoyer la requête de contrôle CONTINUE à un service pour reprendre l'exécution d'un service qui a été interrompue.

Syntaxe

sc [NomServeur] continue [NomService]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisez la commande continue pour reprendre l'exécution d'un service qui a été interrompue.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc continue :

sc continue tapisrv

sc control

Cette commande permet d'envoyer la commande CONTROL B à un service.

Syntaxe

sc [NomServeur] control [NomService] [{paramchange|netbindadd|netbindremove|netbindenable|netbinddisable|CommandeControlBDéfinieParUtilisateur}]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
{paramchange|netbindadd|netbindremove|netbindenable|netbinddisable|CommandeControlBDéfinieParUtilisateur}
Spécifie une commande à envoyer à un service.
/?
Affiche l'aide à l'invite de commandes.

sc create

Permet de créer une sous-clé et des entrées pour un service dans le Registre et dans la base de données du gestionnaire de contrôle de services.

Syntaxe

sc [NomServeur] create [NomService] [type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}] [start= {boot|system|auto|demand|disabled}] [error= {normal|severe|critical|ignore}] [binpath= NomCheminBinaire] [group= NomGroupeService] [tag= {yes|no}] [depend= Dépendances] [obj= {NomCompte|NomObjet}] [displayname= NomAffiché] [password= MotDePasse]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}
Spécifie le type de service. Le paramètre par défaut est type= own.
Valeur | Description
own | Le service s'exécute dans son propre processus. Il ne partage pas de fichier exécutable avec d'autres services. Il s'agit de l'option par défaut.
share | Le service s'exécute comme un processus partagé. Il partage un fichier exécutable avec d'autres services.
kernel | Pilote.
filesys | Pilote de système de fichiers.
rec | Permet d'enregistrer le pilote reconnu par le système (identifie les systèmes de fichiers utilisés sur l'ordinateur).
interact | Le service peut interagir avec le bureau recevant des données des utilisateurs. Les services interactifs doivent être exécutés sous le compte LocalSystem. Ce type doit être utilisé conjointement avec type= own ou type= shared (c'est-à-dire type= interact type= own). Utiliser type= interact proprement dit génère une erreur liée à un paramètre non valide.
start= {boot|system|auto|demand|disabled}
Spécifie le type de démarrage du service. Le paramètre par défaut est start= demand.
boot | Pilote de périphérique chargé par le chargeur de démarrage.
system | Pilote de périphérique démarré au cours de l'initialisation du noyau.
auto | Service lancé à chaque redémarrage de l'ordinateur, qui s'exécute même si aucun utilisateur ne se connecte à l'ordinateur.
demand | Service devant être démarré manuellement. Il s'agit de la valeur par défaut si start= n'est pas spécifié.
disabled | Service ne pouvant pas être démarré. Pour démarrer un service désactivé, changez le type de démarrage.
error= {normal|severe|critical|ignore}
Spécifie le niveau de gravité de l'erreur si le service ne parvient pas à démarrer lors de l'amorçage. Le paramètre par défaut est error= normal.
normal | L'erreur est consignée et une zone de message s'affiche, informant l'utilisateur qu'un service n'est pas parvenu à démarrer. Le démarrage se poursuit. Il s'agit du paramètre par défaut.
severe | L'erreur est consignée dans un journal (si possible). L'ordinateur essaie de redémarrer avec la dernière bonne configuration connue. Il est possible que l'ordinateur puisse redémarrer, mais que le service ne parvienne toujours pas à s'exécuter.
critical | L'erreur est consignée dans un journal (si possible). L'ordinateur essaie de redémarrer avec la dernière bonne configuration connue. Si la dernière bonne configuration connue échoue, le démarrage échoue également et le processus d'amorçage est interrompu par une erreur d'arrêt.
ignore | L'erreur est consignée et le processus de démarrage se poursuit. Aucun avertissement n'est transmis à l'utilisateur. Seule l'erreur est enregistrée dans le journal des événements.
binpath= NomCheminBinaire
Spécifie un chemin d'accès vers le fichier binaire de service. Aucune valeur par défaut n'existe pour le paramètre binpath= et cette chaîne doit obligatoirement être indiquée.
group= NomGroupeService
Spécifie le nom du groupe auquel appartient ce service. La liste des groupes est stockée dans la sous-clé HKLM\System\CurrentControlSet\Control\ServiceGroupOrder du Registre. La valeur par défaut est Null.
tag= {yes|no}
Spécifie si la propriété TagId doit être obtenue ou non par l'appel de CreateService. Les étiquettes sont utilisées uniquement pour les pilotes de démarrage système ou d'amorçage.
depend= Dépendances
Spécifie les noms des services ou des groupes qui doivent démarrer avant ce service. Les noms sont séparés par des barres obliques (/).
obj= {NomCompte|NomObjet}
Spécifie le nom d'un compte dans lequel un service s'exécute ou le nom d'un objet Pilote Windows dans lequel le pilote s'exécute.
displayname= NomAffiché
Spécifie un nom convivial qui peut être utilisé dans les programmes possédant une interface utilisateur pour identifier le service.
password= MotDePasse
Spécifie un mot de passe. L'indication d'un mot de passe est obligatoire si un compte autre que le compte LocalSystem est utilisé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Sans espace entre un paramètre et sa valeur (c'est-à-dire, type= own et non type=own), l'opération échoue.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc create :

sc \\monserveur create NewService binpath= c:\windows\system32\NewServ.exe
sc create NewService binpath= c:\windows\system32\NewServ.exe type= share start= auto depend= "+TDI Netbios"

sc delete

Permet de supprimer la sous-clé d'un service du Registre. Si le service est en cours d'exécution ou bien, si un autre processus a un handle ouvert pour ce service, ce service est marqué pour être supprimé.

Syntaxe

sc [NomServeur] delete [NomService]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisez la fonctionnalité Ajout/Suppression de programmes pour supprimer les services DHCP, DNS ou tout autre service intégré au système d'exploitation. Cette fonctionnalité entraîne non seulement la suppression de la sous-clé du service dans le Registre mais entraîne également la désinstallation du service et la suppression de tous les raccourcis pointant vers lui.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc delete :

sc delete newserv

sc description

Permet de définir la chaîne de description d'un service.

Syntaxe

sc [NomServeur] description [NomService] [Description]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
Description
Spécifie une description pour le service spécifié. Si aucune chaîne n'est spécifiée, la description du service n'est pas modifiée. La description du service peut contenir un nombre illimité de caractères.
/?
Affiche l'aide à l'invite de commandes.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc description :

sc description newserv "Exécute le contrôle de la qualité du service."

sc enumdepend

Affiche la liste des services qui ne peuvent pas être lancés si le service spécifié n'est pas en cours d'exécution.

Syntaxe

sc [NomServeur] enumdepend [NomService] [TailleTampon]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
TailleTampon
Indique la taille en octets de la mémoire tampon d'énumération. La valeur par défaut est de 1024 octets.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si la mémoire tampon est insuffisante, la commande enumdepend énumère les dépendances en partie seulement et signale la taille de mémoire supplémentaire requise pour énumérer toutes les dépendances. Si l'énumération est tronquée, renouvelez l'opération et spécifiez une taille de mémoire tampon plus importante.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc enumdepend :

sc enumdepend rpcss 5690
sc enumdepend tapisrv

sc failure

Spécifie l'action à entreprendre après la panne d'un service.

Syntaxe

sc [NomServeur] failure [NomService] [reset= PériodeSansErreur] [reboot= MessageADiffuser] [command= LigneCommandes] [actions= ActionsAprèsPanneEtDélaiExécution]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
reset= PériodeSansErreur
Spécifie la durée de la période (en secondes) durant laquelle aucune panne ne se produit et après laquelle le compteur doit être remis à zéro. Ce paramètre doit être utilisé en combinaison avec le paramètre Actions=.
reboot= MessageADiffuser
Spécifie le message à diffuser après la panne d'un service.
command= LigneCommandes
Spécifie la ligne de commandes à exécuter après la panne d'un service. Pour plus d'informations sur la façon de lancer une commande ou un fichier VBS après une panne, consultez la section Remarques.
actions= ActionsAprèsPanneEtDélaiExécution
Spécifie les actions à entreprendre après une panne et leur délai d'exécution (en milisecondes). Ces deux informations doivent être séparées par une barre oblique (/) Les actions autorisées sont les suivantes : run, restart et reboot. Ce paramètre doit être utilisé en combinaison avec le paramètre reset=. Pour qu'aucune action ne soit entreprise après une panne, utilisez la commande actions= "".
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Tous les services n'autorisent pas la modification des options relatives aux actions à entreprendre après des pannes. En effet, certaines options font partie d'un ensemble de services.
  • Pour lancer un fichier de commandes après une panne, spécifiez cmd.exe Lecteur:\NomFichier.bat pour le paramètre command= , où la chaîne Lecteur:\NomFichier.bat correspond au nom de fichier complet du fichier de commandes.
  • Pour lancer un fichier VBS après une panne, spécifiez le Lecteur:\monscript.vbs pour le paramètre command=, où Lecteur:\monscript.vbs correspond au nom complet du fichier de script.
  • Vous avez la possibilité de spécifier trois actions différentes pour le paramètre actions=, qui seront utilisées à la première, à la deuxième, puis à la troisième panne du service.
  • Sans espace entre un paramètre et sa valeur (c'est-à-dire, type= own et non type=own), l'opération échoue.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc failure :

sc failure msftpsvc reset= 30 actions= restart/5000
sc failure dfs reset= 60 command= c:\windows\services\restart_dfs.exe actions= run/5000
sc failure dfs reset= 60 actions= reboot/30000
sc failure dfs reset= 60 reboot= "Le service Système de fichiers distribués a échoué. L'ordinateur va donc être redémarré dans 30 secondes." actions= reboot/30000
sc failure monservice reset= 3600 reboot= "Panne MonService -- réinitialisation machine" command= "%windir%\MonServiceRecovery.exe" actions= restart/5000/run/10000/reboot/60000

sc getdisplayname

Cette commande permet d'associer le nom d'affichage à un service en particulier.

Syntaxe

sc [NomServeur] getdisplayname [NomService] [TailleTampon]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
TailleTampon
Spécifie la taille en octets de la mémoire tampon. La valeur par défaut est de 1024 octets.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc getdisplayname :

sc getdisplayname clipsrv
sc getdisplayname tapisrv
sc getdisplayname sharedaccess

sc getkeyname

Cette commande permet d'associer le nom de la clé à un service en particulier, en utilisant le nom d'affichage comme entrée.

Syntaxe

sc [NomServeur] getkeyname [NomAffichageService] [TailleTampon]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomAffichageService
Spécifie le nom d'affichage du service.
TailleTampon
Spécifie la taille en octets de la mémoire tampon. La valeur par défaut est de 1024 octets.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si le paramètre NomAffichageService contient des espaces, encadrez-le de guillemets (par exemple, "Nom Affichage Service").

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc getkeyname :

sc getkeyname "remote procedure call (rpc)"
sc getkeyname "internet connection sharing"
sc getkeyname clipbook

sc interrogate

Cette commande permet d'envoyer une requête de contrôle INTERROGATE à un service.

Syntaxe

sc [NomServeur] interrogate [NomService]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Lorsqu'une requête INTERROGATE est envoyée à un service, celui-ci met à jour son statut avec le Gestionnaire de contrôle de services.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc interrogate :

sc interrogate sharedaccess
sc interrogate rpcss

sc lock

Cette commande permet de verrouiller la base de données du Gestionnaire de contrôle de services.

Syntaxe

sc [NomServeur] lock

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le verrouillage de la base de données du Gestionnaire de contrôle de services empêche le lancement des services. Utilisez cette commande si vous voulez être certain qu'un service ne sera pas relancé après avoir été arrêté. Cela vous permettra d'effectuer certaines actions (par exemple, de supprimer un service) sans engendrer de conflits.
  • La commande lock permet de verrouiller la base de données du Gestionnaire de contrôle de services et, associée à l'option u, de la déverrouiller. Vous pouvez également supprimer le processus qui vous a permis de verrouiller la base de données.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc lock :

sc lock

sc pause

Cette commande permet d'envoyer une requête de contrôle PAUSE à un service.

Syntaxe

sc [NomServeur] pause [NomService]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisez la commande pause pour suspendre l'exécution d'un service avant de le fermer.
  • Certains services ne peuvent pas être suspendus.
  • Tous les services ne se comportent pas de la même façon une fois suspendus. Certains continuent à répondre aux clients existants mais refusent d'accepter de nouveaux clients. D'autres cessent de répondre aux clients existants et refusent également d'en accepter de nouveaux.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc pause :

sc pause tapisrv

sc qc

Permet de rechercher les informations de configuration d'un service.

Syntaxe

sc [NomServeur] qc [NomService] [TailleTampon]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
TailleTampon
Spécifie la taille en octets de la mémoire tampon. La valeur par défaut est de 1024 octets.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • La commande qc permet d'afficher les informations suivantes sur un service : Le nom du service (nom de la sous-clé de Registre du service), le type, le contrôle d'erreur, le nom de chemin binaire, le nom de groupe du service, l'indicateur, le nom d'affichage, les dépendances et le nom de démarrage du service.

  • La commande SC permet aux administrateurs de déterminer le nom binaire des services et de savoir si les services partagent un processus avec d'autres services. Pour cela, ils doivent taper ce qui suit :

    sc qc NomService

    Grâce à la commande SC, il est possible d'établir une correspondance entre le noeud Services de la console MMC (Microsoft Management Console) et les processus du Moniteur système. Si le nom binaire est Services.exe, alors le service partage le processus Contrôleur de services.

    L'exécutable Services.exe permet de lancer tous les services. Afin de conserver les ressources systèmes, plusieurs services Win32 développés pour Windows sont écrits pour partager le processus Services.exe. Ces services ne sont pas mentionnés comme processus distincts dans le Moniteur système ou le Gestionnaire de tâches. Il en est de même de l'exécutable Svchost.exe, qui est un processus hôte de service que plusieurs services de systèmes d'exploitation partagent.

    Il n'existe pas de processus pour tous les services Win32 car certains services Win32 de tierces-parties peuvent également être configurés pour partager des processus. La commande SC permet également de récupérer les informations relatives à la configuration de ces services. Si un service ne partage pas son processus avec d'autres services, un processus sera toutefois créé pour lui dans le Moniteur système au moment de son exécution.

  • La commande SC peut s'avérer utile pour les développeurs de services car elle permet d'obtenir des informations plus détaillées et plus précises sur les services que ne le permet l'exécutable Services.exe, qui est fourni avec Windows. Cet exécutable peut aider à déterminer si un service fonctionne, s'il est arrêté ou s'il est suspendu. Bien que ces outils soient appropriés au débogage des applications, les informations qu'ils fournissent sur un service en cours de développement peuvent être déroutantes. Par exemple, un service dont le lancement est en cours est signalé comme étant lancé, que l'opération aboutisse ou non au fonctionnement de ce service.

    La commande SC permet de mettre en oeuvre des appels à toutes les fonctions API des applications de contrôle des services Windows. Paramétrez ces fonctions en définissant leurs paramètres dans la ligne de commandes.

    En utilisant la commande SC, vous pouvez rechercher le statut d'un service et extraire les valeurs stockées dans les champs de structure des statuts. L'exécutable Services.exe ne permet pas d'obtenir le statut complet d'un service mais la commande SC indique elle, l'état exact du service ainsi que le dernier numéro du point de vérification et l'indication d'attente. Vous pouvez utiliser le point de contrôle comme outil de débogage car il indique jusqu'à quel point l'initialisation a pu être effectuée avant que le programme ne réponde plus. La commande SC permet également de spécifier le nom de l'ordinateur distant de façon à ce qu'il soit possible d'appeler les fonctions API des services ou de visualiser les structures des statuts des services sur un ordinateur distant.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc qc :

sc qc \\myserver newsrvice
sc qc rpcss 248

sc qdescription

Permet d'afficher la chaîne de description d'un service.

Syntaxe

sc [NomServeur] qdescription [NomService] [TailleTampon]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
TailleTampon
Spécifie la taille en octets de la mémoire tampon. La valeur par défaut est de 1024 octets.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc qdescription :

sc qdescription rpcss
sc qdescription rpcss 138

sc qfailure

Permet d'afficher les actions qui doivent être effectuées si le service spécifié échoue.

Syntaxe

sc [NomServeur] qfailure [NomService] [TailleTampon]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
TailleTampon
Spécifie la taille en octets de la mémoire tampon. La valeur par défaut est de 1024 octets.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • La commande qfailure permet d'afficher les informations suivantes sur un service : NOM_SERVICE (nom de la sous-clé de Registre du service), PERIODE_REINITIALISATION, MESSAGE_REINITIALISATION, LIGNE_COMMANDE et ACTIONS_APRES_PANNES.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc qfailure :

sc qfailure rpcss
sc qfailure rpcss 20

sc query

Cette commande permet d'obtenir et d'afficher des informations sur un service, un pilote, le type d'un service ou le type d'un pilote.

Syntaxe

sc [NomServeur] query [NomService] [type= {driver|service|all}] [type= {own|share|interact|kernel|filesys|rec|adapt}] [state= {active|inactive|all}] [bufsize= TailleTampon] [ri= ReprendreIndex] [group= NomGroupe]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname. Ce paramètre n'est pas utilisé en combinaison avec d'autres paramètres de la commande query (autres paramètres que le paramètre NomServeur).
type= {driver|service|all}
Spécifie les éléments à énumérer. Le type par défaut est service.
Valeur | Description
pilote | Spécifie que seuls les pilotes sont énumérés.
service | Spécifie que seuls les services sont énumérés.
all | Spécifie que les pilotes et les services sont énumérés.
type= {own|share|interact|kernel|filesys|rec|adapt}
Spécifie le type de service ou de pilote à énumérer.
Valeur | Description
own | Le service s'exécute dans son propre processus. Il ne partage pas de fichier exécutable avec d'autres services. Il s'agit de l'option par défaut.
share | Le service s'exécute comme un processus partagé. Il partage un fichier exécutable avec d'autres services.
interact | Le service peut interagir avec le bureau recevant des données des utilisateurs. Les services interactifs doivent être exécutés sous le compte LocalSystem.
kernel | Pilote.
filesys | Pilote de système de fichiers.
state= {active|inactive|all}
Spécifie l'état de départ du service pour lequel des éléments sont à énumérer. L'état par défaut est active.
Valeur | Description
active | Spécifie l'ensemble des services actifs.
inactive | Spécifie l'ensemble des services interrompus ou arrêtés.
all | Spécifie l'ensemble des services.
bufsize= TailleTampon
Indique la taille en octets de la mémoire tampon d'énumération. La taille par défaut équivaut à 1 024 octets. Augmentez la taille de la mémoire tampon nécessaire à l'énumération lorsque le résultat d'une requête est supérieur à 1024 octets.
ri= ReprendreIndex
Spécifie le numéro d'index auquel il convient de commencer ou de reprendre l'énumération. La valeur par défaut est 0. Utilisez ce paramètre en combinaison avec le paramètre bufsize= lorsque la taille des informations que renvoient le résultat d'une requête est supérieure à la taille de la mémoire tampon par défaut permettant de les afficher.
group= NomGroupe
Spécifie le groupe de services à énumérer. Par défaut, il s'agit de tous les groupes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Sans espace entre un paramètre et sa valeur (c'est-à-dire, type= own et non type=own), l'opération échoue.
  • La commande query permet d'afficher les informations suivantes sur un service : Le nom du service (nom de la sous-clé de Registre du service), le type, l'état (ainsi que tous les états qui ne sont pas disponibles), WIN32_EXIT_B, SERVICE_EXIT_B, le point de contrôle et l'indication d'attente.
  • Le paramètre type= peut parfois être utilisé deux fois. La première occurrence du paramètre type= spécifie s'il convient d'interroger des services et/ou des pilotes. La seconde occurrence du paramètre type= spécifie un type d'opération create pour limiter la portée d'une requête.
  • Lorsque la taille du résultat de la commande query est supérieure à la taille de la mémoire tampon réservée pour l'énumération, un message similaire au suivant s'affiche :

    Enum: more data, need 1822 bytes start resume at index 79

    Pour pouvoir afficher le reste des informations résultant de la commande query, relancez cette commande en prenant soin d'indiquer pour le paramètre bufsize= le nombre d'octets requis et pour le paramètre ri= l'index concerné. Pour afficher ces informations, vous pouvez par exemple saisir les données suivantes :

    sc query bufsize= 1822 ri= 79

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc query :

sc query
sc query messenger
sc query type= driver
sc query type= service
sc query state= all
sc query bufsize= 50
sc query ri= 14
sc query type= service type= interact
sc query type= driver group= ndis

sc queryex

Cette commande permet d'obtenir et d'afficher des informations étendues sur un service, un pilote, le type d'un service ou le type d'un pilote.

Syntaxe

sc [NomServeur] queryex [type= {driver|service|all}] [type= {own|share|interact|kernel|filesys|rec|adapt}] [state= {active|inactive|all}] [bufsize= TailleTampon] [ri= ReprendreIndex] [group= NomGroupe]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname. Le paramètre queryex n'est utilisé avec aucun autre paramètre de la commande queryex à l'exception du paramètre NomServeur.
type= {driver|service|all}
Spécifie les éléments à énumérer. Le type par défaut est service.
Valeur | Description
pilote | Spécifie que seuls les pilotes sont énumérés.
service | Spécifie que seuls les services sont énumérés.
all | Spécifie que les pilotes et les services sont énumérés.
type= {own|share|interact|kernel|filesys|rec|adapt}
Spécifie le type de service ou de pilote à énumérer.
Valeur | Description
own | Le service s'exécute dans son propre processus. Il ne partage pas de fichier exécutable avec d'autres services. Il s'agit de l'option par défaut.
share | Le service s'exécute comme un processus partagé. Il partage un fichier exécutable avec d'autres services.
interact | Le service peut interagir avec le bureau recevant des données des utilisateurs. Les services interactifs doivent être exécutés sous le compte LocalSystem.
kernel | Pilote.
filesys | Pilote de système de fichiers.
state= {active|inactive|all}
Spécifie l'état de départ du service pour lequel des éléments sont à énumérer. L'état par défaut est active.
Valeur | Description
active | Spécifie l'ensemble des services actifs.
inactive | Spécifie l'ensemble des services interrompus ou arrêtés.
all | Spécifie l'ensemble des services.
bufsize= TailleTampon
Indique la taille en octets de la mémoire tampon d'énumération. La taille par défaut équivaut à 1 024 octets.
ri= ReprendreIndex
Spécifie le numéro d'index auquel il convient de commencer ou de reprendre l'énumération. La valeur par défaut est 0.
group= NomGroupe
Spécifie le groupe de services à énumérer. Par défaut, il s'agit de tous les groupes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Sans espace entre un paramètre et sa valeur (c'est-à-dire, type= own et non type=own), l'opération échoue.
  • La commande queryex permet d'afficher les informations suivantes sur un service : Le nom du service (nom de la sous-clé de Registre du service), le type, l'état (ainsi que tous les états qui ne sont pas disponibles), WIN32_EXIT_B, SERVICE_EXIT_B, le point de vérification, les indications d'attente, le PID et les indicateurs.
  • Le paramètre type= peut parfois être utilisé deux fois. La première occurrence du paramètre type= spécifie s'il convient d'interroger des services et/ou des pilotes. La seconde occurrence du paramètre type= spécifie un type d'opération create pour limiter la portée d'une requête.
  • Lorsque la taille du résultat de la commande queryex est supérieure à la taille de la mémoire tampon réservée pour l'énumération, un message similaire au suivant s'affiche :

    Enum: more data, need 2130 bytes start resume at index 75

    Pour pouvoir afficher le reste des informations résultant de la commande queryex, relancez cette commande en prenant soin d'indiquer pour le paramètre bufsize= le nombre d'octets requis et pour le paramètre ri= l'index concerné. Pour afficher ces informations, vous pouvez par exemple saisir les données suivantes :

    sc queryex bufsize= 2130 ri= 75

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande sc queryex :

sc queryex messenger
sc queryex group= ""

sc querylock

Cette commande permet de rechercher et d'afficher le statut du verrouillage de la base de données du Gestionnaire de contrôle de services.

Syntaxe

sc [NomServeur] querylock

Paramètre

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
/?
Affiche l'aide à l'invite de commandes.

sc sdset

Permet de définir le descripteur de sécurité d'un service en utilisant le langage SDDL (Service Descriptor Definition Language).

Syntaxe

sc [NomServeur] sdset NomService DescripteurSécuritéService

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
DescripteurSécuritéService
Spécifie le descripteur de sécurité du service dans le langage SDDL.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour plus d'informations sur le langage SDDL, consultez la rubrique s'y rapportant sur le site MSDN Online Library (http://www.microsoft.com/).

sc sdshow

Cette commande permet d'afficher le descripteur de sécurité d'un service en utilisant le langage SDDL.

Syntaxe

sc [NomServeur] sdshow NomService

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour plus d'informations sur le langage SDDL, consultez la rubrique s'y rapportant sur le site MSDN Online Library (http://www.microsoft.com/).

Exemples

sc sdshow rpcss

sc start

Permet de lancer un service qui est déjà en cours de fonctionnement.

Syntaxe

sc [NomServeur] start NomService [ArgumentsService]

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
ArgumentsService
Spécifie les arguments du service à transmettre au service qui doit être démarré.
/?
Affiche l'aide à l'invite de commandes.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc start :

sc start tapisrv

sc stop

Cette commande permet d'envoyer une requête de contrôle STOP à un service.

Syntaxe

sc [NomServeur] stop NomService

Paramètres

NomServeur
Spécifie le nom du serveur distant sur lequel se trouve le service. Le nom doit utiliser le format UNC ("\\monserveur"). Pour exécuter SC.exe localement, ignorez ce paramètre.
NomService
Spécifie le nom du service renvoyé par l'opération getkeyname.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Certains services ne peuvent pas être arrêtés.

Exemples

L'exemple suivant illustre la façon d'utiliser la commande sc stop :

sc stop tapisrv

Remarques

    XOX

    Rubriques connexes


Schtasks

Planifie l'exécution périodique ou à heure spécifique des commandes et des programmes. Permet d'ajouter et de supprimer des tâches de la planification, de démarrer et d'interrompre des tâches à la demande et enfin, d'afficher et de modifier des tâches planifiées.

Pour afficher la syntaxe de cette commande, sélectionnez-la :

schtasks create

Permet de créer une nouvelle tâche planifiée.

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc planification [/mo modificateur] [/d jour] [/m mois[,mois...] [/i DuréeInactivité] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]] /?

Paramètres

/tn NomTâche
Spécifie le nom de la tâche.
/tr ÉlémentExécutéParTâche
Spécifie le programme ou la commande que la tâche exécute. Tapez le chemin d'accès complet et le nom du fichier exécutable, du fichier de script ou de commandes. Si vous n'indiquez pas de chemin d'accès, SchTasks.exe suppose que le fichier se trouve dans le répertoire RacineSystème\System32.
/sc planification
Spécifie le type de planification. Les valeurs autorisées sont : MINUTE, HOURLY (Heure), DAILY (Jour), WEEKLY (Semaine), MONTHLY (Mois), ONCE (Une fois), ONSTART (Au démarrage), ONLOGON (À la connexion), ONIDLE (Pendant le temps d'inactivité).
Valeur | Description
MINUTE, HOURLY, DAILY, WEEKLY, MONTHLY | Spécifie l'unité de temps de la planification.
ONCE | Permet d'exécuter la tâche une fois, à une date et une heure précise.
ONSTART | Permet d'exécuter la tâche à chaque démarrage du système. Il est possible de spécifier une date de démarrage ou d'exécuter la tâche au prochain démarrage du système.
ONLOGON | Permet d'exécuter la tâche lorsqu'un utilisateur se connecte. Il est possible de spécifier une date ou d'exécuter la tâche lors de la prochaine connexion de l'utilisateur.
ONIDLE | Permet d'exécuter la tâche lorsque le système est inactif pendant une durée précise. Il est possible de spécifier une date ou d'exécuter la tâche dès que le système est inactif.
/mo modificateur
Permet de spécifier la fréquence à laquelle la tâche est exécutée dans le cadre de ce type de planification. Ce paramètre est requis pour les planifications mensuelles (de type MONTHLY). Il est accepté mais facultatif pour les planifications de type MINUTE, HOURLY, DAILY ou WEEKLY. Sa valeur par défaut est 1.
Type de planification | Modificateur | Description
MINUTE | 1 - 1439 | La tâche est exécutée toutes les n minutes.
HOURLY | 1 - 23 | La tâche est exécutée toutes les n heures.
DAILY | 1 - 365 | La tâche est exécutée tous les n jours.
WEEKLY | 1 - 52 | La tâche est exécutée toutes les n semaines.
MONTHLY | 1 - 12 | La tâche est exécutée tous les n mois.
 | LASTDAY | La tâche est exécutée le dernier jour du mois.
 | FIRST, SECOND, THIRD, FOURTH, LAST | Utilisez le paramètre /d jour pour exécuter une tâche une semaine et un jour précis. Par exemple, le troisième mercredi du mois.
/d jour
Spécifie un jour de la semaine ou un jour du mois. Paramètre accepté uniquement avec les types de planification WEEKLY ou MONTHLY.
Type de planification | Valeurs acceptées pour le paramètre Jour
WEEKLY | Facultatif. Les valeurs autorisées sont MON - SUN (Dimanche à Lundi) et * (tous les jours). MON (Lundi) est la valeur par défaut.
MONTHLY | Une valeur comprise entre MON (Lundi) et SUN (Dimanche) est requise lorsque le modificateur (/mo) FIRST, SECOND, THIRD, FOURTH ou LAST est utilisé. Les valeurs comprises entre 1 et 31 sont facultatives et autorisées uniquement sans modificateur ou avec un modificateur d'un type compris entre 1 et 12. La valeur par défaut est : jour 1 (le premier jour du mois).
/m mois[,mois...]
Spécifie un mois de l'année. Les valeurs autorisées sont JAN - DEC et * (tous les mois). Le paramètre /m est autorisé uniquement pour une planification mensuelle. Il est obligatoire lorsque le modificateur LASTDAY (dernier jour) est utilisé. Dans le cas contraire, il est facultatif et la valeur par défaut est * (tous les mois).
/i DuréeInactivité
Spécifie le nombre de minutes pendant lequel l'ordinateur doit être inactif avant que la tâche ne soit exécutée. Tapez un nombre entier compris entre 1 et 999. Ce paramètre est valide uniquement avec une planification du type ONIDLE. et dans ce cas, il est obligatoire.
/st HeureDébut
Spécifie l'heure du jour à laquelle la tâche doit démarrer. L'heure est exprimée au format 24 heures HH:MM:SS. La valeur par défaut correspond à l'heure locale courante qui est celle à laquelle l'exécution de la commande prend fin. Le paramètre /st est valide avec les planifications du type MINUTE, HOURLY, DAILY, WEEKLY, MONTHLY et ONCE. Il est obligatoire avec les planifications du type ONCE.
/sd DateDébut
Spécifie la date à laquelle la tâche doit être lancée au formatMM/JJ/AAAA. La valeur par défaut correspond à la date courante. Le paramètre /sd est valide avec toutes les planifications et il est obligatoire pour les planifications du type ONCE.
/ed DateFin
Spécifie la date à laquelle est planifiée la dernière exécution de la tâche. Ce paramètre est facultatif. Il n'est pas autorisé avec les planifications du type ONCE, ONSTART, ONLOGON ou ONIDLE. Par défaut, aucune date de fin n'est indiquée pour les planifications.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (avec ou sans barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u [domaine\]utilisateur
Permet d'exécuter la commande avec les autorisations du compte d'utilisateur spécifié. Par défaut, la commande est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
/p mot de passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u. Ce paramètre est requis quand le paramètre /u est utilisé.
/ru {[Domaine\]Utilisateur | "System"}
Permet d'exécuter les tâches avec les autorisations du compte d'utilisateur spécifié. Par défaut, la tâche est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
Valeur | Description
[Domaine\]Utilisateur | Permet de spécifier un compte d'utilisateur.
"System" ou "" | Spécifie le compte d'autorité NT ou système qui est utilisé par le système d'exploitation.
/rp MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /ru. Si vous n'indiquez pas ce paramètre lorsque vous spécifiez un compte d'utilisateur, SchTasks.exe affiche un message vous demandant de saisir un mot de passe (les caractères saisis ne s'affichent pas à l'écran). Les tâches exécutées avec les autorisations du compte d'autorité NT ou système ne requièrent pas la saisie d'un mot de passe et SchTasks n'en demande pas.
/?
Affiche l'aide à l'invite de commandes.

Remarques

    XOX
  • SchTasks.exe ne vérifie pas les emplacements des fichiers programme ou des mots de passe des comptes d'utilisateur. Si vous indiquez un emplacement de fichier incorrect ou un mot de passe incorrect pour le compte d'utilisateur, la tâche est créée mais elle n'est pas exécutée. De plus, si le mot de passe d'un compte change ou arrive à expiration et que vous ne le changez pas pour la tâche, celle-ci n'est alors pas exécutée.
  • Le compte d'autorité NT ou système ne dispose pas de droits de connexion interactifs. Les utilisateurs ne voient pas et ne peuvent pas interagir avec les programmes lancés avec les autorisations système.
  • Chaque tâche exécute un seul programme uniquement. Toutefois, vous pouvez créer un fichier de commandes pour lancer plusieurs tâches, puis planifier une tâche pour l'exécution de ce fichier de commandes.
  • Il vous est possible de tester une tâche dès sa création. Utilisez la commande run pour tester la tâche et contrôler le fichier SchedLgU.txt (RacineSystème\SchedLgU.txt) pour vérifier la présence d'erreurs.

Syntaxe et exemples pour chaque type de planification

Pour afficher la syntaxe d'une commande, sélectionnez-la :

schtasks create minute

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc minute [/mo {1 - 1439}] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une tâche toutes les 20 minutes

La commande suivante permet de planifier le script de sécurité, Sec.vbs, pour qu'il soit exécuté toutes les 20 minutes. Cette commande ne contient pas de date ou d'heure de début. Par conséquent, la tâche démarre 20 minutes après la fin de l'exécution de la commande et s'exécute par la suite toutes les 20 minutes, chaque fois que le système est lancé. Notez que le fichier source de script de sécurité est situé sur un ordinateur distant mais que la tâche est planifiée et exécutée sur un ordinateur local.

schtasks /create /sc minute /mo 20 /tn "Security Script" /tr \\central\data\scripts\sec.vbs

En réponse à la commande, SchTasks.exe affiche un message expliquant que la tâche sera exécutée avec les autorisations de l'utilisateur courant et demande le mot de passe de cet utilisateur. Lorsque vous saisissez le mot de passe, SchTasks.exe n'affiche pas les caractères à l'écran.

La tâche sera créée sous le nom de l'utilisateur actuellement connecté.

Veuillez entrer votre mot de passe

************

SchTasks.exe affiche ensuite un message indiquant que la tâche est planifiée :

RÉUSSITE : La tâche planifiée "Script de sécurité" a été correctement créée.

Une requête montre la tâche que la commande a planifiée :

Nom de tâche                  Heure de la prochaine exécution            État

========================= ======================== ==============

Script de sécurité           10:50:00 AM , 4/4/2001

schtasks create hourly

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc hourly [/mo {1 - 365}] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une commande toutes les heures, à l'heure pile passée de cinq minutes

La commande suivante permet de planifier le programme MonApp pour qu'il s'exécute toutes les heures en commençant à minuit cinq. Étant donné que le paramètre /mo est omis, la commande utilise la valeur par défaut pour la planification horaire, qui a lieu toutes les (1) heures. Si cette commande est lancée après 12h05, le programme ne s'exécute pas avant le lendemain.

schtasks /create /sc hourly /st 00:05:00 /tn "Mon App" /tr c:\apps\monapp.exe

Pour planifier l'exécution d'une commande toutes les cinq heures

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté toutes les cinq heures en commençant le premier jour du mois de mars 2001. Le paramètre /mo est utilisé pour spécifier un intervalle et le paramètre /sd, pour spécifier la date de début. La commande ne spécifie pas d'heure de début. Par conséquent, c'est l'heure courante qui est utilisée comme heure de début.

schtasks /create /sc hourly /mo 5 /sd 03/01/2001 /tn "Mon App" /tr c:\apps\monapp.exe

schtasks create daily

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc daily [/mo {1 - 365}] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une tâche tous les jours

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté une fois par jour, tous les jours, à huit heures du matin, jusqu'au 31 décembre 2001. Le paramètre /mo est omis et l'intervalle 1 par défaut est donc utilisé pour exécuter la commande chaque jour.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc daily /st 08:00:00 /ed 12/31/2001

Pour planifier l'exécution d'une tâche tous les autres jours

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté tous les autres jours à une heure de l'après-midi en commençant le 31 décembre 2001. La commande utilise la paramètre /mo pour spécifier un intervalle de deux (2) jours.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc daily /mo 2 /st 13:00:00 /sd 12/31/2001

schtasks create daily

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc weekly [/d {MON - SUN | *}] [/mo {1 - 52}] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une tâche toutes les six semaines

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté sur un ordinateur distant toutes les six semaines. La commande utilise le paramètre /mo pour spécifier un intervalle. Elle utilise également le paramètre /s pour spécifier l'ordinateur distant et le paramètre /ru pour planifier la tâche à exécuter avec les autorisations attribuées au compte d'utilisateur Administrateur. Étant donné que le paramètre /rp est omis, SchTasks.exe affiche un message demandant à l'utilisateur d'indiquer le mot de passe du compte Administrateur.

Par ailleurs, comme la commande est exécutée à distance, tous les chemins d'accès qui y sont indiqués, y compris le chemin d'accès au fichier MonApp.exe, sont relatifs à l'ordinateur distant.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc weekly /mo 6 /s Server16 /ru Admin01

Pour planifier l'exécution d'une tâche toutes les autres semaines, le vendredi

La commande suivante permet de planifier l'exécution d'une tâche tous les autres vendredis. Elle utilise le paramètre /mo pour spécifier l'intervalle de deux semaines et le paramètre /d pour spécifier le jour de la semaine. Pour planifier l'exécution d'une tâche tous les vendredis, n'indiquez pas le paramètre /mo ou attribuez-lui la valeur 1.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc weekly /mo 2 /d FRI

schtasks create monthly

Syntaxe

Syntaxe de planification mensuelle générale
schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc monthly [/mo {FIRST | SECOND | THIRD | FOURTH | LAST | LASTDAY] [/d {MON - SUN | 1 - 31}] [/m {JAN - DEC[,JAN - DEC...] | *}] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]
Syntaxe spécifique pour une exécution à une semaine précise
schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc monthly /mo {FIRST | SECOND | THIRD | FOURTH | LAST} /d {MON - SUN} [/m {JAN - DEC[,JAN - DEC...] | *}] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]
Syntaxe pour une exécution le dernier jour
schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc monthly /mo LASTDAY /m {JAN - DEC[,JAN - DEC...] | *} [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]
Syntaxe spécifique pour une exécution à un jour précis
schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc monthly /d {1 - 31} [/m {JAN - DEC[,JAN - DEC...] | *}] [/st HeureDébut] [/sd DateDébut] [/ed DateFin] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemples

Pour planifier l'exécution d'une tâche le premier jour de chaque mois

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté le premier jour de chaque mois. Aucun modificateur n'est utilisé. Par conséquent, le jour par défaut est le jour 1 et le mois par défaut, tous les mois ; aucun paramètre supplémentaire n'est nécessaire pour cette commande.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc monthly

Pour planifier l'exécution d'une tâche le dernier jour de chaque mois

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté le dernier jour de chaque mois. Le paramètre /mo est utilisé pour spécifier le dernier jour du mois et le paramètre /m associé au caractère générique (*), pour indiquer que le programme doit être exécuté le dernier jour de chaque mois.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc monthly /mo lastday /m *

Pour planifier l'exécution d'une tâche tous les trois mois

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté tous les trois mois. La commande utilise le paramètre /mo pour spécifier un intervalle.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc monthly /mo 3

Pour planifier l'exécution d'une tâche le deuxième dimanche de chaque mois

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté le deuxième dimanche de chaque mois. La commande utilise le paramètre /mo pour spécifier la deuxième semaine du mois et le paramètre /d pour spécifier le jour de la semaine.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc monthly /mo SECOND /d SUN

Pour planifier l'exécution d'une tâche le quinzième jour du mois de mai et du mois de juin

La commande suivante permet de planifier l'exécution du programme MonApp le 15 mai et le 15 juin à 15 heures de l'après-midi. Cette commande utilise le paramètre /d pour spécifier la date et le paramètre /m pour spécifier les mois. Elle utilise également le paramètre /st pour spécifier l'heure de début.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc monthly /d 15 /m MAY,JUN /st 15:00:00

schtasks create once

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc once /st HeureDébut /sd DateDébut [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une tâche une fois

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté à minuit le 1er janvier 2001. Le paramètre /ru permet d'exécuter la tâche avec les autorisations du compte d'utilisateur Administrateur et le paramètre /rp de fournir le mot de passe du compte Administrateur.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc once /st 00:00:00 /sd 01/01/2002 /ru Admin23 /rp motdep@sseD1

schtasks create onstart

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc onstart [/sd DateDébut] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une tâche à chaque démarrage du système

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté à chaque fois que le système démarre, en commençant le 15 mars 2001.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc onstart /sd 03/15/2001

schtasks create onlogon

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc onlogon [/sd DateDébut] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une tâche à chaque connexion de l'utilisateur sur un ordinateur distant

La commande suivante permet de planifier l'exécution d'un fichier de commandes à chaque fois qu'un utilisateur (n'importe quel utilisateur) se connecte à l'ordinateur distant. La commande utilise le paramètre /s pour spécifier l'ordinateur distant. Étant donné que la commande est exécutée à distance, tous les chemins d'accès qui y sont indiqués, y compris le chemin d'accès au fichier de commandes, sont relatifs à l'ordinateur distant.

schtasks /create /tn "Start Web Site" /tr c:\moniis\webstart.bat /sc onlogon /s Server23

schtasks create onidle

Syntaxe

schtasks /create /tn NomTâche /tr ÉlémentExécutéParTâche /sc onidle /i DuréeInactivité [/sd DateDébut] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/ru {[Domaine\]Utilisateur | "System"} [/rp Mot_de_passe]]

Exemple

Pour planifier l'exécution d'une tâche à chaque fois que l'ordinateur est inactif

Dans l'exemple suivant, le programme MonApp est planifié pour être exécuté dès que l'ordinateur enregistre un temps d'inactivité. La commande utilise le paramètre /i pour spécifier que l'ordinateur doit rester inactif pendant dix minutes avant que la tâche ne soit lancée.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc onidle /i 10

Exemples supplémentaires

Pour afficher l'exemple, cliquez sur son nom :

Pour créer une tâche qui s'exécute avec les autorisations système

La commande suivante permet de planifier l'exécution du programme MonApp avec les autorisations du compte d'autorité ou système. Dans cet exemple, la tâche est planifiée pour être exécutée le premier jour de chaque mois mais vous pouvez utiliser n'importe quel type de planification avec les tâches qui sont exécutées avec les autorisations système.

La commande utilise le paramètre /ru "System" pour spécifier le contexte de sécurité du système. Les tâches système ne requièrent pas l'utilisation d'un mot de passe. Le paramètre /rp est donc omis.

schtasks /create /tn "Mon App" /tr c:\apps\monapp.exe /sc monthly /d 1 /ru "System"

En réponse à l'exécution de cette commande, SchTasks.exe affiche un message d'information et un message indiquant le succès de l'opération. Il ne demande pas la saisie d'un mot de passe.

INFO: La tâche sera créée sous le nom d'utilisateur ("NT AUTHORITY\SYSTEM").

SUCCÈS : La tâche planifiée "Mon App" a été correctement créée.

Pour créer une tâche qui exécute plusieurs programmes

Chaque tâche exécute un seul programme uniquement. Toutefois, vous pouvez créer un fichier de commandes pour exécuter plusieurs programmes, puis planifier une tâche pour l'exécution de ce fichier de commandes. La procédure suivante illustre cette méthode :

  1. Créez un fichier de commandes qui permet de démarrer les programmes que vous voulez exécuter.

    Dans cet exemple, vous devez créer un fichier de commandes qui permet de lancer l'Observateur d'événements (Eventvwr.exe) et le Moniteur système (Perfmon.exe).

    • Ouvrez un éditeur de texte tel que le Bloc-notes.
    • Tapez le nom et le chemin d'accès complet au fichier exécutable de chaque programme. Dans ce cas, le fichier doit comprendre les éléments suivants :

      C:\Windows\System32\Eventvwr.exe
      C:\Windows\System32\Perfmon.exe

    • Enregistrez le fichier sous le nom MonApp.bat.
  2. Utilisez SchTasks.exe pour créer une tâche permettant de lancer le fichier MonApp.bat.

    La commande suivante permet de créer la tâche Moniteur, qui s'exécute dès qu'un utilisateur se connecte. Cette commande utilise le paramètre /tn pour nommer la tâche, et le paramètre /tr pour lancer le fichier MonApp.bat. Elle utilise le paramètre /sc pour indiquer le type de planification OnLogon, et le paramètre /ru pour spécifier le compte Administrateur.

    schtasks /create /tn Monitor /tr C:\MonApp.bat /sc onlogon /ru Reskit\Administrator

    L'exécution de cette commande entraîne le lancement à la fois de l'Observateur d'événements et du Moniteur système dès qu'un utilisateur se connecte à l'ordinateur.

schtasks change

Permet de modifier l'une ou toutes les propriétés suivantes d'une tâche.

  • Le programme que la tâche exécute (/tr).
  • Le compte d'utilisateur sous lequel la tâche est exécutée (/ru).
  • Le mot de passe du compte d'utilisateur (/rp).

Syntaxe

schtasks /change /tn NomTâche [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/tr ÉlémentExécutéParTâche] [/ru [Domaine\]Utilisateur | "System"] [/rp Mot_de_passe]

Paramètres

/tn NomTâche
Identifie la tâche à modifier. Tapez le nom de la tâche.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (avec ou sans barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u [domaine\]utilisateur
Permet d'exécuter la commande avec les autorisations du compte d'utilisateur spécifié. Par défaut, la commande est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
/p mot de passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u. Ce paramètre est requis quand le paramètre /u est utilisé.
/tr ÉlémentExécutéParTâche
Permet de changer le programme que la tâche exécute. Tapez le chemin d'accès complet et le nom du fichier exécutable, du fichier de script ou de commandes. Si vous n'indiquez pas de chemin d'accès, SchTasks.exe suppose que le fichier se trouve dans le répertoire RacineSystème\System32. Le programme indiqué remplace le programme d'origine exécuté par la tâche.
/ru [Domaine\]Utilisateur | "System"
Permet de changer le compte d'utilisateur sous lequel la tâche est lancée.
Valeur | Description
[Domaine\]Utilisateur | Permet de spécifier un compte d'utilisateur.
"System" ou "" | Spécifie le compte d'autorité NT ou système qui est utilisé par le système d'exploitation.

Lorsque vous changez le compte d'utilisateur, vous devez également modifier le mot de passe de l'utilisateur. Si la commande contient le paramètre /ru et non le paramètre /rp, SchTasks.exe invite l'utilisateur à indiquer un nouveau mot de passe. Les caractères saisis ne sont pas affichés à l'écran.

Les tâches exécutées avec les autorisations du compte d'autorité NT ou système ne requièrent pas la saisie d'un mot de passe et SchTasks n'en demande pas.

/rp MotDePasse
Permet de changer le mot de passe du compte sous lequel la tâche est lancée. Tapez le nouveau mot de passe
/?
Affiche l'aide à l'invite de commandes.

Remarques

    XOX
  • Les paramètres /tn et /s identifient la tâche. Les paramètres /tr, /ru et /rp spécifient les propriétés de la tâche qui peuvent être modifiées.
  • Si la commande contient l'option change, au moins une propriété doit être changée.
  • Le compte d'autorité NT ou système ne dispose pas de droits de connexion interactifs. Les utilisateurs ne voient pas et ne peuvent pas interagir avec les programmes lancés avec les autorisations système.

Exemples

Pour modifier le programme exécuté par une tâche

La commande suivante permet de changer le programme que la tâche Virus Check exécute à partir de l'exécutable VirusCheck.exe en remplaçant cet exécutable par l'exécutable VirusCheck2.exe. Cette commande utilise le paramètre /tn pour identifier la tâche, et le paramètre /tr pour spécifier le nouveau programme de la tâche. (Vous ne pouvez pas changer le nom de la tâche.)

schtasks /change /tn "Virus Check" /tr C:\VirusCheck2.exe

En réponse à cette commande, SchTasks.exe affiche le message suivant :

RÉUSSITE : Le paramètre de la tâche planifiée "Virus Check" a été modifié.

Lorsque cette commande est exécutée, la tâche Virus Check lance l'exécutable VirusCheck2.exe.

Pour modifier le mot de passe d'une tâche distante

La commande suivante permet de modifier le mot de passe du compte d'utilisateur de la tâche RemindMe sur l'ordinateur distant, Svr01. Cette commande utilise le paramètre /tn pour identifier la tâche, et le paramètre /s pour spécifier l'ordinateur distant. Elle utilise le paramètre /rp pour spécifier le nouveau mot de passe, MotDeP@sse3.

Cette procédure est obligatoire lorsque le mot de passe d'un utilisateur arrive à expiration ou change. Si le mot de passe indiqué dans une tâche n'est plus valide, la tâche ne s'exécute pas.

schtasks /change /tn RemindMe /s Svr01 /rp MotDeP@sse3

En réponse à cette commande, SchTasks.exe affiche le message suivant :

RÉUSSITE : Le paramètre de la tâche planifiée "RemindMe" a été modifié.

Lorsque cette commande est exécutée, la tâche RemindMe se lance sous le compte d'utilisateur d'origine, mais avec un nouveau mot de passe.

Pour changer le programme et le compte d'utilisateur d'une tâche

La commande suivante permet de changer le programme qu'une tâche exécute et de modifier le compte d'utilisateur sous lequel se lance cette tâche. Cela consiste essentiellement à utiliser une ancienne planification pour une nouvelle tâche. Cette commande permet de modifier la tâche Bloc-notes, qui lance le Bloc-notes tous les matins à 9 heures pour qu'elle lance Internet Explorer à la place.

Cette commande utilise le paramètre /tn pour identifier la tâche. Elle utilise le paramètre /tr pour changer le programme que la tâche exécute, et le paramètre /ru pour modifier le compte d'utilisateur sous lequel la tâche s'exécute.

Le paramètre /rp, qui indique le mot de passe du compte d'utilisateur, est omis. Vous devez fournir un mot de passe pour le compte, mais vous pouvez utiliser le paramètre /rp et taper le mot de passe en texte clair ou bien, attendre que SchTasks.exe vous invite à saisir un mot de passe, puis le taper en texte caché.

schtasks /change /tn Bloc-notes /tr "c:\program files\Internet Explorer\iexplore.exe" /ru DomainX\Admin01

Lorsque cette commande est exécutée, SchTasks.exe demande la saisie du mot de passe du compte d'utilisateur. Les caractères saisis ne sont pas affichés et le mot de passe n'est donc pas visible.

Tapez le mot de passe du compte DomaineX\Admin01: *********

Cette commande utilise le paramètre /tn pour identifier la tâche, et les paramètres /tr et /ru pour changer les propriétés de la tâche. Vous ne pouvez pas utiliser un autre paramètre pour identifier la tâche et vous ne pouvez pas non plus changer le nom de la tâche.

En réponse à cette commande, SchTasks.exe affiche le message suivant :

RÉUSSITE : Le paramètre de la tâche planifiée "Bloc-Notes" a été modifié.

Lorsque cette commande est exécutée, la tâche RemindMe se lance sous le compte d'utilisateur d'origine, mais avec un nouveau mot de passe.

Pour changer un programme lancé sous un compte système

La commande suivante permet de modifier la tâche ScriptDeSécurité de façon à ce qu'elle soit exécutée avec les autorisations du compte d'autorité ou système. La commande utilise le paramètre /ru "" pour indiquer le compte système.

schtasks /change /tn ScriptDeSécurité /ru ""

En réponse à cette commande, SchTasks.exe affiche le message suivant :

RÉUSSITE : Le paramètre de la tâche planifiée "Script De Sécurité" a été modifié.

Étant donné que les tâches exécutées avec les autorisations du compte système ne requièrent pas la saisie d'un mot de passe, SchTasks.exe n'en demande pas.

schtasks run

Permet d'exécuter une tâche immédiatement. L'option run ignore la planification mais utilise l'emplacement du fichier du programme, le compte d'utilisateur et le mot de passe indiqués dans la tâche pour exécuter la tâche immédiatement.

Syntaxe

schtasks /run /tn NomTâche [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] /?

Paramètres

/tn NomTâche
Identifie la tâche. Ce paramètre est obligatoire.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (avec ou sans barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u [domaine\]utilisateur
Permet d'exécuter la commande avec les autorisations du compte d'utilisateur spécifié. Par défaut, la commande est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
/p mot de passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u. Ce paramètre est requis quand le paramètre /u est utilisé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

    XOX
  • Suivez la procédure suivante pour tester vos tâches. Si une tâche ne s'exécute pas, contrôlez le journal des transactions (SchedLgU.txt) du service du Planificateur de tâches, qui se trouve dans le répertoire RacineSystème\ pour prendre connaissance des erreurs.
  • L'exécution d'une tâche n'affecte pas sa planification et ne change pas l'exécution suivante planifiée pour la tâche.
  • Une tâche qui doit être exécutée à distance, doit être planifiée sur l'ordinateur distant. Lorsque vous exécutez ce type de tâche, elle n'est exécutée que sur l'ordinateur distant. Pour vous assurer que la tâche est exécutée uniquement sur un ordinateur distant, consultez le journal des transactions (SchedLgU.txt) du Gestionnaire de tâches ou du Planificateur de tâches, qui se trouve dans le répertoire RacineSystème\.

Exemples

Pour exécuter une tâche sur un ordinateur local

La commande suivante permet de lancer la tâche « Script de sécurité ».

schtasks /run /tn "Script de sécurité"

En réponse à l'exécution de cette commande, SchTasks.exe lance le script associé à la tâche et affiche le message suivant :

RÉUSSITE : La tâche planifiée "Script de sécurité" est en cours d'exécution......

Pour exécuter une tâche sur un ordinateur distant

La commande suivante permet de lancer la tâche de mise à jour (Update) sur l'ordinateur distant, Svr01 :

schtasks /run /tn Update /s Svr01

En réponse à cette commande, SchTasks.exe affiche le message d'erreur suivant :

Erreur : Impossible d'exécuter la tâche planifiée "Update".

Pour déterminer l'origine de l'erreur, consultez le journal des transactions (SchedLgU.txt) du Planificateur de tâches, qui se trouve dans le répertoire C:\Windows\ sur l'ordinateur Svr01. Dans ce cas, l'entrée suivante figure dans le journal :

"Update.job" (update.exe) 3/26/2001 1:15:46 PM ** ERROR **

La tentative de connexion au compte associé à cette tâche a échoué. La tâche n'a donc pas démarré.

    L'erreur spécifique est :

    0x8007052e: Échec d'ouverture de session : nom d’utilisateur inconnu ou mot de passe incorrect.

    Vérifiez que le champ "Exécuter en tant que" de la tâche et le mot de passe sont valides, puis réessayez.

Apparemment, le nom de l'utilisateur ou le mot de passe indiqué dans la tâche n'est pas valide pour ce système. La commande schtasks /change suivante permet de mettre à jour le nom de l'utilisateur et son mot de passe pour la tâche de mise à jour sur l'ordinateur Svr01 :

schtasks /change /tn Update /s Svr01 /ru Administrator /rp M@tDePasse3

Une fois la commande change exécutée, la commande run est relancée. Cette fois, le programme Update.exe est lancé et SchTasks.exe affiche le message suivant :

RÉUSSITE : La tâche planifiée "Update" est en cours d'exécution......

schtasks end

Permet d'interrompre un programme lancé par une tâche.

Syntaxe

schtasks /end /tn NomTâche [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] /?

Paramètres

/tn NomTâche
Identifie la tâche qui a démarré le programme. Ce paramètre est obligatoire.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (avec ou sans barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u [domaine\]utilisateur
Permet d'exécuter la commande avec les autorisations du compte d'utilisateur spécifié. Par défaut, la commande est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
/p mot de passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u. Ce paramètre est requis quand le paramètre /u est utilisé.
/?
Affiche l'aide.

Remarques

    XOX
  • SchTasks.exe permet uniquement de mettre fin aux instances d'un programme qui a été lancé par une tâche planifiée. Pour mettre fin à d'autres processus, utilisez l'outil TaskKill, fourni avec Windows XP Professionnel. Pour plus d'informations sur l'utilitaire TaskKill, consultez Taskkill
    • .

Exemples

Pour mettre fin à une tâche sur un ordinateur local

La commande suivante permet d'arrêter l'exécution de l'instance du Bloc-notes lancé par la tâche Mon Bloc-notes :

schtasks /end /tn "Mon Bloc-notes"

En réponse à l'exécution de cette commande, SchTasks.exe met fin à l'exécution de l'instance du Bloc-notes et affiche le message suivant :

RÉUSSITE :  La tâche planifiée"Mon Bloc-notes" s'est terminée correctement.

Pour mettre fin à une tâche sur un ordinateur distant

La commande suivante permet de mettre fin à l'exécution de l'instance de Internet Explorer qui a été lancée par la tâche InternetOn sur l'ordinateur distant, Svr01.

schtasks /end /tn InternetOn /s Svr01

En réponse à l'exécution de cette commande, SchTasks.exe met fin à l'exécution de l'instance de Internet Explorer que la tâche a lancée et affiche le message suivant :

RÉUSSITE : La tâche planifiée "InternetOn" s'est terminée correctement.

schtasks delete

Permet de supprimer une tâche planifiée.

Syntaxe

schtasks /delete /tn {NomTâche | *} [/f] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]] [/?]

Paramètres

/tn {NomTâche | *}
Identifie la tâche à supprimer. Ce paramètre est obligatoire.
Valeur | Description
NomTâche | Permet de supprimer la tâche indiquée.
* | Supprime toutes les tâches planifiées sur l'ordinateur.
/f
Supprime le message de confirmation. La tâche est supprimée sans avertissement préalable.
/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (avec ou sans barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u [domaine\]utilisateur
Permet d'exécuter la commande avec les autorisations du compte d'utilisateur spécifié. Par défaut, la commande est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
/p mot de passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u. Ce paramètre est requis quand le paramètre /u est utilisé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

    XOX
  • La commande delete permet de supprimer la tâche de la planification. Elle ne permet pas de supprimer le programme que la tâche exécute ou d'interrompre un programme en cours d'exécution.
  • La commande delete * permet, quant à elle, de supprimer toutes les tâches planifiées pour l'ordinateur, et pas uniquement celles qui ont été planifiées par l'utilisateur courant.

Exemples

Pour supprimer une tâche planifiée pour un ordinateur distant

La commande suivante permet de supprimer la tâche « Démarrer messagerie » de la planification pour un ordinateur distant. La commande utilise le paramètre /s pour spécifier l'ordinateur distant.

schtasks /delete /tn "Démarrer messagerie" /s Svr16

En réponse à cette commande, SchTasks.exe affiche le message : Pour supprimer la tâche, tapez o. Pour annuler la commande, tapez n:

AVERTISSEMENT : Voulez-vous vraiment supprimer la tâche "Démarrer messagerie" (O/N )? O

SUCCÈS : La tâche planifiée "Démarrer messagerie" a été correctement supprimée.

Pour supprimer toutes les tâches planifiées pour l'ordinateur local

La commande suivante permet de supprimer toutes les tâches de la planification de l'ordinateur local, y compris les tâches planifiées par d'autres utilisateurs. Cette commande utilise le paramètre /tn * pour désigner toutes les tâches sur l'ordinateur, et le paramètre /f pour supprimer l'affichage du message de confirmation.

schtasks /delete /tn * /f

En réponse à l'exécution de cette commande, SchTasks.exe affiche les messages suivants, indiquant que seule la tâche planifiée, Script de sécurité, est supprimée.

RÉUSSITE : La tâche planifiée "Script de sécurité" a été correctement supprimée.

schtasks query

Permet d'afficher toutes les tâches planifiées pour être exécutées sur l'ordinateur, y compris celles qui ont été planifiées par d'autres utilisateurs.

Syntaxe

schtasks [/query] [/fo {TABLE | LIST | CSV}] [/nh] [/v] [/s ordinateur [/u [domaine\]utilisateur /p mot_de_passe]]

Paramètres

[/query]
Le nom de la tâche est facultatif. La commande schtasks utilisée sans paramètres lance une recherche.
/fo {TABLE|LIST|CSV}
Spécifie le format en sortie. Le format TABLE est utilisé par défaut.
/nh
Permet de ne pas indiquer les en-têtes de colonne de la table qui est affichée. Ce paramètre est valide avec les formats de sortie TABLE et CSV.
/v
Permet d'ajouter les propriétés avancées de la tâche à l'affichage.

Les recherches pour lesquelles le paramètre /v est utilisé, doivent avoir le format LIST ou CSV.

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (avec ou sans barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u [domaine\]utilisateur
Permet d'exécuter la commande avec les autorisations du compte d'utilisateur spécifié. Par défaut, la commande est lancée avec les autorisations de l'utilisateur connecté à l'ordinateur sur lequel la commande SchTasks est exécutée.
/p mot de passe
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u. Ce paramètre est requis quand le paramètre /u est utilisé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

    XOX
  • La commande query permet de répertorier toutes les tâches planifiées pour l'ordinateur, et pas uniquement celles qui ont été planifiées par l'utilisateur courant.

Exemples

Pour afficher toutes les tâches planifiées sur l'ordinateur local

Les commandes suivantes permettent d'afficher toutes les tâches planifiées pour l'ordinateur local. Ces commandes produisent un résultat identique et sont interchangeables.

schtasks

schtasks /query

En réponse à leur exécution, SchTasks.exe affiche par défaut les tâches dans un format de tableau simple, tel que l'illustre l'exemple suivant :

Nom de tâche                  Heure de la prochaine exécution            État

========================= ======================== ==============

Microsoft Outlook         À l'ouverture de session

Script de sécurité              14:42:00 PM , 2/4/2001

Pour afficher les propriétés avancées des tâches planifiées

La commande suivante demande l'affichage détaillé des tâches sur l'ordinateur local. Elle utilise le paramètre /v pour demander l'affichage détaillé (documenté), et le paramètre /fo LIST pour présenter l'affichage sous forme de liste facilement lisible. Vous pouvez utiliser cette commande pour vous assurer que la tâche que vous avez créée l'a été en respectant le modèle approprié aux répétitions.

schtasks /query /fo LIST /v

En réponse à l'exécution de cette commande, SchTasks.exe affiche la liste détaillée des propriétés de toutes les tâches. Dans l'exemple suivant, l'affichage présente, sous forme de liste, les données relatives à une tâche planifiée pour être exécutée à 4 heures du matin, le dernier vendredi de chaque mois.

NomHôte :                                  RESKIT01

NomTâche :                                  Script de sécurité

Heure de la prochaine exécution :                             4:00:00 AM , 30/3/2001

État :                                    N'est pas encore exécuté

Heure de la dernière exécution :                             Jamais

Dernier résultat :                               0

Créateur :                                   util01

Planification :                                  À 4:00 AM le dernier vendredi de chaque mois, à partir du 24/3/2001

Tâche à exécuter :                               C:\WINDOWS\system32\notepad.exe

Commencer dans :                                  notepad.exe

Commentaire :                                   Non applicable

Statut de la tâche planifiée :                      Activé

Type planifié :                            Mensuel

Modificateur :                                  Dernier vendredi

Heure de début :                                4:00:00 AM

Date de début :                                3/24/2001

Date de fin :                                  Non applicable

Jours :                                      VENDREDI

Mois :                                    JAN,FEV,MAR,AVR,MAI,JUN,JUL,AOU,SEP,OCT,NOV,DEC

Exécuter en tant qu'utilisateur :                               RESKIT\util01

Supprimer la tâche si elle n'est pas replanifiée :            Activé

Arrêter la tâche après X Heures et X Minutes :      72:0

Répétition : Jusqu'à l'heure indiquée :                        Désactivé

Répétition : Durée :                          Désactivé

Répétition : Arrêter si l'exécution est toujours en cours :             Désactivé

Inactivité : Démarrer l'heure (pour le type d'IDLE programmé) : Désactivé

Inactivité : Ne démarrer que si inactif depuis X Minutes :    Désactivé

Inactivité : Si l'ordinateur n'est pas inactif essayer à nouveau pendant X Minutes :     Désactivé

Inactivité : Arrêter la tâche si l'inactivité est terminée :         Désactivé

Gestion de l'alimentation : Pas de démarrage sur batteries :         Désactivé

Gestion de l'alimentation : Arrêt sur mode batteries :          Désactivé

Pour consigner dans un journal les tâches planifiées pour un ordinateur distant

La commande suivante permet d'obtenir la liste des tâches planifiées pour un ordinateur distant et d'ajouter ces tâches dans un fichier journal (les entrées sont séparées par des virgules) situé sur l'ordinateur local. Vous pouvez utiliser le format de cette commande pour collecter et suivre les tâches qui sont planifiées pour plusieurs ordinateurs.

Cette commande utilise le paramètre /s pour identifier l'ordinateur distant, Reskit16, le paramètre /fo pour spécifier le format, et le paramètre /nh pour supprimer les en-têtes des colonnes. Le symbole >> permet de rediriger les résultats de la commande vers le fichier journal des tâches, p0102.csv, sur l'ordinateur local, Svr01. Étant donné que la commande est exécutée sur l'ordinateur distant, le chemin d'accès à l'ordinateur local doit être complet.

schtasks /query /s Reskit16 /fo csv /nh >> \\svr01\data\tasklogs\p0102.csv

En réponse à l'exécution de cette commande, SchTasks.exe ajoute les tâches planifiées pour l'ordinateur Reskit16 dans le fichier p0102.csv sur l'ordinateur local, Svr01.

Remarques

  • SchTasks.exe permet d'effectuer des opérations qui sont similaires à celles qui peuvent l'être en utilisant l'outil Tâches planifiées accessible par le Panneau de configuration. Vous pouvez utiliser l'un ou l'autre outil pour créer, supprimer, configurer ou afficher les tâches planifiées.
  • La commande schtasks utilisée sans paramètres lance une recherche.
  • L'utilisateur doit être membre du groupe Administrateurs sur l'ordinateur concerné par la commande.
  • Pour vous assurer qu'une tâche planifiée s'est bien exécutée ou pour déterminer pourquoi elle ne s'est pas exécutée, consultez le journal des transactions du Planificateur de tâches (SchedLgU.txt), qui se trouve dans le répertoire RacineSystème\. Ce journal consigne toutes les tentatives d'exécution initiées par tous les outils utilisés par le service, y compris par les outils Tâches planifiées et SchTasks.exe.
  • En de rares occasions, les fichiers de tâche finissent pas être corrompus. Il est impossible d'exécuter des tâches corrompues. Si vous tentez d'effectuer une opération sur des tâches corrompues, SchTasks.exe affiche le message d'erreur suivant :
    Erreur : Données non valides.

    Il est impossible de récupérer des tâches corrompues. Pour restaurer les fonctions de planification de tâche du système, utilisez les outils SchTasks.exe ou Tâches planifiées pour supprimer du système les tâches et les replanifier.

  • L'outil SchTasks.exe remplace l'outil At.exe, un outil qui était fourni avec les versions précédentes de Windows.


Secedit

Permet de configurer et d'analyser la sécurité du système en comparant la configuration actuelle à au moins un modèle.

Pour afficher la syntaxe d'une commande, sélectionnez-la :

secedit /analyze

Syntaxe

secedit /analyze /db NomFichier [/cfg NomFichier] [/log NomFichier] [/quiet]

Paramètres

/db NomFichier
Obligatoire. Indique le chemin d'accès et le nom de fichier de la base de données qui contient la configuration stockée par rapport à laquelle l'analyse sera effectuée. Si le paramètre NomFichier spécifie une nouvelle base de données, l'option /cfg NomFichier de la ligne de commandes doit également être indiquée.
/cfg NomFichier
Spécifie le chemin d'accès et le nom de fichier du modèle de sécurité qui sera importé dans la base de données en vue d'une analyse. Cette option de ligne de commandes est uniquement valide lorsqu'elle est utilisée avec le paramètre /db. Si elle n'est pas spécifiée, l'analyse sera effectuée par rapport à n'importe quelle configuration déjà stockée dans la base de données.
/log NomFichier
Indique le chemin d'accès et le nom du fichier journal pour le processus. Si cette option n'est pas spécifiée, le fichier par défaut sera utilisé.
/quiet
Supprime les sorties écran et journal. Vous pouvez toutefois toujours analyser les résultats en utilisant le composant Configuration et analyse de la sécurité.

secedit /configure

Cette commande permet de configurer la sécurité du système en appliquant un modèle stocké.

Syntaxe

secedit /configure /db NomFichier [/cfg NomFichier ] [/overwrite][/areas zone1 zone2...] [/log NomFichier] [/quiet]

Paramètres

/db NomFichier
Obligatoire. Indique le nom de fichier de la base de données qui contient le modèle de sécurité devant être appliqué.
/cfg NomFichier
Permet de spécifier le nom de fichier du modèle de sécurité qui sera importé dans la base de données et appliqué au système. Cette option de ligne de commandes est uniquement valide lorsqu'elle est utilisée avec le paramètre /db. Si elle n'est pas spécifiée, le modèle déjà stocké dans la base de données sera appliqué.
/overwrite
Indique si le modèle de sécurité spécifié dans le paramètre /cfg doit remplacer ou non tout modèle ou tout modèle composite stocké dans la base de données au lieu d'ajouter les résultats au modèle stocké. Cette option de ligne de commandes est uniquement valide lorsqu'elle est utilisée avec le paramètre /cfg. Si elle n'est pas spécifiée, le modèle indiqué dans le paramètre /cfg sera ajouté au modèle stocké.
/areas zone1 zone2...
Spécifie les zones de sécurité à appliquer au système. Si aucune zone n'est spécifiée, toutes les zones sont appliquées au système. Chaque zone doit être délimitée par un espace.
Nom des zones | Description
SECURITYPOLICY | Stratégie locale et stratégie de domaine du système, comprenant les stratégies de compte, les stratégies d'audit, etc.
GROUP_MGMT | Paramètres de groupes restreints pour n'importe quel groupe spécifié dans le modèle de sécurité.
USER_RIGHTS | Droits de connexion de l'utilisateur et privilèges accordés.
REGKEYS | Sécurité sur les clés de Registre locales.
FILESTORE | Sécurité sur les emplacements de fichiers locaux.
SERVICES | Sécurité pour tous les services définis.
/log NomFichier
Indique le nom du fichier journal pour le processus. Si cette option n'est pas spécifiée, c'est le chemin par défaut qui est utilisé.
/quiet
Supprime les sorties écran et journal.

secedit /export

Cette commande permet d'exporter un modèle stocké depuis une base de données de sécurité vers un fichier modèle de sécurité.

Syntaxe

secedit /export [/mergedpolicy] [/DB NomFichier] [/CFG NomFichier] [/areas zone1 zone2...] [/log NomFichier] [/quiet]

Paramètres

/mergedpolicy
Fusionne et exporte les paramètres de sécurité de la stratégie locale et de la stratégie de domaine.
/db NomFichier
Spécifie le fichier de la base de données qui contient le modèle à exporter. Si aucun nom de fichier de base de données n'est spécifié, c'est la base de données de stratégie du système qui est utilisée.
/db NomFichier
Spécifie le nom du fichier dans lequel enregistrer le modèle.
/areas zone1 zone2...
Spécifie les zones de sécurité qui doivent être exportées vers un modèle. Si aucune zone n'est spécifiée, toutes les zones sont exportées. Chaque zone doit être délimitée par un espace.
Nom des zones | Description
SECURITYPOLICY | Spécifie la stratégie locale et la stratégie de domaine du système, comprenant les stratégies de compte, les stratégies d'audit, etc.
GROUP_MGMT | Spécifie les paramètres de groupes restreints pour n'importe quels groupes spécifiés dans le modèle de sécurité.
USER_RIGHTS | Spécifie les droits de connexion de l'utilisateur et les privilèges accordés.
REGKEYS | Spécifie la sécurité sur les clés de Registre locales.
FILESTORE | Spécifie la sécurité sur le stockage des fichiers en local.
SERVICES | Spécifie la sécurité pour tous les services définis.
/log NomFichier
Indique le nom du fichier journal pour le processus. Si cette option n'est pas spécifiée, c'est le chemin par défaut qui est utilisé.
/quiet
Supprime les sorties écran et journal.

secedit /validate

Cette commande permet de valider la syntaxe du modèle de sécurité à importer dans une base de données en vue de son analyse ou de son application à un système.

Syntaxe

secedit /validate NomFichier

Paramètre

NomFichier
Spécifie le nom de fichier du modèle de sécurité que vous avez créé à l'aide du composant Modèles de sécurité.

Remarques

  • La commande secedit /refreshpolicy a été remplacée par la commande gpupdate. Pour plus d'informations sur l'actualisation des paramètres de sécurité, consultez gpupdate.


Set

Permet d'afficher, de définir ou de supprimer des variables d'environnement. Utilisée sans paramètres, la commande set affiche les paramètres d'environnement en cours.

Syntaxe

set [[/a [expression]] [/p [variable=]] chaîne]

Paramètres

/a
Permet d'indiquer pour le paramètre chaîne une expression numérique qui est évaluée.
/p
Affecte au paramètre variable la valeur d'une ligne d'entrées.
variable
Désigne la variable à définir ou à modifier.
chaîne
Indique la chaîne à associer à la variable spécifiée.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de la commande set sur la console de récupération

    La commande set est disponible, avec d'autres paramètres, à partir de la console de récupération.

  • Utilisation de caractères spéciaux

    Les caractères <, >, |, &, ^ sont des caractères spéciaux de l'interpréteur de commandes et doivent être précédés soit de caractères d'échappement (^), soit être encadrés de guillemets lorsqu'ils sont utilisés dans le paramètre chaîne (par exemple lorsque le, "Symbole&EstContenuDansChaîne". Si vous utilisez des guillemets pour encadrer une chaîne contenant l'un de ces caractères spéciaux, ces guillemets sont définis comme faisant partie de la valeur de la variable d'environnement.

  • Utilisation des variables d'environnement

    Les variables d'environnement sont utilisées pour contrôler le comportement de certains fichiers et programmes de commandes, ainsi que la présentation et le mode de fonctionnement de Windows XP et du sous-système MS-DOS. La commande set est souvent utilisée dans le fichier Autoexec.nt pour définir les variables d'environnement.

  • Affichage des paramètres d'environnement en cours

    Lorsque vous tapez la commande set sans paramètre, ce sont les paramètres d'environnement en cours qui sont affichés. Ceux-ci incluent généralement les variables d'environnement COMSPEC et PATH utilisées pour rechercher des programmes sur un disque. Windows XP utilise aussi les deux variables d'environnement PROMPT et DIRCMD.

  • Utilisation de paramètres

    Lorsque vous spécifiez des valeurs pour une variable et une chaîne, la valeur de la variable indiquée est ajoutée à l'environnement et la chaîne est associée à cette variable. Si la variable existe déjà dans l'environnement, la nouvelle valeur de la chaîne se substitue à l'ancienne.

    Si vous ne spécifiez qu'une variable et un signe égal (sans chaîne) pour la commande set, la valeur de la chaîne associée à la variable est effacée (comme si la variable n'existait pas).

  • Utilisation de l'option /a

    Le tableau suivant présente les opérateurs autorisés avec l'option /a par ordre de priorité décroissante.

    Opérateur Opération effectuée
    < > Groupement
    * / % + - Calcul
    << >> Décalage logique
    & ET au niveau du bit
    ^ OU exclusif au niveau du bit
    | OU au niveau du bit
    = *= /= %= += -= &= ^= |= <<= >>= Attribution
    , Séparateur d'expression

    Si vous utilisez des opérateurs logiques (&& ||) ou des nombres (%), vous devez mettre l'expression entre guillemets. Toute chaîne non numérique dans l'expression est traitée comme un nom de variable d'environnement dont les valeurs sont converties en nombres avant d'être utilisées. Si un nom de variable d'environnement est spécifié mais n'est pas défini dans l'environnement en cours, alors, la valeur zéro est allouée. Cela vous permet de faire des calculs avec les valeurs d'une variable d'environnement sans avoir à entrer le signe % pour obtenir ces valeurs.

    Si vous exécutez la commande set /a à partir de la ligne de commandes en dehors d'un script de commande, alors la valeur finale de l'expression est affichée.

    Les valeurs numériques sont des nombres décimaux, à moins qu'ils ne soient préfixés par 0× pour les valeurs hexadécimales ou par 0 pour la notation octale. Donc, 0×12 équivaut à 18 et à 022. Notez que la notation octale peut être confuse. Par exemple, 08 et 09 ne sont pas valides car 8 et 9 ne sont pas des nombres valides en notation octale.

  • Utilisation de l'option /p

    Vous n'êtes pas autorisé à inclure une chaîne d'invite de commandes.

  • Prise en charge de l'expansion retardée de variables d'environnement

    La prise en charge de l'expansion retardée de variables d'environnement a été ajoutée. Cette prise en charge est toujours désactivée par défaut mais elle peut être activée ou désactivée via l'option de ligne de commandes cmd /v.

  • Utilisation des extensions de commandes

    Lorsque les extensions de commandes sont activées, ce qui est le cas par défaut, et que vous exécutez la commande set sans paramètres, celle-ci permet d'afficher toutes les variables d'environnement courantes. Si vous exécutez la commande set avec une valeur, elle affiche les variables qui correspondent à cette valeur.

  • Utilisation de la commande set dans des fichiers de commandes

    Lorsque vous créez des fichiers de commandes, vous pouvez utiliser la commande set pour créer des variables et les utiliser tout comme vous utiliseriez des variables numérotées de %0 à %9. Les variables %0 à %9 peuvent également être utilisées comme entrées pour la commande set.

  • Appel d'une variable pour la commande set à partir d'un fichier de commandes

    Quand vous appelez une valeur de variable à partir d'un fichier de commandes, vous devez la placer entre des signes de pourcentage (%). Si, par exemple, votre programme de commandes crée une variable d'environnement nommée BAUD, vous pouvez utiliser la chaîne associée à BAUD comme un paramètre remplaçable, en tapant %baud% sur la ligne de commandes.

Exemples

Pour définir une variable d'environnement nommée TEST^1, tapez :

set testVar=test^^1

Pour définir une variable d'environnement nommées TEST&1, tapez :

set testVar=test^&1

La commande Set permet d'affecter à la valeur de la variable toutes les valeurs qui suivent le signe égal (=). Si vous tapez :

set testVar="test^1"

Vous obtenez le résultat suivant :

testVar="test^1"

Pour définir une variable d'environnement nommée INCLUDE de manière à lui associer la chaîne C:\Inc (répertoire Inc du disque C), tapez la commande suivante :

set include=c:\inc

Pour utiliser la chaîne C:\Inc dans des fichiers de commandes, vous pouvez alors encadrer le nom INCLUDE par des signes de pourcentage (%). Incluez, par exemple, la commande suivante dans un fichier de commandes afin d'afficher le contenu du répertoire associé à la variable d'environnement INCLUDE :

dir %include%

Lorsque cette commande est traitée, la chaîne C:\Inc se substitue à %include%.

Vous pouvez aussi utiliser la commande set dans un programme de commandes qui ajoute un nouveau répertoire dans la variable d'environnement PATH. Par exemple :

@echo off
rem ADDPATH.BAT ajoute un nouveau répertoire
rem à la variable d'environnement path.
set path=%1;%chemin%
set

Lorsque les extensions de commandes sont activées, ce qui est le cas par défaut, et que vous exécutez la commande set avec une valeur, celle-ci permet d'afficher toutes les variables qui correspondent à cette valeur. Par exemple, si vous tapez set p à l'invite de commandes, vous obtenez les résultats suivants :

Path=C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 8 Stepping 1, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0801
ProgramFiles=C:\Program Files
PROMPT=$P$G


Setlocal

Permet de démarrer la localisation des variables d'environnement dans un fichier de commandes. La localisation se poursuit jusqu'à ce qu'une commande endlocal concordante soit trouvée ou que la fin du fichier de commandes soit atteinte.

Syntaxe

setlocal {enableextension | disableextensions} {enabledelayedexpansion | disabledelayedexpansion}

Arguments

enableextension
Cet argument active les extensions de commandes jusqu'à ce que la commande endlocal correspondante soit rencontrée, quelle que soit sa valeur avant l'exécution de la commande setlocal.
disableextensions
Cet argument désactive les extensions de commandes jusqu'à ce que la commande endlocal correspondante soit rencontrée, quelle que soit sa valeur avant l'exécution de la commande setlocal.
enabledelayedexpansion
Cet argument active l'expansion retardée des variables d'environnement jusqu'à ce que la commande endlocal correspondante soit rencontrée, quelle que soit sa valeur avant l'exécution de la commande setlocal.
disabledelayedexpansion
Cet argument désactive l'expansion retardée des variables d'environnement jusqu'à ce que la commande endlocal correspondante soit rencontrée, quelle que soit sa valeur avant l'exécution de la commande setlocal.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de l'option setlocal

    L'utilisation de la commande setlocal, indépendamment d'un fichier de commandes ou de scripts, n'a aucun effet.

  • Modification des variables d'environnement

    Utilisez la commande setlocal pour modifier les variables d'environnement lorsque vous exécutez un fichier de commandes. Les modifications d'environnement apportées après l'exécution de la commande setlocal sont appliquées localement au fichier de commandes. L'exécutable Cmd.exe permet de rétablir les paramètres précédents lorsqu'une commande endlocal est rencontrée ou lorsque la fin du fichier de commandes est atteinte.

  • Un programme de commandes peut contenir plusieurs commandes setlocal ou endlocal (des commandes imbriquées).
  • Test des extensions de commandes dans des fichiers de commandes

    La commande setlocal permet de définir la variable ERRORLEVEL. Si vous transmettez la commande {enableextension | disableextensions} ou {enabledelayedexpansion | disabledelayedexpansion}, la variable ERRORLEVEL prend la valeur zéro (0). Dans le cas contraire, elle prend la valeur un (1). Vous pouvez utiliser cette commande dans des scripts de commandes pour déterminer si les extensions sont disponibles, comme dans l'exemple ci-dessous :

        verify other 2>nul

    setlocal enableextensions

    if errorlevel 1 echo Impossible d'activer les extensions

    Étant donné que la commande cmd ne permet pas de définir la variable ERRORLEVEL lorsque les extensions de commandes sont désactivées, la commande verify affecte à la variable ERRORLEVEL une valeur différente de zéro lorsque vous l'utilisez avec un argument non autorisé. Par ailleurs, si vous utilisez la commande setlocal avec les arguments {enableextension | disableextensions} ou {enabledelayedexpansion | disabledelayedexpansion} et que la variable ERRORLEVEL ne prend pas la valeur un (1), les extensions de commandes ne sont pas disponibles.

    Pour plus d'informations sur l'activation et la désactivation des extensions de commandes, cliquez sur cmd dans Rubriques connexes.

Exemples

Pour commencer la localisation des variables d'environnement dans un fichier de commandes, tapez :

  rem *******Début du commentaire**************

  rem Ce programme lance le programme de commandes superapp sur le réseau,

  rem dirige le résultat obtenu en sortie vers un fichier et affiche le contenu du fichier

  rem dans le Bloc-notes.

  rem *******Fin du commentaire**************

      @echo off

      setlocal

      path=g:\programs\superapp;%path%

      call superapp>c:\superapp.out

      endlocal

      start notepad c:\superapp.out


Setver

Définit le numéro de version de MS-DOS que le sous-système MS-DOS renvoie à un programme. Utilisée sans paramètres, la commande setver affiche la table des versions en cours.

Syntaxe

setver [Lecteur:Chemin] [NomFichier n.nn]

setver [Lecteur:Chemin] [NomFichier [/delete [/quiet]]

Pour afficher la table des versions en cours, utilisez la syntaxe suivante :

setver [Lecteur:Chemin]

Paramètres

[Lecteur:Chemin]
Indique l'emplacement du fichier Setver.exe.
NomFichier
Indique le nom du fichier programme (.exe ou .com) à ajouter à la table des versions. Les caractères génériques (* ou ?) ne sont pas autorisés.
n.nn
Spécifie la version MS-DOS (3.3 ou 4.01, par exemple) que le sous-système MS-DOS renvoie au fichier programme spécifié.
/delete
Supprime l'entrée correspondant au fichier programme spécifié dans la table des versions. Vous pouvez aussi utiliser /d.
/quiet
Permet de masquer le message qui s'affiche habituellement lorsque vous supprimez une entrée de la table des versions.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • XOX
  • XOX
  • Utilisation de la table des versions

    De nombreux programmes conçus pour être exécutés sous une version antérieure de MS-DOS fonctionnent correctement sous Windows XP. Dans certains cas cependant, il se peut qu'un programme ne fonctionne pas correctement à moins que son nom ne soit inclus dans la table des versions. Cette table indique en effet au programme qu'il s'exécute sous la version MS-DOS pour laquelle il a été conçu, bien qu'il s'exécute en fait sous le sous-système MS-DOS. En interprétant la version 5.0 de MS-DOS comme la version antérieure voulue, il est probable que le programme s'exécute correctement. Cependant, si le programme n'est pas compatible avec Windows XP, l'utilisation de la commande setver ne résoudra pas le problème.

  • Chargement en mémoire de la table des versions

    Pour que la commande setver puisse être utilisée, il faut que la table des versions soit chargée en mémoire en ajoutant une commande device dans le fichier Config.nt.

  • Redémarrage après la mise à jour de la table des versions

    Lorsque vous mettez à jour la table des versions en lui ajoutant ou en supprimant des entrées, vous devez démarrer une nouvelle session d'invite de commandes pour relire la table des versions.

  • Mise à jour des entrées existantes

    Si vous spécifiez un nom de fichier qui se trouve déjà dans la table des versions, la nouvelle entrée se substitue à l'ancienne.

  • Présentation des codes de sortie de la commande setver

    Vous pouvez utiliser le paramètre errorlevel sur la ligne de commandes if dans un programme de commandes pour traiter les codes de sortie renvoyés par la commande setver. Pour obtenir un exemple d'un programme de commandes qui traite les codes de sortie en utilisant la commande if, consultez Rubriques connexes. Le tableau suivant énumère chaque code de sortie accompagné d'une description.

    Code de sortie | Description
    0 | Setver a accompli sa tâche avec succès.
    1 | L'utilisateur a spécifié une option de ligne de commandes non valide.
    2 | L'utilisateur a spécifié un nom de fichier non valide.
    3 | La mémoire système est insuffisante pour exécuter la commande.
    4 | L'utilisateur a spécifié un numéro de version sous un format non valide.
    5 | Setver ne trouve pas l'entrée spécifiée dans la table des versions.
    6 | Setver ne trouve pas le fichier Setver.exe.
    7 | L'utilisateur a désigné un lecteur non valide.
    8 | L'utilisateur a utilisé trop de paramètres sur la ligne de commandes.
    9 | Setver a détecté l'absence de certaines options de ligne de commandes.
    10 | Setver a détecté une erreur lors de la lecture du fichier Setver.exe.
    11 | Le fichier Setver.exe est endommagé.
    12 | Le fichier Setver.exe spécifié ne prend en charge aucune table des versions.
    13 | Il n'y a pas assez de place pour une nouvelle entrée dans la table des versions.
    14 | Setver a détecté une erreur lors de l'écriture dans le fichier Setver.exe.

Exemples

Pour exécuter MonProg.exe, un fichier qui fonctionne sous la version 3.30 de MS-DOS, créez une entrée dans la table des versions qui fait que MonProg.exe interprète le sous-système MS-DOS comme étant la version 3.30 en tapant :

setver monprog.exe 3.30

Pour supprimer l'entrée MonProg.exe de la table des versions (sans toucher à MonProg.exe), tapez la commande suivante :

setver monprog.exe /delete

Pour afficher le contenu de la table des versions sur le lecteur C, tapez la commande suivante :

setver c:


Share

XOX

Remarques

  • XOX


Shell

Indique le nom et l'emplacement d'un autre interpréteur de commandes que Windows XP doit utiliser pour le sous-système MS-DOS.

Syntaxe

shell=[[Lecteur:]Chemin] NomFichier [Paramètres]

Paramètres

[[Lecteur:]Chemin] NomFichier
Indique l'emplacement et le nom de l'interpréteur de commandes.
Paramètres
Spécifie tout paramètre ou option de ligne de commandes pouvant être utilisée avec l'interpréteur de commandes spécifié.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Paramétrage par défaut

    Par défaut, le sous-système MS-DOS utilise une version spéciale de Command.com qui fonctionne de façon transparente pour les autres sous-systèmes de Windows XP (y compris la canalisation et la redirection entre sous-systèmes). La commande shell n'est donc pas nécessaire.

  • Indication d'un interpréteur de commandes 16 bits

    Bien que cela ne soit pas recommandé, vous pouvez utiliser la commande shell pour spécifier votre propre interpréteur de commandes 16 bits.

  • Utilisation d'options de ligne de commandes avec un interpréteur de commandes

    Bien que la commande shell elle-même ne les accepte pas, si votre interpréteur de commandes utilise des options de ligne de commandes, vous pouvez les inclure dans la ligne de commande shell.

Exemples

Supposez que vous souhaitiez utiliser comme interpréteur de commandes le fichier NouvInt.com figurant dans le répertoire /Bin du lecteur de démarrage. Il vous suffit pour cela d'ajouter la commande ci-dessous au fichier Config.nt :

shell=\bin\nouvint.com


Shift

Permet de changer la position des paramètres de commandes dans un fichier de commandes.

Syntaxe

shift

Paramètres

Aucun

Remarques

  • Utilisation de l'option de ligne de commandes shift avec des extensions de commandes

    Quand les extensions de commandes sont activées, ce qui est le cas par défaut, la commande shift prend en charge l'option de ligne de commandes /n, qui indique à la commande de démarrer le décalage au nième argument, où n est une valeur comprise entre zéro et huit. Par exemple,

    SHIFT /2

    décale %3 à %2, %4 à %3, etc., sans toucher à %0 et %1.

  • Mode de fonctionnement de la commande shift

    La commande shift change les valeurs des paramètres %0 à %9 en copiant chaque paramètre dans le précédent. En d'autres termes, la valeur de %1 est copiée dans %0, la valeur de %2 est copiée dans %1, et ainsi de suite. Cette commande s'avère utile pour écrire un fichier de commandes qui exécute la même opération sur tous les paramètres.

  • Utilisation de plus de 10 paramètres de commandes

    Vous pouvez aussi utiliser la commande shift pour créer un fichier de commandes qui accepte plus de 10 paramètres. Si vous indiquez plus de 10 paramètres sur la ligne de commandes, ceux qui apparaissent après le dixième (%9) sont déplacés un à un dans %9.

  • Utilisation de %* avec shift

    La commande Shift n'a aucun effet sur le paramètre de commande %*.

  • Déplacement inverse des paramètres

    Il n'existe pas de commande shift inverse. Une fois la commande shift exécutée, il est impossible de récupérer le premier paramètre de commande (%0) qui existait avant le déplacement.

Exemples

Le fichier de commandes ci-dessous, appelé MaCopie.bat, indique comment utiliser la commande shift avec un nombre quelconque de paramètres. Il copie une liste de fichiers dans un répertoire spécifique. Les paramètres de commandes sont représentés par les arguments du répertoire et du nom de fichier.

@echo off

rem MACOPIE.BAT copie un nombre quelconque de fichiers

rem vers un répertoire

rem La commande utilise la syntaxe suivante :

rem macopie dir fichier1 fichier2 ...

set todir=%1

:getfile

shift

if "%1"=="" goto end

copy %1 %todir%

goto getfile

:end

set todir=

echo All done


Shutdown

Cette commande permet d'arrêter ou de redémarrer un ordinateur local ou distant. Utilisée sans paramètres, la commande shutdown permet de déconnecter l'utilisateur courant.

Syntaxe

shutdown [{-l|-s|-r|-a}] [-f] [-m [\\NomOrdinateur]] [-t xx] [-c "message"] [-d[u][p]:xx:yy]

Paramètres

-l
Déconnecte l'utilisateur courant. Il s'agit du paramètre par défaut. -m NomOrdinateur a la priorité.
-s
Arrête l'ordinateur local.
-r
Réinitialise l'ordinateur après son arrêt.
-a
Annule l'arrêt. Ignore les autres paramètres, à l'exception de -l et de NomOrdinateur. Vous pouvez utiliser uniquement -a durant le délai de temporisation.
-f
Force la fermeture des applications en cours.
-m [\\NomOrdinateur]
Spécifie l'ordinateur que vous souhaitez arrêter.
-t xx
Fixe à xx secondes le délai avant l'arrêt du système. La valeur par défaut est 20 secondes.
-c "message"
Indique le message qui sera affiché dans la zone Message de la fenêtre Arrêt du système. Vous disposez de 127 caractères au plus. Le message doit être encadré de guillemets.
-d [u][p]:xx:yy
Indique le code correspondant au motif de l'arrêt. Le tableau suivant indique les différentes valeurs.
Valeur | Description
u | Indique un code utilisateur.
p | Indique un code d'arrêt planifié.
xx | Précise le code de motif principal (0-255).
yy | Précise le code de motif secondaire (0-65536).
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si vous indiquez un code de motif principal et un code de motif secondaire, vous devez commencer par définir ces codes sur chaque ordinateur pour lequel vous envisagez d'utiliser ce motif. Si les codes de motif ne sont pas définis sur l'ordinateur cible, l'Observateur d'événements ne peut pas enregistrer le texte du code de motif approprié.

Exemples

Pour arrêter \\MonServeur en 60 secondes, forcez l'arrêt des applications en cours, redémarrez l'ordinateur après l'arrêt, indiquez un code utilisateur, précisez que l'arrêt est planifié, enregistrez le code de motif principal 125, enregistrez le code de motif secondaire 1, puis tapez :

shutdown -r -f -m \\MonServeur -t 60 -d up:125:1


Sort

Lit les données d'entrée, les trie et affiche les résultats à l'écran ou les envoie dans un fichier ou à un autre périphérique.

Syntaxe

sort [/r] [/+n] [/m KiloOctets] [/l locale] [/rec caractères] [[Lecteur1:][Chemin1]NomFichier1] [/t [Lecteur2:][Chemin2]] [/o [Lecteur3:][Chemin3]NomFichier3]

[Commande |] sort [/r] [/+n] [/m KiloOctets] [/l locale] [/rec caractères] [[Lecteur1:][Chemin1]NomFichier1][/t [Lecteur2:][Chemin2]] [/o [Lecteur3:][Chemin3]NomFichier3]

Paramètres

/r
Inverse l'ordre de tri (trie les données de Z à A, puis de 9 à 0).
/+n
Indique le numéro de position du caractère, n, auquel la commande sort commence chaque comparaison.
/m KiloOctets
Indique le volume de mémoire principale à utiliser pour le tri, en kilo-octets (ko).
/l locale
Ignore l'ordre de tri des caractères défini par les paramètres régionaux par défaut du système, c'est-à-dire la langue et le pays/région sélectionnés lors de l'installation.
/rec caractères
Indique le nombre maximal de caractères dans un enregistrement ou une ligne du fichier d'entrée (la valeur par défaut est 4 096 et la valeur maximale, 65 535).
[Lecteur1:][Chemin1]NomFichier1
Désigne le fichier à trier. Si aucun nom de fichier n'est spécifié, c'est l'entrée standard qui est triée. La désignation du fichier d'entrée est plus rapide que sa redirection en entrée standard.
/t [Lecteur2:][Chemin2]
Indique le chemin du répertoire qui doit contenir le résultat de la commande sort si la mémoire principale est insuffisante. Par défaut, c'est le répertoire temporaire du système qui est utilisé.
/o [Lecteur3:][Chemin3]NomFichier3
Indique le fichier devant contenir l'entrée triée. Si aucun fichier n'est spécifié, les données sont écrites vers la sortie standard. La désignation du fichier de sortie est plus rapide que la redirection de la sortie standard vers le même fichier.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de l'option de ligne de commandes /+n

    L'utilisation de l'option de ligne de commandes /+n par exemple /+3 indique que chaque comparaison doit commencer au troisième caractère de chaque ligne. Les lignes de moins de n caractères sont assemblées avant les autres lignes. Par défaut, les comparaisons commencent au premier caractère de chaque ligne.

  • Utilisation de l'option de ligne de commandes /m kilo-octets

    La mémoire minimale utilisée est toujours de 160 Ko. Si la taille de la mémoire est spécifiée, le volume exact indiqué (mais 160 Ko au minimum) est utilisé pour le tri, quel que soit le volume de mémoire principale disponible.

    Lorsqu'aucune taille n'est spécifiée, la taille maximale par défaut correspond à 90% de la mémoire principale disponible si l'entrée et la sortie sont des fichiers et à 45% dans les autres cas. Le paramètre par défaut offre généralement les meilleures performances.

  • Utilisation de l'option de ligne de commandes /l locale

    Actuellement, la seule alternative aux paramètres régionaux par défaut est le paramètre régional « C », qui permet un tri plus rapide que le tri au moyen d'un langage naturel et trie les caractères en fonction de leurs codes binaires.

  • Spécification d'une source

    Excepté si vous indiquez le paramètre Commande ou NomFichier, la commande sort agit comme un filtre et reçoit ses données du dispositif d'entrée standard (généralement du clavier, d'un signe | ou d'un fichier).

  • Utilisation des symboles de redirection avec la commande sort

    Vous pouvez utiliser la barre verticale (|) pour diriger les données vers la commande sort à partir d'une autre commande ou pour diriger le résultat du tri vers une autre commande (par exemple, vers la commande more pour afficher des informations écran par écran). L'utilisation du signe inférieur à (<) ou supérieur à (>) pour spécifier le fichier d'entrée ou de sortie peut ne pas être efficace. Spécifiez plutôt directement le fichier d'entrée (comme défini dans la syntaxe de la commande) et désignez le fichier de sortie avec le paramètre /o. Cette méthode peut s'avérer beaucoup plus rapide, en particulier avec les fichiers volumineux.

  • Majuscules/minuscules

    La commande sort ne différencie pas les majuscules et les minuscules.

  • Taille limite des fichiers

    Il n'existe pas de taille limite pour les fichiers traités par la commande sort.

  • Séquence d'assemblage

    Le programme de tri utilise la table de séquences d'assemblage qui correspond aux paramètres de la page de codes et du code pays/région. Les caractères supérieurs au code ASCII 127 sont triés sur la base des informations stockées dans le fichier Country.sys ou dans un autre fichier désigné par la commande country dans votre fichier Config.nt.

  • Utilisation de la mémoire

    Si la mémoire peut contenir le résultat du tri, qu'il s'agisse de la mémoire maximale ou de la mémoire spécifiée par le paramètre /m, le tri est effectué en une seule opération. Si cela n'est pas le cas, le tri est effectué en deux passes, et de façon telle que le volume de mémoire utilisé pour l'opération de tri et celui utilisé pour l'opération de fusion sont égaux. Quand deux passes sont effectuées, les données triées partiellement sont stockées dans un fichier temporaire sur le disque. Si la mémoire est insuffisante pour exécuter le tri en deux passes, une erreur d'exécution se produit. Si l'option de ligne de commandes /m est utilisée pour spécifier un volume de mémoire supérieur à celui réellement disponible, les performances risquent de se dégrader ou il se peut qu'une erreur d'exécution survienne.

Exemples

Tri d'un fichier

La commande ci-dessous lit le fichier Dépenses.txt, trie les données selon l'ordre inverse et affiche le résultat à l'écran :

sort /r depenses.txt

Tri du résultat d'une commande

Pour rechercher le texte « Jean » dans un fichier volumineux nommé Maillist.txt et trier les résultats de la recherche, utilisez le symbole (|) pour diriger le résultat de la commande find vers la commande sort, comme ci-dessous :

find "Jean" maillist.txt | sort

La commande produit une liste triée des lignes qui contiennent le texte recherché.

Tri des entrées clavier

Pour trier les entrées clavier et afficher le résultat par ordre alphabétique à l'écran, vous pouvez d'abord utiliser la commande sort sans paramètres, comme suit :

sort

Tapez ensuite le texte à trier, en appuyant sur ENTRÉE à la fin de chaque ligne. Une fois le texte tapé, appuyez sur CTRL+Z, puis sur ENTRÉE. La commande sort affiche alors le texte que vous venez de taper, trié par ordre alphabétique.

Vous pouvez aussi rediriger vers un fichier les entrées clavier triées. Pour plus d'informations, cliquez sur redirect dans Rubriques connexes.


Stacks

Prend en charge l'utilisation dynamique de piles de données pour traiter les interruptions liées au matériel. Pour utiliser cette variable d'environnement, placez-la dans votre fichier Config.nt.

Syntaxe

stacks=n,s

Paramètres

n
Indique le nombre de piles. Les valeurs valides pour n sont 0 et les nombres de 8 à 64.
s
Indique la taille en octets de chaque pile. Les valeurs valides pour s sont 0 et les nombres de 32 à 512.

Remarques

  • Paramètres par défaut

    Le tableau ci-dessous répertorie les paramètres par défaut de la commande stacks.

    Ordinateur | Stacks
    IBM PC, IBM PC/XT, IBM PC portable | 0,0
    Autre | 9,128
  • Cas particuliers d'allocation de piles

    Lorsqu'il reçoit une interruption matérielle, Windows XP alloue une seule des piles spécifiées. Lorsque vous affectez la valeur 0 à n et s, Windows XP n'alloue pas de piles. Si les valeurs affectées sont égales à 0, chaque programme en cours d'exécution doit disposer de suffisamment d'espace de pile pour les pilotes d'interruption matérielle de l'ordinateur. De nombreux ordinateurs fonctionnent correctement et économise de la mémoire pour les programmes en affectant la valeur 0 à n et s. Toutefois, si votre ordinateur montre des signes d'instabilité avec cette valeur, revenez aux valeurs par défaut.

Exemples

Pour allouer 8 piles de 512 octets chacune pour le traitement des interruptions liées au matériel, ajoutez la commande ci-dessous au fichier Config.nt :

stacks=8,512


Start

Ouvre une fenêtre d'invite de commandes distincte pour exécuter une commande ou un programme déterminé. Utilisée sans paramètres, la commande start ouvre une seconde fenêtre d'invite de commandes.

Syntaxe

start ["titre"] [/d Chemin] [/i] [/min] [/max] [{/separate | /shared}] [{/low | /normal | /high | /realtime | /abovenormal | belownormal}] [/wait] [/b] [NomFichier] [paramètres]

Paramètres

"titre"
Spécifie le titre à afficher dans la barre de titre de la fenêtre d'invite de commandes.
/d Chemin
Spécifie le répertoire de démarrage.
/i
Passe l'environnement de démarrage Cmd.exe à la nouvelle fenêtre d'invite de commandes.
/min
Démarre une nouvelle fenêtre d'invite de commandes réduite à une icône.
/max
Démarre une nouvelle fenêtre d'invite de commandes en plein écran.
/separate
Démarre les applications 16 bits dans un espace mémoire distinct.
/shared
Démarre les applications 16 bits dans un espace mémoire partagé.
/low
Démarre une application dans la classe de priorité inactive.
/normal
Démarre une application dans la classe de priorité normale.
/high
Démarre une application dans la classe de priorité haute.
/realtime
Démarre une application dans la classe de priorité temps réel.
/abovenormal
Démarre une application dans la classe de priorité supérieure à la normale.
/belownormal
Démarre une application dans la classe de priorité inférieure à la normale.
/wait
Démarre une application et attend qu'elle se termine.
/b
Démarre une application sans ouvrir une nouvelle fenêtre d'invite de commandes. L'effet de la combinaison de touches CTRL+C est ignoré si l'application n'active pas le traitement de CTRL+C. Pour interrompre l'application, utilisez CTRL+ATTN.
NomFichier
Désigne la commande ou le programme à démarrer.
Paramètres
Spécifie les paramètres à passer à la commande ou au programme.

Remarques

  • Les fichiers non exécutables peuvent être appelés par l'intermédiaire de leur association de fichier en tapant le nom du fichier comme commande. Pour plus d'informations sur la création de ces associations dans un script de commandes en utilisant les commandes assoc et ftype, consultez Rubriques connexes.
  • Lorsque vous exécutez une commande dont le premier mot clé est la chaîne « CMD » dépourvue d'extension ou de qualificateur de chemin d'accès, « CMD » est remplacée par la valeur de la variable COMSPEC. Cela évite aux utilisateurs de devoir choisir cmd dans le répertoire en cours.
  • Lorsque vous exécutez une application 32 bits a interface graphique, la commande cmd n'attend pas que l'application se ferme pour afficher de nouveau l'invite de commandes. Ceci ne se produit pas si vous exécutez l'application à partir d'un script de commandes.
  • Lorsque vous exécutez une commande dont le premier mot clé ne contient pas d'extension, Cmd.exe utilise la valeur de la variable d'environnement PATHEXT pour déterminer quelles extensions rechercher et dans quel ordre. La valeur par défaut de la variable PATHEXT est : .COM;.EXE;.BAT;.CMD. La syntaxe est identique à celle de la variable PATH et les différents éléments sont séparés par des points-virgules.
  • Lorsque vous recherchez un exécutable et qu'aucune extension ne correspond à votre recherche, la commande start lance la recherche sur les noms des répertoires. Si tel est le cas, start ouvre l'Explorateur dans le répertoire trouvé.

Exemples

Pour démarrer le programme MonApp à l'invite de commandes et continuer à utiliser la fenêtre d'invite de commandes actuellement ouverte, tapez :

start monapp


Subst

Associe un chemin d'accès à une lettre de lecteur. Utilisée sans paramètres, la commande subst affiche les noms des lecteurs virtuels en vigueur.

Syntaxe

subst [lecteur1: [lecteur2:]Chemin]

subst lecteur1: /d

Paramètres

lecteur1:
Désigne le lecteur virtuel auquel vous voulez affecter un chemin d'accès.
lecteur2:
Désigne le lecteur physique qui contient le chemin d'accès spécifié (s'il est différent du lecteur actif).
Chemin
Spécifie le chemin d'accès que vous souhaitez affecter à un lecteur virtuel.
/d
Supprime un lecteur virtuel.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les commandes ci-dessous ne fonctionnent pas ou ne doivent pas être lancées sur les lecteurs indiqués dans la commande subst :
    • chkdsk
    • diskcomp
    • diskcopy
    • format
    • label
    • recover
  • Le paramètre lecteur1 doit être compris dans la plage définie par la commande lastdrive. Sinon, la commande subst affiche le message d'erreur suivant :

    Paramètre non valide - lecteur1:

Exemples

Pour créer un lecteur virtuel Z pour le chemin d'accès B:\Utilisateur\Marie\Formulaires, tapez :

subst z: b:\utilisateur\marie\formulaires

Au lieu de taper le chemin complet, vous pouvez désormais atteindre ce répertoire en tapant simplement la lettre du lecteur virtuel suivie d'un signe deux-points (:), comme dans l'exemple suivant :

z:


Switches

Force l'utilisation d'un clavier étendu en tant que clavier standard.

Syntaxe

switches=/k

Paramètres

Aucun

Remarques

  • Utilisez cette commande dans le fichier Config.nt.
  • Si un programme n'interprète pas correctement les données entrées à partir d'un clavier étendu, ajoutez cette commande au fichier Config.nt afin que votre clavier étendu utilise les fonctions d'un clavier standard.
  • Si vous utilisez la commande switches=/k et que vous installez le pilote de périphérique Ansi.sys, ajoutez l'option de ligne de commandes /k sur la ligne de commandes device de Ansi.sys.

Exemples

Si vous voulez utiliser les fonctions d'un clavier standard alors que vous vous servez d'un clavier étendu, ajoutez la commande ci-dessous au fichier Config.nt :

switches=/k


Vérificateur des fichiers système (sfc)

Ce composant permet de numériser et de vérifier les versions de tous les fichiers système protégés après le redémarrage des ordinateurs.

Syntaxe

sfc [/scannow] [/scanonce] [/scanboot] [/revert] [/purgecache] [/cachesize=x]

Paramètres

/scannow
Numérise immédiatement tous les fichiers système protégés.
/scanonce
Numérise une seule fois tous les fichiers système protégés.
/scanboot
Numérise tous les fichiers système protégés à chaque redémarrage de l'ordinateur.
/revert
Annule le résultat de l'opération de numérisation.
/purgecache
Purge le cache du fichier Protection de fichiers Windows et numérise immédiatement tous les fichiers système protégés.
/cachesize=x
Définit la taille, en Mo, du cache du fichier Protection de fichiers Windows.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour exécuter la commande sfc, vous devez avoir ouvert une session en tant que membre du groupe Administrateurs.
  • Si le Vérificateur des fichiers système détecte qu'un fichier protégé a été remplacé, il récupère la version correcte du fichier dans le dossier %systemroot%\system32\dllcache, puis remplace le fichier incorrect.
  • Si le dossier %systemroot%\system32\dllcache est corrompu ou inutilisable, utilisez la commande sfc /scannow, sfc /scanonce ou sfc /scanboot pour réparer le contenu du répertoire Dllcache.


Systeminfo

Permet d'afficher des informations détaillées sur la configuration d'un ordinateur et sur son système d'exploitation et notamment, des informations sur la configuration du système d'exploitation, la sécurité, l'ID produit et les propriétés matérielles telles que la RAM, l'espace disque et les cartes réseau.

Syntaxe

systeminfo[.exe] [/s Ordinateur [/u Domaine\Utilisateur [/p MotDePasse]]] [/fo {TABLE|LIST|CSV}] [/nh]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par le paramètre Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur à partir duquel est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/fo {TABLE|LIST|CSV}
Spécifie le format à utiliser pour le résultat obtenu en sortie. Les valeurs valides sont TABLE, LIST et CSV. Le format de sortie par défaut est LIST.
/nh
Supprime les en-têtes des colonnes dans la sortie. Valide lorsque le paramètre /fo prend la valeur TABLE ou CSV.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande systeminfo :

systeminfo.exe /s srvmain
systeminfo.exe /s srvmain /u maindom\hiropln
systeminfo /s srvmain /u maindom\hiropln /p p@ssW23 /fo table


Taskkill

Supprime un ou plusieurs processus ou tâches. Les processus peuvent être supprimés au moyen de l'ID ou du nom de l'image.

Syntaxe

taskkill [/s Ordinateur] [/u Domaine\Utilisateur [/p MotDePasse]]] [/fi NomFiltre] [/pid IDProcessus]|[/im NomImage] [/f]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par le paramètre Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur à partir duquel est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/fi NomFiltre
Spécifie les types des processus à inclure ou à exclure de l'opération d'arrêt. Le tableau suivant présente les noms, les opérateurs et les valeurs de filtre valides :
Nom | Opérateurs | Valeur
Nom de l'hôte | eq, ne | Toute chaîne valide.
État | eq, ne | RUNNING|NOT RESPONDING
Nom d'image | eq, ne | Toute chaîne valide.
ID du processus | eg, ne, gt, lt, ge, le | Tout entier positif valide.
Session | eg, ne, gt, lt, ge, le | Tout numéro de session valide.
Heure CPU | eq, ne, gt, lt, ge, le | Heure valide au format hh:mm:ss. Les paramètres mm et ss doivent être compris entre 0 et 59, tandis que le paramètre hh peut correspondre à n'importe quelle valeur numérique valide non signée.
Utilisation de la mémoire | eg, ne, gt, lt, ge, le | Tout entier valide.
Utilisateur | eq, ne | Tout nom d'utilisateur valide ([Domaine\]Utilisateur).
Services | eq, ne | Toute chaîne valide.
Titre de la fenêtre | eq, ne | Toute chaîne valide.
/pid IDProcessus
Spécifie l'ID du processus à arrêter.
/im NomImage
Spécifie le nom d'image du processus à arrêter. Utilisez le caractère générique (*) pour spécifier tous les noms d'image.
/f
Indique que l'arrêt des processus doit être forcé. Ce paramètre est ignoré pour les processus distants ; l'arrêt des processus distants est toujours forcé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Le caractère générique (*) est accepté uniquement s'il est spécifié avec les filtres.
  • L'arrêt des processus distants est toujours forcé, que le paramètre /f soit spécifié ou non.
  • L'indication d'un nom d'ordinateur pour le filtre HOSTNAME, entraîne la fermeture de l'ordinateur et l'arrêt de tous les processus.
  • Utilisez la commande tasklist pour trouver l'ID du processus à arrêter.
  • La commande Taskkill remplace l'outil Kill.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande taskkill :

taskkill /pid 1230 /pid 1241 /pid 1253
taskkill /f /fi "USERNAME eq NT AUTHORITY\SYSTEM" /im notepad.exe
taskkill /s srvmain /f /im notepad.exe
taskkill /s srvmain /u maindom\hiropln /p p@ssW23 /fi "IMAGENAME eq note*" /im *
taskkill /s srvmain /u maindom\hiropln /fi "USERNAME ne NT*" /im *
taskkill /f /fi "PID ge 1000" /im *


Tasklist

Affiche la liste des applications, des services et l'ID du processus (PID) en cours d'exécution sur un ordinateur local ou distant.

Syntaxe

tasklist[.exe] [/s Ordinateur] [/u Domaine\Utilisateur [/p MotDePasse]]] [/fo {TABLE|LIST|CSV}] [/nh] [/fi NomFiltre [/fi Nom2Filtre [ ... ]]] [/svc] [/v]

Paramètres

/s Ordinateur
Spécifie le nom ou l'adresse IP d'un ordinateur distant (n'utilisez pas de barres obliques inverses). Il s'agit par défaut de l'ordinateur local.
/u Domaine\Utilisateur
Exécute la commande avec les autorisations de compte de l'utilisateur spécifié par le paramètre Utilisateur ou Domaine\Utilisateur. Il s'agit par défaut des autorisations de l'utilisateur actuellement connecté sur l'ordinateur à partir duquel est émise la commande.
/p MotDePasse
Spécifie le mot de passe du compte d'utilisateur spécifié par le paramètre /u.
/fo {TABLE|LIST|CSV}
Spécifie le format à utiliser pour le résultat obtenu en sortie. Les valeurs valides sont TABLE, LIST et CSV. Le format de sortie par défaut est TABLE.
/nh
Supprime les en-têtes des colonnes dans la sortie. Valide lorsque le paramètre /fo prend la valeur TABLE ou CSV.
/fi NomFiltre
Spécifie les types des processus à inclure ou à exclure de la requête. Le tableau suivant présente les noms, opérateurs et valeurs de filtre valides :
Nom | Opérateurs | Valeur
État | eq, ne | RUNNING|NOT RESPONDING
Nom d'image | eq, ne | Toute chaîne valide.
PID | eq, ne, gt, lt, ge, le | Tout entier positif valide.
Session | eq, ne, gt, lt, ge, le | Tout numéro de session valide.
Nom de la session | eq, ne | Toute chaîne valide.
Heure CPU | eq, ne, gt, lt, ge, le | Heure valide au format hh:mm:ss. Les paramètres mm et ss doivent être compris entre 0 et 59, tandis que le paramètre hh peut correspondre à n'importe quelle valeur numérique valide non signée.
Utilisation de la mémoire | eq, ne, gt, lt, ge, le | Tout entier valide.
Utilisateur | eq, ne | Tout nom d'utilisateur valide ([Domaine\]Utilisateur).
Services | eq, ne | Toute chaîne valide.
Titre de la fenêtre | eq, ne | Toute chaîne valide.
/svc
Énumère toutes les informations de service pour chaque processus sans troncation. Valide lorsque le paramètre /fo prend la valeur TABLE.
/v
Spécifie l'affichage des commentaires sur les tâches dans la sortie. Afin de pouvoir visualiser ces commentaires sans qu'ils soient tronqués, utilisez ce paramètre avec le paramètre /svc.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • La commande Tasklist remplace l'outil TList.

Exemples

Les exemples suivants illustrent la façon d'utiliser la commande tasklist :

tasklist /v /fi "PID gt 1000" /fo csv
tasklist /fi "USERNAME ne NT AUTHORITY\SYSTEM" /fi "STATUS eq running"
tasklist /v /fi "STATUS eq running"
tasklist /s srvmain /nh
tasklist /s srvmain /s srvny
tasklist /s srvmain /u maindom\hiropln /p p@ssW23 /nh


Tcmsetup

Installe ou désactive un client TAPI

Syntaxe

tcmsetup [/q] [/x] /c Serveur1 [Serveur2...]

tcmsetup [/q] /c /d

Paramètres

/q
Empêche l'affichage des messages.
/x
Spécifie que les rappels orientés connexion doivent être utilisés pour les réseaux sur lesquels le trafic est dense et où de nombreux paquets sont perdus. Lorsque ce paramètre est omis, ce sont les rappels sans connexion qui sont utilisés.
/c
Obligatoire. Spécifie l'installation d'un client.
Serveur1
Obligatoire. Spécifie le nom du serveur distant équipé des fournisseurs de service TAPI que le client doit utiliser. Le client utilise les lignes et les téléphones du fournisseur de services. Le client doit se trouver dans le même domaine que le serveur ou dans un domaine qui entretient une relation d'approbation mutuelle avec le domaine contenant le serveur.
Serveur2
Spécifie un ou plusieurs serveurs supplémentaires disponibles pour ce client. Si vous spécifiez plusieurs serveurs, séparez leurs noms d'un espace.
/d
Efface la liste des serveurs distants. Désactive le client TAPI en l'empêchant d'utiliser les fournisseurs de services TAPI qui se trouvent sur les serveurs distants.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour que le service TAPI fonctionne correctement, vous devez exécuter la commande tcmsetup pour spécifier les serveurs distants qui doivent être utilisés par les clients TAPI.
  • Pour exécuter cette commande, vous devez appartenir au groupe Administrateurs. Si vous avez ouvert une session à partir d'un autre groupe, consultez Utiliser la commande runas pour démarrer un programme en tant qu'administrateur.
  • Avant qu'un utilisateur client puisse utiliser un téléphone ou une ligne sur un serveur TAPI, l'administrateur du serveur de téléphonie doit affecter le téléphone ou la ligne à l'utilisateur.
  • La liste des serveurs de téléphonie créée par cette commande remplace toute liste de serveurs de téléphonie existante accessible au client. Vous ne pouvez pas recourir à cette commande pour ajouter un élément à une liste existante.


Utilitaires et services TCP/IP

Les utilitaires TCP/IP permettent aux ordinateurs non équipés de l'environnement Microsoft, par exemple, aux stations UNIX, de se connecter à un réseau. Le protocole réseau TCP/IP doit être installé pour pouvoir utiliser les utilitaires TCP/IP. Pour plus d'informations sur le lancement des services TCP/IP à partir d'une invite de commandes, consultez Net start. Pour plus d'informations sur l'arrêt des services TCP/IP à partir d'une invite de commandes, consultez Net stop.

Pour plus d'informations sur un utilitaire ou un service, sélectionnez-le ci-dessous :

  • Arp
  • Nslookup
  • Finger
  • Ping
  • Ftp
  • Rcp
  • Hostname
  • Rexec
  • Ipconfig
  • Route
  • Lpq
  • Rsh
  • Lpr
  • Tftp
  • Nbtstat
  • Tracert
  • Netstat


Commandes Telnet

Les commandes telnet permettent de communiquer avec un ordinateur distant qui utilise le protocole Telnet. Exécutées sans paramètres, les commandes telnet permettent d'entrer dans le contexte telnet, indiqué par l'invite Telnet (telnet>). À partir de l'invite Telnet, utilisez les commandes suivantes pour gérer un ordinateur qui exécute le client Telnet.

Les commandes tlntadmn permettent de gérer à distance un ordinateur qui exécute Telnet Server. Ces commandes doivent être exécutées à partir d'une invite de commandes. Utilisée sans paramètres, la commande tlntadmn permet d'afficher les paramètres du serveur local.

Pour utiliser les commandes telnet à partir de l'invite Telnet

Pour lancer un client Telnet et accéder à une invite Telnet

Syntaxe

telnet [\\ServeurDistant]

Paramètres

\\ServeurDistant
Spécifie le nom du serveur auquel vous souhaitez vous connecter.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisée sans paramètres, la commande telnet permet de lancer le client Telnet.
  • Une fois l'invite Telnet activée, vous devez utiliser des commandes Telnet.

Pour arrêter le client Telnet

Syntaxe

quit

Paramètres

Aucun

Remarques

  • Cette commande peut être abrégée par q.

Pour connecter le client Telnet à un ordinateur distant

Syntaxe

open [\\ServeurDistant] [Port]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
Port
Spécifie le port que vous souhaitez utiliser. Si vous n'indiquez pas de port, l'opération est effectuée sur le port par défaut.

Remarques

  • Cette commande peut être abrégée par o.

Exemples

Pour vous connecter au serveur distant Redmond via le port numéro 44, tapez :
o redmond 44

Pour déconnecter le client Telnet d'un ordinateur distant

Syntaxe

close [\\ServeurDistant]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.

Remarques

  • Cette commande peut être abrégée par c.

Exemples

Pour vous déconnecter du serveur distant Redmond, tapez :
c redmond 44

Pour définir les options du client Telnet

Syntaxe

set [\\ServeurDistant] [ntlm] [localecho] [term {ansi | vt100 | vt52 | vtnt}] [escape Caractère] [logfile NomFichier] [logging] [bsasdel] [crlf] [delasbs] [mode {console | stream}] [?]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
ntlm
Permet d'activer l'authentification NTLM si elle est disponible sur le serveur distant.
localecho
Permet d'activer l'écho local.
term {ansi | vt100 | vt52 | vtnt}
Attribue le type spécifié au terminal.
escape Caractère
Définit le caractère d'échappement. Il peut s'agir d'un caractère unique ou d'une combinaison formée de la touche CTRL et d'un caractère. Pour définir une combinaison de touches, maintenez la touche CTRL enfoncée et tapez le caractère que vous voulez affecter.
logfile NomFichier
Définit le fichier à utiliser pour la journalisation des activités liées à Telnet. Le fichier journal doit être situé sur l'ordinateur local. La journalisation commence automatiquement à l'activation de cette option.
logging
Active la fonction de consignation dans un journal. Si aucun fichier journal n'est défini, un message d'erreur apparaît.
bsasdel
Affecte à la touche de retour arrière la fonction de suppression.
crlf
Définit le nouveau mode de ligne pour que la frappe de la touche ENTRÉE envoie les valeurs 0x0D, 0x0A.
delasbs
Affecte à la touche SUPPR. la fonction de retour arrière.
mode {console | stream}
Spécifie le mode d'opération.
?
Permet d'afficher la syntaxe complète de cette commande.

Remarques

  • Pour désactiver une option précédemment définie, à l'invite Telnet, tapez :

    unset [Option]

  • Pour définir le caractère d'échappement, tapez :

    –e Caractère

  • Dans les versions non anglaises de Telnet, le paramètre Option de la commande codeset est disponible. Ce paramètre permet d'affecter un jeu de codes courants à une option. Il peut s'agir des jeux de codes suivants : Shift JIS, Japanese EUC, JIS Kanji, JIS Kanji (78), DEC Kanji, NEC Kanji. Vous devez définir le même jeu de codes sur l'ordinateur distant.

Pour envoyer des commandes du client Telnet

Syntaxe

send [\\ServeurDistant] [ao] [ayt] [esc] [ip] [synch] [?]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
ao
Abandonne la commande en sortie.
ayt
Envoie une commande d'identification.
esc
Envoie le caractère d'échappement courant.
ip
Interrompt la commande de traitement.
synch
Lance l'opération de synchronisation Telnet.
?
Permet d'afficher la syntaxe complète de cette commande.

Pour visualiser les paramètres courants du client Telnet

Syntaxe

display

Paramètres

Aucun

Remarques

  • La commande display permet de répertorier les paramètres actuellement définis pour le client Telnet. Si vous avez ouvert une session Telnet (en d'autres termes, si vous êtes connecté à un serveur Telnet), vous pouvez quitter cette session pour modifier les paramètres en appuyant sur CTRL+]. Pour retourner dans la session Telnet, appuyez sur ENTRÉE.

Pour utiliser les commandes tlntadmn à partir de l'invite de commandes

Pour administrer un ordinateur qui exécute Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] [start] [stop] [pause] [continue]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
start
Démarre Telnet Server.
stop
Arrête Telnet Server.
pause
Interrompt Telnet Server.
continue
Reprend l'exécution de Telnet Server.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Pour administrer des sessions Telnet

Syntaxe

tlntadmn [\\ServeurDistant] [-s] [-k{IDSession | all}] [-m {IDSession | all} "Message"]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
-s
Affiche les sessions Telnet actives.
-k{IDSession | all}
Met fin aux sessions. Tapez l'ID de la session à laquelle mettre fin ou tapez all pour mettre fin à toutes les sessions.
-m {IDSession | all} "Message"
Envoie un message à une ou plusieurs sessions. Tapez l'ID de la session à laquelle envoyer un message ou tapez all pour envoyer un message à toutes les sessions. Tapez le message à envoyer et encadrez-le de guillemets (exemple : "Message").
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Pour définir les options d'ouverture de session sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [auditlocation={eventlog | file | both}][audit=[{+ | -}admin][{+ | -}user][{+ | -}fail]]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
auditlocation={eventlog | file | both}
Spécifie si les informations relatives aux événements doivent être transmises à l'Observateur d'événements, à un fichier ou aux deux.
audit=[{+ | -}admin][{+ | -}user][{+ | -}fail]
Spécifie les événements à auditer (les événements liés à la connexion des administrateurs, des utilisateurs ou liés aux échecs de connexion). Pour auditer un événement d'un type particulier, tapez un signe plus (+) avant le type d'événement. Pour arrêter l'audit d'un événement d'un type particulier, tapez un signe moins (-) avant le type d'événement.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.
  • Si vous indiquez où transmettre les informations liées aux événements sans spécifier le ou les types d'informations à auditer, seules les informations relatives aux événements de connexion des administrateurs sont auditées et transmises à l'emplacement spécifié.

Exemples

Pour transmettre des informations sur les événements à l'Observateur d'événements, tapez :

tlntadmn config auditlocation=eventlog

Pour auditer les événements liés aux connexions des administrateurs et aux échecs de connexion, tapez :

tlntadmn config audit=+admin +fail

Pour définir le domaine par défaut sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [dom=DomainName]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
dom=NomDomaine
Spécifie le domaine à utiliser comme domaine par défaut.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Exemples

Pour que Redmond soit le domaine par défaut sur votre serveur local, tapez :

tlntadmn config dom=Redmond

Pour mapper la touche ALT sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [ctrlakeymap={yes | no}]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
ctrlakeymap={yes | no}
Spécifie si le serveur Telnet doit interpréter la combinaison de touches CTRL+A comme étant la touche ALT. Tapez oui pour mapper la touche de raccourci ou non pour qu'elle ne soit pas mappée.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.
  • Si vous ne mappez pas la touche ALT, le serveur Telnet ne l'envoie pas aux applications qui pourraient l'utiliser.

Pour définir le nombre maximal de connexions sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [maxconn=EntierPositif]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
maxconn=EntierPositif
Définit le nombre maximal de connexions. Vous devez spécifier ce nombre en utilisant un entier positif inférieur à 10 millions.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Pour définir le nombre maximal de tentatives de connexions échouées sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [maxfail=EntierPositif]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
maxfail=EntierPositif
Définit le nombre maximal d'échecs de connexion autorisé pour un utilisateur. Vous devez spécifier ce nombre en utilisant un entier positif inférieur à 100.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Pour définir le mode d'opération sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [mode={console | stream}]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
mode={console | stream}
Spécifie le mode d'opération.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Pour définir le port Telnet sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [port=ValeurEntier]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
port=ValeurEntier
Définit le port Telnet. Vous devez spécifier le port au moyen d'un nombre entier inférieur à 1024.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Pour définir les méthodes d'authentification sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [sec=[{+ | -}ntlm][{+ | -}passwd]]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
sec=[{+ | -}ntlm][{+ | -}passwd]
Spécifie si vous voulez utiliser NTLM, un mot de passe ou les deux pour authentifier les tentatives de connexion. Pour utiliser un type particulier d'authentification, tapez un signe plus (+) devant le type d'authentification. Pour empêcher l'utilisation d'un type particulier d'authentification, tapez un signe moins (-) devant le type d'authentification.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.
  • NTLM est le protocole d'authentification utilisé pour les transactions entre deux ordinateurs lorsque l'un des ordinateurs ou les deux exécutent la version 4.0 de Windows NT ou une version antérieure. Par ailleurs, NTLM est le protocole d'authentification utilisé par les ordinateurs qui ne font pas partie d'un domaine, tels que les serveurs autonomes et les groupes de travail.

Pour définir le délai de dépassement de la durée d'inactivité des sessions sur un ordinateur exécutant Telnet Server

Syntaxe

tlntadmn [\\ServeurDistant] config [timeout=hh:mm:ss]

Paramètres

\\ServeurDistant
Indique le nom du serveur que vous voulez gérer. Si vous n'indiquez pas de serveur, l'opération est effectuée sur le serveur local.
timeout=hh:mm:ss
Définit le délai de dépassement en heures, minutes et secondes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez administrer à distance un ordinateur sur lequel fonctionne Telnet Server à l'aide des commandes tlntadmn si les deux ordinateurs exécutent Windows XP. Vous ne pouvez pas utiliser les commandes tlntadmn pour administrer à distance un ordinateur sur lequel fonctionne Windows 2000 et Telnet Server à partir d'un ordinateur exécutant Windows XP.

Remarques

  • Pour passer du client Telnet au mode de commande, à l'invite Telnet, tapez CTRL+ ]. Pour repasser au client Telnet, appuyez sur ENTRÉE.


Tftp

Permet le transfert de fichiers depuis et vers un ordinateur distant, qui en général fonctionne sous UNIX et exécute le service ou le démon TFTP (Trivial File Transfer Protocol). Utilisée sans paramètres, la commande tftp permet d'afficher l'aide.

Syntaxe

tftp [-i] [Hôte] [{get | put}] [Source] [Destination]

Paramètres

-i
Spécifie le mode de transfert d'images binaires (aussi appelé mode octet). En mode image binaire, le fichier est transféré par unité de un octet. Ce mode sert à transférer les fichiers binaires. Si le paramètre -i est omis, le fichier est transmis en mode ASCII. Il s'agit du mode de transfert par défaut. Ce mode convertit les caractères EOL dans le format qui est approprié pour l'ordinateur spécifié. Ce mode sert à transférer les fichiers texte. Lorsque le transfert de fichier est correct, le taux de transfert est affiché.
Hôte
Spécifie l'ordinateur local ou distant.
put
Effectue le transfert entre la Destination (ordinateur local) et la Source (ordinateur distant). Le protocole TFTP ne gérant pas l'authentification des utilisateurs, l'utilisateur doit être connecté sur l'ordinateur distant et les fichiers accessibles en écriture sur l'ordinateur distant.
get
Effectue le transfert entre la Destination (ordinateur distant) et la Source (ordinateur local).
Source
Spécifie le fichier à transférer.
Destination
Spécifie l'emplacement où transférer le fichier. Si le paramètre Destination est omis, il est supposé posséder le même nom que le paramètre Source.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation du paramètre get

    Spécifiez put si vous transférez le fichier FichierDeux de l'ordinateur local vers le fichier FichierUn de l'ordinateur distant. Spécifiez get si vous transférez le fichier FichierDeux de l'ordinateur distant vers le fichier FichierUn de l'ordinateur distant.

  • Windows XP ou Windows 2000 ne fournissent pas un service de serveur TFTP pour une utilisation générale. Windows 2000 contient un service de serveur TFTP uniquement pour fournir les fonctionnalités d'amorçage aux ordinateurs clients Windows XP et Windows 2000.
  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est déclaré comme composant dans les propriétés d'une carte réseau dans les Connexions réseau.

Exemples

Pour transférer le fichier Utilisateurs.txt de l'ordinateur local dans le fichier Utilisateurs19.txt de l'ordinateur distant nommé vax1, tapez :

tftp vax1 put utilisateurs.txt utilisateurs19.txt


Time

Affiche ou définit l'heure système. Utilisée sans paramètres, la commande time permet d'afficher l'heure système et invite l'utilisateur à saisir une nouvelle heure.

Syntaxe

time [/t] [/time] [heures:[minutes[:secondes[.centièmes]]][{A|P}]]

Paramètres

/t
Affiche l'heure système courante, sans inviter l'utilisateur à saisir une nouvelle heure.
/time
Identique à /t.
heures
Spécifie l'heure. Les valeurs valides sont comprises entre 0 et 23.
minutes
Spécifie les minutes. Les valeurs valides sont comprises entre 0 et 59.
secondes
Spécifie les secondes. Les valeurs valides sont comprises entre 0 et 59.
centièmes
Spécifie les centièmes de seconde. Les valeurs valides sont comprises entre 0 et 99.
{A|P}
Représente les heures avant et après midi pour un format de 12 heures. Si vous tapez une heure valide exprimée dans la plage de 12 heures, sans taper A ou P, la commande time utilise A pour les heures précédant midi.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si vous utilisez la commande time sans paramètres, appuyez sur ENTRÉE pour conserver la même heure.
  • Utilisation du paramètre /t

    L'option de ligne de commandes /t peut être utilisée uniquement si les extensions de commandes sont activées (ce qui est le cas par défaut). Pour plus d'informations sur l'activation et la désactivation des extensions de commandes, cliquez sur cmd dans Rubriques connexes.

  • Utilisation d'un format incorrect pour l'heure

    Si vous spécifiez l'heure dans un format non valide, le message suivant s'affiche et le système s'interrompt le temps que vous indiquiez l'heure dans le format approprié.

    Heure incorrecte
    Entrez la nouvelle heure :_

  • Changement du format de l'heure

    Pour changer le format de l'heure, vous pouvez changer le paramètre Date/Heure dans le Panneau de configuration. Pour le sous-système MS-DOS, il suffit de changer le paramètre country dans le fichier Config.nt. Selon le code du pays ou de la région utilisé, l'heure est affichée au format 12 ou 24 heures. Si vous réglez l'heure sous le format 12 heures, veillez à spécifier P pour les heures de l'après-midi.

Exemples

Pour régler l'horloge de l'ordinateur à 13:36, utilisez l'une ou l'autre des commandes suivantes :

time 13:36

time 1:36P


W32tm

Outil permettant d'établir des diagnostics sur les problèmes liés au service Temps Windows

Syntaxe

{/config [/computer:NomOrdinateur] [ [/update] [/manualpeerlist:ListeNomsOrdinateurs] ] [/syncfromflags:ListeIndicateurs] ]|/monitor|/ntte|/ntpte|/register|/resync [{:NomOrdinateur] [/nowait]|[/rediscover}]|/tz|/unregister}

Paramètres

/config [/computer:NomOrdinateur] [ [/update] [/manualpeerlist:ListeNomsOrdinateurs] ] [/syncfromflags:ListeIndicateurs]
Règle les paramètres relatifs à l'heure sur l'ordinateur local ou sur l'ordinateur cible. Il est possible de définir des homologues de synchronisation de l'heure avec le commutateur /manualpeerlist. Les modifications apportées à la configuration ne sont pas prises en compte par le service Temps Windows excepté lorsque le service est redémarré ou lorsque le commutateur /update est utilisé. Le paramètre /syncfromflags peut être utilisé pour définir les types de sources utilisés pour la synchronisation. Il peut prendre la valeur MANUAL pour utiliser la liste d'homologues manuelle ou la valeur DOMHIER pour effectuer la synchronisation à partir d'un contrôleur de domaine.
/monitor
Surveille l'ordinateur ou les listes d'ordinateurs cibles.
/ntte
Convertit une heure système NT dans un format lisible.
/ntpte
Convertit une heure NTP dans un format lisible.
/register
Permet l'enregistrement en tant que service et l'ajout de la configuration par défaut dans le Registre.
/resync [{:NomOrdinateur] [/nowait]|[/rediscover}]
Resynchronise l'horloge dès que possible en vidant toutes les statistiques d'erreur accumulées. Si aucun nom d'ordinateur n'est spécifié, c'est l'ordinateur local qui est resynchronisé. La commande attend la fin de la resynchronisation, excepté si le commutateur /nowait est utilisé. Les ressources temps actuelles sont utilisées, excepté si le paramètre /rediscover est indiqué, ce qui force la nouvelle détection des ressources réseau préalablement à la resynchronisation.
/tz
Affiche les paramètres de fuseau horaire actuels.
/unregister
Annule l'enregistrement du service et supprime toutes les informations de configuration du Registre.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cet outil est destiné aux administrateurs réseau qui doivent diagnostiquer les problèmes liés au temps Windows.

    Pour plus d'informations, consultez net time dans Rubriques connexes.

  • Pour que le service Temps Windows puisse utiliser les modifications apportées avec l'outil W32tm, ces modifications doivent lui être notifiées. Pour notifier le service Temps Windows, à l'invite de commandes, tapez w32tm /config /update.

Exemples

Pour afficher les paramètres de fuseau horaire actuels, tapez :

w32tm /tz


Title

Crée le titre de la fenêtre d'invite de commandes.

Syntaxe

title [chaîne]

Paramètres

chaîne
Spécifie le titre de la fenêtre d'invite de commandes.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Pour utiliser le titre de la fenêtre pour les programmes de commandes, ajoutez la commande title au début du programme de commandes.
  • Une fois défini, le titre de la fenêtre ne peut être modifié qu'au moyen de la commande title.

Exemples

Pour définir le titre de la fenêtre d'un programme de commandes, tapez :

rem Ce programme de commandes met à jour les données des employés :

cls

@echo off

title Mise à jour des fichiers

copy \\server\share\*.xls c:\users\common\*.xls

echo Fichiers mis à jours

title Invite de commandes


Tracert

Détermine l'itinéraire menant vers une destination par la transmission de messages ICMP (messages Requête d'écho Internet Control Message Protocol) en augmentant de façon incrémentielle les valeurs des champs TTL (Time to Live, Durée de vie). L'itinéraire affiché correspond à la série d'interfaces de routeurs les plus proches des routeurs sur l'itinéraire situé entre un hôte source et une destination. L'interface la plus proche est celle du routeur qui est la plus proche de l'hôte émetteur sur l'itinéraire. Utilisée sans paramètres, la commande tracert permet d'afficher l'aide.

Syntaxe

tracert [-d] [-h TronçonsMaximaux] [-j ListeHôtes] [-w Temporisation] [NomCible]

Paramètres

-d
Empêche la commande tracert de convertir en noms les adresses IP des routeurs intermédiaires. Ceci a pour but d'accélérer l'affichage des résultats de la commande tracert.
-h TronçonsMaximaux
Spécifie le nombre maximal de tronçons de l'itinéraire pour rechercher la cible (destination). La valeur par défaut est 30 tronçons.
-j ListeHôtes
Spécifie que les messages Requête d'écho utilisent l'option Itinéraire source libre de l'en-tête IP avec l'ensemble des destinations intermédiaires spécifiées dans le paramètre ListeHôtes. Avec le routage de source souple, les destinations intermédiaires successives peuvent être séparées par un ou plusieurs routeurs. Le nombre maximal d'adresses ou de noms de la liste d'hôtes est 9. Le paramètre ListeHôtes correspond à une série d'adresses IP (en notation décimale à point) séparées par des espaces.
-w Temporisation
Spécifie la durée exprimée en milisecondes pendant laquelle il est nécessaire d'attendre un message de temps ICMP dépassé ou un message Réponse d'écho en réponse à un message Requête d'écho donné, en attente de réception. Si aucun message n'est reçu durant ce délai, un astérisque (*) est affiché. La valeur par défaut de ce paramètre est 4 000 (4 secondes).
NomCible
Spécifie la destination, identifiée par une adresse IP ou par un nom d'hôte.
-?
Affiche l'aide à l'invite de commandes.

Remarques

  • Cet outil de diagnostic détermine l'itinéraire emprunté vers une destination par l'envoi, vers la destination, de messages Requête d'écho ICMP (Internet Control Message Protocol) avec des valeurs TTL variables. Chaque routeur situé sur l'itinéraire décrémente d'au moins 1 la valeur TTL dans un paquet IP avant de le retransmettre. En fait, les valeurs TTL permettent de compter les liens maximums. Lorsque la valeur TTL d'un paquet atteint 0, le routeur est supposé renvoyer un message ICMP de temps dépassé à l'ordinateur source. Tracert détermine l'itinéraire en envoyant le premier message Requête d'écho dont la valeur TTL est 1 et en l'augmentant de 1 à chaque transmission ultérieure jusqu'à ce que la cible réponde ou que le nombre maximal de tronçons soit atteint. Par défaut, le nombre maximal de tronçons est 30. Il peut être spécifié au moyen du paramètre -h. L'itinéraire est déterminé par l'analyse des messages de temps ICMP dépassé renvoyés par les routeurs intermédiaires et du message Réponse d'écho renvoyé par la destination. Toutefois, certains routeurs ne renvoient pas de messages de temps dépassé pour les paquets dont les valeurs TTL ont expiré et sont invisibles pour la commande tracert. Dans ce cas, une ligne d'astérisques (*) s'affiche pour le tronçon concerné.
  • Pour tracer un itinéraire et permettre la latence réseau et la perte de paquets pour chaque routeur et chaque lien de l'itinéraire, utilisez la commande pathping.
  • Cette commande est disponible uniquement si le protocole TCP/IP (Internet Protocol) est déclaré comme composant dans les propriétés d'une carte réseau dans les Connexions réseau.

Exemples

Pour tracer l'itinéraire vers l'hôte nommé corp7.microsoft.com, tapez :

tracert corp7.microsoft.com

Pour tracer l'itinéraire vers l'hôte nommé corp7.microsoft.com et empêcher la conversion de chaque adresse IP en nom, tapez :

tracert -d corp7.microsoft.com

Pour tracer l'itinéraire vers l'hôte nommé corp7.microsoft.com et utiliser le routage de source libre 10.12.0.1-10.29.3.1-10.1.44.1, tapez :

tracert -j 10.12.0.1 10.29.3.1 10.1.44.1 corp7.microsoft.com


Tree

Affiche graphiquement l'arborescence des répertoires d'un chemin d'accès ou du disque placé dans un lecteur.

Syntaxe

tree [Lecteur:][Chemin] [/f] [/a]

Paramètres

Lecteur:
Spécifie le lecteur qui contient le disque dont vous voulez afficher l'arborescence des répertoires.
Chemin
Spécifie le répertoire dont vous voulez afficher l'arborescence.
/f
Affiche les noms des fichiers contenus dans chaque répertoire.
/a
Spécifie que tree doit utiliser des caractères texte et non graphique pour représenter les lignes de liaison entre les sous-répertoires.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • L'arborescence affichée par la commande tree dépend des paramètres spécifiés sur la ligne de commandes. Si vous ne désignez ni lecteur ni chemin, la commande tree affiche l'arborescence du répertoire en cours du lecteur actif.

Exemples

Pour afficher les noms de tous les sous-répertoires du disque placé dans le lecteur actif, tapez :

tree \

Pour afficher, écran par écran, les noms des fichiers contenus dans tous les répertoires du disque C, tapez :

tree c:\ /f | more

Pour imprimer la liste que la commande a permis d'afficher dans l'exemple précédent, tapez :

tree c:\ /f prn


Commandes de modification des services Terminal Server

Pour plus d'informations sur les commandes de modification des services Terminal Server, consultez les rubriques suivantes :

  • Commande change logon (changer l'ouverture de session)
  • Commande change port (changer le port)
  • Commande change user (changer l'utilisateur)


Commande change logon (changer l'ouverture de session)

Active ou désactive les ouvertures de session à partir des sessions clientes, ou affiche l'état de l'ouverture des sessions en cours. Cet utilitaire est utile à la gestion du système.

Syntaxe

change logon {/enable|/disable|/query}

Paramètres

/enable
Active les ouvertures de session à partir des sessions clientes, mais non depuis la console.
/disable
Désactive les prochaines ouvertures de session à partir des sessions clientes, mais non depuis la console. Les utilisateurs déjà connectés ne sont pas affectés.
/query
Affiche l'état (activé ou désactivé) de l'ouverture de session en cours.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Seuls les administrateurs peuvent utiliser la commande change logon.
  • Les ouvertures de session sont réactivées au redémarrage du système. Si vous êtes connecté au serveur Terminal Server à partir d'une session cliente et que vous mettez fin à la session avant d'avoir réactivé les ouvertures de session, vous ne pourrez plus vous reconnecter à partir de votre session. Connectez-vous à la console afin de réactiver les ouvertures de session à partir des sessions clientes.


Commande change port (changer le port)

Répertorie ou modifie les mappages du port COM pour maintenir la compatibilité avec les applications MS-DOS.

Syntaxe

change port [{portx=porty|/d portx|/query}]

Paramètres

portx=porty
Mappe le port COM x au port y.
/d portx
Supprime le mappage du port COM x.
/query
Affiche les mappages de port actuels.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • La plupart des applications MS-DOS ne prennent en charge que les ports séries COM1 à COM4. La commande change port mappe un port série vers un autre numéro de port, permettant ainsi aux applications qui ne gèrent pas un nombre important de ports COM d'accéder au port série. Par exemple, pour mapper le port COM12 au port COM1, afin de le rendre utilisable par une application MS-DOS, tapez change port com12=com1. La modification de mappage ne fonctionne que pour la session en cours et n'est pas conservée lorsque vous fermez une session pour en ouvrir une nouvelle.
  • Utilisez la commande change port sans paramètres pour afficher les ports COM disponibles et leurs mappages actuels.


Commande change user (changer l'utilisateur)

Modifie le paramétrage relatif au mappage du fichier .ini.

Syntaxe

change user {/execute | /install | /query}

Paramètres

/execute
Active le mappage du fichier .ini au répertoire de base. Il s'agit du paramètre par défaut.
/install
Désactive le mappage du fichier .ini au répertoire de base. Tous les fichiers .ini sont lus et enregistrés dans le répertoire système. Vous devez désactiver le mappage du fichier .ini lors de l'installation des applications sur un serveur Terminal Server.
/query
Affiche le paramétrage actuel relatif au mappage du fichier .ini.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisez la commande change user /install avant d'installer une application, pour créer des fichiers .ini pour cette application dans le répertoire système. Ces fichiers servent de sources pour les fichiers .ini spécifiques aux utilisateurs. Après avoir installé l'application, utilisez la commande change user /execute pour revenir au mappage du fichier .ini standard.
  • La première fois que vous exécutez l'application, celle-ci recherche ses fichiers .ini dans le répertoire de base. Si les fichiers .ini ne se trouvent pas dans le répertoire de base mais dans le répertoire système, ces fichiers sont copiés dans le répertoire de base par les services Terminal Server, garantissant ainsi que chaque utilisateur dispose d'une copie unique des fichiers .ini de l'application. Les nouveaux fichiers .ini sont créés dans le répertoire de base.
  • Chaque utilisateur doit disposer d'une copie unique des fichiers .ini d'une application. Cela permet d'éviter les situations où différents utilisateurs possèdent des configurations d'applications incompatibles, par exemple, des répertoires par défaut ou des résolutions d'écran qui ne sont pas les mêmes.
  • Lorsque le système est en mode Installation (change user /install), plusieurs événements se produisent : toutes les entrées du Registre créées sont masquées sous HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServer\Install. Les clés ajoutées à HKEY_CURRENT_USER sont copiées sous la clé \SOFTWARE, tandis que les clés HKEY_LOCAL_MACHINE sont copiées sous \MACHINE. Si l'application interroge le répertoire Windows en utilisant des appels système, comme GetWindowsDirectory, les services Terminal Server renvoient le répertoire RacineSystème. Si des entrées de fichier .ini sont ajoutées à l'aide d'appels système, comme WritePrivateProfileString, elles sont ajoutées aux fichiers .ini sous le répertoire RacineSystème.
  • Lorsque le système revient en mode d'exécution (change user /execute), et que l'application tente de lire une entrée du Registre sous HKEY_CURRENT_USER qui n'existe pas, les services Terminal Server vérifient si une copie de la clé existe sous la clé \TerminalServer\Install. Si c'est le cas, les clés sont copiées à l'emplacement approprié sous HKEY_CURRENT_USER. Si l'application tente de lire un fichier .ini qui n'existe pas, les services Terminal Server recherchent ce fichier .ini sous la racine système. Si le fichier .ini se trouve à la racine système, il est copié dans le sous-répertoire \Windows du répertoire de base de l'utilisateur. Si l'application interroge le répertoire Windows, les services Terminal Server renvoient le sous-répertoire \Windows du répertoire de base de l'utilisateur.
  • Lorsque vous ouvrez une session, les services Terminal Server vérifient si ses fichiers système .ini sont plus récents que les fichiers .ini qui se trouvent sur votre ordinateur. Si la version système est la plus récente, votre fichier .ini est soit remplacé soit fusionné avec cette version. Ceci dépend du fait que le bit INISYNC, 0x40, a été défini ou non pour ce fichier .ini. La version précédente de votre fichier .ini est renommée en Inifile.ctx. Si les valeurs du Registre du système sous la clé \TerminalServer\Install sont plus récentes que la version située sous HKEY_CURRENT_USER, alors votre version des clés est supprimée et remplacée par les nouvelles clés situées sous \TerminalServer\Install.


Cprofile

Procède à un nettoyage de l'espace perdu dans les profils et, lorsque des associations de fichiers spécifiques à l'utilisateur ont été désactivées, supprime ces associations du Registre. Les profils en cours d'utilisation ne sont pas modifiés.

Syntaxe

cprofile [/l] [/i] [/v] [ListeFichiers]

cprofile [/i] [/v] ListeFichiers

Paramètres

/l
Nettoie tous les profils locaux. Vous pouvez également spécifier une liste de profils supplémentaires dans le paramètre ListeFichiers.
/i
Interroge l'utilisateur de façon interactive sur chaque profil.
/v
Affiche des informations sur les actions en cours d'exécution.
ListeFichiers
Liste des fichiers parmi lesquels vous souhaitez supprimer certaines associations de fichiers spécifiques à l'utilisateur. Séparez chaque fichier de la liste par un espace. Les noms des fichiers peuvent contenir des caractères génériques.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Seuls les administrateurs peuvent exécuter cprofile.
  • Un serveur Terminal Server utilise les associations de fichiers pour déterminer les applications à utiliser pour accéder aux différents types de fichiers. Les types de fichiers sont enregistrés à l'aide de l'Explorateur Windows.
  • Les associations de fichiers au niveau utilisateur permettent à chaque utilisateur de posséder une application différente associée à un type de fichier spécifique. Par exemple, un premier utilisateur peut posséder des fichiers .doc associés à Microsoft Word et un second utilisateur des fichiers .doc associés à WordPad Windows.
  • Lorsque ce type d'association est activé, la commande cprofile permet de supprimer uniquement l'espace perdu du profil d'utilisateur. Lorsque ce type d'association est désactivé, la commande cprofile permet de supprimer également les entrées du Registre correspondantes.


Flattemp

Active ou désactive les dossiers temporaires communs.

Syntaxe

flattemp {/query | /enable | /disable}

Paramètres

/query
Interroge le paramètre en cours.
/enable
Active les dossiers temporaires communs.
/disable
Désactive les dossiers temporaires communs.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Lorsque chaque utilisateur possède un dossier temporaire unique, utilisez flattemp //enable pour activer les dossiers temporaires communs.
  • La méthode par défaut de création de dossiers temporaires pour plusieurs utilisateurs (dossiers vers lesquels pointent généralement les variables d'environnement TEMP et TMP) consiste à créer des sous-dossiers dans le dossier \Temp, en utilisant l'ID d'ouverture de session comme nom de sous-dossier. Par exemple, si la variable d'environnement TEMP pointe vers C:\Temp, le dossier temporaire affecté à l'ID d'ouverture de session 4 de l'utilisateur est C:\Temp\4. En utilisant la commande flattemp, vous pouvez pointer directement vers le dossier \Temp et empêcher la création de sous-dossiers. Ceci est particulièrement utile lorsque vous souhaitez que les dossiers temporaires des utilisateurs soient contenus dans des répertoires de base, sur un lecteur local de serveur Terminal Server ou sur un lecteur de partage réseau. N'utilisez cette commande que lorsque chaque utilisateur dispose d'un dossier temporaire séparé. Pour plus d'informations sur l'utilisation de dossiers temporaires par session, consultez Pour utiliser des dossiers temporaires séparés pour chaque session.
  • Vous devez disposer de privilèges d'administrateur pour exécuter la commande flattemp.
  • Des erreurs liées aux applications risquent de se produire si le répertoire temporaire de l'utilisateur se trouve sur un lecteur réseau. Cette situation peut se produire lorsque le partage réseau est momentanément inaccessible. Étant donné que les fichiers temporaires de l'application sont soit inaccessibles soit désynchronisés, le répertoire temporaire réagit comme si le disque s'était arrêté. Il est déconseillé de placer un répertoire temporaire sur un lecteur réseau. Par défaut, il est préférable de conserver les répertoires temporaires sur le disque dur local. Si vous observez, pour certaines applications, un comportement inattendu ou des erreurs liées à l'endommagement du disque, stabilisez votre réseau ou déplacez les répertoires temporaires vers le disque dur local.
  • Les paramètres de la commande flattemp sont ignorés si vous désactivez l'utilisation de dossiers temporaires séparés par session. Cette option est définie dans la configuration des services Terminal Server.


Logoff

Ferme la session d'un utilisateur, puis la supprime du serveur.

Syntaxe

logoff [{IDSession|NomSession}] [/server:NomServeur] [/v]

Paramètres

IDSession
Spécifie l'ID numérique qui identifie la session auprès du serveur.
NomSession
Spécifie le nom de la session.
/server:NomServeur
Indique le serveur Terminal Server qui contient la session utilisateur que vous souhaitez fermer. Si ce paramètre n'est pas spécifié, c'est le serveur auquel vous êtes actuellement connecté qui est utilisé.
/v
Affiche des informations sur les actions en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez toujours fermer la session à laquelle vous êtes actuellement connecté. Cependant, vous devez posséder l'autorisation Contrôle total pour fermer les sessions des autres utilisateurs.
  • La fermeture de la session d'un utilisateur sans avertissement peut entraîner la perte de données utilisées lors de cette session. Vous devez envoyer un message d'avertissement à l'utilisateur à l'aide de la commande msg avant d'entreprendre une telle action.
  • Si aucun identificateur ou nom de session n'est spécifié, l'utilisation de la commande logoff ferme la session en cours de l'utilisateur. Si vous indiquez le nom d'une session, celle-ci doit être active.
  • Lorsque vous fermez la session d'un utilisateur, tous les processus sont interrompus et la session est supprimée du serveur.
  • Vous ne pouvez pas fermer la session d'un utilisateur à partir d'une session ouverte depuis la console.

Exemples

Pour fermer la session d'un utilisateur à partir de la session en cours, tapez :

logoff

Pour fermer la session d'un utilisateur à l'aide de l'ID de session, par exemple la session 12, tapez :

logoff 12

Pour fermer la session d'un utilisateur à l'aide du nom de la session et du serveur, par exemple la session TERM04 sur le serveur WF12, tapez :

logoff TERM04 /server:WF12


Msg

Envoie un message à un utilisateur.

Syntaxe

msg {NomUtilisateur|NomSession|IDSession|@NomFichier|*} [/server:NomServeur] [/time:secondes] [/v] [/w] [message]

Paramètres

NomUtilisateur
Nom de l'utilisateur auquel vous souhaitez adresser le message.
NomSession
Nom de la session à laquelle vous souhaitez envoyer un message.
IDSession
Identificateur numérique de la session dont l'utilisateur doit recevoir un message.
@NomFichier
Identifie un fichier contenant la liste des noms d'utilisateurs, des noms de sessions et des ID de sessions auxquelles adresser un message.
*
Envoie le message à tous les noms d'utilisateurs sur le système.
/server:NomServeur
Indique le serveur Terminal Server dont la session ou l'utilisateur doit recevoir le message. Si vous n'indiquez pas de données, la commande, /server utilise le serveur auquel vous êtes actuellement connecté.
/time:secondes
Indique la durée pendant laquelle votre message reste affiché sur l'écran de l'utilisateur. Lorsque le délai est atteint, le message disparaît. Si aucune durée n'est définie, le message demeure sur l'écran de l'utilisateur jusqu'à ce que celui-ci clique sur OK, une fois sa lecture terminée.
/v
Affiche des informations sur les actions en cours d'exécution.
/w
Attend un accusé de réception de la part de l'utilisateur indiquant que le message a bien été reçu. Utilisez ce paramètre avec /time:secondes pour éviter l'apparition éventuelle de délais d'attente trop longs si l'utilisateur ne répond pas immédiatement. L'utilisation de ce paramètre avec l'option /v est également utile.
message
Texte du message que vous souhaitez envoyer. Si vous ne tapez pas de message, vous êtes invité à le faire, sinon une entrée standard (STDIN) est indiquée pour le message. Pour envoyer un message contenu dans un fichier, tapez le symbole supérieur à (>) suivi du nom du fichier.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si vous n'indiquez pas de nom d'utilisateur ou de session, la commande msg affiche un message d'erreur. Lorsque vous indiquez le nom d'une session, celle-ci doit être active.
  • L'utilisateur doit posséder une autorisation d'envoi de message pour pouvoir envoyer un message.

Exemples

Pour envoyer le message intitulé Rendez-vous aujourd'hui au musée à toutes les sessions de l'utilisateur JEAN, tapez :

msg JEAN Rendez-vous aujourd'hui au musée

Pour envoyer le même message à la session MODEM02, tapez :

msg modem02 Rendez-vous aujourd'hui au musée

Pour envoyer le message à la session 12, tapez :

msg 12 Rendez-vous aujourd'hui au musée

Pour envoyer le message à toutes les sessions contenues dans le fichier LISTUTIL, tapez :

msg @listutil Rendez-vous aujourd'hui au musée

Pour envoyer le message à tous les utilisateurs ayant ouvert une session, tapez :

msg * Rendez-vous aujourd'hui au musée

Pour envoyer le message à tous les utilisateurs, avec un délai d'accusé de réception de 10 secondes par exemple, tapez :

msg * /TIME:10 Rendez-vous aujourd'hui au musée


Mstsc

Permet de créer des connexions aux serveurs Terminal Server ou à d'autres ordinateurs distants, de modifier un fichier de configuration .rdp existant (Remote Desktop Connection, Connexion au Bureau à distance) et de migrer les connexions Windows XP (les connexions créées avec le Gestionnaire de connexion client) vers des fichiers .rdp.

Syntaxe

mstsc.exe {FichierConnexion|/v:serveur} [/console] [/f] [/w:largeur /h:hauteur]

mstsc.exe /edit"FichierConnexion"

mstsc.exe /migrate

Paramètres

FichierConnexion
Indique le nom d'un fichier .rdp pour la connexion.
/v:serveur
Spécifie l'ordinateur distant auquel se connecter.
/console
Établit la connexion à la session de la console du serveur Windows 2000 spécifié.
/f
Lance le module Connexion au Bureau à distance en plein écran.
/w:largeur /h:hauteur
Spécifie les dimensions de l'écran du module Connexion au Bureau à distance.
/edit
Ouvre le fichier .rdp spécifié en mode édition.
/migrate
Permet d'effectuer la migration des fichiers de connexion d'ancienne génération, créés par le Gestionnaire de connexion client, vers les nouveaux fichiers de connexion .rdp.

Remarques

  • Vous devez être administrateur sur le serveur auquel vous êtes connecté pour créer une connexion à une console à distance.
  • Les fichiers .rdp sont stockés pour chaque utilisateur en tant que fichiers cachés dans le répertoire Mes documents.


Commandes d'interrogation des services Terminal Server

Pour plus d'informations sur les commandes d'interrogation des services Terminal Server, consultez les rubriques suivantes :

  • Query process (Interroger le processus)
  • Query session (Interroger la session)
  • Query termserver (Interroger termserver)
  • Query user (Interroger l'utilisateur)


Query process (Interroger le processus)

Affiche des informations sur les processus en cours d'exécution sur un serveur Terminal Server. Vous pouvez utiliser cette commande pour connaître les programmes qu'un utilisateur en particulier exécute et savoir également quels sont les utilisateurs qui exécutent un programme déterminé.

Syntaxe

query process [{ *|IDProcessus|NomUtilisateur|NomSession|/id:nn|NomProgramme}] [/server:NomServeur] [/system]

Paramètres

*
Énumère les processus pour toutes les sessions.
IDProcessus
Spécifie l'ID numérique qui identifie le processus que vous souhaitez interroger.
NomUtilisateur
Spécifie le nom de l'utilisateur dont vous souhaitez énumérer les processus.
NomSession
Spécifie le nom de la session pour laquelle vous souhaitez énumérer les processus.
/id:nn
Spécifie l'ID de la session pour laquelle vous souhaitez énumérer les processus.
NomProgramme
Spécifie le nom du programme dont vous souhaitez interroger les processus. L'extension .exe est obligatoire.
/server:NomServeur
Indique le serveur Terminal Server dont vous souhaitez énumérer les processus. Si ce paramètre n'est pas spécifié, c'est le serveur auquel vous êtes actuellement connecté qui est utilisé.
/system
Indique que les informations courantes sur les processus système sont affichées. Si vous ne souhaitez pas que les processus système soient affichés, n'utilisez pas ce paramètre.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Les administrateurs disposent d'un accès total à l'ensemble des fonctions de la commande query process.
  • Si vous n'indiquez pas les paramètres NomUtilisateur, NomSession, /id::IDSession, NomProgramme ou *, la commande query process n'affiche que les processus appartenant à l'utilisateur en cours.
  • Si une session est indiquée, elle doit identifier une session active. Vous pouvez utiliser des caractères génériques pour identifier le processus.
  • Query process renvoie les informations suivantes :
    • Utilisateur propriétaire du processus
    • Session d'origine du processus
    • ID de la session
    • Nom du processus
    • État du processus
    • ID du processus
  • Lorsque la commande query process renvoie des informations, le symbole supérieur à (>) s'affiche devant chaque processus appartenant à la session en cours.


Query termserver (Interroger termserver)

Affiche la liste de tous les serveurs Terminal Server du réseau.

Syntaxe

query termserver [NomServeur] [/domain:Domaine] [/address] [/continue]

Paramètres

NomServeur
Spécifie le nom identifiant le serveur Terminal Server.
/domain:Domaine
Indique le domaine ou rechercher les serveurs Terminal Server. Vous n'avez pas besoin de spécifier un domaine si vous interrogez le domaine dans lequel vous travaillez actuellement.
/address
Affiche le réseau et les adresses de nœud de chaque serveur.
/continue
Empêche toute pause après l'affichage de chaque écran d'information.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • La commande Query termserver permet de parcourir le réseau pour rechercher les serveurs Terminal Server et renvoie les informations suivantes :
    • Nom du serveur.
    • Réseau (et adresse de nœud si l'option /address est utilisée).

Exemples

Pour afficher des informations sur tous les serveurs Terminal Server du réseau, tapez :

query termserver

Pour afficher des informations sur le serveur Terminal Server nommé serveur3, tapez :

query termserver serveur3

Pour afficher des informations sur tous les serveurs Terminal Server du domaine SYSTEM, tapez :

query termserver /domain:system

Pour afficher l'adresse de réseau et de nœud du serveur Terminal Server nommé serveur3, tapez :

query termserver serveur3 /address


Query session (Interroger la session)

Affiche des informations sur les sessions d'un serveur Terminal Server. Les informations énumérées concernent non seulement les sessions actives mais également les autres sessions exécutées par le serveur.

Syntaxe

query session [{NomSession|NomUtilisateur|IDSession}] [/server:NomServeur] [/mode] [/flow] [/connect] [/counter]

Paramètres

NomSession
Nom de la session à interroger.
NomUtilisateur
Nom de l'utilisateur dont vous souhaitez interroger les sessions.
IDSession
ID de la session à interroger.
/server:NomServeur
Identifie le serveur Terminal Server à interroger. Le paramètre par défaut est le serveur actuel.
/mode
Affiche les paramètres de la ligne en cours.
/flow
Affiche les paramètres de contrôle de flux en cours.
/connect
Affiche les paramètres de connexion en cours.
/counter
Affiche les informations en cours sur les compteurs, notamment le nombre total de sessions créées, déconnectées et reconnectées.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Un utilisateur peut toujours interroger la session à laquelle il est actuellement connecté. Pour interroger les autres sessions, l'utilisateur doit être autorisé à accéder à Query Information.
  • Si vous n'indiquez pas de session avec le paramètre NomSession, NomUtilisateur ou IDSession, la commande query session affiche des informations sur toutes les sessions actives dans le système.
  • Lorsque la commande query session renvoie des informations, le symbole supérieur à (>) s'affiche devant la session en cours.

Exemples

Pour afficher des informations sur toutes les sessions actives du serveur SERVEUR2, tapez :

query session /server:SERVEUR2

Pour afficher des informations sur la session active MODEM02, tapez :

query session MODEM02

Voici un exemple de résultat de la commande query session :

C:\>query session

 NOMSESSION    NOMUTILISATEUR  ID ÉTAT  TYPE  PÉRIPHÉRIQUE

>console       administrateur   0 active wdcon

 rdp-tcp#1      client1         1 active wdtshare

 rdp-tcp                        2 écoute wdtshare

                                4 inactive

                                5 inactive

Le symbole supérieur à (>) indique la session en cours. NOMSESSION indique le nom affecté à la session. NOMUTILISATEUR indique le nom de l'utilisateur connecté à la session. ÉTAT fournit des informations sur l'état de la session en cours. TYPE indique le type de la session. PÉRIPHÉRIQUE, qui n'est pas présent pour les sessions sur la console ou connectées au réseau, correspond au nom du périphérique attribué à la session. Le commentaire qui suit les informations de session provient du profil de la session.

Les sessions dont l'état initial est DISABLED (désactivé) ne s'affichent pas dans le résultat de la commande query session tant qu'elles ne sont pas activées.


Query user (Interroger l'utilisateur)

Affiche des informations sur des sessions utilisateur ouvertes sur un serveur Terminal Server.

Syntaxe

query user [{NomUtilisateur|NomSession|IDSession}] [/server:NomServeur]

Paramètres

NomUtilisateur
Indique le nom d'ouverture de session de l'utilisateur à interroger.
NomSession
Indique le nom de la session à interroger.
IDSession
Indique l'identificateur de la session à interroger.
/server:NomServeur
Indique le serveur Terminal Server à interroger. À défaut, c'est le serveur Terminal Server en cours qui est utilisé.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez utiliser cette commande pour savoir si un utilisateur en particulier est connecté à un serveur Terminal Server déterminé. La commande query user renvoie les informations suivantes :
    • Nom de l'utilisateur
    • Nom de la session ouverte sur le serveur Terminal Server
    • ID de la session
    • État de la session (active ou déconnectée)
    • Durée d'inactivité (nombre de minutes écoulées depuis qu'une touche a été frappée ou qu'un mouvement de souris a été enregistré pour la dernière fois au cours de la session)
    • Date et heure à laquelle l'utilisateur a ouvert la session
  • Pour utiliser la commande query user, vous devez posséder l'autorisation Contrôle total ou être autorisé à accéder à Query Information.
  • Si vous utilisez la commande query user sans indiquer de nom d'utilisateur, de nom de session ou d'ID de session, vous obtenez la liste de tous les utilisateurs ayant ouvert une session sur le serveur. Vous pouvez également utiliser query session pour afficher la liste de toutes les sessions ouvertes sur un serveur.
  • Lorsque la commande query user renvoie des informations, le symbole supérieur à (>) s'affiche devant la session en cours.
  • Le paramètre /server est obligatoire uniquement si vous exécutez la commande query user à partir d'un serveur distant.

Exemples

Pour afficher des informations sur tous les utilisateurs ayant ouvert une session sur le système, tapez :

query user

Pour afficher des informations sur l'utilisateur UTILISATEUR1 connecté au serveur SERVEUR1, tapez :

query user UTILISATEUR1 /server:SERVEUR1


Register

Enregistre un programme de telle sorte qu'il dispose de caractéristiques d'exécution particulières.

Syntaxe

register NomFichier [{/system|/user}] [/v]

Paramètres

NomFichier
Spécifie le nom du fichier que vous souhaitez enregistrer.
/system
Enregistre le fichier en tant que ressource système globale.
/user
Enregistre l'utilisateur en tant que ressource utilisateur globale.
/v
Affiche des informations supplémentaires.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Seuls les administrateurs peuvent utiliser la commande register.
  • Certaines applications et certains sous-systèmes complexes doivent s'exécuter dans un contexte système global pour établir les ressources communes à plusieurs ouvertures de session.
  • Les données d'enregistrement d'un programme sont reconnues uniquement lorsque le programme est installé. Si vous exécutez une commande register pour un programme déjà installé, les modifications prennent effet à la prochaine installation du programme.


Commande reset session (Réinitialiser la session)

Permet de réinitialiser (supprimer) une session à partir du serveur Terminal Server.

Syntaxe

reset session {NomSession|IDSession} [/server:NomServeur] [/v]

Paramètres

NomSession
Nom de la session à réinitialiser. Pour connaître le nom de la session, utilisez la commande query session.
IDSession
ID de la session à réinitialiser.
/server:NomServeur
Indique le serveur Terminal Server qui contient la session à réinitialiser. À défaut, c'est le serveur Terminal Server en cours qui est utilisé.
/v
Affiche des informations sur les actions en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez toujours réinitialiser vos propres sessions, mais vous devez posséder l'autorisation Contrôle total pour réinitialiser la session d'un autre utilisateur.
  • Sachez que la réinitialisation de la session d'un utilisateur sans avertissement peut entraîner la perte des données utilisées lors de la session.
  • Il est recommandé de réinitialiser une session uniquement lorsqu'elle présente un dysfonctionnement ou qu'elle ne répond plus.
  • Le paramètre /server est obligatoire uniquement si vous exécutez la commande reset session à partir d'un serveur distant.


Shadow

Permet de contrôler à distance la session active d'un autre utilisateur.

Syntaxe

shadow {NomSession | IDSession} [/server:NomServeur] [/v]

Paramètres

NomSession
Nom de la session à contrôler à distance.
IDSession
ID de la session à contrôler à distance. Utilisez la commande query user pour afficher la liste des sessions et les ID correspondants.
/server:NomServeur
Indique le serveur Terminal Server qui contient la session à contrôler à distance. À défaut, c'est le serveur Terminal Server en cours qui est utilisé.
/v
Affiche des informations sur les actions en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez afficher ou contrôler activement la session. Lorsque vous choisissez de contrôler activement la session d'un utilisateur, vous pouvez effectuer des actions dans cette session à partir du clavier et de la souris.
  • Vous pouvez toujours contrôler à distance vos propres sessions (à l'exception de la session en cours), mais vous devez disposer de l'autorisation Contrôle total pour contrôler une autre session à distance.
  • Vous pouvez également démarrer un contrôle à distance à l'aide du Gestionnaire de services Terminal Server. Pour plus d'informations, consultez Pour contrôler une session à distance.
  • Avant que la surveillance ne commence, le serveur informe l'utilisateur que la session va être contrôlée à distance, à moins que cette fonctionnalité soit désactivée. Votre session peut paraître figée pendant quelques secondes en attente de la réponse de l'utilisateur. Pour configurer le contrôle à distance des utilisateurs et des sessions, utilisez l'outil Configuration des services Terminal Server ou les extensions des services Terminal Server du composant Utilisateurs et groupes locaux ainsi que le composant Utilisateurs et ordinateurs Active Directory.
  • Au risque de faire échouer le contrôle à distance, votre session doit être en mesure de prendre en charge la résolution vidéo utilisée au niveau de la session contrôlée.
  • La session de console ne peut ni contrôler à distance une autre session, ni être contrôlée à distance par une autre session.
  • Lorsque vous souhaitez mettre fin au contrôle distant (Préséance), appuyez sur CTRL+* (en utilisant uniquement la touche * du pavé numérique), ou toute autre touche d'accès rapide que vous avez définie. La touche d'accès rapide se définit dans le Gestionnaire de services Terminal Server.

Exemples

Pour observer la session 93, tapez :

shadow 93

Pour observer la session ACCTG01, tapez :

shadow ACCTG01


Tscon

Permet la connexion à une autre session.

Syntaxe

tscon {IDSession | NomSession} [/dest:NomSession] [/password:pw] [/v]

Paramètres

IDSession
ID de la session à laquelle vous souhaitez vous connecter. Si vous utilisez le paramètre facultatif /dest::NomSession, vous devez spécifier l'ID de la session à laquelle vous souhaitez vous connecter.
NomSession
Nom de la session à laquelle vous souhaitez vous connecter.
/dest:NomSession
Indique le nom de la session en cours. Cette session est déconnectée lorsque vous vous connectez à la nouvelle session.
/password:MotDePasse
Mot de passe de l'utilisateur propriétaire de la session à laquelle vous souhaitez vous connecter. Ce mot de passe est obligatoire lorsque l'utilisateur qui se connecte n'est pas le propriétaire de la session.
/v
Affiche des informations sur les actions en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous devez posséder l'autorisation Contrôle total ou être autorisé à accéder à Connect pour vous connecter à une autre session.
  • Le paramètre /dest:NomSession permet de connecter la session d'un utilisateur à une autre session.
  • Si vous ne spécifiez pas de mot de passe pour le paramètre MotDePasse, et que la session cible appartient à un autre utilisateur que l'utilisateur en cours, la commande tscon échoue.
  • Vous ne pouvez pas vous connecter à la session de la console.

Exemples

Pour vous connecter à la session 12 sur le serveur Terminal Server en cours et vous déconnecter de la session en cours, tapez :

tscon 12

Pour vous connecter à la session 23 sur le serveur Terminal Server en cours, à l'aide du mot de passe « monmot », et vous déconnecter de la session en cours, tapez :

tscon 23 /password:monmot

Pour connecter la session nommée TERM03 à la session nommée TERM05, et pour déconnecter la session TERM05, si elle est encore connectée, tapez :

tscon TERM03 /v /dest:TERM05


Tsdiscon

Déconnecte une session d'un serveur Terminal Server.

Syntaxe

tsdiscon [{IDSession | NomSession}] [/server:NomServeur] [/v]

Paramètres

IDSession
ID de la session à déconnecter.
NomSession
Nom de la session à déconnecter.
/server:NomServeur
Indique le serveur Terminal Server qui contient la session à déconnecter. À défaut, c'est le serveur Terminal Server en cours qui est utilisé.
/v
Affiche des informations sur les actions en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous devez posséder l'autorisation Contrôle total pour déconnecter un autre utilisateur d'une session.
  • Si aucun identificateur de session ou nom de session n'est indiqué, la commande tsdiscon déconnecte la session en cours.
  • Les applications qui étaient en cours d'exécution lorsque vous vous êtes déconnecté de la session, s'exécutent à nouveau automatiquement lorsque vous vous reconnectez à la session, sans perte de données. Utilisez la commande reset session pour arrêter l'exécution des applications de la session déconnectée, mais sachez que cela peut entraîner la perte de certaines données au cours de la session.
  • Le paramètre /server est obligatoire uniquement si vous exécutez la commande tsdiscon à partir d'un serveur distant.
  • La session de la console ne peut pas être déconnectée.

Exemples

Pour déconnecter la session en cours, tapez :

tsdiscon

Pour déconnecter la session 10, tapez :

tsdiscon 10

Pour déconnecter la session nommée TERM04, tapez :

tsdiscon TERM04


Tskill

Met fin à un processus.

Syntaxe

tskill {IDProcessus | NomProcessus} [/server:NomServeur] [{/id:IDSession | /a}] [/v]

Paramètres

IDProcessus
ID du processus auquel mettre fin.
NomProcessus
Nom du processus auquel mettre fin. Vous pouvez utiliser des caractères génériques pour spécifier ce paramètre.
/server:NomServeur
Indique le serveur Terminal Server qui contient le processus auquel mettre fin. À défaut, c'est le serveur Terminal Server en cours qui est utilisé.
/id:IDSession
Met fin à l'exécution du processus dans la session spécifiée.
/a
Met fin à l'exécution du processus dans toutes les sessions.
/v
Affiche des informations sur les actions en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous pouvez utiliser la commande tskill uniquement pour mettre fin aux processus qui vous appartiennent, à moins que vous soyiez administrateur. Les administrateurs ont un accès total à toutes les fonctions tskill et peuvent mettre fin à l'exécution des processus d'autres sessions utilisateur.
  • Lorsque tous les processus s'exécutant au cours d'une session se terminent, la session se termine également.


Tsprof

Copie, d'un utilisateur à un autre, les informations de configuration utilisateur, qui sont affichées dans les extensions des services Terminal Server pour les Utilisateurs et groupes locaux et dans le composant Utilisateurs et ordinateurs Active Directory. La commande Tsprof permet également de définir le chemin d'accès au profil d'un utilisateur.

Syntaxe

tsprof /update {/domain:NomDomaine | /local} /profile:CheminProfil NomUtilisateur

tsprof /copy {/domain:NomDomaine | /local}[/profile:Chemin] UtilisateurSource UtilisateurDestination

tsprof /q {/domain:NomDomaine | /local} NomUtilisateur

Paramètres

NomUtilisateur
Spécifie le nom de l'utilisateur dont vous souhaitez mettre à jour ou interroger le chemin d'accès au profil sur le serveur.
UtilisateurSource
Spécifie le nom de l'utilisateur dont vous souhaitez copier les informations de configuration utilisateur.
UtilisateurDestination
Spécifie le nom de l'utilisateur pour lequel vous souhaitez copier les informations de configuration utilisateur.
/domain:NomDomaine
Spécifie le nom du domaine dans lequel l'opération est appliquée.
/local
Applique uniquement l'opération aux comptes d'utilisateurs locaux.
/profile:CheminProfil
Spécifie le chemin d'accès au profil tel qu'il est affiché dans les extensions des services Terminal Server pour les Utilisateurs et groupes locaux et le composant Utilisateurs et ordinateurs Active Directory.
/update
Met à jour les informations du chemin d'accès au profil de l'utilisateur NomUtilisateur du domaine NomDomaine vers le CheminProfil.
/copy
Copie les informations de configuration utilisateur à partir de l'UtilisateurSource vers l'UtilisateurDestination, et met à jour les informations du chemin d'accès au profil de l'UtilisateurDestination dans le CheminProfil. L'utilisateur source et l'utilisateur de destination doivent tous les deux être des utilisateurs locaux ou être situés dans le domaine NomDomaine.
/q
Affiche le chemin d'accès au profil en cours de l'utilisateur dont vous souhaitez interroger le chemin du profil sur le serveur.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Seuls les administrateurs peuvent exécuter la commande tsprof.


Tsshutdn

Permet à un administrateur de fermer ou de redémarrer à distance un serveur Terminal Server. Vous avez également la possibilité d'éteindre le serveur si l'ordinateur prend en charge le contrôle logiciel du courant alternatif.

Syntaxe

tsshutdn [TempsAttente] [/server:NomServeur] [/reboot] [/powerdown] [/delay:DélaiFermetureSession] [/v]

Paramètres

TempsAttente
Après avoir averti les utilisateurs, indique une durée (en secondes) d'attente avant de fermer les sessions de tous les utilisateurs. La valeur par défaut est 60 secondes.
/server:NomServeur
Indique le serveur Terminal Server à arrêter. Si ce paramètre n'est pas indiqué, c'est le serveur Terminal Server en cours qui est arrêté.
/reboot
Redémarre le serveur Terminal Server après la fermeture des sessions utilisateur.
/powerdown
Éteint le serveur Terminal Server si l'ordinateur prend en charge le contrôle logiciel du courant alternatif.
/delay:DélaiFermetureSession
Après avoir fermé les sessions de tous les utilisateurs, indique la durée d'attente (en secondes) avant la fermeture de tous les processus et l'arrêt du serveur Terminal Server. La valeur par défaut est 30 secondes.
/v
Affiche des informations sur les actions en cours d'exécution.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Vous devez disposer de privilèges d'administrateur pour exécuter la commande tsshutdn.
  • Il est déconseillé d'utiliser la commande Arrêter du menu Démarrer pour éteindre un serveur Terminal Server. Cette méthode met fin aux sessions des utilisateurs sans les avertir.
  • Toutes les sessions connectées reçoivent un avertissement indiquant qu'elles vont bientôt être fermées. Dans les sessions où des fichiers d'application sont ouverts, l'utilisateur est invité à enregistrer ces fichiers. Après le lancement de la commande de fermeture de session, tsshutdn attend une durée déterminée (par défaut, elle est de 30 secondes et est définie à l'aide de /delay), avant de mettre fin à tous les processus.
  • Tsshutdn ne redémarre pas le serveur Terminal Server, excepté si l'option /reboot est spécifiée.


Commandes des services Terminal Server

Pour plus d'informations sur une commande, cliquez dessus :

  • change logon
  • change port
  • change user
  • cprofile
  • flattemp
  • logoff
  • msg
  • mstsc
  • query process
  • query session
  • query termserver
  • query user
  • register
  • reset session
  • shadow
  • tscon
  • tsdiscon
  • tskill
  • tsprof
  • tsshutdn


Type

Affiche le contenu d'un fichier texte. Utilisez la commande type pour afficher le contenu d'un fichier texte sans le modifier.

Syntaxe

type [Lecteur:][Chemin] NomFichier

Paramètres

[Lecteur:][Chemin] NomFichier
Spécifie l'emplacement et le nom du ou des fichiers à afficher. Séparez les noms des fichiers par des espaces.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si vous utilisez un lecteur NTFS et que le paramètre NomFichier contient des espaces, encadrez le texte de guillemets (par exemple, "Nom Du Fichier").
  • Si vous affichez un fichier binaire ou un fichier créé par un programme, il se peut que des caractères inattendus, tels que des caractères de saut de page ou des symboles de séquence d'échappement, apparaissent à l'écran. Ces caractères représentent les codes de contrôle utilisés dans le fichier binaire. En règle générale, évitez d'utiliser la commande type pour afficher des fichiers binaires.

Exemples

Pour afficher le contenu du fichier nommé Vacances.mer, tapez :

type vacances.mer

Pour afficher, écran par écran, le contenu d'un fichier qui est long, tapez :

type vacances.mer | more


Unlodctr

Permet de supprimer du Registre système les noms et les chaînes d'explication des compteurs de performance pour un service ou un pilote de périphérique.

Syntaxe

Unlodctr [\\NomOrdinateur] NomPilote

Paramètres

[\\NomOrdinateur] NomPilote
Supprime les paramètres de nom des compteurs de performance et décrit un service ou un pilote de périphérique du Registre système Windows XP. Si vous ne spécifiez pas le paramètre NomOrdinateur, Windows XP utilise le nom de l'ordinateur local par défaut.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Si les informations que vous devez saisir contiennent des espaces, encadrez le texte de guillemets (par exemple, "Nom Ordinateur").

Exemples

Pour supprimer les paramètres courants du Registre relatifs aux performances et les chaînes d'explication du compteur pour le service RSVP sur l'ordinateur ordi1, tapez :

unlodctr \\ordi1 RSVP


Ver

Affiche le numéro de version de Windows XP.

Syntaxe

ver

Paramètres

/?
Affiche l'aide à l'invite de commandes.


Verify

XOX

Rubriques connexes


Vol

Affiche le nom de volume et le numéro de série d'un disque, s'ils existent. Le numéro de série est affiché pour les disques formatés sous MS-DOS version 4.0 ou ultérieure.

Syntaxe

vol [Lecteur:]

Paramètres

Lecteur:
Spécifie le lecteur qui contient le disque dont vous voulez afficher le nom de volume et le numéro de série.
/?
Affiche l'aide à l'invite de commandes.


Vssadmin

Affiche, dans la fenêtre d'invite de commandes, le volume courant des sauvegardes instantanées et de tous les enregistreurs et fournisseurs installés.

Syntaxe

Vssadmin list {snapshots [-set [GUIDJeuInstantanés]] | writers | providers}

Paramètres

list snapshots [-set [GUIDJeuInstantanés]]
Répertorie toutes les sauvegardes instantanées sur le système, regroupées par GUID (Globally Unique Identifier) pour le jeu d'instantanés (un groupe d'instantanés créés en même temps).
list writers
Répertorie le nom, le GUID, l'ID de l'instance et l'état de tous les enregistreurs d'instantanés installés.
list providers
Répertorie le nom, le type, le GUID et la version de tous les fournisseurs d'instantanés installés.
/?
Affiche l'aide à l'invite de commandes.

Exemples

Pour afficher tous les fournisseurs d'instantanés du volume qui sont installés, tapez la commande suivante :

vssadmin list providers


Winnt32

Effectue une installation ou une mise à niveau vers Windows XP. Vous pouvez exécuter la commande winnt32 à partir de l'invite de commandes sur un ordinateur qui exécute Windows 95, Windows 98, Windows Millennium Edition, Windows NT, Windows 2000 ou Windows XP.

Remarque

  • Si vous exécutez winnt32 sur un ordinateur équipé d'un processeur Itanium, la commande peut être exécutée à partir d'une Extensible Firmware Interface (EFI) ou de Windows XP (mais non à partir d'un système d'exploitation antérieur). Par ailleurs, sur un ordinateur équipé d'un processeur Itanium, les commandes /cmdcons et /syspart et les options relatives aux mises à niveau ne sont pas disponibles.

Syntaxe

winnt32 [/checkupgradeonly] [/cmd:LigneCommandes] [/cmdcons] [/copydir:{i386|ia64}\NomDossier] [/copysource:NomDossier] [/debug[Niveau]:[NomFichier]] [/disabledynamicupdates] [/dynamicupdatesshare:NomChemin] [/prepareinstallshare] [/m:NomDossier] [/makelocalsource] [/noreboot] [/s:CheminSource] [/syspart:LettreLecteur] [/tempdrive:LettreLecteur] [/udf:id [,FichierUDB]] [/unattend[Nombre]:[FichierRéponse]]

Paramètres

/checkupgradeonly
Contrôle votre ordinateur pour vérifier la compatibilité avec Windows XP en vue de sa mise à niveau.

Si vous utilisez cette option avec le paramètre /unattend, aucune entrée utilisateur n'est requise. Dans le cas contraire, les résultats sont affichés à l'écran et vous pouvez les enregistrer sous le nom de fichier que vous spécifiez. Le nom de fichier par défaut est Upgrade.txt dans le dossier systemroot.

/cmd:LigneCommandes
Demande au programme d'installation d'exécuter une commande spécifique avant la phase finale de l'installation. Cette exécution doit avoir lieu après le redémarrage de l'ordinateur et une fois que le programme d'installation a collecté les informations de configuration nécessaires, mais avant la fin de l'installation.
/cmdcons
Installe la console de récupération comme option de démarrage sur un ordinateur équipé d'un processeur x86. La console de récupération est une interface de ligne de commandes à partir de laquelle vous pouvez effectuer des tâches telles que le démarrage et l'arrêt des services ou l'accès au disque local (y compris les disques formatés avec NTFS). Vous pouvez utiliser l'option /cmdcons uniquement une fois que l'installation normale est terminée.
/copydir:{i386|ia64}\NomDossier
Crée un dossier supplémentaire à l'intérieur du dossier où les fichiers Windows XP sont installés. NomDossier désigne un dossier que vous avez créé en vue d'y placer les modifications relatives à votre site uniquement. Par exemple, pour les ordinateurs équipés d'un processeur x86, vous pouvez créer un dossier appelé Pilotes_privés dans le dossier source i386 de votre installation et y placer les fichiers des pilotes. Ensuite, vous pouvez taper /copydir:i386\Pilotes_privés pour que le programme d'installation copie ce dossier sur votre nouvel ordinateur et crée le chemin RacineSystème\Pilotes_privés. L'option /copydir permet de créer autant de dossiers supplémentaires que nécessaire.
/copysource:NomDossier
Crée un dossier supplémentaire temporaire à l'intérieur du dossier où les fichiers Windows XP sont installés. NomDossier désigne un dossier que vous avez créé en vue d'y placer les modifications relatives à votre site uniquement. Par exemple, vous pouvez créer un dossier appelé Pilotes_privés dans le dossier source de votre installation et y placer les fichiers des pilotes. Ensuite, vous pouvez taper /copydir:Pilotes_privés pour que le programme d'installation copie ce dossier sur votre nouvel ordinateur, qu'il utilise les fichiers que ce dossier contient pendant l'installation, et crée le dossier Pilotes_privés dans le dossier RacineSystème\. L'option /copysource permet de créer autant de dossiers supplémentaires que nécessaire. Contrairement aux dossiers créés par la commande /copydir, les dossiers créés au moyen de la commande /copysource sont supprimés une fois l'installation terminée.
/debug[Niveau]:[NomFichier]
Crée un journal de débogage au niveau spécifié, par exemple, /debug4:Debug.log. Le fichier du journal de débogage par défaut est C:\RacineSystème\Winnt32.log, et le niveau de débogage par défaut est fixé à 2. Les niveaux de débogage sont les suivants : Le niveau 0 est utilisé pour les erreurs graves, le niveau 1 pour les erreurs, le niveau 2 pour les avertissements, le niveau 3 pour les informations et enfin, le niveau 4 pour les informations détaillées relatives au débogage. Chaque niveau englobe les niveaux qui lui sont inférieurs.
/dudisable
Empêche l'exécution de la mise à jour dynamique. Sans la mise à jour dynamique, le programme d'installation n'est exécuté qu'à partir des fichiers d'installation d'origine. Cette option désactive la mise à jour dynamique même si vous utilisez un fichier de réponse et y spécifiez des options de mise à jour dynamique.
/duprepare:NomChemin
Prépare un partage d'installation afin qu'il puisse être utilisé avec les fichiers de mise à jour dynamique téléchargés à partir du site Web Windows Update. Ce partage peut ensuite être utilisé pour installer Windows XP sur plusieurs clients.
/dushare:NomChemin
Spécifie un partage sur lequel vous avez précédemment téléchargé des fichiers de mise à jour dynamique (fichiers mis à jour à utiliser avec le programme d'installation) à partir du site Web Windows Update, et sur lequel vous avez lancé /duprepare:nomchemin. Lorsqu'elle est exécutée sur un client, spécifie que l'installation cliente utilisera les fichiers mis à jour sur le partage spécifié dans NomChemin.
/m:NomDossier
Spécifie que le programme d'installation copie les fichiers de remplacement à partir d'un autre emplacement. Demande au programme d'installation de rechercher d'abord les fichiers dans l'autre emplacement et, si les fichiers s'y trouvent, de les utiliser à la place des fichiers de l'emplacement par défaut.
/makelocalsource
Demande au programme d'installation de copier tous les fichiers sources d'installation vers le disque dur local. Utilisez le paramètre /makelocalsource lors de l'installation à partir d'un CD-ROM pour que les fichiers d'installation soient accessibles si le CD-ROM n'est plus disponible à une phase ultérieure de l'installation.
/noreboot
Demande au programme d'installation de ne pas redémarrer l'ordinateur une fois les fichiers d'installation copiés afin de vous permettre d'exécuter une autre commande.
/s:CheminSource
Spécifie l'emplacement source des fichiers Windows XP. Pour copier simultanément des fichiers provenant de plusieurs serveurs, tapez l'option /s:CheminSource plusieurs fois (huit fois au maximum). Si vous tapez cette option plusieurs fois, le premier serveur spécifié doit être disponible car, si cela n'est pas le cas, l'installation échoue.
/syspart:LettreLecteur
Sur un ordinateur équipé d'un processeur x86, spécifie que vous pouvez copier les fichiers de démarrage du programme d'installation sur un disque dur, marquer ce disque comme étant actif, puis installer ce disque sur un autre ordinateur. Lorsque vous démarrez cet ordinateur, il démarre automatiquement par la phase suivante de l'installation. Veillez à toujours associer le paramètre /tempdrive au paramètre /syspart. Vous pouvez exécuter la commande Winnt32 avec l'option /syspart sur un ordinateur équipé d'un processeur x86 qui exécute Windows NT 4.0, Windows 2000 ou Windows XP. L'ordinateur sur lequel vous exécutez cette commande ne doit pas fonctionner sous Windows 95, Windows 98 ou Windows Millennium Edition.
/tempdrive:LettreLecteur
Indique au programme d'installation de placer les fichiers temporaires dans la partition spécifiée. S'il s'agit d'une nouvelle installation, Windows XP est également installé dans cette partition. S'il s'agit d'une mise à niveau, l'option /tempdrive affecte l'emplacement des fichiers temporaires uniquement ; le système d'exploitation est lui mis à niveau dans la partition à partir de laquelle vous avez exécuté la commande winnt32.
/udf:id [,FichierUDB]
Indique un identificateur (id) que le programme d'installation utilise pour spécifier la façon dont un fichier de base de données d'unicité (UDB, Uniqueness Database) modifie un fichier de réponse (consultez l'entrée /unattend). Le fichier UDB remplace les valeurs du fichier de réponse, et l'identificateur détermine quelles valeurs du fichier UDB sont utilisées. Par exemple, /udf:RAS_user,Notre_société.udb remplace des paramètres spécifiés pour l'identificateur RAS_user dans le fichier Notre_société.udb. Si aucun FichierUDB n'est spécifié, le programme d'installation invite l'utilisateur à insérer une disquette contenant le fichier $Unique$.udb.
/unattend
Met à niveau l'ancienne version de Windows 98, Windows Millennium Edition, Windows NT 4.0 ou Windows 2000 en mode sans assistance. Tous les paramètres utilisateur sont récupérés à partir de l'installation précédente et aucune intervention de l'utilisateur n'est donc requise pendant l'installation.
/unattend[Nombre]:[FichierRéponse]
Exécute une nouvelle installation en mode sans assistance. Le fichier réponse spécifié fournit au programme d'installation les spécifications personnalisées. Le paramètre Nombre correspond au nombre de secondes qui s'écoulent entre le moment où le programme d'installation finit de copier les fichiers et le moment où il redémarre votre ordinateur. Vous pouvez utiliser le paramètre Nombre sur n'importe quel ordinateur fonctionnant sous Windows 98, Windows Millennium Edition, Windows NT, Windows 2000 ou Windows XP.

Si vous utilisez l'option de ligne de commandes /unattend pour automatiser l'installation, vous serez amené à confirmer que vous avez lu et accepté les termes du contrat de licence Microsoft de Windows XP. Avant d'utiliser cette option de ligne de commandes pour installer Windows XP pour une société autre que la vôtre, vous devez confirmer que l'utilisateur final (particulier ou entité unique) a reçu, lu et accepté les termes du contrat de licence Microsoft de Windows XP. Les OEM ne sont pas autorisés à spécifier cette clé sur les ordinateurs vendus aux utilisateurs finals.


Winnt

Effectue une installation ou une mise à niveau vers Windows XP. Si vous disposez d'un matériel compatible avec Windows XP, vous pouvez exécuter la commande winnt à partir de l'invite de commandes de Windows 3.x ou de MS-DOS.

Syntaxe

winnt [/s:CheminSource] [/t:LecteurTemp] [/u:FichierRéponse][/udf:ID [,FichierUDB]] [/r:Dossier][/rx:Dossier][/e:Commande][/a]

Paramètres

/s:CheminSource
Spécifie l'emplacement source des fichiers Windows XP. Cet emplacement doit correspondre à un chemin d'accès complet sous la forme x:\[Chemin] ou \\serveur\partage[\Chemin].
/t:LecteurTemp
Indique au programme d'installation de placer les fichiers temporaires sur le lecteur spécifié et d'installer Windows XP sur ce lecteur. Si vous ne spécifiez aucun emplacement, le programme d'installation recherche un lecteur à votre place.
/u:FichierRéponse
Exécute une installation en mode sans assistance en utilisant un fichier de réponse. Le fichier de réponse répond à une partie ou à la totalité des questions qui sont normalement posées à l'utilisateur final au cours de l'installation. Si vous utilisez le paramètre /u, vous devez également utiliser le paramètre /s.
/udf:ID [,FichierUDB]
Indique un identificateur (ID) que le programme d'installation utilise pour spécifier la façon dont un fichier de base de données d'unicité (UDB, Uniqueness Database) modifie un fichier de réponse (voir /u). Le fichier UDB remplace les valeurs du fichier de réponse, et l'identificateur détermine quelles sont les valeurs du fichier UDB utilisées. Si aucun FichierUDB n'est spécifié, le programme d'installation vous invite à insérer une disquette contenant le fichier $Unique$.udb.
/r:Dossier
Spécifie un dossier facultatif à installer. Le dossier n'est pas supprimé après l'installation.
/rx:Dossier
Spécifie un dossier facultatif à copier. Le dossier est supprimé après l'installation.
/e:Commande
Spécifie la commande à exécuter avant la phase finale de l'installation.
/a
Active les options d'accessibilité.
/?
Affiche l'aide à l'invite de commandes.


Xcopy

Copie des fichiers et des répertoires, sous-répertoires compris.

Syntaxe

xcopy Source [Destination] [/w] [/p] [/c] [/v] [/q] [/f] [/l] [/g] [/d[:mm-jj-aaaa]] [/u] [/i] [/s [/e]] [/t] [/k] [/r] [/h] [{/a|/m}] [/n] [/o] [/x] [/exclude:Fichier1[+[Fichier2]][+[Fichier3]] [{/y|/-y}] [/z]

Paramètres

Source
Obligatoire. Spécifie l'emplacement et le nom des fichiers à copier. Ce paramètre doit obligatoirement inclure un lecteur ou un chemin d'accès.
Destination
Spécifie la destination des fichiers à copier. Ce paramètre peut inclure une lettre de lecteur et le signe deux-points (:), un nom de répertoire, un nom de fichier ou toute combinaison de ces éléments.
/w
Affiche le message suivant et attend une réponse avant de commencer à copier les fichiers :

Appuyez sur une touche pour lancer la copie des fichiers.

/p
Demande à l'utilisateur de confirmer la création de chaque fichier de destination.
/c
Ne tient pas compte des erreurs.
/v
Vérifie chaque fichier au fur et à mesure de son écriture dans le fichier de destination afin de garantir que les fichiers de destination sont identiques aux fichiers sources.
/q
Supprime l'affichage des messages de la commande xcopy .
/f
Affiche les noms des fichiers sources et de destination pendant la copie.
/l
Affiche la liste des fichiers à copier.
/g
Crée des fichiers de destination décryptés.
/d[:mm-jj-aaaa]
Copie uniquement les fichiers sources qui ont été modifiés à la date précisée ou après cette date. Si vous n'utilisez pas le paramètre mm-jj-aaaa, la commande xcopy copie tous les fichiers Source qui sont plus récents que les fichiers de Destination existants. Cette option de ligne de commandes permet de ne mettre à jour que les fichiers qui ont été modifiés.
/u
Copie uniquement les fichiers sources qui existent dans la destination.
/i
Si le paramètre Source correspond à un répertoire ou qu'il contient des caractères génériques et que le paramètre Destination n'est pas spécifié, la commande xcopy suppose que le nom du répertoire de destination est destination et un nouveau répertoire est donc créé. Tous les fichiers sont ensuite copiés dans ce nouveau répertoire. Par défaut, la commande xcopy demande à l'utilisateur si la destination est un fichier ou un répertoire.
/s
À moins qu'ils ne soient vides, copie les répertoires et les sous-répertoires. En l'absence de cette option de ligne de commandes, xcopy travaille dans un seul répertoire.
/e
Copie tous les sous-répertoires, même s'ils sont vides. Utilisez /e en combinaison avec les options de ligne de commandes /s et /t.
/t
Copie uniquement la structure (l'arborescence) du sous-répertoire et non les fichiers. Pour copier des répertoires vides, vous devez inclure l'option de ligne de commandes /e.
/k
Copie les fichiers et conserve l'attribut de lecture seule pour les fichiers de destination si les fichiers sources possèdent cet attribut. Par défaut, xcopy supprime l'attribut de lecture seule.
/r
Copie les fichiers avec un attribut de lecture seule.
/h
Copie les fichiers dotés des attributs fichier caché et fichier système. Par défaut, la commande xcopy ne copie pas les fichiers cachés ou les fichiers système.
/a
Copie uniquement les fichiers sources dotés de l'attribut archive. Cette option de ligne de commandes ne permet pas de modifier l'attribut archive du fichier source. Pour plus d'informations sur l'activation de cet attribut à l'aide de la commande attrib, consultez Rubriques connexes.
/m
Copie les fichiers sources dotés de l'attribut archive. Contrairement à l'option de ligne de commandes /a, l'option /m permet de désactiver l'attribut archive des fichiers spécifiés dans la source. Pour plus d'informations sur l'activation de cet attribut à l'aide de la commande attrib, consultez Rubriques connexes.
/n
Crée des copies en utilisant les noms de fichier ou de répertoire abrégés NTFS. Cette option de ligne de commandes est requise lors de la copie de fichiers ou de répertoires d'un volume NTFS vers un volume FAT ou lorsque que les conventions de noms de fichier du système de fichiers FAT (8.3) sont exigées sur le système de fichiers de destination. Le système de fichiers de destination peut être le système FAT ou NTFS.
/o
Copie les informations relatives à l'appartenance des fichiers et à la liste de contrôle d'accès discrétionnaire (DACL, Discretionary access control list)
/x
Copie les paramètres d'audit des fichiers et les informations relatives à la liste de contrôle d'accès du système (SACL, System access control list) (implique l'utilisation de l'option /o).
/exclude:NomFichier1[+[NomFichier2]][+[NomFichier3]]
Spécifie la liste des fichiers contenant des chaînes.
/y
Supprime la demande de confirmation de remplacement d'un fichier de destination existant.
/-y
Affiche la demande de confirmation de remplacement d'un fichier de destination existant.
/z
Permet la copie sur un réseau en mode redémarrage.
/?
Affiche l'aide à l'invite de commandes.

Remarques

  • Utilisation de l'option /v

    XOX

  • Utilisation de /exclude

    Présente chaque chaîne sur une ligne distincte dans chaque fichier. Si l'une quelconque des chaînes présentées correspond à une partie du chemin d'accès absolu du fichier à copier, ce fichier est alors exclus du processus de copie. Par exemple, si vous spécifiez la chaîne "\Obj\", vous excluez tous les fichiers qui figurent sous le répertoire Obj. Si vous spécifiez la chaîne ".obj", vous excluez tous les fichiers avec l'extension .obj.

  • Utilisation de /z

    Si la connexion est perdue pendant la phase de copie (notamment si le serveur qui est mis hors connexion entrave la connexion), l'exécution de la commande reprend dès que la connexion est rétablie. L'utilisation de cette option permet également d'afficher le pourcentage de copie réalisée pour chaque fichier.

  • Utilisation de l'option /y dans la variable d'environnement COPYCMD

    Vous pouvez utiliser l'option /y dans la variable d'environnement COPYCMD. Cette option peut être remplacée par /-y sur la ligne de commandes. Par défaut, l'utilisateur est invité à la remplacer, excepté s'il exécute la commande copy à partir d'un script de commandes.

  • Copie de fichiers cryptés

    La copie de fichiers cryptés sur un volume qui ne prend pas en charge les résultats au format EFS génère une erreur. Commencez par décrypter les fichiers ou par les copier sur un volume qui prend en charge le système EFS de fichiers cryptés.

  • Ajout de fichiers

    Pour ajouter des fichiers, spécifiez un fichier de destination unique et plusieurs fichiers sources (en utilisant des caractères génériques ou le format fichier1+fichier2+fichier3).

  • Valeur par défaut du paramètre Destination

    Si vous omettez le paramètre Destination, la commande xcopy copie les fichiers dans le répertoire en cours.

  • Comment indiquer si la destination est un fichier ou un répertoire

    Si le paramètre Destination ne fait référence à aucun répertoire existant et qu'il ne se termine pas par une barre oblique inverse (\), le message suivant s'affiche :

    Est-ce que [répertoire de destination] spécifie un nom de fichier
    ou un nom de répertoire de la destination
    (F = fichier, R = répertoire) ?

    Appuyez sur F si vous souhaitez que les fichiers soient copiés dans un fichier. Appuyez sur R si vous souhaitez que les fichiers soient copiés dans un répertoire.

    Vous pouvez supprimer l'affichage de ce message en utilisant l'option de ligne de commandes /i. La commande xcopy suppose alors que la destination est un répertoire si la source correspond à plusieurs fichiers ou à un répertoire.

  • Utilisation de la commande xcopy pour affecter l'attribut archive aux fichiers de destination

    La commande xcopy crée des fichiers avec l'attribut archive même si le fichier source ne possède pas cet attribut. Pour plus d'informations sur les attributs de fichier et sur attrib, consultez Rubriques connexes.

  • Comparaison des commandes xcopy et diskcopy

    Si un disque contient des fichiers stockés dans des sous-répertoires et que vous voulez copier le contenu de ce disque sur un disque de format différent, utilisez la commande xcopy au lieu de la commande diskcopy. Comme la commande diskcopy copie les disques piste par piste, les disques sources et de destination doivent être au même format. Cette obligation n'existe pas pour la commande xcopy. Utilisez plutôt xcopy à moins que vous ne souhaitiez avoir une copie complète de l'image d'un disque.

  • Codes de sortie pour la commande xcopy

    Pour traiter les codes de sortie renvoyés par la commande xcopy, utilisez le paramètre NiveauErreur dans la commande if dans un programme de commandes. Pour obtenir un exemple d'un programme de commandes qui traite les codes de sortie en utilisant la commande if, consultez Rubriques connexes. Le tableau suivant énumère chaque code de sortie accompagné d'une description.

    Code de sortie | Description
    0 | Les fichiers ont été copiés sans erreur.
    1 | Il n'existe pas de fichiers à copier.
    2 | L'utilisateur a appuyé sur CTRL+C pour arrêter l'exécution de la commande xcopy.
    4 | Une erreur d'initialisation s'est produite. La mémoire ou l'espace disque est insuffisant, ou vous avez entré un nom de lecteur ou une syntaxe non valide sur la ligne de commandes.
    5 | Une erreur d'écriture s'est produite sur le disque.

Exemples

Pour copier tous les fichiers et sous-répertoires (y compris tout sous-répertoire vide) du lecteur A vers le lecteur B, tapez :

xcopy a: b: /s /e

Dans l'exemple précédent, pour inclure tout fichier système ou tout fichier caché, ajoutez l'option de ligne de commandes /h :

xcopy a: b: /s /e /h

Pour mettre à jour les fichiers du répertoire \Rapports à partir des fichiers du répertoire \Données qui ont été modifiés depuis le 29 décembre 1993, tapez :

xcopy \données \rapports /d:29-12-1993

Dans l'exemple précédent, pour mettre à jour tous les fichiers du répertoire \Rapports quelle qu'en soit la date, tapez :

xcopy \données \rapports /u

Pour obtenir la liste des fichiers qui doivent être copiés par la commande ci-dessus, sans toutefois copier les fichiers, tapez :

xcopy \données \rapports /d:29-12-1993 /l > xcopy.out

Le fichier Xcopy.out contient la liste de tous les fichiers devant être copiés.

Pour copier le répertoire \Clients et tous ses sous-répertoires dans le répertoire \\Public\Adresses sur le lecteur H du réseau, conserver l'attribut de lecture seule et demander l'affichage d'une invite lorsqu'un nouveau fichier est créé sur le lecteur H:, tapez :

xcopy \client h:\public\adresse /s /e /k /p

Pour exécuter la commande précédente, assurez-vous que la commande xcopy crée le répertoire \Adresse s'il n'existe pas, supprimez l'affichage du message qui apparaît lors de la création d'un nouveau répertoire et ajoutez l'option de ligne de commandes \i de la façon suivante :

xcopy \client h:\public\adresse /s /e /k /p /i

Vous pouvez créer un programme de commandes assurant les opérations xcopy et utiliser la commande if dans ce programme afin de traiter le code de sortie en cas d'erreur. Le programme de commandes ci-dessous, par exemple, utilise des paramètres remplaçables pour la source et la destination de xcopy :

@echo off
rem COPYIT.BAT transfère tous les fichiers de tous les sous-répertoires
rem du lecteur ou du répertoire source (%1) au lecteur ou répertoire de destination

(%2)

xcopy %1 %2 /s /e

if errorlevel 4 goto lowmemory
if errorlevel 2 goto abort
if errorlevel 0 goto exit

:lowmemory
echo Mémoire insuffisante pour copier les fichiers ou
echo lecteur ou syntaxe de ligne de commandes non valide.
goto exit

:abort
echo Vous avez appuyé sur CTRL+C pour mettre fin à la copie.
goto exit

:exit

Pour utiliser ce programme de commandes afin de copier dans le lecteur B tous les fichiers du répertoire C:\PrgmCode et de ses sous-répertoires, tapez :

copyit c:\prgmcode b:

L'interpréteur de commandes substitue C:\Prgmcode à %1 et B: à %2, puis utilise xcopy avec les options de ligne de commandes /e et /s. Si xcopy rencontre une erreur, le programme de commandes lit le code de sortie et passe à l'étiquette indiquée dans l'instruction correspondante IF ERRORLEVEL, puis affiche le message approprié et le programme de commandes se ferme.